Bollettino sulla sicurezza Android: novembre 2017

Pubblicato il 6 novembre 2017 | Aggiornato l'8 novembre 2017

L'Android Security Bulletin contiene i dettagli delle vulnerabilità di sicurezza che interessano i dispositivi Android. I livelli di patch di sicurezza del 06-11-2017 o successivi risolvono tutti questi problemi. Per informazioni su come controllare il livello di patch di sicurezza di un dispositivo, consulta Controllare e aggiornare la versione di Android .

I partner Android sono stati informati di tutti i problemi relativi ai livelli di patch 2017-11-01 e 2017-11-05 almeno un mese prima della pubblicazione. I partner Android sono stati informati di tutti i problemi nel livello di patch 2017-11-06 nell'ultimo mese. Le patch del codice sorgente per questi problemi sono state rilasciate nel repository Android Open Source Project (AOSP) e collegate da questo bollettino. Questo bollettino include anche collegamenti a patch al di fuori di AOSP.

Il più grave di questi problemi è una vulnerabilità di sicurezza critica nel framework Media che potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato. La valutazione della gravità si basa sull'effetto che lo sfruttamento della vulnerabilità potrebbe avere su un dispositivo interessato, supponendo che la piattaforma e le attenuazioni del servizio siano disattivate per scopi di sviluppo o se bypassate correttamente.

Non abbiamo avuto segnalazioni di sfruttamento attivo da parte dei clienti o abuso di questi problemi appena segnalati. Fare riferimento alla sezione sulle attenuazioni di Android e Google Play Protect per i dettagli sulle protezioni della piattaforma di sicurezza Android e su Google Play Protect, che migliorano la sicurezza della piattaforma Android.

Nota: le informazioni sull'ultimo aggiornamento over-the-air (OTA) e le immagini del firmware per i dispositivi Google sono disponibili nel Bollettino sulla sicurezza Pixel/Nexus di novembre 2017 .

Annunci

  • Abbiamo lanciato un nuovo bollettino sulla sicurezza Pixel/Nexus , che contiene informazioni su ulteriori vulnerabilità di sicurezza e miglioramenti funzionali che vengono risolti sui dispositivi Pixel e Nexus supportati. I produttori di dispositivi Android possono scegliere di risolvere questi problemi sui propri dispositivi. Vedere Domande e risposte comuni per ulteriori informazioni.
  • Le patch di sicurezza per le vulnerabilità di KRACK sono fornite con il livello di patch di sicurezza 2017-11-06.

Mitigazioni dei servizi Android e Google

Questo è un riepilogo delle attenuazioni fornite dalla piattaforma di sicurezza Android e dalle protezioni del servizio come Google Play Protect . Queste funzionalità riducono la probabilità che le vulnerabilità della sicurezza possano essere sfruttate con successo su Android.

  • Lo sfruttamento per molti problemi su Android è reso più difficile dai miglioramenti nelle versioni più recenti della piattaforma Android. Incoraggiamo tutti gli utenti ad aggiornare all'ultima versione di Android, ove possibile.
  • Il team di sicurezza di Android monitora attivamente gli abusi tramite Google Play Protect e avvisa gli utenti in merito alle applicazioni potenzialmente dannose . Google Play Protect è abilitato per impostazione predefinita sui dispositivi con Google Mobile Services ed è particolarmente importante per gli utenti che installano app al di fuori di Google Play.

Livello patch di sicurezza 2017-11-01: dettagli sulla vulnerabilità

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2017-11-01. Le vulnerabilità sono raggruppate sotto la componente che interessano. Sono presenti una descrizione del problema e una tabella con il CVE, i riferimenti associati, il tipo di vulnerabilità , la gravità e le versioni AOSP aggiornate (ove applicabile). Quando disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID del bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, i riferimenti aggiuntivi sono collegati a numeri che seguono l'ID del bug.

Struttura

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di ignorare i requisiti di interazione dell'utente per ottenere l'accesso a autorizzazioni aggiuntive.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2017-0830 A-62623498 EoP Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0831 A-37442941 [ 2 ] EoP Alto 8.0

Quadro dei media

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2017-0832 A-62887820 RCE Critico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0833 A-62896384 RCE Critico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0834 A-63125953 RCE Critico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0835 A-63316832 RCE Critico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0836 A-64893226 RCE Critico 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0839 A-64478003 ID Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0840 A-62948670 ID Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0

Sistema

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2017-0841 A-37723026 RCE Critico 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0842 A-37502513 EoP Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0

Livello patch di sicurezza 2017-11-05: dettagli sulla vulnerabilità

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2017-11-05. Le vulnerabilità sono raggruppate in base al componente che interessano e includono dettagli come CVE, riferimenti associati, tipo di vulnerabilità , gravità , componente (ove applicabile) e versioni AOSP aggiornate (ove applicabile). Quando disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID del bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, i riferimenti aggiuntivi sono collegati a numeri che seguono l'ID del bug.

Componenti del kernel

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Componente
CVE-2017-9077 A-62265013
kernel a monte
EoP Alto Sottosistema di rete
CVE-2017-7541 A-64258073
kernel a monte
EoP Alto WLAN

componenti MediaTek

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Componente
CVE-2017-0843 A-62670819 *
M-ALPS03361488
EoP Alto CCCI

componenti NVIDIA

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Componente
CVE-2017-6264 A-34705430 *
N-CVE-2017-6264
EoP Alto Driver GPU

componenti Qualcomm

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Componente
CVE-2017-11013 A-64453535
QC-CR#2058261 [ 2 ]
RCE Critico WLAN
CVE-2017-11015 A-64438728
QC-CR#2060959 [ 2 ]
RCE Critico WLAN
CVE-2017-11014 A-64438727
QC-CR#2060959
RCE Critico WLAN
CVE-2017-11092 A-62949902 *
QC-CR#2077454
EoP Alto Driver GPU
CVE-2017-9690 A-36575870 *
QC-CR#2045285
EoP Alto Driver QBT1000
CVE-2017-11017 A-64453575
QC-CR#2055629
EoP Alto Avvio di Linux
CVE-2017-11028 A-64453533
QC-CR#2008683 [ 2 ]
ID Alto Telecamera

Livello patch di sicurezza 2017-11-06: dettagli sulla vulnerabilità

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2017-11-06. Le vulnerabilità sono raggruppate in base al componente che interessano e includono dettagli come CVE, riferimenti associati, tipo di vulnerabilità , gravità , componente (ove applicabile) e versioni AOSP aggiornate (ove applicabile). Quando disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID del bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, i riferimenti aggiuntivi sono collegati a numeri che seguono l'ID del bug.

Sistema

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato prossimo di ignorare i requisiti di interazione dell'utente prima di accedere a una rete Wi-Fi non protetta.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2017-13077 A-67737262 EoP Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13078 A-67737262 EoP Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13079 A-67737262 EoP Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13080 A-67737262 EoP Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13081 A-67737262 EoP Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13082 A-67737262 EoP Alto 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13086 A-67737262 EoP Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13087 A-67737262 EoP Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13088 A-67737262 EoP Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0

Nota : i partner Android potrebbero anche dover ottenere correzioni dai produttori di chipset, ove applicabile.

Domande e risposte comuni

Questa sezione risponde alle domande più comuni che possono verificarsi dopo la lettura di questo bollettino.

1. Come faccio a determinare se il mio dispositivo è aggiornato per risolvere questi problemi?

Per informazioni su come controllare il livello di patch di sicurezza di un dispositivo, consulta Verifica e aggiorna la versione di Android .

  • I livelli di patch di sicurezza del 01-11-2017 o successivi risolvono tutti i problemi associati al livello di patch di sicurezza del 01-11-2017.
  • I livelli di patch di sicurezza del 05-11-2017 o successivi risolvono tutti i problemi associati al livello di patch di sicurezza del 05-11-2017 e tutti i livelli di patch precedenti.
  • I livelli di patch di sicurezza del 06-11-2017 o successivi risolvono tutti i problemi associati al livello di patch di sicurezza del 06-11-2017 e tutti i livelli di patch precedenti.

I produttori di dispositivi che includono questi aggiornamenti devono impostare il livello della stringa di patch su:

  • [ro.build.version.security_patch]:[2017-11-01]
  • [ro.build.version.security_patch]:[2017-11-05]
  • [ro.build.version.security_patch]:[2017-11-06]

2. Perché questo bollettino ha tre livelli di patch di sicurezza?

Questo bollettino ha tre livelli di patch di sicurezza in modo che i partner Android abbiano la flessibilità di correggere più rapidamente un sottoinsieme di vulnerabilità simili su tutti i dispositivi Android. I partner Android sono invitati a risolvere tutti i problemi in questo bollettino e utilizzare il livello di patch di sicurezza più recente.

  • I dispositivi che utilizzano il livello di patch di sicurezza 2017-11-01 devono includere tutti i problemi associati a tale livello di patch di sicurezza, nonché le correzioni per tutti i problemi segnalati nei precedenti bollettini sulla sicurezza.
  • I dispositivi che utilizzano il livello di patch di sicurezza 2017-11-05 devono includere tutti i problemi associati a tale livello di patch di sicurezza, il livello di patch di sicurezza 2017-11-01, nonché le correzioni per tutti i problemi segnalati nei precedenti bollettini sulla sicurezza.
  • I dispositivi che utilizzano il livello di patch di sicurezza del 06-11-2017 o più recente devono includere tutte le patch applicabili in questo (e precedenti) bollettini sulla sicurezza.

I partner sono incoraggiati a raggruppare le correzioni per tutti i problemi che stanno affrontando in un unico aggiornamento.

3. Cosa significano le voci nella colonna Tipo ?

Le voci nella colonna Tipo della tabella dei dettagli della vulnerabilità fanno riferimento alla classificazione della vulnerabilità della sicurezza.

Abbreviazione Definizione
RCE Esecuzione di codice a distanza
EoP Elevazione del privilegio
ID Rivelazione di un 'informazione
DoS Negazione del servizio
N / A Classificazione non disponibile

4. Cosa significano le voci nella colonna Riferimenti ?

Le voci nella colonna Riferimenti della tabella dei dettagli della vulnerabilità possono contenere un prefisso che identifica l'organizzazione a cui appartiene il valore di riferimento.

Prefisso Riferimento
UN- ID bug Android
controllo qualità- Numero di riferimento Qualcomm
M- Numero di riferimento MediaTek
N- Numero di riferimento NVIDIA
B- Numero di riferimento Broadcom

5. Cosa significa un * accanto all'ID del bug Android nella colonna Riferimenti ?

I problemi che non sono disponibili pubblicamente hanno un * accanto all'ID del bug Android nella colonna Riferimenti . L'aggiornamento per quel problema è generalmente contenuto nei driver binari più recenti per i dispositivi Nexus disponibili sul sito Google Developer .

6. Perché le vulnerabilità della sicurezza sono suddivise tra questo bollettino e i bollettini sulla sicurezza del dispositivo/partner, come il bollettino Pixel/Nexus?

Le vulnerabilità di sicurezza documentate in questo bollettino sulla sicurezza sono necessarie per dichiarare il livello di patch di sicurezza più recente sui dispositivi Android. Per dichiarare un livello di patch di sicurezza non sono necessarie ulteriori vulnerabilità di sicurezza documentate nei bollettini sulla sicurezza del dispositivo/partner. I produttori di dispositivi Android e chipset sono incoraggiati a documentare la presenza di altre correzioni sui propri dispositivi tramite i propri siti Web di sicurezza, come i bollettini sulla sicurezza Samsung , LGE o Pixel/Nexus .

Versioni

Versione Data Appunti
1.0 6 novembre 2017 Bollettino pubblicato.
1.1 8 novembre 2017 Bollettino rivisto per includere i collegamenti AOSP.