O Google tem o compromisso de promover a igualdade racial para as comunidades negras. Saiba como.

Boletim de segurança do Android - junho de 2021

Publicado em 7 de junho de 2021 | Atualizado em 8 de junho de 2021

O Boletim de Segurança do Android contém detalhes das vulnerabilidades de segurança que afetam os dispositivos Android. Os níveis de patch de segurança de 2021-06-05 ou posteriores tratam de todos esses problemas. Para saber como verificar o nível de patch de segurança de um dispositivo, consulte verificar e atualizar sua versão Android .

Os parceiros Android são notificados de todos os problemas pelo menos um mês antes da publicação. Os patches do código-fonte para esses problemas foram lançados no repositório Android Open Source Project (AOSP) e vinculados a este boletim. Este boletim também inclui links para patches fora do AOSP.

O mais grave desses problemas é uma vulnerabilidade de segurança crítica no componente do sistema que pode permitir que um invasor remoto, usando uma transmissão especialmente criada, execute código arbitrário no contexto de um processo privilegiado. A avaliação da gravidade baseia-se no efeito que a exploração da vulnerabilidade, eventualmente, ter em um dispositivo afetado, assumindo a plataforma e serviços atenuações estão desligados para fins de desenvolvimento ou se ultrapassado com sucesso.

Anúncios

  • Para julho, o boletim de segurança pública do Android será lançado em 7 de julho de 2021

Consulte o Android e Google Play atenuações Protect seção para obter detalhes sobre as proteções de plataforma de segurança Android e Google Play Protect, que melhorar a segurança da plataforma Android.

Reduções de serviço do Android e do Google

Este é um resumo das atenuações fornecidas pelas plataformas de segurança do Android e de serviços proteções como o Google Play Protect . Esses recursos reduzem a probabilidade de as vulnerabilidades de segurança serem exploradas com êxito no Android.

  • A exploração de muitos problemas no Android é dificultada pelos aprimoramentos nas versões mais recentes da plataforma Android. Encorajamos todos os usuários a atualizar para a versão mais recente do Android sempre que possível.
  • A equipe de segurança Android monitora ativamente para o abuso por meio do Google Play Protect e avisa os usuários sobre aplicativos potencialmente prejudiciais . Google Play Protect está ativado por padrão em dispositivos com Google Mobile Serviços , e é especialmente importante para os usuários que instalar aplicativos de fora do Google Play.

Detalhes de vulnerabilidade de nível de patch de segurança 2021-06-01

Nas seções abaixo, fornecemos detalhes para cada uma das vulnerabilidades de segurança que se aplicam ao nível de patch 2021-06-01. As vulnerabilidades são agrupadas no componente que afetam. Problemas são descritos nas tabelas abaixo e incluem CVE ID, referências associadas, tipo de vulnerabilidade , gravidade , e versões AOSP atualizados (quando aplicável). Quando disponível, vinculamos a alteração pública que abordou o problema ao ID do bug, como a lista de alterações AOSP. Quando várias alterações estão relacionadas a um único bug, referências adicionais são vinculadas a números após a ID do bug. Dispositivos com Android 10 e posterior pode receber atualizações de segurança, bem como atualizações de sistema do Google Play .

Android runtime

A vulnerabilidade nesta seção pode permitir que um invasor local execute código arbitrário e ignore os requisitos de interação do usuário para obter acesso a permissões adicionais.

CVE Referências Modelo Gravidade Versões atualizadas de AOSP
CVE-2021-0511 A-178055795 [ 2 ] [ 3 ] EoP Alto 9, 10, 11

Estrutura

A vulnerabilidade nesta seção pode levar à divulgação de informações locais de permissões entre usuários sem a necessidade de privilégios de execução adicionais.

CVE Referências Modelo Gravidade Versões atualizadas de AOSP
CVE-2021-0521 A-174661955 EU IRIA Alto 8,1, 9, 10, 11

Media Framework

A vulnerabilidade mais grave nesta seção pode permitir que um aplicativo mal-intencionado local ignore os requisitos de interação do usuário para obter acesso a permissões adicionais.

CVE Referências Modelo Gravidade Versões atualizadas de AOSP
CVE-2021-0508 A-176444154 EoP Alto 8,1, 9, 10, 11
CVE-2021-0509 A-176444161 [ 2 ] EoP Alto 8,1, 9, 10, 11
CVE-2021-0510 A-176444622 EoP Alto 8,1, 9, 10, 11
CVE-2021-0520 A-176237595 EoP Alto 10, 11

Sistema

A vulnerabilidade mais grave nesta seção pode permitir que um invasor remoto, usando uma transmissão especialmente criada, execute código arbitrário no contexto de um processo privilegiado.

CVE Referências Modelo Gravidade Versões atualizadas de AOSP
CVE-2021-0507 A-181860042 RCE Crítico 8,1, 9, 10, 11
CVE-2021-0516 A-181660448 EoP Crítico 8,1, 9, 10, 11
CVE-2021-0505 A-179975048 EoP Alto 11
CVE-2021-0506 A-181962311 EoP Alto 8,1, 9, 10, 11
CVE-2021-0523 A-174047492 EoP Alto 10, 11
CVE-2021-0504 A-179162665 EU IRIA Alto 11
CVE-2021-0517 A-179053823 EU IRIA Alto 11
CVE-2021-0522 A-174182139 EU IRIA Alto 9, 10, 11

Atualizações do sistema do Google Play

Não há problemas de segurança abordados nas atualizações do sistema do Google Play (Project Mainline) neste mês.

Detalhes de vulnerabilidade de nível de patch de segurança 2021-06-05

Nas seções abaixo, fornecemos detalhes para cada uma das vulnerabilidades de segurança que se aplicam ao nível de patch 2021-06-05. As vulnerabilidades são agrupadas no componente que afetam. Problemas são descritos nas tabelas abaixo e incluem CVE ID, referências associadas, tipo de vulnerabilidade , gravidade , e versões AOSP atualizados (quando aplicável). Quando disponível, vinculamos a alteração pública que abordou o problema ao ID do bug, como a lista de alterações AOSP. Quando várias alterações estão relacionadas a um único bug, referências adicionais são vinculadas a números após a ID do bug.

Estrutura

A vulnerabilidade nesta seção pode permitir que um aplicativo mal-intencionado local ignore os requisitos de interação do usuário para obter acesso a permissões adicionais.

CVE Referências Modelo Gravidade Versões atualizadas de AOSP
CVE-2021-0513 A-156090809 EoP Alto 8,1, 9, 10, 11

Sistema

A vulnerabilidade mais grave nesta seção pode permitir que um invasor remoto usando uma transmissão especialmente criada para obter acesso a permissões adicionais.

CVE Referências Modelo Gravidade Versões atualizadas de AOSP
CVE-2020-26555 A-174626251 EoP Alto 8,1, 9, 10, 11
CVE-2020-26558 A-174886838 EoP Alto 8,1, 9, 10, 11
CVE-2021-0478 A-169255797 EoP Alto 8,1, 9, 10, 11

Componentes do kernel

A vulnerabilidade mais grave nesta seção pode levar ao aumento local de privilégios sem a necessidade de privilégios de execução adicionais.

CVE Referências Modelo Gravidade Componente
CVE-2020-14305 A-174904512
Kernel upstream
EoP Alto Voz sobre IP H.323
CVE-2021-0512 A-173843328
Kernel upstream
EoP Alto ESCONDIDO

Componentes MediaTek

Essas vulnerabilidades afetam os componentes do MediaTek e mais detalhes estão disponíveis diretamente no MediaTek. A avaliação da gravidade desses problemas é fornecida diretamente pela MediaTek.

CVE Referências Gravidade Componente
CVE-2021-0525 A-185193929
H-ALPS05403499 *
Alto driver de gerenciamento de memória
CVE-2021-0526 A-185195264
H-ALPS05403499 *
Alto driver de gerenciamento de memória
CVE-2021-0527 A-185193931
H-ALPS05403499 *
Alto driver de gerenciamento de memória
CVE-2021-0528 A-185195266
H-ALPS05403499 *
Alto driver de gerenciamento de memória
CVE-2021-0529 A-185195268
H-ALPS05403499 *
Alto driver de gerenciamento de memória
CVE-2021-0530 A-185196175
H-ALPS05403499 *
Alto driver de gerenciamento de memória
CVE-2021-0531 A-185195272
H-ALPS05403499 *
Alto driver de gerenciamento de memória
CVE-2021-0532 A-185196177
H-ALPS05403499 *
Alto driver de gerenciamento de memória
CVE-2021-0533 A-185193932
H-ALPS05403499 *
Alto driver de gerenciamento de memória

Componentes Qualcomm

Essa vulnerabilidade afeta os componentes da Qualcomm e é descrita em mais detalhes no boletim de segurança ou alerta de segurança da Qualcomm apropriado. A avaliação da gravidade desse problema é fornecida diretamente pela Qualcomm.

CVE Referências Gravidade Componente
CVE-2020-11267 A-168918351
QC-CR # 2723768 [ 2 ] [ 3 ]
Alto Segurança

Componentes de código fechado da Qualcomm

Essas vulnerabilidades afetam os componentes de código fechado da Qualcomm e são descritas em mais detalhes no boletim de segurança ou alerta de segurança da Qualcomm apropriado. A avaliação da gravidade desses problemas é fornecida diretamente pela Qualcomm.

CVE Referências Gravidade Componente
CVE-2020-11176 A-175038159 * Crítico Componente de código fechado
CVE-2020-11291 A-175038624 * Crítico Componente de código fechado
CVE-2020-26558 A-179039983 * Crítico Componente de código fechado
CVE-2020-11292 A-171309888 * Alto Componente de código fechado
CVE-2020-11298 A-175038385 * Alto Componente de código fechado
CVE-2020-11304 A-167567084 * Alto Componente de código fechado
CVE-2020-11306 A-175038981 * Alto Componente de código fechado
CVE-2020-26555 A-181682537 * Alto Componente de código fechado
CVE-2021-1900 A-181682536 * Alto Componente de código fechado
CVE-2021-1925 A-179040020 * Alto Componente de código fechado
CVE-2021-1937 A-181682513 * Alto Componente de código fechado

Perguntas e respostas comuns

Esta seção responde a perguntas comuns que podem ocorrer após a leitura deste boletim.

1. Como posso determinar se meu dispositivo está atualizado para resolver esses problemas?

Para saber como verificar o nível de patch de segurança de um dispositivo, consulte verificar e atualizar sua versão Android .

  • Os níveis do patch de segurança de 2021-06-01 ou posterior tratam de todos os problemas associados ao nível do patch de segurança 2021-06-01.
  • Os níveis de patch de segurança de 2021-06-05 ou posteriores tratam de todos os problemas associados ao nível de patch de segurança de 2021-06-05 e todos os níveis de patch anteriores.

Os fabricantes de dispositivos que incluem essas atualizações devem definir o nível da string de patch para:

  • [ro.build.version.security_patch]: [2021-06-01]
  • [ro.build.version.security_patch]: [2021-06-05]

Para alguns dispositivos com Android 10 ou posterior, a atualização do sistema Google Play terá uma string de data que corresponde ao nível do patch de segurança 2021-06-01. Por favor, veja este artigo para obter mais detalhes sobre como instalar atualizações de segurança.

2. Por que este boletim tem dois níveis de patch de segurança?

Este boletim tem dois níveis de patch de segurança para que os parceiros Android tenham a flexibilidade de corrigir um subconjunto de vulnerabilidades que são semelhantes em todos os dispositivos Android mais rapidamente. Os parceiros Android são incentivados a corrigir todos os problemas neste boletim e usar o nível de patch de segurança mais recente.

  • Os dispositivos que usam o nível de patch de segurança 2021-06-01 devem incluir todos os problemas associados a esse nível de patch de segurança, bem como correções para todos os problemas relatados em boletins de segurança anteriores.
  • Os dispositivos que usam o nível de patch de segurança de 2021-06-05 ou mais recente devem incluir todos os patches aplicáveis ​​neste (e nos anteriores) boletins de segurança.

Os parceiros são incentivados a agrupar as correções para todos os problemas que estão abordando em uma única atualização.

3. O que as entradas na média coluna Tipo?

As entradas na coluna Tipo da vulnerabilidade detalhes referência a tabela de classificação da vulnerabilidade de segurança.

Abreviação Definição
RCE Execução remota de código
EoP Elevação de privilégio
EU IRIA Divulgação de informação
DoS Negação de serviço
N / D Classificação não disponível

4. O que fazer as entradas na média coluna Referências?

Entradas sob a Referências coluna da tabela de detalhes da vulnerabilidade pode conter um prefixo que identifica o organismo ao qual o valor de referência pertence.

Prefixo Referência
UMA- ID de bug do Android
QC- Número de referência da Qualcomm
M- Número de referência da MediaTek
N- Número de referência NVIDIA
B- Número de referência Broadcom

5. O que faz um * ao lado do ID bug Android na média coluna Referências?

Os problemas que não estão publicamente disponíveis têm um * ao lado do ID de referência correspondente. A atualização para esse problema é geralmente contido nos últimos drivers binários para dispositivos Pixel disponíveis a partir do site do desenvolvedor Google .

6. Por que as vulnerabilidades de segurança estão divididas entre este boletim e os boletins de segurança do dispositivo / parceiro, como o boletim Pixel?

As vulnerabilidades de segurança documentadas neste boletim de segurança são necessárias para declarar o nível de patch de segurança mais recente em dispositivos Android. Vulnerabilidades de segurança adicionais documentadas nos boletins de segurança do dispositivo / parceiro não são necessárias para declarar um nível de patch de segurança. Dispositivos e chipsets fabricantes Android pode também publicar detalhes da vulnerabilidade de segurança específica para os seus produtos, como o Google , Huawei , LGE , Motorola , Nokia ou Samsung .

Versões

Versão Encontro Notas
1.0 7 de junho de 2021 Boletim publicado
1,1 8 de junho de 2021 Boletim revisado para incluir links AOSP