Sdk28ModuleController

public class Sdk28ModuleController
extends BaseModuleController

java.lang.Object
   ↳ com.android.tradefed.testtype.suite.module.BaseModuleController
     ↳ com.android.tradefed.testtype.suite.module.Sdk28ModuleController


A module controller to check if a device is on SDK 28 (Android 9) or above. This is used to workaround b/78780430, where on Android 8.1 armeabi-v7a devices, instrumentation will crash because the target package was pre-opted for only arm64.

Use by adding this line to your AndroidTest.xml:

Summary

Public constructors

Sdk28ModuleController()

Public methods

IModuleController.RunStrategy shouldRun(IInvocationContext context)

Method to decide if the module should run or not.

Public constructors

Sdk28ModuleController

public Sdk28ModuleController ()

Public methods

shouldRun

public IModuleController.RunStrategy shouldRun (IInvocationContext context)

Method to decide if the module should run or not.

Parameters
context IInvocationContext: the IInvocationContext of the module

Returns
IModuleController.RunStrategy True if the module should run, false otherwise.