Google is committed to advancing racial equity for Black communities. See how.
This page was translated by the Cloud Translation API.
Switch to English

Boletim de segurança do Android - julho de 2017

Publicado em 5 de julho de 2017 | Atualizado em 26 de setembro de 2017

O Boletim de Segurança do Android contém detalhes de vulnerabilidades de segurança que afetam dispositivos Android. Os níveis de patch de segurança de 5 de julho de 2017 ou posteriores tratam de todos esses problemas. Consulte a programação de atualização do Pixel e Nexus para saber como verificar o nível de patch de segurança de um dispositivo.

Os parceiros foram notificados dos problemas descritos no boletim há pelo menos um mês. Os patches do código-fonte para esses problemas foram lançados no repositório Android Open Source Project (AOSP) e vinculados a este boletim. Este boletim também inclui links para patches fora do AOSP.

O mais grave desses problemas é uma vulnerabilidade crítica de segurança na estrutura de mídia que pode permitir que um invasor remoto, usando um arquivo especialmente criado, execute código arbitrário no contexto de um processo privilegiado. A avaliação da gravidade é baseada no efeito que a exploração da vulnerabilidade possivelmente teria em um dispositivo afetado, supondo que as atenuações de plataforma e serviço sejam desligadas para fins de desenvolvimento ou se contornadas com sucesso.

Não recebemos relatórios de exploração ativa do cliente ou abuso desses problemas relatados recentemente. Consulte a seção de mitigações Android e Google Play Protect para obter detalhes sobre as proteções da plataforma de segurança Android e Google Play Protect, que melhoram a segurança da plataforma Android.

Incentivamos todos os clientes a aceitar essas atualizações em seus dispositivos.

Nota: As informações sobre as últimas atualizações over-the-air (OTA) e imagens de firmware para dispositivos Google estão disponíveis na seção de atualizações de dispositivos Google .

Anúncios

  • Este boletim possui duas strings de nível de patch de segurança para fornecer aos parceiros Android a flexibilidade de corrigir mais rapidamente um subconjunto de vulnerabilidades que são semelhantes em todos os dispositivos Android. Consulte Perguntas e respostas comuns para obter informações adicionais:
    • 01-07-2017 : string de nível de patch de segurança parcial. Esta string de nível de patch de segurança indica que todos os problemas associados a 2017-07-01 (e todas as strings de nível de patch de segurança anteriores) foram resolvidos.
    • 05/07/2017 : string de nível de patch de segurança completa Esta string de nível de patch de segurança indica que todos os problemas associados a 2017-07-01 e 2017-07-05 (e todas as strings de nível de patch de segurança anteriores) foram resolvidos.

Reduções do Android e Google Play Protect

Este é um resumo das atenuações fornecidas pela plataforma de segurança Android e proteções de serviço, como o Google Play Protect . Esses recursos reduzem a probabilidade de que as vulnerabilidades de segurança possam ser exploradas com êxito no Android.

  • A exploração de muitos problemas no Android é dificultada pelos aprimoramentos nas versões mais recentes da plataforma Android. Incentivamos todos os usuários a atualizar para a versão mais recente do Android sempre que possível.
  • A equipe de segurança do Android monitora ativamente o abuso por meio do Google Play Protect e avisa os usuários sobre aplicativos potencialmente nocivos . O Google Play Protect é ativado por padrão em dispositivos com Google Mobile Services e é especialmente importante para usuários que instalam aplicativos de fora do Google Play.

Nível do patch de segurança de 01/07/2017 - detalhes da vulnerabilidade

Nas seções abaixo, fornecemos detalhes para cada uma das vulnerabilidades de segurança que se aplicam ao nível de patch de 01-07-2017. As vulnerabilidades são agrupadas no componente que afetam. Há uma descrição do problema e uma tabela com o CVE, referências associadas, tipo de vulnerabilidade , gravidade e versões atualizadas do AOSP (quando aplicável). Quando disponível, vinculamos a alteração pública que abordou o problema ao ID do bug, como a lista de alterações AOSP. Quando várias alterações estão relacionadas a um único bug, referências adicionais são vinculadas a números após a ID do bug.

Tempo de execução

A vulnerabilidade mais grave nesta seção pode permitir que um invasor remoto usando um arquivo especialmente criado para executar código arbitrário dentro do contexto de um processo sem privilégios.

CVE Referências Tipo Gravidade Versões atualizadas de AOSP
CVE-2017-3544 A-35784677 RCE Moderado 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

Estrutura

A vulnerabilidade mais grave nesta seção pode permitir que um aplicativo mal-intencionado local, usando um arquivo especialmente criado, execute código arbitrário no contexto de um aplicativo que usa a biblioteca.

CVE Referências Tipo Gravidade Versões atualizadas de AOSP
CVE-2017-0664 A-36491278 EoP Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0665 A-36991414 EoP Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0666 A-37285689 EoP Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-06-07 A-37478824 EoP Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0668 A-22011579 EU IRIA Moderado 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2016.669 A-34114752 EU IRIA Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0670 A-36104177 DoS Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

Bibliotecas

A vulnerabilidade mais grave nesta seção pode permitir que um invasor remoto usando um arquivo especialmente criado execute código arbitrário no contexto de um aplicativo que usa a biblioteca.

CVE Referências Tipo Gravidade Versões atualizadas de AOSP
CVE-2017-0671 A-34514762 * RCE Alto 4.4.4
CVE-2016-2109 A-35443725 DoS Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0672 A-34778578 DoS Alto 7.0, 7.1.1, 7.1.2

Estrutura de mídia

A vulnerabilidade mais grave nesta seção pode permitir que um invasor remoto usando um arquivo especialmente criado para executar código arbitrário no contexto de um processo privilegiado.

CVE Referências Tipo Gravidade Versões atualizadas de AOSP
CVE-2017-0540 A-33966031 RCE Crítico 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0673 A-33974623 RCE Crítico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0674 A-34231163 RCE Crítico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0675 A-34779227 [ 2 ] RCE Crítico 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0676 A-34896431 RCE Crítico 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0677 A-36035074 RCE Crítico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0678 A-36576151 RCE Crítico 7.0, 7.1.1, 7.1.2
CVE-2017-0679 A-36996978 RCE Crítico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0680 A-37008096 RCE Crítico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2016.681 A-37208566 RCE Crítico 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2016.682 A-36588422 * RCE Alto 7.0, 7.1.1, 7.1.2
CVE-2016.683 A-36591008 * RCE Alto 7.0, 7.1.1, 7.1.2
CVE-2017-0684 A-35421151 EoP Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2016.685 A-34203195 DoS Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-08-06 A-34231231 DoS Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2016.688 A-35584425 DoS Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2016.689 A-36215950 DoS Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0690 A-36592202 DoS Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0691 A-36724453 DoS Alto 7.0, 7.1.1, 7.1.2
CVE-2016.692 A-36725407 DoS Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2016.693 A-36993291 DoS Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2016.694 A-37093318 DoS Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0695 A-37094889 DoS Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2016.696 A-37207120 DoS Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2016.07 A-37239013 DoS Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0698 A-35467458 EU IRIA Moderado 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0699 A-36490809 EU IRIA Moderado 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

IU do sistema

A vulnerabilidade mais grave nesta seção pode permitir que um invasor remoto usando um arquivo especialmente criado para executar código arbitrário no contexto de um processo privilegiado.

CVE Referências Tipo Gravidade Versões atualizadas de AOSP
CVE-2017-0700 A-35639138 RCE Alto 7.1.1, 7.1.2
CVE-2017-0701 A-36385715 [ 2 ] RCE Alto 7.1.1, 7.1.2
CVE-2017-0702 A-36621442 RCE Alto 7.1.1, 7.1.2
CVE-2017-0703 A-33123882 EoP Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0704 A-33059280 EoP Moderado 7.1.1, 7.1.2

Nível do patch de segurança 05/07/2017 - detalhes da vulnerabilidade

Nas seções abaixo, fornecemos detalhes para cada uma das vulnerabilidades de segurança que se aplicam ao nível de patch 2017-07-05. As vulnerabilidades são agrupadas no componente que afetam e incluem detalhes como o CVE, referências associadas, tipo de vulnerabilidade , gravidade , componente (quando aplicável) e versões atualizadas do AOSP (quando aplicável). Quando disponível, vinculamos a alteração pública que abordou o problema ao ID do bug, como a lista de alterações AOSP. Quando várias alterações estão relacionadas a um único bug, referências adicionais são vinculadas a números após a ID do bug.

Componentes Broadcom

A vulnerabilidade mais grave nesta seção pode permitir que um invasor próximo execute código arbitrário no contexto do kernel.

CVE Referências Tipo Gravidade Componente
CVE-2017-9417 A-38041027 *
B-RB # 123023
RCE Crítico Driver de Wi-Fi
CVE-2017-0705 A-34973477 *
B-RB # 119898
EoP Moderado Driver de Wi-Fi
CVE-2017-0706 A-35195787 *
B-RB # 120532
EoP Moderado Driver de Wi-Fi

Componentes HTC

A vulnerabilidade mais grave nesta seção pode permitir que um aplicativo mal-intencionado local execute código arbitrário dentro do contexto de um processo privilegiado.

CVE Referências Tipo Gravidade Componente
CVE-2017-0707 A-36088467 * EoP Moderado Driver de LED
CVE-2017-0708 A-35384879 * EU IRIA Moderado Driver de som
CVE-2017-0709 A-35468048 * EU IRIA Baixo Driver do hub do sensor

Componentes do kernel

A vulnerabilidade mais grave nesta seção pode permitir que um aplicativo mal-intencionado local execute código arbitrário dentro do contexto de um processo privilegiado.

CVE Referências Tipo Gravidade Componente
CVE-2017-6074 A-35784697
Kernel upstream
EoP Alto Subsistema de rede
CVE-2017-5970 A-35805460
Kernel upstream
DoS Alto Subsistema de rede
CVE-2015-5707 A-35841297
Kernel upstream [ 2 ]
EoP Moderado Driver SCSI
CVE-2017-7308 A-36725304
Kernel upstream [ 2 ] [ 3 ]
EoP Moderado Motorista de rede
CVE-2014-9731 A-35841292
Kernel upstream
EU IRIA Moderado Sistema de arquivo

Componentes MediaTek

A vulnerabilidade mais grave nesta seção pode permitir que um aplicativo mal-intencionado local execute código arbitrário dentro do contexto de um processo privilegiado.

CVE Referências Tipo Gravidade Componente
CVE-2017-0711 A-36099953 *
M-ALPS03206781
EoP Alto Motorista de rede

Componentes NVIDIA

A vulnerabilidade mais grave nesta seção pode permitir que um aplicativo mal-intencionado local execute código arbitrário dentro do contexto de um processo privilegiado.

CVE Referências Tipo Gravidade Componente
CVE-2017-0340 A-33968204 *
N-CVE-2017-0340
EoP Alto Libnvparser
CVE-2017-0326 A-33718700 *
N-CVE-2017-0326
EU IRIA Moderado Driver de vídeo

Componentes Qualcomm

A vulnerabilidade mais grave nesta seção pode permitir que um aplicativo mal-intencionado local execute código arbitrário dentro do contexto do kernel.

CVE Referências Tipo Gravidade Componente
CVE-2017-8255 A-36251983
QC-CR # 985205
EoP Alto Bootloader
CVE-2016-10389 A-34500449
QC-CR # 1009145
EoP Alto Bootloader
CVE-2017-8253 A-35400552
QC-CR # 1086764
EoP Alto Motorista da câmera
CVE-2017-8262 A-32938443
QC-CR # 2029113
EoP Alto Driver GPU
CVE-2017-8263 A-34126808 *
QC-CR # 1107034
EoP Alto Subsistema de memória compartilhada anônima
CVE-2017-8267 A-34173755 *
QC-CR # 2001129
EoP Alto Subsistema de memória compartilhada anônima
CVE-2017-8273 A-35400056
QC-CR # 1094372 [ 2 ]
EoP Alto Bootloader
CVE-2016-5863 A-36251182
QC-CR # 1102936
EoP Moderado Driver USB HID
CVE-2017-8243 A-34112490 *
QC-CR # 2001803
EoP Moderado Motorista SoC
CVE-2017-8246 A-37275839
QC-CR # 2008031
EoP Moderado Driver de som
CVE-2017-8256 A-37286701
QC-CR # 1104565
EoP Moderado Driver de Wi-Fi
CVE-2017-8257 A-37282763
QC-CR # 2003129
EoP Moderado Driver de vídeo
CVE-2017-8259 A-34359487
QC-CR # 2009016
EoP Moderado Motorista SoC
CVE-2017-8260 A-34624155
QC-CR # 2008469
EoP Moderado Motorista da câmera
CVE-2017-8261 A-35139833 *
QC-CR # 2013631
EoP Moderado Motorista da câmera
CVE-2017-8264 A-33299365 *
QC-CR # 1107702
EoP Moderado Motorista da câmera
CVE-2017-8265 A-32341313
QC-CR # 1109755
EoP Moderado Driver de vídeo
CVE-2017-8266 A-33863407
QC-CR # 1110924
EoP Moderado Driver de vídeo
CVE-2017-8268 A-34620535 *
QC-CR # 2002207
EoP Moderado Motorista da câmera
CVE-2017-8270 A-35468665 *
QC-CR # 2021363
EoP Moderado Driver de Wi-Fi
CVE-2017-8271 A-35950388 *
QC-CR # 2028681
EoP Moderado Driver de vídeo
CVE-2017-8272 A-35950805 *
QC-CR # 2028702
EoP Moderado Driver de vídeo
CVE-2017-8254 A-36252027
QC-CR # 832914
EU IRIA Moderado Driver de som
CVE-2017-8258 A-37279737
QC-CR # 2005647
EU IRIA Moderado Motorista da câmera
CVE-2017-8269 A-33967002 *
QC-CR # 2013145
EU IRIA Moderado Driver IPA

Componentes de código fechado da Qualcomm

Essas vulnerabilidades afetam os componentes da Qualcomm e são descritas com mais detalhes nos boletins de segurança AMSS da Qualcomm em 2014-2016. Eles estão incluídos neste boletim de segurança do Android para associar suas correções a um nível de patch de segurança do Android. As correções para essas vulnerabilidades estão disponíveis diretamente na Qualcomm.

CVE Referências Tipo Gravidade Componente
CVE-2014-9411 A-37473054 * N / D Alto Componente de código fechado
CVE-2014-9968 A-37304413 * N / D Alto Componente de código fechado
CVE-2014-9973 A-37470982 * N / D Alto Componente de código fechado
CVE-2014-9974 A-37471979 * N / D Alto Componente de código fechado
CVE-2014-9975 A-37471230 * N / D Alto Componente de código fechado
CVE-2014-9977 A-37471087 * N / D Alto Componente de código fechado
CVE-2014-9978 A-37468982 * N / D Alto Componente de código fechado
CVE-2014-9979 A-37471088 * N / D Alto Componente de código fechado
CVE-2014-9980 A-37471029 * N / D Alto Componente de código fechado
CVE-2015-0575 A-37296999 * N / D Alto Componente de código fechado
CVE-2015-8592 A-37470090 * N / D Alto Componente de código fechado
CVE-2015-8595 A-37472411 * N / D Alto Componente de código fechado
CVE-2015-8596 A-37472806 * N / D Alto Componente de código fechado
CVE-2015-9034 A-37305706 * N / D Alto Componente de código fechado
CVE-2015-9035 A-37303626 * N / D Alto Componente de código fechado
CVE-2015-9036 A-37303519 * N / D Alto Componente de código fechado
CVE-2015-9037 A-37304366 * N / D Alto Componente de código fechado
CVE-2015-9038 A-37303027 * N / D Alto Componente de código fechado
CVE-2015-9039 A-37302628 * N / D Alto Componente de código fechado
CVE-2015-9040 A-37303625 * N / D Alto Componente de código fechado
CVE-2015-9041 A-37303518 * N / D Alto Componente de código fechado
CVE-2015-9042 A-37301248 * N / D Alto Componente de código fechado
CVE-2015-9043 A-37305954 * N / D Alto Componente de código fechado
CVE-2015-9044 A-37303520 * N / D Alto Componente de código fechado
CVE-2015-9045 A-37302136 * N / D Alto Componente de código fechado
CVE-2015-9046 A-37301486 * N / D Alto Componente de código fechado
CVE-2015-9047 A-37304367 * N / D Alto Componente de código fechado
CVE-2015-9048 A-37305707 * N / D Alto Componente de código fechado
CVE-2015-9049 A-37301488 * N / D Alto Componente de código fechado
CVE-2015-9050 A-37302137 * N / D Alto Componente de código fechado
CVE-2015-9051 A-37300737 * N / D Alto Componente de código fechado
CVE-2015-9052 A-37304217 * N / D Alto Componente de código fechado
CVE-2015-9053 A-37301249 * N / D Alto Componente de código fechado
CVE-2015-9054 A-37303177 * N / D Alto Componente de código fechado
CVE-2015-9055 A-37472412 * N / D Alto Componente de código fechado
CVE-2015-9060 A-37472807 * N / D Alto Componente de código fechado
CVE-2015-9061 A-37470436 * N / D Alto Componente de código fechado
CVE-2015-9062 A-37472808 * N / D Alto Componente de código fechado
CVE-2015-9067 A-37474000 * N / D Alto Componente de código fechado
CVE-2015-9068 A-37470144 * N / D Alto Componente de código fechado
CVE-2015-9069 A-37470777 * N / D Alto Componente de código fechado
CVE-2015-9070 A-37474001 * N / D Alto Componente de código fechado
CVE-2015-9071 A-37471819 * N / D Alto Componente de código fechado
CVE-2015-9072 A-37474002 * N / D Alto Componente de código fechado
CVE-2015-9073 A-37473407 * N / D Alto Componente de código fechado
CVE-2016-10343 A-32580186 * N / D Alto Componente de código fechado
CVE-2016-10344 A-32583954 * N / D Alto Componente de código fechado
CVE-2016-10346 A-37473408 * N / D Alto Componente de código fechado
CVE-2016-10347 A-37471089 * N / D Alto Componente de código fechado
CVE-2016-10382 A-28823584 * N / D Alto Componente de código fechado
CVE-2016-10383 A-28822389 * N / D Alto Componente de código fechado
CVE-2016-10388 A-32580294 * N / D Alto Componente de código fechado
CVE-2016-10391 A-32583804 * N / D Alto Componente de código fechado
CVE-2016-5871 A-37473055 * N / D Alto Componente de código fechado
CVE-2016-5872 A-37472809 * N / D Alto Componente de código fechado

Atualizações de dispositivos do Google

Esta tabela contém o nível do patch de segurança na última atualização over-the-air (OTA) e imagens de firmware para dispositivos Google. As imagens de firmware do dispositivo Google estão disponíveis no site Google Developer .

Dispositivo Google Nível do patch de segurança
Pixel / Pixel XL 05 de julho de 2017
Nexus 5X 05 de julho de 2017
Nexus 6 5 de julho de 2017
Nexus 6P 5 de julho de 2017
Nexus 9 05 de julho de 2017
Nexus Player 05 de julho de 2017
Pixel C 05 de julho de 2017

As atualizações de dispositivos do Google também contêm patches para essas vulnerabilidades de segurança, se aplicável:

CVE Referências Tipo Gravidade Componente
CVE-2017-0710 A-34951864 * EoP Moderado TCB

Reconhecimentos

Gostaríamos de agradecer a esses pesquisadores por suas contribuições:

CVEs Pesquisadores
CVE-2017-8263 Billy Lau do Google
CVE-2017-0711 Chengming Yang, Baozeng Ding e Yang Song do Alibaba Mobile Security Group
CVE-2017-0681 Chi Zhang , Hanxiang Wen , Mingjian Zhou ( @Mingjian_Zhou ) e Xuxian Jiang da equipe C0RE
CVE-2017-0706 Daxing Guo ( @ freener0 ) do Laboratório Xuanwu, Tencent
CVE-2017-8260 Derrek ( @ derrekr6 ) e Scott Bauer
CVE-2017-8265 Di Shen ( @returnsme ) de KeenLab ( @keen_lab ), Tencent
CVE-2017-0703 Dzmitry Lukyanenka
CVE-2016.692, CVE-2016.694 Elphet e Gong Guang da equipe Alpha, Qihoo 360 Technology Co. Ltd.
CVE-2017-8266, CVE-2017-8243, CVE-2017-8270 Gengjia Chen ( @ chengjia4574 ) e pjf do IceSword Lab, Qihoo 360 Technology Co. Ltd.
CVE-2017-0665 Chi Zhang , Hanxiang Wen , Mingjian Zhou ( @Mingjian_Zhou ) e Xuxian Jiang da equipe C0RE
CVE-2017-8268, CVE-2017-8261 Jianqiang Zhao ( @jianqiangzhao ) e pjf do IceSword Lab, Qihoo 360
CVE-2017-0698 Joey Brand da Census Consulting Inc.
CVE-2017-0666, CVE-2017-0684 Mingjian Zhou ( @Mingjian_Zhou ), Chi Zhang e Xuxian Jiang da equipe C0RE
CVE-2017-0670, CVE-2017-0670 Niky1235 ( @jiych_guru )
CVE-2017-9417 Nitay Artenstein da Exodus Intelligence
CVE-2017-0705, CVE-2017-8259 Scott Bauer
CVE-2017-06-07 Timothy Becker da CSS Inc.
CVE-2017-0682, CVE-2017-0676, CVE-2017-0676, CVE-2017-0675, CVE-2017-0701, CVE-2017-0702, CVE-2017-0699 Vasily Vasiliev
CVE-2017-0695, CVE-2017-0689, CVE-2017-0540, CVE-2017-0680, CVE-2017-0679, CVE-2017-0685, CVE-2016.686, CVE-2017-0693, CVE- 2017-0674, CVE-2017-0677 VEO ( @VYSEa ) da Equipe de Resposta a Ameaças Móveis , Trend Micro
CVE-2017-0708 Xiling Gong do Departamento de Plataforma de Segurança da Tencent
CVE-2017-0690 Yangkang ( @dnpushme ) e Liyadong da equipe Qihoo 360 Qex
CVE-2017-8269, CVE-2017-8271, CVE-2017-8272, CVE-2017-8267 Yonggang Guo ( @guoygang ) do IceSword Lab, Qihoo 360 Technology Co. Ltd.
CVE-2017-8264, CVE-2017-0326, CVE-2017-0709 Yuan-Tsung Lo ( computernik@gmail.com ) e Xuxian Jiang da equipe C0RE
CVE-2017-0704, CVE-2017-0669 Yuxiang Li ( @ Xbalien29 ) do Departamento de Plataforma de Segurança da Tencent
CVE-2017-0710 Zach Riggle ( @ ebeip90 ) da equipe de segurança do Android
CVE-2017-0678 Zinuo Han do Centro de Resposta de Segurança de Chengdu, Qihoo 360 Technology Co. Ltd.
CVE-2017-0691, CVE-2017-0700 Zinuo Han do Centro de Resposta de Segurança de Chengdu, Qihoo 360 Technology Co. Ltd. e Ao Wang ( @ArayzSegment ) da Equipe Pangu

Perguntas e respostas comuns

Esta seção responde a perguntas comuns que podem ocorrer após a leitura deste boletim.

1. Como posso determinar se meu dispositivo está atualizado para resolver esses problemas?

Para saber como verificar o nível de patch de segurança de um dispositivo, leia as instruções na programação de atualização do Pixel e Nexus .

  • Os níveis do patch de segurança de 01-07-2017 ou posterior tratam de todos os problemas associados ao nível do patch de segurança 2017/07/01.
  • Os níveis do patch de segurança de 05-07-2017 ou posterior tratam de todos os problemas associados ao nível do patch de segurança 2017/07/05 e todos os níveis de patch anteriores.

Os fabricantes de dispositivos que incluem essas atualizações devem definir o nível da string de patch para:

  • [ro.build.version.security_patch]: [2017-07-01]
  • [ro.build.version.security_patch]: [2017-07-05]

2. Por que este boletim tem dois níveis de patch de segurança?

Este boletim tem dois níveis de patch de segurança para que os parceiros do Android tenham a flexibilidade de corrigir um subconjunto de vulnerabilidades que são semelhantes em todos os dispositivos Android mais rapidamente. Os parceiros Android são encorajados a corrigir todos os problemas neste boletim e usar o nível de patch de segurança mais recente.

  • Os dispositivos que usam o nível de patch de segurança de 01 de julho de 2017 devem incluir todos os problemas associados a esse nível de patch de segurança, bem como correções para todos os problemas relatados em boletins de segurança anteriores.
  • Os dispositivos que usam o nível de patch de segurança de 5 de julho de 2017 ou mais recente devem incluir todos os patches aplicáveis ​​neste (e nos anteriores) boletins de segurança.

Os parceiros são incentivados a agrupar as correções para todos os problemas que estão abordando em uma única atualização.

3. O que significam as entradas na coluna Tipo ?

As entradas na coluna Tipo da tabela de detalhes da vulnerabilidade fazem referência à classificação da vulnerabilidade de segurança.

Abreviação Definição
RCE Execução remota de código
EoP Elevação de privilégio
EU IRIA Divulgação de informação
DoS Negação de serviço
N / D Classificação não disponível

4. O que significam as entradas na coluna Referências ?

As entradas na coluna Referências da tabela de detalhes da vulnerabilidade podem conter um prefixo que identifica a organização à qual o valor de referência pertence.

Prefixo Referência
UMA- ID de bug do Android
QC- Número de referência da Qualcomm
M- Número de referência da MediaTek
N- Número de referência NVIDIA
B- Número de referência Broadcom

5. O que significa um * ao lado do ID do bug do Android na coluna Referências ?

Os problemas que não estão publicamente disponíveis têm um * próximo ao ID do bug do Android na coluna Referências . A atualização para esse problema geralmente está contida nos drivers binários mais recentes para dispositivos Nexus disponíveis no site Google Developer .

Versões

Versão Encontro Notas
1.0 5 de julho de 2017 Boletim publicado.
1,1 6 de julho de 2017 Boletim revisado para incluir links AOSP.
1,2 11 de julho de 2017 Boletim revisado para atualizar os agradecimentos.
1,3 17 de agosto de 2017 Boletim revisado para atualizar os números de referência.
1,4 19 de setembro de 2017 Agradecimentos atualizados para CVE-2017-0710.
1,5 26 de setembro de 2017 Agradecimentos atualizados para CVE-2017-0681.