Google is committed to advancing racial equity for Black communities. See how.
This page was translated by the Cloud Translation API.
Switch to English

Boletim de segurança do Android - dezembro de 2017

Publicado em 4 de dezembro de 2017 | Atualizado em 6 de dezembro de 2017

O Boletim de Segurança do Android contém detalhes de vulnerabilidades de segurança que afetam dispositivos Android. Os níveis do patch de segurança de 05-12-2017 ou posteriores tratam de todos esses problemas. Para saber como verificar o nível de patch de segurança de um dispositivo, consulte Verificar e atualizar sua versão do Android .

Os parceiros Android são notificados de todos os problemas pelo menos um mês antes da publicação. Os patches do código-fonte para esses problemas foram lançados no repositório Android Open Source Project (AOSP) e vinculados a este boletim. Este boletim também inclui links para patches fora do AOSP.

O mais grave desses problemas é uma vulnerabilidade crítica de segurança na estrutura de mídia que pode permitir que um invasor remoto usando um arquivo especialmente criado para executar código arbitrário no contexto de um processo privilegiado. A avaliação da gravidade é baseada no efeito que a exploração da vulnerabilidade possivelmente teria em um dispositivo afetado, supondo que as atenuações de plataforma e serviço sejam desativadas para fins de desenvolvimento ou se forem contornadas com êxito.

Não recebemos relatórios de exploração ativa do cliente ou abuso desses problemas relatados recentemente. Consulte a seção de mitigações Android e Google Play Protect para obter detalhes sobre as proteções da plataforma de segurança Android e Google Play Protect, que melhoram a segurança da plataforma Android.

Observação: as informações sobre as últimas atualizações over-the-air (OTA) e imagens de firmware para dispositivos do Google estão disponíveis no Boletim de segurança Pixel / Nexus de dezembro de 2017 .

Reduções de serviços Android e Google

Este é um resumo das atenuações fornecidas pela plataforma de segurança Android e proteções de serviço, como o Google Play Protect . Esses recursos reduzem a probabilidade de que as vulnerabilidades de segurança possam ser exploradas com êxito no Android.

  • A exploração de muitos problemas no Android é dificultada pelos aprimoramentos nas versões mais recentes da plataforma Android. Incentivamos todos os usuários a atualizar para a versão mais recente do Android sempre que possível.
  • A equipe de segurança do Android monitora ativamente o abuso por meio do Google Play Protect e avisa os usuários sobre aplicativos potencialmente nocivos . O Google Play Protect é habilitado por padrão em dispositivos com Google Mobile Services e é especialmente importante para usuários que instalam aplicativos de fora do Google Play.

Nível do patch de segurança de 01-12-2017 - detalhes de vulnerabilidade

Nas seções abaixo, fornecemos detalhes para cada uma das vulnerabilidades de segurança que se aplicam ao nível de patch 2017-12-01. As vulnerabilidades são agrupadas no componente que afetam. Há uma descrição do problema e uma tabela com o CVE, referências associadas, tipo de vulnerabilidade , gravidade e versões atualizadas do AOSP (quando aplicável). Quando disponível, vinculamos a alteração pública que abordou o problema ao ID do bug, como a lista de alterações AOSP. Quando várias alterações estão relacionadas a um único bug, referências adicionais são vinculadas a números após a ID do bug.

Estrutura

A vulnerabilidade mais grave nesta seção pode permitir que um aplicativo malicioso local ignore os requisitos de interação do usuário para obter acesso a permissões adicionais.

CVE Referências Tipo Gravidade Versões atualizadas de AOSP
CVE-2017-0807 A-35056974 * EoP Alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0870 A-62134807 EoP Alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0871 A-65281159 EoP Alto 8,0

Estrutura de mídia

A vulnerabilidade mais grave nesta seção pode permitir que um invasor remoto usando um arquivo especialmente criado para executar código arbitrário no contexto de um processo privilegiado.

CVE Referências Tipo Gravidade Versões atualizadas de AOSP
CVE-2017-0872 A-65290323 RCE Crítico 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0876 A-64964675 * RCE Crítico 6,0
CVE-2017-0877 A-66372937 * RCE Crítico 6,0
CVE-2017-0878 A-65186291 RCE Crítico 8,0
CVE-2017-13151 A-63874456 RCE Crítico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13153 A-65280854 EoP Alto 8,0
CVE-2017-0837 A-64340921 [ 2 ] EoP Alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0873 A-63316255 DoS Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0874 A-63315932 DoS Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0880 A-65646012 [ 2 ] DoS Alto 7.0, 7.1.1, 7.1.2
CVE-2017-13148 A-65717533 DoS Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0

Sistema

A vulnerabilidade mais grave nesta seção pode permitir que um invasor próximo execute código arbitrário dentro do contexto de um processo privilegiado.

CVE Referências Tipo Gravidade Versões atualizadas de AOSP
CVE-2017-13160 A-37160362 RCE Crítico 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13156 A-64211847 EoP Alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13157 A-32990341 EU IRIA Alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13158 A-32879915 EU IRIA Alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13159 A-32879772 EU IRIA Alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0

Nível do patch de segurança 05-12-2017 - detalhes da vulnerabilidade

Nas seções abaixo, fornecemos detalhes para cada uma das vulnerabilidades de segurança que se aplicam ao nível de patch 2017-12-05. As vulnerabilidades são agrupadas no componente que afetam e incluem detalhes como o CVE, referências associadas, tipo de vulnerabilidade , gravidade , componente (quando aplicável) e versões atualizadas do AOSP (quando aplicável). Quando disponível, vinculamos a alteração pública que abordou o problema ao ID do bug, como a lista de alterações AOSP. Quando várias alterações estão relacionadas a um único bug, referências adicionais são vinculadas a números após a ID do bug.

Componentes do kernel

A vulnerabilidade mais grave nesta seção pode permitir que um aplicativo mal-intencionado local execute código arbitrário dentro do contexto de um processo privilegiado.

CVE Referências Tipo Gravidade Componente
CVE-2017-13162 A-64216036 * EoP Alto Encadernador
CVE-2017-0564 A-34276203 * EoP Alto ÍON
CVE-2017-7533 A-63689921
Kernel upstream
EoP Alto Manipulação de arquivos
CVE-2017-13174 A-63100473 * EoP Alto EDL

Componentes MediaTek

A vulnerabilidade mais grave nesta seção pode permitir que um aplicativo mal-intencionado local execute código arbitrário dentro do contexto de um processo privilegiado.

CVE Referências Tipo Gravidade Componente
CVE-2017-13170 A-36102397 *
M-ALPS03359280
EoP Alto Driver de vídeo
CVE-2017-13171 A-64316572 *
M-ALPS03479086
EoP Alto Serviço de desempenho
CVE-2017-13173 A-28067350 *
M-ALPS02672361
EoP Alto Servidor de sistema

Componentes NVIDIA

A vulnerabilidade mais grave nesta seção pode permitir que um aplicativo mal-intencionado local execute código arbitrário dentro do contexto de um processo privilegiado.

CVE Referências Tipo Gravidade Componente
CVE-2017-6262 A-38045794 *
N-CVE-2017-6262
EoP Alto Driver NVIDIA
CVE-2017-6263 A-38046353 *
N-CVE-2017-6263
EoP Alto Driver NVIDIA
CVE-2017-6276 A-63802421 *
N-CVE-2017-6276
EoP Alto Servidor de mídia

Componentes Qualcomm

A vulnerabilidade mais grave nesta seção pode permitir que um invasor remoto usando um arquivo especialmente criado para executar código arbitrário dentro do contexto de um processo privilegiado.

CVE Referências Tipo Gravidade Componente
CVE-2017-11043 A-64728953
QC-CR # 2067820
RCE Crítico WLAN
CVE-2016-3706 A-34499281
QC-CR # 1058691 [ 2 ]
RCE Crítico UDP RPC
CVE-2016-4429 A-68946906
QC-CR # 1058691 [ 2 ]
RCE Crítico UDP RPC
CVE-2017-11007 A-66913719
QC-CR # 2068824
EoP Alto Fastboot
CVE-2017-14904 A-63662821 *
QC-CR # 2109325
EoP Alto Gralloc
CVE-2017-9716 A-63868627
QC-CR # 2006695
EoP Alto Driver Qbt1000
CVE-2017-14897 A-65468973
QC-CR # 2054091
EoP Alto Driver RPMB
CVE-2017-14902 A-65468970
QC-CR # 2061287
EoP Alto MProc
CVE-2017-14895 A-65468977
QC-CR # 2009308
EoP Alto WLAN

Componentes de código fechado da Qualcomm

Essas vulnerabilidades afetam os componentes da Qualcomm e são descritas em mais detalhes no boletim de segurança ou alerta de segurança Qualcomm AMSS apropriado. A avaliação da gravidade desses problemas é fornecida diretamente pela Qualcomm.

CVE Referências Tipo Gravidade Componente
CVE-2017-6211 A-36217326 * N / D Crítico Componente de código fechado
CVE-2017-14908 A-62212840 * N / D Alto Componente de código fechado
CVE-2017-14909 A-62212839 * N / D Alto Componente de código fechado
CVE-2017-14914 A-62212297 * N / D Alto Componente de código fechado
CVE-2017-14916 A-62212841 * N / D Alto Componente de código fechado
CVE-2017-14917 A-62212740 * N / D Alto Componente de código fechado
CVE-2017-14918 A-65946406 * N / D Alto Componente de código fechado
CVE-2017-11005 A-66913715 * N / D Alto Componente de código fechado
CVE-2017-11006 A-66913717 * N / D Alto Componente de código fechado

Perguntas e respostas comuns

Esta seção responde a perguntas comuns que podem ocorrer após a leitura deste boletim.

1. Como posso determinar se meu dispositivo está atualizado para resolver esses problemas?

Para saber como verificar o nível do patch de segurança de um dispositivo, consulte Verificar e atualizar sua versão do Android .

  • Os níveis do patch de segurança de 01-12-2017 ou posteriores tratam de todos os problemas associados ao nível do patch de segurança 2017-12-01.
  • Os níveis do patch de segurança de 05-12-2017 ou posteriores tratam de todos os problemas associados ao nível do patch de segurança 2017-12-05 e todos os níveis de patch anteriores.

Os fabricantes de dispositivos que incluem essas atualizações devem definir o nível da string de patch para:

  • [ro.build.version.security_patch]: [2017-12-01]
  • [ro.build.version.security_patch]: [2017-12-05]

2. Por que este boletim tem dois níveis de patch de segurança?

Este boletim tem dois níveis de patch de segurança para que os parceiros Android tenham flexibilidade para corrigir um subconjunto de vulnerabilidades que são semelhantes em todos os dispositivos Android mais rapidamente. Os parceiros Android são encorajados a corrigir todos os problemas neste boletim e usar o nível de patch de segurança mais recente.

  • Os dispositivos que usam o nível de patch de segurança 2017-12-01 devem incluir todos os problemas associados a esse nível de patch de segurança, bem como correções para todos os problemas relatados em boletins de segurança anteriores.
  • Os dispositivos que usam o nível de patch de segurança de 05-12-2017 ou mais recente devem incluir todos os patches aplicáveis ​​neste (e nos anteriores) boletins de segurança.

Os parceiros são incentivados a agrupar as correções para todos os problemas que estão abordando em uma única atualização.

3. O que significam as entradas na coluna Tipo ?

As entradas na coluna Tipo da tabela de detalhes da vulnerabilidade fazem referência à classificação da vulnerabilidade de segurança.

Abreviação Definição
RCE Execução remota de código
EoP Elevação de privilégio
EU IRIA Divulgação de informação
DoS Negação de serviço
N / D Classificação não disponível

4. O que significam as entradas na coluna Referências ?

As entradas na coluna Referências da tabela de detalhes da vulnerabilidade podem conter um prefixo que identifica a organização à qual o valor de referência pertence.

Prefixo Referência
UMA- ID de bug do Android
QC- Número de referência da Qualcomm
M- Número de referência da MediaTek
N- Número de referência NVIDIA
B- Número de referência Broadcom

5. O que significa um * ao lado do ID do bug do Android na coluna Referências ?

Os problemas que não estão publicamente disponíveis têm um * próximo ao ID do bug do Android na coluna Referências . A atualização para esse problema geralmente está contida nos drivers binários mais recentes para dispositivos Nexus disponíveis no site Google Developer .

6. Por que as vulnerabilidades de segurança estão divididas entre este boletim e os boletins de segurança do dispositivo / parceiro, como o boletim Pixel / Nexus?

As vulnerabilidades de segurança documentadas neste boletim de segurança são necessárias para declarar o nível de patch de segurança mais recente em dispositivos Android. Vulnerabilidades de segurança adicionais documentadas nos boletins de segurança do dispositivo / parceiro não são necessárias para declarar um nível de patch de segurança. Os fabricantes de dispositivos e chipsets Android são incentivados a documentar a presença de outras correções em seus dispositivos por meio de seus próprios sites de segurança, como os boletins de segurança Samsung , LGE ou Pixel / Nexus .

Versões

Versão Encontro Notas
1.0 4 de dezembro de 2017 Boletim publicado.
1,1 6 de dezembro de 2017 Boletim revisado para incluir links AOSP.