O Google tem o compromisso de promover a igualdade racial para as comunidades negras. Saiba como.

Notas de versão da biblioteca de IU do carro

car-ui-lib-plugin-apis versão 1.1.1

  • Alterado minSdkVersion para 28.

car-ui-lib versão 2.2.1

  • Introduzido CarUiFooterPreference .
  • Alterado minSdkVersion para 28.

car-ui-lib-plugin-apis versão 1.1.0

  • AppStyledViewControllerOEMV1 obsoleto.
  • Introduzido AppStyledViewControllerOEMV2 .

    Alterações do AppStyledViewControllerOEMV1

    public abstract int getContentAreaHeight();
    public abstract int getContentAreaWidth();
    
  • PluginFactoryOEMV1 e PluginFactoryOEMV2 .

  • Introduziu a interface PluginFactoryOEMV3 .

car-ui-lib versão 2.1.0

  • Novas APIs de cliente AppStyledView .

    public int getContentAreaHeight();
    public int getContentAreaWidth();
    
  • Introduzido CarUiPrimarySwitchPreference .

  • AppStyledDialogController atualizado para exigir Activity em vez de Context .

    Adicionado

    public AppStyledDialogController(android.app.Activity);
    

    Descontinuada

    public AppStyledDialogController(android.content.Context);
    

car-ui-lib-plugin-apis versão 1.0.1

Esta versão adiciona anotações de nulidade.

car-ui-lib-plugin-apis versão 1.0.0

Esta versão apresenta suporte para as seguintes APIs de plugins car-ui-lib :

  • AppStyledViewDialog
  • CarUiRecyclerView
  • CarUiToolbar
  • CarUiListItems

car-ui-lib versão 2.0.0

Esta versão, disponível no Google Maven , apresenta suporte ao plug-in car-ui-lib para estes componentes:

  • AppStyledViewDialog
  • CarUiRecyclerView
  • CarUiToolbar
  • CarUiListItems

car-ui-lib versão 1.0.0

Esta versão está disponível no AOSP para Android S e abaixo e oferece suporte para: