Google은 흑인 공동체를 위한 인종 간 평등을 진전시키기 위해 노력하고 있습니다. Google에서 어떤 노력을 하고 있는지 확인하세요.

Android 보안 게시판 - 2022년 6월

2022년 6월 6일 게시 | 2022년 7월 22일 업데이트됨

Android 보안 게시판에는 Android 기기에 영향을 미치는 보안 취약점에 대한 세부 정보가 포함되어 있습니다. 2022-06-05 이상의 보안 패치 수준은 이러한 모든 문제를 해결합니다. 기기의 보안 패치 수준을 확인하는 방법을 알아보려면 Android 버전 확인 및 업데이트 를 참조하세요.

Android 파트너는 발행하기 최소 한 달 전에 모든 문제에 대한 알림을 받습니다. 이러한 문제에 대한 소스 코드 패치가 AOSP(Android 오픈 소스 프로젝트) 저장소에 릴리스되었으며 이 게시판에 링크되어 있습니다. 이 게시판에는 AOSP 외부의 패치에 대한 링크도 포함되어 있습니다.

이러한 문제 중 가장 심각한 것은 추가 실행 권한 없이 원격 코드를 실행할 수 있는 시스템 구성 요소의 심각한 보안 취약점입니다. 심각도 평가 는 플랫폼 및 서비스 완화가 개발 목적으로 꺼져 있거나 성공적으로 우회된 경우 취약성 악용이 영향을 받는 장치에 미칠 수 있는 영향을 기반으로 합니다.

Android 플랫폼의 보안을 향상시키는 Android 보안 플랫폼 보호 및 Google Play Protect에 대한 자세한 내용은 Android 및 Google Play Protect 완화 섹션을 참조하세요.

Android 및 Google 서비스 완화

다음은 Android 보안 플랫폼Google Play Protect 와 같은 서비스 보호에서 제공하는 완화 조치에 대한 요약입니다. 이러한 기능은 Android에서 보안 취약점이 성공적으로 악용될 가능성을 줄입니다.

  • Android 플랫폼의 최신 버전에서 향상된 기능으로 인해 Android의 많은 문제에 대한 악용이 더 어려워졌습니다. 가능한 경우 모든 사용자가 최신 버전의 Android로 업데이트할 것을 권장합니다.
  • Android 보안 팀은 Google Play Protect 를 통해 악용 사례를 적극적으로 모니터링하고 잠재적으로 유해한 애플리케이션 에 대해 사용자에게 경고합니다. Google Play 프로텍트는 Google 모바일 서비스 가 있는 기기에서 기본적으로 활성화되며 Google Play 외부에서 앱을 설치하는 사용자에게 특히 중요합니다.

2022-06-01 보안 패치 수준 취약점 세부 정보

아래 섹션에서는 2022-06-01 패치 수준에 적용되는 각 보안 취약점에 대한 세부 정보를 제공합니다. 취약점은 영향을 받는 구성 요소 아래에 그룹화됩니다. 문제는 아래 표에 설명되어 있으며 CVE ID, 관련 참조, 취약점 유형 , 심각도 및 업데이트된 AOSP 버전(해당되는 경우)을 포함합니다. 가능한 경우 문제를 해결한 공개 변경 사항을 AOSP 변경 목록과 같은 버그 ID에 연결합니다. 여러 변경 사항이 단일 버그와 관련된 경우 추가 참조는 버그 ID 뒤에 오는 번호에 연결됩니다. Android 10 이상이 설치된 기기는 보안 업데이트와 Google Play 시스템 업데이트 를 받을 수 있습니다.

뼈대

이 섹션의 가장 심각한 취약점은 추가 실행 권한이 필요하지 않은 로컬 권한 상승으로 이어질 수 있습니다.

CVE 참고문헌 유형 심각성 업데이트된 AOSP 버전
CVE-2021-39691 A-157929241 EOP 높은 10, 11, 12
CVE-2022-20006 A-151095871 EOP 높은 10, 11, 12, 12L
CVE-2022-20125 A-194402515 EOP 높은 10, 11, 12, 12L
CVE-2022-20138 A-210469972 [ 2 ] EOP 높은 10, 11, 12, 12L

미디어 프레임워크

이 섹션의 취약점은 추가 실행 권한이 필요하지 않은 원격 코드 실행으로 이어질 수 있습니다.

CVE 참고문헌 유형 심각성 업데이트된 AOSP 버전
CVE-2022-20130 A-224314979 RCE 위독한 10, 11, 12, 12L

체계

이 섹션의 가장 심각한 취약점은 추가 실행 권한이 필요하지 않은 원격 코드 실행으로 이어질 수 있습니다.

CVE 참고문헌 유형 심각성 업데이트된 AOSP 버전
CVE-2022-20127 A-221862119 RCE 위독한 10, 11, 12, 12L
CVE-2022-20140 A-227618988 EOP 위독한 12, 12L
CVE-2022-20145 A-201660636 EOP 위독한 11
CVE-2022-20126 A-203431023 EOP 높은 10, 11, 12, 12L
CVE-2022-20133 A-206807679 EOP 높은 10, 11, 12, 12L
CVE-2022-20134 A-218341397 [ 2 ] EOP 높은 10, 11, 12, 12L
CVE-2022-20135 A-220303465 EOP 높은 10, 11, 12, 12L
CVE-2022-20137 A-206986392 EOP 높은 12, 12L
CVE-2022-20142 A-216631962 EOP 높은 10, 11, 12, 12L
CVE-2022-20144 A-187702830 [ 2 ] EOP 높은 10, 11, 12, 12L
CVE-2022-20147 A-221216105 EOP 높은 10, 11, 12, 12L
CVE-2022-20123 A-221852424 ID 높은 10, 11, 12, 12L
CVE-2022-20131 A-221856662 ID 높은 10, 11, 12, 12L
CVE-2022-20129 A-217934478 [ 2 ] DoS 높은 10, 11, 12, 12L
CVE-2022-20143 A-220735360 DoS 높은 10, 11, 12, 12L

Google Play 시스템 업데이트

Project Mainline 구성 요소에는 다음 문제가 포함되어 있습니다.

요소 CVE
미디어 코덱 CVE-2022-20130

2022-06-05 보안 패치 수준 취약점 세부 정보

아래 섹션에서는 2022-06-05 패치 수준에 적용되는 각 보안 취약점에 대한 세부 정보를 제공합니다. 취약점은 영향을 받는 구성 요소 아래에 그룹화됩니다. 문제는 아래 표에 설명되어 있으며 CVE ID, 관련 참조, 취약점 유형 , 심각도 및 업데이트된 AOSP 버전(해당되는 경우)을 포함합니다. 가능한 경우 문제를 해결한 공개 변경 사항을 AOSP 변경 목록과 같은 버그 ID에 연결합니다. 여러 변경 사항이 단일 버그와 관련된 경우 추가 참조는 버그 ID 뒤에 오는 번호에 연결됩니다.

커널 구성 요소

이 섹션의 가장 심각한 취약점은 추가 실행 권한이 필요하지 않은 로컬 권한 상승으로 이어질 수 있습니다.

CVE 참고문헌 유형 심각성 요소
CVE-2021-4154 A-218836280
업스트림 커널
EOP 높은 핵심
CVE-2022-20141 A-112551163
업스트림 커널
EOP 높은 인터넷 소켓
CVE-2022-24958 A-220261709
업스트림 커널 [ 2 ] [ 3 ] [ 4 ]
EOP 높은 USB
CVE-2022-25258 A-222023189
업스트림 커널 [ 2 ]
EOP 높은 USB
CVE-2022-20132 A-188677105
업스트림 커널 [ 2 ] [ 3 ] [ 4 ] [ 5 ] [ 6 ] [ 7 ]
ID 높은 USB HID
CVE-2022-25375 A-162326603
업스트림 커널
ID 높은 RNDIS 드라이버

MediaTek 구성 요소

이 취약점은 MediaTek 구성 요소에 영향을 미치며 자세한 내용은 MediaTek에서 직접 확인할 수 있습니다. 이 문제의 심각도 평가는 MediaTek에서 직접 제공합니다.

CVE 참고문헌 심각성 요소
CVE-2022-21745
A-228972609
M-ALPS06468872 *
높은 와이파이 펌웨어

Unisoc 구성 요소

이 취약점은 Unisoc 구성 요소에 영향을 미치며 자세한 내용은 Unisoc에서 직접 확인할 수 있습니다. 이 문제의 심각도 평가는 Unisoc에서 직접 제공합니다.

CVE 참고문헌 심각성 요소
CVE-2022-20210
A-228868888
U-1770644 *
위독한 모뎀

Qualcomm 폐쇄 소스 구성 요소

이러한 취약점은 Qualcomm 비공개 소스 구성 요소에 영향을 미치며 해당 Qualcomm 보안 게시판 또는 보안 경고에 자세히 설명되어 있습니다. 이러한 문제의 심각도 평가는 Qualcomm에서 직접 제공합니다.

CVE 참고문헌 심각성 요소
CVE-2021-35083
A-209481130 * 높은 비공개 소스 구성 요소
CVE-2021-35102
A-209469926 * 높은 비공개 소스 구성 요소
CVE-2021-35111
A-209469960 * 높은 비공개 소스 구성 요소
CVE-2022-22082 A-223211217 * 높은 비공개 소스 구성 요소
CVE-2022-22083 A-223210917 * 높은 비공개 소스 구성 요소
CVE-2022-22084
A-223209816 * 높은 비공개 소스 구성 요소
CVE-2022-22085 A-223209306 * 높은 비공개 소스 구성 요소
CVE-2022-22086 A-223211218 * 높은 비공개 소스 구성 요소
CVE-2022-22087 A-223209610 * 높은 비공개 소스 구성 요소
CVE-2022-22090 A-223210918 * 높은 비공개 소스 구성 요소

일반적인 질문과 답변

이 섹션에서는 이 게시판을 읽은 후 발생할 수 있는 일반적인 질문에 대한 답변을 제공합니다.

1. 내 장치가 이러한 문제를 해결하도록 업데이트되었는지 어떻게 확인합니까?

기기의 보안 패치 수준을 확인하는 방법을 알아보려면 Android 버전 확인 및 업데이트 를 참조하세요.

  • 2022-06-01 이상의 보안 패치 수준은 2022-06-01 보안 패치 수준과 관련된 모든 문제를 해결합니다.
  • 2022-06-05 이상의 보안 패치 수준은 2022-06-05 보안 패치 수준 및 모든 이전 패치 수준과 관련된 모든 문제를 해결합니다.

이러한 업데이트를 포함하는 장치 제조업체는 패치 문자열 수준을 다음으로 설정해야 합니다.

  • [ro.build.version.security_patch]:[2022-06-01]
  • [ro.build.version.security_patch]:[2022-06-05]

Android 10 이상의 일부 기기의 경우 Google Play 시스템 업데이트에는 2022-06-01 보안 패치 수준과 일치하는 날짜 문자열이 있습니다. 보안 업데이트를 설치하는 방법에 대한 자세한 내용은 이 문서 를 참조하십시오.

2. 이 게시판에 두 가지 보안 패치 수준이 있는 이유는 무엇입니까?

이 게시판에는 두 가지 보안 패치 수준이 있으므로 Android 파트너는 모든 Android 기기에서 유사한 취약점의 하위 집합을 보다 신속하게 수정할 수 있습니다. Android 파트너는 이 게시판의 모든 문제를 수정하고 최신 보안 패치 수준을 사용하는 것이 좋습니다.

  • 2022-06-01 보안 패치 수준을 사용하는 장치에는 해당 보안 패치 수준과 관련된 모든 문제와 이전 보안 게시판에서 보고된 모든 문제에 대한 수정 사항이 포함되어야 합니다.
  • 2022-06-05 이상의 보안 패치 수준을 사용하는 장치는 이(및 이전) 보안 게시판에 적용 가능한 모든 패치를 포함해야 합니다.

파트너는 단일 업데이트에서 해결 중인 모든 문제에 대한 수정 사항을 번들로 제공하는 것이 좋습니다.

3. 유형 열의 항목은 무엇을 의미합니까?

취약성 세부 정보 테이블의 유형 열 항목은 보안 취약성의 분류를 참조합니다.

약어 정의
RCE 원격 코드 실행
EOP 특권 승격
ID 정보 공개
DoS 서비스 거부
해당 없음 분류 불가

4. 참조 열의 항목은 무엇을 의미합니까?

취약점 세부 정보 테이블의 참조 열 아래 항목에는 참조 값이 속한 조직을 식별하는 접두사가 포함될 수 있습니다.

접두사 참조
ㅏ- 안드로이드 버그 ID
QC- Qualcomm 참조 번호
중- MediaTek 참조 번호
N- NVIDIA 참조 번호
비- Broadcom 참조 번호
유- UNISOC 참조 번호

5. 참조 열의 Android 버그 ID 옆에 있는 *는 무엇을 의미합니까?

공개되지 않은 문제는 해당 참조 ID 옆에 *가 표시됩니다. 해당 문제에 대한 업데이트는 일반적으로 Google 개발자 사이트 에서 제공되는 Pixel 장치용 최신 바이너리 드라이버에 포함되어 있습니다.

6. 이 게시판과 Pixel 게시판과 같은 장치/파트너 보안 게시판 간에 보안 취약점이 분할된 이유는 무엇입니까?

이 보안 게시판에 설명된 보안 취약점은 Android 장치에서 최신 보안 패치 수준을 선언하는 데 필요합니다. 장치/파트너 보안 게시판에 문서화된 추가 보안 취약성은 보안 패치 수준을 선언하는 데 필요하지 않습니다. Android 기기 및 칩셋 제조업체는 Google , Huawei , LGE , Motorola , Nokia 또는 Samsung 과 같은 자사 제품과 관련된 보안 취약성 세부정보도 게시할 수 있습니다.

버전

버전 날짜 메모
1.0 2022년 6월 6일 게시된 게시판
1.1 2022년 6월 7일 AOSP 링크를 포함하도록 수정된 게시판
2.0 2022년 6월 28일 CVE-2021-39624는 회귀 가능성으로 인해 2022-06-01 SPL에서 제거되었습니다. 향후 SPL을 위해 이 수정 사항의 업데이트된 버전이 필요할 수 있습니다.
3.0 2022년 7월 22일 CVE-2022-20124는 회귀 가능성으로 인해 2022-06-01 SPL에서 제거되었습니다. 향후 SPL을 위해 이 수정 사항의 업데이트된 버전이 필요합니다.