Google は、黒人コミュニティに対する人種平等の促進に取り組んでいます。取り組みを見る

車のUIライブラリのリリースノート

car-ui-lib-plugin-apisバージョン1.1.1

  • minSdkVersionを28に変更しました。

car-ui-libバージョン2.2.1

  • CarUiFooterPreferenceを導入しました。
  • minSdkVersionを28に変更しました。

car-ui-lib-plugin-apisバージョン1.1.0

  • 非推奨AppStyledViewControllerOEMV1
  • AppStyledViewControllerOEMV2導入されました。

    AppStyledViewControllerOEMV1からの変更

    public abstract int getContentAreaHeight();
    public abstract int getContentAreaWidth();
    
  • 非推奨PluginFactoryOEMV1およびPluginFactoryOEMV2

  • PluginFactoryOEMV3インターフェースが導入されました。

car-ui-libバージョン2.1.0

  • 新しいAppStyledViewクライアントAPI。

    public int getContentAreaHeight();
    public int getContentAreaWidth();
    
  • CarUiPrimarySwitchPreferenceを導入しました。

  • AppStyledDialogControllerコンストラクターを更新して、 ContextではなくActivityを要求するようにしました。

    追加した

    public AppStyledDialogController(android.app.Activity);
    

    非推奨

    public AppStyledDialogController(android.content.Context);
    

car-ui-lib-plugin-apisバージョン1.0.1

このバージョンでは、nullness注釈が追加されています。

car-ui-lib-plugin-apisバージョン1.0.0

このバージョンでは、次のcar-ui-libプラグインAPIのサポートが導入されています。

  • AppStyledViewDialog
  • CarUiRecyclerView
  • CarUiToolbar
  • CarUiListItems

car-ui-libバージョン2.0.0

このバージョンは、 Google Mavenで入手可能で、これらのコンポーネントcar-ui-libプラグインサポートを導入しています。

  • AppStyledViewDialog
  • CarUiRecyclerView
  • CarUiToolbar
  • CarUiListItems

car-ui-libバージョン1.0.0

このリリースは、Android S以下のAOSPで利用可能であり、以下のサポートを提供します。