Google se compromete a impulsar la igualdad racial para las comunidades afrodescendientes. Obtén información al respecto.

Boletín de seguridad de Android: mayo de 2022

Publicado el 2 de mayo de 2022 | Actualizado el 3 de mayo de 2022

El Boletín de seguridad de Android contiene detalles de las vulnerabilidades de seguridad que afectan a los dispositivos Android. Los niveles de parches de seguridad de 2022-05-05 o posteriores abordan todos estos problemas. Para obtener información sobre cómo verificar el nivel del parche de seguridad de un dispositivo, consulte Verifique y actualice su versión de Android .

Los socios de Android son notificados de todos los problemas al menos un mes antes de la publicación. Los parches del código fuente para estos problemas se publicarán en el repositorio del Proyecto de código abierto de Android (AOSP) en las próximas 48 horas. Revisaremos este boletín con los enlaces AOSP cuando estén disponibles.

El más grave de estos problemas es una vulnerabilidad de alta seguridad en el componente Framework que podría conducir a una escalada local de privilegios con la necesidad de privilegios de ejecución del usuario. La evaluación de la gravedad se basa en el efecto que podría tener la explotación de la vulnerabilidad en un dispositivo afectado, suponiendo que las mitigaciones de la plataforma y el servicio estén desactivadas con fines de desarrollo o si se eluden con éxito.

Consulte la sección Mitigaciones de Android y Google Play Protect para obtener detalles sobre las protecciones de la plataforma de seguridad de Android y Google Play Protect, que mejoran la seguridad de la plataforma Android.

Mitigaciones de servicios de Android y Google

Este es un resumen de las mitigaciones proporcionadas por la plataforma de seguridad de Android y las protecciones de servicios como Google Play Protect . Estas capacidades reducen la probabilidad de que las vulnerabilidades de seguridad puedan explotarse con éxito en Android.

  • La explotación de muchos problemas en Android se hace más difícil debido a las mejoras en las versiones más recientes de la plataforma Android. Alentamos a todos los usuarios a actualizar a la última versión de Android siempre que sea posible.
  • El equipo de seguridad de Android monitorea activamente el abuso a través de Google Play Protect y advierte a los usuarios sobre aplicaciones potencialmente dañinas . Google Play Protect está habilitado de forma predeterminada en los dispositivos con Google Mobile Services y es especialmente importante para los usuarios que instalan aplicaciones desde fuera de Google Play.

Detalles de vulnerabilidad de nivel de parche de seguridad 2022-05-01

En las secciones a continuación, proporcionamos detalles para cada una de las vulnerabilidades de seguridad que se aplican al nivel de parche 2022-05-01. Las vulnerabilidades se agrupan según el componente al que afectan. Los problemas se describen en las tablas siguientes e incluyen el ID de CVE, las referencias asociadas, el tipo de vulnerabilidad , la gravedad y las versiones actualizadas de AOSP (cuando corresponda). Cuando está disponible, vinculamos el cambio público que abordó el problema con la identificación del error, como la lista de cambios de AOSP. Cuando varios cambios se relacionan con un solo error, las referencias adicionales se vinculan a los números que siguen al ID del error. Los dispositivos con Android 10 y versiones posteriores pueden recibir actualizaciones de seguridad, así como actualizaciones del sistema de Google Play .

Marco de referencia

La vulnerabilidad más grave en esta sección podría dar lugar a una escalada local de privilegios con la necesidad de privilegios de ejecución del usuario.

CVE Referencias Tipo Gravedad Versiones actualizadas de AOSP
CVE-2021-39662 A-197302116 EoP Alto 11, 12
CVE-2022-20004 A-179699767 EoP Alto 10, 11, 12, 12L
CVE-2022-20005 A-219044664 EoP Alto 10, 11, 12, 12L
CVE-2022-20007 A-211481342 EoP Alto 10, 11, 12, 12L
CVE-2021-39700 A-201645790 IDENTIFICACIÓN Moderado 10, 11, 12

Sistema

La vulnerabilidad más grave de esta sección podría dar lugar a una escalada local de privilegios sin necesidad de privilegios de ejecución adicionales.

CVE Referencias Tipo Gravedad Versiones actualizadas de AOSP
CVE-2022-20113 A-205996517 EoP Alto 12, 12L
CVE-2022-20114 A-211114016 EoP Alto 10, 11, 12, 12L
CVE-2022-20116 A-212467440 EoP Alto 12, 12L
CVE-2022-20010 A-213519176 IDENTIFICACIÓN Alto 12, 12L
CVE-2022-20011 A-214999128 IDENTIFICACIÓN Alto 10, 11, 12, 12L
CVE-2022-20115 A-210118427 IDENTIFICACIÓN Alto 12, 12L
CVE-2021-39670 A-204087139 DoS Alto 12, 12L
CVE-2022-20112 A-206987762 DoS Alto 10, 11, 12, 12L

Actualizaciones del sistema de Google Play

Los siguientes problemas se incluyen en los componentes de Project Mainline.

Componente CVE
proveedor de medios CVE-2021-39662

Detalles de vulnerabilidad de nivel de parche de seguridad 2022-05-05

En las secciones a continuación, proporcionamos detalles para cada una de las vulnerabilidades de seguridad que se aplican al nivel de parche 2022-05-05. Las vulnerabilidades se agrupan según el componente al que afectan. Los problemas se describen en las tablas siguientes e incluyen el ID de CVE, las referencias asociadas, el tipo de vulnerabilidad , la gravedad y las versiones actualizadas de AOSP (cuando corresponda). Cuando está disponible, vinculamos el cambio público que abordó el problema con la identificación del error, como la lista de cambios de AOSP. Cuando varios cambios se relacionan con un solo error, las referencias adicionales se vinculan a los números que siguen al ID del error.

Componentes del núcleo

La vulnerabilidad más grave de esta sección podría dar lugar a una escalada local de privilegios en las bibliotecas del sistema sin necesidad de privilegios de ejecución adicionales.

CVE Referencias Tipo Gravedad Componente
CVE-2022-0847 A-220741611
Núcleo ascendente [ 2 ] [ 3 ]
EoP Alto tubería
CVE-2022-20009 A-213172319
Núcleo ascendente [ 2 ]
EoP Alto linux
CVE-2022-20008 A-216481035
Núcleo ascendente [ 2 ] [ 3 ]
IDENTIFICACIÓN Alto SD MMC
CVE-2021-22600 A-213464034
Núcleo ascendente
EoP Moderado Núcleo

Componentes de MediaTek

Estas vulnerabilidades afectan a los componentes de MediaTek y hay más detalles disponibles directamente de MediaTek. MediaTek proporciona directamente la evaluación de la gravedad de estos problemas.

CVE Referencias Gravedad Componente
CVE-2022-20084 A-223071148
M-ALPS06498874 *
Alto telefonía
CVE-2022-20109 A-223072269
M-ALPS06399915 *
Alto ion
CVE-2022-20110 A-223071150
M-ALPS06399915 *
Alto ion

Componentes Qualcomm

Estas vulnerabilidades afectan a los componentes de Qualcomm y se describen con más detalle en el boletín de seguridad o alerta de seguridad correspondiente de Qualcomm. Qualcomm proporciona directamente la evaluación de la gravedad de estos problemas.

CVE Referencias Gravedad Componente
CVE-2022-22057 A-218337595
QC-CR#3077687
Alto Mostrar
CVE-2022-22064 A-218338071
QC-CR#3042282
QC-CR#3048959
QC-CR#3056532
QC-CR#3049158 [ 2 ]
Alto WiFi
CVE-2022-22065 A-218337597
QC-CR#3042293
QC-CR#3064612
Alto WiFi
CVE-2022-22068 A-218337596
QC-CR#3084983 [ 2 ]
Alto Núcleo
CVE-2022-22072 A-218339149
QC-CR#3073345 [ 2 ]
Alto WiFi

Componentes de código cerrado de Qualcomm

Estas vulnerabilidades afectan a los componentes de código cerrado de Qualcomm y se describen con más detalle en el boletín de seguridad o alerta de seguridad de Qualcomm correspondiente. Qualcomm proporciona directamente la evaluación de la gravedad de estos problemas.

CVE Referencias Gravedad Componente
CVE-2021-35090 A-204905205 ​​* Crítico Componente de código cerrado
CVE-2021-35072 A-204905110 * Alto Componente de código cerrado
CVE-2021-35073 A-204905209 * Alto Componente de código cerrado
CVE-2021-35076 A-204905151 * Alto Componente de código cerrado
CVE-2021-35078 A-204905326 * Alto Componente de código cerrado
CVE-2021-35080 A-204905287 * Alto Componente de código cerrado
CVE-2021-35086 A-204905289 * Alto Componente de código cerrado
CVE-2021-35087 A-204905111 * Alto Componente de código cerrado
CVE-2021-35094 A-204905838 * Alto Componente de código cerrado
CVE-2021-35096 A-204905290 * Alto Componente de código cerrado
CVE-2021-35116 A-209469826 * Alto Componente de código cerrado

Preguntas y respuestas comunes

Esta sección responde preguntas comunes que pueden surgir después de leer este boletín.

1. ¿Cómo puedo determinar si mi dispositivo está actualizado para solucionar estos problemas?

Para obtener información sobre cómo verificar el nivel del parche de seguridad de un dispositivo, consulte Verifique y actualice su versión de Android .

  • Los niveles de parche de seguridad 2022-05-01 o posteriores abordan todos los problemas asociados con el nivel de parche de seguridad 2022-05-01.
  • Los niveles de parches de seguridad de 2022-05-05 o posteriores abordan todos los problemas asociados con el nivel de parches de seguridad 2022-05-05 y todos los niveles de parches anteriores.

Los fabricantes de dispositivos que incluyen estas actualizaciones deben establecer el nivel de la cadena de parches en:

  • [ro.build.version.security_patch]:[2022-05-01]
  • [ro.build.version.security_patch]:[2022-05-05]

Para algunos dispositivos con Android 10 o posterior, la actualización del sistema de Google Play tendrá una cadena de fecha que coincida con el nivel del parche de seguridad 2022-05-01. Consulte este artículo para obtener más detalles sobre cómo instalar actualizaciones de seguridad.

2. ¿Por qué este boletín tiene dos niveles de parches de seguridad?

Este boletín tiene dos niveles de parches de seguridad para que los socios de Android tengan la flexibilidad de corregir un subconjunto de vulnerabilidades que son similares en todos los dispositivos Android con mayor rapidez. Se recomienda a los socios de Android que solucionen todos los problemas de este boletín y utilicen el nivel de parche de seguridad más reciente.

  • Los dispositivos que usan el nivel de parche de seguridad 2022-05-01 deben incluir todos los problemas asociados con ese nivel de parche de seguridad, así como soluciones para todos los problemas informados en boletines de seguridad anteriores.
  • Los dispositivos que usan el nivel de parche de seguridad de 2022-05-05 o posterior deben incluir todos los parches aplicables en este (y en los anteriores) boletines de seguridad.

Se alienta a los socios a agrupar las soluciones para todos los problemas que están solucionando en una sola actualización.

3. ¿Qué significan las entradas en la columna Tipo ?

Las entradas en la columna Tipo de la tabla de detalles de la vulnerabilidad hacen referencia a la clasificación de la vulnerabilidad de seguridad.

Abreviatura Definición
RCE Ejecución remota de código
EoP Elevación de privilegio
IDENTIFICACIÓN Divulgación de información
DoS Negación de servicio
N / A Clasificación no disponible

4. ¿Qué significan las entradas en la columna Referencias ?

Las entradas en la columna Referencias de la tabla de detalles de vulnerabilidad pueden contener un prefijo que identifique la organización a la que pertenece el valor de referencia.

Prefijo Referencia
UN- ID de error de Android
QC- Número de referencia de Qualcomm
METRO- Número de referencia de MediaTek
NORTE- Número de referencia de NVIDIA
B- Número de referencia de Broadcom
tu- Número de referencia UNISOC

5. ¿Qué significa un * junto al ID de error de Android en la columna Referencias ?

Los problemas que no están disponibles públicamente tienen un * junto al ID de referencia correspondiente. La actualización para ese problema generalmente se incluye en los controladores binarios más recientes para dispositivos Pixel disponibles en el sitio para desarrolladores de Google .

6. ¿Por qué las vulnerabilidades de seguridad se dividen entre este boletín y los boletines de seguridad de dispositivos/socios, como el boletín de Pixel?

Las vulnerabilidades de seguridad que se documentan en este boletín de seguridad deben declarar el último nivel de parche de seguridad en los dispositivos Android. Las vulnerabilidades de seguridad adicionales que están documentadas en los boletines de seguridad del dispositivo/socio no son necesarias para declarar un nivel de parche de seguridad. Los fabricantes de chipsets y dispositivos Android también pueden publicar detalles de vulnerabilidad de seguridad específicos de sus productos, como Google , Huawei , LGE , Motorola , Nokia o Samsung .

Versiones

Versión Fecha notas
1.0 2 de mayo de 2022 Boletín publicado
1.1 3 de mayo de 2022 Boletín revisado para incluir enlaces AOSP