অ্যান্ড্রয়েড নিরাপত্তা বুলেটিন—অক্টোবর 2016

সেভ করা পৃষ্ঠা গুছিয়ে রাখতে 'সংগ্রহ' ব্যবহার করুন আপনার পছন্দ অনুযায়ী কন্টেন্ট সেভ করুন ও সঠিক বিভাগে রাখুন।

প্রকাশিত অক্টোবর 03, 2016 | 04 অক্টোবর, 2016 আপডেট করা হয়েছে

অ্যান্ড্রয়েড সিকিউরিটি বুলেটিনে অ্যান্ড্রয়েড ডিভাইসগুলিকে প্রভাবিত করে এমন নিরাপত্তা দুর্বলতার বিবরণ রয়েছে৷ বুলেটিনের পাশাপাশি, আমরা ওভার-দ্য-এয়ার (OTA) আপডেটের মাধ্যমে Nexus ডিভাইসে একটি নিরাপত্তা আপডেট প্রকাশ করেছি। নেক্সাস ফার্মওয়্যারের ছবিগুলিও গুগল ডেভেলপার সাইটে প্রকাশ করা হয়েছে। অক্টোবর 05, 2016 বা তার পরে নিরাপত্তা প্যাচ স্তরগুলি এই সমস্যাগুলির সমাধান করে৷ সিকিউরিটি প্যাচ লেভেল কিভাবে চেক করতে হয় তা জানতে ডকুমেন্টেশন পড়ুন। সমর্থিত Nexus ডিভাইসগুলি অক্টোবর 05, 2016 নিরাপত্তা প্যাচ স্তরের সাথে একটি একক OTA আপডেট পাবে৷

06 সেপ্টেম্বর, 2016 বা তার আগে বুলেটিনে বর্ণিত সমস্যাগুলি সম্পর্কে অংশীদারদের অবহিত করা হয়েছিল৷ যেখানে প্রযোজ্য, এই সমস্যাগুলির জন্য সোর্স কোড প্যাচগুলি Android ওপেন সোর্স প্রজেক্ট (AOSP) সংগ্রহস্থলে প্রকাশ করা হয়েছে৷ এই বুলেটিনে AOSP-এর বাইরের প্যাচগুলির লিঙ্কও রয়েছে৷

এই সমস্যাগুলির মধ্যে সবচেয়ে গুরুতর হল ডিভাইস-নির্দিষ্ট কোডে গুরুতর নিরাপত্তা দুর্বলতা যা কার্নেলের প্রেক্ষাপটে দূরবর্তী কোড কার্যকর করতে পারে, যার ফলে স্থানীয় স্থায়ী ডিভাইস আপস হওয়ার সম্ভাবনা তৈরি হয়, যার জন্য ডিভাইসটি মেরামত করার জন্য অপারেটিং সিস্টেমকে রিফ্ল্যাশ করার প্রয়োজন হতে পারে। . প্ল্যাটফর্ম এবং পরিষেবার প্রশমনগুলি উন্নয়নের উদ্দেশ্যে অক্ষম করা হয়েছে বা সফলভাবে বাইপাস করা হয়েছে বলে ধরে নিয়ে, দুর্বলতাকে কাজে লাগানোর প্রভাবের উপর ভিত্তি করে তীব্রতা মূল্যায়ন করা হয়।

আমাদের কাছে এই নতুন রিপোর্ট করা সমস্যাগুলির সক্রিয় গ্রাহক শোষণ বা অপব্যবহারের কোনও রিপোর্ট নেই। Android নিরাপত্তা প্ল্যাটফর্ম সুরক্ষা এবং SafetyNet- এর মতো পরিষেবা সুরক্ষা সম্পর্কে বিশদ বিবরণের জন্য Android এবং Google পরিষেবা প্রশমন বিভাগটি পড়ুন, যা Android প্ল্যাটফর্মের নিরাপত্তা উন্নত করে৷

আমরা সমস্ত গ্রাহকদের তাদের ডিভাইসে এই আপডেটগুলি গ্রহণ করতে উত্সাহিত করি৷

ঘোষণা

  • এই বুলেটিনে দুটি নিরাপত্তা প্যাচ স্তরের স্ট্রিং রয়েছে যা Android অংশীদারদের আরও দ্রুত দুর্বলতার একটি উপসেট ঠিক করার জন্য নমনীয়তা প্রদান করে যা সমস্ত Android ডিভাইসে একই রকম। অতিরিক্ত তথ্যের জন্য সাধারণ প্রশ্ন এবং উত্তর দেখুন:
    • 2016-10-01 : আংশিক নিরাপত্তা প্যাচ স্তরের স্ট্রিং। এই নিরাপত্তা প্যাচ স্তরের স্ট্রিংটি নির্দেশ করে যে 2016-10-01 (এবং সমস্ত পূর্ববর্তী নিরাপত্তা প্যাচ স্তরের স্ট্রিং) এর সাথে সম্পর্কিত সমস্ত সমস্যা সমাধান করা হয়েছে৷
    • 2016-10-05 : সম্পূর্ণ নিরাপত্তা প্যাচ স্তরের স্ট্রিং। এই নিরাপত্তা প্যাচ স্তরের স্ট্রিংটি নির্দেশ করে যে 2016-10-01 এবং 2016-10-05 (এবং সমস্ত পূর্ববর্তী নিরাপত্তা প্যাচ স্তরের স্ট্রিং) এর সাথে সম্পর্কিত সমস্ত সমস্যা সমাধান করা হয়েছে৷
  • সমর্থিত Nexus ডিভাইসগুলি অক্টোবর 05, 2016 নিরাপত্তা প্যাচ স্তরের সাথে একটি একক OTA আপডেট পাবে৷

অ্যান্ড্রয়েড এবং গুগল পরিষেবা প্রশমন

এটি Android নিরাপত্তা প্ল্যাটফর্ম এবং SafetyNet এর মতো পরিষেবা সুরক্ষা দ্বারা প্রদত্ত প্রশমনের একটি সারাংশ। এই ক্ষমতাগুলি Android-এ নিরাপত্তার দুর্বলতাগুলি সফলভাবে কাজে লাগানোর সম্ভাবনা কমিয়ে দেয়৷

  • অ্যান্ড্রয়েড প্ল্যাটফর্মের নতুন সংস্করণে বর্ধিতকরণের মাধ্যমে অ্যান্ড্রয়েডে অনেক সমস্যার জন্য শোষণকে আরও কঠিন করা হয়েছে। আমরা সকল ব্যবহারকারীকে যেখানে সম্ভব Android এর সর্বশেষ সংস্করণে আপডেট করতে উৎসাহিত করি।
  • Android সিকিউরিটি টিম সক্রিয়ভাবে Verify Apps এবং SafetyNet এর সাথে অপব্যবহারের জন্য নিরীক্ষণ করে, যা ব্যবহারকারীদের সম্ভাব্য ক্ষতিকারক অ্যাপ্লিকেশন সম্পর্কে সতর্ক করার জন্য ডিজাইন করা হয়েছে৷ Google মোবাইল পরিষেবাগুলির সাথে ডিভাইসগুলিতে ডিফল্টরূপে অ্যাপগুলিকে যাচাইকরণ সক্ষম করা থাকে এবং বিশেষ করে যারা Google Play এর বাইরে থেকে অ্যাপ্লিকেশনগুলি ইনস্টল করেন তাদের জন্য এটি গুরুত্বপূর্ণ৷ ডিভাইস রুট করার টুলগুলি Google Play-এর মধ্যে নিষিদ্ধ, কিন্তু ভেরিফাই অ্যাপ্লিকেশানগুলি ব্যবহারকারীদের সতর্ক করে যখন তারা একটি শনাক্ত রুটিং অ্যাপ্লিকেশন ইনস্টল করার চেষ্টা করে—সেটি যেখান থেকেই আসুক না কেন। উপরন্তু, ভেরিফাই অ্যাপ্লিকেশানগুলি পরিচিত দূষিত অ্যাপ্লিকেশনগুলির ইনস্টলেশন সনাক্ত এবং ব্লক করার চেষ্টা করে যা একটি বিশেষাধিকার বৃদ্ধির দুর্বলতাকে কাজে লাগায়৷ যদি এই ধরনের একটি অ্যাপ্লিকেশন ইতিমধ্যেই ইনস্টল করা হয়ে থাকে, তবে ভেরিফাই অ্যাপ্লিকেশানগুলি ব্যবহারকারীকে অবহিত করবে এবং সনাক্ত করা অ্যাপ্লিকেশনটি সরানোর চেষ্টা করবে৷
  • উপযুক্ত হিসাবে, Google Hangouts এবং Messenger অ্যাপ্লিকেশনগুলি মিডিয়া সার্ভারের মতো প্রক্রিয়াগুলিতে স্বয়ংক্রিয়ভাবে মিডিয়া পাস করে না।

স্বীকৃতি

আমরা এই গবেষকদের তাদের অবদানের জন্য ধন্যবাদ জানাতে চাই:

  • Andre Teixeira Rizzo: CVE-2016-3882
  • Andrea Biondo: CVE-2016-3921
  • কপারহেড সিকিউরিটির ড্যানিয়েল মাইকে: CVE-2016-3922
  • গুগলের দিমিত্রি ভিউকভ : CVE-2016-7117
  • dosomder: CVE-2016-3931
  • ট্রেন্ড মাইক্রো এর ইকুলার জু (徐健): CVE-2016-3920
  • Gengjia Chen ( @chengjia4574 ) এবং IceSword Lab, Qihoo 360 Technology Co. Ltd. এর pjf: CVE-2016-6690, CVE-2016-3901, CVE-2016-6672, CVE-2016, CVE-2016-339-3901
  • Hang Zhang , Dongdong She , and Zhiyun Qian of UC Riverside: CVE-2015-8950
  • আলফা টিমের হাও চেন, কিহু 360 প্রযুক্তি কোং লিমিটেড: CVE-2016-3860
  • গুগল প্রজেক্ট জিরোর জ্যান হর্ন: CVE-2016-3900, CVE-2016-3885
  • জেসন রোজেনা : CVE-2016-3917
  • Jianqiang Zhao ( @jianqiangzhao ) এবং IceSword Lab, Qihoo 360 এর pjf: CVE-2016-6688, CVE-2016-6677, CVE-2016-6673, CVE-2016-666687, CVE-66687, CVE-6687, CVE-6687 , CVE-2016-6682, CVE-2016-3930
  • জোশুয়া ড্রেক ( @jduck ): CVE-2016-3920
  • Google নিরাপত্তা দলের Maciej Szawłowski: CVE-2016-3905
  • গুগল প্রোজেক্ট জিরোর মার্ক ব্র্যান্ড: CVE-2016-6689
  • Michał Bednarski : CVE-2016-3914, CVE-2016-6674, CVE-2016-3911, CVE-2016-3912
  • Mingjian Zhou ( @Mingjian_Zhou ), Chiachih Wu ( @chiachih_wu ), এবং C0RE টিমের Xuxian জিয়াং: CVE-2016-3933, CVE-2016-3932
  • নাইটওয়াচ সাইবারসিকিউরিটি রিসার্চ ( @ নাইটওয়াচসাইবার): CVE-2016-5348
  • রোই হে, আইবিএম সিকিউরিটি এক্স-ফোর্স গবেষক: CVE-2016-6678
  • গুগলের স্যামুয়েল ট্যান: CVE-2016-3925
  • স্কট বাউয়ার ( @ScottyBauer1 ): CVE-2016-3936, CVE-2016-3928, CVE-2016-3902, CVE-2016-3937, CVE-2016-6696
  • ট্রেন্ড মাইক্রো মোবাইল থ্রেট রিসার্চ টিমের সেভেন শেন ( @লিংটোংশেন ) CVE-2016-6694, CVE-2016-6695
  • Wenke Dou , Mingjian Zhou ( @Mingjian_Zhou ), Chiachih Wu ( @chiachih_wu ), এবং C0RE টিমের Xuxian জিয়াং: CVE-2016-3909
  • আলফা টিমের ওয়েনলিন ইয়াং এবং গুয়াং গং (龚广) ( @oldfresher ), Qihoo 360 Technology Co. Ltd.: CVE-2016-3918
  • ট্রেন্ড মাইক্রো ইনকর্পোরেটেডের উইশ উ (吴潍浠) ( @wish_wu) : CVE-2016-3924, CVE-2016-3915, CVE-2016-3916, CVE-2016-3910
  • Eagleye দলের ইয়ং শি, SCC, Huawei: CVE-2016-3938
  • নিরাপত্তা গবেষণা ল্যাব, চিতা মোবাইলের ঝানপেং ঝাও (行之) ( @0xr0ot ) : CVE-2016-3908

2016-10-01 নিরাপত্তা প্যাচ লেভেল—ভালনারেবিলিটি বিশদ

নীচের বিভাগগুলিতে, আমরা 2016-10-01 প্যাচ স্তরে প্রযোজ্য প্রতিটি নিরাপত্তা দুর্বলতার জন্য বিশদ প্রদান করি। সমস্যাটির একটি বিবরণ, একটি তীব্রতার যুক্তি, এবং CVE সহ একটি টেবিল, সংশ্লিষ্ট রেফারেন্স, তীব্রতা, আপডেট করা নেক্সাস ডিভাইস, আপডেট করা AOSP সংস্করণ (যেখানে প্রযোজ্য), এবং রিপোর্ট করা তারিখ রয়েছে। উপলব্ধ হলে, আমরা AOSP পরিবর্তনের তালিকার মতো বাগ আইডিতে সমস্যাটির সমাধানকারী সর্বজনীন পরিবর্তনকে লিঙ্ক করব। যখন একাধিক পরিবর্তন একটি একক বাগের সাথে সম্পর্কিত হয়, তখন বাগ আইডি অনুসরণকারী সংখ্যার সাথে অতিরিক্ত উল্লেখ সংযুক্ত করা হয়।

সার্ভিস ম্যানেজারে বিশেষাধিকার দুর্বলতার উচ্চতা

ServiceManager-এ বিশেষাধিকারের একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে নির্বিচারে পরিষেবাগুলি নিবন্ধন করতে সক্ষম করতে পারে যা সাধারণত একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়া দ্বারা প্রদান করা হয়, যেমন system_server। পরিষেবা ছদ্মবেশের সম্ভাবনার কারণে এই সমস্যাটিকে উচ্চ তীব্রতা হিসাবে রেট করা হয়েছে৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-3900 A-29431260 [ 2 ] উচ্চ সমস্ত নেক্সাস 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 15 জুন, 2016

লক সেটিংস পরিষেবাতে বিশেষাধিকার দুর্বলতার উচ্চতা

লক সেটিংস পরিষেবাতে বিশেষাধিকার দুর্বলতার একটি উচ্চতা ডিভাইস পিন বা পাসওয়ার্ড সাফ করতে একটি স্থানীয় দূষিত অ্যাপ্লিকেশন সক্ষম করতে পারে৷ এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি কোনও বিকাশকারী বা সুরক্ষা সেটিংস পরিবর্তনের জন্য ব্যবহারকারীর ইন্টারঅ্যাকশন প্রয়োজনীয়তার স্থানীয় বাইপাস।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-3908 A-30003944 উচ্চ সমস্ত নেক্সাস 6.0, 6.0.1, 7.0 6 জুলাই, 2016

মিডিয়াসার্ভারে বিশেষাধিকার দুর্বলতার উচ্চতা

মিডিয়াসার্ভারে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে একটি সুবিধাপ্রাপ্ত প্রক্রিয়ার প্রেক্ষাপটে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি উন্নত ক্ষমতাগুলিতে স্থানীয় অ্যাক্সেস পেতে ব্যবহার করা যেতে পারে, যা সাধারণত তৃতীয় পক্ষের অ্যাপ্লিকেশনে অ্যাক্সেসযোগ্য নয়।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-3909 A-30033990 [ 2 ] উচ্চ সমস্ত নেক্সাস 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 8ই জুলাই, 2016
CVE-2016-3910 এ-30148546 উচ্চ সমস্ত নেক্সাস 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 13 জুলাই, 2016
CVE-2016-3913 এ-30204103 উচ্চ সমস্ত নেক্সাস 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 18 জুলাই, 2016

জাইগোট প্রক্রিয়ায় বিশেষাধিকার দুর্বলতার উচ্চতা

জাইগোট প্রক্রিয়ায় বিশেষাধিকারের উচ্চতা একটি বিশেষাধিকারপ্রাপ্ত প্রক্রিয়ার প্রেক্ষাপটে স্বেচ্ছাচারী কোড কার্যকর করতে একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি উন্নত ক্ষমতাগুলিতে স্থানীয় অ্যাক্সেস পেতে ব্যবহার করা যেতে পারে, যা সাধারণত তৃতীয় পক্ষের অ্যাপ্লিকেশনে অ্যাক্সেসযোগ্য নয়।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-3911 এ-30143607 উচ্চ সমস্ত নেক্সাস 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 12 জুলাই, 2016

ফ্রেমওয়ার্ক এপিআই-এ বিশেষাধিকার দুর্বলতার উচ্চতা

ফ্রেমওয়ার্ক API-এ বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে একটি সুবিধাপ্রাপ্ত প্রক্রিয়ার প্রেক্ষাপটে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি উন্নত ক্ষমতাগুলিতে স্থানীয় অ্যাক্সেস পেতে ব্যবহার করা যেতে পারে, যা সাধারণত তৃতীয় পক্ষের অ্যাপ্লিকেশনে অ্যাক্সেসযোগ্য নয়।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-3912 এ-30202481 উচ্চ সমস্ত নেক্সাস 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 জুলাই 17, 2016

টেলিফোনিতে বিশেষাধিকার দুর্বলতার উচ্চতা

টেলিফোনি কম্পোনেন্টে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে একটি সুবিধাপ্রাপ্ত প্রক্রিয়ার প্রেক্ষাপটে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি উন্নত ক্ষমতাগুলিতে স্থানীয় অ্যাক্সেস পেতে ব্যবহার করা যেতে পারে, যা সাধারণত তৃতীয় পক্ষের অ্যাপ্লিকেশনে অ্যাক্সেসযোগ্য নয়।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-3914 এ-30481342 উচ্চ সমস্ত নেক্সাস 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 জুলাই 28, 2016

ক্যামেরা পরিষেবায় বিশেষাধিকারের দুর্বলতার উচ্চতা

ক্যামেরা পরিষেবাতে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার প্রেক্ষাপটে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি উন্নত ক্ষমতাগুলিতে স্থানীয় অ্যাক্সেস পেতে ব্যবহার করা যেতে পারে, যা সাধারণত তৃতীয় পক্ষের অ্যাপ্লিকেশনে অ্যাক্সেসযোগ্য নয়।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-3915 এ-30591838 উচ্চ সমস্ত নেক্সাস 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 1 আগস্ট, 2016
CVE-2016-3916 এ-30741779 উচ্চ সমস্ত নেক্সাস 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 2 আগস্ট, 2016

ফিঙ্গারপ্রিন্ট লগইনে বিশেষাধিকার দুর্বলতার উচ্চতা

ফিঙ্গারপ্রিন্ট লগইনের সময় বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি দূষিত ডিভাইসের মালিককে ডিভাইসে একটি ভিন্ন ব্যবহারকারীর অ্যাকাউন্ট হিসাবে লগইন করতে সক্ষম করতে পারে। লকস্ক্রিন বাইপাসের সম্ভাবনার কারণে এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-3917 এ-30744668 উচ্চ সমস্ত নেক্সাস 6.0.1, 7.0 5 আগস্ট, 2016

AOSP মেলে তথ্য প্রকাশের দুর্বলতা

AOSP মেলে একটি তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে অপারেটিং সিস্টেম সুরক্ষাগুলি বাইপাস করতে সক্ষম করতে পারে যা অন্যান্য অ্যাপ্লিকেশন থেকে অ্যাপ্লিকেশন ডেটা বিচ্ছিন্ন করে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি অনুমতি ছাড়াই ডেটা অ্যাক্সেস করতে ব্যবহার করা যেতে পারে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-3918 এ-30745403 উচ্চ সমস্ত নেক্সাস 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 5 আগস্ট, 2016

Wi-Fi-এ পরিষেবার দুর্বলতা অস্বীকার করা

Wi-Fi-এ পরিষেবার দুর্বলতা অস্বীকার করার ফলে একটি স্থানীয় আনুমানিক আক্রমণকারীকে একটি হটস্পট তৈরি করতে এবং একটি ডিভাইস রিবুট করতে সক্ষম করতে পারে৷ পরিষেবার অস্থায়ী দূরবর্তী অস্বীকৃতির সম্ভাবনার কারণে এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-3882 A-29464811 উচ্চ সমস্ত নেক্সাস 6.0, 6.0.1, 7.0 জুন 17, 2016

জিপিএসে পরিষেবার দুর্বলতা অস্বীকার করা

জিপিএস কম্পোনেন্টে পরিষেবার দুর্বলতা অস্বীকার করা একটি দূরবর্তী আক্রমণকারীকে একটি ডিভাইস হ্যাং বা রিবুট করতে সক্ষম করতে পারে। পরিষেবার অস্থায়ী দূরবর্তী অস্বীকৃতির সম্ভাবনার কারণে এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-5348 এ-29555864 উচ্চ সমস্ত নেক্সাস 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 জুন 20, 2016

মিডিয়াসার্ভারে পরিষেবার দুর্বলতা অস্বীকার করা

মিডিয়াসার্ভারে পরিষেবার দুর্বলতা অস্বীকার করা হলে একজন আক্রমণকারীকে ডিভাইস হ্যাং বা রিবুট করার জন্য একটি বিশেষভাবে তৈরি করা ফাইল ব্যবহার করতে সক্ষম করে। দূরবর্তী পরিষেবা অস্বীকার করার সম্ভাবনার কারণে এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-3920 এ-30744884 উচ্চ সমস্ত নেক্সাস 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 5 আগস্ট, 2016

ফ্রেমওয়ার্ক লিসেনারে বিশেষাধিকার দুর্বলতার উচ্চতা

ফ্রেমওয়ার্ক লিসেনারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি বিশেষাধিকারপ্রাপ্ত প্রক্রিয়ার প্রেক্ষাপটে স্বেচ্ছাচারী কোড কার্যকর করতে একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-3921 এ-29831647 পরিমিত সমস্ত নেক্সাস 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 25 জুন, 2016

টেলিফোনিতে বিশেষাধিকার দুর্বলতার উচ্চতা

টেলিফোনিতে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি বিশেষাধিকারপ্রাপ্ত প্রক্রিয়ার প্রেক্ষাপটে নির্বিচারে কোড চালানোর জন্য একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-3922 এ-30202619 পরিমিত সমস্ত নেক্সাস 6.0, 6.0.1, 7.0 জুলাই 17, 2016

অ্যাক্সেসিবিলিটি পরিষেবাগুলিতে বিশেষাধিকার দুর্বলতার উচ্চতা

অ্যাক্সেসিবিলিটি পরিষেবাগুলিতে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে ডিভাইসে অপ্রত্যাশিত স্পর্শ ইভেন্ট তৈরি করতে সক্ষম করতে পারে যা ব্যবহারকারীর স্পষ্ট সম্মতি ছাড়াই অনুমতি ডায়ালগ গ্রহণকারী অ্যাপ্লিকেশনগুলির দিকে নিয়ে যেতে পারে৷ এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটি ব্যবহারকারীর ইন্টারঅ্যাকশন প্রয়োজনীয়তার একটি স্থানীয় বাইপাস যা সাধারণত ব্যবহারকারীর সূচনা বা ব্যবহারকারীর অনুমতির প্রয়োজন হয়।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-3923 এ-30647115 পরিমিত সমস্ত নেক্সাস 7.0 গুগল অভ্যন্তরীণ

মিডিয়া সার্ভারে তথ্য প্রকাশের দুর্বলতা

মিডিয়াসার্ভারে একটি তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে তার অনুমতি স্তরের বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটি অনুমতি ছাড়াই সংবেদনশীল ডেটা অ্যাক্সেস করতে ব্যবহার করা যেতে পারে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-3924 এ-30204301 পরিমিত সমস্ত নেক্সাস 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 18 জুলাই, 2016

Wi-Fi-এ পরিষেবার দুর্বলতা অস্বীকার করা

ওয়াই-ফাই পরিষেবাতে পরিষেবার দুর্বলতা অস্বীকার করা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে Wi-Fi কলিং প্রতিরোধ করতে সক্ষম করতে পারে৷ অ্যাপ্লিকেশন কার্যকারিতার পরিষেবা অস্বীকার করার সম্ভাবনার কারণে এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-3925 এ-30230534 পরিমিত সমস্ত নেক্সাস 6.0, 6.0.1, 7.0 গুগল অভ্যন্তরীণ

2016-10-05 নিরাপত্তা প্যাচ লেভেল—ভালনারেবিলিটি বিশদ

নীচের বিভাগগুলিতে, আমরা 2016-10-05 প্যাচ স্তরে প্রযোজ্য প্রতিটি নিরাপত্তা দুর্বলতার জন্য বিশদ প্রদান করি। সমস্যাটির একটি বিবরণ, একটি তীব্রতার যুক্তি, এবং CVE সহ একটি টেবিল, সংশ্লিষ্ট রেফারেন্স, তীব্রতা, আপডেট করা নেক্সাস ডিভাইস, আপডেট করা AOSP সংস্করণ (যেখানে প্রযোজ্য), এবং রিপোর্ট করা তারিখ রয়েছে। উপলব্ধ হলে, আমরা AOSP পরিবর্তনের তালিকার মতো বাগ আইডিতে সমস্যাটির সমাধানকারী সর্বজনীন পরিবর্তনকে লিঙ্ক করব। যখন একাধিক পরিবর্তন একটি একক বাগের সাথে সম্পর্কিত হয়, তখন বাগ আইডি অনুসরণকারী সংখ্যার সাথে অতিরিক্ত উল্লেখ সংযুক্ত করা হয়।

কার্নেল ASN.1 ডিকোডারে দূরবর্তী কোড কার্যকর করার দুর্বলতা

কার্নেল ASN.1 ডিকোডারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। স্থানীয় স্থায়ী ডিভাইস সমঝোতার সম্ভাবনার কারণে এই সমস্যাটিকে জটিল হিসাবে রেট করা হয়েছে, যার জন্য ডিভাইসটি মেরামত করার জন্য অপারেটিং সিস্টেমকে রিফ্ল্যাশ করার প্রয়োজন হতে পারে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-0758 এ-29814470
আপস্ট্রিম কার্নেল
সমালোচনামূলক Nexus 5X, Nexus 6P 12 মে, 2016

কার্নেল নেটওয়ার্কিং সাবসিস্টেমে রিমোট কোড এক্সিকিউশন দুর্বলতা

কার্নেল নেটওয়ার্কিং সাবসিস্টেমে একটি দূরবর্তী কোড কার্যকর করার দুর্বলতা একটি দূরবর্তী আক্রমণকারীকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। স্থানীয় স্থায়ী ডিভাইস সমঝোতার সম্ভাবনার কারণে এই সমস্যাটিকে জটিল হিসাবে রেট করা হয়েছে, যার জন্য ডিভাইসটি মেরামত করার জন্য অপারেটিং সিস্টেমকে রিফ্ল্যাশ করার প্রয়োজন হতে পারে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-7117 এ-30515201
আপস্ট্রিম কার্নেল
সমালোচনামূলক সমস্ত নেক্সাস গুগল অভ্যন্তরীণ

MediaTek ভিডিও ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

MediaTek ভিডিও ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। স্থানীয় স্থায়ী ডিভাইস সমঝোতার সম্ভাবনার কারণে এই সমস্যাটিকে জটিল হিসাবে রেট করা হয়েছে, যার জন্য ডিভাইসটি মেরামত করার জন্য অপারেটিং সিস্টেমকে রিফ্ল্যাশ করার প্রয়োজন হতে পারে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-3928 A-30019362*
M-ALPS02829384
সমালোচনামূলক কোনোটিই নয় 6 জুলাই, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

কার্নেল শেয়ার্ড মেমরি ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

কার্নেল শেয়ার্ড মেমরি ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। স্থানীয় স্থায়ী ডিভাইস সমঝোতার সম্ভাবনার কারণে এই সমস্যাটিকে জটিল হিসাবে রেট করা হয়েছে, যার জন্য ডিভাইসটি মেরামত করার জন্য অপারেটিং সিস্টেমকে রিফ্ল্যাশ করার প্রয়োজন হতে পারে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-5340 এ-30652312
QC-CR#1008948
সমালোচনামূলক Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Android One জুলাই 26, 2016

কোয়ালকম উপাদানে দুর্বলতা

নিচের সারণীতে নিরাপত্তা দুর্বলতা রয়েছে যা Qualcomm উপাদানগুলিকে প্রভাবিত করে এবং Qualcomm AMSS মার্চ 2016 এবং Qualcomm AMSS এপ্রিল 2016 নিরাপত্তা বুলেটিনে আরও বিস্তারিতভাবে বর্ণনা করা হয়েছে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-3926 A-28823953* সমালোচনামূলক Nexus 5, Nexus 5X, Nexus 6, Nexus 6P কোয়ালকম অভ্যন্তরীণ
CVE-2016-3927 A-28823244* সমালোচনামূলক Nexus 5X, Nexus 6P কোয়ালকম অভ্যন্তরীণ
CVE-2016-3929 A-28823675* উচ্চ Nexus 5X, Nexus 6P কোয়ালকম অভ্যন্তরীণ

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

কোয়ালকম নেটওয়ার্কিং কম্পোনেন্টে বিশেষাধিকার দুর্বলতার উচ্চতা

কোয়ালকম নেটওয়ার্কিং কম্পোনেন্টে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-2059 এ-27045580
QC-CR#974577
উচ্চ Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Android One ফেব্রুয়ারী 4, 2016

NVIDIA MMC পরীক্ষা ড্রাইভারে বিশেষাধিকারের দুর্বলতার উচ্চতা

NVIDIA MMC পরীক্ষা ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-3930 A-28760138*
N-CVE-2016-3930
উচ্চ নেক্সাস 9 12 মে, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

Qualcomm QSEE কমিউনিকেটর ড্রাইভারে বিশেষাধিকারের দুর্বলতার উচ্চতা

Qualcomm QSEE কমিউনিকেটর ড্রাইভারে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-3931 এ-29157595
QC-CR#1036418
উচ্চ Nexus 5X, Nexus 6, Nexus 6P, Android One জুন 4, 2016

মিডিয়াসার্ভারে বিশেষাধিকার দুর্বলতার উচ্চতা

মিডিয়াসার্ভারে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে একটি সুবিধাপ্রাপ্ত প্রক্রিয়ার প্রেক্ষাপটে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি উন্নত ক্ষমতাগুলিতে স্থানীয় অ্যাক্সেস পেতে ব্যবহার করা যেতে পারে, যা সাধারণত তৃতীয় পক্ষের অ্যাপ্লিকেশনে অ্যাক্সেসযোগ্য নয়।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-3932 এ-29161895
M-ALPS02770870
উচ্চ কোনোটিই নয় জুন 6, 2016
CVE-2016-3933 A-29421408*
N-CVE-2016-3933
উচ্চ Nexus 9, Pixel C জুন 14, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

Qualcomm ক্যামেরা ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

Qualcomm ক্যামেরা ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে স্বেচ্ছাচারী কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-3903 এ-29513227
QC-CR#1040857
উচ্চ Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Android One জুন 20, 2016
CVE-2016-3934 A-30102557
QC-CR#789704
উচ্চ Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Android One 12 জুলাই, 2016

Qualcomm সাউন্ড ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

Qualcomm সাউন্ড ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে স্বেচ্ছাচারী কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2015-8951 এ-30142668
QC-CR#948902
QC-CR#948902
উচ্চ Nexus 5X, Nexus 6P, Android One জুন 20, 2016

Qualcomm ক্রিপ্টো ইঞ্জিন ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

Qualcomm ক্রিপ্টোগ্রাফিক ইঞ্জিন ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা কার্নেলের প্রেক্ষাপটে নির্বিচারে কোড চালানোর জন্য একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-3901 A-29999161
QC-CR#1046434
উচ্চ Nexus 5X, Nexus 6, Nexus 6P, Android One 6 জুলাই, 2016
CVE-2016-3935 এ-29999665
QC-CR#1046507
উচ্চ Nexus 5X, Nexus 6, Nexus 6P, Android One 6 জুলাই, 2016

MediaTek ভিডিও ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

MediaTek ভিডিও ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-3936 A-30019037*
M-ALPS02829568
উচ্চ কোনোটিই নয় 6 জুলাই, 2016
CVE-2016-3937 A-30030994*
M-ALPS02834874
উচ্চ কোনোটিই নয় 7 জুলাই, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

Qualcomm ভিডিও ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

Qualcomm ভিডিও ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-3938 এ-30019716
QC-CR#1049232
উচ্চ Nexus 5X, Nexus 6, Nexus 6P, Android One 7 জুলাই, 2016
CVE-2016-3939 এ-30874196
QC-CR#1001224
উচ্চ Nexus 5X, Nexus 6, Nexus 6P, Android One আগস্ট 15, 2016

Synaptics টাচস্ক্রিন ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

Synaptics টাচস্ক্রিন ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-3940 A-30141991* উচ্চ Nexus 6P, Android One 12 জুলাই, 2016
CVE-2016-6672 A-30537088* উচ্চ Nexus 5X জুলাই 31, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

এনভিআইডিআইএ ক্যামেরা ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

NVIDIA ক্যামেরা ড্রাইভারে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রেক্ষাপটে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-6673 A-30204201*
N-CVE-2016-6673
উচ্চ নেক্সাস 9 জুলাই 17, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

সিস্টেম_সার্ভারে বিশেষাধিকার দুর্বলতার উচ্চতা

সিস্টেম_সার্ভারে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে একটি সুবিধাপ্রাপ্ত প্রক্রিয়ার প্রেক্ষাপটে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি উন্নত ক্ষমতাগুলিতে স্থানীয় অ্যাক্সেস পেতে ব্যবহার করা যেতে পারে, যা সাধারণত তৃতীয় পক্ষের অ্যাপ্লিকেশনে অ্যাক্সেসযোগ্য নয়।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-6674 A-30445380* উচ্চ সমস্ত নেক্সাস জুলাই 26, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

Qualcomm Wi-Fi ড্রাইভারে বিশেষাধিকারের দুর্বলতার উচ্চতা

কোয়ালকম ওয়াই-ফাই ড্রাইভারে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-3905 এ-28061823
QC-CR#1001449
উচ্চ Nexus 5X গুগল অভ্যন্তরীণ
CVE-2016-6675 এ-30873776
QC-CR#1000861
উচ্চ Nexus 5X, Android One আগস্ট 15, 2016
CVE-2016-6676 এ-30874066
QC-CR#1000853
উচ্চ Nexus 5X, Android One আগস্ট 15, 2016
CVE-2016-5342 এ-30878283
QC-CR#1032174
উচ্চ অ্যান্ড্রয়েড ওয়ান আগস্ট 15, 2016

কার্নেল কর্মক্ষমতা সাবসিস্টেমে বিশেষাধিকার দুর্বলতার উচ্চতা

কার্নেল পারফরম্যান্স সাবসিস্টেমে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে স্বেচ্ছাচারী কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2015-8955 এ-29508816
আপস্ট্রিম কার্নেল
উচ্চ Nexus 5X, Nexus 6P, Pixel C, Android One গুগল অভ্যন্তরীণ

কার্নেল ION সাবসিস্টেমে তথ্য প্রকাশের দুর্বলতা

কার্নেল ION সাবসিস্টেমের একটি তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে তার অনুমতি স্তরের বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি ব্যবহারকারীর স্পষ্ট অনুমতি ছাড়াই সংবেদনশীল ডেটা অ্যাক্সেস করতে ব্যবহার করা যেতে পারে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2015-8950 এ-29795245
QC-CR#1041735
উচ্চ Nexus 5, Nexus 5X, Nexus 6, Nexus 6P 12 মে, 2016

NVIDIA GPU ড্রাইভারে তথ্য প্রকাশের দুর্বলতা

NVIDIA GPU ড্রাইভারে একটি তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে তার অনুমতি স্তরের বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-6677 A-30259955*
N-CVE-2016-6677
উচ্চ নেক্সাস 9 জুলাই 19, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

কোয়ালকম ক্যারেক্টার ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

কোয়ালকম ক্যারেক্টার ড্রাইভারে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রেক্ষাপটে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন এবং দুর্বল কোডটি বর্তমানে অ্যাক্সেসযোগ্য নয়৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2015-0572 এ-29156684
QC-CR#848489
পরিমিত Nexus 5X, Nexus 6P 28 মে, 2016

Qualcomm সাউন্ড ড্রাইভারে তথ্য প্রকাশের দুর্বলতা

Qualcomm সাউন্ড ড্রাইভারে তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে অনুমতির মাত্রার বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-3860 এ-29323142
QC-CR#1038127
পরিমিত Nexus 5X, Nexus 6P, Android One 13 জুন, 2016

Motorola USBNet ড্রাইভারে তথ্য প্রকাশের দুর্বলতা

Motorola USBNet ড্রাইভারে তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে অনুমতির মাত্রার বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-6678 A-29914434* পরিমিত নেক্সাস 6 জুন 30, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

Qualcomm উপাদানে তথ্য প্রকাশের দুর্বলতা

সাউন্ড ড্রাইভার, আইপিএ ড্রাইভার এবং ওয়াই-ফাই ড্রাইভার সহ কোয়ালকম উপাদানগুলিতে একটি তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে তার অনুমতি স্তরের বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-6679 এ-29915601
QC-CR#1000913 [ 2 ]
পরিমিত Nexus 5X, Android One জুন 30, 2016
CVE-2016-3902 A-29953313*
QC-CR#1044072
পরিমিত Nexus 5X, Nexus 6P, 2 জুলাই, 2016
CVE-2016-6680 A-29982678*
QC-CR#1048052
পরিমিত Nexus 5X, Android One 3 জুলাই, 2016
CVE-2016-6681 এ-30152182
QC-CR#1049521
পরিমিত Nexus 5X, Nexus 6P, Android One 14 জুলাই, 2016
CVE-2016-6682 এ-30152501
QC-CR#1049615
পরিমিত Nexus 5X, Nexus 6P, Android One 14 জুলাই, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

কার্নেল উপাদানে তথ্য প্রকাশের দুর্বলতা

বাইন্ডার, সিঙ্ক, ব্লুটুথ এবং সাউন্ড ড্রাইভার সহ কার্নেল উপাদানগুলিতে একটি তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে তার অনুমতি স্তরের বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-6683 A-30143283* পরিমিত সমস্ত নেক্সাস 13 জুলাই, 2016
CVE-2016-6684 A-30148243* পরিমিত Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Nexus Player, Android One 13 জুলাই, 2016
CVE-2015-8956 A-30149612* পরিমিত Nexus 5, Nexus 6P, Android One 14 জুলাই, 2016
CVE-2016-6685 A-30402628* পরিমিত Nexus 6P 25 জুলাই, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

NVIDIA প্রোফাইলারে তথ্য প্রকাশের দুর্বলতা

NVIDIA প্রোফাইলারে একটি তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে তার অনুমতি স্তরের বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-6686 A-30163101*
N-CVE-2016-6686
পরিমিত নেক্সাস 9 15 জুলাই, 2016
CVE-2016-6687 A-30162222*
N-CVE-2016-6687
পরিমিত নেক্সাস 9 15 জুলাই, 2016
CVE-2016-6688 A-30593080*
N-CVE-2016-6688
পরিমিত নেক্সাস 9 2 আগস্ট, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

কার্নেলে তথ্য প্রকাশের দুর্বলতা

বাইন্ডারে একটি তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে তার অনুমতি স্তরের বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-6689 A-30768347* পরিমিত সমস্ত নেক্সাস 9 আগস্ট, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

কার্নেল নেটওয়ার্কিং সাবসিস্টেমে পরিষেবার দুর্বলতা অস্বীকার করা

কার্নেল নেটওয়ার্কিং সাবসিস্টেমে পরিষেবার দুর্বলতা অস্বীকার করা একজন আক্রমণকারীকে TCP সংযোগগুলিতে অ্যাক্সেস ব্লক করতে এবং পরিষেবার অস্থায়ী দূরবর্তী অস্বীকারের কারণ হতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ সেলুলার পরিষেবাগুলি এখনও উপলব্ধ এবং ডিভাইসটি এখনও ব্যবহারযোগ্য৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-5696 A-30809774
আপস্ট্রিম কার্নেল
পরিমিত Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Nexus Player, Pixel C, Android One 12 জুলাই, 2016

কার্নেল সাউন্ড ড্রাইভারে পরিষেবার দুর্বলতা অস্বীকার করা

কার্নেলে পরিষেবার দুর্বলতা অস্বীকার করার ফলে একটি স্থানীয় দূষিত অ্যাপ্লিকেশন ডিভাইস রিবুট করতে পারে। এই সমস্যাটিকে নিম্ন হিসাবে রেট করা হয়েছে কারণ এটি পরিষেবার অস্থায়ী অস্বীকৃতি৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-6690 A-28838221* কম Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus Player 18 মে, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

কোয়ালকম উপাদানে দুর্বলতা

নীচের টেবিলে নিরাপত্তা দুর্বলতার একটি তালিকা রয়েছে যা Qualcomm উপাদানগুলিকে প্রভাবিত করে৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Nexus ডিভাইস তারিখ রিপোর্ট
CVE-2016-6691 QC-CR#978452 উচ্চ কোনোটিই নয় জুলাই 2016
CVE-2016-6692 QC-CR#1004933 উচ্চ কোনোটিই নয় আগস্ট 2016
CVE-2016-6693 QC-CR#1027585 উচ্চ কোনোটিই নয় আগস্ট 2016
CVE-2016-6694 QC-CR#1033525 উচ্চ কোনোটিই নয় আগস্ট 2016
CVE-2016-6695 QC-CR#1033540 উচ্চ কোনোটিই নয় আগস্ট 2016
CVE-2016-6696 QC-CR#1041130 উচ্চ কোনোটিই নয় আগস্ট 2016
CVE-2016-5344 QC-CR#993650 পরিমিত কোনোটিই নয় আগস্ট 2016
CVE-2016-5343 QC-CR#1010081 পরিমিত কোনোটিই নয় আগস্ট 2016

সাধারণ প্রশ্ন ও উত্তর

এই বিভাগটি সাধারণ প্রশ্নের উত্তর দেয় যা এই বুলেটিন পড়ার পরে হতে পারে।

1. এই সমস্যাগুলি সমাধান করার জন্য আমার ডিভাইস আপডেট করা হয়েছে কিনা তা আমি কীভাবে নির্ধারণ করব?

2016-10-01 এর নিরাপত্তা প্যাচ স্তর বা তার পরে 2016-10-01 নিরাপত্তা প্যাচ স্ট্রিং স্তরের সাথে সম্পর্কিত সমস্ত সমস্যার সমাধান করে। 2016-10-05 এর নিরাপত্তা প্যাচ স্তর বা তার পরে 2016-10-05 নিরাপত্তা প্যাচ স্ট্রিং স্তরের সাথে সম্পর্কিত সমস্ত সমস্যার সমাধান করে। কিভাবে নিরাপত্তা প্যাচ স্তর পরীক্ষা করতে নির্দেশাবলীর জন্য সহায়তা কেন্দ্র পড়ুন. এই আপডেটগুলি অন্তর্ভুক্ত করে এমন ডিভাইস নির্মাতাদের প্যাচ স্ট্রিং লেভেল সেট করা উচিত: [ro.build.version.security_patch]:[2016-10-01] বা [ro.build.version.security_patch]:[2016-10-05]।

2. কেন এই বুলেটিনে দুটি নিরাপত্তা প্যাচ স্তরের স্ট্রিং আছে?

এই বুলেটিনে দুটি নিরাপত্তা প্যাচ স্তরের স্ট্রিং রয়েছে যাতে Android অংশীদারদের দুর্বলতার একটি উপসেটকে আরও দ্রুত ঠিক করার নমনীয়তা থাকে যা সমস্ত Android ডিভাইসে একই রকম। Android অংশীদারদের এই বুলেটিনে সমস্ত সমস্যা সমাধান করতে এবং সর্বশেষ নিরাপত্তা প্যাচ স্তরের স্ট্রিং ব্যবহার করতে উত্সাহিত করা হয়৷

যে ডিভাইসগুলি 5 অক্টোবর, 2016-এর নিরাপত্তা প্যাচ স্তর ব্যবহার করে বা নতুন সেগুলিকে অবশ্যই এই (এবং পূর্ববর্তী) নিরাপত্তা বুলেটিনে সমস্ত প্রযোজ্য প্যাচ অন্তর্ভুক্ত করতে হবে৷

যে ডিভাইসগুলি 1 অক্টোবর, 2016 নিরাপত্তা প্যাচ স্তর ব্যবহার করে সেগুলিতে অবশ্যই সেই নিরাপত্তা প্যাচ স্তরের সাথে সম্পর্কিত সমস্ত সমস্যা এবং সেইসাথে পূর্ববর্তী নিরাপত্তা বুলেটিনে রিপোর্ট করা সমস্ত সমস্যার সমাধান অন্তর্ভুক্ত করতে হবে।

3. প্রতিটি সমস্যা দ্বারা কোন Nexus ডিভাইসগুলি প্রভাবিত হবে তা আমি কীভাবে নির্ধারণ করব?

2016-10-01 এবং 2016-10-05 নিরাপত্তা দুর্বলতার বিবরণ বিভাগে, প্রতিটি টেবিলে একটি আপডেট করা Nexus ডিভাইস কলাম রয়েছে যা প্রতিটি সমস্যার জন্য আপডেট করা প্রভাবিত Nexus ডিভাইসগুলির পরিসরকে কভার করে। এই কলামে কয়েকটি বিকল্প রয়েছে:

  • সমস্ত নেক্সাস ডিভাইস : যদি কোনও সমস্যা সমস্ত নেক্সাস ডিভাইসকে প্রভাবিত করে, তবে আপডেট করা নেক্সাস ডিভাইস কলামে টেবিলটিতে "সমস্ত নেক্সাস" থাকবে। "সমস্ত Nexus" নিম্নলিখিত সমর্থিত ডিভাইসগুলিকে এনক্যাপসুলেট করে: Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player এবং Pixel C।
  • কিছু নেক্সাস ডিভাইস : যদি কোনো সমস্যা সমস্ত নেক্সাস ডিভাইসকে প্রভাবিত না করে, ক্ষতিগ্রস্ত নেক্সাস ডিভাইসগুলি আপডেট করা নেক্সাস ডিভাইস কলামে তালিকাভুক্ত করা হয়।
  • কোনো নেক্সাস ডিভাইস নেই : যদি অ্যান্ড্রয়েড 7.0 চালিত কোনো নেক্সাস ডিভাইস সমস্যা দ্বারা প্রভাবিত না হয়, তবে আপডেট করা নেক্সাস ডিভাইস কলামে টেবিলটিতে "কোনটিই নয়" থাকবে।

4. রেফারেন্স কলামের এন্ট্রিগুলি কিসের সাথে মানচিত্র করে?

দুর্বলতার বিবরণ সারণীর রেফারেন্স কলামের অধীনে এন্ট্রিতে একটি উপসর্গ থাকতে পারে যে সংস্থার রেফারেন্স মানটি চিহ্নিত করে। এই উপসর্গগুলি নিম্নরূপ মানচিত্র:

উপসর্গ রেফারেন্স
ক- অ্যান্ড্রয়েড বাগ আইডি
QC- কোয়ালকম রেফারেন্স নম্বর
এম- মিডিয়াটেক রেফারেন্স নম্বর
এন- NVIDIA রেফারেন্স নম্বর
খ- ব্রডকম রেফারেন্স নম্বর

রিভিশন

  • অক্টোবর 03, 2016: বুলেটিন প্রকাশিত।
  • অক্টোবর 04, 2016: CVE-2016-3920, CVE-2016-6693, CVE-2016-6694, CVE-2016-6695, এবং CVE-2016-666-এর জন্য AOSP লিঙ্ক এবং আপডেট বৈশিষ্ট্যগুলি অন্তর্ভুক্ত করতে বুলেটিন সংশোধন করা হয়েছে।