Android নিরাপত্তা বুলেটিন—এপ্রিল 2017

সেভ করা পৃষ্ঠা গুছিয়ে রাখতে 'সংগ্রহ' ব্যবহার করুন আপনার পছন্দ অনুযায়ী কন্টেন্ট সেভ করুন ও সঠিক বিভাগে রাখুন।

প্রকাশিত এপ্রিল 03, 2017 | 17 আগস্ট, 2017 আপডেট করা হয়েছে

অ্যান্ড্রয়েড সিকিউরিটি বুলেটিনে অ্যান্ড্রয়েড ডিভাইসগুলিকে প্রভাবিত করে এমন নিরাপত্তা দুর্বলতার বিবরণ রয়েছে৷ বুলেটিনের পাশাপাশি, আমরা ওভার-দ্য-এয়ার (OTA) আপডেটের মাধ্যমে Nexus ডিভাইসে একটি নিরাপত্তা আপডেট প্রকাশ করেছি। গুগল ডিভাইসের ফার্মওয়্যারের ছবিগুলোও গুগল ডেভেলপার সাইটে প্রকাশ করা হয়েছে। 05 এপ্রিল, 2017 বা তার পরে নিরাপত্তা প্যাচ স্তরগুলি এই সমস্ত সমস্যার সমাধান করে৷ একটি ডিভাইসের নিরাপত্তা প্যাচ স্তর কিভাবে চেক করতে হয় তা জানতে Pixel এবং Nexus আপডেটের সময়সূচী পড়ুন।

06 মার্চ, 2017 বা তার আগে বুলেটিনে বর্ণিত সমস্যাগুলির বিষয়ে অংশীদারদের অবহিত করা হয়েছিল৷ এই সমস্যাগুলির জন্য সোর্স কোড প্যাচগুলি অ্যান্ড্রয়েড ওপেন সোর্স প্রজেক্ট (AOSP) সংগ্রহস্থলে প্রকাশ করা হয়েছে এবং এই বুলেটিন থেকে লিঙ্ক করা হয়েছে৷ এই বুলেটিনে AOSP-এর বাইরের প্যাচগুলির লিঙ্কও রয়েছে৷

এই সমস্যাগুলির মধ্যে সবচেয়ে গুরুতর হল একটি গুরুতর নিরাপত্তা দুর্বলতা যা মিডিয়া ফাইলগুলি প্রক্রিয়া করার সময় ইমেল, ওয়েব ব্রাউজিং এবং এমএমএসের মতো একাধিক পদ্ধতির মাধ্যমে প্রভাবিত ডিভাইসে দূরবর্তী কোড কার্যকর করতে পারে। প্ল্যাটফর্ম এবং পরিষেবার প্রশমনগুলি উন্নয়নের উদ্দেশ্যে অক্ষম করা হয়েছে বা সফলভাবে বাইপাস করা হয়েছে বলে ধরে নিয়ে, দুর্বলতাকে কাজে লাগানোর প্রভাবের উপর ভিত্তি করে তীব্রতা মূল্যায়ন করা হয়।

আমাদের কাছে এই নতুন রিপোর্ট করা সমস্যাগুলির সক্রিয় গ্রাহক শোষণ বা অপব্যবহারের কোনও রিপোর্ট নেই। Android নিরাপত্তা প্ল্যাটফর্ম সুরক্ষা এবং SafetyNet- এর মতো পরিষেবা সুরক্ষা সম্পর্কে বিশদ বিবরণের জন্য Android এবং Google পরিষেবা প্রশমন বিভাগটি পড়ুন, যা Android প্ল্যাটফর্মের নিরাপত্তা উন্নত করে৷

আমরা সমস্ত গ্রাহকদের তাদের ডিভাইসে এই আপডেটগুলি গ্রহণ করতে উত্সাহিত করি৷

ঘোষণা

  • এই বুলেটিনে দুটি নিরাপত্তা প্যাচ স্তরের স্ট্রিং রয়েছে যা Android অংশীদারদের আরও দ্রুত দুর্বলতার একটি উপসেট ঠিক করার জন্য নমনীয়তা প্রদান করে যা সমস্ত Android ডিভাইসে একই রকম। অতিরিক্ত তথ্যের জন্য সাধারণ প্রশ্ন এবং উত্তর দেখুন:
    • 2017-04-01 : আংশিক নিরাপত্তা প্যাচ স্তরের স্ট্রিং। এই নিরাপত্তা প্যাচ স্তরের স্ট্রিংটি নির্দেশ করে যে 2017-04-01 (এবং সমস্ত পূর্ববর্তী নিরাপত্তা প্যাচ স্তরের স্ট্রিং) এর সাথে সম্পর্কিত সমস্ত সমস্যা সমাধান করা হয়েছে৷
    • 2017-04-05 : সম্পূর্ণ নিরাপত্তা প্যাচ স্তরের স্ট্রিং। এই নিরাপত্তা প্যাচ স্তরের স্ট্রিংটি নির্দেশ করে যে 2017-04-01 এবং 2017-04-05 (এবং পূর্ববর্তী সমস্ত নিরাপত্তা প্যাচ স্তরের স্ট্রিং) এর সাথে সম্পর্কিত সমস্ত সমস্যা সমাধান করা হয়েছে৷
  • সমর্থিত Google ডিভাইসগুলি এপ্রিল 05, 2017 নিরাপত্তা প্যাচ স্তরের সাথে একটি একক OTA আপডেট পাবে৷

অ্যান্ড্রয়েড এবং গুগল সার্ভিস মিটিগেশন

এটি Android নিরাপত্তা প্ল্যাটফর্ম এবং SafetyNet এর মতো পরিষেবা সুরক্ষা দ্বারা প্রদত্ত প্রশমনের একটি সারাংশ। এই ক্ষমতাগুলি Android-এ নিরাপত্তার দুর্বলতাগুলি সফলভাবে কাজে লাগানোর সম্ভাবনা কমিয়ে দেয়৷

  • অ্যান্ড্রয়েড প্ল্যাটফর্মের নতুন সংস্করণে বর্ধিতকরণের মাধ্যমে অ্যান্ড্রয়েডে অনেক সমস্যার জন্য শোষণকে আরও কঠিন করা হয়েছে। আমরা সকল ব্যবহারকারীকে যেখানে সম্ভব Android এর সর্বশেষ সংস্করণে আপডেট করতে উৎসাহিত করি।
  • Android সিকিউরিটি টিম সক্রিয়ভাবে Verify Apps এবং SafetyNet এর সাথে অপব্যবহারের জন্য নিরীক্ষণ করে, যা ব্যবহারকারীদের সম্ভাব্য ক্ষতিকারক অ্যাপ্লিকেশন সম্পর্কে সতর্ক করার জন্য ডিজাইন করা হয়েছে৷ Google মোবাইল পরিষেবাগুলির সাথে ডিভাইসগুলিতে ডিফল্টরূপে অ্যাপগুলি যাচাই করা সক্রিয় থাকে এবং বিশেষ করে ব্যবহারকারীদের জন্য গুরুত্বপূর্ণ যারা Google Play এর বাইরে থেকে অ্যাপ্লিকেশনগুলি ইনস্টল করেন৷ ডিভাইস রুট করার টুলগুলি Google Play-এর মধ্যে নিষিদ্ধ, কিন্তু ভেরিফাই অ্যাপ্লিকেশানগুলি ব্যবহারকারীদের সতর্ক করে যখন তারা একটি শনাক্ত রুটিং অ্যাপ্লিকেশন ইনস্টল করার চেষ্টা করে—সেটি যেখান থেকেই আসুক না কেন। উপরন্তু, ভেরিফাই অ্যাপ্লিকেশানগুলি পরিচিত দূষিত অ্যাপ্লিকেশনগুলির ইনস্টলেশন সনাক্ত এবং ব্লক করার চেষ্টা করে যা একটি বিশেষাধিকার বৃদ্ধির দুর্বলতাকে কাজে লাগায়৷ যদি এই ধরনের একটি অ্যাপ্লিকেশন ইতিমধ্যেই ইনস্টল করা হয়ে থাকে, তবে ভেরিফাই অ্যাপ্লিকেশানগুলি ব্যবহারকারীকে অবহিত করবে এবং সনাক্ত করা অ্যাপ্লিকেশনটি সরানোর চেষ্টা করবে৷
  • উপযুক্ত হিসাবে, Google Hangouts এবং Messenger অ্যাপ্লিকেশনগুলি মিডিয়া সার্ভারের মতো প্রক্রিয়াগুলিতে স্বয়ংক্রিয়ভাবে মিডিয়া পাস করে না।

স্বীকৃতি

আমরা এই গবেষকদের তাদের অবদানের জন্য ধন্যবাদ জানাতে চাই:

  • শেলফিশ গ্রিল দলের অরবিন্দ মাচিরি (ডনফোস): CVE-2016-5349
  • Xuanwu Lab এর Daxing Guo ( @freener0 ), Tencent: CVE-2017-0585, CVE-2017-0553
  • ডেরেক ( @derrekr6 ) এবং স্কট বাউয়ার: CVE-2017-0576
  • প্রোজেক্ট জিরোর গ্যাল বেনিয়ামিনি: CVE-2017-0571, CVE-2017-0570, CVE-2017-0572, CVE-2017-0569, CVE-2017-0561
  • Gengjia Chen ( @chengjia4574 ) এবং IceSword Lab, Qihoo 360 Technology Co. Ltd. এর pjf: CVE-2017-6426, CVE-2017-0581, CVE-2017-0329, CVE-2017, CVE-2017, CVE261-0326 CVE-2017-0573
  • আলফা টিমের গুয়াং গং (龚广) ( @oldfresher ), Qihoo 360 Technology Co. Ltd.: CVE-2017-0547
  • আলফা টিমের হাও চেন এবং গুয়াং গং, কিহু 360 প্রযুক্তি কোং লিমিটেড: CVE-2017-6424, CVE-2017-0584, CVE-2017-0454, CVE-2017-0574, CVE-2017-0575, CVE-2017-0575 -0567
  • ইয়ান ফস্টার ( @lanrat ): CVE-2017-0554
  • ট্রেন্ড মাইক্রো ইনকর্পোরেটেডের জ্যাক ট্যাং: CVE-2017-0579
  • Qihoo 360 Skyeye ল্যাবসের জিয়ানজুন দাই ( @Jioun_dai ) : CVE-2017-0559, CVE-2017-0541
  • Jianqiang Zhao ( @jianqiangzhao ) এবং IceSword Lab, Qihoo 360 এর pjf: CVE-2017-6425, CVE-2016-5346
  • C0RE টিমের লুবো ঝাং ( zlbzlb815@163.com ) এবং IceSword Lab, Qihoo 360 Technology Co. Ltd. এর Yonggang Guo ( @guoygang ): CVE-2017-0564
  • গুগলের মার্ক স্যালিজিন : CVE-2017-0558
  • টেসলার প্রোডাক্ট সিকিউরিটি টিমের মাইক অ্যান্ডারসন (@ম্যান্ডারবট) এবং নাথান ক্র্যান্ডাল ( @নেটক্রে ) : CVE-2017-0327, CVE-2017-0328
  • আলিবাবা মোবাইল সিকিউরিটি গ্রুপের পেং জিয়াও, চেংমিং ইয়াং, নিং ইউ, চাও ইয়াং এবং ইয়াং গান: CVE-2017-0565
  • পেংফেই ডিং (丁鹏飞), চেনফু বাও (包沉浮), এবং বাইদু এক্স-ল্যাবের লেনক্স ওয়েই (韦韬) (百度安全实验室): CVE-2016-10236
  • কিদান হে (何淇丹 - @flanker_hqd ) KeenLab, Tencent: CVE-2017-0544, CVE-2017-0325
  • আলেফ রিসার্চের রোই হে ( @roeehay ), HCL টেকনোলজিস: CVE-2017-0582, CVE-2017-0563
  • স্কট বাউয়ার ( @ScottyBauer1 ): CVE-2017-0562, CVE-2017-0339
  • TrendMicro মোবাইল থ্রেট রিসার্চ টিমের সেভেন শেন ( @lingtongshen ): CVE-2016-10231, CVE-2017-0578, CVE-2017-0586
  • টিম বেকার: CVE-2017-0546
  • উমা শঙ্কর প্রধান ( @umasankar_iitd ): CVE-2017-0560
  • মোবাইল থ্রেট রেসপন্স টিমের VEO ( @VYSEa ), ট্রেন্ড মাইক্রো : CVE-2017-0555, CVE-2017-0538, CVE-2017-0539, CVE-2017-0557, CVE-2017-0556
  • আলিবাবা ইনকর্পোরেটেডের উইচাও সান ( @সানব্লেট ): CVE-2017-0549
  • ওয়েনলিন ইয়াং ( @wenlin_yang ), গুয়াং গং ( @oldfresher ), এবং আলফা টিমের হাও চেন, Qihoo 360 Technology Co. Ltd.: CVE-2017-0580, CVE-2017-0577
  • Qihoo 360 টেকনোলজি কোং লিমিটেডের চেংডু সিকিউরিটি রেসপন্স সেন্টার থেকে জিনু হান : CVE-2017-0548
  • গুগলের জুবিন মিত্রা: CVE-2017-0462

2017-04-01 নিরাপত্তা প্যাচ স্তর — দুর্বলতার বিবরণ

নীচের বিভাগে, আমরা 2017-04-01 প্যাচ স্তরে প্রযোজ্য প্রতিটি নিরাপত্তা দুর্বলতার জন্য বিশদ বিবরণ প্রদান করি। সমস্যাটির একটি বিবরণ, একটি তীব্রতার যুক্তি, এবং CVE সহ একটি টেবিল, সংশ্লিষ্ট উল্লেখ, তীব্রতা, আপডেট করা Google ডিভাইস, আপডেট করা AOSP সংস্করণ (যেখানে প্রযোজ্য), এবং তারিখ রিপোর্ট করা হয়েছে। উপলব্ধ হলে, আমরা AOSP পরিবর্তনের তালিকার মতো বাগ আইডিতে সমস্যাটির সমাধানকারী সর্বজনীন পরিবর্তনকে লিঙ্ক করব। যখন একাধিক পরিবর্তন একটি একক বাগের সাথে সম্পর্কিত হয়, তখন বাগ আইডি অনুসরণকারী সংখ্যার সাথে অতিরিক্ত উল্লেখ সংযুক্ত করা হয়।

মিডিয়াসার্ভারে রিমোট কোড এক্সিকিউশন দুর্বলতা

মিডিয়া সার্ভারে একটি দূরবর্তী কোড কার্যকর করার দুর্বলতা একটি আক্রমণকারীকে একটি বিশেষভাবে তৈরি করা ফাইল ব্যবহার করে মিডিয়া ফাইল এবং ডেটা প্রক্রিয়াকরণের সময় মেমরি দুর্নীতির কারণ হতে পারে। মিডিয়াসার্ভার প্রক্রিয়ার প্রেক্ষাপটে দূরবর্তী কোড কার্যকর করার সম্ভাবনার কারণে এই সমস্যাটিকে সমালোচনামূলক হিসাবে রেট করা হয়েছে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2017-0538 এ-33641588 সমালোচনামূলক সব 6.0, 6.0.1, 7.0, 7.1.1 13 ডিসেম্বর, 2016
CVE-2017-0539 এ-33864300 সমালোচনামূলক সব 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 23 ডিসেম্বর, 2016
CVE-2017-0541 এ-34031018 সমালোচনামূলক সব 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 জানুয়ারী 1, 2017
CVE-2017-0542 A-33934721 সমালোচনামূলক সব 6.0, 6.0.1, 7.0, 7.1.1 গুগল অভ্যন্তরীণ
CVE-2017-0543 এ-34097866 সমালোচনামূলক সব 6.0, 6.0.1, 7.0, 7.1.1 গুগল অভ্যন্তরীণ

ক্যামেরাবেসে বিশেষাধিকার দুর্বলতার উচ্চতা

CameraBase-এ বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ায় স্থানীয় নির্বিচারে কোড সম্পাদন।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2017-0544 A-31992879 উচ্চ সব 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 6 অক্টোবর, 2016

অডিও সার্ভারে বিশেষাধিকারের দুর্বলতার উচ্চতা

অডিওসার্ভারে বিশেষাধিকার দুর্বলতার উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার প্রেক্ষাপটে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি উন্নত ক্ষমতাগুলিতে স্থানীয় অ্যাক্সেস পেতে ব্যবহার করা যেতে পারে, যা সাধারণত তৃতীয় পক্ষের অ্যাপ্লিকেশনে অ্যাক্সেসযোগ্য নয়।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2017-0545 এ-32591350 উচ্চ সব 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 31 অক্টোবর, 2016

সারফেসফ্লিংগারে বিশেষাধিকারের দুর্বলতার উচ্চতা

SurfaceFlinger-এ বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি বিশেষাধিকারপ্রাপ্ত প্রক্রিয়ার প্রেক্ষাপটে নির্বিচারে কোড চালানোর জন্য একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি উন্নত ক্ষমতাগুলিতে স্থানীয় অ্যাক্সেস পেতে ব্যবহার করা যেতে পারে, যা সাধারণত তৃতীয় পক্ষের অ্যাপ্লিকেশনে অ্যাক্সেসযোগ্য নয়।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2017-0546 এ-32628763 উচ্চ সব 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 2শে নভেম্বর, 2016

মিডিয়া সার্ভারে তথ্য প্রকাশের দুর্বলতা

মিডিয়াসার্ভারে একটি তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে তার অনুমতি স্তরের বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটি উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি অপারেটিং সিস্টেম সুরক্ষার জন্য একটি সাধারণ বাইপাস যা অন্যান্য অ্যাপ্লিকেশন থেকে অ্যাপ্লিকেশন ডেটা আলাদা করে৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2017-0547 এ-33861560 উচ্চ সব 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 22 ডিসেম্বর, 2016

লিবস্কিয়াতে পরিষেবার দুর্বলতা অস্বীকার করা

লিবস্কিয়াতে পরিষেবার দুর্বলতার একটি দূরবর্তী অস্বীকৃতি একটি আক্রমণকারীকে একটি বিশেষভাবে তৈরি করা ফাইল ব্যবহার করতে সক্ষম করতে পারে যাতে একটি ডিভাইস হ্যাং বা রিবুট হয়। দূরবর্তী পরিষেবা অস্বীকার করার সম্ভাবনার কারণে এই সমস্যাটিকে উচ্চ তীব্রতা হিসাবে রেট করা হয়েছে৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2017-0548 এ-33251605 উচ্চ সব 7.0, 7.1.1 নভেম্বর 29, 2016

মিডিয়াসার্ভারে পরিষেবার দুর্বলতা অস্বীকার করা

মিডিয়াসার্ভারে পরিষেবার দুর্বলতার একটি দূরবর্তী অস্বীকৃতি একটি আক্রমণকারীকে একটি বিশেষভাবে তৈরি করা ফাইল ব্যবহার করতে সক্ষম করতে পারে যাতে একটি ডিভাইস হ্যাং বা রিবুট হয়। দূরবর্তী পরিষেবা অস্বীকার করার সম্ভাবনার কারণে এই সমস্যাটিকে উচ্চ তীব্রতা হিসাবে রেট করা হয়েছে৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2017-0549 এ-33818508 উচ্চ সব 6.0, 6.0.1, 7.0, 7.1.1 20 ডিসেম্বর, 2016
CVE-2017-0550 এ-33933140 উচ্চ সব 6.0, 6.0.1, 7.0, 7.1.1 গুগল অভ্যন্তরীণ
CVE-2017-0551 A-34097231 [ 2 ] উচ্চ সব 6.0, 6.0.1, 7.0, 7.1.1 গুগল অভ্যন্তরীণ
CVE-2017-0552 A-34097915 উচ্চ সব 6.0, 6.0.1, 7.0, 7.1.1 গুগল অভ্যন্তরীণ

libnl-এ বিশেষাধিকার দুর্বলতার উচ্চতা

libnl-এ বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে Wi-Fi পরিষেবার প্রেক্ষাপটে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করতে হবে এবং বর্তমান প্ল্যাটফর্ম কনফিগারেশন দ্বারা প্রশমিত হয়৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2017-0553 এ-32342065 পরিমিত সব 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 21 অক্টোবর, 2016

টেলিফোনিতে বিশেষাধিকার দুর্বলতার উচ্চতা

টেলিফোনি কম্পোনেন্টে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে অনুমতির স্তরের বাইরের ক্ষমতা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটি উন্নত ক্ষমতাগুলিতে অ্যাক্সেস পেতে ব্যবহার করা যেতে পারে, যা সাধারণত তৃতীয় পক্ষের অ্যাপ্লিকেশনে অ্যাক্সেসযোগ্য নয়।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2017-0554 A-33815946 [ 2 ] পরিমিত সব 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 20 ডিসেম্বর, 2016

মিডিয়া সার্ভারে তথ্য প্রকাশের দুর্বলতা

মিডিয়াসার্ভারে একটি তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে তার অনুমতি স্তরের বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটি অনুমতি ছাড়াই ডেটা অ্যাক্সেস করতে ব্যবহার করা যেতে পারে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2017-0555 এ-33551775 পরিমিত সব 6.0, 6.0.1, 7.0, 7.1.1 12 ডিসেম্বর, 2016
CVE-2017-0556 এ-৩৪০৯৩৯৫২ পরিমিত সব 6.0, 6.0.1, 7.0, 7.1.1 4 জানুয়ারী, 2017
CVE-2017-0557 এ-34093073 পরিমিত সব 6.0, 6.0.1, 7.0, 7.1.1 4 জানুয়ারী, 2017
CVE-2017-0558 এ-34056274 পরিমিত সব 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 গুগল অভ্যন্তরীণ

লিবস্কিয়ায় তথ্য প্রকাশের দুর্বলতা

লিবস্কিয়াতে একটি তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে তার অনুমতি স্তরের বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটি অনুমতি ছাড়াই ডেটা অ্যাক্সেস করতে ব্যবহার করা যেতে পারে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2017-0559 A-33897722 পরিমিত সব 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 25 ডিসেম্বর, 2016

ফ্যাক্টরি রিসেটে তথ্য প্রকাশের দুর্বলতা

ফ্যাক্টরি রিসেট প্রক্রিয়ায় একটি তথ্য প্রকাশের দুর্বলতা স্থানীয় দূষিত আক্রমণকারীকে পূর্ববর্তী মালিকের ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। ডিভাইস সুরক্ষা বাইপাস করার সম্ভাবনার কারণে এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2017-0560 এ-30681079 পরিমিত সব 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 গুগল অভ্যন্তরীণ

2017-04-05 নিরাপত্তা প্যাচ স্তর — দুর্বলতার বিবরণ

নীচের বিভাগগুলিতে, আমরা 2017-04-05 প্যাচ স্তরে প্রযোজ্য প্রতিটি নিরাপত্তা দুর্বলতার জন্য বিশদ প্রদান করি। সমস্যাটির একটি বর্ণনা, একটি তীব্রতার যুক্তি এবং CVE সহ একটি টেবিল, সংশ্লিষ্ট রেফারেন্স, তীব্রতা, আপডেট করা Google ডিভাইস, আপডেট করা AOSP সংস্করণ (যেখানে প্রযোজ্য), এবং রিপোর্ট করা তারিখ রয়েছে। উপলব্ধ হলে, আমরা AOSP পরিবর্তনের তালিকার মতো বাগ আইডিতে সমস্যাটির সমাধানকারী সর্বজনীন পরিবর্তনকে লিঙ্ক করব। যখন একাধিক পরিবর্তন একটি একক বাগের সাথে সম্পর্কিত হয়, তখন বাগ আইডি অনুসরণকারী সংখ্যার সাথে অতিরিক্ত উল্লেখ সংযুক্ত করা হয়।

ব্রডকম ওয়াই-ফাই ফার্মওয়্যারে রিমোট কোড এক্সিকিউশন দুর্বলতা

ব্রডকম ওয়াই-ফাই ফার্মওয়্যারে একটি দূরবর্তী কোড কার্যকর করার দুর্বলতা একটি দূরবর্তী আক্রমণকারীকে Wi-Fi SoC-এর প্রেক্ষাপটে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। Wi-Fi SoC-এর প্রেক্ষাপটে দূরবর্তী কোড কার্যকর করার সম্ভাবনার কারণে এই সমস্যাটিকে জটিল হিসাবে রেট করা হয়েছে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0561 A-34199105*
B-RB#110814
সমালোচনামূলক Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player জানুয়ারী 9, 2017

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

Qualcomm ক্রিপ্টো ইঞ্জিন ড্রাইভারে রিমোট কোড এক্সিকিউশন দুর্বলতা

Qualcomm ক্রিপ্টো ইঞ্জিন ড্রাইভারের একটি দূরবর্তী কোড কার্যকর করার দুর্বলতা একটি দূরবর্তী আক্রমণকারীকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। কার্নেলের প্রেক্ষাপটে দূরবর্তী কোড কার্যকর করার সম্ভাবনার কারণে এই সমস্যাটিকে জটিল হিসাবে রেট করা হয়েছে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2016-10230 A-34389927
QC-CR#1091408
সমালোচনামূলক Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One জানুয়ারী 10, 2017

কার্নেল নেটওয়ার্কিং সাবসিস্টেমে রিমোট কোড এক্সিকিউশন দুর্বলতা

কার্নেল নেটওয়ার্কিং সাবসিস্টেমে একটি দূরবর্তী কোড কার্যকর করার দুর্বলতা একটি দূরবর্তী আক্রমণকারীকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। কার্নেলের প্রেক্ষাপটে দূরবর্তী কোড কার্যকর করার সম্ভাবনার কারণে এই সমস্যাটিকে জটিল হিসাবে রেট করা হয়েছে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2016-10229 এ-32813456
আপস্ট্রিম কার্নেল
সমালোচনামূলক Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Pixel C, Android One, Nexus Player গুগল অভ্যন্তরীণ

মিডিয়াটেক টাচস্ক্রিন ড্রাইভারে বিশেষাধিকারের দুর্বলতার উচ্চতা

মিডিয়াটেক টাচস্ক্রিন ড্রাইভারে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। স্থানীয় স্থায়ী ডিভাইস সমঝোতার সম্ভাবনার কারণে এই সমস্যাটিকে জটিল হিসাবে রেট করা হয়েছে, যার জন্য ডিভাইসটি মেরামত করার জন্য অপারেটিং সিস্টেমকে রিফ্ল্যাশ করার প্রয়োজন হতে পারে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0562 A-30202425*
M-ALPS02898189
সমালোচনামূলক* কোনটিই** 16 জুলাই, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

** সমর্থিত Google ডিভাইসগুলি Android 7.0 বা তার পরে যে সমস্ত উপলব্ধ আপডেটগুলি ইনস্টল করেছে তারা এই দুর্বলতার দ্বারা প্রভাবিত হয় না৷

এইচটিসি টাচস্ক্রিন ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

এইচটিসি টাচস্ক্রিন ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। স্থানীয় স্থায়ী ডিভাইস সমঝোতার সম্ভাবনার কারণে এই সমস্যাটিকে জটিল হিসাবে রেট করা হয়েছে, যার জন্য ডিভাইসটি মেরামত করার জন্য অপারেটিং সিস্টেমকে রিফ্ল্যাশ করার প্রয়োজন হতে পারে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0563 A-32089409*
সমালোচনামূলক নেক্সাস 9 9 অক্টোবর, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

কার্নেল আইওন সাবসিস্টেমে বিশেষাধিকার দুর্বলতার উচ্চতা

কার্নেল ION সাবসিস্টেমে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে স্বেচ্ছাচারী কোড কার্যকর করতে সক্ষম করতে পারে। স্থানীয় স্থায়ী ডিভাইস সমঝোতার সম্ভাবনার কারণে এই সমস্যাটিকে জটিল হিসাবে রেট করা হয়েছে, যার জন্য ডিভাইসটি মেরামত করার জন্য অপারেটিং সিস্টেমকে রিফ্ল্যাশ করার প্রয়োজন হতে পারে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0564 A-34276203*
সমালোচনামূলক Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Pixel C, Android One, Nexus Player জানুয়ারী 12, 2017

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

কোয়ালকম উপাদানে দুর্বলতা

এই দুর্বলতাগুলি Qualcomm উপাদানগুলিকে প্রভাবিত করে এবং Qualcomm AMSS অক্টোবর 2016 নিরাপত্তা বুলেটিনে আরও বিশদে বর্ণনা করা হয়েছে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2016-10237 A-31628601**
QC-CR#1046751
সমালোচনামূলক কোনটিই** কোয়ালকম অভ্যন্তরীণ
CVE-2016-10238 A-35358527**
QC-CR#1042558
সমালোচনামূলক কোনটিই না *** কোয়ালকম অভ্যন্তরীণ
CVE-2016-10239 A-31624618**
QC-CR#1032929
উচ্চ পিক্সেল, পিক্সেল এক্সএল কোয়ালকম অভ্যন্তরীণ

* এই দুর্বলতার জন্য তীব্রতা রেটিং বিক্রেতা দ্বারা নির্ধারিত হয়েছিল।

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

*** অ্যান্ড্রয়েড 7.0 বা তার পরবর্তী সংস্করণে সমর্থিত Google ডিভাইসগুলি যে সমস্ত উপলব্ধ আপডেটগুলি ইনস্টল করেছে সেগুলি এই দুর্বলতার দ্বারা প্রভাবিত হয় না৷

v8 এ রিমোট কোড এক্সিকিউশন দুর্বলতা

v8-এ একটি দূরবর্তী কোড কার্যকর করার দুর্বলতা দূরবর্তী আক্রমণকারীদের একটি সুবিধাপ্রাপ্ত প্রক্রিয়ার প্রেক্ষাপটে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। ওয়েবসাইটগুলিতে দূরবর্তী কোড কার্যকর করার সম্ভাবনার কারণে এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-5129 এ-29178923 উচ্চ কোনটিই না* 6.0, 6.0.1, 7.0 20 জুলাই, 2016

* Android 7.0 বা তার পরবর্তী সংস্করণে সমর্থিত Google ডিভাইসগুলি যে সমস্ত উপলব্ধ আপডেটগুলি ইনস্টল করেছে সেগুলি এই দুর্বলতার দ্বারা প্রভাবিত হয় না৷

ফ্রিটাইপে রিমোট কোড এক্সিকিউশন দুর্বলতা

ফ্রিটাইপে একটি দূরবর্তী কোড কার্যকর করার দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে একটি বিশেষভাবে তৈরি করা ফন্ট লোড করতে সক্ষম করতে পারে যাতে একটি সুবিধাবিহীন প্রক্রিয়ায় মেমরি দুর্নীতির কারণ হয়৷ এই লাইব্রেরি ব্যবহার করে এমন একটি অ্যাপ্লিকেশনে দূরবর্তী কোড কার্যকর করার সম্ভাবনার কারণে এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস AOSP সংস্করণ আপডেট করা হয়েছে তারিখ রিপোর্ট
CVE-2016-10244 এ-31470908 উচ্চ কোনটিই না* 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 13 সেপ্টেম্বর, 2016

* Android 7.0 বা তার পরবর্তী সংস্করণে সমর্থিত Google ডিভাইসগুলি যে সমস্ত উপলব্ধ আপডেটগুলি ইনস্টল করেছে সেগুলি এই দুর্বলতার দ্বারা প্রভাবিত হয় না৷

কার্নেল সাউন্ড সাবসিস্টেমে বিশেষাধিকার দুর্বলতার উচ্চতা

কার্নেল সাউন্ড সাবসিস্টেমে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2014-4656 এ-34464977
আপস্ট্রিম কার্নেল
উচ্চ নেক্সাস 6, নেক্সাস প্লেয়ার জুন 26, 2014

এনভিআইডিআইএ ক্রিপ্টো ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

NVIDIA ক্রিপ্টো ড্রাইভারে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0339 A-27930566*
N-CVE-2017-0339
উচ্চ নেক্সাস 9 29 মার্চ, 2016
CVE-2017-0332 A-33812508*
N-CVE-2017-0332
উচ্চ নেক্সাস 9 ডিসেম্বর 21, 2016
CVE-2017-0327 A-33893669*
N-CVE-2017-0327
উচ্চ নেক্সাস 9 24 ডিসেম্বর, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

মিডিয়াটেক থার্মাল ড্রাইভারে বিশেষাধিকারের দুর্বলতার উচ্চতা

মিডিয়াটেক থার্মাল ড্রাইভারে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0565 A-28175904*
M-ALPS02696516
উচ্চ কোনটিই** 11 এপ্রিল, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

** সমর্থিত Google ডিভাইসগুলি Android 7.0 বা তার পরে যে সমস্ত উপলব্ধ আপডেটগুলি ইনস্টল করেছে তারা এই দুর্বলতার দ্বারা প্রভাবিত হয় না৷

MediaTek ক্যামেরা ড্রাইভারের বিশেষাধিকার দুর্বলতার উচ্চতা

মিডিয়াটেক ক্যামেরা ড্রাইভারে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0566 A-28470975*
M-ALPS02696367
উচ্চ কোনটিই** এপ্রিল 29, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

** সমর্থিত Google ডিভাইসগুলি Android 7.0 বা তার পরে যে সমস্ত উপলব্ধ আপডেটগুলি ইনস্টল করেছে তারা এই দুর্বলতার দ্বারা প্রভাবিত হয় না৷

ব্রডকম ওয়াই-ফাই ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

ব্রডকম ওয়াই-ফাই ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0567 A-32125310*
B-RB#112575
উচ্চ Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player অক্টোবর 12, 2016
CVE-2017-0568 A-34197514*
B-RB#112600
উচ্চ Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player জানুয়ারী 9, 2017
CVE-2017-0569 A-34198729*
B-RB#110666
উচ্চ Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player জানুয়ারী 9, 2017
CVE-2017-0570 A-34199963*
B-RB#110688
উচ্চ Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player জানুয়ারী 9, 2017
CVE-2017-0571 A-34203305*
B-RB#111541
উচ্চ Nexus 6, Nexus 6P, Pixel C, Nexus Player জানুয়ারী 9, 2017
CVE-2017-0572 A-34198931*
B-RB#112597
উচ্চ কোনটিই** জানুয়ারী 9, 2017
CVE-2017-0573 A-34469904*
B-RB#91539
উচ্চ Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 18 জানুয়ারী, 2017
CVE-2017-0574 A-34624457*
B-RB#113189
উচ্চ Nexus 6, Nexus 6P, Nexus 9, Pixel C জানুয়ারী 22, 2017

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

** সমর্থিত Google ডিভাইসগুলি Android 7.0 বা তার পরে যে সমস্ত উপলব্ধ আপডেটগুলি ইনস্টল করেছে তারা এই দুর্বলতার দ্বারা প্রভাবিত হয় না৷

Qualcomm Wi-Fi ড্রাইভারে বিশেষাধিকারের দুর্বলতার উচ্চতা

কোয়ালকম ওয়াই-ফাই ড্রাইভারে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0575 A-32658595*
QC-CR#1103099
উচ্চ Nexus 5X, Pixel, Pixel XL নভেম্বর 3, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

NVIDIA I2C HID ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

NVIDIA I2C HID ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0325 A-33040280*
N-CVE-2017-0325
উচ্চ Nexus 9, Pixel C নভেম্বর 20, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

Qualcomm অডিও ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

Qualcomm অডিও ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0454 এ-33353700
QC-CR#1104067
উচ্চ Nexus 5X, Nexus 6P, Pixel, Pixel XL 5 ডিসেম্বর, 2016

Qualcomm ক্রিপ্টো ইঞ্জিন ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

Qualcomm ক্রিপ্টো ইঞ্জিন ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রেক্ষাপটে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0576 এ-33544431
QC-CR#1103089
উচ্চ Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 9 ডিসেম্বর, 2016

এইচটিসি টাচস্ক্রিন ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

এইচটিসি টাচস্ক্রিন ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0577 A-33842951*
উচ্চ কোনটিই** ডিসেম্বর 21, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

** সমর্থিত Google ডিভাইসগুলি Android 7.0 বা তার পরে যে সমস্ত উপলব্ধ আপডেটগুলি ইনস্টল করেছে তারা এই দুর্বলতার দ্বারা প্রভাবিত হয় না৷

ডিটিএস সাউন্ড ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

ডিটিএস সাউন্ড ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0578 A-33964406*
উচ্চ কোনটিই** 28 ডিসেম্বর, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

** সমর্থিত Google ডিভাইসগুলি Android 7.0 বা তার পরে যে সমস্ত উপলব্ধ আপডেটগুলি ইনস্টল করেছে তারা এই দুর্বলতার দ্বারা প্রভাবিত হয় না৷

Qualcomm সাউন্ড কোডেক ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

Qualcomm সাউন্ড কোডেক ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রেক্ষাপটে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2016-10231 A-33966912
QC-CR#1096799
উচ্চ পিক্সেল, পিক্সেল এক্সএল ডিসেম্বর 29, 2016

Qualcomm ভিডিও ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

Qualcomm ভিডিও ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0579 A-34125463*
QC-CR#1115406
উচ্চ Nexus 5X, Nexus 6P, Pixel, Pixel XL জানুয়ারী 5, 2017
CVE-2016-10232 এ-34386696
QC-CR#1024872 [2]
উচ্চ Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One জানুয়ারী 10, 2017
CVE-2016-10233 A-34389926
QC-CR#897452
উচ্চ কোনটিই** জানুয়ারী 10, 2017

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

** সমর্থিত Google ডিভাইসগুলি Android 7.0 বা তার পরে যে সমস্ত উপলব্ধ আপডেটগুলি ইনস্টল করেছে তারা এই দুর্বলতার দ্বারা প্রভাবিত হয় না৷

NVIDIA বুট এবং পাওয়ার ম্যানেজমেন্ট প্রসেসর ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

NVIDIA বুট এবং পাওয়ার ম্যানেজমেন্ট প্রসেসর ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে বুট এবং পাওয়ার ম্যানেজমেন্ট প্রসেসরের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0329 A-34115304*
N-CVE-2017-0329
উচ্চ পিক্সেল সি জানুয়ারী 5, 2017

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

Synaptics টাচস্ক্রিন ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

Synaptics Touchscreen ড্রাইভারে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0580 A-34325986*
উচ্চ কোনটিই** 16 জানুয়ারী, 2017
CVE-2017-0581 A-34614485*
উচ্চ কোনটিই** জানুয়ারী 22, 2017

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

** সমর্থিত Google ডিভাইসগুলি Android 7.0 বা তার পরে যে সমস্ত উপলব্ধ আপডেটগুলি ইনস্টল করেছে তারা এই দুর্বলতার দ্বারা প্রভাবিত হয় না৷

Qualcomm Seemp ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

Qualcomm Seemp ড্রাইভারে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0462 এ-33353601
QC-CR#1102288
উচ্চ পিক্সেল, পিক্সেল এক্সএল গুগল অভ্যন্তরীণ

Qualcomm Kyro L2 ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

Qualcomm Kyro L2 ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রেক্ষাপটে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-6423 এ-32831370
QC-CR#1103158
উচ্চ পিক্সেল, পিক্সেল এক্সএল গুগল অভ্যন্তরীণ

কার্নেল ফাইল সিস্টেমে বিশেষাধিকার দুর্বলতার উচ্চতা

কার্নেল ফাইল সিস্টেমে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে স্বেচ্ছাচারী কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2014-9922 এ-32761463
আপস্ট্রিম কার্নেল
উচ্চ Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Android One, Nexus Player 24 অক্টোবর, 2014

কার্নেল মেমরি সাবসিস্টেমে তথ্য প্রকাশের দুর্বলতা

কার্নেল মেমরি সাবসিস্টেমের একটি তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে তার অনুমতি স্তরের বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি ব্যবহারকারীর স্পষ্ট অনুমতি ছাড়াই সংবেদনশীল ডেটা অ্যাক্সেস করতে ব্যবহার করা যেতে পারে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2014-0206 এ-34465735
আপস্ট্রিম কার্নেল
উচ্চ নেক্সাস 6, নেক্সাস প্লেয়ার 6 মে, 2014

কার্নেল নেটওয়ার্কিং সাবসিস্টেমে তথ্য প্রকাশের দুর্বলতা

কার্নেল নেটওয়ার্কিং সাবসিস্টেমে একটি তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে তার অনুমতি স্তরের বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি ব্যবহারকারীর স্পষ্ট অনুমতি ছাড়াই সংবেদনশীল ডেটা অ্যাক্সেস করতে ব্যবহার করা যেতে পারে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2014-3145 A-34469585
আপস্ট্রিম কার্নেল [২]
উচ্চ নেক্সাস 6, নেক্সাস প্লেয়ার 9 মে, 2014

Qualcomm TrustZone-এ তথ্য প্রকাশের দুর্বলতা

Qualcomm TrustZone-এ তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে অনুমতির মাত্রার বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি ব্যবহারকারীর স্পষ্ট অনুমতি ছাড়াই সংবেদনশীল ডেটা অ্যাক্সেস করতে ব্যবহার করা যেতে পারে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2016-5349 এ-29083830
QC-CR#1021945 [2] [3] [4]
উচ্চ Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One জুন 1, 2016

Qualcomm IPA ড্রাইভারে তথ্য প্রকাশের দুর্বলতা

Qualcomm IPA ড্রাইভারের একটি তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে অনুমতির মাত্রার বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে কারণ এটি ব্যবহারকারীর স্পষ্ট অনুমতি ছাড়াই সংবেদনশীল ডেটা অ্যাক্সেস করতে ব্যবহার করা যেতে পারে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2016-10234 A-34390017
QC-CR#1069060 [2]
উচ্চ Nexus 5X, Nexus 6P, Pixel, Pixel XL জানুয়ারী 10, 2017

কার্নেল নেটওয়ার্কিং সাবসিস্টেমে পরিষেবার দুর্বলতা অস্বীকার করা

কার্নেল নেটওয়ার্কিং সাবসিস্টেমে পরিষেবার দুর্বলতা অস্বীকার করা একটি দূরবর্তী আক্রমণকারীকে একটি ডিভাইস হ্যাং বা রিবুট করার জন্য একটি বিশেষভাবে তৈরি করা নেটওয়ার্ক প্যাকেট ব্যবহার করতে সক্ষম করতে পারে। দূরবর্তী পরিষেবা অস্বীকার করার সম্ভাবনার কারণে এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2014-2706 এ-34160553
আপস্ট্রিম কার্নেল
উচ্চ নেক্সাস প্লেয়ার 1 এপ্রিল, 2014

কোয়ালকম ওয়াই-ফাই ড্রাইভারে পরিষেবার দুর্বলতা অস্বীকার

কোয়ালকম ওয়াই-ফাই ড্রাইভারে পরিষেবার দুর্বলতা অস্বীকার করা একজন আনুমানিক আক্রমণকারীকে ওয়াই-ফাই সাবসিস্টেমে পরিষেবা অস্বীকার করতে সক্ষম করতে পারে। দূরবর্তী পরিষেবা অস্বীকার করার সম্ভাবনার কারণে এই সমস্যাটিকে উচ্চ হিসাবে রেট করা হয়েছে৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2016-10235 A-34390620
QC-CR#1046409
উচ্চ কোনটিই** জানুয়ারী 10, 2017

** সমর্থিত Google ডিভাইসগুলি Android 7.0 বা তার পরে যে সমস্ত উপলব্ধ আপডেটগুলি ইনস্টল করেছে তারা এই দুর্বলতার দ্বারা প্রভাবিত হয় না৷

কার্নেল ফাইল সিস্টেমে বিশেষাধিকার দুর্বলতার উচ্চতা

কার্নেল ফাইল সিস্টেমে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে অনুমতির স্তরের বাইরে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করতে হবে এবং বর্তমান প্ল্যাটফর্ম কনফিগারেশন দ্বারা প্রশমিত হয়৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2016-7097 এ-32458736
আপস্ট্রিম কার্নেল
পরিমিত Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Nexus Player 28 আগস্ট, 2016

Qualcomm Wi-Fi ড্রাইভারে বিশেষাধিকারের দুর্বলতার উচ্চতা

কোয়ালকম ওয়াই-ফাই ড্রাইভারে বিশেষাধিকারের দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন এবং দুর্বলতার নির্দিষ্ট বিবরণের কারণে যা সমস্যার প্রভাবকে সীমিত করে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-6424 এ-32086742
QC-CR#1102648
পরিমিত Nexus 5X, Pixel, Pixel XL, Android One 9 অক্টোবর, 2016

ব্রডকম ওয়াই-ফাই ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

ব্রডকম ওয়াই-ফাই ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে নির্বিচারে কোড চালানোর জন্য সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করতে হবে এবং বর্তমান প্ল্যাটফর্ম কনফিগারেশন দ্বারা প্রশমিত হয়৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2016-8465 A-32474971*
B-RB#106053
পরিমিত Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player অক্টোবর 27, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

এইচটিসি OEM ফাস্টবুট কমান্ডে বিশেষাধিকার দুর্বলতার উচ্চতা

HTC OEM ফাস্টবুট কমান্ডে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে সেন্সর হাবের প্রেক্ষাপটে নির্বিচারে কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে আলাদা দুর্বলতার শোষণ প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0582 A-33178836*
পরিমিত নেক্সাস 9 নভেম্বর 28, 2016

* এই সমস্যার জন্য প্যাচ সর্বজনীনভাবে উপলব্ধ নয়। আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

Qualcomm CP অ্যাক্সেস ড্রাইভারে বিশেষাধিকার দুর্বলতার উচ্চতা

Qualcomm CP অ্যাক্সেস ড্রাইভারে বিশেষাধিকার দুর্বলতার একটি উচ্চতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে কার্নেলের প্রসঙ্গে স্বেচ্ছাচারী কোড কার্যকর করতে সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন এবং দুর্বলতার নির্দিষ্ট বিবরণের কারণে যা সমস্যার প্রভাবকে সীমিত করে।

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2017-0583 এ-32068683
QC-CR#1103788
পরিমিত Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One গুগল অভ্যন্তরীণ

কার্নেল মিডিয়া ড্রাইভারে তথ্য প্রকাশের দুর্বলতা

কার্নেল মিডিয়া ড্রাইভারে একটি তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে তার অনুমতি স্তরের বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। এই সমস্যাটিকে মধ্যপন্থী হিসাবে রেট করা হয়েছে কারণ এটির জন্য প্রথমে একটি বিশেষ সুবিধাপ্রাপ্ত প্রক্রিয়ার সাথে আপস করা প্রয়োজন৷

সিভিই তথ্যসূত্র নির্দয়তা আপডেট করা Google ডিভাইস তারিখ রিপোর্ট
CVE-2014-1739 এ-34460642
আপস্ট্রিম কার্নেল
পরিমিত নেক্সাস 6, নেক্সাস 9, নেক্সাস প্লেয়ার জুন 15, 2014

Qualcomm Wi-Fi ড্রাইভারে তথ্য প্রকাশের দুর্বলতা

Qualcomm Wi-Fi ড্রাইভারে তথ্য প্রকাশের দুর্বলতা একটি স্থানীয় দূষিত অ্যাপ্লিকেশনকে অনুমতির মাত্রার বাইরে ডেটা অ্যাক্সেস করতে সক্ষম করতে পারে। This issue is rated as Moderate because it first requires compromising a privileged process.

সিভিই তথ্যসূত্র নির্দয়তা Updated Google devices তারিখ রিপোর্ট
CVE-2017-0584 A-32074353*
QC-CR#1104731
পরিমিত Nexus 5X, Pixel, Pixel XL Oct 9, 2016

* The patch for this issue is not publicly available. আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

Information disclosure vulnerability in Broadcom Wi-Fi driver

An information disclosure vulnerability in the Broadcom Wi-Fi driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

সিভিই তথ্যসূত্র নির্দয়তা Updated Google devices তারিখ রিপোর্ট
CVE-2017-0585 A-32475556*
B-RB#112953
পরিমিত Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Oct 27, 2016

* The patch for this issue is not publicly available. আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

Information disclosure vulnerability in Qualcomm Avtimer driver

An information disclosure vulnerability in the Qualcomm Avtimer driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

সিভিই তথ্যসূত্র নির্দয়তা Updated Google devices তারিখ রিপোর্ট
CVE-2016-5346 A-32551280
QC-CR#1097878
পরিমিত Pixel, Pixel XL Oct 29, 2016

Information disclosure vulnerability in Qualcomm video driver

An information disclosure vulnerability in the Qualcomm video driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

সিভিই তথ্যসূত্র নির্দয়তা Updated Google devices তারিখ রিপোর্ট
CVE-2017-6425 A-32577085
QC-CR#1103689
পরিমিত Pixel, Pixel XL Oct 29, 2016

Information disclosure vulnerability in Qualcomm USB driver

An information disclosure vulnerability in the Qualcomm USB driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

সিভিই তথ্যসূত্র নির্দয়তা Updated Google devices তারিখ রিপোর্ট
CVE-2016-10236 A-33280689
QC-CR#1102418
পরিমিত Pixel, Pixel XL Nov 30, 2016

Information disclosure vulnerability in Qualcomm sound driver

An information disclosure vulnerability in the Qualcomm sound driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

সিভিই তথ্যসূত্র নির্দয়তা Updated Google devices তারিখ রিপোর্ট
CVE-2017-0586 A-33649808
QC-CR#1097569
পরিমিত Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Dec 13, 2016

Information disclosure vulnerability in Qualcomm SPMI driver

An information disclosure vulnerability in the Qualcomm SPMI driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

সিভিই তথ্যসূত্র নির্দয়তা Updated Google devices তারিখ রিপোর্ট
CVE-2017-6426 A-33644474
QC-CR#1106842
পরিমিত Pixel, Pixel XL Dec 14, 2016

Information disclosure vulnerability in NVIDIA crypto driver

An information disclosure vulnerability in the NVIDIA crypto driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

সিভিই তথ্যসূত্র নির্দয়তা Updated Google devices তারিখ রিপোর্ট
CVE-2017-0328 A-33898322*
N-CVE-2017-0328
পরিমিত None** Dec 24, 2016
CVE-2017-0330 A-33899858*
N-CVE-2017-0330
পরিমিত None** Dec 24, 2016

* The patch for this issue is not publicly available. আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Vulnerabilities in Qualcomm components

These vulnerabilities affecting Qualcomm components were released as part of Qualcomm AMSS security bulletins between 2014–2016. They are included in this Android security bulletin to associate their fixes with an Android security patch level.

সিভিই তথ্যসূত্র নির্দয়তা Updated Google devices তারিখ রিপোর্ট
CVE-2014-9931 A-35445101** সমালোচনামূলক None** Qualcomm internal
CVE-2014-9932 A-35434683** সমালোচনামূলক Pixel, Pixel XL Qualcomm internal
CVE-2014-9933 A-35442512** সমালোচনামূলক None** Qualcomm internal
CVE-2014-9934 A-35439275** সমালোচনামূলক None** Qualcomm internal
CVE-2014-9935 A-35444951** সমালোচনামূলক None** Qualcomm internal
CVE-2014-9936 A-35442420** সমালোচনামূলক None** Qualcomm internal
CVE-2014-9937 A-35445102** সমালোচনামূলক None** Qualcomm internal
CVE-2015-8995 A-35445002** সমালোচনামূলক None** Qualcomm internal
CVE-2015-8996 A-35444658** সমালোচনামূলক None** Qualcomm internal
CVE-2015-8997 A-35432947** সমালোচনামূলক None** Qualcomm internal
CVE-2015-8998 A-35441175** সমালোচনামূলক None** Qualcomm internal
CVE-2015-8999 A-35445401** সমালোচনামূলক None** Qualcomm internal
CVE-2015-9000 A-35441076** সমালোচনামূলক None** Qualcomm internal
CVE-2015-9001 A-35445400** সমালোচনামূলক None** Qualcomm internal
CVE-2015-9002 A-35442421** সমালোচনামূলক None** Qualcomm internal
CVE-2015-9003 A-35440626** সমালোচনামূলক None** Qualcomm internal
CVE-2016-10242 A-35434643** সমালোচনামূলক None** Qualcomm internal

* The severity rating for these vulnerabilities was determined by the vendor.

** The patch for this issue is not publicly available. আপডেটটি গুগল ডেভেলপার সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে রয়েছে৷

*** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

সাধারণ প্রশ্ন ও উত্তর

এই বিভাগটি সাধারণ প্রশ্নের উত্তর দেয় যা এই বুলেটিন পড়ার পরে হতে পারে।

1. এই সমস্যাগুলি সমাধান করার জন্য আমার ডিভাইস আপডেট করা হয়েছে কিনা তা আমি কীভাবে নির্ধারণ করব?

কিভাবে একটি ডিভাইসের নিরাপত্তা প্যাচ স্তর চেক করতে হয় তা জানতে, Pixel এবং Nexus আপডেট শিডিউলের নির্দেশাবলী পড়ুন।

  • Security patch levels of 2017-04-01 or later address all issues associated with the 2017-04-01 security patch level.
  • Security patch levels of 2017-04-05 or later address all issues associated with the 2017-04-05 security patch level and all previous patch levels.

এই আপডেটগুলি অন্তর্ভুক্ত করে এমন ডিভাইস নির্মাতাদের প্যাচ স্ট্রিং স্তর সেট করা উচিত:

  • [ro.build.version.security_patch]:[2017-04-01]
  • [ro.build.version.security_patch]:[2017-04-05]

2. কেন এই বুলেটিন দুটি নিরাপত্তা প্যাচ স্তর আছে?

এই বুলেটিনে দুটি নিরাপত্তা প্যাচ স্তর রয়েছে যাতে Android অংশীদারদের দুর্বলতাগুলির একটি উপসেটকে আরও দ্রুত ঠিক করার নমনীয়তা থাকে যা সমস্ত Android ডিভাইসে একই রকম। Android অংশীদারদের এই বুলেটিনে সমস্ত সমস্যা সমাধান করতে এবং সর্বশেষ নিরাপত্তা প্যাচ স্তর ব্যবহার করতে উত্সাহিত করা হয়৷

  • Devices that use the April 01, 2017 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins.
  • Devices that use the security patch level of April 05, 2017 or newer must include all applicable patches in this (and previous) security bulletins.

অংশীদারদের একটি একক আপডেটে তারা যে সমস্ত সমস্যার সমাধান করছে সেগুলিকে বান্ডিল করতে উত্সাহিত করা হয়৷

3. How do I determine which Google devices are affected by each issue?

In the 2017-04-01 and 2017-04-05 security vulnerability details sections, each table has an Updated Google devices column that covers the range of affected Google devices updated for each issue. এই কলামে কয়েকটি বিকল্প রয়েছে:

  • All Google devices : If an issue affects All and Pixel devices, the table will have "All" in the Updated Google devices column. "All" encapsulates the following supported devices : Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel, and Pixel XL.
  • Some Google devices : If an issue doesn't affect all Google devices, the affected Google devices are listed in the Updated Google devices column.
  • No Google devices : If no Google devices running Android 7.0 are affected by the issue, the table will have "None" in the Updated Google devices column.

4. What do the entries in the references column map to?

দুর্বলতার বিবরণ সারণীর রেফারেন্স কলামের অধীনে এন্ট্রিতে একটি উপসর্গ থাকতে পারে যে সংস্থার রেফারেন্স মানটি চিহ্নিত করে। These prefixes map as follows:

উপসর্গ রেফারেন্স
ক- অ্যান্ড্রয়েড বাগ আইডি
QC- কোয়ালকম রেফারেন্স নম্বর
এম- মিডিয়াটেক রেফারেন্স নম্বর
এন- NVIDIA রেফারেন্স নম্বর
খ- ব্রডকম রেফারেন্স নম্বর

রিভিশন

  • April 03, 2017: Bulletin published.
  • April 05, 2017: Bulletin revised to include AOSP links.
  • April 21, 2017: Attribution for CVE-2016-10231 and CVE-2017-0586 corrected.
  • April 27, 2017: CVE-2017-0540 removed from bulletin.
  • August 17, 2017: Bulletin revised to update reference numbers.