Android Güvenlik Bülteni—Mayıs 2017

Koleksiyonlar ile düzeninizi koruyun İçeriği tercihlerinize göre kaydedin ve kategorilere ayırın.

01 Mayıs 2017 tarihinde yayınlandı | 03 Ekim 2017'de güncellendi

Android Güvenlik Bülteni, Android cihazlarını etkileyen güvenlik açıklarının ayrıntılarını içerir. Bültenin yanı sıra, kablosuz (OTA) güncellemesi aracılığıyla Nexus cihazlarına yönelik bir güvenlik güncellemesi yayınladık. Google cihazı donanım yazılımı görüntüleri de Google Developer sitesinde yayınlandı. 05 Mayıs 2017 veya sonraki güvenlik yaması seviyeleri, tüm bu sorunları giderir. Bir cihazın güvenlik yama düzeyini nasıl kontrol edeceğinizi öğrenmek için Pixel ve Nexus güncelleme planına bakın.

Ortaklar, bültende açıklanan sorunlar hakkında 03 Nisan 2017 veya daha önce bilgilendirildi. Bu sorunlar için kaynak kodu yamaları Android Açık Kaynak Projesi (AOSP) deposunda yayınlandı ve bu bültenden bağlantı verildi. Bu bülten ayrıca AOSP dışındaki yamalara bağlantılar içerir.

Bu sorunlardan en ciddi olanı, medya dosyalarını işlerken e-posta, web'de gezinme ve MMS gibi birden çok yöntemle etkilenen bir cihazda uzaktan kod yürütülmesine olanak verebilecek bir Kritik güvenlik açığıdır. Önem derecesi değerlendirmesi , platform ve hizmet azaltmalarının geliştirme amaçları için devre dışı bırakıldığı veya başarılı bir şekilde atlandığı varsayılarak, güvenlik açığından yararlanmanın etkilenen bir cihaz üzerindeki etkisine dayanır.

Yeni bildirilen bu sorunların aktif müşteri istismarı veya kötüye kullanımı hakkında herhangi bir rapor almadık. Android platformunun güvenliğini artıran SafetyNet gibi Android güvenlik platformu korumaları ve hizmet korumaları hakkında ayrıntılı bilgi için Android ve Google hizmeti azaltma bölümüne bakın.

Tüm müşterilerimizi cihazlarında bu güncellemeleri kabul etmeye teşvik ediyoruz.

Duyurular

  • Bu bülten, Android iş ortaklarına tüm Android cihazlarda benzer bir güvenlik açığı alt kümesini daha hızlı düzeltme esnekliği sağlamak için iki güvenlik düzeltme eki düzeyinde dizeye sahiptir. Ek bilgi için Genel sorular ve yanıtlara bakın:
    • 2017-05-01 : Kısmi güvenlik yaması düzeyi dizesi. Bu güvenlik yaması düzeyi dizesi, 2017-05-01 (ve önceki tüm güvenlik yaması düzeyi dizeleri) ile ilişkili tüm sorunların ele alındığını gösterir.
    • 2017-05-05 : Güvenlik yaması düzeyi dizesini tamamlayın. Bu güvenlik yaması düzeyi dizesi, 2017-05-01 ve 2017-05-05 (ve önceki tüm güvenlik yaması düzeyi dizeleri) ile ilişkili tüm sorunların ele alındığını gösterir.
  • Desteklenen Google cihazları, 05 Mayıs 2017 güvenlik yaması düzeyiyle tek bir OTA güncellemesi alacaktır.

Android ve Google Hizmet Azaltıcıları

Bu, Android güvenlik platformu ve SafetyNet gibi hizmet korumaları tarafından sağlanan azaltmaların bir özetidir. Bu yetenekler, güvenlik açıklarından Android'de başarıyla yararlanma olasılığını azaltır.

  • Android platformunun daha yeni sürümlerinde yapılan geliştirmeler sayesinde Android'deki birçok sorundan yararlanma daha zor hale getirilmiştir. Tüm kullanıcıları, mümkün olduğunda Android'in en son sürümüne güncellemeye teşvik ediyoruz.
  • Android Güvenlik ekibi, kullanıcıları Zararlı Olabilecek Uygulamalar hakkında uyarmak için tasarlanmış olan Verify Apps ve SafetyNet ile kötüye kullanımı etkin bir şekilde izler. Uygulamaları Doğrula, Google Mobil Hizmetleri olan cihazlarda varsayılan olarak etkindir ve özellikle Google Play'in dışından uygulama yükleyen kullanıcılar için önemlidir. Google Play'de cihaz köklendirme araçları yasaktır, ancak Uygulamaları Doğrula, tespit edilen bir köklendirme uygulamasını yüklemeye çalıştıklarında, nereden gelirse gelsin kullanıcıları uyarır. Ayrıca, Verify Apps, bir ayrıcalık yükseltme güvenlik açığından yararlanan bilinen kötü amaçlı uygulamaların yüklenmesini belirlemeye ve engellemeye çalışır. Böyle bir uygulama zaten yüklenmişse, Uygulamaları Doğrula, kullanıcıyı bilgilendirecek ve algılanan uygulamayı kaldırmaya çalışacaktır.
  • Uygun olduğu şekilde, Google Hangouts ve Messenger uygulamaları, medyayı Mediaserver gibi işlemlere otomatik olarak iletmez.

Teşekkür

Bu araştırmacılara katkılarından dolayı teşekkür etmek isteriz:

  • Venustech ADlab: CVE-2017-0630
  • KeenLab'dan ( @keen_lab ), Di Shen ( @returnsme ), Tencent: CVE-2016-10287
  • Trend Micro'nun Ecular Xu (徐健): CVE-2017-0599, CVE-2017-0635
  • MS509Team'den En He ( @heeeeen4x ) ve Bo Liu: CVE- 2017-0601
  • Team Win Recovery Project'ten Ethan Yonker : CVE-2017-0493
  • Gengjia Chen ( @chengjia4574 ) ve IceSword Lab, Qihoo 360 Technology Co. Ltd'nin pjf'si: CVE-2016-10285, CVE-2016-10288, CVE-2016-10290, CVE-2017-0624, CVE-2017-0616, CVE -2017-0617, CVE-2016-10294, CVE-2016-10295, CVE-2016-10296
  • Tencent PC Manager'dan godzheng (郑文选@VirtualSeekers ): CVE-2017-0602
  • Urbana-Champaign'deki Illinois Üniversitesi'nden Güliz Seray Tuncay : CVE-2017-0593
  • Alfa Ekibinden Hao Chen ve Guang Gong, Qihoo 360 Technology Co. Ltd: CVE-2016-10283
  • Xiaomi Inc'den Juhu Nie, Yang Cheng, Nan Li ve Qiwu Huang: CVE-2016-10276
  • Michał Bednarski : CVE-2017-0598
  • Tesla'nın Ürün Güvenliği Ekibinden Nathan Crandall ( @natecray ): CVE-2017-0331, CVE-2017-0606
  • Niky1235 ( @jiych_guru ): CVE-2017-0603
  • Alibaba Mobile Security Group'un Peng Xiao, Chengming Yang, Ning You, Chao Yang ve Yang şarkısı: CVE-2016-10281, CVE-2016-10280
  • Aleph Research'ten Roee Hay ( @roeehay ) : CVE-2016-10277
  • Scott Bauer ( @ScottyBauer1 ): CVE-2016-10274
  • C0RE Ekibinden Tong Lin , Yuan-Tsung Lo ve Xuxian Jiang : CVE-2016-10291
  • Vasiliy Vasiliev: CVE-2017-0589
  • Mobile Threat Response Team'in VEO'su ( @VYSEa ), Trend Micro : CVE-2017-0590, CVE-2017-0587, CVE-2017-0600
  • Tencent Güvenlik Platformu Departmanından Xiling Gong: CVE-2017-0597
  • 360 Marvel Ekibinden Xingyuan Lin: CVE-2017-0627
  • Alibaba Inc'den Yong Wang (王勇) ( @ThomasKing2014 ): CVE-2017-0588
  • IceSword Lab'den Yonggang Guo ( @guoygang ), Qihoo 360 Technology Co. Ltd: CVE-2016-10289, CVE-2017-0465
  • Vulpecker Ekibinden Yu Pan, Qihoo 360 Technology Co. Ltd: CVE-2016-10282, CVE-2017-0615
  • Yu Pan ve Peide Zhang, Vulpecker Ekibi, Qihoo 360 Technology Co. Ltd: CVE-2017-0618, CVE-2017-0625

2017-05-01 güvenlik yaması düzeyi-Güvenlik açığı ayrıntıları

Aşağıdaki bölümlerde, 2017-05-01 yama düzeyi için geçerli olan güvenlik açıklarının her biri için ayrıntılar sunuyoruz. Sorunun açıklaması, önem derecesi gerekçesi ve CVE, ilgili referanslar, önem derecesi, güncellenmiş Google cihazları, güncellenmiş AOSP sürümleri (varsa) ve rapor edilen tarihi içeren bir tablo vardır. Mevcut olduğunda, sorunu ele alan genel değişikliği AOSP değişiklik listesi gibi hata kimliğine bağlayacağız. Birden fazla değişiklik tek bir hatayla ilgili olduğunda, hata kimliğini izleyen sayılara ek referanslar bağlanır.

Mediaserver'da uzaktan kod yürütme güvenlik açığı

Mediaserver'daki bir uzaktan kod yürütme güvenlik açığı, özel hazırlanmış bir dosya kullanan bir saldırganın medya dosyası ve veri işleme sırasında belleğin bozulmasına neden olabilir. Mediaserver süreci bağlamında uzaktan kod yürütme olasılığı nedeniyle bu sorun Kritik olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Güncellenmiş AOSP sürümleri Bildirilen tarih
CVE-2017-0587 A-35219737 kritik Herşey 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 4 Ocak 2017
CVE-2017-0588 A-34618607 kritik Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 21 Oca 2017
CVE-2017-0589 A-34897036 kritik Herşey 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 1 Şubat 2017
CVE-2017-0590 A-35039946 kritik Herşey 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 6 Şub 2017
CVE-2017-0591 A-34097672 kritik Herşey 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 Google dahili
CVE-2017-0592 A-34970788 kritik Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 Google dahili

Framework API'lerinde ayrıcalık yükselmesi güvenlik açığı

Framework API'lerinde bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın özel izinlere erişmesini sağlayabilir. Bu sorun, uygulama verilerini diğer uygulamalardan izole eden işletim sistemi korumaları için genel bir atlama olduğu için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Güncellenmiş AOSP sürümleri Bildirilen tarih
CVE-2017-0593 A-34114230 Yüksek Herşey 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 5 Ocak 2017

Mediaserver'da ayrıcalık yükselmesi güvenlik açığı

Mediaserver'daki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın ayrıcalıklı bir işlem bağlamında rasgele kod yürütmesine olanak sağlayabilir. Bu sorun Yüksek olarak derecelendirilmiştir, çünkü normalde bir üçüncü taraf uygulaması tarafından erişilemeyen yükseltilmiş yeteneklere yerel erişim elde etmek için kullanılabilir.

CVE Referanslar önem Google cihazları güncellendi Güncellenmiş AOSP sürümleri Bildirilen tarih
CVE-2017-0594 A-34617444 Yüksek Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 22 Oca 2017
CVE-2017-0595 A-34705519 Yüksek Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 24 Oca 2017
CVE-2017-0596 A-34749392 Yüksek Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 24 Oca 2017

Audioserver'da ayrıcalık yükselmesi güvenlik açığı

Audioserver'daki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın ayrıcalıklı bir işlem bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun Yüksek olarak derecelendirilmiştir, çünkü normalde bir üçüncü taraf uygulaması tarafından erişilemeyen yükseltilmiş yeteneklere yerel erişim elde etmek için kullanılabilir.

CVE Referanslar önem Google cihazları güncellendi Güncellenmiş AOSP sürümleri Bildirilen tarih
CVE-2017-0597 A-34749571 Yüksek Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 25 Oca 2017

Framework API'lerinde bilginin açığa çıkması güvenlik açığı

Framework API'lerinde bir bilginin açığa çıkması güvenlik açığı, yerel bir kötü amaçlı uygulamanın, uygulama verilerini diğer uygulamalardan izole eden işletim sistemi korumalarını atlamasına olanak verebilir. Bu sorun, uygulamanın erişimi olmayan verilere erişim sağlamak için kullanılabildiğinden Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Güncellenmiş AOSP sürümleri Bildirilen tarih
CVE-2017-0598 A-34128677 [ 2 ] Yüksek Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 6 Ocak 2017

Mediaserver'da hizmet reddi güvenlik açığı

Mediaserver'daki bir uzaktan hizmet reddi güvenlik açığı, bir saldırganın özel hazırlanmış bir dosyayı kullanarak aygıtın askıda kalmasına veya yeniden başlatılmasına neden olabilir. Bu sorun, uzaktan hizmet reddi olasılığı nedeniyle Yüksek önem derecesi olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Güncellenmiş AOSP sürümleri Bildirilen tarih
CVE-2017-0599 A-34672748 Yüksek Herşey 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 23 Oca 2017
CVE-2017-0600 A-35269635 Yüksek Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 10 Şub 2017

Bluetooth'ta ayrıcalık yükselmesi güvenlik açığı

Bluetooth'taki bir Ayrıcalık Yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın, kullanıcı izni olmadan bluetooth aracılığıyla paylaşılan zararlı dosyaları kabul etmesine olanak sağlayabilir. Bu sorun, kullanıcı etkileşimi gereksinimlerinin yerel olarak atlanması nedeniyle Orta olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Güncellenmiş AOSP sürümleri Bildirilen tarih
CVE-2017-0601 A-35258579 Ilıman Herşey 7.0, 7.1.1, 7.1.2 9 Şubat 2017

Dosya Tabanlı Şifrelemede bilginin açığa çıkması güvenlik açığı

Dosya Tabanlı Şifreleme'deki bir bilginin açığa çıkması güvenlik açığı, yerel kötü niyetli bir saldırganın kilit ekranı için işletim sistemi korumalarını atlamasına olanak verebilir. Bu sorun, kilit ekranını atlama olasılığı nedeniyle Orta olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Güncellenmiş AOSP sürümleri Bildirilen tarih
CVE-2017-0493 A-32793550 [ 2 ] [ 3 ] Ilıman Herşey 7.0, 7.1.1 9 Kasım 2016

Bluetooth'ta bilginin açığa çıkması güvenlik açığı

Bluetooth'taki bir bilginin açığa çıkması güvenlik açığı, yerel bir kötü amaçlı uygulamanın, uygulama verilerini diğer uygulamalardan izole eden işletim sistemi korumalarını atlamasına izin verebilir. Bu sorun, güvenlik açığına özgü ayrıntılar nedeniyle Orta olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Güncellenmiş AOSP sürümleri Bildirilen tarih
CVE-2017-0602 A-34946955 Ilıman Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 5 Ara 2016

OpenSSL ve BoringSSL'de bilgi ifşası güvenlik açığı

OpenSSL ve BoringSSL'deki bir bilginin açığa çıkması güvenlik açığı, uzaktaki bir saldırganın hassas bilgilere erişmesini sağlayabilir. Bu sorun, güvenlik açığına özgü ayrıntılar nedeniyle Orta olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Güncellenmiş AOSP sürümleri Bildirilen tarih
CVE-2016-7056 A-33752052 Ilıman Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 19 Ara 2016

Mediaserver'da hizmet reddi güvenlik açığı

Mediaserver'daki bir hizmet reddi güvenlik açığı, bir saldırganın, aygıtın askıda kalmasına veya yeniden başlatılmasına neden olmak için özel hazırlanmış bir dosya kullanmasına olanak verebilir. Bu sorun, olağandışı bir cihaz yapılandırması gerektirdiğinden Orta olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Güncellenmiş AOSP sürümleri Bildirilen tarih
CVE-2017-0603 A-35763994 Ilıman Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 23 Şubat 2017

Mediaserver'da hizmet reddi güvenlik açığı

Mediaserver'daki bir uzaktan hizmet reddi güvenlik açığı, bir saldırganın özel hazırlanmış bir dosyayı kullanarak aygıtın askıda kalmasına veya yeniden başlatılmasına neden olabilir. Bu sorun, güvenlik açığına özgü ayrıntılar nedeniyle Düşük olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Güncellenmiş AOSP sürümleri Bildirilen tarih
CVE-2017-0635 A-35467107 Düşük Herşey 7.0, 7.1.1, 7.1.2 16 Şub 2017

2017-05-05 güvenlik yaması düzeyi-Güvenlik açığı ayrıntıları

Aşağıdaki bölümlerde, 2017-05-05 yama düzeyi için geçerli olan güvenlik açıklarının her biri için ayrıntılar sunuyoruz. Sorunun açıklaması, önem derecesi gerekçesi ve CVE, ilgili referanslar, önem derecesi, güncellenmiş Google cihazları, güncellenmiş AOSP sürümleri (varsa) ve rapor edilen tarihi içeren bir tablo vardır. Mevcut olduğunda, sorunu ele alan genel değişikliği AOSP değişiklik listesi gibi hata kimliğine bağlayacağız. Birden fazla değişiklik tek bir hatayla ilgili olduğunda, hata kimliğini izleyen sayılara ek referanslar bağlanır.

GIFLIB'de uzaktan kod yürütme güvenlik açığı

GIFLIB'deki bir uzaktan kod yürütme güvenlik açığı, özel hazırlanmış bir dosya kullanan bir saldırganın medya dosyası ve veri işleme sırasında belleğin bozulmasına neden olabilir. Mediaserver süreci bağlamında uzaktan kod yürütme olasılığı nedeniyle bu sorun Kritik olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Güncellenmiş AOSP sürümleri Bildirilen tarih
CVE-2015-7555 A-34697653 kritik Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 13 Nisan 2016

MediaTek dokunmatik ekran sürücüsünde ayrıcalık yükselmesi güvenlik açığı

MediaTek dokunmatik ekran sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, aygıtı onarmak için işletim sisteminin yeniden başlatılmasını gerektirebilecek yerel kalıcı aygıt güvenliğinin ihlal edilmesi olasılığı nedeniyle Kritik olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2016-10274 A-30202412*
M-ALPS02897901
kritik Hiçbiri** 16 Tem 2016

* Bu sorunla ilgili yama herkese açık değildir. Güncelleme, Google Developer sitesinde bulunan Nexus cihazlarının en son ikili sürücülerinde bulunur.

** Mevcut tüm güncellemeleri yükleyen, Android 7.1.1 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

Qualcomm önyükleyicide ayrıcalık yükselmesi güvenlik açığı

Qualcomm önyükleyicisindeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, aygıtı onarmak için işletim sisteminin yeniden başlatılmasını gerektirebilecek yerel kalıcı aygıt güvenliğinin ihlal edilmesi olasılığı nedeniyle Kritik olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2016-10275 A-34514954
QC-CR#1009111
kritik Nexus 5X, Nexus 6, Piksel, Pixel XL, Android Bir 13 Eylül 2016
CVE-2016-10276 A-32952839
QC-CR#1094105
kritik Nexus 5X, Nexus 6P, Piksel, Piksel XL 16 Kasım 2016

Çekirdek ses alt sisteminde ayrıcalık yükselmesi güvenlik açığı

Çekirdek ses alt sistemindeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, aygıtı onarmak için işletim sisteminin yeniden başlatılmasını gerektirebilecek yerel kalıcı aygıt güvenliğinin ihlal edilmesi olasılığı nedeniyle Kritik olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2016-9794 A-34068036
yukarı akış çekirdeği
kritik Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Android One, Nexus Player 3 Ara 2016

Motorola önyükleyicisinde ayrıcalık yükselmesi güvenlik açığı

Motorola önyükleyicisindeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın önyükleyici bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, aygıtı onarmak için işletim sisteminin yeniden başlatılmasını gerektirebilecek yerel kalıcı aygıt güvenliğinin ihlal edilmesi olasılığı nedeniyle Kritik olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2016-10277 A-33840490*
kritik Bağlantı Noktası 6 21 Aralık 2016

* Bu sorunla ilgili yama herkese açık değildir. Güncelleme, Google Developer sitesinde bulunan Nexus cihazlarının en son ikili sürücülerinde bulunur.

NVIDIA video sürücüsünde ayrıcalık yükselmesi güvenlik açığı

NVIDIA video sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, aygıtı onarmak için işletim sisteminin yeniden başlatılmasını gerektirebilecek yerel kalıcı aygıt güvenliğinin ihlal edilmesi olasılığı nedeniyle Kritik olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2017-0331 A-3413000*
N-CVE-2017-0331
kritik Bağlantı Noktası 9 4 Ocak 2017

* Bu sorunla ilgili yama herkese açık değildir. Güncelleme, Google Developer sitesinde bulunan Nexus cihazlarının en son ikili sürücülerinde bulunur.

Qualcomm güç sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Çekirdek Qualcomm güç sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, aygıtı onarmak için işletim sisteminin yeniden başlatılmasını gerektirebilecek yerel kalıcı aygıt güvenliğinin ihlal edilmesi olasılığı nedeniyle Kritik olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2017-0604 A-35392981
QC-CR#826589
kritik Hiçbiri* 15 Şubat 2017

* Mevcut tüm güncellemeleri yükleyen, Android 7.1.1 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

Qualcomm bileşenlerindeki güvenlik açıkları

Bu güvenlik açıkları Qualcomm bileşenlerini etkiler ve Qualcomm AMSS Ağustos, Eylül, Ekim ve Aralık 2016 güvenlik bültenlerinde daha ayrıntılı olarak açıklanmıştır.

CVE Referanslar önem* Google cihazları güncellendi Bildirilen tarih
CVE-2016-10240 A-32578446**
QC-CR#955710
kritik Nexus 6P Qualcomm dahili
CVE-2016-10241 A-35436149**
QC-CR#1068577
kritik Nexus 5X, Nexus 6, Nexus 6P, Piksel, Piksel XL Qualcomm dahili
CVE-2016-10278 A-31624008**
KK-CR#1043004
Yüksek Piksel, Piksel XL Qualcomm dahili
CVE-2016-10279 A-31624421**
QC-CR#1031821
Yüksek Piksel, Piksel XL Qualcomm dahili

* Bu güvenlik açıklarının önem derecesi satıcı tarafından belirlendi.

* Bu sorunla ilgili yama herkese açık değildir. Güncelleme, Google Developer sitesinde bulunan Nexus cihazlarının en son ikili sürücülerinde bulunur.

libxml2'de uzaktan kod yürütme güvenlik açığı

libxml2'deki bir uzaktan kod yürütme güvenlik açığı, bir saldırganın ayrıcalıksız bir işlem bağlamında rasgele kod yürütmek için özel hazırlanmış bir dosya kullanmasına olanak verebilir. Bu kitaplığı kullanan bir uygulamada uzaktan kod yürütme olasılığı nedeniyle bu sorun Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Güncellenmiş AOSP sürümleri Bildirilen tarih
CVE-2016-5131 A-32956747* Yüksek Hiçbiri** 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 23 Temmuz 2016

* Bu sorunla ilgili yama herkese açık değildir. Güncelleme, Google Developer sitesinde bulunan Nexus cihazlarının en son ikili sürücülerinde bulunur.

** Mevcut tüm güncellemeleri yükleyen, Android 7.1.1 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

MediaTek termal sürücüsünde ayrıcalık yükselmesi güvenlik açığı

MediaTek termal sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2016-10280 A-28175767*
M-ALPS02696445
Yüksek Hiçbiri** 11 Nis 2016
CVE-2016-10281 A-28175647*
M-ALPS02696475
Yüksek Hiçbiri** 11 Nis 2016
CVE-2016-10282 A-33939045*
M-ALPS03149189
Yüksek Hiçbiri** 27 Aralık 2016

* Bu sorunla ilgili yama herkese açık değildir. Güncelleme, Google Developer sitesinde bulunan Nexus cihazlarının en son ikili sürücülerinde bulunur.

** Mevcut tüm güncellemeleri yükleyen, Android 7.1.1 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

Qualcomm Wi-Fi sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Qualcomm Wi-Fi sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2016-10283 A-32094986
QC-CR#2002052
Yüksek Nexus 5X, Piksel, Piksel XL, Android Bir 11 Eki 2016

Qualcomm video sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Qualcomm video sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2016-10284 A-32402303*
KK-CR#2000664
Yüksek Nexus 5X, Nexus 6, Nexus 6P, Piksel, Pixel XL, Android Bir 24 Ekim 2016
CVE-2016-10285 A-33752702
QC-CR#1104899
Yüksek Piksel, Piksel XL 19 Ara 2016
CVE-2016-10286 A-35400904
QC-CR#1090237
Yüksek Piksel, Piksel XL 15 Şubat 2017

* Bu sorunla ilgili yama herkese açık değildir. Güncelleme, Google Developer sitesinde bulunan Nexus cihazlarının en son ikili sürücülerinde bulunur.

Çekirdek performans alt sisteminde ayrıcalık yükselmesi güvenlik açığı

Çekirdek performans alt sistemindeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2015-9004 A-34515362
yukarı akış çekirdeği
Yüksek Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Android One, Nexus Player 23 Kasım 2016

Qualcomm ses sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Qualcomm ses sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2016-10287 A-33784446
QC-CR#1112751
Yüksek Nexus 5X, Nexus 6P, Piksel, Pixel XL, Android Bir 20 Aralık 2016
CVE-2017-0606 A-34088848
QC-CR#1116015
Yüksek Nexus 5X, Nexus 6P, Piksel, Pixel XL, Android Bir 3 Oca 2017
CVE-2016-5860 A-34623424
QC-CR#1100682
Yüksek Piksel, Piksel XL 22 Oca 2017
CVE-2016-5867 A-35400602
QC-CR#1095947
Yüksek Hiçbiri* 15 Şubat 2017
CVE-2017-0607 A-35400551
QC-CR#1085928
Yüksek Piksel, Piksel XL 15 Şubat 2017
CVE-2017-0608 A-35400458
QC-CR#1098363
Yüksek Nexus 5X, Nexus 6, Nexus 6P, Piksel, Pixel XL, Android Bir 15 Şubat 2017
CVE-2017-0609 A-35399801
QC-CR#1090482
Yüksek Nexus 5X, Nexus 6P, Piksel, Pixel XL, Android Bir 15 Şubat 2017
CVE-2016-5859 A-35399758
QC-CR#1096672
Yüksek Hiçbiri* 15 Şubat 2017
CVE-2017-0610 A-35399404
QC-CR#1094852
Yüksek Nexus 5X, Nexus 6, Nexus 6P, Piksel, Pixel XL, Android Bir 15 Şubat 2017
CVE-2017-0611 A-35393841
QC-CR#1084210
Yüksek Nexus 5X, Nexus 6, Nexus 6P, Piksel, Pixel XL, Android Bir 15 Şubat 2017
CVE-2016-5853 A-35392629
QC-CR#1102987
Yüksek Hiçbiri* 15 Şubat 2017

* Mevcut tüm güncellemeleri yükleyen, Android 7.1.1 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

Qualcomm LED sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Qualcomm LED sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2016-10288 A-33863909
QC-CR#1109763
Yüksek Piksel, Piksel XL 23 Aralık 2016

Qualcomm kripto sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Qualcomm kripto sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2016-10289 A-33899710
QC-CR#1116295
Yüksek Nexus 5X, Nexus 6, Nexus 6P, Piksel, Pixel XL, Android Bir 24 Aralık 2016

Qualcomm paylaşılan bellek sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Qualcomm paylaşılan bellek sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2016-10290 A-33898330
QC-CR#1109782
Yüksek Nexus 5X, Nexus 6P, Piksel, Piksel XL 24 Aralık 2016

Qualcomm Slimbus sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Qualcomm Slimbus sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2016-10291 A-34030871
QC-CR#986837
Yüksek Nexus 5X, Nexus 6, Nexus 6P, Android Bir 31 Aralık 2016

Qualcomm ADSPRPC sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Qualcomm ADSPRPC sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2017-0465 A-34112914
QC-CR#1110747
Yüksek Nexus 5X, Nexus 6P, Piksel, Pixel XL, Android Bir 5 Ocak 2017

Qualcomm Secure Execution Environment Communicator sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Qualcomm Secure Execution Environment Communicator sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2017-0612 A-34389303
KK-CR#1061845
Yüksek Piksel, Piksel XL 10 Oca 2017
CVE-2017-0613 A-35400457
QC-CR#1086140
Yüksek Nexus 5X, Nexus 6, Nexus 6P, Piksel, Pixel XL, Android Bir 15 Şubat 2017
CVE-2017-0614 A-35399405
QC-CR#1080290
Yüksek Nexus 5X, Nexus 6, Nexus 6P, Piksel, Pixel XL, Android Bir 15 Şubat 2017

MediaTek güç sürücüsünde ayrıcalık yükselmesi güvenlik açığı

MediaTek güç sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2017-0615 A-34259126*
M-ALPS03150278
Yüksek Hiçbiri** 12 Oca 2017

* Bu sorunla ilgili yama herkese açık değildir. Güncelleme, Google Developer sitesinde bulunan Nexus cihazlarının en son ikili sürücülerinde bulunur.

** Mevcut tüm güncellemeleri yükleyen, Android 7.1.1 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

MediaTek sistem yönetimi kesinti sürücüsünde ayrıcalık yükselmesi güvenlik açığı

MediaTek sistem yönetimi kesinti sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2017-0616 A-34470286*
M-ALPS03149160
Yüksek Hiçbiri** 19 Oca 2017

* Bu sorunla ilgili yama herkese açık değildir. Güncelleme, Google Developer sitesinde bulunan Nexus cihazlarının en son ikili sürücülerinde bulunur.

** Mevcut tüm güncellemeleri yükleyen, Android 7.1.1 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

MediaTek video sürücüsünde ayrıcalık yükselmesi güvenlik açığı

MediaTek video sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2017-0617 A-34471002*
M-ALPS03149173
Yüksek Hiçbiri** 19 Oca 2017

* Bu sorunla ilgili yama herkese açık değildir. Güncelleme, Google Developer sitesinde bulunan Nexus cihazlarının en son ikili sürücülerinde bulunur.

** Mevcut tüm güncellemeleri yükleyen, Android 7.1.1 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

MediaTek komut kuyruğu sürücüsünde ayrıcalık yükselmesi güvenlik açığı

MediaTek komut kuyruğu sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2017-0618 A-35100728*
M-ALPS03161536
Yüksek Hiçbiri** 7 Şubat 2017

* Bu sorunla ilgili yama herkese açık değildir. Güncelleme, Google Developer sitesinde bulunan Nexus cihazlarının en son ikili sürücülerinde bulunur.

** Mevcut tüm güncellemeleri yükleyen, Android 7.1.1 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

Qualcomm pin denetleyici sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Qualcomm pin denetleyici sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Google cihazları güncellendi Bildirilen tarih
CVE-2017-0619 A-35401152
QC-CR#826566
Yüksek Nexus 6, Android Bir 15 Şubat 2017

Qualcomm Güvenli Kanal Yöneticisi Sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Qualcomm Secure Channel Manager sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar önem Updated Google devices Date reported
CVE-2017-0620 A-35401052
QC-CR#1081711
High Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Feb 15, 2017

Elevation of privilege vulnerability in Qualcomm sound codec driver

An elevation of privilege vulnerability in the Qualcomm sound codec driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-5862 A-35399803
QC-CR#1099607
High Pixel, Pixel XL Feb 15, 2017

Elevation of privilege vulnerability in kernel voltage regulator driver

An elevation of privilege vulnerability in the kernel voltage regulator driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2014-9940 A-35399757
Upstream kernel
High Nexus 6, Nexus 9, Pixel C, Android One, Nexus Player Feb 15, 2017

Elevation of privilege vulnerability in Qualcomm camera driver

An elevation of privilege vulnerability in the Qualcomm camera driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0621 A-35399703
QC-CR#831322
High Android One Feb 15, 2017

Elevation of privilege vulnerability in Qualcomm networking driver

An elevation of privilege vulnerability in the Qualcomm networking driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-5868 A-35392791
QC-CR#1104431
High Nexus 5X, Pixel, Pixel XL Feb 15, 2017

Elevation of privilege vulnerability in kernel networking subsystem

An elevation of privilege vulnerability in the kernel networking subsystem could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-7184 A-36565222
Upstream kernel [2]
High Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Android One Mar 23, 2017

Elevation of privilege vulnerability in Goodix touchscreen driver

An elevation of privilege vulnerability in the Goodix touchscreen driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0622 A-32749036
QC-CR#1098602
High Android One Google internal

Elevation of privilege vulnerability in HTC bootloader

An elevation of privilege vulnerability in the HTC bootloader could enable a local malicious application to execute arbitrary code within the context of the bootloader. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0623 A-32512358*
High Pixel, Pixel XL Google Internal

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm Wi-Fi driver

An information disclosure vulnerability in the Qualcomm Wi-Fi driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2017-0624 A-34327795*
QC-CR#2005832
High Nexus 5X, Pixel, Pixel XL Jan 16, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in MediaTek command queue driver

An information disclosure vulnerability in the MediaTek command queue driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2017-0625 A-35142799*
M-ALPS03161531
High None** Feb 8, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.1.1 or later that have installed all available updates are not affected by this vulnerability.

Information disclosure vulnerability in Qualcomm crypto engine driver

An information disclosure vulnerability in the Qualcomm crypto engine driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2017-0626 A-35393124
QC-CR#1088050
High Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Feb 15, 2017

Denial of service vulnerability in Qualcomm Wi-Fi driver

A denial of service vulnerability in the Qualcomm Wi-Fi driver could enable a proximate attacker to cause a denial of service in the Wi-Fi subsystem. This issue is rated as High due to the possibility of remote denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2016-10292 A-34514463*
QC-CR#1065466
High Nexus 5X, Pixel, Pixel XL Dec 16, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in kernel UVC driver

An information disclosure vulnerability in the kernel UVC driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0627 A-33300353*
Moderate Nexus 5X, Nexus 6P, Nexus 9, Pixel C, Nexus Player Dec 2, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm video driver

An information disclosure vulnerability in the Qualcomm video driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-10293 A-33352393
QC-CR#1101943
Moderate Nexus 5X, Nexus 6P, Android One Dec 4, 2016

Information disclosure vulnerability in Qualcomm power driver (device specific)

An information disclosure vulnerability in the Qualcomm power driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-10294 A-33621829
QC-CR#1105481
Moderate Nexus 5X, Nexus 6P, Pixel, Pixel XL Dec 14, 2016

Information disclosure vulnerability in Qualcomm LED driver

An information disclosure vulnerability in the Qualcomm LED driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-10295 A-33781694
QC-CR#1109326
Moderate Pixel, Pixel XL Dec 20, 2016

Information disclosure vulnerability in Qualcomm shared memory driver

An information disclosure vulnerability in the Qualcomm shared memory driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-10296 A-33845464
QC-CR#1109782
Moderate Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One Dec 22, 2016

Information disclosure vulnerability in Qualcomm camera driver

An information disclosure vulnerability in the Qualcomm camera driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0628 A-34230377
QC-CR#1086833
Moderate Nexus 5X, Nexus 6, Pixel, Pixel XL Jan 10, 2017
CVE-2017-0629 A-35214296
QC-CR#1086833
Moderate Nexus 5X, Nexus 6, Pixel, Pixel XL Feb 8, 2017

Information disclosure vulnerability in kernel trace subsystem

An information disclosure vulnerability in the kernel trace subsystem could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0630 A-34277115*
Moderate Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Android One, Nexus Player Jan 11, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm sound codec driver

An information disclosure vulnerability in the Qualcomm sound codec driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-5858 A-35400153
QC-CR#1096799 [2]
Moderate Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Feb 15, 2017

Information disclosure vulnerability in Qualcomm camera driver

An information disclosure vulnerability in the Qualcomm camera driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0631 A-35399756
QC-CR#1093232
Moderate Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One Feb 15, 2017

Information disclosure vulnerability in Qualcomm sound driver

An information disclosure vulnerability in the Qualcomm sound driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-5347 A-35394329
QC-CR#1100878
Moderate Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Feb 15, 2017

Information disclosure vulnerability in Qualcomm SPCom driver

An information disclosure vulnerability in the Qualcomm SPCom driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-5854 A-35392792
QC-CR#1092683
Moderate None* Feb 15, 2017
CVE-2016-5855 A-35393081
QC-CR#1094143
Moderate None* Feb 15, 2017

* Supported Google devices on Android 7.1.1 or later that have installed all available updates are not affected by this vulnerability.

Information disclosure vulnerability in Qualcomm sound codec driver

An information disclosure vulnerability in the Qualcomm sound codec driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0632 A-35392586
QC-CR#832915
Moderate Android One Feb 15, 2017

Information disclosure vulnerability in Broadcom Wi-Fi driver

An information disclosure vulnerability in the Broadcom Wi-Fi driver could enable a local malicious component to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0633 A-36000515*
B-RB#117131
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Feb 23, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Synaptics touchscreen driver

An information disclosure vulnerability in the Synaptics touchscreen driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0634 A-32511682*
Moderate Pixel, Pixel XL Google internal

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Vulnerabilities in Qualcomm components

These vulnerabilities affecting Qualcomm components were released as part of Qualcomm AMSS security bulletins between 2014–2016. They are included in this Android security bulletin to associate their fixes with an Android security patch level.

CVE References Severity* Updated Google devices Date reported
CVE-2014-9923 A-35434045** Critical None*** Qualcomm internal
CVE-2014-9924 A-35434631** Critical None*** Qualcomm internal
CVE-2014-9925 A-35444657** Critical None*** Qualcomm internal
CVE-2014-9926 A-35433784** Critical None*** Qualcomm internal
CVE-2014-9927 A-35433785** Critical None*** Qualcomm internal
CVE-2014-9928 A-35438623** Critical None*** Qualcomm internal
CVE-2014-9929 A-35443954**
QC-CR#644783
Critical None*** Qualcomm internal
CVE-2014-9930 A-35432946** Critical None*** Qualcomm internal
CVE-2015-9005 A-36393500** Critical None*** Qualcomm internal
CVE-2015-9006 A-36393450** Critical None*** Qualcomm internal
CVE-2015-9007 A-36393700** Critical None*** Qualcomm internal
CVE-2016-10297 A-36393451** Critical None*** Qualcomm internal
CVE-2014-9941 A-36385125** High None*** Qualcomm internal
CVE-2014-9942 A-36385319** High None*** Qualcomm internal
CVE-2014-9943 A-36385219** High None*** Qualcomm internal
CVE-2014-9944 A-36384534** High None*** Qualcomm internal
CVE-2014-9945 A-36386912** High None*** Qualcomm internal
CVE-2014-9946 A-36385281** High None*** Qualcomm internal
CVE-2014-9947 A-36392400** High None*** Qualcomm internal
CVE-2014-9948 A-36385126** High None*** Qualcomm internal
CVE-2014-9949 A-36390608** High None*** Qualcomm internal
CVE-2014-9950 A-36385321** High None*** Qualcomm internal
CVE-2014-9951 A-36389161** High None*** Qualcomm internal
CVE-2014-9952 A-36387019** High None*** Qualcomm internal

* The severity rating for these vulnerabilities was determined by the vendor.

** The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

*** Supported Google devices on Android 7.1.1 or later that have installed all available updates are not affected by this vulnerability.

Common Questions and Answers

This section answers common questions that may occur after reading this bulletin.

1. How do I determine if my device is updated to address these issues?

To learn how to check a device's security patch level, read the instructions on the Pixel and Nexus update schedule .

  • Security patch levels of 2017-05-01 or later address all issues associated with the 2017-05-01 security patch level.
  • Security patch levels of 2017-05-05 or later address all issues associated with the 2017-05-05 security patch level and all previous patch levels.

Device manufacturers that include these updates should set the patch string level to:

  • [ro.build.version.security_patch]:[2017-05-01]
  • [ro.build.version.security_patch]:[2017-05-05]

2. Why does this bulletin have two security patch levels?

This bulletin has two security patch levels so that Android partners have the flexibility to fix a subset of vulnerabilities that are similar across all Android devices more quickly. Android partners are encouraged to fix all issues in this bulletin and use the latest security patch level.

  • Devices that use the May 01, 2017 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins.
  • Devices that use the security patch level of May 05, 2017 or newer must include all applicable patches in this (and previous) security bulletins.

Partners are encouraged to bundle the fixes for all issues they are addressing in a single update.

3. How do I determine which Google devices are affected by each issue?

In the 2017-05-01 and 2017-05-05 security vulnerability details sections, each table has an Updated Google devices column that covers the range of affected Google devices updated for each issue. This column has a few options:

  • All Google devices : If an issue affects All and Pixel devices, the table will have "All" in the Updated Google devices column. "All" encapsulates the following supported devices : Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel, and Pixel XL.
  • Some Google devices : If an issue doesn't affect all Google devices, the affected Google devices are listed in the Updated Google devices column.
  • No Google devices : If no Google devices running Android 7.0 are affected by the issue, the table will have "None" in the Updated Google devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefix Reference
A- Android bug ID
QC- Qualcomm reference number
M- MediaTek reference number
N- NVIDIA reference number
B- Broadcom reference number

Revisions

  • May 01, 2017: Bulletin published.
  • May 02, 2017: Bulletin revised to include AOSP links.
  • August 10, 2017: Bulletin revised to include additional AOSP link for CVE-2017-0493.
  • August 17, 2017: Bulletin revised to update reference numbers.
  • October 03, 2017: Bulletin revised to remove CVE-2017-0605.