Android सुरक्षा बुलेटिन—मार्च 2020

संग्रह की मदद से व्यवस्थित रहें अपनी प्राथमिकताओं के आधार पर, कॉन्टेंट को सेव करें और कैटगरी में बांटें.

2 मार्च, 2020 को प्रकाशित | 9 मार्च, 2020 को अपडेट किया गया

Android सुरक्षा बुलेटिन में Android उपकरणों को प्रभावित करने वाली सुरक्षा कमजोरियों का विवरण होता है। 2020-03-05 या उसके बाद के सुरक्षा पैच स्तर इन सभी मुद्दों को संबोधित करते हैं। किसी डिवाइस के सुरक्षा पैच स्तर की जांच करने का तरीका जानने के लिए, अपना Android संस्करण जांचें और अपडेट करें देखें.

प्रकाशन से कम से कम एक महीने पहले Android भागीदारों को सभी मुद्दों के बारे में सूचित किया जाता है। इन मुद्दों के लिए स्रोत कोड पैच एंड्रॉइड ओपन सोर्स प्रोजेक्ट (एओएसपी) रिपोजिटरी में जारी किए गए हैं और इस बुलेटिन से जुड़े हुए हैं। इस बुलेटिन में एओएसपी के बाहर पैच के लिंक भी शामिल हैं।

इन मुद्दों में सबसे गंभीर मीडिया ढांचे में एक महत्वपूर्ण सुरक्षा भेद्यता है जो एक विशेष रूप से तैयार की गई फ़ाइल का उपयोग करके एक विशेषाधिकार प्राप्त प्रक्रिया के संदर्भ में मनमाने कोड को निष्पादित करने के लिए एक दूरस्थ हमलावर को सक्षम कर सकता है। गंभीरता का आकलन इस प्रभाव पर आधारित है कि भेद्यता का शोषण संभवतः एक प्रभावित डिवाइस पर होगा, यह मानते हुए कि प्लेटफॉर्म और सेवा शमन को विकास उद्देश्यों के लिए बंद कर दिया गया है या सफलतापूर्वक बायपास कर दिया गया है।

Android सुरक्षा प्लेटफ़ॉर्म सुरक्षा और Google Play प्रोटेक्ट पर विवरण के लिए Android और Google Play प्रोटेक्ट मिटिगेशन अनुभाग देखें, जो Android प्लेटफ़ॉर्म की सुरक्षा में सुधार करते हैं।

Android और Google सेवा में कमी

यह Android सुरक्षा प्लेटफ़ॉर्म और Google Play Protect जैसी सेवा सुरक्षा द्वारा प्रदान किए गए शमन का सारांश है। ये क्षमताएं इस संभावना को कम करती हैं कि Android पर सुरक्षा कमजोरियों का सफलतापूर्वक शोषण किया जा सकता है।

  • एंड्रॉइड प्लेटफॉर्म के नए संस्करणों में एन्हांसमेंट द्वारा एंड्रॉइड पर कई मुद्दों के लिए शोषण को और अधिक कठिन बना दिया गया है। हम सभी उपयोगकर्ताओं को जहां संभव हो, Android के नवीनतम संस्करण में अपडेट करने के लिए प्रोत्साहित करते हैं।
  • एंड्रॉइड सुरक्षा टीम सक्रिय रूप से Google Play Protect के माध्यम से दुरुपयोग की निगरानी करती है और उपयोगकर्ताओं को संभावित रूप से हानिकारक एप्लिकेशन के बारे में चेतावनी देती है। Google Play Protect Google मोबाइल सेवाओं वाले उपकरणों पर डिफ़ॉल्ट रूप से सक्षम होता है, और यह उन उपयोगकर्ताओं के लिए विशेष रूप से महत्वपूर्ण है जो Google Play के बाहर से ऐप्स इंस्टॉल करते हैं।

2020-03-01 सुरक्षा पैच स्तर की भेद्यता विवरण

नीचे दिए गए अनुभागों में, हम 2020-03-01 पैच स्तर पर लागू होने वाली प्रत्येक सुरक्षा भेद्यता के लिए विवरण प्रदान करते हैं। कमजोरियों को उस घटक के तहत वर्गीकृत किया जाता है जो वे प्रभावित करते हैं। समस्याओं को नीचे दी गई तालिका में वर्णित किया गया है और इसमें सीवीई आईडी, संबद्ध संदर्भ, भेद्यता का प्रकार , गंभीरता और अद्यतन एओएसपी संस्करण (जहां लागू हो) शामिल हैं। उपलब्ध होने पर, हम उस सार्वजनिक परिवर्तन को जोड़ते हैं जिसने समस्या को बग आईडी से संबोधित किया, जैसे AOSP परिवर्तन सूची। जब एक से अधिक परिवर्तन एक बग से संबंधित होते हैं, तो अतिरिक्त संदर्भ बग आईडी के बाद की संख्याओं से जुड़े होते हैं। Android 10 और बाद के संस्करण वाले डिवाइस सुरक्षा अपडेट के साथ-साथ Google Play सिस्टम अपडेट प्राप्त कर सकते हैं।

रूपरेखा

इस खंड में भेद्यता एक स्थानीय दुर्भावनापूर्ण एप्लिकेशन को ऑपरेटिंग सिस्टम सुरक्षा को बायपास करने में सक्षम कर सकती है जो अन्य एप्लिकेशन से एप्लिकेशन डेटा को अलग करती है।

सीवीई संदर्भ टाइप तीव्रता अपडेट किया गया एओएसपी संस्करण
सीवीई-2020-0031 ए-141703197 [ 2 ] पहचान उच्च 10

मीडिया ढांचा

इस खंड में सबसे गंभीर भेद्यता एक विशेष रूप से तैयार की गई फ़ाइल का उपयोग करके एक विशेषाधिकार प्राप्त प्रक्रिया के संदर्भ में मनमाने कोड को निष्पादित करने के लिए एक दूरस्थ हमलावर को सक्षम कर सकती है।

सीवीई संदर्भ टाइप तीव्रता अपडेट किया गया एओएसपी संस्करण
सीवीई-2020-0032 ए-145364230 आरसीई नाजुक 8.0, 8.1, 9, 10
सीवीई-2020-0033 ए-144351324 ईओपी उच्च 8.0, 8.1, 9, 10
सीवीई-2020-0034 ए-62458770 पहचान उच्च 8.0, 8.1

व्यवस्था

इस खंड में सबसे गंभीर भेद्यता स्थानीय दुर्भावनापूर्ण एप्लिकेशन को अतिरिक्त अनुमतियों तक पहुंच प्राप्त करने के लिए उपयोगकर्ता इंटरैक्शन आवश्यकताओं को बायपास करने में सक्षम कर सकती है।

सीवीई संदर्भ टाइप तीव्रता अपडेट किया गया एओएसपी संस्करण
सीवीई-2020-0036 ए-144679405 ईओपी उच्च 8.0, 8.1, 9, 10
सीवीई-2020-0035 ए-140622024 पहचान उच्च 8.0, 8.1, 9
सीवीई-2020-0029 ए-140065828 पहचान उच्च 10
सीवीई-2020-0037 ए-143106535 पहचान उच्च 8.0, 8.1, 9, 10
सीवीई-2020-0038 ए-143109193 पहचान उच्च 8.0, 8.1, 9, 10
सीवीई-2020-0039 ए-143155861 पहचान उच्च 8.0, 8.1, 9, 10

Google Play सिस्टम अपडेट

निम्न समस्या प्रोजेक्ट मेनलाइन घटकों में शामिल है।

अवयव सीवीई
मीडिया कोडेक सीवीई-2020-0032

2020-03-05 सुरक्षा पैच स्तर की भेद्यता विवरण

नीचे दिए गए अनुभागों में, हम 2020-03-05 पैच स्तर पर लागू होने वाली प्रत्येक सुरक्षा भेद्यता के लिए विवरण प्रदान करते हैं। कमजोरियों को उस घटक के तहत वर्गीकृत किया जाता है जो वे प्रभावित करते हैं और इसमें सीवीई, संबद्ध संदर्भ, भेद्यता के प्रकार , गंभीरता , घटक (जहां लागू हो), और अद्यतन एओएसपी संस्करण (जहां लागू हो) जैसे विवरण शामिल होते हैं। उपलब्ध होने पर, हम उस सार्वजनिक परिवर्तन को जोड़ते हैं जिसने समस्या को बग आईडी से संबोधित किया, जैसे AOSP परिवर्तन सूची। जब एक से अधिक परिवर्तन एक बग से संबंधित होते हैं, तो अतिरिक्त संदर्भ बग आईडी के बाद की संख्याओं से जुड़े होते हैं।

कर्नेल घटक

इस खंड में सबसे गंभीर भेद्यता एक स्थानीय हमलावर को विशेष रूप से तैयार की गई USB डिवाइस का उपयोग करके एक विशेषाधिकार प्राप्त प्रक्रिया के संदर्भ में मनमाने कोड को निष्पादित करने में सक्षम कर सकती है।

सीवीई संदर्भ टाइप तीव्रता अवयव
सीवीई-2019-19527 ए-146257915
अपस्ट्रीम कर्नेल [ 2 ]
ईओपी उच्च यु एस बी
सीवीई-2019-19537 ए-146258055
अपस्ट्रीम कर्नेल
ईओपी उच्च यु एस बी
सीवीई-2019-15239 ए-143009752
अपस्ट्रीम कर्नेल
ईओपी उच्च नेटवर्किंग
सीवीई-2020-0041 ए-145988638
अपस्ट्रीम कर्नेल
ईओपी उच्च जिल्दसाज़

एफपीसी घटक

इस खंड में सबसे गंभीर भेद्यता स्थानीय दुर्भावनापूर्ण एप्लिकेशन को अतिरिक्त अनुमतियों तक पहुंच प्राप्त करने के लिए उपयोगकर्ता इंटरैक्शन आवश्यकताओं को बायपास करने में सक्षम कर सकती है।

सीवीई संदर्भ टाइप तीव्रता अवयव
सीवीई-2020-0010 ए-137014293 * ईओपी उच्च एफपीसी फिंगरप्रिंट टी
सीवीई-2020-0011 ए-137648045 * ईओपी उच्च एफपीसी फिंगरप्रिंट टी
सीवीई-2020-0012 ए-137648844 * ईओपी उच्च एफपीसी फिंगरप्रिंट टी
सीवीई-2020-0042 ए-137649599 * पहचान संतुलित एफपीसी फिंगरप्रिंट टी
सीवीई-2020-0043 ए-137650218 * पहचान संतुलित एफपीसी फिंगरप्रिंट टी
सीवीई-2020-0044 ए-137650219 * पहचान संतुलित एफपीसी फिंगरप्रिंट टी

मीडियाटेक घटक

सीवीई संदर्भ टाइप तीव्रता अवयव
सीवीई-2020-0069 ए-147882143 *
एम-एएलपीएस04356754
ईओपी उच्च व्यवस्था

क्वालकॉम घटक

ये भेद्यताएं क्वालकॉम घटकों को प्रभावित करती हैं और उपयुक्त क्वालकॉम सुरक्षा बुलेटिन या सुरक्षा चेतावनी में और अधिक विस्तार से वर्णित हैं। इन मुद्दों की गंभीरता का आकलन सीधे क्वालकॉम द्वारा प्रदान किया जाता है।

सीवीई संदर्भ टाइप तीव्रता अवयव
सीवीई-2019-14079 ए-138848422
क्यूसी-सीआर#2521001
एन/ए उच्च यु एस बी
सीवीई-2018-11838 ए-145545090
क्यूसी-सीआर#221457 [ 2 ]
एन/ए उच्च WLAN
सीवीई-2019-10526 ए-145544085
क्यूसी-सीआर#2232526
क्यूसी-सीआर#2541970
एन/ए उच्च WLAN
सीवीई-2019-10569 ए-145545820
क्यूसी-सीआर#2315791
एन/ए उच्च ऑडियो
सीवीई-2019-14029 ए-145546793
क्यूसी-सीआर#2528795
एन/ए उच्च ग्राफिक्स
सीवीई-2019-14032 ए-145546652
क्यूसी-सीआर#2537311
एन/ए उच्च ऑडियो
सीवीई-2019-14068 ए-145546435
क्यूसी-सीआर#2507653 [ 2 ]
एन/ए उच्च ऑडियो
सीवीई-2019-14072 ए-145545251
क्यूसी-सीआर#2509391
एन/ए उच्च ग्राफिक्स

क्वालकॉम बंद-स्रोत घटक

ये कमजोरियां क्वालकॉम के क्लोज्ड-सोर्स घटकों को प्रभावित करती हैं और उपयुक्त क्वालकॉम सुरक्षा बुलेटिन या सुरक्षा अलर्ट में अधिक विस्तार से वर्णित हैं। इन मुद्दों की गंभीरता का आकलन सीधे क्वालकॉम द्वारा प्रदान किया जाता है।

सीवीई संदर्भ टाइप तीव्रता अवयव
सीवीई-2019-2317 ए-134436812 * एन/ए नाजुक बंद स्रोत घटक
सीवीई-2019-10586 ए-140423909 * एन/ए नाजुक बंद स्रोत घटक
सीवीई-2019-10587 ए-140423816 * एन/ए नाजुक बंद स्रोत घटक
सीवीई-2019-10593 ए-140424165 * एन/ए नाजुक बंद स्रोत घटक
सीवीई-2019-10594 ए-1404424564 * एन/ए नाजुक बंद स्रोत घटक
सीवीई-2019-10612 ए-144423161 * एन/ए नाजुक बंद स्रोत घटक
सीवीई-2019-14031 ए-142271912 * एन/ए नाजुक बंद स्रोत घटक
सीवीई-2019-14045 ए-140973418 * एन/ए नाजुक बंद स्रोत घटक
सीवीई-2019-14071 ए-1455545489 * एन/ए नाजुक बंद स्रोत घटक
सीवीई-2019-14083 ए-140973259 * एन/ए नाजुक बंद स्रोत घटक
सीवीई-2019-14086 ए-140973417 * एन/ए नाजुक बंद स्रोत घटक
सीवीई-2019-14030 ए-145546515 * एन/ए नाजुक बंद स्रोत घटक
सीवीई-2019-14097 ए-145546003 * एन/ए नाजुक बंद स्रोत घटक
सीवीई-2019-14098 ए-145546314 * एन/ए नाजुक बंद स्रोत घटक
सीवीई-2019-10546 ए-145545250 * एन/ए नाजुक बंद स्रोत घटक
सीवीई-2019-14095 ए-142843397 * एन/ए नाजुक बंद स्रोत घटक
सीवीई-2018-11970 ए-114042111 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-10603 ए-140424074 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-10616 ए-140423338 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-10549 ए-140423162 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-10550 ए-140423702 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-10552 ए-140423817 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-10553 ए-140423081 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-10554 ए-140424012 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-10577 ए-140424166 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-14026 ए-142271986 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-14027 ए-142271756 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-14028 ए-142271831 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-2300 ए-142271659 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-2311 ए-142271967 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-14050 ए-143902706 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-14081 ए-143902882 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-14082 ए-140974589 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-14085 ए-143902807 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-14048 ए-145545282 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-14061 ए-145545758 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-10604 ए-145545725 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-10591 ए-145545283 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-14000 ए-145546434 * एन/ए उच्च बंद स्रोत घटक
सीवीई-2019-14015 ए-145545650 * एन/ए उच्च बंद स्रोत घटक

सामान्य प्रश्न और उत्तर

यह खंड उन सामान्य प्रश्नों के उत्तर देता है जो इस बुलेटिन को पढ़ने के बाद उत्पन्न हो सकते हैं।

1. मैं कैसे निर्धारित करूं कि इन समस्याओं को दूर करने के लिए मेरा डिवाइस अपडेट किया गया है या नहीं?

किसी डिवाइस के सुरक्षा पैच स्तर की जांच करने का तरीका जानने के लिए, अपना Android संस्करण जांचें और अपडेट करें देखें.

  • 2020-03-01 या बाद के सुरक्षा पैच स्तर 2020-03-01 सुरक्षा पैच स्तर से जुड़े सभी मुद्दों को संबोधित करते हैं।
  • 2020-03-05 या बाद के सुरक्षा पैच स्तर 2020-03-05 सुरक्षा पैच स्तर और पिछले सभी पैच स्तरों से जुड़े सभी मुद्दों को संबोधित करते हैं।

इन अद्यतनों को शामिल करने वाले डिवाइस निर्माताओं को पैच स्ट्रिंग स्तर को इस पर सेट करना चाहिए:

  • [ro.build.version.security_patch]:[2020-03-01]
  • [ro.build.version.security_patch]:[2020-03-05]

एंड्रॉइड 10 या उसके बाद के कुछ उपकरणों के लिए, Google Play सिस्टम अपडेट में एक तारीख स्ट्रिंग होगी जो 2020-03-01 सुरक्षा पैच स्तर से मेल खाती है। सुरक्षा अद्यतन स्थापित करने के तरीके के बारे में अधिक विवरण के लिए कृपया यह आलेख देखें।

2. इस बुलेटिन में दो सुरक्षा पैच स्तर क्यों हैं?

इस बुलेटिन में दो सुरक्षा पैच स्तर हैं ताकि Android भागीदारों के पास कमजोरियों के एक सबसेट को ठीक करने की सुविधा हो जो सभी Android उपकरणों में अधिक तेज़ी से समान हो। Android भागीदारों को इस बुलेटिन में सभी समस्याओं को ठीक करने और नवीनतम सुरक्षा पैच स्तर का उपयोग करने के लिए प्रोत्साहित किया जाता है।

  • 2020-03-01 सुरक्षा पैच स्तर का उपयोग करने वाले उपकरणों में उस सुरक्षा पैच स्तर से जुड़े सभी मुद्दों के साथ-साथ पिछले सुरक्षा बुलेटिन में रिपोर्ट की गई सभी समस्याओं के समाधान शामिल होने चाहिए।
  • 2020-03-05 या नए के सुरक्षा पैच स्तर का उपयोग करने वाले उपकरणों में इस (और पिछले) सुरक्षा बुलेटिन में सभी लागू पैच शामिल होने चाहिए।

भागीदारों को उन सभी समस्याओं के समाधान को बंडल करने के लिए प्रोत्साहित किया जाता है जिन्हें वे एक ही अद्यतन में संबोधित कर रहे हैं।

3. टाइप कॉलम में प्रविष्टियों का क्या अर्थ है?

भेद्यता विवरण तालिका के प्रकार कॉलम में प्रविष्टियां सुरक्षा भेद्यता के वर्गीकरण का संदर्भ देती हैं।

संक्षेपाक्षर परिभाषा
आरसीई रिमोट कोड निष्पादन
ईओपी विशेषाधिकार का उन्नयन
पहचान जानकारी प्रकटीकरण
करने योग्य सेवा की मनाई
एन/ए वर्गीकरण उपलब्ध नहीं है

4. सन्दर्भ कॉलम में प्रविष्टियों का क्या अर्थ है?

भेद्यता विवरण तालिका के संदर्भ कॉलम के अंतर्गत प्रविष्टियों में उस संगठन की पहचान करने वाला एक उपसर्ग हो सकता है जिससे संदर्भ मान संबंधित है।

उपसर्ग संदर्भ
ए- एंड्रॉइड बग आईडी
क्यूसी- क्वालकॉम संदर्भ संख्या
एम- मीडियाटेक संदर्भ संख्या
एन- NVIDIA संदर्भ संख्या
बी- ब्रॉडकॉम संदर्भ संख्या

5. संदर्भ कॉलम में Android बग आईडी के आगे * का क्या अर्थ है?

जो समस्याएं सार्वजनिक रूप से उपलब्ध नहीं हैं उनमें संदर्भ कॉलम में Android बग आईडी के आगे एक * होता है। उस समस्या के लिए अद्यतन आम तौर पर Google डेवलपर साइट से उपलब्ध पिक्सेल उपकरणों के लिए नवीनतम बाइनरी ड्राइवरों में निहित है।

6. सुरक्षा कमजोरियों को इस बुलेटिन और डिवाइस/पार्टनर सुरक्षा बुलेटिन, जैसे कि Pixel बुलेटिन के बीच क्यों विभाजित किया गया है?

इस सुरक्षा बुलेटिन में प्रलेखित सुरक्षा भेद्यताएं Android उपकरणों पर नवीनतम सुरक्षा पैच स्तर घोषित करने के लिए आवश्यक हैं। सुरक्षा पैच स्तर घोषित करने के लिए डिवाइस/पार्टनर सुरक्षा बुलेटिन में प्रलेखित अतिरिक्त सुरक्षा भेद्यताएं आवश्यक नहीं हैं। Android डिवाइस और चिपसेट निर्माता अपने उत्पादों के लिए विशिष्ट सुरक्षा भेद्यता विवरण भी प्रकाशित कर सकते हैं, जैसे Google , Huawei , LGE , Motorola , Nokia , या Samsung

संस्करणों

संस्करण दिनांक टिप्पणियाँ
1.0 2 मार्च 2020 बुलेटिन प्रकाशित
1.1 3 मार्च 2020 AOSP लिंक्स को शामिल करने के लिए संशोधित बुलेटिन
1.2 9 मार्च, 2020 अद्यतन समस्या सूची