Google is committed to advancing racial equity for Black communities. See how.
This page was translated by the Cloud Translation API.
Switch to English

Boletim de segurança do Android - agosto de 2016

Publicado em 01 de agosto de 2016 | Atualizado em 21 de outubro de 2016

O Boletim de Segurança do Android contém detalhes de vulnerabilidades de segurança que afetam dispositivos Android. Juntamente com o boletim, lançamos uma atualização de segurança para dispositivos Nexus por meio de uma atualização over-the-air (OTA). As imagens do firmware Nexus também foram lançadas no site Google Developer . Os níveis do patch de segurança de 5 de agosto de 2016 ou posterior tratam desses problemas. Consulte a documentação para saber como verificar o nível do patch de segurança.

Os parceiros foram notificados sobre os problemas descritos no boletim em 06 de julho de 2016 ou antes. Quando aplicável, os patches de código-fonte para esses problemas foram lançados no repositório Android Open Source Project (AOSP). Este boletim também inclui links para patches fora do AOSP.

O mais grave desses problemas é uma vulnerabilidade de segurança crítica que pode permitir a execução remota de código em um dispositivo afetado por meio de vários métodos, como email, navegação na Web e MMS, ao processar arquivos de mídia. A avaliação da gravidade é baseada no efeito que a exploração da vulnerabilidade possivelmente teria em um dispositivo afetado, assumindo que a plataforma e as atenuações do serviço estão desabilitadas para fins de desenvolvimento ou se contornadas com sucesso.

Não recebemos relatórios de exploração ativa do cliente ou abuso desses problemas relatados recentemente. Consulte a seção de mitigações de serviço do Android e do Google para obter detalhes sobre as proteções da plataforma de segurança Android e as proteções de serviço, como SafetyNet, que melhoram a segurança da plataforma Android.

Incentivamos todos os clientes a aceitar essas atualizações em seus dispositivos.

Anúncios

  • Boletim revisado para corrigir CVE-2016-3856 para CVE-2016-2060.
  • Este boletim tem duas sequências de nível de patch de segurança para fornecer aos parceiros Android a flexibilidade de se mover mais rapidamente para corrigir um subconjunto de vulnerabilidades que são semelhantes em todos os dispositivos Android. Consulte Perguntas e respostas comuns para obter informações adicionais:
    • 01/08/2016 : String de nível de patch de segurança parcial. Esta string de nível de patch de segurança indica que todos os problemas associados a 2016-08-01 (e todas as strings de nível de patch de segurança anteriores) foram resolvidos.
    • 05-08-2016 : string de nível de patch de segurança completa. Esta string de nível de patch de segurança indica que todos os problemas associados a 2016-08-01 e 2016-08-05 (e todas as strings de nível de patch de segurança anteriores) foram resolvidos.
  • Os dispositivos Nexus com suporte receberão uma única atualização OTA com o nível de patch de segurança de 5 de agosto de 2016.

Reduções de serviço do Android e do Google

Este é um resumo das atenuações fornecidas pela plataforma de segurança Android e proteções de serviço, como SafetyNet. Esses recursos reduzem a probabilidade de que as vulnerabilidades de segurança possam ser exploradas com êxito no Android.

  • A exploração de muitos problemas no Android é dificultada pelos aprimoramentos nas versões mais recentes da plataforma Android. Incentivamos todos os usuários a atualizar para a versão mais recente do Android sempre que possível.
  • A equipe de segurança do Android monitora ativamente o abuso com Verify Apps e SafetyNet , que são projetados para alertar os usuários sobre aplicativos potencialmente nocivos . Verificar aplicativos é habilitado por padrão em dispositivos com Google Mobile Services e é especialmente importante para usuários que instalam aplicativos de fora do Google Play. As ferramentas de rooting do dispositivo são proibidas no Google Play, mas o Verify Apps avisa os usuários quando eles tentam instalar um aplicativo de rooting detectado, não importa de onde ele venha. Além disso, o Verify Apps tenta identificar e bloquear a instalação de aplicativos mal-intencionados conhecidos que exploram uma vulnerabilidade de escalonamento de privilégios. Se tal aplicativo já tiver sido instalado, o Verify Apps notificará o usuário e tentará remover o aplicativo detectado.
  • Conforme apropriado, os aplicativos Google Hangouts e Messenger não passam mídia automaticamente para processos como o Mediaserver.

Reconhecimentos

Gostaríamos de agradecer a esses pesquisadores por suas contribuições:

Gostaríamos de agradecer a Daniel Micay da Copperhead Security, Jeff Vander Stoep e Yabin Cui do Google por sua contribuição com atualizações no nível da plataforma para mitigar uma classe de vulnerabilidades, como CVE-2016-3843. Esta mitigação é baseada no trabalho de Brad Spengler da Grsecurity.

Nível do patch de segurança de 01/08/2016 - detalhes de vulnerabilidade de segurança

Nas seções abaixo, fornecemos detalhes para cada uma das vulnerabilidades de segurança que se aplicam ao nível de patch de 01/08/2016. Há uma descrição do problema, uma justificativa de gravidade e uma tabela com o CVE, referências associadas, gravidade, dispositivos Nexus atualizados, versões AOSP atualizadas (quando aplicável) e data relatada. Quando disponível, vincularemos a alteração pública que abordou o problema ao ID do bug, como a lista de alterações AOSP. Quando várias alterações estão relacionadas a um único bug, referências adicionais são vinculadas a números após a ID do bug.

Vulnerabilidade de execução remota de código no Mediaserver

Uma vulnerabilidade de execução remota de código no Mediaserver pode permitir que um invasor use um arquivo especialmente criado para causar corrupção de memória durante o processamento de arquivos de mídia e dados. Este problema é classificado como Crítico devido à possibilidade de execução remota de código dentro do contexto do processo Mediaserver. O processo Mediaserver tem acesso a fluxos de áudio e vídeo, bem como acesso a privilégios que aplicativos de terceiros normalmente não poderiam acessar.

A funcionalidade afetada é fornecida como uma parte central do sistema operacional e há vários aplicativos que permitem que ela seja acessada com conteúdo remoto, principalmente MMS e reprodução de mídia no navegador.

CVE Referências Gravidade Dispositivos Nexus atualizados Versões atualizadas de AOSP Data relatada
CVE-2016-3819 A-28533562 Crítico All Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2 de maio de 2016
CVE-2016-3820 A-28673410 Crítico All Nexus 6.0, 6.0.1 6 de maio de 2016
CVE-2016-3821 A-28166152 Crítico All Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Interno do Google

Vulnerabilidade de execução remota de código no libjhead

Uma vulnerabilidade de execução remota de código no libjhead pode permitir que um invasor usando um arquivo especialmente criado execute código arbitrário no contexto de um processo sem privilégios. Este problema é classificado como Alto devido à possibilidade de execução remota de código em aplicativos que usam esta biblioteca.

CVE Referências Gravidade Dispositivos Nexus atualizados Versões atualizadas de AOSP Data relatada
CVE-2016-3822 A-28868315 Alto All Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Interno do Google

Vulnerabilidade de elevação de privilégio no Mediaserver

Uma vulnerabilidade de elevação de privilégio no Mediaserver pode permitir que um aplicativo malicioso local execute código arbitrário no contexto de um processo privilegiado. Esse problema é classificado como Alto porque pode ser usado para obter acesso local a recursos elevados, que normalmente não são acessíveis a um aplicativo de terceiros.

CVE Referências Gravidade Dispositivos Nexus atualizados Versões atualizadas de AOSP Data relatada
CVE-2016-3823 A-28815329 Alto All Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 17 de maio de 2016
CVE-2016-3824 A-28816827 Alto All Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 17 de maio de 2016
CVE-2016-3825 A-28816964 Alto All Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 17 de maio de 2016
CVE-2016-3826 A-29251553 Alto All Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 9 de junho de 2016

Vulnerabilidade de negação de serviço no Mediaserver

Uma vulnerabilidade de negação de serviço no Mediaserver pode permitir que um invasor use um arquivo especialmente criado para causar o travamento ou reinicialização do dispositivo. Esse problema foi classificado como Alto devido à possibilidade de negação de serviço remota temporária.

CVE Referências Gravidade Dispositivos Nexus atualizados Versões atualizadas de AOSP Data relatada
CVE-2016-3827 A-28816956 Alto All Nexus 6.0.1 16 de maio de 2016
CVE-2016-3828 A-28835995 Alto All Nexus 6.0, 6.0.1 17 de maio de 2016
CVE-2016-3829 A-29023649 Alto All Nexus 6.0, 6.0.1 27 de maio de 2016
CVE-2016-3830 A-29153599 Alto All Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Interno do Google

Vulnerabilidade de negação de serviço no relógio do sistema

Uma vulnerabilidade de negação de serviço no relógio do sistema pode permitir que um invasor remoto bloqueie o dispositivo. Esse problema foi classificado como Alto devido à possibilidade de negação de serviço remota temporária.

CVE Referências Gravidade Dispositivos Nexus atualizados Versões atualizadas de AOSP Data relatada
CVE-2016-3831 A-29083635 Alto All Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 31 de maio de 2016

Vulnerabilidade de elevação de privilégio em APIs de estrutura

Uma vulnerabilidade de elevação de privilégio nas APIs de estrutura pode permitir que um aplicativo mal-intencionado local ignore as proteções do sistema operacional que isolam os dados do aplicativo de outros aplicativos. Este problema é classificado como moderado porque pode ser usado para obter acesso a dados que estão fora dos níveis de permissão do aplicativo.

CVE Referências Gravidade Dispositivos Nexus atualizados Versões atualizadas de AOSP Data relatada
CVE-2016-3832 A-28795098 Moderado All Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 15 de maio de 2016

Vulnerabilidade de elevação de privilégio no Shell

Uma elevação de privilégio no Shell pode permitir que um aplicativo mal-intencionado local ignore as restrições do dispositivo, como restrições do usuário. Este problema é classificado como moderado porque é um desvio local das permissões do usuário.

CVE Referências Gravidade Dispositivos Nexus atualizados Versões atualizadas de AOSP Data relatada
CVE-2016-3833 A-29189712 [ 2 ] Moderado All Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 Interno do Google

Vulnerabilidade de divulgação de informações no OpenSSL

Uma vulnerabilidade de divulgação de informações no OpenSSL pode permitir que um aplicativo malicioso local acesse dados fora de seus níveis de permissão. Este problema é classificado como moderado porque pode ser usado para acessar dados confidenciais sem permissão.

CVE Referências Gravidade Dispositivos Nexus atualizados Versões atualizadas de AOSP Data relatada
CVE-2016-2842 A-29060514 Nenhum* All Nexus 4.4.4, 5.0.2, 5.1.1 29 de março de 2016

* Dispositivos Nexus com suporte que instalaram todas as atualizações disponíveis não são afetados por esta vulnerabilidade

Vulnerabilidade de divulgação de informações em APIs de câmera

Uma vulnerabilidade de divulgação de informações nas APIs da câmera pode permitir que um aplicativo malicioso local acesse estruturas de dados fora de seus níveis de permissão. Este problema é classificado como moderado porque pode ser usado para acessar dados confidenciais sem permissão.

CVE Referências Gravidade Dispositivos Nexus atualizados Versões atualizadas de AOSP Data relatada
CVE-2016-3834 A-28466701 Moderado All Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 28 de abril de 2016

Vulnerabilidade de divulgação de informações no Mediaserver

Uma vulnerabilidade de divulgação de informações no Mediaserver pode permitir que um aplicativo malicioso local acesse dados fora de seus níveis de permissão. Este problema é classificado como moderado porque pode ser usado para acessar dados confidenciais sem permissão.

CVE Referências Gravidade Dispositivos Nexus atualizados Versões atualizadas de AOSP Data relatada
CVE-2016-3835 A-28920116 Moderado All Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 23 de maio de 2016

Vulnerabilidade de divulgação de informações no SurfaceFlinger

Uma vulnerabilidade de divulgação de informações no serviço SurfaceFlinger pode permitir que um aplicativo mal-intencionado local acesse dados fora de seus níveis de permissão. Este problema é classificado como moderado porque pode ser usado para acessar dados confidenciais sem permissão explícita do usuário.

CVE Referências Gravidade Dispositivos Nexus atualizados Versões atualizadas de AOSP Data relatada
CVE-2016-3836 A-28592402 Moderado All Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 4 de maio de 2016

Vulnerabilidade de divulgação de informações em Wi-Fi

Uma vulnerabilidade de divulgação de informações no Wi-Fi pode permitir que um aplicativo malicioso local acesse dados fora de seus níveis de permissão. Este problema é classificado como moderado porque pode ser usado para acessar dados confidenciais sem permissão.

CVE Referências Gravidade Dispositivos Nexus atualizados Versões atualizadas de AOSP Data relatada
CVE-2016-3837 A-28164077 Moderado All Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 Interno do Google

Vulnerabilidade de negação de serviço na IU do sistema

Uma vulnerabilidade de negação de serviço na IU do sistema pode permitir que um aplicativo malicioso local impeça chamadas para o 911 de uma tela bloqueada. Este problema foi classificado como moderado devido à possibilidade de negação de serviço em uma função crítica.

CVE Referências Gravidade Dispositivos Nexus atualizados Versões atualizadas de AOSP Data relatada
CVE-2016-3838 A-28761672 Moderado All Nexus 6.0, 6.0.1 Interno do Google

Vulnerabilidade de negação de serviço no Bluetooth

Uma vulnerabilidade de negação de serviço no Bluetooth pode permitir que um aplicativo malicioso local impeça chamadas 911 de um dispositivo Bluetooth. Este problema foi classificado como moderado devido à possibilidade de negação de serviço em uma função crítica.

CVE Referências Gravidade Dispositivos Nexus atualizados Versões atualizadas de AOSP Data relatada
CVE-2016-3839 A-28885210 Moderado All Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Interno do Google

Nível do patch de segurança de 05/08/2016 - detalhes da vulnerabilidade

Nas seções abaixo, fornecemos detalhes para cada uma das vulnerabilidades de segurança que se aplicam ao nível de patch 2016-08-05. Há uma descrição do problema, uma justificativa de gravidade e uma tabela com o CVE, referências associadas, gravidade, dispositivos Nexus atualizados, versões AOSP atualizadas (quando aplicável) e data relatada. Quando disponível, vincularemos a alteração pública que abordou o problema ao ID do bug, como a lista de alterações do AOSP. Quando várias alterações estão relacionadas a um único bug, referências adicionais são vinculadas a números após a ID do bug.

Vulnerabilidade de execução remota de código no driver Qualcomm Wi-Fi

Uma vulnerabilidade de execução remota de código no driver Qualcomm Wi-Fi pode permitir que um invasor remoto execute código arbitrário dentro do contexto do kernel. Este problema foi classificado como Crítico devido à possibilidade de comprometimento de um dispositivo local permanente.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2014-9902 A-28668638

QC-CR # 553937
QC-CR # 553941

Crítico Nexus 7 (2013) 31 de março de 2014

Vulnerabilidade de execução remota de código no Conscrypt

Uma vulnerabilidade de execução remota de código no Conscrypt pode permitir que um invasor remoto execute código arbitrário dentro do contexto de um processo privilegiado. Este problema é classificado como Crítico devido à possibilidade de execução remota de código.

CVE Referências Gravidade Dispositivos Nexus atualizados Versões atualizadas de AOSP Data relatada
CVE-2016-3840 A-28751153 Crítico All Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Interno do Google

Vulnerabilidade de elevação de privilégio em componentes Qualcomm

A tabela abaixo contém vulnerabilidades de segurança que afetam os componentes Qualcomm, potencialmente incluindo o bootloader, driver de câmera, unidade de personagem, rede, driver de som e driver de vídeo.

O mais grave desses problemas é classificado como Crítico devido à possibilidade de um aplicativo malicioso local executar código arbitrário dentro do contexto do kernel, levando ao comprometimento do dispositivo local permanente, o que pode exigir o reflash do sistema operacional para reparar o dispositivo.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2014-9863 A-28768146

QC-CR # 549470

Crítico Nexus 5, Nexus 7 (2013) 30 de abril de 2014
CVE-2014-9864 A-28747998

QC-CR # 561841

Alto Nexus 5, Nexus 7 (2013) 27 de março de 2014
CVE-2014-9865 A-28748271

QC-CR # 550013

Alto Nexus 5, Nexus 7 (2013) 27 de março de 2014
CVE-2014-9866 A-28747684

QC-CR # 511358

Alto Nexus 5, Nexus 7 (2013) 31 de março de 2014
CVE-2014-9867 A-28749629

QC-CR # 514702

Alto Nexus 5, Nexus 7 (2013) 31 de março de 2014
CVE-2014-9868 A-28749721

QC-CR # 511976

Alto Nexus 5, Nexus 7 (2013) 31 de março de 2014
CVE-2014-9869 A-28749728

QC-CR # 514711 [ 2 ]

Alto Nexus 5, Nexus 7 (2013) 31 de março de 2014
CVE-2014-9870 A-28749743

QC-CR # 561044

Alto Nexus 5, Nexus 7 (2013) 31 de março de 2014
CVE-2014-9871 A-28749803

QC-CR # 514717

Alto Nexus 5, Nexus 7 (2013) 31 de março de 2014
CVE-2014-9872 A-28750155

QC-CR # 590721

Alto Nexus 5 31 de março de 2014
CVE-2014-9873 A-28750726

QC-CR # 556860

Alto Nexus 5, Nexus 7 (2013) 31 de março de 2014
CVE-2014-9874 A-28751152

QC-CR # 563086

Alto Nexus 5, Nexus 5X, Nexus 6P, Nexus 7 (2013) 31 de março de 2014
CVE-2014-9875 A-28767589

QC-CR # 483310

Alto Nexus 7 (2013) 30 de abril de 2014
CVE-2014-9876 A-28767796

QC-CR # 483408

Alto Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 7 (2013) 30 de abril de 2014
CVE-2014-9877 A-28768281

QC-CR # 547231

Alto Nexus 5, Nexus 7 (2013) 30 de abril de 2014
CVE-2014-9878 A-28769208

QC-CR # 547479

Alto Nexus 5 30 de abril de 2014
CVE-2014-9879 A-28769221

QC-CR # 524490

Alto Nexus 5 30 de abril de 2014
CVE-2014-9880 A-28769352

QC-CR # 556356

Alto Nexus 7 (2013) 30 de abril de 2014
CVE-2014-9881 A-28769368

QC-CR # 539008

Alto Nexus 7 (2013) 30 de abril de 2014
CVE-2014-9882 A-28769546

QC-CR # 552329 [ 2 ]

Alto Nexus 7 (2013) 30 de abril de 2014
CVE-2014-9883 A-28769912

QC-CR # 565160

Alto Nexus 5, Nexus 7 (2013) 30 de abril de 2014
CVE-2014-9884 A-28769920

QC-CR # 580740

Alto Nexus 5, Nexus 7 (2013) 30 de abril de 2014
CVE-2014-9885 A-28769959

QC-CR # 562261

Alto Nexus 5 30 de abril de 2014
CVE-2014-9886 A-28815575

QC-CR # 555030

Alto Nexus 5, Nexus 7 (2013) 30 de abril de 2014
CVE-2014-9887 A-28804057

QC-CR # 636633

Alto Nexus 5, Nexus 7 (2013) 3 de julho de 2014
CVE-2014-9888 A-28803642

QC-CR # 642735

Alto Nexus 5, Nexus 7 (2013) 29 de agosto de 2014
CVE-2014-9889 A-28803645

QC-CR # 674712

Alto Nexus 5 31 de outubro de 2014
CVE-2015-8937 A-28803962

QC-CR # 770548

Alto Nexus 5, Nexus 6, Nexus 7 (2013) 31 de março de 2015
CVE-2015-8938 A-28804030

QC-CR # 766022

Alto Nexus 6 31 de março de 2015
CVE-2015-8939 A-28398884

QC-CR # 779021

Alto Nexus 7 (2013) 30 de abril de 2015
CVE-2015-8940 A-28813987

QC-CR # 792367

Alto Nexus 6 30 de abril de 2015
CVE-2015-8941 A-28814502

QC-CR # 792473

Alto Nexus 6, Nexus 7 (2013) 29 de maio de 2015
CVE-2015-8942 A-28814652

QC-CR # 803246

Alto Nexus 6 30 de junho de 2015
CVE-2015-8943 A-28815158

QC-CR # 794217

QC-CR # 836226

Alto Nexus 5 11 de setembro de 2015
CVE-2014-9891 A-28749283

QC-CR # 550061

Moderado Nexus 5 13 de março de 2014
CVE-2014-9890 A-28770207

QC-CR # 529177

Moderado Nexus 5, Nexus 7 (2013) 2 de junho de 2014

Vulnerabilidade de elevação de privilégio no componente de rede do kernel

Uma vulnerabilidade de elevação de privilégio no componente de rede do kernel pode permitir que um aplicativo mal-intencionado local execute código arbitrário dentro do contexto do kernel. Este problema é classificado como Crítico devido à possibilidade de comprometimento de um dispositivo local permanente, o que pode exigir o reflash do sistema operacional para reparar o dispositivo.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2015-2686 A-28759139

Kernel upstream

Crítico All Nexus 23 de março de 2015
CVE-2016-3841 A-28746669

Kernel upstream

Crítico All Nexus 3 de dezembro de 2015

Vulnerabilidade de elevação de privilégio no driver Qualcomm GPU

Uma vulnerabilidade de elevação de privilégio no driver Qualcomm GPU pode permitir que um aplicativo malicioso local execute código arbitrário dentro do contexto do kernel. Este problema é classificado como Crítico devido à possibilidade de comprometimento do dispositivo permanente local, o que pode exigir o reflash do sistema operacional para reparar o dispositivo.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2016-2504 A-28026365

QC-CR # 1002974

Crítico Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 7 (2013) 5 de abril de 2016
CVE-2016-3842 A-28377352

QC-CR # 1002974

Crítico Nexus 5X, Nexus 6, Nexus 6P 25 de abril de 2016

* O patch para este problema não está disponível publicamente. A atualização está contida nos drivers binários mais recentes para dispositivos Nexus disponíveis no site Google Developer .

Vulnerabilidade de elevação de privilégio no componente de desempenho Qualcomm

Uma vulnerabilidade de elevação de privilégio no componente de desempenho Qualcomm pode permitir que um aplicativo malicioso local execute código arbitrário no contexto do kernel. Este problema é classificado como Crítico devido à possibilidade de comprometimento de um dispositivo local permanente, o que pode exigir o reflash do sistema operacional para reparar o dispositivo.

Nota: Há também uma atualização de nível de plataforma neste boletim em A-29119870 que foi projetada para atenuar essa classe de vulnerabilidades.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2016-3843 A-28086229 *

QC-CR # 1011071

Crítico Nexus 5X, Nexus 6P 7 de abril de 2016

* O patch para este problema não está disponível publicamente. A atualização está contida nos drivers binários mais recentes para dispositivos Nexus disponíveis no site Google Developer .

Vulnerabilidade de elevação de privilégio no kernel

Uma vulnerabilidade de elevação de privilégio no kernel pode permitir que um aplicativo mal-intencionado local execute código arbitrário dentro do contexto do kernel. Este problema é classificado como Crítico devido à possibilidade de comprometimento de um dispositivo local permanente, o que pode exigir o reflash do sistema operacional para reparar o dispositivo.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2016-3857 A-28522518 * Crítico Nexus 7 (2013) 2 de maio de 2016

* O patch para este problema não está disponível publicamente. A atualização está contida nos drivers binários mais recentes para dispositivos Nexus disponíveis no site Google Developer .

Vulnerabilidade de elevação de privilégio no sistema de memória do kernel

Uma vulnerabilidade de elevação de privilégio no sistema de memória do kernel pode permitir que um aplicativo malicioso local execute código arbitrário dentro do contexto do kernel. Este problema é classificado como Alto porque primeiro requer o comprometimento de um processo privilegiado.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2015-1593 A-29577822

Kernel upstream

Alto Nexus Player 13 de fevereiro de 2015
CVE-2016-3672 A-28763575

Kernel upstream

Alto Nexus Player 25 de março de 2016

Vulnerabilidade de elevação de privilégio no componente de som do kernel

Uma vulnerabilidade de elevação de privilégio no componente de som do kernel pode permitir que um aplicativo malicioso local execute código arbitrário dentro do contexto do kernel. Este problema é classificado como Alto porque primeiro requer o comprometimento de um processo privilegiado.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2016-2544 A-28695438

Kernel upstream

Alto All Nexus 19 de janeiro de 2016
CVE-2016-2546 A-28694392

Kernel upstream

Alto Pixel C 19 de janeiro de 2016
CVE-2014-9904 A-28592007

Kernel upstream

Alto Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Nexus Player 4 de maio de 2016

Vulnerabilidade de elevação de privilégio no sistema de arquivos kernel

Uma vulnerabilidade de elevação de privilégio no sistema de arquivos do kernel pode permitir que um aplicativo mal-intencionado local execute código arbitrário dentro do contexto do kernel. Este problema é classificado como Alto porque primeiro requer o comprometimento de um processo privilegiado.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2012-6701 A-28939037

Kernel upstream

Alto Nexus 5, Nexus 7 (2013) 2 de março de 2016

Vulnerabilidade de elevação de privilégio no Mediaserver

Uma vulnerabilidade de elevação de privilégio no Mediaserver pode permitir que um aplicativo malicioso local execute código arbitrário dentro do contexto de um processo privilegiado. Esse problema é classificado como Alto porque pode ser usado para obter acesso local a recursos elevados, que não são acessíveis a um aplicativo de terceiros.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2016-3844 A-28299517 *

N-CVE-2016-3844

Alto Nexus 9, Pixel C 19 de abril de 2016

* O patch para este problema não está disponível publicamente. A atualização está contida nos drivers binários mais recentes para dispositivos Nexus disponíveis no site Google Developer .

Vulnerabilidade de elevação de privilégio no driver de vídeo do kernel

Uma vulnerabilidade de elevação de privilégio no driver de vídeo do kernel pode permitir que um aplicativo mal-intencionado local execute código arbitrário dentro do contexto do kernel. Este problema é classificado como Alto porque primeiro requer o comprometimento de um processo privilegiado.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2016-3845 A-28399876 * Alto Nexus 5 20 de abril de 2016

* O patch para este problema não está disponível publicamente. A atualização está contida nos drivers binários mais recentes para dispositivos Nexus disponíveis no site Google Developer .

Vulnerabilidade de elevação de privilégio no driver da Interface Periférica Serial

Uma vulnerabilidade de elevação de privilégio no driver Serial Peripheral Interface pode permitir que um aplicativo malicioso local execute código arbitrário dentro do contexto do kernel. Este problema é classificado como Alto porque primeiro requer o comprometimento de um processo privilegiado.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2016-3846 A-28817378 * Alto Nexus 5X, Nexus 6P 17 de maio de 2016

* O patch para este problema não está disponível publicamente. A atualização está contida nos drivers binários mais recentes para dispositivos Nexus disponíveis no site Google Developer .

Vulnerabilidade de elevação de privilégio no driver de mídia NVIDIA

Uma vulnerabilidade de elevação de privilégio no driver de mídia NVIDIA pode permitir que um aplicativo malicioso local execute código arbitrário no contexto do kernel. Este problema é classificado como Alto porque primeiro requer o comprometimento de um processo privilegiado.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2016-3847 A-28871433 *

N-CVE-2016-3847

Alto Nexus 9 19 de maio de 2016
CVE-2016-3848 A-28919417 *

N-CVE-2016-3848

Alto Nexus 9 19 de maio de 2016

* O patch para este problema não está disponível publicamente. A atualização está contida nos drivers binários mais recentes para dispositivos Nexus disponíveis no site Google Developer .

Vulnerabilidade de elevação de privilégio no driver ION

Uma vulnerabilidade de elevação de privilégio no driver ION pode permitir que um aplicativo malicioso local execute código arbitrário dentro do contexto do kernel. Este problema é classificado como Alto porque primeiro requer o comprometimento de um processo privilegiado.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2016-3849 A-28939740 Alto Pixel C 24 de maio de 2016

* O patch para este problema não está disponível publicamente. A atualização está contida nos drivers binários mais recentes para dispositivos Nexus disponíveis no site Google Developer .

Vulnerabilidade de elevação de privilégio no bootloader Qualcomm

Uma vulnerabilidade de elevação de privilégio no bootloader Qualcomm pode permitir que um aplicativo malicioso local execute código arbitrário dentro do contexto do kernel. Este problema é classificado como Alto porque primeiro requer o comprometimento de um processo privilegiado.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2016-3850 A-27917291

QC-CR # 945164

Alto Nexus 5, Nexus 5X, Nexus 6P, Nexus 7 (2013) 28 de março de 2016

Vulnerabilidade de elevação de privilégio no subsistema de desempenho do kernel

Vulnerabilidades de elevação de privilégio no subsistema de desempenho do kernel podem permitir que um aplicativo mal-intencionado local execute código arbitrário dentro do contexto do kernel. Esse problema foi classificado como Alto devido à superfície de ataque do kernel disponível para exploração pelos invasores.

Observação: esta é uma atualização de nível de plataforma projetada para mitigar uma classe de vulnerabilidades, como CVE-2016-3843 (A-28086229).

CVE Referências Gravidade Dispositivos Nexus atualizados Versões atualizadas de AOSP Data relatada
CVE-2016-3843 A-29119870 * Alto All Nexus 6,0, 6,1 Interno do Google

* Um patch para este problema não está disponível publicamente. A atualização está contida nos drivers binários mais recentes para dispositivos Nexus disponíveis no site Google Developer .

Vulnerabilidade de elevação de privilégio no bootloader da LG Electronics

Uma vulnerabilidade de elevação de privilégio no bootloader da LG Electronics pode permitir que um invasor execute código arbitrário dentro do contexto do kernel. Este problema é classificado como Alto porque primeiro requer o comprometimento de um processo privilegiado.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2016-3851 A-29189941 * Alto Nexus 5X Interno do Google

* O patch para este problema não está disponível publicamente. A atualização está contida nos drivers binários mais recentes para dispositivos Nexus disponíveis no site Google Developer .

Vulnerabilidade de divulgação de informações em componentes Qualcomm

A tabela abaixo contém vulnerabilidades de segurança que afetam os componentes da Qualcomm, incluindo potencialmente o bootloader, driver de câmera, driver de personagem, rede, driver de som e driver de vídeo.

O mais grave desses problemas é classificado como Alto devido à possibilidade de um aplicativo malicioso local acessar dados fora de seus níveis de permissão, como dados confidenciais sem a permissão explícita do usuário.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2014-9892 A-28770164

QC-CR # 568717

Alto Nexus 5, Nexus 7 (2013) 2 de junho de 2014
CVE-2015-8944 A-28814213

QC-CR # 786116

Alto Nexus 6, Nexus 7 (2013) 30 de abril de 2015
CVE-2014-9893 A-28747914

QC-CR # 542223

Moderado Nexus 5 27 de março de 2014
CVE-2014-9894 A-28749708

QC-CR # 545736

Moderado Nexus 7 (2013) 31 de março de 2014
CVE-2014-9895 A-28750150

QC-CR # 570757

Moderado Nexus 5, Nexus 7 (2013) 31 de março de 2014
CVE-2014-9896 A-28767593

QC-CR # 551795

Moderado Nexus 5, Nexus 7 (2013) 30 de abril de 2014
CVE-2014-9897 A-28769856

QC-CR # 563752

Moderado Nexus 5 30 de abril de 2014
CVE-2014-9898 A-28814690

QC-CR # 554575

Moderado Nexus 5, Nexus 7 (2013) 30 de abril de 2014
CVE-2014-9899 A-28803909

QC-CR # 547910

Moderado Nexus 5 3 de julho de 2014
CVE-2014-9900 A-28803952

QC-CR # 570754

Moderado Nexus 5, Nexus 7 (2013) 8 de agosto de 2014

Vulnerabilidade de divulgação de informações no agendador de kernel

Uma vulnerabilidade de divulgação de informações no agendador do kernel pode permitir que um aplicativo mal-intencionado local acesse dados fora de seus níveis de permissão. Este problema foi classificado como Alto porque pode ser usado para acessar dados confidenciais sem a permissão explícita do usuário.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2014-9903 A-28731691

Kernel upstream

Alto Nexus 5X, Nexus 6P 21 de fevereiro de 2014

Vulnerabilidade de divulgação de informações no driver MediaTek Wi-Fi (específico do dispositivo)

Uma vulnerabilidade de divulgação de informações no driver MediaTek Wi-Fi pode permitir que um aplicativo malicioso local acesse dados fora de seus níveis de permissão. Este problema foi classificado como Alto porque pode ser usado para acessar dados confidenciais sem a permissão explícita do usuário.

CVE Referências Gravidade Dispositivos Nexus atualizados Data relatada
CVE-2016-3852 A-29141147 *

M-ALPS02751738

Alto Android One 12 de abril de 2016

* O patch para este problema não está disponível publicamente. A atualização está contida nos drivers binários mais recentes para dispositivos Nexus disponíveis no site Google Developer .

Vulnerabilidade de divulgação de informações no driver USB

An information disclosure vulnerability in the USB driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-4482 A-28619695

Upstream kernel

High All Nexus May 3, 2016

Denial of service vulnerability in Qualcomm components

The table below contains security vulnerabilities affecting Qualcomm components, potentially including the Wi-Fi driver.

The most severe of these issues is rated as High due to the possibility that an attacker could cause a temporary remote denial of service resulting in a device hang or reboot.

CVE References Severity Updated Nexus devices Date reported
CVE-2014-9901 A-28670333

QC-CR#548711

High Nexus 7 (2013) Mar 31, 2014

Elevation of privilege vulnerability in Google Play services

An elevation of privilege vulnerability in Google Play services could allow a local attacker to bypass the Factory Reset Protection and gain access to the device. This is rated as Moderate due to the possibility of bypassing Factory Reset Protection, which could lead to successfully resetting the device and erasing all its data.

CVE References Severity Updated Nexus devices Updated AOSP versions Date reported
CVE-2016-3853 A-26803208* Moderate All Nexus None May 4, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Framework APIs

An elevation of privilege vulnerability in the framework APIs could enable a pre-installed application to increase its intent filter priority when the application is being updated without the user being notified. This issue is rated as Moderate because it could be used to gain elevated capabilities without explicit user permission.

CVE References Severity Updated Nexus devices Updated AOSP versions Date reported
CVE-2016-2497 A-27450489 Moderate All Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Google internal

Information disclosure vulnerability in kernel networking component

An information disclosure vulnerability in the kernel networking component could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-4486 A-28620102

Upstream kernel

Moderate All Nexus May 3, 2016

Information disclosure vulnerability in kernel sound component

An information disclosure vulnerability in the kernel sound component could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-4569 A-28980557

Upstream kernel

Moderate All Nexus May 9, 2016
CVE-2016-4578 A-28980217

Upstream kernel [ 2 ]

Moderate All Nexus May 11, 2016

Vulnerabilities in Qualcomm components

The table below contains security vulnerabilities affecting Qualcomm components, potentially including the bootloader, camera driver, character driver, networking, sound driver, and video driver.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3854 QC-CR#897326 High None Feb 2016
CVE-2016-3855 QC-CR#990824 High None May 2016
CVE-2016-2060 QC-CR#959631 Moderate None Apr 2016

Common Questions and Answers

This section answers common questions that may occur after reading this bulletin.

1. How do I determine if my device is updated to address these issues?

Security Patch Levels of 2016-08-01 or later address all issues associated with the 2016-08-01 security patch string level. Security Patch Levels of 2016-08-05 or later address all issues associated with the 2016-08-05 security patch string level. Refer to the help center for instructions on how to check the security patch level. Device manufacturers that include these updates should set the patch string level to: [ro.build.version.security_patch]:[2016-08-01] or [ro.build.version.security_patch]:[2016-08-05].

2. Why does this bulletin have two security patch level strings?

This bulletin has two security patch level strings in order to provide Android partners with the flexibility to move more quickly to fix a subset of vulnerabilities that are similar across all Android devices. Android partners are encouraged to fix all issues in this bulletin and use the latest security patch level string.

Devices that use the security patch level of August 5, 2016 or newer must include all applicable patches in this (and previous) security bulletins.

Devices that use the August 1, 2016 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins. Devices that use August 1, 2016 security patch level may also include a subset of fixes associated with the August 5, 2016 security patch level.

3 . How do I determine which Nexus devices are affected by each issue?

In the 2016-08-01 and 2016-08-05 security vulnerability details sections, each table has an Updated Nexus devices column that covers the range of affected Nexus devices updated for each issue. This column has a few options:

  • All Nexus devices : If an issue affects all Nexus devices, the table will have “All Nexus” in the Updated Nexus devices column. “All Nexus” encapsulates the following supported devices : Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 7 (2013), Nexus 9, Android One, Nexus Player, and Pixel C.
  • Some Nexus devices : If an issue doesn't affect all Nexus devices, the affected Nexus devices are listed in the Updated Nexus devices column.
  • No Nexus devices : If no Nexus devices are affected by the issue, the table will have “None” in the Updated Nexus devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefix Reference
A- Android bug ID
QC- Qualcomm reference number
M- MediaTek reference number
N- NVIDIA reference number

Revisions

  • August 01, 2016: Bulletin published.
  • August 02, 2016: Bulletin revised to include AOSP links.
  • August 16, 2016: CVE-2016-3856 corrected to CVE-2016-2060 and updated the reference URL.
  • October 21, 2016: Corrected typo in CVE-2016-4486.