Google se compromete a impulsar la igualdad racial para las comunidades afrodescendientes. Obtén información al respecto.

Boletín de seguridad de Android: enero de 2017

Organiza tus páginas con colecciones Guarda y categoriza el contenido según tus preferencias.

Publicado 03 de enero de 2017 | Actualizado el 2 de febrero de 2017

El Boletín de seguridad de Android contiene detalles de las vulnerabilidades de seguridad que afectan a los dispositivos Android. Junto con el boletín, lanzamos una actualización de seguridad para los dispositivos de Google a través de una actualización inalámbrica (OTA). Las imágenes del firmware del dispositivo de Google también se publicaron en el sitio para desarrolladores de Google . Los niveles de parches de seguridad del 5 de enero de 2017 o posteriores abordan todos estos problemas. Consulte el programa de actualización de Pixel y Nexus para obtener información sobre cómo verificar el nivel del parche de seguridad de un dispositivo.

Los socios fueron notificados de los problemas descritos en el boletín el 05 de diciembre de 2016 o antes. Los parches de código fuente para estos problemas se publicaron en el repositorio del Proyecto de código abierto de Android (AOSP) y se vincularon desde este boletín. Este boletín también incluye enlaces a parches fuera de AOSP.

El más grave de estos problemas es una vulnerabilidad de seguridad crítica que podría permitir la ejecución remota de código en un dispositivo afectado a través de múltiples métodos, como correo electrónico, navegación web y MMS al procesar archivos multimedia. La evaluación de la gravedad se basa en el efecto que podría tener la explotación de la vulnerabilidad en un dispositivo afectado, suponiendo que las mitigaciones de la plataforma y el servicio estén deshabilitadas para fines de desarrollo o si se eluden con éxito.

No hemos recibido informes de explotación activa de clientes o abuso de estos problemas recientemente informados. Consulte la sección Mitigaciones de servicios de Android y Google para obtener detalles sobre las protecciones de la plataforma de seguridad de Android y las protecciones de servicios como SafetyNet , que mejoran la seguridad de la plataforma Android.

Alentamos a todos los clientes a aceptar estas actualizaciones en sus dispositivos.

Anuncios

  • Este boletín tiene dos cadenas de nivel de parche de seguridad para brindar a los socios de Android la flexibilidad de solucionar más rápidamente un subconjunto de vulnerabilidades que son similares en todos los dispositivos Android. Consulte Preguntas y respuestas comunes para obtener información adicional:
    • 2017-01-01 : cadena de nivel de parche de seguridad parcial. Esta cadena de nivel de parche de seguridad indica que se abordaron todos los problemas asociados con 2017-01-01 (y todas las cadenas de nivel de parche de seguridad anteriores).
    • 2017-01-05 : cadena de nivel de parche de seguridad completa. Esta cadena de nivel de parche de seguridad indica que se abordaron todos los problemas asociados con 2017-01-01 y 2017-01-05 (y todas las cadenas de nivel de parche de seguridad anteriores).
  • Los dispositivos de Google compatibles recibirán una única actualización OTA con el nivel de parche de seguridad del 5 de enero de 2017.

Resumen de vulnerabilidad de seguridad

Las siguientes tablas contienen una lista de vulnerabilidades de seguridad, el ID de exposición y vulnerabilidad común (CVE), la gravedad evaluada y si los dispositivos de Google están afectados o no. La evaluación de la gravedad se basa en el efecto que podría tener la explotación de la vulnerabilidad en un dispositivo afectado, suponiendo que las mitigaciones de la plataforma y el servicio estén deshabilitadas para fines de desarrollo o si se eluden con éxito.

Mitigaciones de servicios de Android y Google

Este es un resumen de las mitigaciones proporcionadas por la plataforma de seguridad de Android y las protecciones de servicios, como SafetyNet. Estas capacidades reducen la probabilidad de que las vulnerabilidades de seguridad puedan explotarse con éxito en Android.

  • La explotación de muchos problemas en Android se hace más difícil debido a las mejoras en las versiones más recientes de la plataforma Android. Alentamos a todos los usuarios a actualizar a la última versión de Android siempre que sea posible.
  • El equipo de seguridad de Android monitorea activamente el abuso con Verify Apps y SafetyNet , que están diseñados para advertir a los usuarios sobre aplicaciones potencialmente dañinas . Verificar aplicaciones está habilitado de forma predeterminada en dispositivos con Google Mobile Services y es especialmente importante para los usuarios que instalan aplicaciones desde fuera de Google Play. Las herramientas de enraizamiento de dispositivos están prohibidas en Google Play, pero Verify Apps advierte a los usuarios cuando intentan instalar una aplicación de enraizamiento detectada, sin importar de dónde provenga. Además, Verify Apps intenta identificar y bloquear la instalación de aplicaciones maliciosas conocidas que explotan una vulnerabilidad de escalada de privilegios. Si ya se instaló una aplicación de este tipo, Verify Apps notificará al usuario e intentará eliminar la aplicación detectada.
  • Según corresponda, las aplicaciones Google Hangouts y Messenger no pasan automáticamente los medios a procesos como Mediaserver.

Agradecimientos

Nos gustaría agradecer a estos investigadores por sus contribuciones:

También nos gustaría agradecer a los siguientes investigadores por sus contribuciones a este boletín:

  • Baozeng Ding, Chengming Yang, Peng Xiao, Ning You, Yang Dong, Chao Yang, Yi Zhang y Yang Song de Alibaba Mobile Security Group
  • Peter Pi ( @heisecode ) de Trend Micro
  • Zubin Mitra de Google

Nivel de parche de seguridad 2017-01-01: detalles de vulnerabilidad

En las secciones a continuación, proporcionamos detalles para cada una de las vulnerabilidades de seguridad que se aplican al nivel de parche 2017-01-01. Hay una descripción del problema, una justificación de la gravedad y una tabla con el CVE, las referencias asociadas, la gravedad, los dispositivos de Google actualizados, las versiones actualizadas de AOSP (cuando corresponda) y la fecha en que se informó. Cuando esté disponible, vincularemos el cambio público que abordó el problema con el ID del error, como la lista de cambios de AOSP. Cuando varios cambios se relacionan con un solo error, las referencias adicionales se vinculan a los números que siguen al ID del error.

Vulnerabilidad de ejecución remota de código en c-ares

Una vulnerabilidad de ejecución remota de código en c-ares podría permitir que un atacante utilice una solicitud especialmente diseñada para ejecutar código arbitrario en el contexto de un proceso sin privilegios. Este problema se califica como alto debido a la posibilidad de ejecución remota de código en una aplicación que usa esta biblioteca.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2016-5180 A-32205736 Alto Todos 7.0 29 de septiembre de 2016

Vulnerabilidad de ejecución remota de código en Framesequence

Una vulnerabilidad de ejecución remota de código en la biblioteca Framesequence podría permitir que un atacante utilice un archivo especialmente diseñado para ejecutar código arbitrario en el contexto de un proceso sin privilegios. Este problema se califica como Alto debido a la posibilidad de ejecución remota de código en una aplicación que usa la biblioteca Framesequence.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0382 A-32338390 Alto Todos 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 21 de octubre de 2016

Vulnerabilidad de elevación de privilegios en las API de Framework

Una vulnerabilidad de elevación de privilegios en las API de Framework podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto de un proceso privilegiado. Este problema se califica como Alto porque podría usarse para obtener acceso local a capacidades elevadas, que normalmente no son accesibles para una aplicación de terceros.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0383 A-31677614 Alto Todos 7.0, 7.1.1 21 de septiembre de 2016

Vulnerabilidad de elevación de privilegios en Audioserver

Una vulnerabilidad de elevación de privilegios en Audioserver podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto de un proceso privilegiado. Este problema se califica como Alto porque podría usarse para obtener acceso local a capacidades elevadas, que normalmente no son accesibles para una aplicación de terceros.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0384 A-32095626 Alto Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 11 de octubre de 2016
CVE-2017-0385 A-32585400 Alto Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 11 de octubre de 2016

Vulnerabilidad de elevación de privilegios en libnl

Una vulnerabilidad de elevación de privilegios en la biblioteca libnl podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto de un proceso privilegiado. Este problema se califica como Alto porque podría usarse para obtener acceso local a capacidades elevadas, que normalmente no son accesibles para una aplicación de terceros.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0386 A-32255299 Alto Todos 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 18 de octubre de 2016

Vulnerabilidad de elevación de privilegios en Mediaserver

Una vulnerabilidad de elevación de privilegios en Mediaserver podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto de un proceso privilegiado. Este problema se califica como Alto porque podría usarse para obtener acceso local a capacidades elevadas, que normalmente no son accesibles para una aplicación de terceros.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0387 A-32660278 Alto Todos 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 4 de noviembre de 2016

Vulnerabilidad de divulgación de información en el proveedor de almacenamiento externo

Una vulnerabilidad de divulgación de información en el proveedor de almacenamiento externo podría permitir que un usuario secundario local lea datos de una tarjeta SD de almacenamiento externo insertada por el usuario principal. Este problema se califica como alto porque podría usarse para acceder a datos sin permiso.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0388 A-32523490 Alto Todos 6.0, 6.0.1, 7.0, 7.1.1 interno de Google

Vulnerabilidad de denegación de servicio en redes centrales

Una vulnerabilidad de denegación de servicio en la red central podría permitir que un atacante remoto use un paquete de red especialmente diseñado para provocar que un dispositivo se cuelgue o se reinicie. Este problema está clasificado como Alto debido a la posibilidad de denegación de servicio remota.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0389 A-31850211 [ 2 ] [ 3 ] Alto Todos 6.0, 6.0.1, 7.0, 7.1.1 20 de julio de 2016

Vulnerabilidad de denegación de servicio en Mediaserver

Una vulnerabilidad de denegación de servicio en Mediaserver podría permitir que un atacante remoto use un archivo especialmente diseñado para provocar que el dispositivo se cuelgue o se reinicie. Este problema está clasificado como Alto debido a la posibilidad de denegación de servicio remota.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0390 A-31647370 Alto Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 19 de septiembre de 2016
CVE-2017-0391 A-32322258 Alto Todos 6.0, 6.0.1, 7.0, 7.1.1 20 de octubre de 2016
CVE-2017-0392 A-32577290 Alto Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 29 de octubre de 2016
CVE-2017-0393 A-30436808 Alto Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 interno de Google

Vulnerabilidad de denegación de servicio en Telefonía

Una vulnerabilidad de denegación de servicio en telefonía podría permitir que un atacante remoto provoque que un dispositivo se cuelgue o se reinicie. Este problema está clasificado como Alto debido a la posibilidad de denegación de servicio remota.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0394 A-31752213 Alto Todos 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 23 de septiembre de 2016

Vulnerabilidad de elevación de privilegios en Contactos

Una vulnerabilidad de elevación de privilegios en Contactos podría permitir que una aplicación malintencionada local cree información de contacto de forma silenciosa. Este problema se clasifica como Moderado porque es una omisión local de los requisitos de interacción del usuario (acceso a la funcionalidad que normalmente requeriría la iniciación o el permiso del usuario).

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0395 A-32219099 Moderado Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 15 de octubre de 2016

Vulnerabilidad de divulgación de información en Mediaserver

Una vulnerabilidad de divulgación de información en Mediaserver podría permitir que una aplicación maliciosa local acceda a datos fuera de sus niveles de permiso. Este problema se clasifica como Moderado porque podría usarse para acceder a datos confidenciales sin permiso.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0381 A-31607432 Moderado Todos 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 18 de septiembre de 2016
CVE-2017-0396 A-31781965 Moderado Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 27 de septiembre de 2016
CVE-2017-0397 A-32377688 Moderado Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 21 de octubre de 2016

Vulnerabilidad de divulgación de información en Audioserver

Una vulnerabilidad de divulgación de información en Audioserver podría permitir que una aplicación maliciosa local acceda a datos fuera de sus niveles de permiso. Este problema se clasifica como Moderado porque podría usarse para acceder a datos confidenciales sin permiso.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0398 A-32438594 Moderado Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 25 de octubre de 2016
CVE-2017-0398 A-32635664 Moderado Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 25 de octubre de 2016
CVE-2017-0398 A-32624850 Moderado Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 25 de octubre de 2016
CVE-2017-0399 A-32247948 [ 2 ] Moderado Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 18 de octubre de 2016
CVE-2017-0400 A-32584034 [ 2 ] Moderado Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 25 de octubre de 2016
CVE-2017-0401 A-32448258 Moderado Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 26 de octubre de 2016
CVE-2017-0402 A-32436341 [ 2 ] Moderado Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 25 de octubre de 2016

Nivel de parche de seguridad 2017-01-05: detalles de vulnerabilidad

En las secciones a continuación, proporcionamos detalles para cada una de las vulnerabilidades de seguridad que se aplican al nivel de parche 2017-01-05. Hay una descripción del problema, una justificación de la gravedad y una tabla con el CVE, las referencias asociadas, la gravedad, los dispositivos de Google actualizados, las versiones actualizadas de AOSP (cuando corresponda) y la fecha en que se informó. Cuando esté disponible, vincularemos el cambio público que abordó el problema con el ID del error, como la lista de cambios de AOSP. Cuando varios cambios se relacionan con un solo error, las referencias adicionales se vinculan a los números que siguen al ID del error.

Vulnerabilidad de elevación de privilegios en el subsistema de memoria del kernel

Una vulnerabilidad de elevación de privilegios en el subsistema de memoria del kernel podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2015-3288 A-32460277
Núcleo ascendente
Crítico Nexus 5X, Nexus 6, Nexus 6P, Android One, Píxel C, Nexus Player, Píxel, Píxel XL 9 de julio de 2015

Vulnerabilidad de elevación de privilegios en el gestor de arranque de Qualcomm

Una vulnerabilidad de elevación de privilegios en el gestor de arranque de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8422 A-31471220
QC-CR#979426
Crítico Nexus 6, Nexus 6P, Píxel, Píxel XL 22 de julio de 2016
CVE-2016-8423 A-31399736
QC-CR#1000546
Crítico Nexus 6P, Píxel, Píxel XL 24 de agosto de 2016

Vulnerabilidad de elevación de privilegios en el sistema de archivos del kernel

Una vulnerabilidad de elevación de privilegios en el sistema de archivos del kernel podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2015-5706 A-32289301
Núcleo ascendente
Crítico Ninguna* 1 de agosto de 2016

* Los dispositivos de Google compatibles con Android 7.0 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidad de elevación de privilegios en el controlador de GPU NVIDIA

Una vulnerabilidad de elevación de privilegios en el controlador NVIDIA GPU podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8424 A-31606947*
N-CVE-2016-8424
Crítico nexo 9 17 de septiembre de 2016
CVE-2016-8425 A-31797770*
N-CVE-2016-8425
Crítico nexo 9 28 de septiembre de 2016
CVE-2016-8426 A-31799206*
N-CVE-2016-8426
Crítico nexo 9 28 de septiembre de 2016
CVE-2016-8482 A-31799863*
N-CVE-2016-8482
Crítico nexo 9 28 de septiembre de 2016
CVE-2016-8427 A-31799885*
N-CVE-2016-8427
Crítico nexo 9 28 de septiembre de 2016
CVE-2016-8428 A-31993456*
N-CVE-2016-8428
Crítico nexo 9 6 de octubre de 2016
CVE-2016-8429 A-32160775*
N-CVE-2016-8429
Crítico nexo 9 13 de octubre de 2016
CVE-2016-8430 A-32225180*
N-CVE-2016-8430
Crítico nexo 9 17 de octubre de 2016
CVE-2016-8431 A-32402179*
N-CVE-2016-8431
Crítico Píxel C 25 de octubre de 2016
CVE-2016-8432 A-32447738*
N-CVE-2016-8432
Crítico Píxel C 26 de octubre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en el controlador MediaTek

Una vulnerabilidad de elevación de privilegios en el controlador MediaTek podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8433 A-31750190*
MT-ALPS02974192
Crítico Ninguna** 24 de septiembre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

** Los dispositivos de Google compatibles con Android 7.0 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidad de elevación de privilegios en el controlador GPU de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador GPU de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8434 A-32125137
QC-CR#1081855
Crítico Nexus 5X, Nexus 6, Nexus 6P, Android Uno 12 de octubre de 2016

Vulnerabilidad de elevación de privilegios en el controlador de GPU NVIDIA

Una vulnerabilidad de elevación de privilegios en el controlador NVIDIA GPU podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8435 A-32700935*
N-CVE-2016-8435
Crítico Píxel C 7 de noviembre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en el controlador de video de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador de video de Qualcomm podría permitir que una aplicación maliciosa local ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8436 A-32450261
QC-CR#1007860
Crítico Ninguna* 13 de octubre de 2016

* Los dispositivos de Google compatibles con Android 7.0 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidades en los componentes de Qualcomm

Las siguientes vulnerabilidades afectan a los componentes de Qualcomm y se describen con más detalle en los boletines de seguridad de Qualcomm AMSS de noviembre de 2015, agosto de 2016, septiembre de 2016 y octubre de 2016.

CVE Referencias Gravedad* Dispositivos de Google actualizados Fecha reportada
CVE-2016-8438 A-31624565** Crítico Ninguna*** Qualcomm interno
CVE-2016-8442 A-31625910** Crítico Ninguna*** Qualcomm interno
CVE-2016-8443 A-32576499** Crítico Ninguna*** Qualcomm interno
CVE-2016-8437 A-31623057** Alto Ninguna*** Qualcomm interno
CVE-2016-8439 A-31625204** Alto Ninguna*** Qualcomm interno
CVE-2016-8440 A-31625306** Alto Ninguna*** Qualcomm interno
CVE-2016-8441 A-31625904** Alto Ninguna*** Qualcomm interno
CVE-2016-8398 A-31548486** Alto Nexus 5X, Nexus 6, Nexus 6P, Android Uno Qualcomm interno
CVE-2016-8459 A-32577972** Alto Ninguna*** Qualcomm interno
CVE-2016-5080 A-31115235** Moderado nexo 5X Qualcomm interno

* El proveedor determinó la clasificación de gravedad de estas vulnerabilidades.

** El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

*** Los dispositivos de Google compatibles con Android 7.0 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidad de elevación de privilegios en cámara Qualcomm

Una vulnerabilidad de elevación de privilegios en la cámara de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8412 A-31225246
QC-CR#1071891
Alto Nexus 5X, Nexus 6, Nexus 6P, Android One, Píxel, Píxel XL 26 de agosto de 2016
CVE-2016-8444 A-31243641*
QC-CR#1074310
Alto Nexus 5X, Nexus 6, Nexus 6P 26 de agosto de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en componentes de MediaTek

Una vulnerabilidad de elevación de privilegios en los componentes de MediaTek, incluido el controlador térmico y el controlador de video, podría permitir que una aplicación maliciosa local ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8445 A-31747590*
MT-ALPS02968983
Alto Ninguna** 25 de septiembre de 2016
CVE-2016-8446 A-31747749*
MT-ALPS02968909
Alto Ninguna** 25 de septiembre de 2016
CVE-2016-8447 A-31749463*
MT-ALPS02968886
Alto Ninguna** 25 de septiembre de 2016
CVE-2016-8448 A-31791148*
MT-ALPS02982181
Alto Ninguna** 28 de septiembre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

** Los dispositivos de Google compatibles con Android 7.0 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidad de elevación de privilegios en el controlador Wi-Fi de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador Wi-Fi de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8415 A-31750554
QC-CR#1079596
Alto Nexus 5X, píxel, píxel XL 26 de septiembre de 2016

Vulnerabilidad de elevación de privilegios en el controlador de GPU NVIDIA

Una vulnerabilidad de elevación de privilegios en el controlador NVIDIA GPU podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8449 A-31798848*
N-CVE-2016-8449
Alto nexo 9 28 de septiembre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en el controlador de sonido de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador de sonido de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8450 A-32450563
QC-CR#880388
Alto Nexus 5X, Nexus 6, Nexus 6P, Android Uno 13 de octubre de 2016

Vulnerabilidad de elevación de privilegios en el controlador de pantalla táctil Synaptics

Una vulnerabilidad de elevación de privilegios en el controlador de pantalla táctil Synaptics podría permitir que una aplicación maliciosa local ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8451 A-32178033* Alto Ninguna** 13 de octubre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

** Los dispositivos de Google compatibles con Android 7.0 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidad de elevación de privilegios en el subsistema de seguridad del kernel

Una vulnerabilidad de elevación de privilegios en el subsistema de seguridad del kernel podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-7042 A-32178986
Núcleo ascendente
Alto Píxel C 14 de octubre de 2016

Vulnerabilidad de elevación de privilegios en el subsistema de rendimiento del kernel

Una vulnerabilidad de elevación de privilegios en el subsistema de rendimiento del kernel podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0403 A-32402548* Alto Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Píxel C, Nexus Player, Píxel, Píxel XL 25 de octubre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en el subsistema de sonido del kernel

Una vulnerabilidad de elevación de privilegios en el subsistema de sonido del kernel podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0404 A-32510733* Alto Nexus 5X, Nexus 6P, Nexus 9, Píxel C, Nexus Player, Píxel, Píxel XL 27 de octubre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en el controlador Wi-Fi de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador Wi-Fi de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8452 A-32506396
QC-CR#1050323
Alto Nexus 5X, Android One, Píxel, Píxel XL 28 de octubre de 2016

Vulnerabilidad de elevación de privilegios en el controlador de radio de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador de radio de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-5345 A-32639452
QC-CR#1079713
Alto androide uno 3 de noviembre de 2016

Vulnerabilidad de elevación de privilegios en el subsistema de creación de perfiles del kernel

Una vulnerabilidad de elevación de privilegios en el subsistema de creación de perfiles del kernel podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-9754 A-32659848
Núcleo ascendente
Alto Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Píxel C, Nexus Player 4 de noviembre de 2016

Vulnerabilidad de elevación de privilegios en el controlador Wi-Fi de Broadcom

Una vulnerabilidad de elevación de privilegios en el controlador Wi-Fi de Broadcom podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8453 A-24739315*
B-RB#73392
Alto nexo 6 interno de Google
CVE-2016-8454 A-32174590*
B-RB#107142
High Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Oct 14, 2016
CVE-2016-8455 A-32219121*
B-RB#106311
High Nexus 6P Oct 15, 2016
CVE-2016-8456 A-32219255*
B-RB#105580
High Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Oct 15, 2016
CVE-2016-8457 A-32219453*
B-RB#106116
High Nexus 6, Nexus 6P, Nexus 9, Pixel C Oct 15, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Synaptics touchscreen driver

An elevation of privilege vulnerability in the Synaptics touchscreen driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-8458 A-31968442* High Nexus 5X, Nexus 6P, Nexus 9, Android One, Pixel, Pixel XL Google internal

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in NVIDIA video driver

An information disclosure vulnerability in the NVIDIA video driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2016-8460 A-31668540*
N-CVE-2016-8460
High Nexus 9 Sep 21, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in bootloader

An information disclosure vulnerability in the bootloader could enable a local attacker to access data outside of its permission level. This issue is rated as High because it could be used to access sensitive data.

CVE References Severity Updated Google devices Date reported
CVE-2016-8461 A-32369621* High Nexus 9, Pixel, Pixel XL Oct 21, 2016
CVE-2016-8462 A-32510383* High Pixel, Pixel XL Oct 27, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Denial of service vulnerability in Qualcomm FUSE file system

A denial of service vulnerability in the Qualcomm FUSE file system could enable a remote attacker to use a specially crafted file to cause a device hang or reboot. This issue is rated as High due to the possibility of remote denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2016-8463 A-30786860
QC-CR#586855
High None* Jan 03, 2014

* Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Denial of service vulnerability in bootloader

A denial of service vulnerability in the bootloader could enable an attacker to cause a local permanent denial of service, which may require reflashing the operating system to repair the device. This issue is rated as High due to the possibility of local permanent denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2016-8467 A-30308784* High Nexus 6, Nexus 6P Jun 29, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Broadcom Wi-Fi driver

An elevation of privilege vulnerability in the Broadcom Wi-Fi driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and is mitigated by current platform configurations.

CVE References Severity Updated Google devices Date reported
CVE-2016-8464 A-29000183*
B-RB#106314
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player May 26, 2016
CVE-2016-8466 A-31822524*
B-RB#105268
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Sep 28, 2016
CVE-2016-8465 A-32474971*
B-RB#106053
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Oct 27, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Binder

An elevation of privilege vulnerability in Binder could enable a local malicious application to execute arbitrary code within the context of a privileged process. This issue is rated as Moderate because it first requires compromising a privileged process and is mitigated by current platform configurations.

CVE References Severity Updated Google devices Date reported
CVE-2016-8468 A-32394425* Moderate Pixel C, Pixel, Pixel XL Google internal

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in NVIDIA camera driver

An information disclosure vulnerability in the camera driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-8469 A-31351206*
N-CVE-2016-8469
Moderate Nexus 9 Sep 7, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in MediaTek driver

An information disclosure vulnerability in the MediaTek driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-8470 A-31528889*
MT-ALPS02961395
Moderate None** Sep 15, 2016
CVE-2016-8471 A-31528890*
MT-ALPS02961380
Moderate None** Sep 15, 2016
CVE-2016-8472 A-31531758*
MT-ALPS02961384
Moderate None** Sep 15, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Information disclosure vulnerability in STMicroelectronics driver

An information disclosure vulnerability in the STMicroelectronics driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-8473 A-31795790* Moderate Nexus 5X, Nexus 6P Sep 28, 2016
CVE-2016-8474 A-31799972* Moderate Nexus 5X, Nexus 6P Sep 28, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm audio post processor

An information disclosure vulnerability in the Qualcomm audio post processor could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it could be used to access sensitive data without permission.

CVE References Severity Updated Google devices Updated AOSP versions Date reported
CVE-2017-0399 A-32588756 [ 2 ] Moderate All 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Oct 18, 2016
CVE-2017-0400 A-32438598 [ 2 ] Moderate All 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Oct 25, 2016
CVE-2017-0401 A-32588016 Moderate All 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Oct 26, 2016
CVE-2017-0402 A-32588352 [ 2 ] Moderate All 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Oct 25, 2016

Information disclosure vulnerability in HTC input driver

An information disclosure vulnerability in the HTC input driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-8475 A-32591129* Moderate Pixel, Pixel XL Oct 30, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Denial of service vulnerability in kernel file system

A denial of service vulnerability in the kernel file system could enable a local malicious application to cause a device hang or reboot. This issue is rated as Moderate because it is a temporary denial of service that requires a factory reset to fix.

CVE References Severity Updated Google devices Date reported
CVE-2014-9420 A-32477499
Upstream kernel
Moderate Pixel C Dec 25, 2014

Common Questions and Answers

This section answers common questions that may occur after reading this bulletin.

1. How do I determine if my device is updated to address these issues?

To learn how to check a device's security patch level, read the instructions on the Pixel and Nexus update schedule .

  • Security patch levels of 2017-01-01 or later address all issues associated with the 2017-01-01 security patch level.
  • Security patch levels of 2017-01-05 or later address all issues associated with the 2017-01-05 security patch level and all previous patch levels.

Device manufacturers that include these updates should set the patch string level to:

  • [ro.build.version.security_patch]:[2017-01-01]
  • [ro.build.version.security_patch]:[2017-01-05]

2. Why does this bulletin have two security patch levels?

This bulletin has two security patch levels so that Android partners have the flexibility to fix a subset of vulnerabilities that are similar across all Android devices more quickly. Android partners are encouraged to fix all issues in this bulletin and use the latest security patch level.

  • Devices that use the January 1, 2017 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins.
  • Devices that use the security patch level of January 5, 2017 or newer must include all applicable patches in this (and previous) security bulletins.

Partners are encouraged to bundle the fixes for all issues they are addressing in a single update.

3. How do I determine which Google devices are affected by each issue?

In the 2017-01-01 and 2017-01-05 security vulnerability details sections, each table has an Updated Google devices column that covers the range of affected Google devices updated for each issue. This column has a few options:

  • All Google devices : If an issue affects All and Pixel devices, the table will have "All" in the Updated Google devices column. "All" encapsulates the following supported devices : Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel, and Pixel XL.
  • Some Google devices : If an issue doesn't affect all Google devices, the affected Google devices are listed in the Updated Google devices column.
  • No Google devices : If no Google devices running the latest available version of Android are affected by the issue, the table will have "None" in the Updated Google devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefix Reference
A- Android bug ID
QC- Qualcomm reference number
M- MediaTek reference number
N- NVIDIA reference number
B- Broadcom reference number

Revisions

  • January 03, 2017: Bulletin published.
  • January 04, 2017: Bulletin revised to include AOSP links.
  • January 05, 2017: Clarified AOSP version number from 7.1 to 7.1.1.
  • January 12, 2017: Removed duplicate entry for CVE-2016-8467.
  • January 24, 2017: Updated description and severity for CVE-2017-0381.
  • February 2, 2017: Updated CVE-2017-0389 with additional patch link.