Google se compromete a impulsar la igualdad racial para las comunidades afrodescendientes. Obtén información al respecto.

Boletín de seguridad de Android: julio de 2017

Organiza tus páginas con colecciones Guarda y categoriza el contenido según tus preferencias.

Publicado el 5 de julio de 2017 | Actualizado el 26 de septiembre de 2017

El Boletín de seguridad de Android contiene detalles de las vulnerabilidades de seguridad que afectan a los dispositivos Android. Los niveles de parches de seguridad del 5 de julio de 2017 o posteriores abordan todos estos problemas. Consulte el programa de actualización de Pixel y Nexus para obtener información sobre cómo verificar el nivel del parche de seguridad de un dispositivo.

Los socios fueron notificados de los problemas descritos en el boletín hace al menos un mes. Los parches de código fuente para estos problemas se publicaron en el repositorio del Proyecto de código abierto de Android (AOSP) y se vincularon desde este boletín. Este boletín también incluye enlaces a parches fuera de AOSP.

El más grave de estos problemas es una vulnerabilidad de seguridad crítica en el marco de medios que podría permitir que un atacante remoto utilice un archivo especialmente diseñado para ejecutar código arbitrario dentro del contexto de un proceso privilegiado. La evaluación de la gravedad se basa en el efecto que podría tener la explotación de la vulnerabilidad en un dispositivo afectado, suponiendo que las mitigaciones de la plataforma y el servicio estén desactivadas con fines de desarrollo o si se eluden con éxito.

No hemos recibido informes de explotación activa de clientes o abuso de estos problemas recientemente informados. Consulte la sección Mitigaciones de Android y Google Play Protect para obtener detalles sobre las protecciones de la plataforma de seguridad de Android y Google Play Protect, que mejoran la seguridad de la plataforma Android.

Alentamos a todos los clientes a aceptar estas actualizaciones en sus dispositivos.

Nota: La información sobre la última actualización inalámbrica (OTA) y las imágenes de firmware para dispositivos de Google están disponibles en la sección de actualizaciones de dispositivos de Google .

Anuncios

  • Este boletín tiene dos cadenas de nivel de parche de seguridad para brindar a los socios de Android la flexibilidad de solucionar más rápidamente un subconjunto de vulnerabilidades que son similares en todos los dispositivos Android. Consulte Preguntas y respuestas comunes para obtener información adicional:
    • 2017-07-01 : cadena de nivel de parche de seguridad parcial. Esta cadena de nivel de parche de seguridad indica que se abordaron todos los problemas asociados con 2017-07-01 (y todas las cadenas de nivel de parche de seguridad anteriores).
    • 2017-07-05 : cadena de nivel de parche de seguridad completa. Esta cadena de nivel de parche de seguridad indica que se abordaron todos los problemas asociados con 2017-07-01 y 2017-07-05 (y todas las cadenas de nivel de parche de seguridad anteriores).

Mitigaciones de Android y Google Play Protect

Este es un resumen de las mitigaciones proporcionadas por la plataforma de seguridad de Android y las protecciones de servicios como Google Play Protect . Estas capacidades reducen la probabilidad de que las vulnerabilidades de seguridad puedan explotarse con éxito en Android.

  • La explotación de muchos problemas en Android se hace más difícil debido a las mejoras en las versiones más recientes de la plataforma Android. Alentamos a todos los usuarios a actualizar a la última versión de Android siempre que sea posible.
  • El equipo de seguridad de Android monitorea activamente el abuso a través de Google Play Protect y advierte a los usuarios sobre aplicaciones potencialmente dañinas . Google Play Protect está habilitado de forma predeterminada en los dispositivos con Google Mobile Services y es especialmente importante para los usuarios que instalan aplicaciones desde fuera de Google Play.

Nivel de parche de seguridad 2017-07-01: detalles de vulnerabilidad

En las secciones a continuación, proporcionamos detalles para cada una de las vulnerabilidades de seguridad que se aplican al nivel de parche 2017-07-01. Las vulnerabilidades se agrupan según el componente al que afectan. Hay una descripción del problema y una tabla con el CVE, las referencias asociadas, el tipo de vulnerabilidad , la gravedad y las versiones actualizadas de AOSP (cuando corresponda). Cuando está disponible, vinculamos el cambio público que abordó el problema con la identificación del error, como la lista de cambios de AOSP. Cuando varios cambios se relacionan con un solo error, las referencias adicionales se vinculan a los números que siguen al ID del error.

tiempo de ejecución

La vulnerabilidad más grave de esta sección podría permitir que un atacante remoto utilice un archivo especialmente diseñado para ejecutar código arbitrario en el contexto de un proceso sin privilegios.

CVE Referencias Escribe Gravedad Versiones actualizadas de AOSP
CVE-2017-3544 A-35784677 RCE Moderado 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

Estructura

La vulnerabilidad más grave de esta sección podría permitir que una aplicación malintencionada local utilice un archivo especialmente diseñado para ejecutar código arbitrario en el contexto de una aplicación que utiliza la biblioteca.

CVE Referencias Escribe Gravedad Versiones actualizadas de AOSP
CVE-2017-0664 A-36491278 EoP Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0665 A-36991414 EoP Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0666 A-37285689 EoP Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0667 A-37478824 EoP Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0668 A-22011579 IDENTIFICACIÓN Moderado 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0669 A-34114752 IDENTIFICACIÓN Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0670 A-36104177 DoS Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

bibliotecas

La vulnerabilidad más grave de esta sección podría permitir que un atacante remoto utilice un archivo especialmente diseñado para ejecutar código arbitrario dentro del contexto de una aplicación que utiliza la biblioteca.

CVE Referencias Escribe Gravedad Versiones actualizadas de AOSP
CVE-2017-0671 A-34514762 * RCE Alto 4.4.4
CVE-2016-2109 A-35443725 DoS Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0672 A-34778578 DoS Alto 7.0, 7.1.1, 7.1.2

Marco de medios

La vulnerabilidad más grave de esta sección podría permitir que un atacante remoto utilice un archivo especialmente diseñado para ejecutar código arbitrario dentro del contexto de un proceso privilegiado.

CVE Referencias Escribe Gravedad Versiones actualizadas de AOSP
CVE-2017-0540 A-33966031 RCE Crítico 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0673 A-33974623 RCE Crítico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0674 A-34231163 RCE Crítico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0675 A-34779227 [ 2 ] RCE Crítico 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0676 A-34896431 RCE Crítico 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0677 A-36035074 RCE Crítico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0678 A-36576151 RCE Crítico 7.0, 7.1.1, 7.1.2
CVE-2017-0679 A-36996978 RCE Crítico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0680 A-37008096 RCE Crítico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0681 A-37208566 RCE Crítico 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0682 A-36588422 * RCE Alto 7.0, 7.1.1, 7.1.2
CVE-2017-0683 A-36591008 * RCE Alto 7.0, 7.1.1, 7.1.2
CVE-2017-0684 A-35421151 EoP Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0685 A-34203195 DoS Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0686 A-34231231 DoS Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0688 A-35584425 DoS Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0689 A-36215950 DoS Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0690 A-36592202 DoS Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0691 A-36724453 DoS Alto 7.0, 7.1.1, 7.1.2
CVE-2017-0692 A-36725407 DoS Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0693 A-36993291 DoS Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0694 A-37093318 DoS Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0695 A-37094889 DoS Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0696 A-37207120 DoS Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0697 A-37239013 DoS Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0698 A-35467458 IDENTIFICACIÓN Moderado 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0699 A-36490809 IDENTIFICACIÓN Moderado 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

Interfaz de usuario del sistema

La vulnerabilidad más grave de esta sección podría permitir que un atacante remoto utilice un archivo especialmente diseñado para ejecutar código arbitrario dentro del contexto de un proceso privilegiado.

CVE Referencias Escribe Gravedad Versiones actualizadas de AOSP
CVE-2017-0700 A-35639138 RCE Alto 7.1.1, 7.1.2
CVE-2017-0701 A-36385715 [ 2 ] RCE Alto 7.1.1, 7.1.2
CVE-2017-0702 A-36621442 RCE Alto 7.1.1, 7.1.2
CVE-2017-0703 A-33123882 EoP Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0704 A-33059280 EoP Moderado 7.1.1, 7.1.2

Nivel de parche de seguridad 2017-07-05: detalles de vulnerabilidad

En las secciones a continuación, proporcionamos detalles para cada una de las vulnerabilidades de seguridad que se aplican al nivel de parche 2017-07-05. Las vulnerabilidades se agrupan según el componente al que afectan e incluyen detalles como el CVE, las referencias asociadas, el tipo de vulnerabilidad , la gravedad , el componente (cuando corresponda) y las versiones actualizadas de AOSP (cuando corresponda). Cuando está disponible, vinculamos el cambio público que abordó el problema con la identificación del error, como la lista de cambios de AOSP. Cuando varios cambios se relacionan con un solo error, las referencias adicionales se vinculan a los números que siguen al ID del error.

Componentes de Broadcom

La vulnerabilidad más grave en esta sección podría permitir que un atacante cercano ejecute código arbitrario dentro del contexto del kernel.

CVE Referencias Escribe Gravedad Componente
CVE-2017-9417 A-38041027 *
B-RB#123023
RCE Crítico controlador wifi
CVE-2017-0705 A-34973477 *
B-RB#119898
EoP Moderado controlador wifi
CVE-2017-0706 A-35195787 *
B-RB#120532
EoP Moderado controlador wifi

Componentes HTC

La vulnerabilidad más grave de esta sección podría permitir que una aplicación local malintencionada ejecute código arbitrario en el contexto de un proceso privilegiado.

CVE Referencias Escribe Gravedad Componente
CVE-2017-0707 A-36088467 * EoP Moderado controlador LED
CVE-2017-0708 A-35384879 * IDENTIFICACIÓN Moderado controlador de sonido
CVE-2017-0709 A-35468048 * IDENTIFICACIÓN Bajo Controlador del concentrador de sensores

Componentes del núcleo

La vulnerabilidad más grave de esta sección podría permitir que una aplicación local malintencionada ejecute código arbitrario en el contexto de un proceso privilegiado.

CVE Referencias Escribe Gravedad Componente
CVE-2017-6074 A-35784697
Núcleo ascendente
EoP Alto subsistema de red
CVE-2017-5970 A-35805460
Núcleo ascendente
DoS Alto subsistema de red
CVE-2015-5707 A-35841297
Núcleo ascendente [ 2 ]
EoP Moderado controlador SCSI
CVE-2017-7308 A-36725304
Núcleo ascendente [ 2 ] [ 3 ]
EoP Moderado controlador de red
CVE-2014-9731 A-35841292
Núcleo ascendente
IDENTIFICACIÓN Moderado sistema de archivos

Componentes de MediaTek

La vulnerabilidad más grave de esta sección podría permitir que una aplicación local malintencionada ejecute código arbitrario en el contexto de un proceso privilegiado.

CVE Referencias Escribe Gravedad Componente
CVE-2017-0711 A-36099953 *
M-ALPS03206781
EoP Alto controlador de red

Componentes NVIDIA

La vulnerabilidad más grave de esta sección podría permitir que una aplicación local malintencionada ejecute código arbitrario en el contexto de un proceso privilegiado.

CVE Referencias Escribe Gravedad Componente
CVE-2017-0340 A-33968204 *
N-CVE-2017-0340
EoP Alto libnvparser
CVE-2017-0326 A-33718700 *
N-CVE-2017-0326
IDENTIFICACIÓN Moderado controlador de vídeo

Componentes Qualcomm

La vulnerabilidad más grave de esta sección podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel.

CVE Referencias Escribe Gravedad Componente
CVE-2017-8255 A-36251983
QC-CR#985205
EoP Alto cargador de arranque
CVE-2016-10389 A-34500449
QC-CR#1009145
EoP Alto cargador de arranque
CVE-2017-8253 A-35400552
QC-CR#1086764
EoP Alto Controlador de cámara
CVE-2017-8262 A-32938443
QC-CR#2029113
EoP Alto controlador de GPU
CVE-2017-8263 A-34126808 *
QC-CR#1107034
EoP Alto Subsistema de memoria compartida anónima
CVE-2017-8267 A-34173755 *
QC-CR#2001129
EoP Alto Subsistema de memoria compartida anónima
CVE-2017-8273 A-35400056
QC-CR#1094372 [ 2 ]
EoP Alto cargador de arranque
CVE-2016-5863 A-36251182
QC-CR#1102936
EoP Moderado Controlador USB HID
CVE-2017-8243 A-34112490 *
QC-CR#2001803
EoP Moderado controlador SoC
CVE-2017-8246 A-37275839
QC-CR#2008031
EoP Moderado controlador de sonido
CVE-2017-8256 A-37286701
QC-CR#1104565
EoP Moderado controlador wifi
CVE-2017-8257 A-37282763
QC-CR#2003129
EoP Moderado controlador de vídeo
CVE-2017-8259 A-34359487
QC-CR#2009016
EoP Moderado controlador SoC
CVE-2017-8260 A-34624155
QC-CR#2008469
EoP Moderado Controlador de cámara
CVE-2017-8261 A-35139833 *
QC-CR#2013631
EoP Moderado Controlador de cámara
CVE-2017-8264 A-33299365 *
QC-CR#1107702
EoP Moderado Controlador de cámara
CVE-2017-8265 A-32341313
QC-CR#1109755
EoP Moderado controlador de vídeo
CVE-2017-8266 A-33863407
QC-CR#1110924
EoP Moderado controlador de vídeo
CVE-2017-8268 A-34620535 *
QC-CR#2002207
EoP Moderado Controlador de cámara
CVE-2017-8270 A-35468665 *
QC-CR#2021363
EoP Moderado controlador wifi
CVE-2017-8271 A-35950388 *
QC-CR#2028681
EoP Moderado controlador de vídeo
CVE-2017-8272 A-35950805 *
QC-CR#2028702
EoP Moderado controlador de vídeo
CVE-2017-8254 A-36252027
QC-CR#832914
IDENTIFICACIÓN Moderado controlador de sonido
CVE-2017-8258 A-37279737
QC-CR#2005647
IDENTIFICACIÓN Moderado Controlador de cámara
CVE-2017-8269 A-33967002 *
QC-CR#2013145
IDENTIFICACIÓN Moderado Conductor IPA

Componentes de código cerrado de Qualcomm

Estas vulnerabilidades afectan a los componentes de Qualcomm y se describen con más detalle en los boletines de seguridad de Qualcomm AMSS de 2014-2016. Se incluyen en este boletín de seguridad de Android para asociar sus correcciones con un nivel de parche de seguridad de Android. Las soluciones para estas vulnerabilidades están disponibles directamente de Qualcomm.

CVE Referencias Escribe Gravedad Componente
CVE-2014-9411 A-37473054 * N / A Alto Componente de código cerrado
CVE-2014-9968 A-37304413 * N / A Alto Componente de código cerrado
CVE-2014-9973 A-37470982 * N / A Alto Componente de código cerrado
CVE-2014-9974 A-37471979 * N / A Alto Componente de código cerrado
CVE-2014-9975 A-37471230 * N / A Alto Componente de código cerrado
CVE-2014-9977 A-37471087 * N / A Alto Componente de código cerrado
CVE-2014-9978 A-37468982 * N / A Alto Componente de código cerrado
CVE-2014-9979 A-37471088 * N / A Alto Componente de código cerrado
CVE-2014-9980 A-37471029 * N / A Alto Componente de código cerrado
CVE-2015-0575 A-37296999 * N / A Alto Componente de código cerrado
CVE-2015-8592 A-37470090 * N / A Alto Componente de código cerrado
CVE-2015-8595 A-37472411 * N / A Alto Componente de código cerrado
CVE-2015-8596 A-37472806 * N / A Alto Componente de código cerrado
CVE-2015-9034 A-37305706 * N / A Alto Componente de código cerrado
CVE-2015-9035 A-37303626 * N / A Alto Componente de código cerrado
CVE-2015-9036 A-37303519 * N / A Alto Componente de código cerrado
CVE-2015-9037 A-37304366 * N / A Alto Componente de código cerrado
CVE-2015-9038 A-37303027 * N / A Alto Componente de código cerrado
CVE-2015-9039 A-37302628 * N / A Alto Componente de código cerrado
CVE-2015-9040 A-37303625 * N / A Alto Componente de código cerrado
CVE-2015-9041 A-37303518 * N / A Alto Componente de código cerrado
CVE-2015-9042 A-37301248 * N / A Alto Componente de código cerrado
CVE-2015-9043 A-37305954 * N / A Alto Componente de código cerrado
CVE-2015-9044 A-37303520 * N / A Alto Componente de código cerrado
CVE-2015-9045 A-37302136 * N / A Alto Componente de código cerrado
CVE-2015-9046 A-37301486 * N / A Alto Componente de código cerrado
CVE-2015-9047 A-37304367 * N / A Alto Componente de código cerrado
CVE-2015-9048 A-37305707 * N / A Alto Componente de código cerrado
CVE-2015-9049 A-37301488 * N / A Alto Componente de código cerrado
CVE-2015-9050 A-37302137 * N / A Alto Componente de código cerrado
CVE-2015-9051 A-37300737 * N / A Alto Componente de código cerrado
CVE-2015-9052 A-37304217 * N / A Alto Componente de código cerrado
CVE-2015-9053 A-37301249 * N / A Alto Componente de código cerrado
CVE-2015-9054 A-37303177 * N / A Alto Componente de código cerrado
CVE-2015-9055 A-37472412 * N / A Alto Componente de código cerrado
CVE-2015-9060 A-37472807 * N / A Alto Componente de código cerrado
CVE-2015-9061 A-37470436 * N / A Alto Componente de código cerrado
CVE-2015-9062 A-37472808 * N / A Alto Componente de código cerrado
CVE-2015-9067 A-37474000 * N / A Alto Componente de código cerrado
CVE-2015-9068 A-37470144 * N / A Alto Componente de código cerrado
CVE-2015-9069 A-37470777 * N / A Alto Componente de código cerrado
CVE-2015-9070 A-37474001 * N / A Alto Componente de código cerrado
CVE-2015-9071 A-37471819 * N / A Alto Componente de código cerrado
CVE-2015-9072 A-37474002 * N / A Alto Componente de código cerrado
CVE-2015-9073 A-37473407 * N / A Alto Componente de código cerrado
CVE-2016-10343 A-32580186 * N / A Alto Componente de código cerrado
CVE-2016-10344 A-32583954 * N / A Alto Componente de código cerrado
CVE-2016-10346 A-37473408 * N / A Alto Componente de código cerrado
CVE-2016-10347 A-37471089 * N / A Alto Componente de código cerrado
CVE-2016-10382 A-28823584 * N / A Alto Componente de código cerrado
CVE-2016-10383 A-28822389 * N / A Alto Componente de código cerrado
CVE-2016-10388 A-32580294 * N / A Alto Componente de código cerrado
CVE-2016-10391 A-32583804 * N / A Alto Componente de código cerrado
CVE-2016-5871 A-37473055 * N / A Alto Componente de código cerrado
CVE-2016-5872 A-37472809 * N / A Alto Componente de código cerrado

Actualizaciones de dispositivos de Google

Esta tabla contiene el nivel del parche de seguridad en la última actualización inalámbrica (OTA) e imágenes de firmware para dispositivos de Google. Las imágenes del firmware del dispositivo de Google están disponibles en el sitio para desarrolladores de Google .

dispositivo de Google Nivel de parche de seguridad
Píxel / Píxel XL 05 de julio de 2017
nexo 5X 05 de julio de 2017
nexo 6 05 de julio de 2017
Nexo 6P 05 de julio de 2017
nexo 9 05 de julio de 2017
jugador nexo 05 de julio de 2017
Píxel C 05 de julio de 2017

Las actualizaciones de dispositivos de Google también contienen parches para estas vulnerabilidades de seguridad, si corresponde:

CVE Referencias Escribe Gravedad Componente
CVE-2017-0710 A-34951864 * EoP Moderado TCB

Agradecimientos

Nos gustaría agradecer a estos investigadores por sus contribuciones:

CVE Investigadores
CVE-2017-8263 Billy Lau de Google
CVE-2017-0711 Chengming Yang, Baozeng Ding y Yang Song de Alibaba Mobile Security Group
CVE-2017-0681 Chi Zhang , Hanxiang Wen , Mingjian Zhou ( @Mingjian_Zhou ) y Xuxian Jiang del equipo C0RE
CVE-2017-0706 Daxing Guo ( @freener0 ) de Xuanwu Lab, Tencent
CVE-2017-8260 Derrek ( @derrekr6 ) y Scott Bauer
CVE-2017-8265 Di Shen ( @returnsme ) de KeenLab ( @keen_lab ), Tencent
CVE-2017-0703 Dzmitri Lukyanenka
CVE-2017-0692, CVE-2017-0694 Elphet y Gong Guang de Alpha Team, Qihoo 360 Technology Co. Ltd.
CVE-2017-8266, CVE-2017-8243, CVE-2017-8270 Gengjia Chen ( @chengjia4574 ) y pjf de IceSword Lab, Qihoo 360 Technology Co. Ltd.
CVE-2017-0665 Chi Zhang , Hanxiang Wen , Mingjian Zhou ( @Mingjian_Zhou ) y Xuxian Jiang del equipo C0RE
CVE-2017-8268, CVE-2017-8261 Jianqiang Zhao ( @jianqiangzhao ) y pjf de IceSword Lab, Qihoo 360
CVE-2017-0698 Joey Brand de Census Consulting Inc.
CVE-2017-0666, CVE-2017-0684 Mingjian Zhou ( @Mingjian_Zhou ), Chi Zhang y Xuxian Jiang del equipo C0RE
CVE-2017-0697, CVE-2017-0670 Niky1235 ( @jiych_guru )
CVE-2017-9417 Nitay Artenstein de Exodus Intelligence
CVE-2017-0705, CVE-2017-8259 scott bauer
CVE-2017-0667 Timothy Becker de CSS Inc.
CVE-2017-0682, CVE-2017-0683, CVE-2017-0676, CVE-2017-0696, CVE-2017-0675, CVE-2017-0701, CVE-2017-0702, CVE-2017-0699 vasili vasiliev
CVE-2017-0695, CVE-2017-0689, CVE-2017-0540, CVE-2017-0680, CVE-2017-0679, CVE-2017-0685, CVE-2017-0686, CVE-2017-0693, CVE- 2017-0674, CVE-2017-0677 VEO ( @VYSEa ) del Equipo de Respuesta a Amenazas Móviles , Trend Micro
CVE-2017-0708 Xiling Gong del Departamento de Plataforma de Seguridad de Tencent
CVE-2017-0690 Yangkang ( @dnpushme ) y Liyadong del equipo Qihoo 360 Qex
CVE-2017-8269, CVE-2017-8271, CVE-2017-8272, CVE-2017-8267 Yonggang Guo ( @guoygang ) de IceSword Lab, Qihoo 360 Technology Co. Ltd.
CVE-2017-8264, CVE-2017-0326, CVE-2017-0709 Yuan-Tsung Lo ( computernik@gmail.com ) y Xuxian Jiang del equipo C0RE
CVE-2017-0704, CVE-2017-0669 Yuxiang Li ( @Xbalien29 ) del Departamento de Plataforma de Seguridad de Tencent
CVE-2017-0710 Zach Riggle ( @ebeip90 ) del equipo de seguridad de Android
CVE-2017-0678 Zinuo Han del Centro de Respuesta de Seguridad de Chengdu, Qihoo 360 Technology Co. Ltd.
CVE-2017-0691, CVE-2017-0700 Zinuo Han del Centro de respuesta de seguridad de Chengdu, Qihoo 360 Technology Co. Ltd. y Ao Wang ( @ArayzSegment ) de Pangu Team

Preguntas y respuestas comunes

Esta sección responde preguntas comunes que pueden surgir después de leer este boletín.

1. ¿Cómo puedo determinar si mi dispositivo está actualizado para solucionar estos problemas?

Para obtener información sobre cómo verificar el nivel del parche de seguridad de un dispositivo, lea las instrucciones en el programa de actualización de Pixel y Nexus .

  • Los niveles de parche de seguridad 2017-07-01 o posteriores abordan todos los problemas asociados con el nivel de parche de seguridad 2017-07-01.
  • Los niveles de parches de seguridad de 2017-07-05 o posteriores abordan todos los problemas asociados con el nivel de parches de seguridad 2017-07-05 y todos los niveles de parches anteriores.

Los fabricantes de dispositivos que incluyen estas actualizaciones deben establecer el nivel de la cadena de parches en:

  • [ro.build.version.security_patch]:[2017-07-01]
  • [ro.build.version.security_patch]:[2017-07-05]

2. ¿Por qué este boletín tiene dos niveles de parches de seguridad?

Este boletín tiene dos niveles de parches de seguridad para que los socios de Android tengan la flexibilidad de corregir un subconjunto de vulnerabilidades que son similares en todos los dispositivos Android con mayor rapidez. Se recomienda a los socios de Android que solucionen todos los problemas de este boletín y utilicen el nivel de parche de seguridad más reciente.

  • Los dispositivos que usan el nivel de parche de seguridad del 1 de julio de 2017 deben incluir todos los problemas asociados con ese nivel de parche de seguridad, así como soluciones para todos los problemas informados en boletines de seguridad anteriores.
  • Los dispositivos que usan el nivel de parche de seguridad del 5 de julio de 2017 o posterior deben incluir todos los parches aplicables en este (y en los anteriores) boletines de seguridad.

Se alienta a los socios a agrupar las soluciones para todos los problemas que están solucionando en una sola actualización.

3. ¿Qué significan las entradas en la columna Tipo ?

Las entradas en la columna Tipo de la tabla de detalles de la vulnerabilidad hacen referencia a la clasificación de la vulnerabilidad de seguridad.

Abreviatura Definición
RCE Ejecución remota de código
EoP Elevación de privilegio
IDENTIFICACIÓN Divulgación de información
DoS Negación de servicio
N / A Clasificación no disponible

4. ¿Qué significan las entradas en la columna Referencias ?

Las entradas en la columna Referencias de la tabla de detalles de vulnerabilidad pueden contener un prefijo que identifique la organización a la que pertenece el valor de referencia.

Prefijo Referencia
A- ID de error de Android
QC- Número de referencia de Qualcomm
METRO- Número de referencia de MediaTek
NORTE- Número de referencia de NVIDIA
B- Número de referencia de Broadcom

5. ¿Qué significa un * junto al ID de error de Android en la columna Referencias ?

Los problemas que no están disponibles públicamente tienen un * junto al ID de error de Android en la columna Referencias . La actualización para ese problema generalmente se incluye en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Versiones

Versión Fecha notas
1.0 5 de julio de 2017 Boletín publicado.
1.1 6 de julio de 2017 Boletín revisado para incluir enlaces AOSP.
1.2 11 de julio de 2017 Boletín revisado para actualizar reconocimientos.
1.3 17 de agosto de 2017 Boletín revisado para actualizar los números de referencia.
1.4 19 de septiembre de 2017 Reconocimientos actualizados para CVE-2017-0710.
1.5 26 de septiembre de 2017 Reconocimientos actualizados para CVE-2017-0681.