بولتن امنیتی اندروید - ژوئن 2022

منتشر شده در 6 ژوئن 2022 | به روز شده در 22 ژوئیه 2022

بولتن امنیتی اندروید حاوی جزئیاتی از آسیب پذیری های امنیتی است که بر دستگاه های اندرویدی تأثیر می گذارد. سطوح وصله امنیتی 2022-06-05 یا جدیدتر همه این مشکلات را برطرف می کند. برای آشنایی با نحوه بررسی سطح وصله امنیتی دستگاه، به بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

شرکای Android حداقل یک ماه قبل از انتشار از همه مشکلات مطلع می شوند. وصله کد منبع برای این مشکلات در مخزن پروژه منبع باز Android (AOSP) منتشر شده و از این بولتن پیوند داده شده است. این بولتن همچنین شامل پیوندهایی به وصله های خارج از AOSP است.

شدیدترین این مسائل یک آسیب پذیری امنیتی حیاتی در مؤلفه System است که می تواند منجر به اجرای کد از راه دور بدون نیاز به مجوزهای اجرایی اضافی شود. ارزیابی شدت بر اساس تأثیری است که بهره‌برداری از آسیب‌پذیری احتمالاً روی دستگاه آسیب‌دیده می‌گذارد، با این فرض که پلت‌فرم و تخفیف‌های سرویس برای اهداف توسعه خاموش شده‌اند یا در صورت دور زدن موفقیت‌آمیز انجام شوند.

برای جزئیات بیشتر در مورد حفاظت های پلتفرم امنیتی اندروید و Google Play Protect که امنیت پلتفرم اندروید را بهبود می بخشد، به بخش کاهش دهنده های Android و Google Play Protect مراجعه کنید.

کاهش خدمات اندروید و گوگل

این خلاصه‌ای از کاهش‌های ارائه شده توسط پلتفرم امنیتی Android و محافظت‌های خدماتی مانند Google Play Protect است. این قابلیت ها احتمال سوء استفاده موفقیت آمیز از آسیب پذیری های امنیتی در اندروید را کاهش می دهد.

  • بهره برداری از بسیاری از مسائل در اندروید با پیشرفت در نسخه های جدیدتر پلتفرم اندروید دشوارتر شده است. ما همه کاربران را تشویق می کنیم تا در صورت امکان به آخرین نسخه اندروید بروزرسانی کنند.
  • تیم امنیتی Android به طور فعال از طریق Google Play Protect برای سوء استفاده نظارت می کند و به کاربران در مورد برنامه های بالقوه مضر هشدار می دهد. Google Play Protect به طور پیش‌فرض در دستگاه‌های دارای سرویس‌های Google Mobile فعال است و به ویژه برای کاربرانی که برنامه‌هایی را از خارج از Google Play نصب می‌کنند، مهم است.

جزئیات آسیب پذیری سطح وصله امنیتی 01/06/2022

در بخش‌های زیر، جزئیات مربوط به هر یک از آسیب‌پذیری‌های امنیتی را که در سطح وصله ۲۰۲۲-۰۶-۰۱ اعمال می‌شوند، ارائه می‌کنیم. آسیب‌پذیری‌ها بر اساس مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند. مسائل در جداول زیر توضیح داده شده اند و شامل شناسه CVE، مراجع مرتبط، نوع آسیب پذیری ، شدت و نسخه های به روز شده AOSP (در صورت لزوم) می باشند. هنگامی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است، مانند لیست تغییرات AOSP، به شناسه اشکال مرتبط می کنیم. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعدادی که پس از شناسه اشکال مرتبط هستند، مرتبط می شوند. دستگاه‌های دارای Android 10 و بالاتر ممکن است به‌روزرسانی‌های امنیتی و همچنین به‌روزرسانی‌های سیستم Google Play را دریافت کنند.

چارچوب

شدیدترین آسیب‌پذیری در این بخش می‌تواند منجر به افزایش محلی امتیاز بدون نیاز به مجوزهای اجرایی اضافی شود.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2021-39691 الف-157929241 EoP بالا 10، 11، 12
CVE-2022-20006 الف-151095871 EoP بالا 10، 11، 12، 12 لیتر
CVE-2022-20125 الف-194402515 EoP بالا 10، 11، 12، 12 لیتر
CVE-2022-20138 A-210469972 [ 2 ] EoP بالا 10، 11، 12، 12 لیتر

چارچوب رسانه ای

آسیب‌پذیری در این بخش می‌تواند منجر به اجرای کد از راه دور بدون نیاز به مجوزهای اجرایی اضافی شود.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2022-20130 الف-224314979 RCE بحرانی 10، 11، 12، 12 لیتر

سیستم

شدیدترین آسیب‌پذیری در این بخش می‌تواند منجر به اجرای کد از راه دور بدون نیاز به مجوزهای اجرایی اضافی شود.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2022-20127 الف-221862119 RCE بحرانی 10، 11، 12، 12 لیتر
CVE-2022-20140 الف-227618988 EoP بحرانی 12، 12 لیتر
CVE-2022-20145 الف-201660636 EoP بحرانی 11
CVE-2022-20126 الف-203431023 EoP بالا 10، 11، 12، 12 لیتر
CVE-2022-20133 الف-206807679 EoP بالا 10، 11، 12، 12 لیتر
CVE-2022-20134 A-218341397 [ 2 ] EoP بالا 10، 11، 12، 12 لیتر
CVE-2022-20135 الف-220303465 EoP بالا 10، 11، 12، 12 لیتر
CVE-2022-20137 الف-206986392 EoP بالا 12، 12 لیتر
CVE-2022-20142 الف-216631962 EoP بالا 10، 11، 12، 12 لیتر
CVE-2022-20144 A-187702830 [ 2 ] EoP بالا 10، 11، 12، 12 لیتر
CVE-2022-20147 الف-221216105 EoP بالا 10، 11، 12، 12 لیتر
CVE-2022-20123 الف-221852424 شناسه بالا 10، 11، 12، 12 لیتر
CVE-2022-20131 الف-221856662 شناسه بالا 10، 11، 12، 12 لیتر
CVE-2022-20129 A-217934478 [ 2 ] DoS بالا 10، 11، 12، 12 لیتر
CVE-2022-20143 الف-220735360 DoS بالا 10، 11، 12، 12 لیتر

به روز رسانی سیستم گوگل پلی

مسائل زیر در اجزای Project Mainline گنجانده شده است.

مولفه CVE
کدک های رسانه ای CVE-2022-20130

جزئیات آسیب پذیری سطح وصله امنیتی 05/06/2022

در بخش‌های زیر، جزئیات مربوط به هر یک از آسیب‌پذیری‌های امنیتی که در سطح وصله ۰۵-۰۶-۲۰۲۲ اعمال می‌شود، ارائه می‌کنیم. آسیب‌پذیری‌ها بر اساس مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند. مسائل در جداول زیر توضیح داده شده اند و شامل شناسه CVE، مراجع مرتبط، نوع آسیب پذیری ، شدت و نسخه های به روز شده AOSP (در صورت لزوم) می باشند. هنگامی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است، مانند لیست تغییرات AOSP، به شناسه اشکال مرتبط می کنیم. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعدادی که پس از شناسه اشکال مرتبط هستند، مرتبط می شوند.

اجزای هسته

شدیدترین آسیب‌پذیری در این بخش می‌تواند منجر به افزایش محلی امتیاز بدون نیاز به مجوزهای اجرایی اضافی شود.

CVE منابع تایپ کنید شدت مولفه
CVE-2021-4154 الف-218836280
هسته بالادست
EoP بالا هسته
CVE-2022-20141 الف-112551163
هسته بالادست
EoP بالا سوکت های اینت
CVE-2022-24958 الف-220261709
هسته بالادست [ 2 ] [ 3 ] [ 4 ]
EoP بالا یو اس بی
CVE-2022-25258 الف-222023189
هسته بالادست [ 2 ]
EoP بالا یو اس بی
CVE-2022-20132 A-188677105
هسته بالادست [ 2 ] [ 3 ] [ 4 ] [ 5 ] [ 6 ] [ 7 ]
شناسه بالا USB HID
CVE-2022-25375 الف-162326603
هسته بالادست
شناسه بالا درایور RNDIS

اجزای مدیاتک

این آسیب پذیری بر اجزای MediaTek تأثیر می گذارد و جزئیات بیشتر به طور مستقیم از MediaTek در دسترس است. ارزیابی شدت این موضوع به طور مستقیم توسط مدیاتک ارائه شده است.

CVE منابع شدت مولفه
CVE-2022-21745
الف-228972609
M-ALPS06468872 *
بالا سفت افزار WIFI

اجزای Unisoc

این آسیب پذیری بر اجزای Unisoc تأثیر می گذارد و جزئیات بیشتر به طور مستقیم از Unisoc در دسترس است. ارزیابی شدت این موضوع به طور مستقیم توسط Unisoc ارائه شده است.

CVE منابع شدت مولفه
CVE-2022-20210
الف-228868888
U-1770644 *
بحرانی مودم

اجزای منبع بسته کوالکام

این آسیب‌پذیری‌ها بر اجزای منبع بسته کوالکام تأثیر می‌گذارند و در بولتن امنیتی یا هشدار امنیتی مناسب کوالکام با جزئیات بیشتر توضیح داده شده‌اند. ارزیابی شدت این مسائل به طور مستقیم توسط کوالکام ارائه شده است.

CVE منابع شدت مولفه
CVE-2021-35083
A-209481130 * بالا جزء منبع بسته
CVE-2021-35102
A-209469926 * بالا جزء منبع بسته
CVE-2021-35111
A-209469960 * بالا جزء منبع بسته
CVE-2022-22082 الف-223211217 * بالا جزء منبع بسته
CVE-2022-22083 الف-223210917 * بالا جزء منبع بسته
CVE-2022-22084
A-223209816 * بالا جزء منبع بسته
CVE-2022-22085 الف-223209306 * بالا جزء منبع بسته
CVE-2022-22086 الف-223211218 * بالا جزء منبع بسته
CVE-2022-22087 A-223209610 * بالا جزء منبع بسته
CVE-2022-22090 A-223210918 * بالا جزء منبع بسته

پرسش و پاسخ متداول

این بخش به سوالات متداولی که ممکن است پس از خواندن این بولتن رخ دهد پاسخ می دهد.

1. چگونه تشخیص دهم که آیا دستگاه من برای رفع این مشکلات به روز شده است؟

برای آشنایی با نحوه بررسی سطح وصله امنیتی دستگاه، به بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

  • سطوح وصله امنیتی 2022-06-01 یا جدیدتر تمام مسائل مرتبط با سطح وصله امنیتی 2022-06-01 را برطرف می کند.
  • سطوح وصله امنیتی 2022-06-05 یا جدیدتر، تمام مسائل مرتبط با سطح وصله امنیتی 2022-06-05 و تمام سطوح وصله قبلی را برطرف می کند.

سازندگان دستگاه‌هایی که شامل این به‌روزرسانی‌ها می‌شوند باید سطح رشته وصله را روی موارد زیر تنظیم کنند:

  • [ro.build.version.security_patch]:[01-06-2022]
  • [ro.build.version.security_patch]:[05-06-2022]

برای برخی از دستگاه‌های اندروید 10 یا بالاتر، به‌روزرسانی سیستم Google Play دارای یک رشته تاریخی است که با سطح وصله امنیتی 01-06-2022 مطابقت دارد. لطفاً برای جزئیات بیشتر در مورد نحوه نصب به‌روزرسانی‌های امنیتی، این مقاله را ببینید.

2. چرا این بولتن دارای دو سطح وصله امنیتی است؟

این بولتن دارای دو سطح وصله امنیتی است تا شرکای Android انعطاف پذیری لازم را داشته باشند تا زیرمجموعه ای از آسیب پذیری ها را که در همه دستگاه های اندرویدی مشابه هستند با سرعت بیشتری برطرف کنند. شرکای Android تشویق می شوند تا تمام مشکلات موجود در این بولتن را برطرف کنند و از آخرین سطح وصله امنیتی استفاده کنند.

  • دستگاه‌هایی که از سطح وصله امنیتی 01-06-2022 استفاده می‌کنند باید شامل تمام مشکلات مرتبط با آن سطح وصله امنیتی و همچنین رفع تمام مشکلات گزارش‌شده در بولتن‌های امنیتی قبلی باشند.
  • دستگاه‌هایی که از سطح وصله امنیتی 2022-06-05 یا جدیدتر استفاده می‌کنند، باید همه وصله‌های قابل‌اجرا در این (و قبلی) بولتن‌های امنیتی را شامل شوند.

شرکا تشویق می شوند تا اصلاحات مربوط به همه مشکلاتی را که در حال رفع آنها هستند در یک به روز رسانی واحد جمع کنند.

3. ورودی های ستون Type به چه معناست؟

ورودی های ستون نوع جدول جزئیات آسیب پذیری به طبقه بندی آسیب پذیری امنیتی اشاره دارد.

مخفف تعریف
RCE اجرای کد از راه دور
EoP بالا بردن امتیاز
شناسه افشای اطلاعات
DoS خود داری از خدمات
N/A طبقه بندی در دسترس نیست

4. ورودی های ستون References به چه معناست؟

ورودی‌های زیر ستون مراجع جدول جزئیات آسیب‌پذیری ممکن است حاوی پیشوندی باشد که سازمانی را که مقدار مرجع به آن تعلق دارد، مشخص می‌کند.

پیشوند ارجاع
آ- شناسه باگ اندروید
QC- شماره مرجع کوالکام
M- شماره مرجع مدیاتک
N- شماره مرجع NVIDIA
ب- شماره مرجع Broadcom
U- شماره مرجع UNISOC

5. یک * در کنار شناسه باگ اندروید در ستون References به چه معناست؟

مسائلی که به صورت عمومی در دسترس نیستند دارای علامت * در کنار شناسه مرجع مربوطه هستند. به‌روزرسانی برای آن مشکل عموماً در آخرین درایورهای باینری دستگاه‌های Pixel موجود در سایت Google Developer موجود است.

6. چرا آسیب‌پذیری‌های امنیتی بین این بولتن و بولتن‌های امنیتی دستگاه/شریک، مانند بولتن Pixel تقسیم می‌شوند؟

آسیب‌پذیری‌های امنیتی که در این بولتن امنیتی مستند شده‌اند برای اعلام آخرین سطح وصله امنیتی در دستگاه‌های اندرویدی مورد نیاز هستند. آسیب‌پذیری‌های امنیتی اضافی که در بولتن‌های امنیتی دستگاه/شریک مستند شده‌اند، برای اعلام سطح وصله امنیتی لازم نیست. سازندگان دستگاه‌ها و چیپ‌ست‌های Android نیز ممکن است جزئیات آسیب‌پذیری امنیتی خاص محصولات خود را منتشر کنند، مانند Google ، Huawei ، LGE ، Motorola ، Nokia یا Samsung .

نسخه ها

نسخه تاریخ یادداشت
1.0 6 ژوئن 2022 بولتن منتشر شد
1.1 7 ژوئن 2022 بولتن اصلاح شد تا شامل پیوندهای AOSP باشد
2.0 28 ژوئن 2022 CVE-2021-39624 به دلیل رگرسیون احتمالی از SPL 2022-06-01 حذف شده است. ممکن است برای SPL آینده به نسخه به‌روزرسانی‌شده این اصلاح نیاز داشته باشیم.
3.0 22 ژوئیه 2022 CVE-2022-20124 به دلیل رگرسیون احتمالی از SPL 2022-06-01 حذف شده است. ما به نسخه به روز شده این اصلاح برای SPL آینده نیاز خواهیم داشت.