Bollettino sulla sicurezza Android: settembre 2019

Pubblicato il 3 settembre 2019 | Aggiornato il 5 settembre 2019

Il Bollettino sulla sicurezza di Android contiene dettagli sulle vulnerabilità della sicurezza che interessano i dispositivi Android. I livelli delle patch di sicurezza del 05-09-2019 o successivi risolvono tutti questi problemi. Per informazioni su come verificare il livello delle patch di sicurezza di un dispositivo, consulta Controllare e aggiornare la versione di Android .

I partner Android vengono informati di tutti i problemi almeno un mese prima della pubblicazione. Le patch del codice sorgente per questi problemi sono state rilasciate nel repository Android Open Source Project (AOSP) e collegate da questo bollettino. Questo bollettino include anche collegamenti a patch esterne a AOSP.

Il più grave di questi problemi è una vulnerabilità critica della sicurezza nel componente del framework Media che potrebbe consentire a un utente malintenzionato remoto di utilizzare un file appositamente predisposto per eseguire codice arbitrario nel contesto di un processo privilegiato. La valutazione della gravità si basa sull'effetto che lo sfruttamento della vulnerabilità potrebbe avere su un dispositivo interessato, presupponendo che le mitigazioni della piattaforma e del servizio siano disattivate per scopi di sviluppo o se aggirate con successo.

Non abbiamo ricevuto segnalazioni di sfruttamento o abuso attivo da parte dei clienti riguardo a questi problemi appena segnalati. Fare riferimento alla sezione Mitigazioni per Android e Google Play Protect per dettagli sulle protezioni della piattaforma di sicurezza Android e Google Play Protect, che migliorano la sicurezza della piattaforma Android.

Mitigazioni dei servizi Android e Google

Questo è un riepilogo delle mitigazioni fornite dalla piattaforma di sicurezza Android e dalle protezioni dei servizi come Google Play Protect . Queste funzionalità riducono la probabilità che le vulnerabilità della sicurezza possano essere sfruttate con successo su Android.

  • Lo sfruttamento di molti problemi su Android è reso più difficile dai miglioramenti apportati alle versioni più recenti della piattaforma Android. Incoraggiamo tutti gli utenti ad aggiornare all'ultima versione di Android, ove possibile.
  • Il team di sicurezza di Android monitora attivamente eventuali abusi tramite Google Play Protect e avvisa gli utenti in merito alle applicazioni potenzialmente dannose . Google Play Protect è abilitato per impostazione predefinita sui dispositivi con Google Mobile Services ed è particolarmente importante per gli utenti che installano app esterne a Google Play.

Dettagli sulla vulnerabilità a livello di patch di sicurezza del 2019-09-01

Nelle sezioni seguenti, forniamo dettagli per ciascuna delle vulnerabilità della sicurezza che si applicano al livello di patch 2019-09-01. Le vulnerabilità sono raggruppate sotto il componente che interessano. I problemi sono descritti nelle tabelle seguenti e includono ID CVE, riferimenti associati, tipo di vulnerabilità , gravità e versioni AOSP aggiornate (ove applicabile). Quando disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID del bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, i riferimenti aggiuntivi sono collegati ai numeri che seguono l'ID del bug.

Struttura

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2019-2123 A-34175893 [ 2 ] [ 3 ] [ 4 ] EoP Alto 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2174 A-132927376 EoP Alto 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2175 A-135551349 EoP Alto 9
CVE-2019-9254 A-130164289 EoP Alto 10
CVE-2019-2103 A-120610669 [ 2 ] ID Alto 9

Quadro mediatico

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto di utilizzare un file appositamente predisposto per eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2019-2176 A-134420911 RCE Critico 8.0, 8.1, 9
CVE-2019-2108 A-130025324 RCE Critico 10

Sistema

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto di utilizzare una trasmissione appositamente predisposta per eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2019-2177 A-132456322 RCE Alto 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2115 A-129768470 [ 2 ] EoP Alto 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2178 A-124462242 EoP Alto 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2179 A-126200054 ID Alto 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2180 A-110899492 ID Alto 8.0, 8.1, 9
CVE-2019-2124 A-127320867 [ 2 ] [ 3 ] ID Alto 7.1.1, 7.1.2, 8.0, 8.1, 9

Dettagli sulla vulnerabilità a livello di patch di sicurezza 2019-09-05

Nelle sezioni seguenti, forniamo dettagli per ciascuna delle vulnerabilità della sicurezza che si applicano al livello di patch 2019-09-05. Le vulnerabilità sono raggruppate in base al componente che interessano e includono dettagli come CVE, riferimenti associati, tipo di vulnerabilità , gravità , componente (ove applicabile) e versioni AOSP aggiornate (ove applicabile). Se disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID del bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, i riferimenti aggiuntivi sono collegati ai numeri che seguono l'ID del bug.

Componenti del kernel

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Componente
CVE-2018-20669 A-135368228 * EoP Alto driver i915
CVE-2019-2181 A-130571081
Kernel a monte
EoP Alto Driver del raccoglitore

Componenti NVIDIA

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Componente
CVE-2018-6240 A-72315181 * EoP Alto BootROM
CVE-2018-6240 A-110169243 * EoP Alto BootROM
CVE-2017-5715 A-73294344 * ID Alto Firmware affidabile ARM

Componenti Qualcomm

Queste vulnerabilità interessano i componenti Qualcomm e sono descritte in maggiore dettaglio nel bollettino di sicurezza o nell'avviso di sicurezza di Qualcomm appropriato. La valutazione della gravità di questi problemi viene fornita direttamente da Qualcomm.

CVE Riferimenti Tipo Gravità Componente
CVE-2017-17768 A-67748905
QC-CR#2127172
N / A Alto Bootloader LK
CVE-2019-2283 A-127513124
QC-CR#2355425
N / A Alto Nocciolo
CVE-2019-2316 A-129848922
QC-CR#2358397
N / A Alto HLOS
CVE-2019-10491 A-132171785
QC-CR#2380709 [ 2 ]
N / A Alto Audio
CVE-2019-10505 A-123533258
QC-CR#2231755
N / A Alto OSPITE WLAN
CVE-2019-10505 A-132171579
QC-CR#2246426
N / A Alto OSPITE WLAN
CVE-2019-2323 A-132173424
QC-CR#2370589
N / A Alto HLOS
CVE-2019-2324 A-132173296
QC-CR#2372292
N / A Alto Audio
CVE-2019-2325 A-132171784
QC-CR#2372302 [ 2 ]
N / A Alto Audio
CVE-2019-2331 A-132172905
QC-CR#2380697 [ 2 ]
N / A Alto Audio
CVE-2019-2332 A-132171963
QC-CR#2380699 [ 2 ]
N / A Alto Audio
CVE-2019-10512 A-134439528
QC-CR#2380702 [ 2 ]
N / A Alto Audio
CVE-2019-10515 A-134440011
QC-CR#2366038 [ 2 ]
N / A Alto Nocciolo
CVE-2019-10524 A-134440735
QC-CR#2422233 [ 2 ] [ 3 ]
N / A Alto Driver della fotocamera
CVE-2019-10529 A-134439992
QC-CR#2442261
N / A Alto Driver grafico
CVE-2019-10531 A-134441415
QC-CR#2402890 [ 2 ]
N / A Alto Nocciolo
CVE-2018-11891 A-134440013
QC-CR#2288859
N / A Alto OSPITE WLAN

Componenti closed source di Qualcomm

Queste vulnerabilità interessano i componenti closed source di Qualcomm e sono descritte in maggiore dettaglio nel bollettino di sicurezza o nell'avviso di sicurezza di Qualcomm appropriato. La valutazione della gravità di questi problemi viene fornita direttamente da Qualcomm.

CVE Riferimenti Tipo Gravità Componente
CVE-2019-2258 A-123998354 * N / A Critico Componente closed source
CVE-2019-10533 A-134437210 * N / A Critico Componente closed source
CVE-2019-2275 A-127347579 * N / A Alto Componente closed source
CVE-2019-2246 A-127347339 * N / A Alto Componente closed source
CVE-2019-10488 A-132108617 * N / A Alto Componente closed source
CVE-2019-10495 A-132108855 * N / A Alto Componente closed source
CVE-2019-10496 A-132108737 * N / A Alto Componente closed source
CVE-2019-2249 A-132108854 * N / A Alto Componente closed source
CVE-2019-2285 A-132109149 * N / A Alto Componente closed source
CVE-2019-10504 A-134437132 * N / A Alto Componente closed source
CVE-2019-10504 A-134437173 * N / A Alto Componente closed source
CVE-2019-10522 A-134437134 * N / A Alto Componente closed source
CVE-2019-10534 A-134437379 * N / A Alto Componente closed source
CVE-2019-10541 A-134437115 * N / A Alto Componente closed source

Domande e risposte comuni

Questa sezione risponde alle domande più comuni che potrebbero sorgere dopo aver letto questo bollettino.

1. Come posso determinare se il mio dispositivo è aggiornato per risolvere questi problemi?

Per informazioni su come verificare il livello delle patch di sicurezza di un dispositivo, consulta Controllare e aggiornare la versione di Android .

  • I livelli delle patch di sicurezza del 01-09-2019 o successivi risolvono tutti i problemi associati al livello delle patch di sicurezza del 01-09-2019.
  • I livelli di patch di sicurezza del 05-09-2019 o successivi risolvono tutti i problemi associati al livello di patch di sicurezza del 05-09-2019 e a tutti i livelli di patch precedenti.

I produttori di dispositivi che includono questi aggiornamenti dovrebbero impostare il livello della stringa di patch su:

  • [ro.build.version.security_patch]:[2019-09-01]
  • [ro.build.version.security_patch]:[2019-09-05]

2. Perché questo bollettino prevede due livelli di patch di sicurezza?

Questo bollettino prevede due livelli di patch di sicurezza in modo che i partner Android abbiano la flessibilità necessaria per correggere più rapidamente un sottoinsieme di vulnerabilità simili su tutti i dispositivi Android. I partner Android sono incoraggiati a risolvere tutti i problemi presenti in questo bollettino e a utilizzare il livello di patch di sicurezza più recente.

  • I dispositivi che utilizzano il livello di patch di sicurezza 2019-09-01 devono includere tutti i problemi associati a tale livello di patch di sicurezza, nonché le correzioni per tutti i problemi segnalati nei bollettini di sicurezza precedenti.
  • I dispositivi che utilizzano il livello di patch di sicurezza del 05-09-2019 o successivo devono includere tutte le patch applicabili in questo (e nei precedenti) bollettini sulla sicurezza.

I partner sono incoraggiati a raggruppare le correzioni per tutti i problemi che stanno affrontando in un unico aggiornamento.

3. Cosa significano le voci nella colonna Tipo ?

Le voci nella colonna Tipo della tabella dei dettagli della vulnerabilità fanno riferimento alla classificazione della vulnerabilità della sicurezza.

Abbreviazione Definizione
RCE Esecuzione di codice remoto
EoP Elevazione dei privilegi
ID Rivelazione di un 'informazione
DoS Negazione del servizio
N / A Classificazione non disponibile

4. Cosa significano le voci nella colonna Riferimenti ?

Le voci nella colonna Riferimenti della tabella dei dettagli della vulnerabilità possono contenere un prefisso che identifica l'organizzazione a cui appartiene il valore di riferimento.

Prefisso Riferimento
UN- ID bug Android
QC- Numero di riferimento di Qualcomm
M- Numero di riferimento MediaTek
N- Numero di riferimento NVIDIA
B- Numero di riferimento Broadcom

5. Cosa significa un * accanto all'ID del bug Android nella colonna Riferimenti ?

I problemi che non sono disponibili pubblicamente hanno un * accanto all'ID del bug Android nella colonna Riferimenti . L'aggiornamento per questo problema è generalmente contenuto negli ultimi driver binari per i dispositivi Pixel disponibili sul sito degli sviluppatori di Google .

6. Perché le vulnerabilità della sicurezza sono suddivise tra questo bollettino e i bollettini sulla sicurezza dei dispositivi/partner, come il bollettino Pixel?

Le vulnerabilità della sicurezza documentate in questo bollettino sulla sicurezza sono necessarie per dichiarare il livello di patch di sicurezza più recente sui dispositivi Android. Ulteriori vulnerabilità di sicurezza documentate nei bollettini sulla sicurezza del dispositivo/del partner non sono necessarie per dichiarare un livello di patch di sicurezza. I produttori di dispositivi e chipset Android possono anche pubblicare dettagli sulle vulnerabilità di sicurezza specifiche dei loro prodotti, come Google , Huawei , LGE , Motorola , Nokia o Samsung .

Versioni

Versione Data Appunti
1.0 3 settembre 2019 Pubblicato il bollettino
1.1 5 settembre 2019 Bollettino rivisto per includere collegamenti AOSP