بولتن امنیتی اندروید - دسامبر 2019

با مجموعه‌ها، منظم بمانید ذخیره و دسته‌بندی محتوا براساس اولویت‌های شما.

منتشر شده در 2 دسامبر 2019 | به روز شده در 14 ژانویه 2020

بولتن امنیتی اندروید حاوی جزئیاتی از آسیب پذیری های امنیتی است که بر دستگاه های اندرویدی تأثیر می گذارد. سطوح وصله امنیتی 2019-12-05 یا بعد از آن همه این مشکلات را برطرف می کند. برای آشنایی با نحوه بررسی سطح وصله امنیتی دستگاه، به بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

شرکای Android حداقل یک ماه قبل از انتشار از همه مشکلات مطلع می شوند. وصله کد منبع برای این مشکلات در مخزن پروژه منبع باز Android (AOSP) منتشر شده و از این بولتن پیوند داده شده است. این بولتن همچنین شامل پیوندهایی به وصله های خارج از AOSP است.

شدیدترین این مشکلات یک آسیب پذیری امنیتی حیاتی در مولفه Framework است که می تواند یک مهاجم راه دور را با استفاده از یک پیام ساخته شده خاص قادر به انکار دائمی سرویس کند. ارزیابی شدت بر اساس تأثیری است که بهره‌برداری از آسیب‌پذیری احتمالاً روی دستگاه آسیب‌دیده می‌گذارد، با این فرض که پلت‌فرم و تخفیف‌های سرویس برای اهداف توسعه خاموش شده‌اند یا در صورت دور زدن موفقیت‌آمیز انجام شوند.

برای جزئیات بیشتر در مورد حفاظت های پلتفرم امنیتی اندروید و Google Play Protect که امنیت پلتفرم اندروید را بهبود می بخشد، به بخش کاهش دهنده های Android و Google Play Protect مراجعه کنید.

توجه: اطلاعات مربوط به آخرین به‌روزرسانی هوایی (OTA) و تصاویر میان‌افزار دستگاه‌های Google در بولتن به‌روزرسانی پیکسل در دسامبر 2019 موجود است.

کاهش خدمات اندروید و گوگل

این خلاصه‌ای از کاهش‌های ارائه شده توسط پلتفرم امنیتی Android و محافظت‌های خدماتی مانند Google Play Protect است. این قابلیت ها احتمال سوء استفاده موفقیت آمیز از آسیب پذیری های امنیتی در اندروید را کاهش می دهد.

  • بهره برداری از بسیاری از مسائل در اندروید با پیشرفت در نسخه های جدیدتر پلتفرم اندروید دشوارتر شده است. ما همه کاربران را تشویق می کنیم تا در صورت امکان به آخرین نسخه اندروید بروزرسانی کنند.
  • تیم امنیتی Android به طور فعال از طریق Google Play Protect برای سوء استفاده نظارت می کند و به کاربران در مورد برنامه های بالقوه مضر هشدار می دهد. Google Play Protect به طور پیش‌فرض در دستگاه‌های دارای سرویس‌های Google Mobile فعال است و به ویژه برای کاربرانی که برنامه‌هایی را از خارج از Google Play نصب می‌کنند، مهم است.

جزئیات آسیب پذیری سطح وصله امنیتی 01/12/2019

در بخش‌های زیر، جزئیات مربوط به هر یک از آسیب‌پذیری‌های امنیتی را که در سطح وصله 01-12-2019 اعمال می‌شود، ارائه می‌کنیم. آسیب‌پذیری‌ها بر اساس مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند. شرحی از مشکل و جدولی با CVE، مراجع مرتبط، نوع آسیب‌پذیری ، شدت و نسخه‌های به‌روزرسانی‌شده AOSP (در صورت لزوم) وجود دارد. هنگامی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است به شناسه اشکال مرتبط می کنیم، مانند لیست تغییرات AOSP. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعدادی که پس از شناسه اشکال مرتبط هستند، مرتبط می شوند. دستگاه‌های دارای Android 10 و بالاتر ممکن است به‌روزرسانی‌های امنیتی و همچنین به‌روزرسانی‌های سیستم Google Play را دریافت کنند.

چارچوب

شدیدترین آسیب‌پذیری در این بخش می‌تواند یک مهاجم راه دور را با استفاده از یک پیام ساخته‌شده خاص قادر به انکار دائمی سرویس کند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2019-2232 الف-140632678 DoS بحرانی 8.0، 8.1، 9، 10
CVE-2019-9464 A-141028068 [ 2 ] [ 3 ] [ 4 ] EoP بالا 10
CVE-2019-2217 الف-141003796 EoP بالا 10
CVE-2019-2218 الف-141169173 EoP بالا 8.0، 8.1، 9، 10
CVE-2019-2220 الف-138636979 [ 2 ] شناسه بالا 9، 10
CVE-2019-2221 A-138583650 [ 2 ] EoP در حد متوسط 10

چارچوب رسانه ای

شدیدترین آسیب‌پذیری در این بخش می‌تواند یک مهاجم از راه دور را با استفاده از یک فایل ساخته‌شده خاص قادر به اجرای کد دلخواه در چارچوب یک فرآیند ممتاز کند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2019-2222 الف-140322595 RCE در حد متوسط 10
RCE بحرانی 8.0، 8.1، 9
CVE-2019-2223 الف-140692129 RCE در حد متوسط 10
RCE بحرانی 8.0، 8.1، 9

سیستم

شدیدترین آسیب‌پذیری در این بخش می‌تواند یک مهاجم از راه دور را با استفاده از یک فایل ساخته‌شده خاص قادر به اجرای کد دلخواه در چارچوب یک فرآیند غیرمجاز کند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2019-15140 الف-140328986 RCE بالا 8.0، 8.1، 9، 10
CVE-2019-2225 A-110433804 [ 2 ] EoP بالا 8.0، 8.1، 9، 10
CVE-2019-2226 الف-140152619 شناسه بالا 8.0، 8.1، 9، 10
CVE-2019-2227 الف-140768453 شناسه بالا 9، 10
CVE-2019-2228 A-111210196 [ 2 ] شناسه بالا 8.0، 8.1، 9، 10
CVE-2019-2229 الف-139803872 [ 2 ] شناسه بالا 8.0، 8.1، 9، 10
CVE-2019-2230 الف-141170038 شناسه بالا 10

به روز رسانی سیستم گوگل پلی

این مسائل امنیتی در به‌روزرسانی‌های سیستم Google Play گنجانده شده است.

مولفه CVE ها
کدک های رسانه ای CVE-2019-2222، CVE-2019-2223

جزئیات آسیب پذیری سطح وصله امنیتی 05/12/2019

در بخش‌های زیر، جزئیات مربوط به هر یک از آسیب‌پذیری‌های امنیتی مربوط به سطح وصله 2019-12-05 را ارائه می‌کنیم. آسیب‌پذیری‌ها تحت مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند و شامل جزئیاتی مانند CVE، مراجع مرتبط، نوع آسیب‌پذیری ، شدت ، مؤلفه (در صورت لزوم) و نسخه‌های به‌روزشده AOSP (در صورت لزوم) می‌شوند. هنگامی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است به شناسه اشکال مرتبط می کنیم، مانند لیست تغییرات AOSP. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعدادی که پس از شناسه اشکال مرتبط هستند، مرتبط می شوند.

سیستم

آسیب پذیری در این بخش می تواند یک مهاجم محلی با دسترسی ممتاز را قادر سازد تا به داده های حساس دسترسی پیدا کند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2019-2231 الف-141955555 شناسه بالا 9، 10

اجزای هسته

شدیدترین آسیب پذیری در این بخش می تواند یک برنامه مخرب محلی را قادر سازد تا کد دلخواه را در چارچوب یک فرآیند ممتاز اجرا کند.

CVE منابع تایپ کنید شدت مولفه
CVE-2018-20961 الف-139522588
هسته بالادست
EoP بالا درایور عملکرد کلاس USB MIDI
CVE-2019-15220 الف-140329469
هسته بالادست
EoP بالا درایور USB WiFi Prism54
CVE-2019-15239 الف-140328996
هسته بالادست
EoP بالا پشته TCP

قطعات کوالکام

این آسیب‌پذیری‌ها بر اجزای کوالکام تأثیر می‌گذارند و با جزئیات بیشتر در بولتن امنیتی یا هشدار امنیتی کوالکام توضیح داده شده‌اند. ارزیابی شدت این مسائل به طور مستقیم توسط کوالکام ارائه شده است.

CVE منابع تایپ کنید شدت مولفه
CVE-2019-10557 A-78657016
QC-CR#2255369
QC-CR#2259707
N/A بالا میزبان WLAN
CVE-2018-11980 الف-140423440
QC-CR#2270117
N/A بالا میزبان WLAN
CVE-2019-10480 الف-140423811
QC-CR#2309399
N/A بالا میزبان WLAN
CVE-2019-10481 الف-140423794
QC-CR#2304610
QC-CR#2318632
N/A بالا میزبان WLAN
CVE-2019-10536 الف-140423334
QC-CR#2433802
N/A بالا میزبان WLAN
CVE-2019-10537 الف-140423693
QC-CR#2436502
N/A بالا میزبان WLAN
CVE-2019-10595 الف-140423810
QC-CR#2148184
N/A بالا میزبان WLAN
CVE-2019-10598 الف-140423155
QC-CR#2324139
N/A بالا میزبان WLAN
CVE-2019-10601 الف-140423156
QC-CR#2428798
N/A بالا میزبان WLAN
CVE-2019-10605 الف-140424124
QC-CR#2187441
N/A بالا میزبان WLAN
CVE-2019-10607 الف-140423690
QC-CR#2211711
N/A بالا امنیت
CVE-2019-2304 الف-123238115
QC-CR#2331868
QC-CR#2335530
QC-CR#2348299
QC-CR#2203904 *
N/A بالا میزبان WLAN

اجزای منبع بسته کوالکام

این آسیب‌پذیری‌ها بر اجزای منبع بسته کوالکام تأثیر می‌گذارند و در بولتن امنیتی یا هشدار امنیتی مناسب کوالکام با جزئیات بیشتر توضیح داده شده‌اند. ارزیابی شدت این مسائل به طور مستقیم توسط کوالکام ارائه شده است.

CVE منابع تایپ کنید شدت مولفه
CVE-2019-2242 A-123998200 * N/A بحرانی جزء منبع بسته
CVE-2019-10500 الف-134437248 * N/A بحرانی جزء منبع بسته
CVE-2019-10525 الف-134437319 * N/A بحرانی جزء منبع بسته
CVE-2019-10482 A-132108950 * N/A بالا جزء منبع بسته
CVE-2019-10487 الف-134437030 * N/A بالا جزء منبع بسته
CVE-2019-10516 الف-134437075 * N/A بالا جزء منبع بسته
CVE-2019-2274 الف-134437362 * N/A بالا جزء منبع بسته
CVE-2019-10513 الف-134437225 * N/A بالا جزء منبع بسته
CVE-2019-10517 الف-140424724 * N/A بالا جزء منبع بسته
CVE-2019-10600 A-140424089 * N/A بالا جزء منبع بسته

پرسش و پاسخ متداول

این بخش به سوالات متداولی که ممکن است پس از خواندن این بولتن رخ دهد پاسخ می دهد.

1. چگونه تشخیص دهم که آیا دستگاه من برای رفع این مشکلات به روز شده است؟

برای آشنایی با نحوه بررسی سطح وصله امنیتی دستگاه، به بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

  • سطوح وصله امنیتی 2019-12-01 یا جدیدتر، تمام مسائل مرتبط با سطح وصله امنیتی 2019-12-01 را برطرف می کند.
  • سطوح وصله امنیتی 2019-12-05 یا بعد از آن، تمام مشکلات مرتبط با سطح وصله امنیتی 2019-12-05 و تمام سطوح وصله قبلی را برطرف می کند.

سازندگان دستگاه‌هایی که شامل این به‌روزرسانی‌ها می‌شوند باید سطح رشته وصله را روی موارد زیر تنظیم کنند:

  • [ro.build.version.security_patch]:[01-12-2019]
  • [ro.build.version.security_patch]:[05-12-2019]

برای برخی از دستگاه‌های اندروید 10 یا بالاتر، به‌روزرسانی سیستم Google Play دارای یک رشته تاریخی است که با سطح وصله امنیتی 01-12-2019 مطابقت دارد. لطفاً برای جزئیات بیشتر در مورد نحوه نصب به‌روزرسانی‌های امنیتی، این مقاله را ببینید.

2. چرا این بولتن دارای دو سطح وصله امنیتی است؟

این بولتن دارای دو سطح وصله امنیتی است تا شرکای Android انعطاف پذیری لازم را داشته باشند تا زیرمجموعه ای از آسیب پذیری ها را که در همه دستگاه های اندرویدی مشابه هستند با سرعت بیشتری برطرف کنند. شرکای Android تشویق می شوند تا تمام مشکلات موجود در این بولتن را برطرف کنند و از آخرین سطح وصله امنیتی استفاده کنند.

  • دستگاه‌هایی که از سطح وصله امنیتی 2019-12-01 استفاده می‌کنند باید همه مشکلات مرتبط با آن سطح وصله امنیتی و همچنین رفع تمام مشکلات گزارش‌شده در بولتن‌های امنیتی قبلی را داشته باشند.
  • دستگاه‌هایی که از سطح وصله امنیتی 05/12/2019 یا جدیدتر استفاده می‌کنند باید همه وصله‌های قابل‌اجرا در این (و قبلی) بولتن‌های امنیتی را شامل شوند.

شرکا تشویق می شوند تا اصلاحات مربوط به همه مشکلاتی را که در حال رفع آنها هستند در یک به روز رسانی واحد جمع کنند.

3. ورودی های ستون Type به چه معناست؟

ورودی های ستون نوع جدول جزئیات آسیب پذیری به طبقه بندی آسیب پذیری امنیتی اشاره دارد.

مخفف تعریف
RCE اجرای کد از راه دور
EoP بالا بردن امتیاز
شناسه افشای اطلاعات
DoS خود داری از خدمات
N/A طبقه بندی در دسترس نیست

4. ورودی های ستون References به چه معناست؟

ورودی‌های زیر ستون مراجع جدول جزئیات آسیب‌پذیری ممکن است حاوی پیشوندی باشد که سازمانی را که مقدار مرجع به آن تعلق دارد، مشخص می‌کند.

پیشوند ارجاع
آ- شناسه باگ اندروید
QC- شماره مرجع کوالکام
M- شماره مرجع مدیاتک
N- شماره مرجع NVIDIA
ب- شماره مرجع Broadcom

5. یک * در کنار شناسه باگ اندروید در ستون References به چه معناست؟

مسائلی که به صورت عمومی در دسترس نیستند دارای یک * در کنار شناسه اشکال Android در ستون References هستند. به‌روزرسانی برای آن مشکل عموماً در آخرین درایورهای باینری دستگاه‌های Pixel موجود در سایت Google Developer موجود است.

6. چرا آسیب‌پذیری‌های امنیتی بین این بولتن و بولتن‌های امنیتی دستگاه/شریک، مانند بولتن Pixel تقسیم می‌شوند؟

آسیب‌پذیری‌های امنیتی که در این بولتن امنیتی مستند شده‌اند برای اعلام آخرین سطح وصله امنیتی در دستگاه‌های اندرویدی مورد نیاز هستند. آسیب‌پذیری‌های امنیتی اضافی که در بولتن‌های امنیتی دستگاه/شریک مستند شده‌اند، برای اعلام سطح وصله امنیتی لازم نیست. سازندگان دستگاه‌ها و چیپ‌ست‌های Android نیز ممکن است جزئیات آسیب‌پذیری امنیتی خاص محصولات خود را منتشر کنند، مانند Google ، Huawei ، LGE ، Motorola ، Nokia یا Samsung .

نسخه ها

نسخه تاریخ یادداشت
1.0 2 دسامبر 2019 بولتن منتشر شد
1.1 3 دسامبر 2019 بولتن اصلاح شد تا شامل پیوندهای AOSP باشد
1.2 13 دسامبر 2019 جدول CVE اصلاح شده
1.3 14 ژانویه 2020 شناسه CVE برای شماره A-140328986 به CVE-2019-15140 به روز شده است