بولتن امنیتی اندروید - ژانویه 2020

با مجموعه‌ها، منظم بمانید ذخیره و دسته‌بندی محتوا براساس اولویت‌های شما.

منتشر شده در 6 ژانویه 2020 | به روز شده در 7 ژانویه 2020

بولتن امنیتی اندروید حاوی جزئیاتی از آسیب پذیری های امنیتی است که بر دستگاه های اندرویدی تأثیر می گذارد. سطوح وصله امنیتی 2020-01-05 یا بالاتر، همه این مشکلات را برطرف می کند. برای آشنایی با نحوه بررسی سطح وصله امنیتی دستگاه، به بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

شرکای Android حداقل یک ماه قبل از انتشار از همه مشکلات مطلع می شوند. وصله کد منبع برای این مشکلات در مخزن پروژه منبع باز Android (AOSP) منتشر شده و از این بولتن پیوند داده شده است. این بولتن همچنین شامل پیوندهایی به وصله های خارج از AOSP است.

شدیدترین این مسائل یک آسیب پذیری امنیتی حیاتی در چارچوب Media است که می تواند یک مهاجم راه دور را با استفاده از یک فایل ساخته شده خاص قادر به اجرای کد دلخواه در چارچوب یک فرآیند ممتاز کند. ارزیابی شدت بر اساس تأثیری است که بهره‌برداری از آسیب‌پذیری احتمالاً روی دستگاه آسیب‌دیده می‌گذارد، با این فرض که پلت‌فرم و تخفیف‌های سرویس برای اهداف توسعه خاموش شده‌اند یا در صورت دور زدن موفقیت‌آمیز انجام شوند.

برای جزئیات بیشتر در مورد حفاظت های پلتفرم امنیتی اندروید و Google Play Protect که امنیت پلتفرم اندروید را بهبود می بخشد، به بخش کاهش دهنده های Android و Google Play Protect مراجعه کنید.

کاهش خدمات اندروید و گوگل

این خلاصه‌ای از کاهش‌های ارائه شده توسط پلتفرم امنیتی Android و محافظت‌های خدماتی مانند Google Play Protect است. این قابلیت ها احتمال سوء استفاده موفقیت آمیز از آسیب پذیری های امنیتی در اندروید را کاهش می دهد.

  • بهره برداری از بسیاری از مسائل در اندروید با پیشرفت در نسخه های جدیدتر پلتفرم اندروید دشوارتر شده است. ما همه کاربران را تشویق می کنیم تا در صورت امکان به آخرین نسخه اندروید بروزرسانی کنند.
  • تیم امنیتی Android به طور فعال از طریق Google Play Protect برای سوء استفاده نظارت می کند و به کاربران در مورد برنامه های بالقوه مضر هشدار می دهد. Google Play Protect به طور پیش‌فرض در دستگاه‌های دارای سرویس‌های Google Mobile فعال است و به ویژه برای کاربرانی که برنامه‌هایی را از خارج از Google Play نصب می‌کنند، مهم است.

جزئیات آسیب پذیری سطح وصله امنیتی 01/01/2020

در بخش‌های زیر، جزئیات مربوط به هر یک از آسیب‌پذیری‌های امنیتی را که در سطح وصله ۲۰۲۰-۰۱-۰۱ اعمال می‌شوند، ارائه می‌کنیم. آسیب‌پذیری‌ها بر اساس مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند. شرحی از مشکل و جدولی با CVE، مراجع مرتبط، نوع آسیب‌پذیری ، شدت و نسخه‌های به‌روزرسانی‌شده AOSP (در صورت لزوم) وجود دارد. هنگامی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است به شناسه اشکال مرتبط می کنیم، مانند لیست تغییرات AOSP. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعدادی که پس از شناسه اشکال مرتبط هستند، مرتبط می شوند.

چارچوب

شدیدترین آسیب پذیری در این بخش می تواند یک برنامه مخرب محلی را قادر سازد تا الزامات تعامل کاربر را برای دسترسی به مجوزهای اضافی دور بزند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2020-0001 الف-140055304 EoP در حد متوسط 10
EoP بالا 8.0، 8.1، 9
CVE-2020-0003 الف-140195904 EoP بالا 8.0
CVE-2020-0004 الف-120847476 DoS بالا 8.0، 8.1، 9، 10

چارچوب رسانه ای

آسیب‌پذیری موجود در این بخش می‌تواند یک مهاجم از راه دور را با استفاده از یک فایل ساخته‌شده خاص قادر به اجرای کد دلخواه در چارچوب یک فرآیند ممتاز کند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2020-0002 الف-142602711 RCE در حد متوسط 10
RCE بحرانی 8.0، 8.1، 9

سیستم

شدیدترین آسیب‌پذیری در این بخش می‌تواند منجر به افشای اطلاعات از راه دور بدون نیاز به امتیازات اجرایی اضافی شود.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2020-0006 الف-139738828 شناسه بالا 8.0، 8.1، 9، 10
CVE-2020-0007 A-141890807 [ 2 ] شناسه بالا 8.0، 8.1، 9، 10
CVE-2020-0008 الف-142558228 شناسه بالا 8.0، 8.1، 9، 10

به روز رسانی سیستم گوگل پلی

موضوع زیر در اجزای Project Mainline گنجانده شده است.

مولفه CVE
کدک های رسانه ای CVE-2020-0002

جزئیات آسیب پذیری سطح وصله امنیتی 05/01/2020

در بخش‌های زیر، جزئیات مربوط به هر یک از آسیب‌پذیری‌های امنیتی را که در سطح وصله ۲۰۲۰-۰۱-۰۵ اعمال می‌شوند، ارائه می‌کنیم. آسیب‌پذیری‌ها تحت مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند و شامل جزئیاتی مانند CVE، مراجع مرتبط، نوع آسیب‌پذیری ، شدت ، مؤلفه (در صورت لزوم) و نسخه‌های به‌روزشده AOSP (در صورت لزوم) می‌شوند. هنگامی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است به شناسه اشکال مرتبط می کنیم، مانند لیست تغییرات AOSP. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعدادی که پس از شناسه اشکال مرتبط هستند، مرتبط می شوند.

اجزای هسته

شدیدترین آسیب‌پذیری در این بخش می‌تواند یک مهاجم نزدیک را با استفاده از یک انتقال ساخته‌شده خاص قادر به اجرای کد دلخواه در چارچوب یک فرآیند ممتاز کند.

CVE منابع تایپ کنید شدت مولفه
CVE-2019-17666 الف-142967706
هسته بالادست
RCE بحرانی درایور Realtek rtlwifi
CVE-2018-20856 الف-138921316
هسته بالادست
EoP بالا هسته
CVE-2019-15214 الف-140920734
هسته بالادست
EoP بالا زیرسیستم صدا
CVE-2020-0009 الف-142938932 * EoP بالا آشمم

قطعات کوالکام

این آسیب‌پذیری‌ها بر اجزای کوالکام تأثیر می‌گذارند و با جزئیات بیشتر در بولتن امنیتی یا هشدار امنیتی کوالکام توضیح داده شده‌اند. ارزیابی شدت این مسائل به طور مستقیم توسط کوالکام ارائه شده است.

CVE منابع تایپ کنید شدت مولفه
CVE-2018-11843 الف-111126051
QC-CR#2216751
N/A بالا میزبان WLAN
CVE-2019-10558 الف-142268223
QC-CR#2355428
N/A بالا هسته
CVE-2019-10581 الف-142267478
QC-CR#2451619
N/A بالا سمعی
CVE-2019-10585 الف-142267685
QC-CR#2457975
N/A بالا هسته
CVE-2019-10602 الف-142270161
QC-CR#2165926 [ 2 ]
N/A بالا نمایش دادن
CVE-2019-10606 الف-142269492
QC-CR#2192810 [ 2 ]
N/A بالا هسته
CVE-2019-14010 الف-142269847
QC-CR#2465851 [ 2 ]
N/A بالا سمعی
CVE-2019-14023 الف-142270139
QC-CR#2493328
N/A بالا هسته
CVE-2019-14024 الف-142269993
QC-CR#2494103
N/A بالا NFC
CVE-2019-14034 الف-142270258
QC-CR#2491649 [ 2 ] [ 3 ]
N/A بالا دوربین
CVE-2019-14036 الف-142269832
QC-CR#2200862
N/A بالا میزبان WLAN

اجزای منبع بسته کوالکام

این آسیب‌پذیری‌ها بر اجزای منبع بسته کوالکام تأثیر می‌گذارند و در بولتن امنیتی یا هشدار امنیتی مناسب کوالکام با جزئیات بیشتر توضیح داده شده‌اند. ارزیابی شدت این مسائل به طور مستقیم توسط کوالکام ارائه شده است.

CVE منابع تایپ کنید شدت مولفه
CVE-2019-2267 الف-132108182 * N/A بالا جزء منبع بسته
CVE-2019-10548 الف-137030896 * N/A بالا جزء منبع بسته
CVE-2019-10532 الف-142271634 * N/A بالا جزء منبع بسته
CVE-2019-10578 A-142268949 * N/A بالا جزء منبع بسته
CVE-2019-10579 الف-142271692 * N/A بالا جزء منبع بسته
CVE-2019-10582 A-130574302 * N/A بالا جزء منبع بسته
CVE-2019-10583 الف-131180394 * N/A بالا جزء منبع بسته
CVE-2019-10611 الف-142271615 * N/A بالا جزء منبع بسته
CVE-2019-14002 الف-142271274 * N/A بالا جزء منبع بسته
CVE-2019-14003 الف-142271498 * N/A بالا جزء منبع بسته
CVE-2019-14004 الف-142271848 * N/A بالا جزء منبع بسته
CVE-2019-14005 A-142271965 * N/A بالا جزء منبع بسته
CVE-2019-14006 A-142271827 * N/A بالا جزء منبع بسته
CVE-2019-14008 A-142271609 * N/A بالا جزء منبع بسته
CVE-2019-14013 A-142271944 * N/A بالا جزء منبع بسته
CVE-2019-14014 A-142270349 * N/A بالا جزء منبع بسته
CVE-2019-14016 A-142270646 * N/A بالا جزء منبع بسته
CVE-2019-14017 الف-142271515 * N/A بالا جزء منبع بسته

پرسش و پاسخ متداول

این بخش به سوالات متداولی که ممکن است پس از خواندن این بولتن رخ دهد پاسخ می دهد.

1. چگونه تشخیص دهم که آیا دستگاه من برای رفع این مشکلات به روز شده است؟

برای آشنایی با نحوه بررسی سطح وصله امنیتی دستگاه، به بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

  • سطوح وصله امنیتی 2020-01-01 یا جدیدتر تمام مسائل مرتبط با سطح وصله امنیتی 2020-01-01 را برطرف می کند.
  • سطوح وصله امنیتی 2020-01-05 یا بعد از آن، تمام مسائل مرتبط با سطح وصله امنیتی 2020-01-05 و تمام سطوح وصله قبلی را برطرف می کند.

سازندگان دستگاه‌هایی که شامل این به‌روزرسانی‌ها می‌شوند باید سطح رشته وصله را روی موارد زیر تنظیم کنند:

  • [ro.build.version.security_patch]:[01-01-2020]
  • [ro.build.version.security_patch]:[05-01-2020]

برای برخی از دستگاه‌های اندروید 10 یا بالاتر، به‌روزرسانی سیستم Google Play دارای یک رشته تاریخی است که با سطح وصله امنیتی 01-01-2020 مطابقت دارد. لطفاً برای جزئیات بیشتر در مورد نحوه نصب به‌روزرسانی‌های امنیتی، این مقاله را ببینید.

2. چرا این بولتن دارای دو سطح وصله امنیتی است؟

این بولتن دارای دو سطح وصله امنیتی است تا شرکای Android انعطاف پذیری لازم را داشته باشند تا زیرمجموعه ای از آسیب پذیری ها را که در همه دستگاه های اندرویدی مشابه هستند با سرعت بیشتری برطرف کنند. شرکای Android تشویق می شوند تا تمام مشکلات موجود در این بولتن را برطرف کنند و از آخرین سطح وصله امنیتی استفاده کنند.

  • دستگاه‌هایی که از سطح وصله امنیتی 01-01-2020 استفاده می‌کنند باید شامل تمام مشکلات مرتبط با آن سطح وصله امنیتی و همچنین رفع تمام مشکلات گزارش‌شده در بولتن‌های امنیتی قبلی باشند.
  • دستگاه‌هایی که از سطح وصله امنیتی 05/01/2020 یا جدیدتر استفاده می‌کنند باید همه وصله‌های قابل‌اجرا در این (و قبلی) بولتن‌های امنیتی را شامل شوند.

شرکا تشویق می شوند تا اصلاحات مربوط به همه مشکلاتی را که در حال رفع آنها هستند در یک به روز رسانی واحد جمع کنند.

3. ورودی های ستون Type به چه معناست؟

ورودی های ستون نوع جدول جزئیات آسیب پذیری به طبقه بندی آسیب پذیری امنیتی اشاره دارد.

مخفف تعریف
RCE اجرای کد از راه دور
EoP بالا بردن امتیاز
شناسه افشای اطلاعات
DoS خود داری از خدمات
N/A طبقه بندی در دسترس نیست

4. ورودی های ستون References به چه معناست؟

ورودی‌های زیر ستون مراجع جدول جزئیات آسیب‌پذیری ممکن است حاوی پیشوندی باشد که سازمانی را که مقدار مرجع به آن تعلق دارد، مشخص می‌کند.

پیشوند ارجاع
آ- شناسه باگ اندروید
QC- شماره مرجع کوالکام
M- شماره مرجع مدیاتک
N- شماره مرجع NVIDIA
ب- شماره مرجع Broadcom

5. یک * در کنار شناسه باگ اندروید در ستون References به چه معناست؟

مسائلی که به صورت عمومی در دسترس نیستند دارای یک * در کنار شناسه اشکال Android در ستون References هستند. به‌روزرسانی برای آن مشکل عموماً در آخرین درایورهای باینری دستگاه‌های Pixel موجود در سایت Google Developer موجود است.

6. چرا آسیب‌پذیری‌های امنیتی بین این بولتن و بولتن‌های امنیتی دستگاه/شریک، مانند بولتن Pixel تقسیم می‌شوند؟

آسیب‌پذیری‌های امنیتی که در این بولتن امنیتی مستند شده‌اند برای اعلام آخرین سطح وصله امنیتی در دستگاه‌های اندرویدی مورد نیاز هستند. آسیب‌پذیری‌های امنیتی اضافی که در بولتن‌های امنیتی دستگاه/شریک مستند شده‌اند، برای اعلام سطح وصله امنیتی لازم نیست. سازندگان دستگاه‌ها و چیپ‌ست‌های Android نیز ممکن است جزئیات آسیب‌پذیری امنیتی خاص محصولات خود را منتشر کنند، مانند Google ، Huawei ، LGE ، Motorola ، Nokia یا Samsung .

نسخه ها

نسخه تاریخ یادداشت
1.0 6 ژانویه 2020 بولتن منتشر شد
1.1 7 ژانویه 2020 بولتن اصلاح شد تا شامل پیوندهای AOSP باشد