Nexus 보안 게시판 - 2016년 1월

Google의 Android 보안 게시판 월간 출시 과정의 일환으로 무선 업데이트를 통해 Nexus 기기에 대한 보안 업데이트가 출시되었습니다. 또한 Nexus 펌웨어 이미지도 Google 개발자 사이트 에 출시되었습니다. 다음 문제는 빌드 LMY49F 이상 및 2016년 1월 1일 보안 패치 수준이 포함된 Android 6.0 이상에서 해결됩니다. 자세한 내용은 일반적인 질문 및 답변 섹션을 참조하세요.

2015년 12월 7일 이전에 게시판을 통해 파트너에게 이 문제에 대한 알림이 전달되고 업데이트가 제공되었습니다. 해당하는 경우, 소스 코드 패치가 Android 오픈소스 프로젝트(AOSP) 저장소에 배포되었습니다.

이 중 가장 심각한 문제는 미디어 파일을 처리할 때 이메일과 웹 탐색, MMS 등 여러 방법을 통해 대상 기기에서 원격으로 코드를 실행할 수 있게 하는 심각한 보안 취약성입니다.

실제 고객이 새로 보고된 이러한 문제로 인해 악용당했다는 신고는 접수되지 않았습니다. SafetyNet과 같이 Android 플랫폼의 보안을 개선하는 Android 보안 플랫폼 보호 및 서비스 보호 기능에 대한 세부정보를 보려면 완화 섹션을 참조하세요. 모든 고객은 기기에서 이 업데이트를 수락하는 것이 좋습니다.

보안 취약성 요약


아래 표에는 보안 취약성 목록, 일반적인 취약성 및 노출 ID(CVE), 평가된 심각도가 포함되어 있습니다. 심각도 평가 는 개발 목적으로 플랫폼 및 서비스 완화를 사용할 수 없거나 우회에 성공한 경우 취약성 악용으로 인해 대상 기기가 받는 영향을 기준으로 평가됩니다.

문제 CVE 심각도
미디어 서버의 원격 코드 실행 취약성 CVE-2015-6636 심각
misc-sd 드라이버의 권한 승격 취약성 CVE-2015-6637 심각
Imagination Technologies 드라이버의 권한 승격 취약성 CVE-2015-6638 심각
Trustzone의 권한 승격 취약성 CVE-2015-6639
CVE-2015-6647
심각
커널의 권한 승격 취약성 CVE-2015-6640 심각
블루투스의 권한 승격 취약성 CVE-2015-6641 높음
커널의 정보 공개 취약성 CVE-2015-6642 높음
설치 마법사의 권한 승격 취약성 CVE-2015-6643 보통
Wi-Fi의 권한 승격 취약성 CVE-2015-5310 보통
Bouncy Castle의 정보 공개 취약성 CVE-2015-6644 보통
SyncManager의 서비스 거부(DoS) 취약성 CVE-2015-6645 보통
Nexus 커널의 공격 범위 축소 CVE-2015-6646 보통

완화


다음은 SafetyNet과 같은 Android 보안 플랫폼 및 서비스 보호 기능에서 제공하는 완화에 대한 요약입니다. 이러한 기능을 통해 Android에서 보안 취약성이 악용될 가능성을 줄입니다.

  • Android 플랫폼 최신 버전의 향상된 기능으로 Android의 여러 문제를 악용하기 더욱 어려워졌습니다. 가능한 경우 모든 사용자는 Android 최신 버전으로 업데이트하는 것이 좋습니다.
  • Android 보안팀에서는 유해할 수 있는 애플리케이션이 설치될 때 경고를 보내는 앱 인증 및 SafetyNet을 사용하여 악용사례를 적극적으로 모니터링합니다. Google Play 내에서 기기 루팅 도구는 금지되어 있습니다. Google Play 외부에서 애플리케이션을 설치하는 사용자를 보호하기 위해 앱 인증이 기본적으로 사용 설정되며 알려진 루팅 애플리케이션이 감지되면 알립니다. 앱 인증은 권한 승격 취약성을 악용하는 것으로 알려진 악성 애플리케이션을 식별하고 차단합니다. 이러한 애플리케이션이 이미 설치된 경우 앱 인증에서 사용자에게 이를 알리고 애플리케이션 삭제를 시도합니다.
  • 가능한 경우 Google 행아웃과 메신저 애플리케이션은 미디어 서버와 같은 프로세스에 미디어를 자동으로 전달하지 않습니다.

사사


참여해 주신 다음 연구원에게 감사드립니다.

  • Chrome 보안팀의 Abhishek Arya, Oliver Chang, Martin Barbella: CVE-2015-6636
  • KEEN lab, Tencent( @K33nTeam )의 Sen Nie( @nforest_ ), jfang: CVE-2015-6637
  • Android Bionic팀의 Yabin Cui: CVE-2015-6640
  • Google X의 Tom Craig: CVE-2015-6641
  • Jann Horn( https://thejh.net ): CVE-2015-6642
  • Jouni Malinen PGP(id: EFC895FA): CVE-2015-5310
  • Google 정보 보안 엔지니어팀의 Quan Nguyen: CVE-2015-6644
  • Gal Beniamini( @laginimaineb , http://bits-please.blogspot.com ): CVE-2015-6639

보안 취약성 세부정보


다음 섹션에서는 위의 보안 취약성 요약 에 나열된 각 취약성의 세부정보를 제공합니다. 여기에는 문제에 대한 설명, 심각도 근거 및 CVE, 관련 버그, 심각도, 업데이트된 버전 및 신고된 날짜가 포함된 표가 제시됩니다. 가능한 경우 문제를 해결한 AOSP 변경사항을 버그 ID에 연결합니다. 하나의 버그와 관련된 변경사항이 여러 개인 경우 추가 AOSP 참조가 버그 ID 다음에 오는 번호에 연결됩니다.

미디어 서버의 원격 코드 실행 취약성

특별히 제작된 파일을 미디어 파일 및 데이터 처리하는 동안 미디어 서버의 취약성을 통해 공격자가 메모리 손상을 일으키고 원격 코드가 미디어 서버 프로세스로 실행되도록 할 수 있습니다.

문제의 기능은 운영체제의 핵심 부분이며, 여러 애플리케이션에서 이 기능이 원격 콘텐츠, 특히 MMS와 미디어의 브라우저 재생에 접근할 수 있게 허용합니다.

이 문제는 미디어 서버 서비스 내에서 원격 코드를 실행할 가능성으로 인해 심각도 심각으로 평가됩니다. 미디어 서버 서비스는 오디오와 동영상 스트림뿐 아니라 타사 앱이 일반적으로 액세스할 수 없는 권한에 액세스할 수 있습니다.

CVE AOSP 링크가 포함된 버그 심각도 업데이트된 버전 신고된 날짜
CVE-2015-6636 ANDROID-25070493 심각 5.0, 5.1.1, 6.0, 6.0.1 Google 사내용
ANDROID-24686670 심각 5.0, 5.1.1, 6.0, 6.0.1 Google 사내용

misc-sd 드라이버의 권한 승격 취약성

MediaTek의 misc-sd 드라이버 권한 승격 취약성으로 인해 로컬 악성 애플리케이션이 커널 내에서 임의의 코드를 실행할 수 있습니다. 이 문제는 영구적인 로컬 기기 손상을 일으킬 가능성이 있으므로 심각도 심각으로 평가되며 기기는 운영체제를 최신 버전으로 업데이트하여 수리할 수 있습니다.

CVE 버그 심각도 업데이트된 버전 신고된 날짜
CVE-2015-6637 ANDROID-25307013* 심각 4.4.4, 5.0, 5.1.1, 6.0, 6.0.1 2015년 10월 26일

* 이 문제에 대한 패치는 AOSP에 포함되어 있지 않습니다. 업데이트는 Google 개발자 사이트 에서 제공되는 Nexus 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

Imagination Technologies 드라이버의 권한 승격 취약성

Imagination Technologies 커널 드라이버의 권한 승격 취약성을 악용하여 로컬 악성 애플리케이션은 커널 내에서 임의의 코드를 실행할 수 있습니다. 이 문제는 영구적인 로컬 기기 손상을 일으킬 가능성이 있으므로 심각도 심각으로 평가되며 기기는 운영체제를 최신 버전으로 업데이트하여 수리할 수 있습니다.

CVE 버그 심각도 업데이트된 버전 신고된 날짜
CVE-2015-6638 ANDROID-24673908* 심각 5.0, 5.1.1, 6.0, 6.0.1 Google 사내용

* 이 문제에 대한 패치는 AOSP에 포함되어 있지 않습니다. 업데이트는 Google 개발자 사이트 에서 제공되는 Nexus 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

Trustzone의 권한 승격 취약성

Widevine QSEE TrustZone 애플리케이션의 권한 승격 취약성으로 인해 QSEECOM에 액세스하는 도용된 애플리케이션이 Trustzone 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다. 이 문제는 영구적인 로컬 기기 손상을 일으킬 가능성이 있으므로 심각도 심각으로 평가되며 기기는 운영체제를 최신 버전으로 업데이트하여 수리할 수 있습니다.

CVE 버그 심각도 업데이트된 버전 신고된 날짜
CVE-2015-6639 ANDROID-24446875* 심각 5.0, 5.1.1, 6.0, 6.0.1 2015년 9월 23일
CVE-2015-6647 ANDROID-24441554* 심각 5.0, 5.1.1, 6.0, 6.0.1 2015년 9월 27일

* 이 문제에 대한 패치는 AOSP에 포함되어 있지 않습니다. 업데이트는 Google 개발자 사이트 에서 제공되는 Nexus 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

커널의 권한 승격 취약성

커널의 권한 승격 취약성으로 인해 로컬 악성 애플리케이션이 커널 내에서 임의의 코드를 실행할 수 있습니다. 이 문제는 영구적인 로컬 기기 손상을 일으킬 가능성이 있으므로 심각도 심각으로 평가되며 기기는 운영체제를 최신 버전으로 업데이트하여 수리할 수 있습니다.

CVE AOSP 링크가 포함된 버그 심각도 업데이트된 버전 신고된 날짜
CVE-2015-6640 ANDROID-20017123 심각 4.4.4, 5.0, 5.1.1, 6.0 Google 사내용

블루투스의 권한 승격 취약성

블루투스 구성요소의 권한 승격 취약성으로 인해 블루투스로 페어링된 원격 기기가 사용자의 개인정보(주소록)에 액세스할 수 있습니다. 이 문제는 ' 위험한 ' 기능에 원격으로 액세스할 수 있으므로 심각도 높음으로 평가됩니다. 이 권한은 로컬에 설치된 타사 애플리케이션에만 액세스할 수 있습니다.

CVE AOSP 링크가 포함된 버그 심각도 업데이트된 버전 신고된 날짜
CVE-2015-6641 ANDROID-23607427 [ 2 ] 높음 6.0, 6.0.1 Google 사내용

커널의 정보 공개 취약성

커널의 정보 공개 취약성으로 인해 공격자가 플랫폼을 악용하기 어렵도록 마련된 보안 장치를 우회할 수 있습니다. 이 문제는 타사 애플리케이션이 액세스할 수 없는 기능에 서명 또는 SignatureOrSystem 권한과 같이 승격된 권한을 부여하는 데 사용될 수 있으므로 심각도 높음으로 평가됩니다.

CVE 버그 심각도 업데이트된 버전 신고된 날짜
CVE-2015-6642 ANDROID-24157888* 높음 4.4.4, 5.0, 5.1.1, 6.0 2015년 9월 12일

* 이 문제에 대한 패치는 AOSP에 포함되어 있지 않습니다. 업데이트는 Google 개발자 사이트 에서 제공되는 Nexus 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

설치 마법사의 권한 승격 취약성

설치 마법사의 권한 승격 취약성으로 인해 기기에 대한 피지컬 액세스 권한이 있는 공격자가 기기 설정에 액세스하고 수동으로 초기화할 수 있습니다. 이 문제는 초기화 보호와 관련하여 부적절한 작업을 수행하는 데 사용될 수 있어서 심각도 보통으로 평가됩니다.

CVE AOSP 링크가 포함된 버그 심각도 업데이트된 버전 신고된 날짜
CVE-2015-6643 ANDROID-25290269 [ 2 ] 보통 5.1.1, 6.0, 6.0.1 Google 사내용

Wi-Fi의 권한 승격 취약성

Wi-Fi 구성요소의 권한 승격 취약성으로 인해 로컬에서 가까운 공격자가 Wi-Fi 서비스 관련 정보에 액세스할 수 있습니다. 이 기기는 로컬 근접 상황에서 이 문제에만 취약합니다. 이 문제는 ' 일반 ' 기능에 원격으로 액세스하는 데 사용될 수 있어서 심각도 보통으로 평가됩니다. 이 권한은 로컬에 설치된 타사 애플리케이션에만 액세스할 수 있습니다.

CVE AOSP 링크가 포함된 버그 심각도 업데이트된 버전 신고된 날짜
CVE-2015-5310 ANDROID-25266660 보통 4.4.4, 5.0, 5.1.1, 6.0, 6.0.1 2015년 10월 25일

Bouncy Castle의 정보 공개 취약성

Bouncy Castle의 정보 공개 취약성으로 인해 로컬 악성 애플리케이션이 사용자의 개인정보에 액세스할 수 있습니다. 이 문제는 부적절하게 ' 위험한 ' 권한을 얻는 데 사용될 수 있어서 심각도 보통으로 평가됩니다.

CVE AOSP 링크가 포함된 버그 심각도 업데이트된 버전 신고된 날짜
CVE-2015-6644 ANDROID-24106146 보통 4.4.4, 5.0, 5.1.1, 6.0, 6.0.1 Google 사내용

SyncManager의 서비스 거부(DoS) 취약성

SyncManager의 서비스 거부 취약성으로 인해 로컬 악성 애플리케이션이 재부팅 루프를 유발할 수 있습니다. 이 문제는 초기화를 통해 해결해야 하는 일시적인 서비스 거부를 유발하는 데 사용될 수 있어서 심각도 보통으로 평가됩니다.

CVE AOSP 링크가 포함된 버그 심각도 업데이트된 버전 신고된 날짜
CVE-2015-6645 ANDROID-23591205 보통 4.4.4, 5.0, 5.1.1, 6.0 Google 사내용

Nexus 커널의 공격 범위 축소

SysV IPC는 Android 커널에서 지원되지 않습니다. SysV IPC는 악성 애플리케이션에 의해 악용될 수 있는 시스템에 기능을 추가하지 않으면서 공격 범위를 더 노출하기 때문에 OS에서 삭제했습니다. 또한 할당된 리소스는 메모리 관리자가 제거할 수 없어서 전반적인 커널 리소스 누출을 유발하기 때문에, System V IPC는 Android의 애플리케이션 수명 주기와 호환되지 않습니다. 이 변경사항은 CVE-2015-7613과 같은 문제를 해결합니다.

CVE 버그 심각도 업데이트된 버전 신고된 날짜
CVE-2015-6646 ANDROID-22300191* 보통 6.0 Google 사내용

* 이 문제에 대한 패치는 AOSP에 포함되어 있지 않습니다. 업데이트는 Google 개발자 사이트 에서 제공되는 Nexus 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

일반적인 질문 및 답변

이 섹션에서는 게시판을 읽은 뒤 제기될 수 있는 일반적인 질문에 답변을 제시합니다.

1. 내 기기가 업데이트되어 이 문제가 해결되었는지 어떻게 알 수 있나요?

위의 문제는 빌드 LMY49F 이상 및 2016년 1월 1일 보안 패치 수준이 포함된 Android 6.0 이상에서 해결됩니다. 보안 패치 수준을 확인하는 방법에 대한 안내는 Nexus 도움말 을 참조하세요. 이 업데이트를 포함하는 기기 제조업체는 패치 문자열 수준을 다음과 같이 설정해야 합니다. [ro.build.version.security_patch]:[2016-01-01]

버전


  • 2016년 1월 4일: 게시판이 게시됨
  • 2016년 1월 6일: 게시판이 수정되어 AOSP 링크 포함됨