Android 보안 게시판 — 2016년 5월

2016년 5월 2일 게시됨 | 2016년 5월 4일 업데이트됨

Android 보안 게시판은 Android 기기에 영향을 미치는 보안 취약성 세부정보를 다룹니다. 게시판과 함께 무선 업데이트를 통해 Nexus 기기 보안 업데이트가 출시되었습니다. 또한 Nexus 펌웨어 이미지도 Google 개발자 사이트에 출시되었습니다. 2016년 5월 1일 이후 보안 패치 수준에서 다음 문제가 해결되었습니다 (보안 패치 수준을 확인하는 방법을 알아보려면 Nexus 도움말을 참조하세요).

파트너에게는 게시판에 설명된 문제를 2016년 4월 4일 이전에 통지했습니다. 해당하는 경우, 소스 코드 패치가 Android 오픈소스 프로젝트(AOSP) 저장소에 배포되었습니다.

이 중 가장 심각한 문제는 미디어 파일을 처리할 때 이메일과 웹 탐색, MMS 등 여러 방법을 통해 대상 기기에서 원격으로 코드를 실행할 수 있게 하는 심각한 보안 취약성입니다.

실제 고객이 새로 보고된 이러한 문제로 인해 악용당했다는 신고는 접수되지 않았습니다. SafetyNet과 같이 Android 플랫폼의 보안을 개선하는 Android 보안 플랫폼 보호 및 서비스 보호 기능에 대한 세부정보를 보려면 Android 및 Google 서비스 완화 섹션을 참조하세요.

모든 고객은 기기에서 이 업데이트를 수락하는 것이 좋습니다.

공지사항

  • 좀 더 넓게 집중적으로 반영하기 위해 이 게시판(및 시리즈의 모든 항목)의 이름을 Android 보안 게시판으로 변경했습니다. 이 게시판은 Nexus 기기에 영향을 미치지 않더라도 Android 기기에 영향을 미칠 수 있는 더 넓은 범위의 취약성을 포함합니다.
  • Android 보안 심각도 등급을 업데이트했습니다. 이 변경사항은 보고된 보안 취약성과 관련하여 최근 6개월간 수집된 데이터의 결과물이며 심각도에 실제로 사용자에게 미치는 영향을 더 밀접히 반영하려고 노력했습니다.

보안 취약성 요약

아래 표에는 보안 취약성 목록, 일반적인 취약성 및 노출 ID(CVE), 평가된 심각도 및 Nexus 기기가 영향을 받는지 여부가 포함되어 있습니다. 심각도 평가는 개발 목적으로 플랫폼 및 서비스 완화를 사용할 수 없거나 우회에 성공한 경우 취약성 악용으로 인해 대상 기기가 받는 영향을 기준으로 내려집니다.

문제 CVE 심각도 Nexus에 영향 여부
미디어 서버의 원격 코드 실행 취약성 CVE-2016-2428
CVE-2016-2429
심각
Debuggered의 권한 승격 취약성 CVE-2016-2430 심각
Qualcomm TrustZone의 권한 승격 취약성 CVE-2016-2431
CVE-2016-2432
심각
Qualcomm Wi-Fi 드라이버의 권한 승격 취약성 CVE-2015-0569
CVE-2015-0570
심각
NVIDIA 동영상 드라이버의 권한 승격 취약성 CVE-2016-2434
CVE-2016-2435
CVE-2016-2436
CVE-2016-2437
심각
커널의 권한 승격 취약성 CVE-2015-1805 심각
커널의 원격 코드 실행 취약성 CVE-2016-2438 높음
Qualcomm 테더링 컨트롤러의 정보 공개 취약성 CVE-2016-2060 높음 아니요
블루투스의 원격 코드 실행 CVE-2016-2439 높음
Binder의 권한 승격 CVE-2016-2440 높음
Qualcomm Buspm 드라이버의 권한 승격 취약성 CVE-2016-2441
CVE-2016-2442
높음
Qualcomm MDP 드라이버의 권한 승격 취약성 CVE-2016-2443 높음
Qualcomm Wi-Fi 드라이버의 권한 승격 취약성 CVE-2015-0571 높음
NVIDIA 동영상 드라이버의 권한 승격 취약성 CVE-2016-2444
CVE-2016-2445
CVE-2016-2446
높음
Wi-Fi의 권한 승격 CVE-2016-4477 높음
미디어 서버의 권한 승격 취약성 CVE-2016-2448
CVE-2016-2449
CVE-2016-2450
CVE-2016-2451
CVE-2016-2452
높음
MediaTek Wi-Fi 드라이버의 권한 승격 취약성 CVE-2016-2453 높음
Qualcomm 하드웨어 코덱의 원격 서비스 거부 취약성 CVE-2016-2454 높음
Conscrypt의 권한 승격 CVE-2016-2461
CVE-2016-2462
보통
OpenSSL & BoringSSL의 권한 승격 취약성 CVE-2016-0705 보통
MediaTek Wi-Fi 드라이버의 권한 승격 취약성 CVE-2016-2456 보통
Wi-Fi의 권한 승격 CVE-2016-2457 보통
AOSP 메일의 정보 공개 취약성 CVE-2016-2458 보통
미디어 서버의 정보 공개 취약성 CVE-2016-2459
CVE-2016-2460
보통
커널의 서비스 거부(DoS) 취약성 CVE-2016-0774 낮음

Android 및 Google 서비스 완화

다음은 SafetyNet과 같은 Android 보안 플랫폼 및 서비스 보호 기능에서 제공하는 완화에 대한 요약입니다. 이러한 기능을 통해 Android에서 보안 취약성이 악용될 가능성을 줄입니다.

  • Android 플랫폼 최신 버전의 향상된 기능으로 Android의 여러 문제를 악용하기가 더욱 어려워졌습니다. 가능한 경우 모든 사용자는 Android 최신 버전으로 업데이트하는 것이 좋습니다.
  • Android 보안팀에서는 유해할 수 있는 애플리케이션이 설치될 때 경고를 보내는 앱 인증 및 SafetyNet을 사용하여 악용사례를 적극적으로 모니터링합니다. 앱 인증은 Google 모바일 서비스로 기기에서 기본적으로 사용 설정되어 있으며 Google Play 외부에서 애플리케이션을 설치하는 사용자에게 특히 중요합니다. Google Play 내에서 기기 루팅 도구는 금지되어 있지만 사용자가 출처에 상관없이 루팅 애플리케이션을 설치하려 하면 앱 인증이 경고를 표시합니다. 또한 앱 인증은 권한 승격 취약성을 악용하는 것으로 알려진 악성 애플리케이션을 식별하고 차단합니다. 이러한 애플리케이션이 이미 설치된 경우 앱 인증에서 사용자에게 이를 알리고 감지된 애플리케이션을 삭제하려고 시도합니다.
  • 가능한 경우 Google 행아웃과 메신저 애플리케이션은 미디어 서버와 같은 프로세스에 미디어를 자동으로 전달하지 않습니다.

사사

참여해 주신 다음 연구원에게 감사드립니다.

  • Chrome 보안팀의 Abhishek Arya, Oliver Chang, Martin Barbella : CVE-2016-2454
  • e2e-assure의 Andy Tyler(@ticarpi) : CVE-2016-2457
  • C0RE팀의 Chiachih Wu(@chiachih_wu), Xuxian Jiang: CVE-2016-2441, CVE-2016-2442
  • Dzmitry Lukyanenka( www.linkedin.com/in/dzima): CVE-2016-2458
  • Gal Beniamini: CVE-2016-2431
  • Qihoo 360 Technology Co. Ltd. Vulpecker 팀의 Hao Chen : CVE-2016-2456
  • FireEye 계열사, Mandiant의 Jake Valletta : CVE-2016-2060
  • Qihoo 360 Technology Co. Ltd. IceSword Lab의 Jianqiang Zhao(@jianqiangzhao), pjf(weibo.com/jfpan) : CVE-2016-2434, CVE-2016-2435, CVE-2016-2436, CVE-2016-2441, CVE-2016-2442, CVE-2016-2444, CVE-2016-2445, CVE-2016-2446
  • Search-Lab Ltd.의 Imre Rad: CVE-2016-4477
  • Google의 Jeremy C. Joslin: CVE-2016-2461
  • Google의 Kenny Root: CVE-2016-2462
  • Tencent, KeenLab(@keen_lab)의 Marco Grassi(@marcograss): CVE-2016-2443
  • Michał Bednarski( https://github.com/michalbednarski): CVE-2016-2440
  • C0RE팀의 Mingjian Zhou(@Mingjian_Zhou), Chiachih Wu(@chiachih_wu), Xuxian Jiang: CVE-2016-2450, CVE-2016-2448, CVE-2016-2449, CVE-2016-2451, CVE-2016-2452
  • Trend Micro의 Peter Pi(@heisecode) : CVE-2016-2459, CVE-2016-2460
  • Alibaba Inc.의 Weichao Sun(@sunblate) : CVE-2016-2428, CVE-2016-2429
  • C0RE팀Yuan-Tsung Lo, Lubo Zhang, Chiachih Wu(@chiachih_wu), Xuxian Jiang: CVE-2016-2437
  • Baidu X-Lab의 Yulong Zhang, Tao (Lenx) Wei: CVE-2016-2439
  • Android 보안팀의 Zach Riggle(@ebeip90) : CVE-2016-2430

보안 취약성 세부정보

다음 섹션에서는 위의 보안 취약성 요약에 나열된 각 취약성 세부정보를 제공합니다. 여기에는 문제 설명, 심각도 근거 및 CVE, 관련 버그, 심각도, 업데이트된 Nexus 기기, 업데이트된 AOSP 버전(해당하는 경우), 신고된 날짜 등이 포함된 표가 제시됩니다. 가능한 경우 문제를 해결한 AOSP 변경사항을 버그 ID에 연결합니다. 하나의 버그와 관련된 변경사항이 여러 개인 경우 추가 AOSP 참조가 버그 ID 다음에 오는 번호에 연결됩니다.

미디어 서버의 원격 코드 실행 취약성

특별히 제작된 파일을 미디어 파일 및 데이터 처리하는 동안 미디어 서버의 취약성을 통해 공격자가 메모리 손상을 일으키고 원격 코드가 미디어 서버 프로세스로 실행되도록 할 수 있습니다.

문제의 기능은 운영체제의 핵심 부분이며, 여러 애플리케이션에서 이 기능이 원격 콘텐츠, 특히 MMS와 미디어의 브라우저 재생에 접근할 수 있게 허용합니다.

이 문제는 미디어 서버 서비스 내에서 원격 코드를 실행할 가능성으로 인해 심각도 심각으로 평가됩니다. 미디어 서버 서비스는 오디오와 동영상 스트림뿐 아니라 타사 앱이 일반적으로 액세스할 수 없는 권한에 액세스할 수 있습니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 업데이트된 AOSP 버전 신고된 날짜
CVE-2016-2428 26751339 심각 모든 Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2016년 1월 22일
CVE-2016-2429 27211885 심각 모든 Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2016년 2월 16일

Debuggered의 권한 승격 취약성

통합 Android 디버거의 권한 승격 취약성으로 인해 로컬 악성 애플리케이션이 Android 디버거의 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다. 이 문제는 영구적인 로컬 기기 손상을 일으킬 가능성이 있으므로 심각도 심각으로 평가되며, 기기를 수리하려면 운영체제를 최신 버전으로 업데이트해야 할 수도 있습니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 업데이트된 AOSP 버전 신고된 날짜
CVE-2016-2430 27299236 심각 모든 Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2016년 2월 22일

Qualcomm TrustZone의 권한 승격 취약성

Qualcomm TrustZone 구성요소의 권한 승격 취약성으로 인해 보안 로컬 악성 애플리케이션이 TrustZone 커널의 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다. 이 문제는 영구적인 로컬 기기 손상을 일으킬 가능성이 있으므로 심각도 심각으로 평가되며, 기기를 수리하려면 운영체제를 최신 버전으로 업데이트해야 할 수도 있습니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 신고된 날짜
CVE-2016-2431 24968809* 심각 Nexus 5, Nexus 6, Nexus 7(2013), Android One 2015년 10월 15일
CVE-2016-2432 25913059* 심각 Nexus 6, Android One 2015년 11월 28일

* 이 문제를 해결하기 위한 패치는 AOSP에 포함되어 있지 않습니다. 업데이트는 Google 개발자 사이트에서 제공되는 Nexus 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

Qualcomm Wi-Fi 드라이버의 권한 승격 취약성

Qualcomm Wi-Fi 드라이버의 권한 승격 취약성으로 인해 로컬 악성 애플리케이션이 커널 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다. 이 문제는 영구적인 로컬 기기 손상을 일으킬 가능성이 있으므로 심각도 심각으로 평가되며, 기기를 수리하려면 운영체제를 최신 버전으로 업데이트해야 할 수도 있습니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 신고된 날짜
CVE-2015-0569 26754117* 심각 Nexus 5X, Nexus 7(2013) 2016년 1월 23일
CVE-2015-0570 26764809* 심각 Nexus 5X, Nexus 7(2013) 2016년 1월 25일

* 이 문제를 해결하기 위한 패치는 AOSP에 포함되어 있지 않습니다. 업데이트는 Google 개발자 사이트에서 제공되는 Nexus 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

NVIDIA 동영상 드라이버의 권한 승격 취약성

NVIDIA 동영상 드라이버의 권한 승격 취약성으로 인해 로컬 악성 애플리케이션이 커널 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다. 이 문제는 영구적인 로컬 기기 손상을 일으킬 가능성이 있으므로 심각도 심각으로 평가되며, 기기를 수리하려면 운영체제를 최신 버전으로 업데이트해야 할 수도 있습니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 신고된 날짜
CVE-2016-2434 27251090* 심각 Nexus 9 2016년 2월 17일
CVE-2016-2435 27297988* 심각 Nexus 9 2016년 2월 20일
CVE-2016-2436 27299111* 심각 Nexus 9 2016년 2월 22일
CVE-2016-2437 27436822* 심각 Nexus 9 2016년 3월 1일

* 이 문제를 해결하기 위한 패치는 AOSP에 포함되어 있지 않습니다. 업데이트는 Google 개발자 사이트에서 제공되는 Nexus 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

커널의 권한 승격 취약성

커널의 권한 승격 취약성으로 인해 로컬 악성 애플리케이션이 커널 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다. 이 문제는 로컬 권한 승격 및 임의의 코드 실행 가능성으로 로컬 기기가 영구적으로 손상될 수 있으므로 심각도 심각으로 평가되며 기기를 수리하려면 운영체제를 최신 버전으로 업데이트해야 할 수도 있습니다. 이 문제는 Android 보안 권고 2016-03-18에 설명되어 있습니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 신고된 날짜
CVE-2015-1805 27275324* 심각 Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 7(2013), Nexus 9 2016년 2월 19일

* 다음과 같은 특정 커널 버전에 AOSP의 패치를 사용할 수 있습니다. 3.14, 3.10, 3.4

커널의 원격 코드 실행 취약성

오디오 하위 시스템의 원격 코드 실행 취약성으로 인해 로컬 악성 애플리케이션이 커널 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다. 일반적으로 이와 같은 커널 코드 실행 버그는 심각으로 평가되지만, 먼저 오디오 하위 시스템을 호출하기 위해 권한이 있는 서비스에 침투해야만 실행 가능하므로 심각도 높음으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 신고된 날짜
CVE-2016-2438 26636060* 높음 Nexus 9 Google 사내용

* 이 문제를 해결하기 위한 패치는 Linux 업스트림에 있습니다.

Qualcomm 테더링 컨트롤러의 정보 공개 취약성

Qualcomm 테더링 컨트롤러의 정보 공개 취약성으로 인해 권한이 없는 로컬 악성 애플리케이션이 개인 식별 정보에 액세스할 수 있습니다. 이 문제는 제3자 애플리케이션이 액세스할 수 없는 기능에 서명 또는 SignatureOrSystem 권한과 같이 승격된 권한을 부여하는 데 사용될 수 있으므로 심각도 높음으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 신고된 날짜
CVE-2016-2060 27942588* 높음 없음 2016년 3월 23일

* 이 문제를 해결하기 위한 패치는 AOSP에 포함되어 있지 않습니다. 업데이트가 대상 기기의 최신 드라이버에 포함되어야 합니다.

블루투스의 원격 코드 실행 취약성

블루투스 기기가 페어링되는 동안 블루투스의 취약성으로 인해 가까운 공격자가 페어링 과정에서 임의의 코드를 실행할 수 있습니다. 이 문제는 블루투스 기기를 초기화하는 동안 원격 코드 실행 가능성으로 인해 심각도 높음으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 업데이트된 AOSP 버전 신고된 날짜
CVE-2016-2439 27411268 높음 모든 Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2016년 2월 28일

Binder의 권한 승격 취약성

Binder의 권한 승격 취약성은 악성 애플리케이션이 다른 앱의 프로세스 내에서 임의의 코드를 실행할 수 있게 합니다. 메모리 공간을 확보하는 동안 Binder의 취약성으로 인해 공격자가 로컬 코드를 실행하도록 할 수 있습니다. Binder에서 여분의 메모리 프로세스 동안 로컬 코드 실행 가능성으로 인해 심각도 높음으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 업데이트된 AOSP 버전 신고된 날짜
CVE-2016-2440 27252896 높음 모든 Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2016년 2월 18일

Qualcomm Buspm 드라이버의 권한 승격 취약성

Qualcomm Buspm 드라이버의 권한 승격 취약성으로 인해 로컬 악성 애플리케이션이 커널 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다. 일반적으로 이와 같은 커널 코드 실행 버그는 심각으로 평가되지만 먼저 드라이버를 호출할 수 있는 서비스에 침투해야만 실행 가능하므로 심각도 높음으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 신고된 날짜
CVE-2016-2441 26354602* 높음 Nexus 5X, Nexus 6, Nexus 6P 2015년 12월 30일
CVE-2016-2442 26494907* 높음 Nexus 5X, Nexus 6, Nexus 6P 2015년 12월 30일

* 이 문제를 해결하기 위한 패치는 AOSP에 포함되어 있지 않습니다. 업데이트는 Google 개발자 사이트에서 제공되는 Nexus 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

Qualcomm MDP 드라이버의 권한 승격 취약성

Qualcomm MDP 드라이버의 권한 승격 취약성으로 인해 로컬 악성 애플리케이션이 커널 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다. 일반적으로 이와 같은 커널 코드 실행 버그는 심각으로 평가되지만 먼저 드라이버를 호출할 수 있는 서비스에 침투해야만 실행 가능하므로 심각도 높음으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 신고된 날짜
CVE-2016-2443 26404525* 높음 Nexus 5, Nexus 7(2013) 2016년 1월 5일

* 이 문제를 해결하기 위한 패치는 AOSP에 포함되어 있지 않습니다. 업데이트는 Google 개발자 사이트에서 제공되는 Nexus 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

Qualcomm Wi-Fi 드라이버의 권한 승격 취약성

Qualcomm Wi-Fi 구성요소의 권한 승격 취약성으로 인해 로컬 악성 애플리케이션이 기기 설정을 변경하는 시스템 호출이나 권한이 없는 작업을 수행할 수 있습니다. 이 문제는 타사 애플리케이션이 액세스할 수 없는 기능에 서명 또는 SignatureOrSystem 권한과 같이 승격된 권한으로의 로컬 액세스를 부여하는 데 사용될 수 있으므로 심각도 높음으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 신고된 날짜
CVE-2015-0571 26763920* 높음 Nexus 5X, Nexus 7(2013) 2016년 1월 25일

* 이 문제를 해결하기 위한 패치는 AOSP에 포함되어 있지 않습니다. 업데이트는 Google 개발자 사이트에서 제공되는 Nexus 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

NVIDIA 동영상 드라이버의 권한 승격 취약성

NVIDIA 미디어 드라이버의 권한 승격 취약성으로 인해 로컬 악성 애플리케이션이 커널의 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다. 일반적으로 이와 같은 커널 코드 실행 버그는 심각으로 평가되지만, 먼저 드라이버를 호출할 수 있는 높은 권한의 서비스에 침투해야만 실행 가능하므로 심각도 높음으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 신고된 날짜
CVE-2016-2444 27208332* 높음 Nexus 9 2016년 2월 16일
CVE-2016-2445 27253079* 높음 Nexus 9 2016년 2월 17일
CVE-2016-2446 27441354* 높음 Nexus 9 2016년 3월 1일

* 이 문제를 해결하기 위한 패치는 AOSP에 포함되어 있지 않습니다. 업데이트는 Google 개발자 사이트에서 제공되는 Nexus 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

Wi-Fi의 권한 승격 취약성

Wi-Fi의 권한 승격 취약성을 악용하여 로컬 악성 애플리케이션이 권한이 승격된 시스템 애플리케이션 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다. 이 문제는 타사 애플리케이션이 액세스할 수 없는 기능에 서명 또는 SignatureOrSystem 권한과 같이 승격된 권한을 부여하는 데 사용될 수 있으므로 심각도 높음으로 평가됩니다.

참고: CVE 번호는 CVE-2016-2447에서 CVE-2016-4477까지 MITRE 요청에 따라 업데이트되었습니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 업데이트된 AOSP 버전 신고된 날짜
CVE-2016-4477 27371366 [2] 높음 모든 Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2016년 2월 24일

미디어 서버의 권한 승격 취약성

미디어 서버의 권한 승격 취약성으로 인해 로컬 악성 애플리케이션이 승격된 시스템 애플리케이션 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다. 이 문제는 타사 애플리케이션이 액세스할 수 없는 기능에 서명 또는 SignatureOrSystem 권한과 같이 승격된 권한을 부여하는 데 사용될 수 있으므로 심각도 높음으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 업데이트된 AOSP 버전 신고된 날짜
CVE-2016-2448 27533704 높음 모든 Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2016년 3월 7일
CVE-2016-2449 27568958 높음 모든 Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2016년 3월 9일
CVE-2016-2450 27569635 높음 모든 Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2016년 3월 9일
CVE-2016-2451 27597103 높음 모든 Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2016년 3월 10일
CVE-2016-2452 27662364 [2] [3] 높음 모든 Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2016년 3월 14일

MediaTek Wi-Fi 드라이버의 권한 승격 취약성

MediaTek Wi-Fi 드라이버의 권한 승격 취약성으로 인해 로컬 악성 애플리케이션이 커널 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다. 일반적으로 이와 같은 커널 코드 실행 버그는 심각으로 평가되지만 먼저 드라이버를 호출할 수 있는 서비스에 침투해야만 실행 가능하므로 심각도 높음으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 신고된 날짜
CVE-2016-2453 27549705* 높음 Android One 2016년 3월 8일

* 이 문제를 해결하기 위한 패치는 AOSP에 포함되어 있지 않습니다. 업데이트는 Google 개발자 사이트에서 제공되는 Nexus 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

Qualcomm 하드웨어 코덱의 원격 서비스 거부 취약성

특별히 제작된 파일의 미디어 파일 및 데이터를 처리하는 동안 Qualcomm 하드웨어 동영상 코덱의 서비스 원격 거부 취약성으로 인해 원격 공격자가 기기를 재부팅하여 대상 기기에 대한 액세스를 차단하도록 할 수 있습니다. 이 문제는 서비스 원격 거부 가능성으로 인해 심각도 높음으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 신고된 날짜
CVE-2016-2454 26221024* 높음 Nexus 5 2015년 12월 16일

* 이 문제를 해결하기 위한 패치는 AOSP에 포함되어 있지 않습니다. 업데이트는 Google 개발자 사이트에서 제공되는 Nexus 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

Conscrypt의 권한 승격 취약성

Conscrypt의 권한 승격 취약성으로 인해 로컬 악성 애플리케이션이 인증되지 않은 메시지를 인증된 메시지로 간주할 수 있습니다. 이 문제는 여러 기기에 걸쳐 조정된 단계가 있어야 실행 가능하므로 심각도 보통으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 업데이트된 AOSP 버전 신고된 날짜
CVE-2016-2461 27324690 [2] 보통 모든 Nexus 6.0, 6.0.1 Google 사내용
CVE-2016-2462 27371173 보통 모든 Nexus 6.0, 6.0.1 Google 사내용

OpenSSL & BoringSSL의 권한 승격 취약성

OpenSSL 및 BoringSSL의 권한 승격 취약성으로 인해 로컬 악성 애플리케이션이 권한 수준을 벗어난 데이터에 액세스할 수 있습니다. 일반적으로 이와 같은 버그는 심각도 높음으로 평가되지만, 일반적이지 않은 수동 설정을 거쳐야 실행 가능하므로 심각도 보통으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 업데이트된 AOSP 버전 신고된 날짜
CVE-2016-0705 27449871 보통 모든 Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2016년 2월 7일

MediaTek Wi-Fi 드라이버의 권한 승격 취약성

MediaTek Wi-Fi 드라이버의 권한 승격 취약성으로 인해 로컬 악성 애플리케이션이 서비스를 거부하도록 할 수 있습니다. 일반적으로 이와 같은 권한 승격 버그는 심각도 높음으로 평가되지만, 먼저 시스템 서비스에 투해야 실행 가능하므로 심각도 보통으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 신고된 날짜
CVE-2016-2456 27275187* 보통 Android One 2016년 2월 19일

* 이 문제를 해결하기 위한 패치는 AOSP에 포함되어 있지 않습니다. 업데이트는 Google 개발자 사이트에서 제공되는 Nexus 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

Wi-Fi의 권한 승격 취약성

Wi-Fi의 권한 승격 취약성으로 인해 게스트 계정이 기본 사용자용으로 유지되는 Wi-Fi 설정을 변경할 수 있습니다. 이 문제는 허가 없이 '위험한' 기능에 로컬 액세스를 허용하기 때문에 심각도 보통으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 업데이트된 AOSP 버전 신고된 날짜
CVE-2016-2457 27411179 보통 모든 Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 2016년 2월 29일

AOSP 메일의 정보 공개 취약성

AOSP 메일의 정보 공개 취약성으로 인해 로컬 악성 애플리케이션이 사용자의 개인정보에 액세스할 수 있습니다. 이 문제는 권한 없이 부적절하게 데이터에 액세스하는 데 사용될 수 있으므로 심각도 보통으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 업데이트된 AOSP 버전 신고된 날짜
CVE-2016-2458 27335139 [2] 보통 모든 Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 2016년 2월 23일

미디어 서버의 정보 공개 취약성

미디어 서버의 정보 공개 취약성으로 인해 특정 애플리케이션이 민감한 정보에 액세스할 수 있습니다. 이 문제는 권한 없이 부적절하게 데이터에 액세스하는 데 사용될 수 있으므로 심각도 보통으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 업데이트된 AOSP 버전 신고된 날짜
CVE-2016-2459 27556038 보통 모든 Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2016년 3월 7일
CVE-2016-2460 27555981 보통 모든 Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2016년 3월 7일

커널의 서비스 거부(DoS) 취약성

커널의 서비스 거부 취약성으로 인해 로컬 악성 애플리케이션이 기기를 재부팅하도록 할 수 있습니다. 이 문제는 영향이 일시적인 서비스 거부이므로 심각도 낮음으로 평가됩니다.

CVE Android 버그 심각도 업데이트된 Nexus 기기 신고된 날짜
CVE-2016-0774 27721803* 낮음 모든 Nexus 2016년 3월 17일

* 이 문제를 해결하기 위한 패치는 Linux 업스트림에 있습니다.

일반적인 질문 및 답변

이 섹션에서는 게시판을 읽은 뒤 제기될 수 있는 일반적인 질문에 답변을 제시합니다.

1. 내 기기가 업데이트되어 이 문제가 해결되었는지 어떻게 알 수 있나요?

2016년 5월 1일 이후 보안 패치 수준에서 다음 문제가 해결되었습니다(방법 안내는 Nexus 도움말을 참조하세요). 이 업데이트를 포함하는 기기 제조업체는 패치 문자열 수준을 다음과 같이 설정해야 합니다. [ro.build.version.security_patch]:[2016-05-01]

2. 문제 유형별로 영향을 받는 Nexus 기기를 어떻게 결정하나요?

보안 취약성 세부정보 섹션에서 각각의 표에 문제 유형별로 업데이트된 대상 Nexus 기기의 범위를 포함하는 업데이트된 Nexus 기기 열이 있습니다. 이 열에는 다음과 같은 옵션이 있습니다.

  • 모든 Nexus 기기: 문제가 모든 Nexus 기기에 영향을 미치는 경우 표에서 업데이트된 Nexus 기기 열에 '모든 Nexus'라고 표시됩니다. '모든 Nexus'는 다음과 같은 지원되는 기기를 포함합니다. Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 7(2013), Nexus 9, Android One, Nexus Player, Pixel C
  • 일부 Nexus 기기: 문제가 영향을 미치지 않는 Nexus 기기가 있는 경우, 영향을 받는 Nexus 기기가 업데이트된 Nexus 기기 열에 표시됩니다.
  • Nexus 기기 해당없음: 문제가 Nexus 기기에 영향을 미치지 않는 경우 표에서 업데이트된 Nexus 기기 열에 '해당없음'이 표시됩니다.

3. 이 게시판에 CVE-2015-1805가 포함된 이유는 무엇인가요?

Android 보안 권고—2016-03-18이 4월 게시판과 거의 같은 때에 게시되어 CVE-2015-1805가 이 게시판에 포함되었습니다. 일정이 촉박하여 2016년 4월 1일의 보안 패치 수준을 사용한 기기 제조업체의 경우 CVE-2015-1805 수정 내용을 포함하지 못하고 Nexus 보안 게시판—2016년 4월의 수정 내용을 포함하는 옵션을 제공했습니다. 2016년 5월 1일의 보안 패치 수준을 사용하기 위해 수정해야 하기 때문에 이 게시판에 다시 포함됩니다.

버전

  • 2016년 5월 2일: 게시판이 게시됨
  • 2016년 5월 4일:
    • 게시판이 수정되어 AOSP 링크 포함됨
    • 모든 Nexus 기기 목록이 업데이트되어 Nexus Player 및 Pixel C 포함됨
    • MITRE 요청에 따라 CVE-2016-2447이 CVE-2016-4477로 업데이트됨