Google se compromete a impulsar la igualdad racial para las comunidades afrodescendientes. Obtén información al respecto.

Boletín de seguridad de Android: mayo de 2017

Organiza tus páginas con colecciones Guarda y categoriza el contenido según tus preferencias.

Publicado el 01 de mayo de 2017 | Actualizado el 03 de octubre de 2017

El Boletín de seguridad de Android contiene detalles de las vulnerabilidades de seguridad que afectan a los dispositivos Android. Junto con el boletín, lanzamos una actualización de seguridad para los dispositivos Nexus a través de una actualización inalámbrica (OTA). Las imágenes del firmware del dispositivo de Google también se publicaron en el sitio para desarrolladores de Google . Los niveles de parches de seguridad del 5 de mayo de 2017 o posteriores abordan todos estos problemas. Consulte el programa de actualización de Pixel y Nexus para obtener información sobre cómo verificar el nivel del parche de seguridad de un dispositivo.

Los socios fueron notificados de los problemas descritos en el boletín el 03 de abril de 2017 o antes. Los parches de código fuente para estos problemas se publicaron en el repositorio del Proyecto de código abierto de Android (AOSP) y se vincularon desde este boletín. Este boletín también incluye enlaces a parches fuera de AOSP.

El más grave de estos problemas es una vulnerabilidad de seguridad crítica que podría permitir la ejecución remota de código en un dispositivo afectado a través de múltiples métodos, como correo electrónico, navegación web y MMS al procesar archivos multimedia. La evaluación de la gravedad se basa en el efecto que podría tener la explotación de la vulnerabilidad en un dispositivo afectado, suponiendo que las mitigaciones de la plataforma y el servicio estén deshabilitadas para fines de desarrollo o si se eluden con éxito.

No hemos recibido informes de explotación activa de clientes o abuso de estos problemas recientemente informados. Consulte la sección Mitigaciones de servicios de Android y Google para obtener detalles sobre las protecciones de la plataforma de seguridad de Android y las protecciones de servicios como SafetyNet , que mejoran la seguridad de la plataforma Android.

Alentamos a todos los clientes a aceptar estas actualizaciones en sus dispositivos.

Anuncios

  • Este boletín tiene dos cadenas de nivel de parche de seguridad para brindar a los socios de Android la flexibilidad de solucionar más rápidamente un subconjunto de vulnerabilidades que son similares en todos los dispositivos Android. Consulte Preguntas y respuestas comunes para obtener información adicional:
    • 2017-05-01 : cadena de nivel de parche de seguridad parcial. Esta cadena de nivel de parche de seguridad indica que se abordaron todos los problemas asociados con 2017-05-01 (y todas las cadenas de nivel de parche de seguridad anteriores).
    • 2017-05-05 : cadena de nivel de parche de seguridad completa. Esta cadena de nivel de parche de seguridad indica que se abordaron todos los problemas asociados con 2017-05-01 y 2017-05-05 (y todas las cadenas de nivel de parche de seguridad anteriores).
  • Los dispositivos de Google compatibles recibirán una única actualización OTA con el nivel de parche de seguridad del 5 de mayo de 2017.

Mitigaciones de servicios de Android y Google

Este es un resumen de las mitigaciones proporcionadas por la plataforma de seguridad de Android y las protecciones de servicios como SafetyNet. Estas capacidades reducen la probabilidad de que las vulnerabilidades de seguridad puedan explotarse con éxito en Android.

  • La explotación de muchos problemas en Android se hace más difícil debido a las mejoras en las versiones más recientes de la plataforma Android. Alentamos a todos los usuarios a actualizar a la última versión de Android siempre que sea posible.
  • El equipo de seguridad de Android monitorea activamente el abuso con Verify Apps y SafetyNet , que están diseñados para advertir a los usuarios sobre aplicaciones potencialmente dañinas . Verificar aplicaciones está habilitado de forma predeterminada en dispositivos con Google Mobile Services y es especialmente importante para los usuarios que instalan aplicaciones desde fuera de Google Play. Las herramientas de enraizamiento de dispositivos están prohibidas en Google Play, pero Verify Apps advierte a los usuarios cuando intentan instalar una aplicación de enraizamiento detectada, sin importar de dónde provenga. Además, Verify Apps intenta identificar y bloquear la instalación de aplicaciones maliciosas conocidas que explotan una vulnerabilidad de escalada de privilegios. Si ya se instaló una aplicación de este tipo, Verify Apps notificará al usuario e intentará eliminar la aplicación detectada.
  • Según corresponda, las aplicaciones Google Hangouts y Messenger no pasan automáticamente los medios a procesos como Mediaserver.

Agradecimientos

Nos gustaría agradecer a estos investigadores por sus contribuciones:

  • ADlab de Venustech: CVE-2017-0630
  • Di Shen ( @returnsme ) de KeenLab ( @keen_lab ), Tencent: CVE-2016-10287
  • Ecular Xu (徐健) de Trend Micro: CVE-2017-0599, CVE-2017-0635
  • En He ( @heeeeen4x ) y Bo Liu de MS509Team : CVE-2017-0601
  • Ethan Yonker del proyecto de recuperación Team Win : CVE-2017-0493
  • Gengjia Chen ( @chengjia4574 ) y pjf de IceSword Lab, Qihoo 360 Technology Co. Ltd: CVE-2016-10285, CVE-2016-10288, CVE-2016-10290, CVE-2017-0624, CVE-2017-0616, CVE -2017-0617, CVE-2016-10294, CVE-2016-10295, CVE-2016-10296
  • godzheng (郑文选@VirtualSeekers ) de Tencent PC Manager: CVE-2017-0602
  • Güliz Seray Tuncay de la Universidad de Illinois en Urbana-Champaign : CVE-2017-0593
  • Hao Chen y Guang Gong de Alpha Team, Qihoo 360 Technology Co. Ltd: CVE-2016-10283
  • Juhu Nie, Yang Cheng, Nan Li y Qiwu Huang de Xiaomi Inc: CVE-2016-10276
  • Michał Bednarski : CVE-2017-0598
  • Nathan Crandall ( @natecray ) del equipo de seguridad de productos de Tesla: CVE-2017-0331, CVE-2017-0606
  • Niky1235 ( @jiych_guru ): CVE-2017-0603
  • Peng Xiao, Chengming Yang, Ning You, Chao Yang y Yang canción de Alibaba Mobile Security Group: CVE-2016-10281, CVE-2016-10280
  • Roee Hay ( @roeehay ) de Aleph Research : CVE-2016-10277
  • Scott Bauer ( @ScottyBauer1 ): CVE-2016-10274
  • Tong Lin , Yuan-Tsung Lo y Xuxian Jiang del equipo C0RE : CVE-2016-10291
  • Vasili Vasiliev: CVE-2017-0589
  • VEO ( @VYSEa ) del equipo de respuesta a amenazas móviles , Trend Micro : CVE-2017-0590, CVE-2017-0587, CVE-2017-0600
  • Xiling Gong del Departamento de Plataforma de Seguridad de Tencent: CVE-2017-0597
  • Xingyuan Lin de 360 ​​Marvel Team: CVE-2017-0627
  • Yong Wang (王勇) ( @ThomasKing2014 ) de Alibaba Inc: CVE-2017-0588
  • Yonggang Guo ( @guoygang ) de IceSword Lab, Qihoo 360 Technology Co. Ltd: CVE-2016-10289, CVE-2017-0465
  • Yu Pan del equipo Vulpecker, Qihoo 360 Technology Co. Ltd: CVE-2016-10282, CVE-2017-0615
  • Yu Pan y Peide Zhang del equipo Vulpecker, Qihoo 360 Technology Co. Ltd: CVE-2017-0618, CVE-2017-0625

2017-05-01 nivel de parche de seguridad-Detalles de vulnerabilidad

En las secciones a continuación, proporcionamos detalles para cada una de las vulnerabilidades de seguridad que se aplican al nivel de parche 2017-05-01. Hay una descripción del problema, una justificación de la gravedad y una tabla con el CVE, las referencias asociadas, la gravedad, los dispositivos de Google actualizados, las versiones actualizadas de AOSP (cuando corresponda) y la fecha en que se informó. Cuando esté disponible, vincularemos el cambio público que abordó el problema con el ID del error, como la lista de cambios de AOSP. Cuando varios cambios se relacionan con un solo error, las referencias adicionales se vinculan a los números que siguen al ID del error.

Vulnerabilidad de ejecución remota de código en Mediaserver

Una vulnerabilidad de ejecución remota de código en Mediaserver podría permitir que un atacante use un archivo especialmente diseñado para causar daños en la memoria durante el procesamiento de datos y archivos multimedia. Este problema se clasifica como Crítico debido a la posibilidad de ejecución remota de código en el contexto del proceso Mediaserver.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0587 A-35219737 Crítico Todos 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 4 de enero de 2017
CVE-2017-0588 A-34618607 Crítico Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 21 de enero de 2017
CVE-2017-0589 A-34897036 Crítico Todos 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 1 de febrero de 2017
CVE-2017-0590 A-35039946 Crítico Todos 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 6 de febrero de 2017
CVE-2017-0591 A-34097672 Crítico Todos 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 interno de Google
CVE-2017-0592 A-34970788 Crítico Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 interno de Google

Vulnerabilidad de elevación de privilegios en las API de Framework

Una vulnerabilidad de elevación de privilegios en las API de Framework podría permitir que una aplicación local malintencionada obtenga acceso a permisos personalizados. Este problema se clasifica como Alto porque es una omisión general para las protecciones del sistema operativo que aíslan los datos de la aplicación de otras aplicaciones.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0593 A-34114230 Alto Todos 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 5 de enero de 2017

Vulnerabilidad de elevación de privilegios en Mediaserver

Una vulnerabilidad de elevación de privilegios en Mediaserver podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto de un proceso privilegiado. Este problema se califica como Alto porque podría usarse para obtener acceso local a capacidades elevadas, que normalmente no son accesibles para una aplicación de terceros.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0594 A-34617444 Alto Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 22 de enero de 2017
CVE-2017-0595 A-34705519 Alto Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 24 de enero de 2017
CVE-2017-0596 A-34749392 Alto Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 24 de enero de 2017

Vulnerabilidad de elevación de privilegios en Audioserver

Una vulnerabilidad de elevación de privilegios en Audioserver podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto de un proceso privilegiado. Este problema se califica como Alto porque podría usarse para obtener acceso local a capacidades elevadas, que normalmente no son accesibles para una aplicación de terceros.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0597 A-34749571 Alto Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 25 de enero de 2017

Vulnerabilidad de divulgación de información en las API de Framework

Una vulnerabilidad de divulgación de información en las API de Framework podría permitir que una aplicación maliciosa local eluda las protecciones del sistema operativo que aíslan los datos de la aplicación de otras aplicaciones. Este problema se califica como Alto porque podría usarse para obtener acceso a datos a los que la aplicación no tiene acceso.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0598 A-34128677 [ 2 ] Alto Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 6 de enero de 2017

Vulnerabilidad de denegación de servicio en Mediaserver

Una vulnerabilidad de denegación de servicio remota en Mediaserver podría permitir que un atacante use un archivo especialmente diseñado para provocar que el dispositivo se cuelgue o se reinicie. Este problema tiene una gravedad alta debido a la posibilidad de una denegación de servicio remota.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0599 A-34672748 Alto Todos 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 23 de enero de 2017
CVE-2017-0600 A-35269635 Alto Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 10 de febrero de 2017

Vulnerabilidad de elevación de privilegios en Bluetooth

Una vulnerabilidad de Elevación de privilegios en Bluetooth podría permitir que una aplicación local maliciosa acepte archivos dañinos compartidos a través de Bluetooth sin el permiso del usuario. Este problema se clasifica como Moderado debido a la omisión local de los requisitos de interacción del usuario.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0601 A-35258579 Moderado Todos 7.0, 7.1.1, 7.1.2 9 de febrero de 2017

Vulnerabilidad de divulgación de información en el cifrado basado en archivos

Una vulnerabilidad de divulgación de información en el cifrado basado en archivos podría permitir que un atacante local malicioso eluda las protecciones del sistema operativo para la pantalla de bloqueo. Este problema se clasifica como Moderado debido a la posibilidad de omitir la pantalla de bloqueo.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0493 A-32793550 [ 2 ] [ 3 ] Moderado Todos 7.0, 7.1.1 9 de noviembre de 2016

Vulnerabilidad de divulgación de información en Bluetooth

Una vulnerabilidad de divulgación de información en Bluetooth podría permitir que una aplicación maliciosa local eluda las protecciones del sistema operativo que aíslan los datos de la aplicación de otras aplicaciones. Este problema se clasifica como moderado debido a los detalles específicos de la vulnerabilidad.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0602 A-34946955 Moderado Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 5 de diciembre de 2016

Vulnerabilidad de divulgación de información en OpenSSL y BoringSSL

Una vulnerabilidad de divulgación de información en OpenSSL y BoringSSL podría permitir que un atacante remoto obtenga acceso a información confidencial. Este problema se clasifica como moderado debido a los detalles específicos de la vulnerabilidad.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2016-7056 A-33752052 Moderado Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 19 de diciembre de 2016

Vulnerabilidad de denegación de servicio en Mediaserver

Una vulnerabilidad de denegación de servicio en Mediaserver podría permitir que un atacante use un archivo especialmente diseñado para provocar que el dispositivo se cuelgue o se reinicie. Este problema se clasifica como Moderado porque requiere una configuración de dispositivo poco común.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0603 A-35763994 Moderado Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 23 de febrero de 2017

Vulnerabilidad de denegación de servicio en Mediaserver

Una vulnerabilidad de denegación de servicio remota en Mediaserver podría permitir que un atacante use un archivo especialmente diseñado para provocar que el dispositivo se cuelgue o se reinicie. Este problema se clasifica como Bajo debido a los detalles específicos de la vulnerabilidad.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0635 A-35467107 Bajo Todos 7.0, 7.1.1, 7.1.2 16 de febrero de 2017

2017-05-05 nivel de parche de seguridad-Detalles de vulnerabilidad

En las secciones a continuación, proporcionamos detalles para cada una de las vulnerabilidades de seguridad que se aplican al nivel de parche 2017-05-05. Hay una descripción del problema, una justificación de la gravedad y una tabla con el CVE, las referencias asociadas, la gravedad, los dispositivos de Google actualizados, las versiones actualizadas de AOSP (cuando corresponda) y la fecha en que se informó. Cuando esté disponible, vincularemos el cambio público que abordó el problema con el ID del error, como la lista de cambios de AOSP. Cuando varios cambios se relacionan con un solo error, las referencias adicionales se vinculan a los números que siguen al ID del error.

Vulnerabilidad de ejecución remota de código en GIFLIB

Una vulnerabilidad de ejecución remota de código en GIFLIB podría permitir que un atacante use un archivo especialmente diseñado para causar daños en la memoria durante el procesamiento de datos y archivos multimedia. Este problema se clasifica como Crítico debido a la posibilidad de ejecución remota de código en el contexto del proceso Mediaserver.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2015-7555 A-34697653 Crítico Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 13 de abril de 2016

Vulnerabilidad de elevación de privilegios en el controlador de pantalla táctil de MediaTek

Una vulnerabilidad de elevación de privilegios en el controlador de pantalla táctil de MediaTek podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-10274 A-30202412*
M-ALPS02897901
Crítico Ninguna** 16 de julio de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

** Los dispositivos de Google compatibles con Android 7.1.1 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidad de elevación de privilegios en el gestor de arranque de Qualcomm

Una vulnerabilidad de elevación de privilegios en el gestor de arranque de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-10275 A-34514954
QC-CR#1009111
Crítico Nexus 5X, Nexus 6, Píxel, Píxel XL, Android Uno 13 de septiembre de 2016
CVE-2016-10276 A-32952839
QC-CR#1094105
Crítico Nexus 5X, Nexus 6P, Píxel, Píxel XL 16 de noviembre de 2016

Vulnerabilidad de elevación de privilegios en el subsistema de sonido del kernel

Una vulnerabilidad de elevación de privilegios en el subsistema de sonido del kernel podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-9794 A-34068036
Núcleo ascendente
Crítico Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Píxel, Píxel XL, Píxel C, Android One, Nexus Player 3 de diciembre de 2016

Vulnerabilidad de elevación de privilegios en el gestor de arranque de Motorola

Una vulnerabilidad de elevación de privilegios en el gestor de arranque de Motorola podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del gestor de arranque. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-10277 A-33840490*
Crítico nexo 6 21 de diciembre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en el controlador de video NVIDIA

Una vulnerabilidad de elevación de privilegios en el controlador de video de NVIDIA podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0331 A-34113000*
N-CVE-2017-0331
Crítico nexo 9 4 de enero de 2017

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en el controlador de potencia de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador de potencia Qualcomm del kernel podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0604 A-35392981
QC-CR#826589
Crítico Ninguna* 15 de febrero de 2017

* Los dispositivos de Google compatibles con Android 7.1.1 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidades en los componentes de Qualcomm

Estas vulnerabilidades afectan a los componentes de Qualcomm y se describen con más detalle en los boletines de seguridad de Qualcomm AMSS de agosto, septiembre, octubre y diciembre de 2016.

CVE Referencias Gravedad* Dispositivos de Google actualizados Fecha reportada
CVE-2016-10240 A-32578446**
QC-CR#955710
Crítico Nexo 6P Qualcomm interno
CVE-2016-10241 A-35436149**
QC-CR#1068577
Crítico Nexus 5X, Nexus 6, Nexus 6P, Píxel, Píxel XL Qualcomm interno
CVE-2016-10278 A-31624008**
QC-CR#1043004
Alto Píxel, Píxel XL Qualcomm interno
CVE-2016-10279 A-31624421**
QC-CR#1031821
Alto Píxel, Píxel XL Qualcomm interno

* El proveedor determinó la clasificación de gravedad de estas vulnerabilidades.

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de ejecución remota de código en libxml2

Una vulnerabilidad de ejecución remota de código en libxml2 podría permitir que un atacante use un archivo especialmente diseñado para ejecutar código arbitrario dentro del contexto de un proceso sin privilegios. Este problema se califica como alto debido a la posibilidad de ejecución remota de código en una aplicación que usa esta biblioteca.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2016-5131 A-32956747* Alto Ninguna** 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 23 de julio de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

** Los dispositivos de Google compatibles con Android 7.1.1 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidad de elevación de privilegios en el controlador térmico de MediaTek

Una vulnerabilidad de elevación de privilegios en el controlador térmico de MediaTek podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-10280 A-28175767*
M-ALPS02696445
Alto Ninguna** 11 de abril de 2016
CVE-2016-10281 A-28175647*
M-ALPS02696475
Alto Ninguna** 11 de abril de 2016
CVE-2016-10282 A-33939045*
M-ALPS03149189
Alto Ninguna** 27 de diciembre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

** Los dispositivos de Google compatibles con Android 7.1.1 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidad de elevación de privilegios en el controlador Wi-Fi de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador Wi-Fi de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-10283 A-32094986
QC-CR#2002052
Alto Nexus 5X, Píxel, Píxel XL, Android Uno 11 de octubre de 2016

Vulnerabilidad de elevación de privilegios en el controlador de video de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador de video de Qualcomm podría permitir que una aplicación maliciosa local ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-10284 A-32402303*
QC-CR#2000664
Alto Nexus 5X, Nexus 6, Nexus 6P, Píxel, Píxel XL, Android Uno 24 de octubre de 2016
CVE-2016-10285 A-33752702
QC-CR#1104899
Alto Píxel, Píxel XL 19 de diciembre de 2016
CVE-2016-10286 A-35400904
QC-CR#1090237
Alto Píxel, Píxel XL 15 de febrero de 2017

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en el subsistema de rendimiento del kernel

Una vulnerabilidad de elevación de privilegios en el subsistema de rendimiento del kernel podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2015-9004 A-34515362
Núcleo ascendente
Alto Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Píxel, Píxel XL, Píxel C, Android One, Nexus Player 23 de noviembre de 2016

Vulnerabilidad de elevación de privilegios en el controlador de sonido de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador de sonido de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-10287 A-33784446
QC-CR#1112751
Alto Nexus 5X, Nexus 6P, Píxel, Píxel XL, Android Uno 20 de diciembre de 2016
CVE-2017-0606 A-34088848
QC-CR#1116015
Alto Nexus 5X, Nexus 6P, Píxel, Píxel XL, Android Uno 3 de enero de 2017
CVE-2016-5860 A-34623424
QC-CR#1100682
Alto Píxel, Píxel XL 22 de enero de 2017
CVE-2016-5867 A-35400602
QC-CR#1095947
Alto Ninguna* 15 de febrero de 2017
CVE-2017-0607 A-35400551
QC-CR#1085928
Alto Píxel, Píxel XL 15 de febrero de 2017
CVE-2017-0608 A-35400458
QC-CR#1098363
Alto Nexus 5X, Nexus 6, Nexus 6P, Píxel, Píxel XL, Android Uno 15 de febrero de 2017
CVE-2017-0609 A-35399801
QC-CR#1090482
Alto Nexus 5X, Nexus 6P, Píxel, Píxel XL, Android Uno 15 de febrero de 2017
CVE-2016-5859 A-35399758
QC-CR#1096672
Alto Ninguna* 15 de febrero de 2017
CVE-2017-0610 A-35399404
QC-CR#1094852
Alto Nexus 5X, Nexus 6, Nexus 6P, Píxel, Píxel XL, Android Uno 15 de febrero de 2017
CVE-2017-0611 A-35393841
QC-CR#1084210
Alto Nexus 5X, Nexus 6, Nexus 6P, Píxel, Píxel XL, Android Uno 15 de febrero de 2017
CVE-2016-5853 A-35392629
QC-CR#1102987
Alto Ninguna* 15 de febrero de 2017

* Los dispositivos de Google compatibles con Android 7.1.1 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidad de elevación de privilegios en el controlador LED de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador LED de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-10288 A-33863909
QC-CR#1109763
Alto Píxel, Píxel XL 23 de diciembre de 2016

Vulnerabilidad de elevación de privilegios en el controlador criptográfico de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador criptográfico de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-10289 A-33899710
QC-CR#1116295
Alto Nexus 5X, Nexus 6, Nexus 6P, Píxel, Píxel XL, Android Uno 24 de diciembre de 2016

Vulnerabilidad de elevación de privilegios en el controlador de memoria compartida de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador de memoria compartida de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-10290 A-33898330
QC-CR#1109782
Alto Nexus 5X, Nexus 6P, Píxel, Píxel XL 24 de diciembre de 2016

Vulnerabilidad de elevación de privilegios en el controlador Qualcomm Slimbus

Una vulnerabilidad de elevación de privilegios en el controlador Qualcomm Slimbus podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-10291 A-34030871
QC-CR#986837
Alto Nexus 5X, Nexus 6, Nexus 6P, Android Uno 31 de diciembre de 2016

Vulnerabilidad de elevación de privilegios en el controlador Qualcomm ADSPRPC

Una vulnerabilidad de elevación de privilegios en el controlador Qualcomm ADSPRPC podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0465 A-34112914
QC-CR#1110747
Alto Nexus 5X, Nexus 6P, Píxel, Píxel XL, Android Uno 5 de enero de 2017

Vulnerabilidad de elevación de privilegios en el controlador Qualcomm Secure Execution Environment Communicator

Una vulnerabilidad de elevación de privilegios en el controlador Qualcomm Secure Execution Environment Communicator podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0612 A-34389303
QC-CR#1061845
Alto Píxel, Píxel XL 10 de enero de 2017
CVE-2017-0613 A-35400457
QC-CR#1086140
Alto Nexus 5X, Nexus 6, Nexus 6P, Píxel, Píxel XL, Android Uno 15 de febrero de 2017
CVE-2017-0614 A-35399405
QC-CR#1080290
Alto Nexus 5X, Nexus 6, Nexus 6P, Píxel, Píxel XL, Android Uno 15 de febrero de 2017

Vulnerabilidad de elevación de privilegios en el controlador de potencia de MediaTek

Una vulnerabilidad de elevación de privilegios en el controlador de energía de MediaTek podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0615 A-34259126*
M-ALPS03150278
Alto Ninguna** 12 de enero de 2017

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

** Los dispositivos de Google compatibles con Android 7.1.1 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidad de elevación de privilegios en el controlador de interrupción de administración del sistema MediaTek

Una vulnerabilidad de elevación de privilegios en el controlador de interrupción de administración del sistema MediaTek podría permitir que una aplicación maliciosa local ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0616 A-34470286*
M-ALPS03149160
Alto Ninguna** 19 de enero de 2017

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

** Los dispositivos de Google compatibles con Android 7.1.1 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidad de elevación de privilegios en el controlador de video MediaTek

Una vulnerabilidad de elevación de privilegios en el controlador de video MediaTek podría permitir que una aplicación maliciosa local ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0617 A-34471002*
M-ALPS03149173
Alto Ninguna** 19 de enero de 2017

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

** Los dispositivos de Google compatibles con Android 7.1.1 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidad de elevación de privilegios en el controlador de cola de comandos de MediaTek

Una vulnerabilidad de elevación de privilegios en el controlador de la cola de comandos de MediaTek podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0618 A-35100728*
M-ALPS03161536
Alto Ninguna** 7 de febrero de 2017

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

** Los dispositivos de Google compatibles con Android 7.1.1 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidad de elevación de privilegios en el controlador de pin de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador de pines de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0619 A-35401152
QC-CR#826566
Alto Nexus 6, Android Uno 15 de febrero de 2017

Vulnerabilidad de elevación de privilegios en el controlador Qualcomm Secure Channel Manager

Una vulnerabilidad de elevación de privilegios en el controlador Qualcomm Secure Channel Manager podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0620 A-35401052
QC-CR#1081711
Alto Nexus 5X, Nexus 6, Nexus 6P, Píxel, Píxel XL, Android Uno 15 de febrero de 2017

Vulnerabilidad de elevación de privilegios en el controlador de códec de sonido de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador de códec de sonido de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-5862 A-35399803
QC-CR#1099607
Alto Píxel, Píxel XL 15 de febrero de 2017

Vulnerabilidad de elevación de privilegios en el controlador del regulador de voltaje del kernel

Una vulnerabilidad de elevación de privilegios en el controlador del regulador de voltaje del kernel podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2014-9940 A-35399757
Núcleo ascendente
Alto Nexus 6, Nexus 9, Píxel C, Android One, Nexus Player 15 de febrero de 2017

Vulnerabilidad de elevación de privilegios en el controlador de la cámara Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador de la cámara Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0621 A-35399703
QC-CR#831322
Alto androide uno 15 de febrero de 2017

Vulnerabilidad de elevación de privilegios en el controlador de red de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador de red de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-5868 A-35392791
QC-CR#1104431
Alto Nexus 5X, píxel, píxel XL 15 de febrero de 2017

Vulnerabilidad de elevación de privilegios en el subsistema de red del kernel

Una vulnerabilidad de elevación de privilegios en el subsistema de red del kernel podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-7184 A-36565222
Núcleo ascendente [2]
Alto Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Píxel, Píxel XL, Android One 23 de marzo de 2017

Elevation of privilege vulnerability in Goodix touchscreen driver

An elevation of privilege vulnerability in the Goodix touchscreen driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2017-0622 A-32749036
QC-CR#1098602
Alto Android One Google internal

Elevation of privilege vulnerability in HTC bootloader

An elevation of privilege vulnerability in the HTC bootloader could enable a local malicious application to execute arbitrary code within the context of the bootloader. This issue is rated as High because it first requires compromising a privileged process.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2017-0623 A-32512358*
Alto Pixel, Pixel XL Google Internal

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm Wi-Fi driver

An information disclosure vulnerability in the Qualcomm Wi-Fi driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2017-0624 A-34327795*
QC-CR#2005832
Alto Nexus 5X, Pixel, Pixel XL Jan 16, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in MediaTek command queue driver

An information disclosure vulnerability in the MediaTek command queue driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2017-0625 A-35142799*
M-ALPS03161531
Alto None** Feb 8, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.1.1 or later that have installed all available updates are not affected by this vulnerability.

Information disclosure vulnerability in Qualcomm crypto engine driver

An information disclosure vulnerability in the Qualcomm crypto engine driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2017-0626 A-35393124
QC-CR#1088050
Alto Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Feb 15, 2017

Denial of service vulnerability in Qualcomm Wi-Fi driver

A denial of service vulnerability in the Qualcomm Wi-Fi driver could enable a proximate attacker to cause a denial of service in the Wi-Fi subsystem. This issue is rated as High due to the possibility of remote denial of service.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2016-10292 A-34514463*
QC-CR#1065466
Alto Nexus 5X, Pixel, Pixel XL Dec 16, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in kernel UVC driver

An information disclosure vulnerability in the kernel UVC driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2017-0627 A-33300353*
Moderado Nexus 5X, Nexus 6P, Nexus 9, Pixel C, Nexus Player Dec 2, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm video driver

An information disclosure vulnerability in the Qualcomm video driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2016-10293 A-33352393
QC-CR#1101943
Moderado Nexus 5X, Nexus 6P, Android One Dec 4, 2016

Information disclosure vulnerability in Qualcomm power driver (device specific)

An information disclosure vulnerability in the Qualcomm power driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2016-10294 A-33621829
QC-CR#1105481
Moderado Nexus 5X, Nexus 6P, Pixel, Pixel XL Dec 14, 2016

Information disclosure vulnerability in Qualcomm LED driver

An information disclosure vulnerability in the Qualcomm LED driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2016-10295 A-33781694
QC-CR#1109326
Moderado Pixel, Pixel XL Dec 20, 2016

Information disclosure vulnerability in Qualcomm shared memory driver

An information disclosure vulnerability in the Qualcomm shared memory driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2016-10296 A-33845464
QC-CR#1109782
Moderado Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One Dec 22, 2016

Information disclosure vulnerability in Qualcomm camera driver

An information disclosure vulnerability in the Qualcomm camera driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2017-0628 A-34230377
QC-CR#1086833
Moderado Nexus 5X, Nexus 6, Pixel, Pixel XL Jan 10, 2017
CVE-2017-0629 A-35214296
QC-CR#1086833
Moderado Nexus 5X, Nexus 6, Pixel, Pixel XL Feb 8, 2017

Information disclosure vulnerability in kernel trace subsystem

An information disclosure vulnerability in the kernel trace subsystem could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2017-0630 A-34277115*
Moderado Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Android One, Nexus Player Jan 11, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm sound codec driver

An information disclosure vulnerability in the Qualcomm sound codec driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2016-5858 A-35400153
QC-CR#1096799 [2]
Moderado Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Feb 15, 2017

Information disclosure vulnerability in Qualcomm camera driver

An information disclosure vulnerability in the Qualcomm camera driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2017-0631 A-35399756
QC-CR#1093232
Moderado Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One Feb 15, 2017

Information disclosure vulnerability in Qualcomm sound driver

An information disclosure vulnerability in the Qualcomm sound driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2016-5347 A-35394329
QC-CR#1100878
Moderado Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Feb 15, 2017

Information disclosure vulnerability in Qualcomm SPCom driver

An information disclosure vulnerability in the Qualcomm SPCom driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2016-5854 A-35392792
QC-CR#1092683
Moderado None* Feb 15, 2017
CVE-2016-5855 A-35393081
QC-CR#1094143
Moderado None* Feb 15, 2017

* Supported Google devices on Android 7.1.1 or later that have installed all available updates are not affected by this vulnerability.

Information disclosure vulnerability in Qualcomm sound codec driver

An information disclosure vulnerability in the Qualcomm sound codec driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2017-0632 A-35392586
QC-CR#832915
Moderado Android One Feb 15, 2017

Information disclosure vulnerability in Broadcom Wi-Fi driver

An information disclosure vulnerability in the Broadcom Wi-Fi driver could enable a local malicious component to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2017-0633 A-36000515*
B-RB#117131
Moderado Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Feb 23, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Synaptics touchscreen driver

An information disclosure vulnerability in the Synaptics touchscreen driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE Referencias Gravedad Updated Google devices Date reported
CVE-2017-0634 A-32511682*
Moderado Pixel, Pixel XL Google internal

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Vulnerabilities in Qualcomm components

These vulnerabilities affecting Qualcomm components were released as part of Qualcomm AMSS security bulletins between 2014–2016. They are included in this Android security bulletin to associate their fixes with an Android security patch level.

CVE Referencias Severity* Updated Google devices Date reported
CVE-2014-9923 A-35434045** Crítico None*** Qualcomm internal
CVE-2014-9924 A-35434631** Crítico None*** Qualcomm internal
CVE-2014-9925 A-35444657** Crítico None*** Qualcomm internal
CVE-2014-9926 A-35433784** Crítico None*** Qualcomm internal
CVE-2014-9927 A-35433785** Crítico None*** Qualcomm internal
CVE-2014-9928 A-35438623** Crítico None*** Qualcomm internal
CVE-2014-9929 A-35443954**
QC-CR#644783
Crítico None*** Qualcomm internal
CVE-2014-9930 A-35432946** Crítico None*** Qualcomm internal
CVE-2015-9005 A-36393500** Crítico None*** Qualcomm internal
CVE-2015-9006 A-36393450** Crítico None*** Qualcomm internal
CVE-2015-9007 A-36393700** Crítico None*** Qualcomm internal
CVE-2016-10297 A-36393451** Crítico None*** Qualcomm internal
CVE-2014-9941 A-36385125** Alto None*** Qualcomm internal
CVE-2014-9942 A-36385319** Alto None*** Qualcomm internal
CVE-2014-9943 A-36385219** Alto None*** Qualcomm internal
CVE-2014-9944 A-36384534** Alto None*** Qualcomm internal
CVE-2014-9945 A-36386912** Alto None*** Qualcomm internal
CVE-2014-9946 A-36385281** Alto None*** Qualcomm internal
CVE-2014-9947 A-36392400** Alto None*** Qualcomm internal
CVE-2014-9948 A-36385126** Alto None*** Qualcomm internal
CVE-2014-9949 A-36390608** Alto None*** Qualcomm internal
CVE-2014-9950 A-36385321** Alto None*** Qualcomm internal
CVE-2014-9951 A-36389161** Alto None*** Qualcomm internal
CVE-2014-9952 A-36387019** Alto None*** Qualcomm internal

* The severity rating for these vulnerabilities was determined by the vendor.

** The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

*** Supported Google devices on Android 7.1.1 or later that have installed all available updates are not affected by this vulnerability.

Common Questions and Answers

Esta sección responde preguntas comunes que pueden surgir después de leer este boletín.

1. ¿Cómo puedo determinar si mi dispositivo está actualizado para solucionar estos problemas?

To learn how to check a device's security patch level, read the instructions on the Pixel and Nexus update schedule .

  • Security patch levels of 2017-05-01 or later address all issues associated with the 2017-05-01 security patch level.
  • Security patch levels of 2017-05-05 or later address all issues associated with the 2017-05-05 security patch level and all previous patch levels.

Los fabricantes de dispositivos que incluyen estas actualizaciones deben establecer el nivel de la cadena de parches en:

  • [ro.build.version.security_patch]:[2017-05-01]
  • [ro.build.version.security_patch]:[2017-05-05]

2. ¿Por qué este boletín tiene dos niveles de parches de seguridad?

Este boletín tiene dos niveles de parches de seguridad para que los socios de Android tengan la flexibilidad de corregir un subconjunto de vulnerabilidades que son similares en todos los dispositivos Android con mayor rapidez. Se recomienda a los socios de Android que solucionen todos los problemas de este boletín y utilicen el nivel de parche de seguridad más reciente.

  • Devices that use the May 01, 2017 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins.
  • Devices that use the security patch level of May 05, 2017 or newer must include all applicable patches in this (and previous) security bulletins.

Se alienta a los socios a agrupar las soluciones para todos los problemas que están solucionando en una sola actualización.

3. How do I determine which Google devices are affected by each issue?

In the 2017-05-01 and 2017-05-05 security vulnerability details sections, each table has an Updated Google devices column that covers the range of affected Google devices updated for each issue. This column has a few options:

  • All Google devices : If an issue affects All and Pixel devices, the table will have "All" in the Updated Google devices column. "All" encapsulates the following supported devices : Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel, and Pixel XL.
  • Some Google devices : If an issue doesn't affect all Google devices, the affected Google devices are listed in the Updated Google devices column.
  • No Google devices : If no Google devices running Android 7.0 are affected by the issue, the table will have "None" in the Updated Google devices column.

4. What do the entries in the references column map to?

Las entradas en la columna Referencias de la tabla de detalles de vulnerabilidad pueden contener un prefijo que identifique la organización a la que pertenece el valor de referencia. These prefixes map as follows:

Prefijo Referencia
A- ID de error de Android
QC- Número de referencia de Qualcomm
METRO- Número de referencia de MediaTek
NORTE- Número de referencia de NVIDIA
B- Número de referencia de Broadcom

Revisions

  • May 01, 2017: Bulletin published.
  • May 02, 2017: Bulletin revised to include AOSP links.
  • August 10, 2017: Bulletin revised to include additional AOSP link for CVE-2017-0493.
  • August 17, 2017: Bulletin revised to update reference numbers.
  • October 03, 2017: Bulletin revised to remove CVE-2017-0605.