Android 보안 게시판—2017년 10월

2017년 10월 2일 게시됨

Android 보안 게시판에서는 Android 기기에 영향을 미치는 보안 취약성 세부정보를 다룹니다. 아래 목록의 문제는 2017년 10월 5일 보안 패치 수준 이상에서 모두 해결되었습니다. 기기의 보안 패치 수준을 확인하는 방법은 Android 버전 확인 및 업데이트를 참조하세요.

Android 파트너에게는 게시되기 최소 한 달 전에 모든 문제 관련 알림이 전달되었습니다. 이러한 문제의 해결을 위한 소스 코드 패치는 향후 48시간 동안 Android 오픈소스 프로젝트(AOSP) 저장소에 배포됩니다. 패치를 사용할 수 있게 되면 AOSP 링크와 함께 이 게시판을 수정하겠습니다.

이러한 문제 중 가장 심각한 것은 미디어 프레임워크의 심각한 심각도 취약성으로, 특별히 제작된 파일을 사용하는 원격 공격자가 권한이 설정된 프로세스의 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다. 심각도 평가는 개발 목적으로 플랫폼 및 서비스 완화를 사용할 수 없는 경우, 또는 우회에 성공한 경우 취약성 악용으로 인해 대상 기기가 받는 영향을 기준으로 합니다.

실제 고객이 새로 보고된 이러한 문제로 인해 악용당했다는 신고는 접수되지 않았습니다. Android 플랫폼의 보안을 개선하는 Android 보안 플랫폼 보호 및 Google Play 프로텍트에 관해 자세히 알아보려면 Android 및 Google Play 프로텍트 완화 섹션을 참조하세요.

모든 고객은 기기에서 이 업데이트를 수락하는 것이 좋습니다.

참고: Google 기기의 최신 무선 업데이트(OTA) 및 펌웨어 이미지 관련 정보는 2017년 10월 Pixel / Nexus 보안 게시판을 참조하세요.

공지사항

  • Google에서는 새로운 월간 Pixel / Nexus 보안 게시판을 출시했으며 여기에는 Pixel 및 Nexus 기기에서 해결된 추가적인 보안 취약성 및 기능 개선 관련 정보가 포함되어 있습니다. Android 기기 제조업체는 해당 문제를 기기에서 해결하도록 선택할 수 있습니다. 자세한 내용은 일반적인 질문 및 답변을 참조하세요.
  • 보안 게시판의 감사의 말씀은 Android 보안 감사의 말씀 페이지에 직접 표시되어 있습니다.

Android 및 Google 서비스 완화

다음은 Android 보안 플랫폼Google Play 프로텍트와 같은 서비스 보호 기능에서 제공하는 완화에 관한 요약입니다. 이러한 기능을 통해 Android에서 보안 취약성이 악용될 가능성을 줄입니다.

  • Android 플랫폼 최신 버전의 향상된 기능으로 Android의 여러 문제를 악용하기 더욱 어려워졌습니다. 가능하다면 모든 사용자는 최신 버전의 Android로 업데이트하는 것이 좋습니다.
  • Android 보안팀에서는 Google Play 프로텍트를 통해 악용사례를 적극적으로 모니터링하고 유해할 수 있는 애플리케이션에 관해 사용자에게 경고를 보냅니다. Google Play 프로텍트는 Google 모바일 서비스가 적용된 기기에 기본적으로 사용 설정되어 있으며 Google Play 외부의 앱을 설치하는 사용자에게 특히 중요합니다.

2017-10-01 보안 패치 수준—취약성 세부정보

다음 섹션에서는 2017-10-01 패치 수준에 적용되는 각 보안 취약성에 관해 자세히 알아볼 수 있습니다. 취약성은 영향을 받는 구성요소 아래에 분류되어 있습니다. 여기에는 문제 설명 및 CVE, 관련 참조, 취약성 유형, 심각도, 업데이트된 AOSP 버전(해당하는 경우)이 포함된 표가 제시됩니다. 가능한 경우 AOSP 변경사항 목록과 같이 문제를 해결한 공개 변경사항을 버그 ID에 연결합니다. 하나의 버그와 관련된 변경사항이 여러 개인 경우 추가 참조가 버그 ID 다음에 오는 번호에 연결됩니다.

프레임워크

이 섹션에서 가장 심각한 취약성으로 인해 로컬 악성 애플리케이션이 사용자 상호작용 요구사항을 우회하여 추가적인 권한에 액세스할 수 있습니다.

CVE 참조 형식 심각도 업데이트된 AOSP 버전
CVE-2017-0806 A-62998805 EoP 높음 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0

미디어 프레임워크

이 섹션의 가장 심각한 취약성으로 인해 특별히 제작된 파일을 사용하는 원격 공격자가 권한이 설정된 프로세스의 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다.

CVE 참조 형식 심각도 업데이트된 AOSP 버전
CVE-2017-0809 A-62673128 RCE 심각 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0810 A-38207066 RCE 심각 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0811 A-37930177 RCE 심각 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0812 A-62873231 EoP 높음 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0815 A-63526567 ID 보통 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0816 A-63662938 ID 보통 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0

시스템

이 섹션의 가장 심각한 취약성으로 인해 인접한 공격자가 권한이 설정된 프로세스의 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다.

CVE 참조 형식 심각도 업데이트된 AOSP 버전
CVE-2017-14496 A-64575136 RCE 높음 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0

2017-10-05 보안 패치 수준—취약성 세부정보

다음 섹션에서는 2017-10-05 패치 수준에 적용되는 각 보안 취약성에 관해 자세히 알아볼 수 있습니다. 취약성은 영향을 받는 구성요소 아래에 분류되어 있으며 CVE, 관련 참조, 취약성 유형, 심각도, 구성요소(해당하는 경우), 업데이트된 AOSP 버전(해당하는 경우)과 같은 세부정보가 포함되어 있습니다. 가능한 경우 AOSP 변경사항 목록과 같이 문제를 해결한 공개 변경사항을 버그 ID에 연결합니다. 하나의 버그와 관련된 변경사항이 여러 개인 경우 추가 참조가 버그 ID 다음에 오는 번호에 연결됩니다.

커널 구성요소

이 섹션의 가장 심각한 취약성으로 인해 로컬 악성 애플리케이션이 권한이 설정된 프로세스 내에서 임의의 코드를 실행할 수 있습니다.

CVE 참조 형식 심각도 구성요소
CVE-2017-7374 A-37866910
업스트림 커널
EoP 높음 파일 시스템
CVE-2017-9075 A-62298712
업스트림 커널
EoP 높음 네트워크 하위 시스템

MediaTek 구성요소

이 섹션의 가장 심각한 취약성으로 인해 로컬 악성 애플리케이션이 권한이 설정된 프로세스 내에서 임의의 코드를 실행할 수 있습니다.

CVE 참조 형식 심각도 구성요소
CVE-2017-0827 A-62539960*
M-ALPS03353876
M-ALPS03353861
M-ALPS03353869
M-ALPS03353867
M-ALPS03353872
EoP 높음 SoC 드라이버

Qualcomm 구성요소

이 섹션의 가장 심각한 취약성으로 인해 특별히 제작된 파일을 사용하는 원격 공격자가 권한이 설정된 프로세스의 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다.

CVE 참조 형식 심각도 구성요소
CVE-2017-11053 A-36895857*
QC-CR#2061544
RCE 심각 SoC 드라이버
CVE-2017-9714 A-63868020
QC-CR#2046578
EoP 심각 네트워크 하위 시스템
CVE-2017-9683 A-62379105
QC-CR#2036397
EoP 높음 Linux 부팅

일반적인 질문 및 답변

이 섹션에서는 게시판을 읽은 뒤 제기될 수 있는 일반적인 질문에 대한 답변을 제시합니다.

1. 내 기기가 업데이트되어 이 문제가 해결되었는지 어떻게 알 수 있나요?

기기의 보안 패치 수준을 확인하는 방법은 Android 버전 확인 및 업데이트를 참조하세요.

  • 2017-09-01 보안 패치 수준과 관련된 모든 문제는 2017-10-01 보안 패치 수준 이상에서 해결되었습니다.
  • 2017-09-05 보안 패치 수준 및 그 이전의 모든 패치 수준과 관련된 모든 문제는 2017-10-05 보안 패치 수준 이상에서 해결되었습니다.

이러한 업데이트를 포함하는 기기 제조업체는 패치 문자열 수준을 다음과 같이 설정해야 합니다.

  • [ro.build.version.security_patch]:[2017-10-01]
  • [ro.build.version.security_patch]:[2017-10-05]

2. 이 게시판에 두 가지 보안 패치 수준이 있는 이유가 무엇인가요?

이 게시판에서는 Android 파트너가 모든 Android 기기에서 유사하게 발생하는 취약성 문제의 일부를 더욱 빠르고 유연하게 해결하도록 하기 위해 두 가지 보안 패치 수준이 포함되어 있습니다. Android 파트너는 이 게시판에 언급된 문제를 모두 수정하고 최신 보안 패치 수준을 사용하는 것이 좋습니다.

  • 2017-10-01 보안 패치 수준을 사용하는 기기는 이 보안 패치 수준과 관련된 모든 문제와 이전 보안 게시판에 보고된 모든 문제의 수정사항을 포함해야 합니다.
  • 2017-10-05 이후의 보안 패치 수준을 사용하는 기기는 이 보안 게시판과 이전 게시판의 모든 관련 패치를 포함해야 합니다.

파트너는 해결하는 모든 문제의 수정사항을 단 한 번의 업데이트에서 번들로 묶는 것이 좋습니다.

3. 유형 열의 항목은 무엇을 의미하나요?

취약성 세부정보 표의 유형 열에 있는 항목은 보안 취약성 분류를 참조합니다.

약어 정의
RCE 원격 코드 실행
EoP 권한 승격
ID 정보 공개
DoS 서비스 거부
해당 없음 분류 없음

4. 참조 열의 항목은 무엇을 의미하나요?

취약성 세부정보 표의 참조 열에 있는 항목은 참조 값이 속한 조직을 나타내는 접두어를 포함할 수 있습니다.

접두어 참조
A- Android 버그 ID
QC- Qualcomm 참조 번호
M- MediaTek 참조 번호
N- NVIDIA 참조 번호
B- Broadcom 참조 번호

5. 참조 열에서 Android 버그 ID 옆에 있는 * 표시는 무엇을 의미하나요?

공개되지 않은 문제는 참조 열의 Android 버그 ID 옆에 * 표시가 있습니다. 일반적으로 해당 문제의 업데이트는 Google 개발자 사이트에서 제공하는 Nexus 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

6. 보안 취약성이 이 게시판과 Pixel / Nexus 게시판과 같은 기기 / 파트너 보안 게시판에 나뉘어져 있는 이유가 무엇인가요?

이 보안 게시판에 설명되어 있는 보안 취약성은 Android 기기의 최신 보안 패치 수준을 선언하는 데 필요합니다. 기기 / 파트너 보안 게시판에 설명된 것과 같은 추가 보안 취약성은 보안 패치 수준을 선언하는 데 필요하지 않습니다. Android 기기 및 칩셋 제조업체는 삼성, LGE, Pixel / Nexus 보안 게시판과 같은 각 업체의 보안 웹사이트를 통해 기기의 다른 수정사항이 있는지를 설명하는 것이 좋습니다.

7 이 게시판에 관련된 감사의 말씀은 어디에서 확인할 수 있나요?

이 게시판 관련 감사의 말씀은 Android 보안 감사의 말씀 페이지에서 직접 확인할 수 있습니다.

버전

버전 날짜 메모
1.0 2017년 10월 2일 게시판이 게시됨