Android 보안 게시판—2018년 5월

2018년 5월 7일 게시됨 | 2018년 7월 11일 업데이트됨

Android 보안 게시판은 Android 기기에 영향을 미치는 보안 취약성 세부정보를 다룹니다. 2018-05-05 보안 패치 수준 이상에서 이러한 문제가 모두 해결되었습니다. 기기의 보안 패치 수준을 확인하는 방법을 알아보려면 Android 버전 확인 및 업데이트를 참조하세요.

Android 파트너에게는 게시되기 최소 한 달 전에 모든 문제 관련 알림이 전달되었습니다. 이러한 문제를 해결하기 위한 소스 코드 패치는 Android 오픈소스 프로젝트(AOSP) 저장소에 배포되었으며 이 게시판에도 링크되어 있습니다. 이 게시판에는 AOSP 외부의 패치 링크도 포함되어 있습니다.

이러한 문제 중 가장 심각한 것은 미디어 프레임워크의 심각한 보안 취약성으로, 특별히 제작된 파일을 사용하는 원격 공격자가 권한이 설정된 프로세스의 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다. 심각도 평가는 개발 목적으로 플랫폼 및 서비스 완화를 사용할 수 없거나 우회에 성공한 경우 취약성 악용으로 인해 대상 기기가 받는 영향을 기준으로 합니다.

실제 고객이 새로 보고된 이러한 문제로 인해 악용당했다는 신고는 접수되지 않았습니다. Android 플랫폼의 보안을 개선하는 Android 보안 플랫폼 보호 및 Google Play 프로텍트에 관해 자세히 알아보려면 Android 및 Google Play 프로텍트 완화 섹션을 참조하세요.

참고: Google 기기의 최신 무선 업데이트(OTA) 및 펌웨어 이미지 관련 정보는 2018년 5월 Pixel / Nexus 보안 게시판을 참조하세요.

Android 및 Google 서비스 완화

다음은 Google Play 프로텍트와 같은 Android 보안 플랫폼 및 서비스 보호 기능에서 제공하는 완화에 관한 요약입니다. 이러한 기능을 통해 Android에서 보안 취약성이 악용될 가능성을 줄입니다.

  • Android 플랫폼 최신 버전의 향상된 기능으로 Android의 여러 문제를 악용하기가 더욱 어려워졌습니다. 가능하다면 모든 사용자는 최신 버전의 Android로 업데이트하는 것이 좋습니다.
  • Android 보안팀에서는 Google Play 프로텍트를 통해 악용사례를 모니터링하고 잠재적으로 위험한 애플리케이션에 관해 사용자에게 경고를 보냅니다. Google Play 프로텍트는 Google 모바일 서비스가 적용된 기기에 기본적으로 사용 설정되어 있으며 Google Play 외부에서 가져온 앱을 설치하는 사용자에게 특히 중요합니다.

2018-05-01 보안 패치 수준 취약성 세부정보

다음 섹션에서는 2018-05-01 패치 수준에 적용되는 각 보안 취약성에 관해 자세히 알아볼 수 있습니다. 취약성은 영향을 받는 구성요소 아래에 분류되어 있습니다. 여기에는 문제 설명 및 CVE, 관련 참조, 취약성 유형, 심각도, 업데이트된 AOSP 버전(해당하는 경우)이 포함된 표가 제시됩니다. 가능한 경우 AOSP 변경사항 목록과 같이 문제를 해결한 공개 변경사항을 버그 ID에 연결합니다. 하나의 버그와 관련된 변경사항이 여러 개인 경우 추가 참조가 버그 ID 다음에 오는 번호에 연결됩니다.

Android 런타임

이 섹션의 가장 심각한 취약성으로 인해 원래는 권한을 갖고 있으며 로컬에 설치한 애플리케이션만 액세스할 수 있는 데이터에 원격 공격자가 액세스하도록 할 수 있습니다.

CVE 참조 유형 심각도 업데이트된 AOSP 버전
CVE-2017-13309 A-73251618 ID 높음 8.1

프레임워크

이 섹션에서 가장 심각한 취약성으로 인해 로컬 악성 애플리케이션이 사용자 상호작용 요구사항을 우회하여 추가적인 권한에 액세스할 수 있습니다.

CVE 참조 유형 심각도 업데이트된 AOSP 버전
CVE-2017-13310 A-71992105 EoP 높음 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2017-13311 A-73252178 EoP 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1

미디어 프레임워크

이 섹션에서 가장 심각한 취약성으로 인해 로컬 악성 애플리케이션이 사용자 상호작용 요구사항을 우회하여 추가적인 권한에 액세스할 수 있습니다.

CVE 참조 유형 심각도 업데이트된 AOSP 버전
CVE-2017-13312 A-73085795* EoP 높음 8.0
CVE-2017-13313 A-74114680 DoS 높음 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1

시스템

이 섹션에서 가장 심각한 취약성으로 인해 로컬 악성 애플리케이션이 사용자 상호작용 요구사항을 우회하여 추가적인 권한에 액세스할 수 있습니다.

CVE 참조 유형 심각도 업데이트된 AOSP 버전
CVE-2017-13314 A-63000005 EoP 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2017-13315 A-70721937 EoP 높음 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1

2018-05-05 보안 패치 수준 취약성 세부정보

다음 섹션에서는 2018-05-05 패치 수준에 적용되는 각 보안 취약성에 관해 자세히 알아볼 수 있습니다. 취약성은 영향을 받는 구성요소 아래에 분류되어 있으며 CVE, 관련 참조, 취약성 유형, 심각도, 구성요소(해당하는 경우), 업데이트된 AOSP 버전(해당하는 경우)과 같은 세부정보가 포함되어 있습니다. 가능한 경우 AOSP 변경사항 목록과 같이 문제를 해결한 공개 변경사항을 버그 ID에 연결합니다. 하나의 버그와 관련된 변경사항이 여러 개인 경우 추가 참조가 버그 ID 다음에 오는 번호에 연결됩니다.

커널 구성요소

이 섹션에서 가장 심각한 취약성으로 인해 로컬 악성 애플리케이션이 다른 애플리케이션으로부터 애플리케이션 데이터를 분리하는 운영체제 보호를 우회할 수 있습니다.

CVE 참조 유형 심각도 구성요소
CVE-2017-16643 A-69916367
업스트림 커널
ID 높음 USB 드라이버

NVIDIA 구성요소

이 섹션의 가장 심각한 취약성으로 인해 로컬 악성 애플리케이션이 TEE 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다.

CVE 참조 유형 심각도 구성요소
CVE-2017-6289 A-72830049* EoP 중요 TEE
CVE-2017-5715 A-71686116* ID 높음 TLK
CVE-2017-6293 A-69377364* EoP 높음 NVIDIA Tegra X1 TZ

Qualcomm 구성요소

이 섹션의 가장 심각한 취약성으로 인해 특별히 제작된 파일을 사용하는 근접한 공격자가 권한이 설정된 프로세스의 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다.

CVE 참조 유형 심각도 구성요소
CVE-2018-3580 A-72957507
QC-CR#2149187
RCE 심각 WLAN
CVE-2018-5841 A-72957293
QC-CR#2073502
EoP 높음 DCC
CVE-2018-5850 A-72957135
QC-CR#2141458
EoP 높음 WLAN
CVE-2018-5846 A-71501683
QC-CR#2120063
EoP 높음 라디오 인터넷 패킷 액셀러레이터
CVE-2018-5845 A-71501680
QC-CR#2119081
EoP 높음 GPU
CVE-2018-5840 A-71501678
QC-CR#2052024
EoP 높음 GPU
CVE-2017-18154 A-62872238*
QC-CR#2109325
EoP 높음 Libgralloc
CVE-2018-3578 A-72956999
QC-CR#2145573
EoP 높음 WLAN
CVE-2018-3565 A-72957234
QC-CR#2138555
EoP 높음 WLAN
CVE-2017-13077 A-77481464* EoP 높음 WLAN
CVE-2018-3562 A-72957526
QC-CR#2147955 [2]
DoS 높음 WLAN

일반적인 질문 및 답변

이 섹션에서는 게시판을 읽은 뒤 제기될 수 있는 일반적인 질문의 답변을 제시합니다.

1. 내 기기가 업데이트되어 이 문제가 해결되었는지 어떻게 알 수 있나요?

기기의 보안 패치 수준을 확인하는 방법은 Android 버전 확인 및 업데이트를 참조하세요.

  • 2018-05-01 보안 패치 수준과 관련된 모든 문제는 2018-05-01 보안 패치 수준 이상에서 해결됩니다.
  • 2018-05-05 보안 패치 수준 및 그 이전의 모든 패치 수준과 관련된 문제는 2018-05-05 보안 패치 수준 이상에서 모두 해결됩니다.

이 업데이트를 포함하는 기기 제조업체는 패치 문자열 수준을 다음과 같이 설정해야 합니다.

  • [ro.build.version.security_patch]:[2018-05-01]
  • [ro.build.version.security_patch]:[2018-05-05]

2. 이 게시판에 두 가지 보안 패치 수준이 있는 이유가 무엇인가요?

이 게시판에는 Android 파트너가 모든 Android 기기에서 유사하게 발생하는 취약성 문제의 일부를 더욱 빠르고 유연하게 해결할 수 있도록 두 가지 보안 패치 수준이 포함되어 있습니다. Android 파트너는 이 게시판에 언급된 문제를 모두 수정하고 최신 보안 패치 수준을 사용하는 것이 좋습니다.

  • 2018-05-01 보안 패치 수준을 사용하는 기기는 이 보안 패치 수준과 관련된 모든 문제와 이전 보안 게시판에 보고된 모든 문제의 수정사항을 포함해야 합니다.
  • 2018-05-05 이후의 보안 패치 수준을 사용하는 기기는 이 보안 게시판과 이전 게시판의 모든 관련 패치를 포함해야 합니다.

파트너는 해결하는 모든 문제의 수정사항을 단 한 번의 업데이트에서 번들로 묶는 것이 좋습니다.

3. 유형 열의 항목은 무엇을 의미하나요?

취약성 세부정보 표의 유형 열에 있는 항목은 보안 취약성 분류를 참조합니다.

약어 정의
RCE 원격 코드 실행
EoP 권한 승격
ID 정보 공개
DoS 서비스 거부
N/A 분류 없음

4. 참조 열의 항목은 무엇을 의미하나요?

취약성 세부정보 표의 참조 열에 있는 항목은 참조 값이 속한 조직을 나타내는 접두어를 포함할 수 있습니다.

접두어 참조
A- Android 버그 ID
QC- Qualcomm 참조 번호
M- MediaTek 참조 번호
N- NVIDIA 참조 번호
B- Broadcom 참조 번호

5. 참조 열에서 Android 버그 ID 옆에 있는 * 표시는 무엇을 의미하나요?

공개되지 않은 문제는 참조 열의 Android 버그 ID 옆에 * 표시가 있습니다. 일반적으로 이러한 문제에 관한 업데이트는 Google 개발자 사이트에서 제공되는 Nexus 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

6. 보안 취약성이 이 게시판과 Pixel / Nexus 게시판과 같은 기기/파트너 보안 게시판에 나뉘어져 있는 이유가 무엇인가요?

이 보안 게시판에 설명되어 있는 보안 취약성은 Android 기기의 최신 보안 패치 수준을 선언하는 데 필요합니다. 기기 / 파트너 보안 게시판에 설명된 추가 보안 취약성은 보안 패치 수준을 선언하는 데 필요하지 않습니다. Android 기기 및 칩셋 제조업체는 삼성, LGE, 또는 Pixel / Nexus 보안 게시판과 같은 자체 보안 웹사이트를 통해 기기의 다른 수정사항이 있는지를 설명하는 것이 좋습니다.

버전

버전 날짜 참고사항
1.0 2018년 5월 7일 게시판이 게시됨
1.1 2018년 5월 9일 게시판이 수정되어 AOSP 링크 포함됨
1.2 2018년 7월 11일 2018-05-05 SPL에서 CVE-2017-5754 삭제됨