Google se compromete a promover la equidad racial para las comunidades negras. Ver cómo.
Se usó la API de Cloud Translation para traducir esta página.
Switch to English

Boletín de seguridad de Android: marzo de 2019

Publicado el 4 de marzo de 2019 | Actualizado 5 de marzo de 2019

El Boletín de seguridad de Android contiene detalles de las vulnerabilidades de seguridad que afectan a los dispositivos Android. Los niveles de parches de seguridad de 2019-03-05 o posterior abordan todos estos problemas. Para saber cómo verificar el nivel de parche de seguridad de un dispositivo, consulte Verificar y actualizar su versión de Android .

Los socios de Android reciben notificaciones de todos los problemas al menos un mes antes de la publicación. Los parches de código fuente para estos problemas se lanzarán al repositorio del Proyecto de Código Abierto de Android (AOSP) en las próximas 48 horas. Revisaremos este boletín con los enlaces de AOSP cuando estén disponibles.

El más grave de estos problemas es una vulnerabilidad de seguridad crítica en el marco de medios que podría permitir a un atacante remoto usar un archivo especialmente diseñado para ejecutar código arbitrario dentro del contexto de un proceso privilegiado. La evaluación de la gravedad se basa en el efecto que la explotación de la vulnerabilidad podría tener en un dispositivo afectado, suponiendo que la plataforma y las mitigaciones de servicio estén desactivadas para fines de desarrollo o si se omiten con éxito.

No hemos tenido informes de explotación activa de clientes o abuso de estos problemas recientemente informados. Consulte la sección de mitigaciones de Android y Google Play Protect para obtener detalles sobre las protecciones de la plataforma de seguridad de Android y Google Play Protect, que mejoran la seguridad de la plataforma de Android.

Nota: La información sobre la última actualización inalámbrica (OTA) e imágenes de firmware para dispositivos Google está disponible en el Boletín de actualización de píxeles de marzo de 2019 .

Mitigaciones de servicios de Android y Google

Este es un resumen de las mitigaciones proporcionadas por la plataforma de seguridad de Android y las protecciones de servicios como Google Play Protect . Estas capacidades reducen la probabilidad de que las vulnerabilidades de seguridad puedan explotarse con éxito en Android.

  • La explotación de muchos problemas en Android se hace más difícil por las mejoras en las versiones más recientes de la plataforma Android. Alentamos a todos los usuarios a actualizar a la última versión de Android cuando sea posible.
  • El equipo de seguridad de Android monitorea activamente el abuso a través de Google Play Protect y advierte a los usuarios sobre aplicaciones potencialmente dañinas . Google Play Protect está habilitado de manera predeterminada en dispositivos con servicios móviles de Google , y es especialmente importante para los usuarios que instalan aplicaciones desde fuera de Google Play.

Detalles de vulnerabilidad de nivel de parche de seguridad del 01-03-2019

En las siguientes secciones, proporcionamos detalles para cada una de las vulnerabilidades de seguridad que se aplican al nivel de parche 2019-03-01. Las vulnerabilidades se agrupan bajo el componente que afectan. Hay una descripción del problema y una tabla con el CVE, las referencias asociadas, el tipo de vulnerabilidad , la gravedad y las versiones actualizadas de AOSP (cuando corresponda). Cuando esté disponible, vinculamos el cambio público que abordó el problema con la identificación del error, como la lista de cambios de AOSP. Cuando varios cambios se relacionan con un solo error, se vinculan referencias adicionales a los números que siguen a la identificación del error.

Marco de referencia

La vulnerabilidad más grave en esta sección podría permitir que una aplicación maliciosa local ejecute código arbitrario dentro del contexto de un proceso privilegiado.

CVE Referencias Tipo Gravedad Versiones actualizadas de AOSP
CVE-2018-20346 A-121156452 EoP Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-1985 A-118694079 * EoP Alto 7.0, 7.1.1, 7.1.2, 8.0
CVE-2019-2003 A-116321860 EoP Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2004 A-115739809 CARNÉ DE IDENTIDAD Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2005 A-68777217 EoP Moderar 8.0, 8.1, 9

Marco de medios

La vulnerabilidad más grave en esta sección podría permitir que un atacante remoto use un archivo especialmente diseñado para ejecutar código arbitrario dentro del contexto de un proceso privilegiado.

CVE Referencias Tipo Gravedad Versiones actualizadas de AOSP
CVE-2019-1989 A-118399205 RCE Crítico 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-1990 A-118453553 RCE Crítico 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2006 A-116665972 EoP Alto 9
CVE-2019-2007 A-120789744 [ 2 ] EoP Alto 8.1, 9
CVE-2019-2008 A-122309228 EoP Alto 8.0, 8.1, 9

Sistema

La vulnerabilidad más grave en esta sección podría permitir a un atacante remoto que utiliza una transmisión especialmente diseñada para ejecutar código arbitrario dentro del contexto de un proceso privilegiado.

CVE Referencias Tipo Gravedad Versiones actualizadas de AOSP
CVE-2019-2009 A-120665616 RCE Crítico 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2010 A-118152591 EoP Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2011 A-120084106 [ 2 ] EoP Alto 8.0, 8.1, 9
CVE-2019-2012 A-120497437 EoP Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2013 A-120497583 EoP Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2014 A-120499324 EoP Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2015 A-120503926 EoP Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2016 A-120664978 EoP Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2017 A-121035711 EoP Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2018 A-110172241 [ 2 ] EoP Alto 8.1, 9
CVE-2018-9561 A-111660010 [ 2 ] CARNÉ DE IDENTIDAD Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2018-9563 A-114237888 [ 2 ] CARNÉ DE IDENTIDAD Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2018-9564 A-114238578 [ 2 ] CARNÉ DE IDENTIDAD Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2019 A-115635871 CARNÉ DE IDENTIDAD Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2020 A-116788646 CARNÉ DE IDENTIDAD Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2021 A-120428041 CARNÉ DE IDENTIDAD Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2022 A-120506143 CARNÉ DE IDENTIDAD Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9

Detalles de vulnerabilidad de nivel de parche de seguridad de 03-03-2019

En las siguientes secciones, proporcionamos detalles para cada una de las vulnerabilidades de seguridad que se aplican al nivel de parche 2019-03-05. Las vulnerabilidades se agrupan bajo el componente al que afectan e incluyen detalles como el CVE, las referencias asociadas, el tipo de vulnerabilidad , la gravedad , el componente (cuando corresponde) y las versiones actualizadas de AOSP (cuando corresponde). Cuando esté disponible, vinculamos el cambio público que abordó el problema con la identificación del error, como la lista de cambios de AOSP. Cuando varios cambios se relacionan con un solo error, se vinculan referencias adicionales a los números que siguen a la identificación del error.

Sistema

La vulnerabilidad en esta sección podría permitir que una aplicación maliciosa local ejecute código arbitrario dentro del contexto de un proceso privilegiado.

CVE Referencias Tipo Gravedad Versiones actualizadas de AOSP
CVE-2019-2023 A-121035042 [ 2 ] [ 3 ] [ 4 ] [ 5 ] [ 6 ] [ 7 ] EoP Alto 8.0, 8.1, 9

Componentes del núcleo

La vulnerabilidad más grave en esta sección podría permitir que un atacante local use un archivo especialmente diseñado para ejecutar código arbitrario dentro del contexto de un proceso privilegiado.

CVE Referencias Tipo Gravedad Componente
CVE-2018-10883 A-117311198
Kernel ascendente [ 2 ]
EoP Alto sistema de archivos ext4
CVE-2019-2024 A-111761954
Kernel aguas arriba
EoP Alto controlador em28xx
CVE-2019-2025 A-116855682
Kernel aguas arriba
EoP Alto Conductor de la carpeta

Componentes Qualcomm

Estas vulnerabilidades afectan los componentes de Qualcomm y se describen con más detalle en el boletín de seguridad o alerta de seguridad de Qualcomm correspondiente. Qualcomm proporciona directamente la evaluación de la gravedad de estos problemas.

CVE Referencias Tipo Gravedad Componente
CVE-2017-8252 A-112277630
QC-CR # 2106159
N / A Crítico Ecosistema
CVE-2017-8252 A-114041175
QC-CR # 2128529
N / A Crítico Ecosistema
CVE-2018-11817 A-114041192
QC-CR # 2241830
N / A Crítico DSP_Services
CVE-2018-11817 A-114041747
QC-CR # 2166542
N / A Crítico DSP_Services
CVE-2018-13899 A-119053086
QC-CR # 2295915 [ 2 ]
N / A Alto Vídeo
CVE-2018-13917 A-120487091
QC-CR # 2251019
N / A Alto WIN NSS Host

Componentes de código cerrado de Qualcomm

Estas vulnerabilidades afectan los componentes de Qualcomm y se describen con más detalle en el boletín de seguridad o alerta de seguridad de Qualcomm correspondiente. Qualcomm proporciona directamente la evaluación de la gravedad de estos problemas.

CVE Referencias Tipo Gravedad Componente
CVE-2017-8252 A-79419898 * N / A Crítico Componente de fuente cerrada
CVE-2017-8252 A-79420414 * N / A Crítico Componente de fuente cerrada
CVE-2017-8252 A-112279542 * N / A Crítico Componente de fuente cerrada
CVE-2018-11958 A-114042786 * N / A Crítico Componente de fuente cerrada
CVE-2018-11966 A-114042484 * N / A Alto Componente de fuente cerrada
CVE-2018-11970 A-114042111 * N / A Alto Componente de fuente cerrada
CVE-2018-11971 A-114042829 * N / A Alto Componente de fuente cerrada
CVE-2018-13918 A-120486115 * N / A Alto Componente de fuente cerrada

Preguntas y respuestas comunes

Esta sección responde preguntas comunes que pueden ocurrir después de leer este boletín.

1. ¿Cómo determino si mi dispositivo se actualiza para resolver estos problemas?

Para saber cómo verificar el nivel de parche de seguridad de un dispositivo, consulte Verificar y actualizar su versión de Android .

  • Los niveles de parche de seguridad de 2019-03-01 o posterior abordan todos los problemas asociados con el nivel de parche de seguridad de 2019-03-01.
  • Los niveles de parche de seguridad de 2019-03-05 o posterior abordan todos los problemas asociados con el nivel de parche de seguridad de 2019-03-05 y todos los niveles de parche anteriores.

Los fabricantes de dispositivos que incluyen estas actualizaciones deben establecer el nivel de cadena de parche en:

  • [ro.build.version.security_patch]: [2019-03-01]
  • [ro.build.version.security_patch]: [2019-03-05]

2. ¿Por qué este boletín tiene dos niveles de parche de seguridad?

Este boletín tiene dos niveles de parche de seguridad para que los socios de Android tengan la flexibilidad de corregir un subconjunto de vulnerabilidades que son similares en todos los dispositivos Android con mayor rapidez. Se recomienda a los socios de Android que solucionen todos los problemas de este boletín y utilicen el último nivel de parche de seguridad.

  • Los dispositivos que usan el nivel de parche de seguridad 2019-03-01 deben incluir todos los problemas asociados con ese nivel de parche de seguridad, así como soluciones para todos los problemas informados en boletines de seguridad anteriores.
  • Los dispositivos que usan el nivel de parche de seguridad del 05-03-2019 o posterior deben incluir todos los parches aplicables en este (y en los anteriores) boletines de seguridad.

Se alienta a los socios a agrupar las soluciones para todos los problemas que abordan en una única actualización.

3. ¿Qué significan las entradas en la columna Tipo ?

Las entradas en la columna Tipo de la tabla de detalles de vulnerabilidad hacen referencia a la clasificación de la vulnerabilidad de seguridad.

Abreviatura Definición
RCE Ejecución remota de código
EoP Elevación de privilegios
CARNÉ DE IDENTIDAD Divulgación de información
DoS Negación de servicio
N / A Clasificación no disponible

4. ¿Qué significan las entradas en la columna Referencias ?

Las entradas en la columna Referencias de la tabla de detalles de vulnerabilidad pueden contener un prefijo que identifica la organización a la que pertenece el valor de referencia.

Prefijo Referencia
UNA- ID de error de Android
QC- Número de referencia de Qualcomm
METRO- Número de referencia de MediaTek
NORTE- Número de referencia de NVIDIA
SI- Número de referencia de Broadcom

5. ¿Qué significa un * junto al ID de error de Android en la columna Referencias ?

Los problemas que no están disponibles públicamente tienen un * junto al ID de error de Android en la columna Referencias . La actualización para ese problema generalmente está contenida en los últimos controladores binarios para dispositivos Pixel disponibles en el sitio para desarrolladores de Google .

6. ¿Por qué las vulnerabilidades de seguridad se dividen entre este boletín y los boletines de seguridad del dispositivo / socio, como el boletín Pixel?

Las vulnerabilidades de seguridad que se documentan en este boletín de seguridad son necesarias para declarar el último nivel de parche de seguridad en dispositivos Android. No se requieren vulnerabilidades de seguridad adicionales que se documentan en los boletines de seguridad del dispositivo / socio para declarar un nivel de parche de seguridad. Se recomienda a los fabricantes de dispositivos Android y conjuntos de chips que documenten la presencia de otras soluciones en sus dispositivos a través de sus propios sitios web de seguridad, como los boletines de actualización de Samsung , LGE o Pixel .

Versiones

Versión Fecha Notas
1.0 4 de marzo de 2019 Boletín publicado
1.1 5 de marzo de 2019 Boletín revisado para incluir enlaces AOSP.