Google은 흑인 공동체를 위한 인종 간 평등을 진전시키기 위해 노력하고 있습니다. Google에서 어떤 노력을 하고 있는지 확인하세요.

Android 보안 게시판—2020년 3월

2020년 3월 2일 게시됨 | 2020년 3월 9일 업데이트됨

Android 보안 게시판은 Android 기기에 영향을 미치는 보안 취약성 세부정보를 다룹니다. 2020-03-05 보안 패치 수준 이상에서 관련 보안 문제가 모두 해결되었습니다. 기기의 보안 패치 수준을 확인하는 방법은 Android 버전 확인 및 업데이트를 참조하세요.

Android 파트너에게는 게시되기 최소 한 달 전에 모든 문제 관련 알림이 전달되었습니다. 문제 해결을 위한 소스 코드 패치는 Android 오픈소스 프로젝트(AOSP) 저장소에 배포되었으며 이 게시판에도 링크되어 있습니다. 이 게시판에는 AOSP 외부의 패치 링크도 포함되어 있습니다.

가장 심각한 문제는 미디어 프레임워크의 치명적인 보안 취약성으로, 특별히 제작된 파일을 사용하는 원격 공격자가 권한이 설정된 프로세스의 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다. 심각도 평가는 개발 목적으로 플랫폼 및 서비스 완화를 사용할 수 없거나 우회에 성공한 경우 취약성 악용으로 인해 대상 기기가 받는 영향을 기준으로 합니다.

Android 플랫폼의 보안을 개선하는 Android 보안 플랫폼 보호 기능 및 Google Play 프로텍트에 관해 자세히 알아보려면 Android 및 Google Play 프로텍트 완화 섹션을 참조하세요.

Android 및 Google 서비스 완화

다음은 Android 보안 플랫폼Google Play 프로텍트와 같은 서비스 보호 기능을 통해 제공되는 완화에 관한 요약입니다. 이러한 기능을 통해 Android에서 보안 취약성이 악용될 가능성을 줄입니다.

  • Android 플랫폼 최신 버전의 향상된 기능으로 Android의 여러 문제를 악용하기 더욱 어려워졌습니다. 가능하다면 모든 사용자는 최신 버전의 Android로 업데이트하는 것이 좋습니다.
  • Android 보안팀에서는 Google Play 프로텍트를 통해 악용사례를 적극적으로 모니터링하고 잠재적으로 위험한 애플리케이션에 관해 사용자에게 경고를 보냅니다. Google Play 프로텍트는 Google 모바일 서비스가 적용된 기기에 기본적으로 사용 설정되어 있으며 Google Play 외부에서 가져온 앱을 설치하는 사용자에게 특히 중요합니다.

2020-03-01 보안 패치 수준 취약점 세부정보

다음 섹션에서는 2020-03-01 패치 수준에 적용되는 각 보안 취약점에 관해 자세히 알아볼 수 있습니다. 취약점은 영향을 받는 구성요소 아래에 분류되어 있습니다. 아래 표에서 문제 설명 및 CVE ID, 관련 참조, 취약점 유형, 심각도, 업데이트된 AOSP 버전(해당하는 경우)을 참조하세요. 가능한 경우 AOSP 변경사항 목록과 같이 문제를 해결한 공개 변경사항을 버그 ID에 연결합니다. 하나의 버그와 관련된 변경사항이 여러 개인 경우 추가 참조가 버그 ID 다음에 오는 번호에 연결되어 있습니다. Android 10 이상을 실행하는 기기에는 보안 업데이트 및 Google Play 시스템 업데이트가 제공될 수 있습니다.

프레임워크

이 섹션의 취약성으로 인해 로컬 악성 애플리케이션이 다른 애플리케이션으로부터 애플리케이션 데이터를 분리하는 운영체제 보호를 우회할 수 있습니다.

CVE 참조 유형 심각도 업데이트된 AOSP 버전
CVE-2020-0031 A-141703197 [2] ID 높음 10

미디어 프레임워크

이 섹션의 가장 심각한 취약성으로 인해 특별히 제작된 파일을 사용하는 원격 공격자가 권한이 설정된 프로세스의 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다.

CVE 참조 유형 심각도 업데이트된 AOSP 버전
CVE-2020-0032 A-145364230 RCE 심각 8.0, 8.1, 9, 10
CVE-2020-0033 A-144351324 EoP 높음 8.0, 8.1, 9, 10
CVE-2020-0034 A-62458770 ID 높음 8.0, 8.1

시스템

이 섹션에서 가장 심각한 취약성으로 인해 로컬 악성 애플리케이션이 사용자 상호작용 요구사항을 우회하여 추가적인 권한에 액세스할 수 있습니다.

CVE 참조 유형 심각도 업데이트된 AOSP 버전
CVE-2020-0036 A-144679405 EoP 높음 8.0, 8.1, 9, 10
CVE-2020-0035 A-140622024 ID 높음 8.0, 8.1, 9
CVE-2020-0029 A-140065828 ID 높음 10
CVE-2020-0037 A-143106535 ID 높음 8.0, 8.1, 9, 10
CVE-2020-0038 A-143109193 ID 높음 8.0, 8.1, 9, 10
CVE-2020-0039 A-143155861 ID 높음 8.0, 8.1, 9, 10

Google Play 시스템 업데이트

Project Mainline 구성요소에는 다음 문제가 있습니다.

구성요소 CVE
미디어 코덱 CVE-2020-0032

2020-03-05 보안 패치 수준 취약점 세부정보

다음 섹션에서는 2020-03-05 패치 수준에 적용되는 각 보안 취약점에 관해 자세히 알아볼 수 있습니다. 취약점은 영향을 받는 구성요소 아래에 분류되어 있으며 CVE, 관련 참조, 취약점 유형, 심각도, 구성요소(해당하는 경우), 업데이트된 AOSP 버전(해당하는 경우)과 같은 세부정보가 포함되어 있습니다. 가능한 경우 AOSP 변경사항 목록과 같이 문제를 해결한 공개 변경사항을 버그 ID에 연결합니다. 하나의 버그와 관련된 변경사항이 여러 개인 경우 추가 참조가 버그 ID 다음에 오는 번호에 연결됩니다.

커널 구성요소

이 섹션의 가장 심각한 취약성으로 인해 특별히 제작된 USB 기기를 사용하는 로컬 공격자가 권한이 있는 프로세스의 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다.

CVE 참조 유형 심각도 구성요소
CVE-2019-19527 A-146257915
업스트림 커널 [2]
EoP 높음 USB
CVE-2019-19537 A-146258055
업스트림 커널
EoP 높음 USB
CVE-2019-15239 A-143009752
업스트림 커널
EoP 높음 네트워킹
CVE-2020-0041 A-145988638
업스트림 커널
EoP 높음 바인더

FPC 구성요소

이 섹션에서 가장 심각한 취약성으로 인해 로컬 악성 애플리케이션이 사용자 상호작용 요구사항을 우회하여 추가적인 권한에 액세스할 수 있습니다.

CVE 참조 유형 심각도 구성요소
CVE-2020-0010 A-137014293* EoP 높음 FPC 지문 TEE
CVE-2020-0011 A-137648045* EoP 높음 FPC 지문 TEE
CVE-2020-0012 A-137648844* EoP 높음 FPC 지문 TEE
CVE-2020-0042 A-137649599* ID 보통 FPC 지문 TEE
CVE-2020-0043 A-137650218* ID 보통 FPC 지문 TEE
CVE-2020-0044 A-137650219* ID 보통 FPC 지문 TEE

MediaTek 구성요소

CVE 참조 유형 심각도 구성요소
CVE-2020-0069 A-147882143*
M-ALPS04356754
EoP 높음 시스템

Qualcomm 구성요소

다음 취약성은 Qualcomm 구성요소에 영향을 주며 해당 Qualcomm 보안 게시판 또는 보안 알림에 자세히 설명되어 있습니다. 이러한 문제의 심각도 평가는 Qualcomm에서 직접 제공합니다.

CVE 참조 유형 심각도 구성요소
CVE-2019-14079 A-138848422
QC-CR#2521001
N/A 높음 USB
CVE-2018-11838 A-145545090
QC-CR#221457 [2]
N/A 높음 WLAN
CVE-2019-10526 A-145544085
QC-CR#2232526
QC-CR#2541970
N/A 높음 WLAN
CVE-2019-10569 A-145545820
QC-CR#2315791
N/A 높음 오디오
CVE-2019-14029 A-145546793
QC-CR#2528795
N/A 높음 그래픽
CVE-2019-14032 A-145546652
QC-CR#2537311
N/A 높음 오디오
CVE-2019-14068 A-145546435
QC-CR#2507653 [2]
N/A 높음 오디오
CVE-2019-14072 A-145545251
QC-CR#2509391
N/A 높음 그래픽

Qualcomm 비공개 소스 구성요소

다음 취약성은 Qualcomm 구성요소에 영향을 주며 해당 Qualcomm 보안 게시판 또는 보안 알림에 자세히 설명되어 있습니다. 이러한 문제의 심각도 평가는 Qualcomm에서 직접 제공합니다.

CVE 참조 유형 심각도 구성요소
CVE-2019-2317 A-134436812* N/A 심각 비공개 소스 구성요소
CVE-2019-10586 A-140423909* N/A 심각 비공개 소스 구성요소
CVE-2019-10587 A-140423816* N/A 심각 비공개 소스 구성요소
CVE-2019-10593 A-140424165* N/A 심각 비공개 소스 구성요소
CVE-2019-10594 A-140424564* N/A 심각 비공개 소스 구성요소
CVE-2019-10612 A-140423161* N/A 심각 비공개 소스 구성요소
CVE-2019-14031 A-142271912* N/A 심각 비공개 소스 구성요소
CVE-2019-14045 A-140973418* N/A 심각 비공개 소스 구성요소
CVE-2019-14071 A-145545489* N/A 심각 비공개 소스 구성요소
CVE-2019-14083 A-140973259* N/A 심각 비공개 소스 구성요소
CVE-2019-14086 A-140973417* N/A 심각 비공개 소스 구성요소
CVE-2019-14030 A-145546515* N/A 심각 비공개 소스 구성요소
CVE-2019-14097 A-145546003* N/A 심각 비공개 소스 구성요소
CVE-2019-14098 A-145546314* N/A 심각 비공개 소스 구성요소
CVE-2019-10546 A-145545250* N/A 심각 비공개 소스 구성요소
CVE-2019-14095 A-142843397* N/A 심각 비공개 소스 구성요소
CVE-2018-11970 A-114042111* N/A 높음 비공개 소스 구성요소
CVE-2019-10603 A-140424074* N/A 높음 비공개 소스 구성요소
CVE-2019-10616 A-140423338* N/A 높음 비공개 소스 구성요소
CVE-2019-10549 A-140423162* N/A 높음 비공개 소스 구성요소
CVE-2019-10550 A-140423702* N/A 높음 비공개 소스 구성요소
CVE-2019-10552 A-140423817* N/A 높음 비공개 소스 구성요소
CVE-2019-10553 A-140423081* N/A 높음 비공개 소스 구성요소
CVE-2019-10554 A-140424012* N/A 높음 비공개 소스 구성요소
CVE-2019-10577 A-140424166* N/A 높음 비공개 소스 구성요소
CVE-2019-14026 A-142271986* N/A 높음 비공개 소스 구성요소
CVE-2019-14027 A-142271756* N/A 높음 비공개 소스 구성요소
CVE-2019-14028 A-142271831* N/A 높음 비공개 소스 구성요소
CVE-2019-2300 A-142271659* N/A 높음 비공개 소스 구성요소
CVE-2019-2311 A-142271967* N/A 높음 비공개 소스 구성요소
CVE-2019-14050 A-143902706* N/A 높음 비공개 소스 구성요소
CVE-2019-14081 A-143902882* N/A 높음 비공개 소스 구성요소
CVE-2019-14082 A-140974589* N/A 높음 비공개 소스 구성요소
CVE-2019-14085 A-143902807* N/A 높음 비공개 소스 구성요소
CVE-2019-14048 A-145545282* N/A 높음 비공개 소스 구성요소
CVE-2019-14061 A-145545758* N/A 높음 비공개 소스 구성요소
CVE-2019-10604 A-145545725* N/A 높음 비공개 소스 구성요소
CVE-2019-10591 A-145545283* N/A 높음 비공개 소스 구성요소
CVE-2019-14000 A-145546434* N/A 높음 비공개 소스 구성요소
CVE-2019-14015 A-145545650* N/A 높음 비공개 소스 구성요소

일반적인 질문 및 답변

이 섹션에서는 게시판 내용에 관한 일반적인 질문의 답변을 제시합니다.

1. 내 기기가 업데이트되어 이 문제가 해결되었는지 어떻게 알 수 있나요?

기기의 보안 패치 수준을 확인하는 방법은 Android 버전 확인 및 업데이트를 참조하세요.

  • 2020-03-01 보안 패치 수준과 관련된 모든 문제는 2020-03-01 보안 패치 수준 이상에서 해결됩니다.
  • 2020-03-05 보안 패치 수준 및 그 이전의 모든 패치 수준과 관련된 모든 문제는 2020-03-05 보안 패치 수준 이상에서 모두 해결됩니다.

이 업데이트를 포함하는 기기 제조업체는 패치 문자열 수준을 다음과 같이 설정해야 합니다.

  • [ro.build.version.security_patch]:[2020-03-01]
  • [ro.build.version.security_patch]:[2020-03-05]

Android 10 이상을 실행하는 일부 기기는 Google Play 시스템 업데이트에 2020-03-01 보안 패치 수준과 일치하는 날짜 문자열이 있습니다. 보안 업데이트를 설치하는 방법에 관한 자세한 내용은 이 도움말을 참조하세요.

2. 이 게시판에 두 가지 보안 패치 수준이 있는 이유가 무엇인가요?

이 게시판에는 Android 파트너가 모든 Android 기기에서 유사하게 발생하는 취약성 문제의 일부를 더욱 빠르고 유연하게 해결할 수 있도록 두 가지 보안 패치 수준이 포함되어 있습니다. Android 파트너는 이 게시판에 언급된 문제를 모두 수정하고 최신 보안 패치 수준을 사용하는 것이 좋습니다.

  • 2020-03-01 보안 패치 수준을 사용하는 기기는 이 보안 패치 수준과 관련된 모든 문제와 이전 보안 게시판에 보고된 모든 문제의 수정사항을 포함해야 합니다.
  • 2020-03-05 이후의 보안 패치 수준을 사용하는 기기는 이 보안 게시판과 이전 게시판의 모든 관련 패치를 포함해야 합니다.

파트너는 해결하는 모든 문제의 수정사항을 단 한 번의 업데이트에서 번들로 묶는 것이 좋습니다.

3. 유형 열의 항목은 무엇을 의미하나요?

취약점 세부정보 표의 유형 열에 있는 항목은 보안 취약점 분류를 뜻합니다.

약어 정의
RCE 원격 코드 실행
EoP 권한 승격
ID 정보 공개
DoS 서비스 거부
N/A 분류 없음

4. 참조 열의 항목은 무엇을 의미하나요?

취약점 세부정보 표의 참조 열에 있는 항목은 참조 값이 속한 조직을 나타내는 접두어를 포함할 수 있습니다.

프리픽스 참조
A- Android 버그 ID
QC- Qualcomm 참조 번호
M- MediaTek 참조 번호
N- NVIDIA 참조 번호
B- Broadcom 참조 번호

5. 참조 열에서 Android 버그 ID 옆에 있는 * 표시는 무엇을 의미하나요?

공개되지 않은 문제에는 참조 열의 Android 버그 ID 옆에 * 표시가 있습니다. 일반적으로 이러한 문제에 관한 업데이트는 Google 개발자 사이트에서 제공되는 Pixel 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

6. 보안 취약성이 이 게시판과 Pixel  게시판과 같은 기기 / 파트너 보안 게시판에 나누어져 있는 이유가 무엇인가요?

이 보안 게시판에 설명되어 있는 보안 취약성은 Android 기기의 최신 보안 패치 수준을 선언하는 데 필요합니다. 기기 / 파트너 보안 게시판에 설명된 추가 보안 취약성은 보안 패치 수준을 선언하는 데 필요하지 않습니다. Google, Huawei, LGE, Motorola, Nokia, 또는 삼성과 같은 Android 기기 및 칩셋 제조업체에서는 자사 기기의 보안 취약점 세부정보를 자체적으로 게시할 수도 있습니다.

버전

버전 날짜 참고
1.0 2020년 3월 2일 게시판이 게시됨
1.1 2020년 3월 3일 게시판이 수정되어 AOSP 링크 포함됨
1.2 202년 3월 9일 문제 목록이 업데이트됨