Nexus 安全公告 - 2015 年 11 月

发布时间:2015 年 11 月 2 日

在每月发布 Android 安全公告的过程中,我们都会通过无线 (OTA) 更新的方式发布针对 Nexus 设备的安全更新。我们还会在 Google Developers 网站上发布 Nexus 固件映像。安全补丁程序级别为 2015 年 11 月 1 日(或之后的日期)的 LMY48X 或更高版本的 Android Lollipop 系统以及所有 Android Marshmallow 系统都已解决本文所列的安全问题。如需了解详情,请参阅常见问题和解答部分。

我们的合作伙伴在 2015 年 10 月 5 日或之前就已收到这些问题的相关通知。我们会在接下来的 48 小时内在 Android 开放源代码项目 (AOSP) 代码库中发布针对相关问题的源代码补丁程序。届时,我们将会修订本公告,将相关 AOSP 链接增补到本文中。

这些问题中危险性最高的是一个严重程度为“严重”的安全漏洞,它可能会导致在处理媒体文件的过程中,可通过电子邮件、网页和彩信等多种方式在受影响的设备上执行远程代码。严重程度评估的依据是漏洞被利用后可能会对受影响设备造成的影响大小(假设相关平台和服务缓解措施被成功规避或出于开发目的而被停用)。

我们尚未收到用户因这些新报告的问题而遭到主动攻击的报告。请参阅缓解措施部分,详细了解 Android 安全平台防护和服务防护功能(如 SafetyNet)。这些功能可提高 Android 平台的安全性。我们建议所有用户在自己的设备上接受这些更新。

缓解措施

本部分概括总结了 Android 安全平台和服务防护功能(如 SafetyNet)提供的缓解措施。这些功能可降低 Android 上的安全漏洞被成功利用的可能性。

  • 新版 Android 平台中的增强功能让攻击者更加难以利用 Android 上存在的许多问题。我们建议所有用户都尽可能更新到最新版 Android。
  • Android 安全团队会积极利用“验证应用”功能和 SafetyNet 监控滥用行为,这些功能会在用户即将安装可能有害的应用时发出警告。Google Play 中禁止提供会获取设备 Root 权限的工具。为了保护从 Google Play 之外的来源安装应用的用户,“验证应用”功能在默认情况下将处于启用状态,并在发现已知会获取 Root 权限的应用时警告用户。“验证应用”功能会尝试识别并阻止用户安装会利用提权漏洞的已知恶意应用。如果用户已安装此类应用,那么“验证应用”功能将会通知用户并尝试移除所有此类应用。
  • 由于已做了适当更新,因此 Google 环聊和 Messenger 应用不会自动将媒体内容传递给 mediaserver 这类进程。

致谢

非常感谢以下研究人员做出的贡献:

  • Google Chrome 安全团队的 Abhishek Arya、Oliver Chang 和 Martin Barbella:CVE-2015-6608
  • Copperhead Security 的 Daniel Micay (daniel.micay@copperhead.co):CVE-2015-6609
  • 韩国科学技术院系统安全实验室 (System Security Lab, KAIST) 的 Dongkwan Kim (dkay@kaist.ac.kr):CVE-2015-6614
  • 韩国科学技术院系统安全实验室 (System Security Lab, KAIST) 的 Hongil Kim (hongilk@kaist.ac.kr):CVE-2015-6614
  • 趋势科技 (Trend Micro) 的 Jack Tang (@jacktang310):CVE-2015-6611
  • 趋势科技 (Trend Micro) 的 Peter Pi:CVE-2015-6611
  • Google Project Zero 的 Natalie Silvanovich:CVE-2015-6608
  • 碁震安全研究团队(@K33nTeam,http://k33nteam.org/)的何淇丹 (@flanker_hqd) 和 Wen Xu (@antlr7):CVE-2015-6612
  • 奇虎 360 科技有限公司的龚广(@oldfresher,higongguang@gmail.com):CVE-2015-6612
  • 趋势科技的 Seven Shen:CVE-2015-6610

安全漏洞详情

我们在下面提供了 2015-11-01 补丁程序级别涵盖的每个安全漏洞的详细信息,其中包括问题描述、严重程度阐述以及一个包含 CVE、相关 Bug、严重程度、受影响版本及报告日期的表格。在适用的情况下,我们会将 Bug ID 链接到解决问题的 AOSP 代码更改记录。如果某个 Bug 有多条相关的代码更改记录,我们还通过 Bug ID 后面的数字链接到了更多 AOSP 参考信息。

Mediaserver 中的远程代码执行漏洞

对于特制的文件,系统在处理其媒体文件和数据时,攻击者可通过 mediaserver 中的漏洞破坏内存并通过 mediaserver 进程执行远程代码。

受影响的功能是操作系统的核心部分,有多个应用允许通过远程内容(最主要是彩信和浏览器媒体播放)使用该功能。

由于该漏洞可用于通过 mediaserver 服务执行远程代码,因此我们将其严重程度评为“严重”。mediaserver 服务可以访问音频和视频流,还可以获取第三方应用通常无法获取的权限。

CVE Bug(附 AOSP 链接) 严重程度 受影响的版本 报告日期
CVE-2015-6608 ANDROID-19779574 严重 5.0、5.1、6.0 Google 内部
ANDROID-23680780
ANDROID-23876444
ANDROID-23881715 严重 4.4、5.0、5.1、6.0 Google 内部
ANDROID-14388161 严重 4.4 和 5.1 Google 内部
ANDROID-23658148 严重 5.0、5.1、6.0 Google 内部

libutils 中的远程代码执行漏洞

在处理音频文件的过程中,通用库 libutils 中的漏洞可能会被利用。在系统处理特制文件时,攻击者可能会通过该漏洞破坏内存和执行远程代码。

受影响的功能是某个 API,有多个应用允许通过远程内容(最主要是彩信和浏览器媒体播放)使用该功能。由于该漏洞可用于在特许服务中执行远程代码,因此我们将其严重程度评为“严重”。受影响的组件可以访问音频和视频流,还可以获取第三方应用通常无法获取的权限。

CVE Bug(附 AOSP 链接) 严重程度 受影响的版本 报告日期
CVE-2015-6609 ANDROID-22953624 [2] 严重 6.0 及更低版本 2015 年 8 月 3 日

Mediaserver 中的信息披露漏洞

mediaserver 中的信息披露漏洞可用于绕过相应安全措施(这类措施可增加攻击者利用平台的难度)。

CVE Bug(附 AOSP 链接) 严重程度 受影响的版本 报告日期
CVE-2015-6611 ANDROID-23905951 [2] [3] 6.0 及更低版本 2015 年 9 月 7 日
ANDROID-23912202*
ANDROID-23953967*
ANDROID-23696300 6.0 及更低版本 2015 年 8 月 31 日
ANDROID-23600291 6.0 及更低版本 2015 年 8 月 26 日
ANDROID-23756261 [2] 6.0 及更低版本 2015 年 8 月 26 日
ANDROID-23540907 [2] 5.1 及更低版本 2015 年 8 月 25 日
ANDROID-23541506 6.0 及更低版本 2015 年 8 月 25 日
ANDROID-23284974*
ANDROID-23542351*
ANDROID-23542352*
ANDROID-23515142 5.1 及更低版本 2015 年 8 月 19 日

* 针对此 Bug 的补丁程序包含在所提供的其他 AOSP 链接中。

libstagefright 中的提权漏洞

本地恶意应用可利用 libstagefright 中的提权漏洞在 mediaserver 服务中破坏内存并执行任意代码。通常情况下,我们会将该漏洞的严重程度评为“严重”,但由于攻击者以远程方式利用该漏洞的可能性较低,因此我们将其严重程度评为“高”。

CVE Bug(附 AOSP 链接) 严重程度 受影响的版本 报告日期
CVE-2015-6610 ANDROID-23707088 [2] 6.0 及更低版本 2015 年 8 月 19 日

libmedia 中的提权漏洞

本地恶意应用可利用 libmedia 中的漏洞通过 mediaserver 服务执行任意代码。由于该漏洞可被用于获取第三方应用无法直接获取的权限,因此我们将其严重程度评为“高”。

CVE Bug(附 AOSP 链接) 严重程度 受影响的版本 报告日期
CVE-2015-6612 ANDROID-23540426 6.0 及更低版本 2015 年 8 月 23 日

蓝牙中的提权漏洞

本地应用可利用蓝牙中的漏洞向设备上的监听调试端口发送命令。由于该漏洞可用于获取第三方应用通常无法获取的特权(如 SignatureSignatureOrSystem 权限),因此我们将其严重程度评为“高”。

CVE Bug(附 AOSP 链接) 严重程度 受影响的版本 报告日期
CVE-2015-6613 ANDROID-24371736 6.0 Google 内部

Telephony 中的提权漏洞

本地恶意应用可利用 Telephony 组件中的漏洞将未经授权的数据传递到受限的网络接口,因而可能会产生流量费。此外,该漏洞还可用于阻碍设备接听电话,并让攻击者控制通话的静音设置。由于该漏洞可被用于以不正当的方式获取“危险”权限,因此我们将其严重程度评为“中”。

CVE Bug(附 AOSP 链接) 严重程度 受影响的版本 报告日期
CVE-2015-6614 ANDROID-21900139 [2] [3] 5.0、5.1 2015 年 6 月 8 日

常见问题和解答

本部分回答了您在阅读本公告后可能会产生的常见问题。

1. 如何确定我的设备已经更新了相关安全补丁程序,因此不受这些问题影响?

安全补丁程序级别为 2015 年 11 月 1 日(或之后的日期)的 LMY48X 或更高版本的 Android Lollipop 系统以及所有 Android Marshmallow 系统都已解决本文所列的安全问题。请参阅 Nexus 文档中提供的有关说明,了解如何检查安全补丁程序级别。提供这些更新的设备制造商应将补丁程序字符串级别设为 [ro.build.version.security_patch]:[2015-11-01]

修订版本

  • 最初发布时间:2015 年 11 月 2 日