Nexus 安全公告 - 2016 年 2 月

发布时间:2016 年 2 月 1 日 | 更新时间:2016 年 3 月 7 日

在每月发布 Android 安全公告的同时,我们都会通过无线 (OTA) 更新的方式发布针对 Nexus 设备的安全更新。我们还会在 Google Developers 网站上发布 Nexus 固件映像。安全补丁程序级别为 2016 年 2 月 1 日(或之后的日期)的 LMY49G 或更高版本的 Android L 系统以及所有 Android M 系统都已解决本文所列的安全问题。请参阅 Nexus 文档中提供的相关说明,了解如何检查安全补丁程序级别。

我们的合作伙伴在 2016 年 1 月 4 日(或之前)就已收到本公告中说明的这些问题的相关通知。我们已在 Android 开放源代码项目 (AOSP) 代码库中发布了针对相关问题的源代码补丁程序(如果适用)。

这些问题中危险性最高的是一个严重程度为“严重”的安全漏洞,它可能会导致在处理媒体文件的过程中,可通过电子邮件、网页和彩信等多种方式在受影响的设备上执行远程代码。Broadcom WLAN 驱动程序中的远程代码执行漏洞也属于“严重”程度的漏洞,因为当用户与攻击者接入同一网络时,该漏洞可用于在受影响的设备上执行远程代码。严重程度评估的依据是漏洞被利用后可能会对受影响设备造成的影响大小(假设相关平台和服务缓解措施被成功规避或出于开发目的而被停用)。

我们尚未收到用户因这些新报告的问题而遭到主动攻击的报告。请参阅缓解措施部分,详细了解 Android 安全平台防护和服务防护功能(如 SafetyNet)。这些功能可提高 Android 平台的安全性。我们建议所有用户在自己的设备上接受这些更新。

缓解措施

本部分概括总结了 Android 安全平台和服务防护功能(如 SafetyNet)提供的缓解措施。这些功能可降低 Android 上的安全漏洞被成功利用的可能性。

  • 新版 Android 平台中的增强功能让攻击者更加难以利用 Android 上存在的许多问题。我们建议所有用户都尽可能更新到最新版 Android。
  • Android 安全团队会积极利用“验证应用”功能和 SafetyNet 监控滥用行为,这些功能会在用户即将安装可能有害的应用时发出警告。Google Play 中禁止提供会获取设备 Root 权限的工具。为了保护从 Google Play 之外的来源安装应用的用户,“验证应用”功能在默认情况下将处于启用状态,并在发现已知会获取 Root 权限的应用时警告用户。“验证应用”功能会尝试识别并阻止用户安装会利用提权漏洞的已知恶意应用。如果用户已安装此类应用,那么“验证应用”功能将会通知用户并尝试移除所有此类应用。
  • 由于已做了适当更新,因此 Google 环聊和 Messenger 应用不会自动将媒体内容传递给 mediaserver 这类进程。

致谢

非常感谢以下研究人员做出的贡献:

安全漏洞详情

我们在下面提供了 2016-02-01 补丁程序级别涵盖的每个安全漏洞的详细信息,其中包括问题描述、严重程度阐述以及一个包含 CVE、相关 Bug、严重程度、受影响版本及报告日期的表格。在适用的情况下,我们会将 Bug ID 链接到解决问题的 AOSP 代码提交记录。如果某个 Bug 有多条相关的代码更改记录,我们还将通过 Bug ID 后面的数字链接到更多 AOSP 参考信息。

Broadcom WLAN 驱动程序中的远程代码执行漏洞

Broadcom WLAN 驱动程序中的多个远程代码执行漏洞可让远程攻击者使用特制的无线控制消息数据包,使远程代码通过内核执行,从而破坏内核内存。当攻击者与受害者接入同一网络时,就可能会触发这些漏洞。由于该漏洞可能会导致在无需用户互动的情况下通过内核执行远程代码,因此我们将其严重程度评为“严重”。

CVE Bug 严重程度 已更新的版本 报告日期
CVE-2016-0801 ANDROID-25662029
ANDROID-25662233
严重 4.4.4、5.0、5.1.1、6.0、6.0.1 2015 年 10 月 25 日
CVE-2016-0802 ANDROID-25306181 严重 4.4.4、5.0、5.1.1、6.0、6.0.1 2015 年 10 月 26 日

Mediaserver 中的远程代码执行漏洞

对于特制的文件,系统在处理其媒体文件和数据时,攻击者可通过 mediaserver 中的漏洞破坏内存并通过 mediaserver 进程执行远程代码。

受影响的功能是操作系统的核心部分,有多个应用允许通过远程内容(最主要是彩信和浏览器媒体播放)使用该功能。

由于该漏洞可用于通过 mediaserver 服务执行远程代码,因此我们将其严重程度评为“严重”。mediaserver 服务可以访问音频和视频流,还可以获取第三方应用通常无法获取的权限。

CVE Bug(附 AOSP 链接) 严重程度 已更新的版本 报告日期
CVE-2016-0803 ANDROID-25812794 严重 4.4.4、5.0、5.1.1、6.0、6.0.1 2015 年 11 月 19 日
CVE-2016-0804 ANDROID-25070434 严重 5.0、5.1.1、6.0、6.0.1 2015 年 10 月 12 日

Qualcomm 效能模块中的提权漏洞

Qualcomm ARM 处理器的效能事件管理器组件中的提权漏洞可让本地恶意应用通过内核执行任意代码。由于该漏洞有可能会造成本地设备永久损坏,而您可能需要通过重写操作系统来修复设备,因此我们将其严重程度评为“严重”。

CVE Bug 严重程度 已更新的版本 报告日期
CVE-2016-0805 ANDROID-25773204* 严重 4.4.4、5.0、5.1.1、6.0、6.0.1 2015 年 11 月 15 日

*针对该问题的补丁程序未在 AOSP 中发布。Google Developers 网站上提供的 Nexus 设备的最新二进制驱动程序中包含相应更新。

Qualcomm WLAN 驱动程序中的提权漏洞

Qualcomm WLAN 驱动程序中有一项漏洞,本地恶意应用可利用这项漏洞通过内核执行任意代码。由于该漏洞有可能会造成本地设备永久损坏,而您可能需要通过重写操作系统来修复设备,因此我们将其严重程度评为“严重”。

CVE Bug 严重程度 已更新的版本 报告日期
CVE-2016-0806 ANDROID-25344453* 严重 4.4.4、5.0、5.1.1、6.0、6.0.1 2015 年 11 月 15 日

*针对该问题的补丁程序未在 AOSP 中发布。Google Developers 网站上提供的 Nexus 设备的最新二进制驱动程序中包含相应更新。

Debuggerd 中的提权漏洞

Debuggerd 组件中的提权漏洞可让本地恶意应用通过设备 Root 执行任意代码。由于该漏洞有可能会造成本地设备永久损坏,而您可能需要通过重写操作系统来修复设备,因此我们将其严重程度评为“严重”。

CVE Bug(附 AOSP 链接) 严重程度 已更新的版本 报告日期
CVE-2016-0807 ANDROID-25187394 严重 6.0 和 6.0.1 Google 内部

Minikin 中的拒绝服务漏洞

Minikin 库中的拒绝服务漏洞可让本地攻击者暂时阻止用户使用受影响的设备。攻击者可使系统加载不可信的字体,造成 Minikin 组件中发生溢出现象,从而导致崩溃。由于拒绝服务漏洞会导致系统不断重新启动,因此我们将其严重程度评为“高”。

CVE Bug(附 AOSP 链接) 严重程度 已更新的版本 报告日期
CVE-2016-0808 ANDROID-25645298 5.0、5.1.1、6.0、6.0.1 2015 年 11 月 3 日

WLAN 中的提权漏洞

WLAN 组件中的提权漏洞可让本地恶意应用通过系统执行任意代码。不过,只有本地邻近区域中的设备才会受到该漏洞的攻击。由于该漏洞可用于远程获取“normal”功能,因此我们将其严重程度评为“高”。通常情况下,只有在本地安装的第三方应用才可以获取这些权限。

CVE Bug(附 AOSP 链接) 严重程度 已更新的版本 报告日期
CVE-2016-0809 ANDROID-25753768 6.0、6.0.1 Google 内部

Mediaserver 中的提权漏洞

Mediaserver 中的提权漏洞可让本地恶意应用通过提权后的系统应用执行任意代码。由于该漏洞可用于获取第三方应用无法获取的特权(如 SignatureSignatureOrSystem 权限),因此我们将其严重程度评为“高”。

CVE Bug(附 AOSP 链接) 严重程度 已更新的版本 报告日期
CVE-2016-0810 ANDROID-25781119 4.4.4、5.0、5.1.1、6.0、6.0.1 Google 内部

libmediaplayerservice 中的信息披露漏洞

libmediaplayerservice 中的信息披露漏洞可用于绕过相应的安全措施(这类措施可增加攻击者利用平台的难度)。由于这类漏洞可用于获取第三方应用无法获取的特权(如 SignatureSignatureOrSystem 权限),因此我们将其严重程度评为“高”。

CVE Bug(附 AOSP 链接) 严重程度 已更新的版本 报告日期
CVE-2016-0811 ANDROID-25800375 6.0、6.0.1 2015 年 11 月 16 日

设置向导中的提权漏洞

设置向导中的漏洞可让恶意攻击者绕过“恢复出厂设置保护”机制,并获取对设备的访问权限。由于该漏洞可让实际拿到设备的人绕过“恢复出厂设置保护”机制,从而使攻击者可以成功重置设备并清除所有数据,因此我们将其严重程度评为“中”。

CVE Bug(附 AOSP 链接) 严重程度 已更新的版本 报告日期
CVE-2016-0812 ANDROID-25229538 5.1.1、6.0 Google 内部
CVE-2016-0813 ANDROID-25476219 5.1.1、6.0、6.0.1 Google 内部

常见问题和解答

本部分针对阅读本公告后可能产生的常见问题提供了相应的解答。

1. 如何确定我的设备已经更新了相关安全补丁程序,因此不受这些问题影响?

安全补丁程序级别为 2016 年 2 月 1 日(或之后的日期)的 LMY49G 或更高版本的 Android L 系统以及所有 Android 6.0 系统都已解决本文所列的安全问题。请参阅 Nexus 文档中提供的相关说明,了解如何检查安全补丁程序级别。提供这些更新的设备制造商应将补丁程序字符串级别设为 [ro.build.version.security_patch]:[2016-02-01]

修订版本

  • 2016 年 2 月 1 日:发布了本公告。
  • 2016 年 2 月 2 日:修订了本公告,添加了 AOSP 链接。
  • 2016 年 3 月 7 日:修订了本公告,添加了更多 AOSP 链接。