Android のセキュリティに関する公開情報 - 2018 年 3 月

2018 年 3 月 5 日公開 | 2018 年 3 月 7 日更新

Android のセキュリティに関する公開情報には、Android 搭載端末に影響を与えるセキュリティの脆弱性の詳細を掲載しています。セキュリティ パッチレベル 2018-03-05 以降では、下記のすべての問題に対処しています。端末のセキュリティ パッチレベルの確認については、Android のバージョンを確認して更新する方法の説明をご覧ください。

Android パートナーには、情報公開の少なくとも 1 か月前にすべての問題が通知されます。Android オープンソース プロジェクト(AOSP)のレポジトリに、各問題に対するソースコードのパッチをリリースしています。また、この公開情報では、これらのパッチへのリンクに加え、AOSP 以外のパッチへのリンクも掲載しています。

下記の問題のうち最も重大度の高いものは、メディア フレームワークに重大なセキュリティの脆弱性があるため、リモートの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあることです。重大度の評価は、攻撃対象の端末でその脆弱性が悪用された場合の影響に基づくもので、プラットフォームやサービスでのリスク軽減策が開発目的または不正な回避により無効となっていることを前提としています。

この新たに報告された問題によって実際のユーザー端末が不正使用された報告はありません。Android セキュリティ プラットフォームの保護や Google Play プロテクトについて詳しくは、Android と Google サービスでのリスク軽減策をご覧ください。こうした保護により、Android プラットフォームのセキュリティが改善されます。

注: 最新の無線(OTA)アップデートと Google 端末のファームウェア イメージについての情報は、2018 年 3 月の Pixel / Nexus のセキュリティに関する公開情報でご覧いただけます。

Android と Google サービスでのリスク軽減策

ここでは、Android セキュリティ プラットフォームの保護と Google Play プロテクトのようなサービスの保護によるリスクの軽減について概説します。こうした機能は、Android でセキュリティの脆弱性が悪用される可能性を減らします。

  • 機能強化された最新版の Android プラットフォームでは、Android 上の多くの問題について悪用が困難になります。Google では、すべてのユーザーに対し、できる限り最新バージョンの Android に更新することをおすすめしています。
  • Android セキュリティ チームは、Google Play プロテクトによって脆弱性の悪用を積極的に監視しており、害を及ぼすおそれのあるアプリについてユーザーに警告しています。Google Play プロテクトは、Google モバイル サービスを搭載した端末でデフォルトで有効になっており、Google Play 以外からアプリをインストールするユーザーにとって特に重要です。

セキュリティ パッチレベル 2018-03-01 の脆弱性の詳細

パッチレベル 2018-03-01 に該当するセキュリティ脆弱性の各項目について、下記に詳細を説明します。脆弱性は、影響を受けるコンポーネントごとに分類しています。問題の内容について説明し、CVE、関連する参照先、脆弱性のタイプ重大度、更新対象の AOSP バージョン(該当する場合)を表にまとめています。該当する場合は、バグ ID の欄に、その問題に対処した一般公開されている変更(AOSP の変更の一覧など)へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に記載した番号に、追加の参照へのリンクを設定しています。

メディア フレームワーク

メディア フレームワークの最も重大な脆弱性により、リモートの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2017-13248 A-70349612 RCE 重大 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13249 A-70399408 RCE 重大 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13250 A-71375536 RCE 重大 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13251 A-69269702 EoP 重大 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13252 A-70526702 EoP 8.0、8.1
CVE-2017-13253 A-71389378 EoP 8.0、8.1

システム

システムの最も重大な脆弱性により、近くにいる攻撃者が特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2017-13255 A-68776054 RCE 重大 5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13256 A-68817966 RCE 重大 5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13272 A-67110137 [2] RCE 重大 7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13266 A-69478941 RCE 重大 5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13257 A-67110692 ID 5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13258 A-67863755 ID 5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13259 A-68161546 [2] ID 5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13260 A-69177251 ID 5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13261 A-69177292 ID 5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13262 A-69271284 ID 5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1

セキュリティ パッチレベル 2018-03-05 の脆弱性の詳細

パッチレベル 2018-03-05 に該当するセキュリティ脆弱性の各項目について、下記に詳細を説明します。影響を受けるコンポーネントごとに脆弱性を分類し、CVE、関連する参照先、脆弱性のタイプ重大度、コンポーネント(該当する場合)、更新対象の AOSP バージョン(該当する場合)などの詳細を記載しています。該当する場合は、バグ ID の欄に、その問題に対処した一般公開されている変更(AOSP の変更の一覧など)へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に記載した番号に、追加の参照へのリンクを設定しています。

カーネル コンポーネント

カーネル コンポーネントの最も重大な脆弱性により、悪意のあるローカルアプリによって特権プロセス内で任意のコードが実行されるおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2017-16530 A-69051940
アップストリーム カーネル
EoP UAS ドライバ
CVE-2017-16525 A-69050921
アップストリーム カーネル
EoP USB ドライバ
CVE-2017-16535 A-69052675
アップストリーム カーネル
ID USB ドライバ
CVE-2017-16533 A-69052348
アップストリーム カーネル
ID USB ドライバ
CVE-2017-16531 A-69052055
アップストリーム カーネル
ID USB ドライバ
CVE-2017-16529 A-69051731
アップストリーム カーネル
ID USB サウンド ドライバ

NVIDIA コンポーネント

NVIDIA コンポーネントの最も重大な脆弱性により、悪意のあるローカルアプリによって特権プロセス内で任意のコードが実行されるおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2017-6281 A-66969318*
N-CVE-2017-6281
EoP Libnvomx
CVE-2017-6286 A-64893247*
N-CVE-2017-6286
EoP Libnvomx

Qualcomm コンポーネント

Qualcomm コンポーネントの最も重大な脆弱性により、リモートの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2017-18067 A-68992411
QC-CR#2081734 [2]
RCE 重大 ワイヤレス ネットワーク ドライバ
CVE-2017-15815 A-68992395
QC-CR#2093392
RCE 重大 WLAN
CVE-2017-18068 A-70799990
QC-CR#2072064
EoP WLAN
CVE-2017-18056 A-70237692
QC-CR#2119404
EoP WLAN
CVE-2017-18063 A-68992442
QC-CR#2114776
EoP WLAN
CVE-2017-18064 A-68992438
QC-CR#2114323
EoP WLAN
CVE-2017-15821 A-68992432
QC-CR#2113072
EoP WLAN
CVE-2017-14885 A-70237686
QC-CR#2113758
EoP WLAN
CVE-2017-18069 A-67582682*
QC-CR#2054772 QC-CR#2058471
ID WLAN
CVE-2017-14882 A-68992424
QC-CR#2101439
ID WLAN
CVE-2017-14878 A-70237706
QC-CR#2064580 [2] [3]
DoS ワイヤレス ネットワーク ドライバ

Qualcomm クローズドソース コンポーネント

Qualcomm コンポーネントに影響する脆弱性は次のとおりです。詳細については、該当する Qualcomm AMSS のセキュリティに関する公開情報またはセキュリティ アラートをご覧ください。この一連の問題の重大度は Qualcomm から直接提供されたものです。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2017-17773 A-70221445 QC-CR#2125554* N/A 重大 クローズドソース コンポーネント
CVE-2016-10393 A-68326806 QC-CR#1055934* N/A クローズドソース コンポーネント

一般的な質問と回答

上記の公開情報に対する一般的な質問とその回答について、以下をご確認ください。

1. 上記の問題に対処するように端末が更新されているかどうかを確かめるには、どうすればよいですか?

端末のセキュリティ パッチレベルを確認する方法については、Android のバージョンを確認して更新するをご覧ください。

  • セキュリティ パッチレベル 2018-03-01 以降では、セキュリティ パッチレベル 2018-03-01 に関連するすべての問題に対処しています。
  • セキュリティ パッチレベル 2018-03-05 以降では、セキュリティ パッチレベル 2018-03-05、およびそれ以前のすべてのパッチレベルに関連するすべての問題に対処しています。

このアップデートを組み込んだ端末メーカーは、パッチレベル文字列を以下に設定する必要があります。

  • [ro.build.version.security_patch]:[2018-03-01]
  • [ro.build.version.security_patch]:[2018-03-05]

2. この公開情報に 2 つのセキュリティ パッチレベルがあるのはなぜですか?

この公開情報では、2 つのセキュリティ パッチレベルを定義しています。これは、すべての Android 搭載端末で同様の問題が発生する一部の脆弱性をサブセットとし、Android パートナーが迅速かつ柔軟に修正できるようにするためです。Android パートナーには、この公開情報に掲載されている問題をすべて修正し、最新のセキュリティ パッチレベルを使用することが推奨されています。

  • 2018-03-01 のセキュリティ パッチレベルを使用する端末では、そのセキュリティ パッチレベルに関連するすべての問題と、それ以前のセキュリティに関する公開情報で報告されたすべての問題の修正を含める必要があります。
  • 2018-03-05 以降のセキュリティ パッチレベルを使用する端末には、今回(およびそれ以前)のセキュリティに関する公開情報に掲載された、該当するすべてのパッチを組み込む必要があります。

パートナーには、対処するすべての問題の修正を 1 つのアップデートにまとめて提供することが推奨されています。

3. 「タイプ」列の項目はどういう意味ですか?

脆弱性の詳細の表で「タイプ」列に記載した項目は、セキュリティの脆弱性の分類を示しています。

略語 定義
RCE リモートコード実行
EoP 権限昇格
ID 情報開示
DoS サービス拒否
N/A 該当する分類なし

4. 「参照」列の項目はどういう意味ですか?

脆弱性の詳細の表で「参照」列に記載した項目には、その参照番号が属す組織を示す接頭辞が含まれる場合があります。

接頭辞 参照
A- Android バグ ID
QC- Qualcomm の参照番号
M- MediaTek の参照番号
N- NVIDIA の参照番号
B- Broadcom の参照番号

5. 「参照」列の Android バグ ID の横にある「*」はどういう意味ですか?

公開されていない問題には、「参照」列の Android バグ ID の横に「*」を付けています。この問題のアップデートは、通常、Google デベロッパー サイトから入手できる Nexus 端末用最新バイナリ ドライバに含まれています。

6. セキュリティの脆弱性が、この公開情報と端末やパートナーのセキュリティに関する公開情報(Pixel / Nexus のセキュリティに関する公開情報など)に分けられているのはなぜですか?

Android 搭載端末の最新のセキュリティ パッチレベルを宣言するためには、このセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処が必要です。それ以外の、端末やパートナーのセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処は必須ではありません。SamsungLGE などの Android 搭載端末やチップセットのメーカーには、自社の端末に関して他にも修正がある場合は、自社のセキュリティ関連のウェブサイトや Pixel / Nexus のセキュリティに関する公開情報にその情報を掲載することが推奨されています。

バージョン

バージョン 日付 メモ
1.0 2018 年 3 月 5 日 情報公開
1.1 2018 年 3 月 7 日 公開情報を改訂し AOSP リンクを追加