Android のセキュリティに関する公開情報 - 2018 年 4 月

2018 年 4 月 2 日公開 | 2018 年 4 月 4 日更新

Android のセキュリティに関する公開情報には、Android 搭載端末に影響を与えるセキュリティの脆弱性の詳細を掲載しています。セキュリティ パッチレベル 2018-04-05 以降では、下記のすべての問題に対処しています。端末のセキュリティ パッチレベルを確認する方法については、Android のバージョンを確認して更新するをご覧ください。

Android パートナーには、情報公開の少なくとも 1 か月前にすべての問題が通知されます。Android オープンソース プロジェクト(AOSP)のレポジトリに、各問題に対するソースコードのパッチをリリースしています。また、この公開情報では、これらのパッチへのリンクに加え、AOSP 以外のパッチへのリンクも掲載しています。

下記の問題のうち最も重大度の高いものは、メディア フレームワークに重大なセキュリティの脆弱性があるため、リモートの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあることです。重大度の評価は、攻撃対象の端末でその脆弱性が悪用された場合の影響に基づくもので、プラットフォームやサービスでのリスク軽減策が開発目的または不正な回避により無効となっていることを前提としています。

この新たに報告された問題によって実際のユーザー端末が不正使用された報告はありません。Android セキュリティ プラットフォームの保護や Google Play プロテクトについて詳しくは、Android と Google サービスでのリスク軽減策をご覧ください。こうした保護により、Android プラットフォームのセキュリティが改善されます。

注: 最新の無線(OTA)アップデートと Google 端末のファームウェア イメージについての情報は、2018 年 4 月の Pixel / Nexus のセキュリティに関する公開情報でご覧いただけます。

お知らせ

モバイル端末のセキュリティ強化のために尽力してくださった Qualcomm に感謝いたします。2018-04-05 SPL には、パートナーが注目した 2014~2016 年の Qualcomm に関する公開情報から抜粋した、対処済みのセキュリティ上の問題の累積リストが含まれており、Qualcomm の継続的な取り組みが示されています。

Android と Google サービスでのリスク軽減策

ここでは、Android セキュリティ プラットフォームの保護と Google Play プロテクトのようなサービスの保護によるリスクの軽減について概説します。こうした機能は、Android でセキュリティの脆弱性が悪用される可能性を減らします。

  • 機能強化された最新版の Android プラットフォームでは、Android 上の多くの問題について悪用が困難になります。Google では、すべてのユーザーに対し、できる限り最新バージョンの Android に更新することをおすすめしています。
  • Android セキュリティ チームは、Google Play プロテクトによって脆弱性の悪用を積極的に監視しており、害を及ぼすおそれのあるアプリについてユーザーに警告しています。Google Play プロテクトは、Google モバイル サービスを搭載した端末でデフォルトで有効になっており、Google Play 以外からアプリをインストールするユーザーにとって特に重要です。

セキュリティ パッチレベル 2018-04-01 の脆弱性の詳細

パッチレベル 2018-04-01 に該当するセキュリティ脆弱性の各項目について、下記に詳細を説明します。脆弱性は、影響を受けるコンポーネントごとに分類しています。問題の内容について説明し、CVE、関連する参照先、脆弱性のタイプ重大度、更新対象の AOSP バージョン(該当する場合)を表にまとめています。該当する場合は、バグ ID の欄に、その問題に対処した一般公開されている変更(AOSP の変更の一覧など)へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に記載した番号に、追加の参照へのリンクを設定しています。

Android ランタイム

Android ランタイムの最も重大な脆弱性により、リモートの攻撃者によって、追加権限を取得するためのユーザー操作の要件が回避されるおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2017-13274 A-71360761 EoP 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1

フレームワーク

フレームワークの最も重大な脆弱性により、悪意のあるローカルアプリが、アプリデータを他のアプリから分離するオペレーティング システムの保護を回避するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2017-13275 A-70808908 ID 8.0、8.1

メディア フレームワーク

メディア フレームワークの最も重大な脆弱性により、リモートの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2017-13276 A-70637599 RCE 重大 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13277 A-72165027 RCE 重大 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13278 A-70546581 EoP 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13279 A-68399439 DoS 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13280 A-71361451 DoS 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1

システム

システムの最も重大な脆弱性により、リモートの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2017-13281 A-71603262 RCE 重大 8.0、8.1
CVE-2017-13282 A-71603315 RCE 重大 7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13283 A-71603410 RCE 重大 7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13267 A-69479009 RCE 重大 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13284 A-70808273 EoP 重大 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13285 A-69177126 RCE 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13286 A-69683251 EoP 8.0、8.1
CVE-2017-13287 A-71714464 EoP 6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13288 A-69634768 EoP 8.0、8.1
CVE-2017-13289 A-70398564 EoP 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13290 A-69384124 ID 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13291 A-71603553 DoS 7.0、7.1.1、7.1.2、8.0、8.1

セキュリティ パッチレベル 2018-04-05 の脆弱性の詳細

パッチレベル 2018-04-05 に該当するセキュリティ脆弱性の各項目について、下記に詳細を説明します。影響を受けるコンポーネントごとに脆弱性を分類し、CVE、関連する参照先、脆弱性のタイプ重大度、コンポーネント(該当する場合)、更新対象の AOSP バージョン(該当する場合)などの詳細を記載しています。該当する場合は、バグ ID の欄に、その問題に対処した一般公開されている変更(AOSP の変更の一覧など)へのリンクがあります。

複数の変更が同じバグに関係する場合は、バグ ID の後に続く番号で、追加の参照先へのリンクを示します。

Broadcom コンポーネント

Broadcom コンポーネントの最も重大な脆弱性により、近くにいる攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2017-13292 A-70722061*
B-V2018010201
RCE 重大 bcmdhd ドライバ

カーネル コンポーネント

カーネル コンポーネントの最も重大な脆弱性により、悪意のあるローカルアプリによって特権プロセス内で任意のコードが実行されるおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2017-13293 A-62679701* EoP NFC ドライバ
CVE-2017-16534 A-69052594
アップストリーム カーネル
ID USB

Qualcomm コンポーネント

Qualcomm コンポーネントの最も重大な脆弱性により、近くにいる攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2017-15822 A-71501534
QC-CR#2123807
RCE 重大 Wi-Fi
CVE-2017-17770 A-70237684
QC-CR#2103199 [2]
EoP Binder
CVE-2018-3566 A-72957177
QC-CR#2143847
EoP WLAN
CVE-2018-3563 A-72956842
QC-CR#2143207 [2] [3]
EoP オーディオ ドライバ
CVE-2017-13077 A-72957017
QC-CR#2129237
ID WLAN

Qualcomm クローズドソース コンポーネント

Qualcomm コンポーネントに影響する脆弱性は次のとおりです。詳細については、該当する Qualcomm AMSS のセキュリティに関する公開情報またはセキュリティ アラートをご覧ください。この一連の問題の重大度は Qualcomm から直接提供されたものです。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2017-18071 A-68326813* N/A 重大 クローズドソース コンポーネント
CVE-2017-8274 A-68141335* N/A 重大 クローズドソース コンポーネント
CVE-2017-18146 A-70221449* N/A 重大 クローズドソース コンポーネント
CVE-2017-18128 A-70221448* N/A 重大 クローズドソース コンポーネント
CVE-2018-3592 A-71501105* N/A 重大 クローズドソース コンポーネント
CVE-2018-3591 A-71501103* N/A 重大 クローズドソース コンポーネント
CVE-2017-18074 A-68326816* N/A クローズドソース コンポーネント
CVE-2017-18073 A-68326820* N/A クローズドソース コンポーネント
CVE-2017-18125 A-68326821* N/A クローズドソース コンポーネント
CVE-2017-8275 A-68141336* N/A クローズドソース コンポーネント
CVE-2017-11011 A-68326823* N/A クローズドソース コンポーネント
CVE-2017-18137 A-67712318* N/A クローズドソース コンポーネント
CVE-2017-18134 A-67712320* N/A クローズドソース コンポーネント
CVE-2017-18136 A-68989810* N/A クローズドソース コンポーネント
CVE-2017-18140 A-68989811* N/A クローズドソース コンポーネント
CVE-2017-18135 A-68989813* N/A クローズドソース コンポーネント
CVE-2017-18142 A-68989814* N/A クローズドソース コンポーネント
CVE-2017-18138 A-68989815* N/A クローズドソース コンポーネント
CVE-2017-18139 A-68989819* N/A クローズドソース コンポーネント
CVE-2017-18129 A-68989822* N/A クローズドソース コンポーネント
CVE-2017-18132 A-68989825* N/A クローズドソース コンポーネント
CVE-2017-18133 A-68989826* N/A クローズドソース コンポーネント
CVE-2017-18072 A-68989828* N/A クローズドソース コンポーネント
CVE-2017-18126 A-68989829* N/A クローズドソース コンポーネント
CVE-2017-18144 A-70221450* N/A クローズドソース コンポーネント
CVE-2017-18145 A-70221453* N/A クローズドソース コンポーネント
CVE-2017-18147 A-70221456* N/A クローズドソース コンポーネント
CVE-2017-18130 A-70221460* N/A クローズドソース コンポーネント
CVE-2017-18143 A-70221461* N/A クローズドソース コンポーネント
CVE-2017-18127 A-70221462* N/A クローズドソース コンポーネント
CVE-2018-3590 A-71501106* N/A クローズドソース コンポーネント
CVE-2018-3593 A-71501107* N/A クローズドソース コンポーネント
CVE-2018-3589 A-71501108* N/A クローズドソース コンポーネント
CVE-2018-3594 A-71501112* N/A クローズドソース コンポーネント

Qualcomm クローズドソース コンポーネントの 2014~2016 年の累積アップデート

Qualcomm コンポーネントに影響する次の脆弱性は、2014~2016 年の Qualcomm AMSS のセキュリティに関する公開情報またはセキュリティ アラートを通じて Qualcomm からパートナーに公開されました。これらが今回の「Android のセキュリティに関する公開情報」に追記されているのは、セキュリティ パッチレベルと関連付けるためです(多くの Android 搭載端末では、以前のアップデートですでにこれらの問題に対処しています)。この一連の問題の重大度は Qualcomm から直接提供されたものです。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2014-9996 A-37535090* N/A 重大 クローズドソース コンポーネント
CVE-2014-9971 A-37546253* N/A クローズドソース コンポーネント
CVE-2014-9972 A-37546853* N/A クローズドソース コンポーネント
CVE-2014-10063 A-37534948* N/A クローズドソース コンポーネント
CVE-2014-10057 A-62261099* N/A クローズドソース コンポーネント
CVE-2014-10059 A-62260706* N/A クローズドソース コンポーネント
CVE-2014-10053 A-37544066* N/A クローズドソース コンポーネント
CVE-2014-10054 A-62261100* N/A クローズドソース コンポーネント
CVE-2014-10052 A-62258372* N/A クローズドソース コンポーネント
CVE-2014-10050 A-37546901* N/A クローズドソース コンポーネント
CVE-2014-10055 A-37545605* N/A クローズドソース コンポーネント
CVE-2014-10051 A-37546302* N/A クローズドソース コンポーネント
CVE-2014-10048 A-62258088* N/A クローズドソース コンポーネント
CVE-2014-10062 A-62258373* N/A クローズドソース コンポーネント
CVE-2014-10058 A-62260741* N/A クローズドソース コンポーネント
CVE-2014-10047 A-37538492* N/A クローズドソース コンポーネント
CVE-2014-10045 A-62258536* N/A クローズドソース コンポーネント
CVE-2014-10056 A-62261338* N/A クローズドソース コンポーネント
CVE-2014-9976 A-37534895* N/A クローズドソース コンポーネント
CVE-2014-10043 A-62259947* N/A クローズドソース コンポーネント
CVE-2014-10044 A-62260777* N/A クローズドソース コンポーネント
CVE-2014-10046 A-62261408* N/A クローズドソース コンポーネント
CVE-2014-9981 A-37534949* N/A クローズドソース コンポーネント
CVE-2014-9993 A-37540928* N/A クローズドソース コンポーネント
CVE-2014-9986 A-37534645* N/A クローズドソース コンポーネント
CVE-2014-9994 A-37538493* N/A クローズドソース コンポーネント
CVE-2014-9995 A-37546303* N/A クローズドソース コンポーネント
CVE-2014-9997 A-37546854* N/A クローズドソース コンポーネント
CVE-2014-9988 A-62258089* N/A クローズドソース コンポーネント
CVE-2014-9990 A-62261216* N/A クローズドソース コンポーネント
CVE-2014-9987 A-62261293* N/A クローズドソース コンポーネント
CVE-2014-9989 A-62261380* N/A クローズドソース コンポーネント
CVE-2014-9991 A-62261409* N/A クローズドソース コンポーネント
CVE-2014-10039 A-62261608* N/A クローズドソース コンポーネント
CVE-2014-9985 A-62261609* N/A クローズドソース コンポーネント
CVE-2015-9204 A-37540929* N/A クローズドソース コンポーネント
CVE-2015-0574 A-37546304* N/A クローズドソース コンポーネント
CVE-2015-9205 A-37534696* N/A クローズドソース コンポーネント
CVE-2015-9221 A-37534796* N/A クローズドソース コンポーネント
CVE-2015-9212 A-37535795* N/A クローズドソース コンポーネント
CVE-2015-9210 A-62258538* N/A クローズドソース コンポーネント
CVE-2015-9211 A-62261217* N/A クローズドソース コンポーネント
CVE-2015-9207 A-62261410* N/A クローズドソース コンポーネント
CVE-2015-9202 A-37540473* N/A クローズドソース コンポーネント
CVE-2015-9213 A-37547700* N/A クローズドソース コンポーネント
CVE-2015-9209 A-38193247* N/A クローズドソース コンポーネント
CVE-2015-9203 A-62261218* N/A クローズドソース コンポーネント
CVE-2015-9206 A-62261294* N/A クローズドソース コンポーネント
CVE-2015-9215 A-62251854* N/A クローズドソース コンポーネント
CVE-2015-9216 A-62260780* N/A クローズドソース コンポーネント
CVE-2015-9169 A-37535098* N/A クローズドソース コンポーネント
CVE-2015-9173 A-37536244* N/A クローズドソース コンポーネント
CVE-2015-9179 A-37542567* N/A クローズドソース コンポーネント
CVE-2015-9177 A-37544075* N/A クローズドソース コンポーネント
CVE-2015-9187 A-37544109* N/A クローズドソース コンポーネント
CVE-2015-9162 A-37544110* N/A クローズドソース コンポーネント
CVE-2015-9172 A-37545607* N/A クローズドソース コンポーネント
CVE-2015-9181 A-37546754* N/A クローズドソース コンポーネント
CVE-2015-9219 A-37546859* N/A クローズドソース コンポーネント
CVE-2015-9183 A-37546860* N/A クローズドソース コンポーネント
CVE-2015-9182 A-37546904* N/A クローズドソース コンポーネント
CVE-2015-9185 A-37546952* N/A クローズドソース コンポーネント
CVE-2015-9184 A-37546953* N/A クローズドソース コンポーネント
CVE-2015-9170 A-37546954* N/A クローズドソース コンポーネント
CVE-2015-9175 A-37547404* N/A クローズドソース コンポーネント
CVE-2015-9171 A-37547405* N/A クローズドソース コンポーネント
CVE-2015-9192 A-37547750* N/A クローズドソース コンポーネント
CVE-2015-9208 A-62258540* N/A クローズドソース コンポーネント
CVE-2015-9224 A-62259949* N/A クローズドソース コンポーネント
CVE-2015-9201 A-62260711* N/A クローズドソース コンポーネント
CVE-2015-9200 A-62260779* N/A クローズドソース コンポーネント
CVE-2015-9198 A-62261219* N/A クローズドソース コンポーネント
CVE-2015-9196 A-62261339* N/A クローズドソース コンポーネント
CVE-2015-9199 A-62261411* N/A クローズドソース コンポーネント
CVE-2015-9174 A-62258090* N/A クローズドソース コンポーネント
CVE-2015-9178 A-62258541* N/A クローズドソース コンポーネント
CVE-2015-9180 A-62260712* N/A クローズドソース コンポーネント
CVE-2015-9176 A-62260713* N/A クローズドソース コンポーネント
CVE-2015-9189 A-62260820* N/A クローズドソース コンポーネント
CVE-2015-9188 A-62260821* N/A クローズドソース コンポーネント
CVE-2015-0576 A-37543715* N/A クローズドソース コンポーネント
CVE-2015-9156 A-62260743* N/A クローズドソース コンポーネント
CVE-2015-9195 A-62251855* N/A クローズドソース コンポーネント
CVE-2015-9197 A-62260742* N/A クローズドソース コンポーネント
CVE-2015-9218 A-62260781* N/A クローズドソース コンポーネント
CVE-2015-9217 A-62261295* N/A クローズドソース コンポーネント
CVE-2015-9166 A-62251856* N/A クローズドソース コンポーネント
CVE-2015-9164 A-62258542* N/A クローズドソース コンポーネント
CVE-2015-9190 A-62259744* N/A クローズドソース コンポーネント
CVE-2015-9159 A-62259745* N/A クローズドソース コンポーネント
CVE-2015-9167 A-62259950* N/A クローズドソース コンポーネント
CVE-2015-9191 A-62260394* N/A クローズドソース コンポーネント
CVE-2015-9161 A-62260462* N/A クローズドソース コンポーネント
CVE-2015-9163 A-62260822* N/A クローズドソース コンポーネント
CVE-2015-9158 A-62261381* N/A クローズドソース コンポーネント
CVE-2015-9152 A-37546305* N/A クローズドソース コンポーネント
CVE-2015-9144 A-37540474* N/A クローズドソース コンポーネント
CVE-2015-9165 A-37539224* N/A クローズドソース コンポーネント
CVE-2015-9223 A-37543718* N/A クローズドソース コンポーネント
CVE-2015-9222 A-62258374* N/A クローズドソース コンポーネント
CVE-2015-9193 A-62259951* N/A クローズドソース コンポーネント
CVE-2015-9194 A-62261296* N/A クローズドソース コンポーネント
CVE-2015-9153 A-62260395* N/A クローズドソース コンポーネント
CVE-2015-9151 A-62260396* N/A クローズドソース コンポーネント
CVE-2015-9148 A-62260463* N/A クローズドソース コンポーネント
CVE-2015-9149 A-62260744* N/A クローズドソース コンポーネント
CVE-2015-9146 A-62260745* N/A クローズドソース コンポーネント
CVE-2015-9186 A-62261340* N/A クローズドソース コンポーネント
CVE-2015-9150 A-62261341* N/A クローズドソース コンポーネント
CVE-2015-9147 A-62261488* N/A クローズドソース コンポーネント
CVE-2015-8593 A-37535091* N/A クローズドソース コンポーネント
CVE-2015-9160 A-37546254* N/A クローズドソース コンポーネント
CVE-2015-8594 A-37546855* N/A クローズドソース コンポーネント
CVE-2015-9145 A-37535099* N/A クローズドソース コンポーネント
CVE-2015-9143 A-62260900* N/A クローズドソース コンポーネント
CVE-2015-9157 A-62260934* N/A クローズドソース コンポーネント
CVE-2015-9141 A-62261297* N/A クローズドソース コンポーネント
CVE-2015-9140 A-62259746* N/A クローズドソース コンポーネント
CVE-2015-9135 A-37546950* N/A クローズドソース コンポーネント
CVE-2015-9138 A-62259952* N/A クローズドソース コンポーネント
CVE-2015-9136 A-62260823* N/A クローズドソース コンポーネント
CVE-2015-9137 A-62260975* N/A クローズドソース コンポーネント
CVE-2015-9131 A-37542272* N/A クローズドソース コンポーネント
CVE-2015-9139 A-62251857* N/A クローズドソース コンポーネント
CVE-2015-9130 A-62252820* N/A クローズドソース コンポーネント
CVE-2015-9129 A-62260397* N/A クローズドソース コンポーネント
CVE-2015-9133 A-62260464* N/A クローズドソース コンポーネント
CVE-2015-9127 A-62260824* N/A クローズドソース コンポーネント
CVE-2015-9132 A-62260976* N/A クローズドソース コンポーネント
CVE-2015-9134 A-62261382* N/A クローズドソース コンポーネント
CVE-2015-9128 A-62261610* N/A クローズドソース コンポーネント
CVE-2015-9065 A-37538494* N/A クローズドソース コンポーネント
CVE-2015-9064 A-37546801* N/A クローズドソース コンポーネント
CVE-2015-9063 A-37546802* N/A クローズドソース コンポーネント
CVE-2015-9126 A-62258375* N/A クローズドソース コンポーネント
CVE-2015-9124 A-62252821* N/A クローズドソース コンポーネント
CVE-2015-9142 A-62260901* N/A クローズドソース コンポーネント
CVE-2015-9066 A-37540467* N/A クローズドソース コンポーネント
CVE-2014-9998 A-62260398* N/A クローズドソース コンポーネント
CVE-2015-9220 A-62261299* N/A クローズドソース コンポーネント
CVE-2015-9122 A-62261611* N/A クローズドソース コンポーネント
CVE-2015-9123 A-62259953* N/A クローズドソース コンポーネント
CVE-2015-9118 A-62261220* N/A クローズドソース コンポーネント
CVE-2015-9120 A-62261298* N/A クローズドソース コンポーネント
CVE-2015-9119 A-62261489* N/A クローズドソース コンポーネント
CVE-2015-9116 A-37540934* N/A クローズドソース コンポーネント
CVE-2015-9115 A-37544076* N/A クローズドソース コンポーネント
CVE-2015-9113 A-37544077* N/A クローズドソース コンポーネント
CVE-2015-9112 A-62258091* N/A クローズドソース コンポーネント
CVE-2015-9114 A-62259954* N/A クローズドソース コンポーネント
CVE-2015-9111 A-62260465* N/A クローズドソース コンポーネント
CVE-2015-9108 A-62260714* N/A クローズドソース コンポーネント
CVE-2015-9109 A-62260977* N/A クローズドソース コンポーネント
CVE-2015-9110 A-62261383* N/A クローズドソース コンポーネント
CVE-2016-10492 A-62261300* N/A クローズドソース コンポーネント
CVE-2016-10482 A-62260978* N/A クローズドソース コンポーネント
CVE-2016-10483 A-62258092* N/A クローズドソース コンポーネント
CVE-2016-10489 A-62258093* N/A クローズドソース コンポーネント
CVE-2016-10487 A-62259955* N/A クローズドソース コンポーネント
CVE-2016-10477 A-62260399* N/A クローズドソース コンポーネント
CVE-2016-10485 A-62260902* N/A クローズドソース コンポーネント
CVE-2016-10478 A-62260979* N/A クローズドソース コンポーネント
CVE-2016-10476 A-62260980* N/A クローズドソース コンポーネント
CVE-2016-10475 A-62260981* N/A クローズドソース コンポーネント
CVE-2016-10474 A-62260982* N/A クローズドソース コンポーネント
CVE-2016-10494 A-62261102* N/A クローズドソース コンポーネント
CVE-2016-10484 A-62261342* N/A クローズドソース コンポーネント
CVE-2016-10491 A-62261490* N/A クローズドソース コンポーネント
CVE-2016-10486 A-62267788* N/A クローズドソース コンポーネント
CVE-2016-10472 A-62259956* N/A クローズドソース コンポーネント
CVE-2016-10490 A-62260468* N/A クローズドソース コンポーネント
CVE-2016-10480 A-62261301* N/A クローズドソース コンポーネント
CVE-2016-10467 A-37526814* N/A クローズドソース コンポーネント
CVE-2016-10495 A-62261103* N/A クローズドソース コンポーネント
CVE-2016-10481 A-62260401* N/A クローズドソース コンポーネント
CVE-2016-10479 A-62261412* N/A クローズドソース コンポーネント
CVE-2016-10384 A-37536238* N/A クローズドソース コンポーネント
CVE-2016-10385 A-37544067* N/A クローズドソース コンポーネント
CVE-2016-10452 A-37523164* N/A クローズドソース コンポーネント
CVE-2016-10423 A-37534896* N/A クローズドソース コンポーネント
CVE-2016-10424 A-37540034* N/A クローズドソース コンポーネント
CVE-2016-10449 A-37546861* N/A クローズドソース コンポーネント
CVE-2016-10454 A-37544078* N/A クローズドソース コンポーネント
CVE-2016-10450 A-62260825* N/A クローズドソース コンポーネント
CVE-2016-10451 A-62267789* N/A クローズドソース コンポーネント
CVE-2016-10386 A-37534646* N/A クローズドソース コンポーネント
CVE-2016-10469 A-37542273* N/A クローズドソース コンポーネント
CVE-2016-10440 A-37535092* N/A クローズドソース コンポーネント
CVE-2016-10499 A-62259957* N/A クローズドソース コンポーネント
CVE-2016-10446 A-37547406* N/A クローズドソース コンポーネント
CVE-2016-10473 A-62260746* N/A クローズドソース コンポーネント
CVE-2016-10466 A-62260783* N/A クローズドソース コンポーネント
CVE-2016-10457 A-62260826* N/A クローズドソース コンポーネント
CVE-2016-10442 A-62267790* N/A クローズドソース コンポーネント
CVE-2016-10433 A-37540468* N/A クローズドソース コンポーネント
CVE-2016-10430 A-37540930* N/A クローズドソース コンポーネント
CVE-2016-10445 A-37545608* N/A クローズドソース コンポーネント
CVE-2016-10426 A-62252822* N/A クローズドソース コンポーネント
CVE-2016-10435 A-62260402* N/A クローズドソース コンポーネント
CVE-2016-10425 A-62260983* N/A クローズドソース コンポーネント
CVE-2016-10438 A-62261302* N/A クローズドソース コンポーネント
CVE-2016-10436 A-62261494* N/A クローズドソース コンポーネント
CVE-2016-10439 A-62263656* N/A クローズドソース コンポーネント
CVE-2016-10431 A-37540931* N/A クローズドソース コンポーネント
CVE-2016-10434 A-37540932* N/A クローズドソース コンポーネント
CVE-2016-10432 A-37546902* N/A クローズドソース コンポーネント
CVE-2016-10462 A-37539225* N/A クローズドソース コンポーネント
CVE-2016-10443 A-37540475* N/A クローズドソース コンポーネント
CVE-2016-10427 A-62261495* N/A クローズドソース コンポーネント
CVE-2016-10387 A-32583751* N/A クローズドソース コンポーネント
CVE-2016-10390 A-37536239* N/A クローズドソース コンポーネント
CVE-2016-10498 A-32582870* N/A クローズドソース コンポーネント
CVE-2016-10419 A-32577129* N/A クローズドソース コンポーネント
CVE-2016-10420 A-32579916* N/A クローズドソース コンポーネント
CVE-2016-10429 A-32579411* N/A クローズドソース コンポーネント
CVE-2016-10493 A-32574787* N/A クローズドソース コンポーネント
CVE-2016-10447 A-37542968* N/A クローズドソース コンポーネント
CVE-2016-10444 A-37544163* N/A クローズドソース コンポーネント
CVE-2016-5348 A-37546905* N/A クローズドソース コンポーネント
CVE-2016-10421 A-32579095* N/A クローズドソース コンポーネント
CVE-2016-10455 A-32580964* N/A クローズドソース コンポーネント
CVE-2016-10441 A-32582927* N/A クローズドソース コンポーネント
CVE-2016-10418 A-37547407* N/A クローズドソース コンポーネント
CVE-2016-10417 A-32576287* N/A クローズドソース コンポーネント
CVE-2016-10464 A-32580243* N/A クローズドソース コンポーネント
CVE-2016-10458 A-32583424* N/A クローズドソース コンポーネント
CVE-2016-10471 A-37539226* N/A クローズドソース コンポーネント
CVE-2016-10416 A-62259747* N/A クローズドソース コンポーネント
CVE-2016-10411 A-62260404* N/A クローズドソース コンポーネント
CVE-2016-10496 A-62260469* N/A クローズドソース コンポーネント
CVE-2016-10410 A-62260936* N/A クローズドソース コンポーネント
CVE-2016-10414 A-62260937* N/A クローズドソース コンポーネント
CVE-2016-10461 A-62263657* N/A クローズドソース コンポーネント
CVE-2016-10460 A-62271227* N/A クローズドソース コンポーネント
CVE-2016-10392 A-37544068* N/A クローズドソース コンポーネント
CVE-2016-10409 A-37544164* N/A クローズドソース コンポーネント
CVE-2016-10459 A-62260716* N/A クローズドソース コンポーネント
CVE-2016-10407 A-62261222* N/A クローズドソース コンポーネント
CVE-2016-10406 A-62267791* N/A クローズドソース コンポーネント
CVE-2016-10497 A-62271228* N/A クローズドソース コンポーネント
CVE-2016-10501 A-62261303* N/A クローズドソース コンポーネント
CVE-2016-10381 A-37539788* N/A クローズドソース コンポーネント
CVE-2016-10380 A-37541976* N/A クローズドソース コンポーネント
CVE-2016-10412 A-37536245* N/A クローズドソース コンポーネント
CVE-2016-10415 A-62260403* N/A クローズドソース コンポーネント
CVE-2016-10422 A-37542966* N/A クローズドソース コンポーネント
CVE-2016-10456 A-62261413* N/A クローズドソース コンポーネント
CVE-2016-10428 A-37534697* N/A クローズドソース コンポーネント
CVE-2016-10448 A-62261414* N/A クローズドソース コンポーネント
CVE-2016-10437 A-62260715* N/A クローズドソース コンポーネント

一般的な質問と回答

上記の公開情報に対する一般的な質問とその回答について、以下をご確認ください。

1. 上記の問題に対処するように端末が更新されているかどうかを確かめるには、どうすればよいですか?

端末のセキュリティ パッチレベルを確認する方法については、Android のバージョンを確認して更新するをご覧ください。

  • セキュリティ パッチレベル 2018-04-01 以降では、セキュリティ パッチレベル 2018-04-01 に関連するすべての問題に対処しています。
  • セキュリティ パッチレベル 2018-04-05 以降では、セキュリティ パッチレベル 2018-04-05、およびそれ以前のすべてのパッチレベルに関連するすべての問題に対処しています。

このアップデートを組み込んだ端末メーカーは、パッチレベル文字列を以下に設定する必要があります。

  • [ro.build.version.security_patch]:[2018-04-01]
  • [ro.build.version.security_patch]:[2018-04-05]

2. この公開情報に 2 つのセキュリティ パッチレベルがあるのはなぜですか?

この公開情報では、2 つのセキュリティ パッチレベルを定義しています。これは、すべての Android 搭載端末で同様の問題が発生する一部の脆弱性をサブセットとし、Android パートナーが迅速かつ柔軟に修正できるようにするためです。Android パートナーには、この公開情報に掲載されている問題をすべて修正し、最新のセキュリティ パッチレベルを使用することが推奨されています。

  • 2018-04-01 のセキュリティ パッチレベルを使用する端末では、そのセキュリティ パッチレベルに関連するすべての問題と、それ以前のセキュリティに関する公開情報で報告されたすべての問題の修正を含める必要があります。
  • 2018-04-05 以降のセキュリティ パッチレベルを使用する端末には、今回(およびそれ以前)のセキュリティに関する公開情報に掲載された、該当するすべてのパッチを組み込む必要があります。

パートナーには、対処するすべての問題の修正を 1 つのアップデートにまとめて提供することが推奨されています。

3. 「タイプ」列の項目はどういう意味ですか?

脆弱性の詳細の表で「タイプ」列に記載した項目は、セキュリティの脆弱性の分類を示しています。

略語 定義
RCE リモートコード実行
EoP 権限昇格
ID 情報開示
DoS サービス拒否
N/A 該当する分類なし

4. 「参照」列の項目はどういう意味ですか?

脆弱性の詳細の表で「参照」列に記載した項目には、その参照番号が属す組織を示す接頭辞が含まれる場合があります。

接頭辞 参照
A- Android バグ ID
QC- Qualcomm の参照番号
M- MediaTek の参照番号
N- NVIDIA の参照番号
B- Broadcom の参照番号

5. 「参照」列の Android バグ ID の横にある「*」はどういう意味ですか?

公開されていない問題には、「参照」列の Android バグ ID の横に「*」を付けています。この問題のアップデートは、通常、Google デベロッパー サイトから入手できる Nexus 端末用最新バイナリ ドライバに含まれています。

6. セキュリティの脆弱性が、この公開情報と端末やパートナーのセキュリティに関する公開情報(Pixel / Nexus のセキュリティに関する公開情報など)に分けられているのはなぜですか?

Android 搭載端末の最新のセキュリティ パッチレベルを宣言するためには、このセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処が必要です。それ以外の、端末やパートナーのセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処は必須ではありません。SamsungLGE などの Android 搭載端末やチップセットのメーカーには、自社の端末に関して他にも修正がある場合は、自社のセキュリティ関連のウェブサイトや Pixel / Nexus のセキュリティに関する公開情報にその情報を掲載することが推奨されています。

バージョン

バージョン 日付 メモ
1.0 2018 年 4 月 2 日 情報公開
1.1 2018 年 4 月 4 日 公開情報を改訂し AOSP リンクを追加
1.2 2018 年 5 月 1 日 公開情報を改訂し、「カーネル コンポーネント」セクションから CVE-2017-5754 を削除。CVE-2017-5754 は現在、2018 年 5 月のセキュリティに関する公開情報に掲載されています