Android のセキュリティに関する公開情報 - 2018 年 6 月

2018 年 6 月 4 日公開 | 2018 年 7 月 24 日更新

Android のセキュリティに関する公開情報には、Android 搭載端末に影響を与えるセキュリティの脆弱性の詳細を掲載しています。セキュリティ パッチレベル 2018-06-05 以降では、下記のすべての問題に対処しています。端末のセキュリティ パッチレベルを確認する方法については、Android のバージョンを確認して更新するをご覧ください。

Android パートナーには、情報公開の 1 か月前までにすべての問題が通知されます。Android オープンソース プロジェクト(AOSP)のレポジトリに、下記の問題に対するソースコードのパッチをリリースしています。また、この公開情報では、これらのパッチへのリンクに加え、AOSP 以外のパッチへのリンクも掲載しています。

下記の問題のうち最も重大度の高いものは、メディア フレームワークに重大なセキュリティの脆弱性があるため、リモートの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあることです。重大度の評価は、攻撃対象の端末でその脆弱性が悪用された場合の影響に基づくもので、プラットフォームやサービスでのリスク軽減策が開発目的または不正な回避により無効となっていることを前提としています。

この新たに報告された問題によって実際のユーザー端末が不正使用された報告はありません。Android セキュリティ プラットフォームの保護や Google Play プロテクトについて詳しくは、Android と Google サービスでのリスク軽減策をご覧ください。こうした保護により、Android プラットフォームのセキュリティが改善されます。

注: 最新の無線(OTA)アップデートと Google 端末のファームウェア イメージについての情報は、2018 年 6 月の Pixel / Nexus のセキュリティに関する公開情報でご覧いただけます。

Android と Google サービスでのリスク軽減策

ここでは、Android セキュリティ プラットフォームの保護と Google Play プロテクトのようなサービスの保護によるリスクの軽減について概説します。こうした機能は、Android でセキュリティの脆弱性が悪用される可能性を減らします。

  • 機能強化された最新版の Android プラットフォームでは、Android 上の多くの問題について悪用が困難になります。Google では、すべてのユーザーに対し、できる限り最新バージョンの Android に更新することをおすすめしています。
  • Android セキュリティ チームは、Google Play プロテクトによって脆弱性の悪用を積極的に監視しており、害を及ぼすおそれのあるアプリについてユーザーに警告しています。Google Play プロテクトは、Google モバイル サービスを搭載した端末でデフォルトで有効になっており、Google Play 以外からアプリをインストールするユーザーにとっては特に重要です。

セキュリティ パッチレベル 2018-06-01 の脆弱性の詳細

ここでは、パッチレベル 2018-06-01 に該当するセキュリティ脆弱性の各項目の詳細を説明します。脆弱性は、影響を受けるコンポーネントごとに分類しています。問題の内容について説明し、CVE、関連する参照先、脆弱性のタイプ重大度、更新対象の AOSP バージョン(該当する場合)を表にまとめています。該当する場合は、バグ ID の欄に、その問題に対処した一般公開されている変更(AOSP の変更の一覧など)へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に記載した番号に、追加の参照へのリンクを設定しています。

フレームワーク

フレームワークの最も重大な脆弱性により、悪意のあるローカルアプリによって、追加権限を取得するためのユーザー操作の要件が回避されるおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2018-9338 A-71361168 EoP 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2018-9339 A-71508348 EoP 8.0、8.1
CVE-2017-13227 A-69981710 ID 8.0、8.1
CVE-2018-9340 A-71360999 ID 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1

メディア フレームワーク

メディア フレームワークの最も重大な脆弱性により、リモートの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2018-9341 A-74016277 RCE 重大 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2018-5146 A-77284393* RCE 重大 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13230 A-65483665 RCE 重大 6.0
CVE-2018-9344 A-73172817 EoP 8.1
CVE-2018-9345 A-77238250 ID 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2018-9346 A-77238762 ID 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2018-9347 A-68664359 DoS 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2018-9348 A-68953854 DoS 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1

システム

システムの最も重大な脆弱性により、リモートの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2018-9355 A-74016921 RCE 重大 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2018-9356 A-74950468 RCE 重大 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2018-9357 A-74947856 RCE 重大 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2018-9358 A-73172115 ID 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2018-9359 A-74196706 ID 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2018-9360 A-74201143 ID 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2018-9361 A-74202041 ID 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2018-9362 A-72298611 DoS 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1

セキュリティ パッチレベル 2018-06-05 の脆弱性の詳細

パッチレベル 2018-06-05 に該当するセキュリティ脆弱性の各項目について、下記に詳細を説明します。影響を受けるコンポーネントごとに脆弱性を分類し、CVE、関連する参照先、脆弱性のタイプ重大度、コンポーネント(該当する場合)、更新対象の AOSP バージョン(該当する場合)などの詳細を記載しています。該当する場合は、バグ ID の欄に、その問題に対処した一般公開されている変更(AOSP の変更の一覧など)へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に続く番号で、追加の参照先へのリンクを示します。

Broadcom コンポーネント

Broadcom コンポーネントの最も重大な脆弱性により、リモートの攻撃者が、通常はローカルにインストールされた権限のあるアプリのみがアクセスできるデータにアクセスするおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2018-5383 A-73665456*
B-CS4906525
ID Bluetooth

カーネル コンポーネント

カーネル コンポーネントの最も重大な脆弱性により、悪意のあるローカルアプリによって特権プロセス内で任意のコードが実行されるおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2018-9363 A-65853588* EoP Bluetooth
CVE-2017-17806 A-71752561
アップストリーム カーネル
EoP Crypto
CVE-2017-17807 A-71751178
アップストリーム カーネル
EoP キーリング
CVE-2017-17558 A-71751622
アップストリーム カーネル
EoP USB

LG コンポーネント

LG コンポーネントの最も重大な脆弱性により、ローカルの攻撃者によって、追加権限を取得するためのユーザー操作の要件が回避されるおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2018-9364 A-69163111* EoP 重大 ブートローダー

メディア フレームワーク

メディア フレームワークの最も重大な脆弱性により、悪意のあるローカルアプリによって、追加権限を取得するためのユーザー操作の要件が回避されるおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2018-9409 A-63144992*
QC-CR#2114346
EoP 8.1

MediaTek コンポーネント

MediaTek コンポーネントの最も重大な脆弱性により、リモートの攻撃者によって TCB 内で任意のコードが実行されるおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2018-9373 A-71867247*
M-ALPS03740330
EoP 重大 Mediatek WLAN TDLS
CVE-2018-9366 A-72314499*
M-ALPS03762526
EoP IMSA
CVE-2018-9367 A-72314219*
M-ALPS03762692
EoP Cameratool CCAP
CVE-2018-9368 A-70727446*
M-ALPS03730693
EoP mtksocaudio
CVE-2018-9369 A-70514573*
M-ALPS03666161
EoP ブートローダー
CVE-2018-9370 A-70515281*
M-ALPS03693488
EoP ブートローダー
CVE-2018-9371 A-70515752*
M-ALPS03683903
EoP ブートローダー
CVE-2018-9372 A-70730215*
M-ALPS03676237
EoP ブートローダー

NVIDIA コンポーネント

NVIDIA コンポーネントの最も重大な脆弱性により、悪意のあるローカルアプリによって特権プロセス内で任意のコードが実行されるおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2017-6290 A-69559414*
N-200373895
EoP TLK TrustZone
CVE-2017-6294 A-69316825*
N-200369095
EoP NVIDIA Tegra X1 TZ
CVE-2017-6292 A-69480285*
N-200373888
EoP TLZ TrustZone

Qualcomm コンポーネント

Qualcomm コンポーネントの最も重大な脆弱性により、ローカルの攻撃者によって、追加権限を取得するためのユーザー操作の要件が回避されるおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2017-18158 A-68992400
QC-CR#2104056
EoP 重大 ブートローダー
CVE-2018-3569 A-74237215
QC-CR#2161920
EoP 重大 WLAN ホスト
CVE-2017-18155 A-66734153*
QC-CR#1050893
RCE 重大 ハードウェア コーデック
CVE-2018-5854 A-71800779
QC-CR#2183877
EoP 重大 ブートローダー
CVE-2017-13077 A-63165064* EoP WLAN
CVE-2018-5896 A-70399602*
QC-CR#2163793
ID Diag ドライバ
CVE-2018-5829 A-74237546
QC-CR#2151241
ID WLAN
CVE-2018-5383 A-73665204*
QC-CR#2187697
ID Bluetooth
CVE-2017-18159 A-68992405
QC-CR#2105697 [2] [3] [4] [5] [6] [7] [8] [9]
EoP ブートローダー
CVE-2017-18158 A-67782849*
QC-CR#2104056
EoP ブートローダー
CVE-2018-5835 A-74237148
QC-CR#2153553
EoP WLAN ホスト
CVE-2018-5834 A-74237804
QC-CR#2153326
EoP WLAN
CVE-2018-5831 A-74237606
QC-CR#2161310
EoP GPU ドライバ
CVE-2018-5830 A-74237532
QC-CR#2157917 [2]
EoP WLAN ホスト

Qualcomm クローズドソース コンポーネント

Qualcomm コンポーネントに影響する脆弱性は次のとおりです。詳細については、該当する Qualcomm AMSS のセキュリティに関する公開情報またはセキュリティ アラートをご覧ください。この一連の問題の重大度は Qualcomm から直接提供されたものです。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2017-18157 A-73539080* N/A クローズドソース コンポーネント
CVE-2017-18156 A-73539065* N/A クローズドソース コンポーネント
CVE-2018-5892 A-72951191* N/A クローズドソース コンポーネント
CVE-2018-5891 A-72950815* N/A クローズドソース コンポーネント
CVE-2018-5885 A-72950554* N/A クローズドソース コンポーネント
CVE-2018-5894 A-74236854* N/A クローズドソース コンポーネント
CVE-2018-5884 A-74235510* N/A クローズドソース コンポーネント

システム

システムの最も重大な脆弱性により、リモートの攻撃者が、通常はローカルにインストールされた権限のあるアプリのみがアクセスできるデータにアクセスするおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2018-5383 A-72377774 ID 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1

一般的な質問と回答

上記の公開情報に対する一般的な質問とその回答について、以下をご確認ください。

1. 上記の問題に対処するように端末が更新されているかどうかを確かめるには、どうすればよいですか?

端末のセキュリティ パッチレベルを確認する方法については、Android のバージョンを確認して更新するをご覧ください。

  • セキュリティ パッチレベル 2018-06-01 以降では、セキュリティ パッチレベル 2018-06-01 に関連するすべての問題に対処しています。
  • セキュリティ パッチレベル 2018-06-05 以降では、セキュリティ パッチレベル 2018-06-05、およびそれ以前のすべてのパッチレベルに関連するすべての問題に対処しています。

このアップデートを組み込んだ端末メーカーは、パッチレベル文字列を以下に設定する必要があります。

  • [ro.build.version.security_patch]:[2018-06-01]
  • [ro.build.version.security_patch]:[2018-06-05]

2. この公開情報に 2 つのセキュリティ パッチレベルがあるのはなぜですか?

この公開情報では、2 つのセキュリティ パッチレベルを定義しています。これは、すべての Android 搭載端末で同様の問題が発生する一部の脆弱性をサブセットとし、Android パートナーが迅速かつ柔軟に修正できるようにするためです。Android パートナーには、この公開情報に掲載されている問題をすべて修正し、最新のセキュリティ パッチレベルを使用することが推奨されています。

  • 2018-06-01 のセキュリティ パッチレベルを使用する端末では、そのセキュリティ パッチレベルに関連するすべての問題と、それ以前のセキュリティに関する公開情報で報告されたすべての問題の修正を含める必要があります。
  • 2018-06-05 以降のセキュリティ パッチレベルを使用する端末には、今回(およびそれ以前)のセキュリティに関する公開情報に掲載された、該当するすべてのパッチを組み込む必要があります。

パートナーには、対処するすべての問題の修正を 1 つのアップデートにまとめて提供することが推奨されています。

3. 「タイプ」列の項目はどういう意味ですか?

脆弱性の詳細の表で「タイプ」列に記載した項目は、セキュリティの脆弱性の分類を示しています。

略語 定義
RCE リモートコード実行
EoP 権限昇格
ID 情報開示
DoS サービス拒否
N/A 該当する分類なし

4. 「参照」列の項目はどういう意味ですか?

脆弱性の詳細の表で「参照」列に記載した項目には、その参照番号が属す組織を示す接頭辞が含まれる場合があります。

接頭辞 参照
A- Android バグ ID
QC- Qualcomm の参照番号
M- MediaTek の参照番号
N- NVIDIA の参照番号
B- Broadcom の参照番号

5. 「参照」列の Android バグ ID の横にある「*」はどういう意味ですか?

公開されていない問題には、「参照」列の Android バグ ID の横に「*」を付けています。この問題のアップデートは、Google デベロッパー サイトから入手できる Pixel / Nexus 端末用最新バイナリ ドライバに通常含まれています。

6. セキュリティの脆弱性が、この公開情報と端末やパートナーのセキュリティに関する公開情報(Pixel / Nexus のセキュリティに関する公開情報など)に分けられているのはなぜですか?

Android 搭載端末の最新のセキュリティ パッチレベルを宣言するためには、このセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処が必要です。それ以外の、端末やパートナーのセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処は必須ではありません。SamsungLGE などの Android 搭載端末やチップセットのメーカーには、自社の端末に関して他にも修正がある場合は、自社のセキュリティ関連のウェブサイトや Pixel / Nexus のセキュリティに関する公開情報にその情報を掲載することが推奨されています。

バージョン

バージョン 日付 メモ
1.0 2018 年 6 月 4 日 情報公開
1.1 2018 年 6 月 6 日 公開情報を改訂し AOSP リンクを追加
1.2 2018 年 7 月 24 日 公開情報を改訂し、基準に即した情報開示により CVE-2018-5383 への参照を追加