Android のセキュリティに関する公開情報 - 2018 年 11 月

2018 年 11 月 5 日公開 | 2018 年 11 月 5 日更新

Android のセキュリティに関する公開情報には、Android デバイスに影響を与えるセキュリティの脆弱性の詳細を掲載しています。セキュリティ パッチレベル 2018-11-05 以降では、下記のすべての問題に対処しています。デバイスのセキュリティ パッチレベルを確認する方法については、Android のバージョンを確認して更新する方法をご覧ください。

Android パートナーには、情報公開の 1 か月前までにすべての問題が通知されます。Android オープンソース プロジェクト(AOSP)リポジトリに、下記の問題に対するソースコードのパッチをリリースしています。また、この公開情報では、これらのパッチへのリンクに加え、AOSP 以外のパッチへのリンクも掲載しています。

下記の問題のうち最も重大な脆弱性は、近くにいる攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行できるようになるおそれがあることです。重大度の評価は、攻撃対象のデバイスでその脆弱性が悪用された場合の影響に基づくもので、プラットフォームやサービスでのリスク軽減策が開発目的または不正な回避により無効となっていることを前提としています。

この新たに報告された問題によってユーザーのデバイスが実際に不正使用された報告はありません。Android プラットフォームのセキュリティの向上に役立つ Android セキュリティ プラットフォームでの保護や Google Play プロテクトについて詳しくは、Android と Google サービスでのリスク軽減策をご覧ください。

注: 最新の無線(OTA)アップデートと Google デバイスのファームウェア イメージについての情報は、2018 年 11 月の Pixel / Nexus のセキュリティに関する公開情報でご覧いただけます。

お知らせ

Libxaac ライブラリでセキュリティに関する問題がいくつか見つかりました(CVE-2018-9528、CVE-2018-9529、CVE-2018-9530、CVE-2018-9531、CVE-2018-9532、CVE-2018-9533、CVE-2018-9534、CVE-2018-9535、CVE-2018-9569、CVE-2018-9570、CVE-2018-9571、CVE-2018-9572、CVE-2018-9573、CVE-2018-9574、CVE-2018-9575、CVE-2018-9576、CVE-2018-9577、CVE-2018-9578 など)。

このライブラリは試験運用版としてマークされており、Android の本番ビルドから除外されました。

Android と Google サービスでのリスク軽減策

ここでは、Android セキュリティ プラットフォームGoogle Play プロテクトのようなサービスでの保護によってリスクを軽減する手段について概説します。こうした機能は、Android でセキュリティの脆弱性が悪用される可能性を減らすものです。

  • Android 上の多くの問題の悪用は、Android プラットフォームの最新版で機能が強化されるほど困難になります。Google では、すべてのユーザーに対し、できる限り最新バージョンの Android に更新することをおすすめしています。
  • Android セキュリティ チームは、Google Play プロテクトによって脆弱性の悪用を積極的に監視しており、害を及ぼすおそれのあるアプリについてユーザーに警告しています。Google Play プロテクトは、Google モバイル サービスを搭載したデバイスではデフォルトで有効になっており、Google Play 以外からアプリをインストールするユーザーにとっては特に重要です。

セキュリティ パッチレベル 2018-11-01 の脆弱性の詳細

パッチレベル 2018-11-01 に該当するセキュリティ脆弱性の各項目について、下記で詳しく説明します。脆弱性は、影響を受けるコンポーネントごとに分類しています。問題の内容について説明し、CVE、関連する参照先、脆弱性のタイプ重大度、更新対象の AOSP バージョン(該当する場合)を表にまとめています。該当する場合は、バグ ID の欄に、その問題の対処法として一般公開されている変更内容(AOSP の変更の一覧など)へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に記載した番号に、追加の参照へのリンクを設定しています。

フレームワーク

フレームワークの最も重大な脆弱性により、悪意のあるローカルアプリによって特権プロセス内で任意のコードが実行されるおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2018-9522 A-112550251 EoP 9
CVE-2018-9524 A-34170870 EoP 7.0、7.1.1、7.1.2、8.0、8.1
CVE-2018-9525 A-111330641 EoP 9

メディア フレームワーク

メディア フレームワークの最も重大な脆弱性により、リモートの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2018-9527 A-112159345 RCE 重大 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9531 A-112661641 RCE 重大 9
CVE-2018-9536 A-112662184 EoP 重大 9
CVE-2018-9537 A-112891564 EoP 重大 9
CVE-2018-9521 A-111874331 RCE 9
CVE-2018-9539 A-113027383 EoP 8.0、8.1、9

システム

システムの最も重大な脆弱性により、リモートの攻撃者が、通常はローカルにインストールされた権限のあるアプリのみがアクセスできるデータにアクセスするおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2018-9540 A-111450417 ID 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9542 A-111896861 ID 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9543 A-112868088 ID 9
CVE-2018-9544 A-113037220 ID 9
CVE-2018-9545 A-113111784 ID 9
CVE-2018-9541 A-111450531 ID 9
ID 7.0、7.1.1、7.1.2、8.0、8.1

セキュリティ パッチレベル 2018-11-05 の脆弱性の詳細

パッチレベル 2018-11-05 に該当するセキュリティ脆弱性の各項目について、下記で詳しく説明します。影響を受けるコンポーネントごとに脆弱性を分類し、CVE、関連する参照先、脆弱性のタイプ重大度、コンポーネント(該当する場合)、更新対象の AOSP バージョン(該当する場合)などの詳細を記載しています。該当する場合は、バグ ID の欄に、その問題の対処法として一般公開されている変更内容(AOSP の変更の一覧など)へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に番号を併記して、追加の参照先へのリンクを設定しています。

フレームワーク

フレームワークの最も重大な脆弱性により、悪意のあるローカルアプリによって特権プロセス内で任意のコードが実行されるおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2018-9523 A-112859604 EoP 7.0、7.1.1、7.1.2、8.0、8.1、9

Qualcomm コンポーネント

Qualcomm コンポーネントの最も重大な脆弱性により、悪意のあるローカルアプリによって特権プロセス内で任意のコードが実行されるおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2017-15818 A-68992408
QC-CR#2078580
N/A EcoSystem
CVE-2018-11995 A-71501677
QC-CR#2129639
N/A Bootloader
CVE-2018-11905 A-112277889
QC-CR#2090797
N/A DSP_Services

Qualcomm クローズドソース コンポーネント

Qualcomm コンポーネントに影響する脆弱性は次のとおりです。詳細については、該当する Qualcomm AMSS のセキュリティに関する公開情報またはセキュリティ アラートをご覧ください。これらの問題の重大度の評価は、Qualcomm から直接提供されたものです。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2017-18317 A-78244877 * N/A 重大 クローズドソース コンポーネント
CVE-2018-5912 A-79420111 * N/A 重大 クローズドソース コンポーネント
CVE-2018-11264 A-109677962 * N/A 重大 クローズドソース コンポーネント
CVE-2016-10502 A-68326808 * N/A クローズドソース コンポーネント
CVE-2017-18316 A-78240714 * N/A クローズドソース コンポーネント
CVE-2017-18318 A-78240675 * N/A クローズドソース コンポーネント
CVE-2017-18315 A-78241957 * N/A クローズドソース コンポーネント
CVE-2018-11994 A-72950294 * N/A クローズドソース コンポーネント
CVE-2018-11996 A-74235967 * N/A クローズドソース コンポーネント
CVE-2018-5870 A-77484722 * N/A クローズドソース コンポーネント
CVE-2018-5877 A-77484786 * N/A クローズドソース コンポーネント
CVE-2018-5916 A-79420492 * N/A クローズドソース コンポーネント
CVE-2018-5917 A-79420096 * N/A クローズドソース コンポーネント
CVE-2018-11269 A-109678529 * N/A クローズドソース コンポーネント

一般的な質問と回答

上記の公開情報に対する一般的な質問についての回答は以下のとおりです。

1. 上記の問題に対処するようにデバイスが更新されているかどうかを確かめるには、どうすればよいですか?

デバイスのセキュリティ パッチレベルを確認する方法については、Android のバージョンを確認して更新する方法をご覧ください。

  • セキュリティ パッチレベル 2018-11-01 以降では、セキュリティ パッチレベル 2018-11-01 に関連するすべての問題に対処しています。
  • セキュリティ パッチレベル 2018-11-05 以降では、セキュリティ パッチレベル 2018-11-05、およびそれ以前のすべてのパッチレベルに関連するすべての問題に対処しています。

デバイス メーカーは、こうしたアップデートを組み込む場合、パッチレベル文字列を以下のとおり設定する必要があります。

  • [ro.build.version.security_patch]:[2018-11-01]
  • [ro.build.version.security_patch]:[2018-11-05]

2. この公開情報に 2 つのセキュリティ パッチレベルがあるのはなぜですか?

この公開情報では、2 つのセキュリティ パッチレベルを定義しています。これは、すべての Android デバイスにまたがる同様の脆弱性をひとまとめにして、Android パートナーが迅速かつ柔軟に修正できるようにするためです。Android パートナーは、この公開情報に掲載されている問題をすべて修正し、最新のセキュリティ パッチレベルを使用することが推奨されています。

  • 2018-11-01 のセキュリティ パッチレベルを使用するデバイスでは、そのセキュリティ パッチレベルに関連するすべての問題と、それ以前のセキュリティに関する公開情報で報告されたすべての問題の修正を含める必要があります。
  • 2018-11-05 以降のセキュリティ パッチレベルを使用するデバイスには、今回(およびそれ以前)のセキュリティに関する公開情報に掲載された、該当するすべてのパッチを組み込む必要があります。

パートナーは、対処する問題すべてについて、修正を 1 つのアップデートにまとめて提供することが推奨されます。

3. 「タイプ」列の項目はどういう意味ですか?

脆弱性の詳細の表で「タイプ」列に記載した項目は、セキュリティの脆弱性の分類を示しています。

略語 定義
RCE リモートコード実行
EoP 権限昇格
ID 情報開示
DoS サービス拒否
N/A 該当する分類なし

4. 「参照」列の項目はどういう意味ですか?

脆弱性の詳細の表で「参照」列に記載した項目には、その参照番号が属す組織を示す接頭辞が含まれる場合があります。

接頭辞 参照
A- Android バグ ID
QC- Qualcomm の参照番号
M- MediaTek の参照番号
N- NVIDIA の参照番号
B- Broadcom の参照番号

5. 「参照」列の Android バグ ID の横にある「*」はどういう意味ですか?

公開されていない問題には、「参照」列の Android バグ ID の横に「*」を付けています。この問題のアップデートは、Google デベロッパー サイトから入手できる Pixel / Nexus デバイス用最新バイナリ ドライバに通常含まれています。

6. セキュリティの脆弱性が、この公開情報とデバイスやパートナーのセキュリティに関する公開情報(Pixel / Nexus のセキュリティに関する公開情報など)に分けられているのはなぜですか?

Android デバイスの最新のセキュリティ パッチレベルを宣言するためには、このセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処が必要となります。それ以外の、デバイスやパートナーのセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処は必要ありません。SamsungLGE などの Android デバイスやチップセットのメーカーは、自社のデバイスに関して他にも修正がある場合、その情報を自社のセキュリティ関連のウェブサイトや Pixel / Nexus のセキュリティに関する公開情報に掲載することが推奨されています。

バージョン

バージョン 日付 メモ
1.0 2018 年 11 月 5 日 情報公開
1.1 2018 年 11 月 5 日 公開情報を改訂し AOSP リンクを追加