Google 致力于为黑人社区推动种族平等。查看具体举措

Android 安全公告 - 2021 年 1 月

发布时间:2021 年 1 月 4 日 | 更新时间:2021 年 1 月 7 日

本 Android 安全公告详细介绍了会影响 Android 设备的安全漏洞。如果安全补丁程序级别是 2021-01-05 或更高级别,就意味着已解决本公告中所述的所有问题。 如需了解如何查看设备的安全补丁程序级别,请参阅查看并更新 Android 版本

Android 合作伙伴在本公告发布前至少一个月就已收到所有问题的相关通知。我们已将针对这些问题的源代码补丁程序发布到 Android 开源项目 (AOSP) 代码库中,并在本公告中提供了相应链接。本公告中还提供了指向 AOSP 之外的补丁程序的链接。

这些问题中危险性最高的是系统组件中的一个严重程度为“严重”的安全漏洞,远程攻击者可以利用该漏洞通过蓄意创建的传输内容在特权进程环境中执行任意代码。 严重程度评估的依据是漏洞被利用后可能会对受影响的设备造成的影响(假设相关平台和服务缓解措施被成功规避或出于开发目的而被停用)。

请参阅 Android 和 Google Play 保护机制提供的缓解措施部分,详细了解有助于提高 Android 平台安全性的 Android 安全平台防护功能和 Google Play 保护机制。

Android 和 Google 服务缓解措施

这一部分总结了 Android 安全平台和服务防护功能(如 Google Play 保护机制)提供的缓解措施。这些功能有助于降低 Android 上的安全漏洞被成功利用的可能性。

  • 较高版本的 Android 平台中提供的增强功能让攻击者更加难以利用 Android 上存在的许多问题。我们建议所有用户都尽可能更新到最新版 Android。
  • Android 安全团队会积极利用 Google Play 保护机制监控滥用行为,并会在发现潜在有害应用时向用户发出警告。在安装有 Google 移动服务的设备上,Google Play 保护机制会默认处于启用状态,对于从 Google Play 以外的来源安装应用的用户来说,该功能尤为重要。

2021-01-01 安全补丁程序级别漏洞详情

我们在下面提供了 2021-01-01 补丁程序级别涵盖的每个安全漏洞的详细信息。 漏洞列在所影响的组件下,具体问题会在以下表格中说明,包括 CVE ID、相关参考编号、漏洞类型严重程度和已更新的 AOSP 版本(若有)。如果有解决相应问题的公开更改记录(例如 AOSP 代码更改列表),我们会将 Bug ID 链接到该记录。如果某个 Bug 有多条相关的代码更改记录,我们还会通过 Bug ID 后面的数字链接到更多参考编号。搭载 Android 10 及更高版本的设备可能会收到安全更新以及 Google Play 系统更新

框架

这一部分中最严重的漏洞可让远程攻击者利用蓄意创建的字符串发起永久性拒绝服务攻击。

CVE 参考编号 类型 严重程度 已更新的 AOSP 版本
CVE-2021-0313
A-170968514 DoS 严重 8.0、8.1、9、10、11
CVE-2021-0303
A-170407229 EoP 11
CVE-2021-0306
A-154505240 [2] EoP 8.0、8.1、9、10、11
CVE-2021-0307
A-155648771 [2] EoP 10、11
CVE-2021-0310
A-170212632 EoP 11
CVE-2021-0315
A-169763814 EoP 8.0、8.1、9、10、11
CVE-2021-0317
A-168319670 EoP 8.0、8.1、9、10、11
CVE-2021-0318
A-168211968 EoP 8.1、9、10、11
CVE-2021-0319
A-167244818 EoP 8.0、8.1、9、10、11
CVE-2021-0304
A-162738636 ID 8.0、8.1、9、10
CVE-2021-0309
A-158480899 ID 8.0、8.1、9、10、11
CVE-2021-0321
A-166667403 ID 11
CVE-2021-0322
A-159145361 [2] ID 9、10、11
CVE-2019-9376
A-129287265 DoS 8.0、8.1、9
CVE-2020-15999
A-171232105 RCE 8.0、8.1、9、10、11

媒体框架

这一部分中最严重的漏洞可让远程攻击者利用蓄意创建的文件在特权进程环境中执行任意代码。

CVE 参考编号 类型 严重程度 已更新的 AOSP 版本
CVE-2016-6328
A-162602132 RCE 8.0、8.1、9、10、11
CVE-2021-0311
A-170240631 ID 8.0、8.1、9、10、11
CVE-2021-0312
A-170583712 ID 8.0、8.1、9、10、11

系统

这一部分中最严重的漏洞可让远程攻击者利用蓄意创建的传输在特权进程环境中执行任意代码。

CVE 参考编号 类型 严重程度 已更新的 AOSP 版本
CVE-2021-0316
A-168802990 RCE 严重 8.0、8.1、9、10、11
CVE-2020-0471
A-169327567 EoP 8.0、8.1、9、10、11
CVE-2021-0308
A-158063095 EoP 8.0、8.1、9、10、11
CVE-2021-0320
A-169933423 ID 10、11

Google Play 系统更新

以下问题包含在 Project Mainline 组件中。

组件 CVE
媒体框架组件 CVE-2021-0311、CVE-2021-0312

2021-01-05 安全补丁程序级别漏洞详情

我们在下面提供了 2021-01-05 补丁程序级别涵盖的每个安全漏洞的详细信息。漏洞列在所影响的组件下,具体问题会在以下表格中说明,包括 CVE ID、相关参考编号、漏洞类型严重程度和已更新的 AOSP 版本(若有)。如果有解决相应问题的公开更改记录(例如 AOSP 代码更改列表),我们会将 Bug ID 链接到该记录。如果某个 Bug 有多条相关的代码更改记录,我们还会通过 Bug ID 后面的数字链接到更多参考编号。

内核组件

这一部分中最严重的漏洞可让本地恶意应用绕过将应用数据与其他应用分隔开来的操作系统防护功能。

CVE 参考编号 类型 严重程度 组件
CVE-2020-10732 A-170658976
上游内核
ID ELF 核心转储
CVE-2020-10766 A-169505740
上游内核
ID 推测执行
CVE-2020-10767 A-156766097
上游内核
ID Linux 内核

MediaTek 组件

此漏洞会影响 MediaTek 组件,请直接从 MediaTek 了解更多详细信息。此漏洞的严重程度评估是由 MediaTek 直接提供的。

CVE 参考编号 严重程度 组件
CVE-2021-0301 A-172514667
M-ALPS05342361*
ged

Qualcomm 组件

以下漏洞会影响 Qualcomm 组件,相应的 Qualcomm 安全公告或安全提醒中对这些漏洞进行了详细说明。这些漏洞的严重程度评估是由 Qualcomm 直接提供的。

CVE 参考编号 严重程度 组件
CVE-2020-11233 A-170138863
QC-CR#2257789
内核
CVE-2020-11239 A-168722551
QC-CR#2744826
显示
CVE-2020-11240 A-170138526
QC-CR#2702760 [2] [3]
相机
CVE-2020-11250 A-170139097
QC-CR#2734543
音频
CVE-2020-11261 A-161373974
QC-CR#2742124
显示
CVE-2020-11262 A-170138789
QC-CR#2742711
显示

Qualcomm 闭源组件

以下漏洞会影响 Qualcomm 闭源组件,相应的 Qualcomm 安全公告或安全提醒中对这些漏洞进行了详细说明。这些漏洞的严重程度评估是由 Qualcomm 直接提供的。

CVE 参考编号 严重程度 组件
CVE-2020-11134 A-170138862* 严重 闭源组件
CVE-2020-11182 A-168722721* 严重 闭源组件
CVE-2020-11126 A-170139227* 闭源组件
CVE-2020-11159
A-170138666* 闭源组件
CVE-2020-11181 A-168051034* 闭源组件
CVE-2020-11235 A-170138866* 闭源组件
CVE-2020-11238 A-170139099* 闭源组件
CVE-2020-11241 A-170139229* 闭源组件
CVE-2020-11260 A-168918332* 闭源组件

常见问题和解答

这一部分解答了用户在阅读本公告后可能会提出的常见问题。

1. 如何确定我的设备是否已通过更新解决这些问题?

如需了解如何查看设备的安全补丁程序级别,请参阅查看并更新 Android 版本

  • 如果安全补丁程序级别是 2021-01-01 或更新,就意味着已解决 2021-01-01 安全补丁程序级别涵盖的所有问题。
  • 如果安全补丁程序级别是 2021-01-05 或更新,就意味着已解决 2021-01-05 以及之前的所有安全补丁程序级别涵盖的所有问题。

预装这些更新的设备制造商应将补丁程序字符串级别设为:

  • [ro.build.version.security_patch]:[2021-01-01]
  • [ro.build.version.security_patch]:[2021-01-05]

对于某些搭载 Android 10 或更高版本的设备,Google Play 系统更新的日期字符串将与 2021-01-01 安全补丁程序级别一致。 如需详细了解如何安装安全更新,请查看这篇文章

2. 为何本公告有 2 个安全补丁程序级别?

本公告之所以有 2 个安全补丁程序级别,是为了让 Android 合作伙伴能够灵活地、更快速地修复在各种 Android 设备上类似的一系列漏洞。我们建议 Android 合作伙伴修复本公告中列出的所有问题并使用最新的安全补丁程序级别。

  • 如果设备使用的是 2021-01-01 这一安全补丁程序级别,就必须包含该安全补丁程序级别涵盖的所有问题以及之前的安全公告中报告的所有问题的修复程序。
  • 如果设备使用的是 2021-01-05 或更新的安全补丁程序级别,就必须包含本安全公告(以及之前的安全公告)中的所有适用补丁程序。

我们建议合作伙伴将要解决的全部问题的修复程序打包到一个更新中。

3.“类型”列中的条目表示什么意思?

在漏洞详情表内,“类型”列中的条目是安全漏洞的分类。

缩写词 定义
RCE 远程代码执行
EoP 提权
ID 信息披露
DoS 拒绝服务攻击
没有分类

4. “参考编号”列中的条目表示什么意思?

在漏洞详情表内,“参考编号”列中的条目可能包含用于标识参考编号值所属组织的前缀。

前缀 参考编号
A- Android Bug ID
QC- Qualcomm 参考编号
M- MediaTek 参考编号
N- NVIDIA 参考编号
B- Broadcom 参考编号

5. 在“参考编号”列中,Android Bug ID 旁边的 * 表示什么意思?

如果问题尚未公开发布,在“参考编号”列中,相应 Android Bug ID 旁边就会显示 *。Google Developers 网站上针对 Pixel 设备提供的最新二进制驱动程序中通常包含旨在解决相应问题的更新。

6. 为什么将安全漏洞拆分到本公告和设备 /合作伙伴安全公告(如 Pixel 公告)中?

如需在 Android 设备上声明最新的安全补丁程序级别,必须修复本安全公告中记录的安全漏洞。但在声明安全补丁程序级别时,并不是必须修复设备/ 合作伙伴安全公告中记录的其他安全漏洞。Android 设备和芯片组制造商可能也会发布针对其产品的安全漏洞详情,例如:Google华为LGE摩托罗拉诺基亚三星

版本

版本 日期 备注
1.0 2021 年 1 月 4 日 发布了本公告
1.1 2021 年 1 月 7 日 在本公告中添加了 AOSP 链接,并修改了 CVE 表格