Biuletyn dotyczący bezpieczeństwa Androida – kwiecień 2022 r

Opublikowano 4 kwietnia 2022 | Zaktualizowano 5 kwietnia 2022 r

Biuletyn bezpieczeństwa systemu Android zawiera szczegółowe informacje na temat luk w zabezpieczeniach urządzeń z systemem Android. Poprawki zabezpieczeń z wersji 2022-04-05 lub nowszej rozwiązują wszystkie te problemy. Aby dowiedzieć się, jak sprawdzić poziom poprawek zabezpieczeń urządzenia, zobacz Sprawdzanie i aktualizowanie wersji Androida .

Partnerzy Androida są powiadamiani o wszystkich problemach co najmniej na miesiąc przed publikacją. Poprawki kodu źródłowego rozwiązujące te problemy zostały udostępnione w repozytorium Android Open Source Project (AOSP), a linki do nich znajdują się w tym biuletynie. Biuletyn ten zawiera także łącza do poprawek spoza AOSP.

Najpoważniejszym z tych problemów jest duża luka w zabezpieczeniach komponentu Framework, która może prowadzić do lokalnej eskalacji uprawnień bez konieczności posiadania dodatkowych uprawnień do wykonywania. Ocena ważności opiera się na możliwym wpływie wykorzystania luki na urządzenie, którego dotyczy luka, przy założeniu, że zabezpieczenia platformy i usług zostaną wyłączone na potrzeby programowania lub jeśli uda się je obejść.

Szczegółowe informacje na temat zabezpieczeń platformy zabezpieczeń Androida i Google Play Protect , które poprawiają bezpieczeństwo platformy Android , można znaleźć w sekcji Środki zaradcze dotyczące systemów Android i Google Play Protect.

Ograniczenia dotyczące usług Android i Google

To jest podsumowanie środków zaradczych zapewnianych przez platformę bezpieczeństwa Androida i zabezpieczenia usług, takie jak Google Play Protect . Funkcje te zmniejszają prawdopodobieństwo skutecznego wykorzystania luk w zabezpieczeniach systemu Android.

  • Eksploatację wielu problemów na Androidzie utrudniają ulepszenia w nowszych wersjach platformy Android. Zachęcamy wszystkich użytkowników, jeśli to możliwe, do aktualizacji do najnowszej wersji Androida.
  • Zespół ds. bezpieczeństwa Androida aktywnie monitoruje nadużycia za pośrednictwem Google Play Protect i ostrzega użytkowników przed potencjalnie szkodliwymi aplikacjami . Usługa Google Play Protect jest domyślnie włączona na urządzeniach z Usługami mobilnymi Google i jest szczególnie ważna dla użytkowników instalujących aplikacje spoza Google Play.

2022-04-01 Szczegóły luki w zabezpieczeniach na poziomie poprawki zabezpieczeń

W poniższych sekcjach podajemy szczegółowe informacje na temat każdej luki w zabezpieczeniach, która ma zastosowanie do poziomu poprawki 2022-04-01. Luki są pogrupowane według komponentu, którego dotyczą. Problemy opisano w tabelach poniżej i obejmują identyfikator CVE, powiązane odniesienia, typ luki , wagę i zaktualizowane wersje AOSP (w stosownych przypadkach). Jeśli jest to możliwe, łączymy publiczną zmianę, która rozwiązała problem, z identyfikatorem błędu, np. listą zmian AOSP. Gdy wiele zmian dotyczy jednego błędu, dodatkowe odniesienia są powiązane z liczbami następującymi po identyfikatorze błędu. Urządzenia z Androidem 10 i nowszym mogą otrzymywać aktualizacje zabezpieczeń, a także aktualizacje systemu Google Play .

Struktura

Najpoważniejsza luka w tej sekcji może prowadzić do lokalnej eskalacji uprawnień bez konieczności posiadania dodatkowych uprawnień do wykonywania.

CVE Bibliografia Typ Powaga Zaktualizowane wersje AOSP
CVE-2021-0694 A-183147114 EoP Wysoki 11
CVE-2021-39794 A-205836329 EoP Wysoki 11, 12, 12L
CVE-2021-39796 A-205595291 EoP Wysoki 10, 11, 12, 12L
CVE-2021-39797 A-209607104 EoP Wysoki 12, 12L
CVE-2021-39798 A-213169612 EoP Wysoki 12, 12L
CVE-2021-39799 A-200288596 EoP Wysoki 12, 12L

Ramy medialne

Najpoważniejsza luka w tej sekcji może prowadzić do zdalnego ujawnienia informacji bez konieczności posiadania dodatkowych uprawnień do wykonywania.

CVE Bibliografia Typ Powaga Zaktualizowane wersje AOSP
CVE-2021-39803 A-193790350 ID Wysoki 10, 11, 12, 12L
CVE-2021-39804 A-215002587 DoS Wysoki 11, 12, 12L

System

Najpoważniejsza luka w tej sekcji może prowadzić do lokalnej eskalacji uprawnień bez konieczności posiadania dodatkowych uprawnień do wykonywania.

CVE Bibliografia Typ Powaga Zaktualizowane wersje AOSP
CVE-2021-39808 A-209966086 EoP Wysoki 10, 11, 12
CVE-2021-39805 A-212694559 ID Wysoki 12, 12L
CVE-2021-39809 A-205837191 ID Wysoki 10, 11, 12, 12L

Aktualizacje systemu Google Play

Następujące zagadnienia są zawarte w składnikach Project Mainline.

Część CVE
Dostawca multimediów CVE-2021-39795
Kodeki multimedialne CVE-2021-39803

2022-04-05 Szczegóły luki w zabezpieczeniach na poziomie poprawki zabezpieczeń

W poniższych sekcjach podajemy szczegółowe informacje na temat każdej luki w zabezpieczeniach, która ma zastosowanie do poziomu poprawki z dnia 2022-04-05. Luki są pogrupowane według komponentu, którego dotyczą. Problemy opisano w tabelach poniżej i obejmują identyfikator CVE, powiązane odniesienia, typ luki , wagę i zaktualizowane wersje AOSP (w stosownych przypadkach). Jeśli jest to możliwe, łączymy publiczną zmianę, która rozwiązała problem, z identyfikatorem błędu, np. listą zmian AOSP. Gdy wiele zmian dotyczy jednego błędu, dodatkowe odniesienia są powiązane z liczbami następującymi po identyfikatorze błędu.

System

Najpoważniejsza luka w tej sekcji może prowadzić do lokalnej eskalacji uprawnień z konta Gość bez konieczności posiadania dodatkowych uprawnień do wykonywania.

CVE Bibliografia Typ Powaga Zaktualizowane wersje AOSP
CVE-2021-39807 A-209446496 EoP Wysoki 10, 11, 12, 12L

Składniki jądra

Najpoważniejsza luka w tej sekcji może prowadzić do lokalnej eskalacji uprawnień bez konieczności posiadania dodatkowych uprawnień do wykonywania.

CVE Bibliografia Typ Powaga Część
CVE-2021-0707 A-155756045
Jądro nadrzędne
EoP Wysoki dma-buf
CVE-2021-39801 A-209791720
Jądro nadrzędne [ 2 ] [ 3 ]
EoP Wysoki JON
CVE-2021-39802 A-213339151
Jądro nadrzędne [ 2 ] [ 3 ] [ 4 ]
EoP Wysoki Zarządzanie pamięcią
CVE-2021-39800 A-208277166
Jądro nadrzędne [ 2 ] [ 3 ]
ID Wysoki JON

Komponenty MediaTeka

Luki te dotyczą komponentów MediaTek. Dalsze szczegóły można uzyskać bezpośrednio od MediaTek. Ocena wagi tych problemów jest przeprowadzana bezpośrednio przez firmę MediaTek.

CVE Bibliografia Powaga Część
CVE-2022-20081
A-218242055
M-ALPS06461919 *
Wysoki A-GPS
CVE-2021-25477
A-220262213
M-MOLY00684727 *
Wysoki Modem LTE RRC

Komponenty Qualcomma

Luki te dotyczą komponentów Qualcomm i są szczegółowo opisane w odpowiednim biuletynie bezpieczeństwa Qualcomm lub alercie bezpieczeństwa. Oceny istotności tych problemów dokonuje bezpośrednio Qualcomm.

CVE Bibliografia Powaga Część
CVE-2021-35081
A-213239834
QC-CR#3028274
Krytyczny WLAN
CVE-2021-35112
A-201574693
QC-CR#3049280
Krytyczny Wyświetlacz
CVE-2021-35123
A-213239948
QC-CR#3032290
Krytyczny Bluetooth
CVE-2021-30334
A-213239835
QC-CR#2963049 [ 2 ]
QC-CR#3052789
Wysoki Wyświetlacz
CVE-2021-35091
A-204905109
QC-CR#3008877
Wysoki Wyświetlacz
CVE-2021-35095 A-204905206
QC-CR#2996895
Wysoki Jądro
CVE-2021-35130
A-213240026
QC-CR#3057133
Wysoki Wyświetlacz

Komponenty Qualcomm o zamkniętym kodzie źródłowym

Luki te dotyczą komponentów Qualcomm o zamkniętym kodzie źródłowym i są opisane bardziej szczegółowo w odpowiednim biuletynie bezpieczeństwa Qualcomm lub alercie bezpieczeństwa. Oceny istotności tych problemów dokonuje bezpośrednio Qualcomm.

CVE Bibliografia Powaga Część
CVE-2021-30339
A-202025975 * Krytyczny Komponent o zamkniętym źródle
CVE-2021-30341
A-202024969 * Krytyczny Komponent o zamkniętym źródle
CVE-2021-30342
A-202025860 * Krytyczny Komponent o zamkniętym źródle
CVE-2021-30343
A-202025978 * Krytyczny Komponent o zamkniętym źródle
CVE-2021-30347 A-202025598 * Krytyczny Komponent o zamkniętym źródle
CVE-2021-35104 A-213240044 * Krytyczny Komponent o zamkniętym źródle
CVE-2021-30281 A-202025858 * Wysoki Komponent o zamkniętym źródle
CVE-2021-30338
A-202025859 * Wysoki Komponent o zamkniętym źródle
CVE-2021-30340 A-202025736 * Wysoki Komponent o zamkniętym źródle
CVE-2021-30344 A-192612963 * Wysoki Komponent o zamkniętym źródle
CVE-2021-30345 A-202025737 * Wysoki Komponent o zamkniętym źródle
CVE-2021-30346 A-202025862 * Wysoki Komponent o zamkniętym źródle
CVE-2021-30349 A-202025797 * Wysoki Komponent o zamkniętym źródle
CVE-2021-30350
A-202025979 * Wysoki Komponent o zamkniętym źródle
CVE-2021-35070
A-202025864 * Wysoki Komponent o zamkniętym źródle
CVE-2021-35100 A-213240046 * Wysoki Komponent o zamkniętym źródle

Często zadawane pytania i odpowiedzi

W tej sekcji znajdują się odpowiedzi na często zadawane pytania, które mogą pojawić się po przeczytaniu niniejszego biuletynu.

1. Jak sprawdzić, czy moje urządzenie zostało zaktualizowane w celu rozwiązania tych problemów?

Aby dowiedzieć się, jak sprawdzić poziom poprawek zabezpieczeń urządzenia, zobacz Sprawdzanie i aktualizowanie wersji Androida .

  • Poziomy poprawek zabezpieczeń 2022-04-01 lub nowsze rozwiązują wszystkie problemy związane z poziomem poprawek zabezpieczeń 2022-04-01.
  • Poziomy poprawek zabezpieczeń z dnia 2022-04-05 lub nowsze rozwiązują wszystkie problemy związane z poziomem poprawek zabezpieczeń z dnia 2022-04-05 i wszystkimi poprzednimi poziomami poprawek.

Producenci urządzeń, którzy zawierają te aktualizacje, powinni ustawić poziom ciągu poprawek na:

  • [ro.build.version.security_patch]:[2022-04-01]
  • [ro.build.version.security_patch]:[2022-04-05]

W przypadku niektórych urządzeń z Androidem 10 lub nowszym aktualizacja systemu Google Play będzie zawierać ciąg daty zgodny z poziomem poprawki zabezpieczeń z dnia 2022-04-01. Więcej informacji na temat instalowania aktualizacji zabezpieczeń można znaleźć w tym artykule .

2. Dlaczego ten biuletyn ma dwa poziomy poprawek zabezpieczeń?

W tym biuletynie dostępne są dwa poziomy poprawek zabezpieczeń, dzięki czemu partnerzy systemu Android mogą szybciej naprawić podzbiór luk w zabezpieczeniach, które są podobne na wszystkich urządzeniach z systemem Android. Zachęcamy partnerów korzystających z systemu Android do naprawienia wszystkich problemów opisanych w tym biuletynie i korzystania z najnowszego poziomu poprawek zabezpieczeń.

  • Urządzenia korzystające z poprawki zabezpieczeń na poziomie 2022-04-01 muszą zawierać wszystkie problemy związane z tym poziomem poprawki zabezpieczeń, a także poprawki wszystkich problemów zgłoszonych w poprzednich biuletynach zabezpieczeń.
  • Urządzenia korzystające z poprawki zabezpieczeń na poziomie 2022-04-05 lub nowszym muszą zawierać wszystkie odpowiednie poprawki opisane w tym (i poprzednich) biuletynach zabezpieczeń.

Zachęcamy partnerów do grupowania poprawek wszystkich problemów, które rozwiązują, w ramach jednej aktualizacji.

3. Co oznaczają wpisy w kolumnie Typ ?

Wpisy w kolumnie Typ tabeli szczegółów luki odnoszą się do klasyfikacji luki w zabezpieczeniach.

Skrót Definicja
RCE Zdalne wykonanie kodu
EoP Podniesienie przywilejów
ID Ujawnianie informacji
DoS Odmowa usługi
Nie dotyczy Klasyfikacja niedostępna

4. Co oznaczają wpisy w kolumnie Referencje ?

Wpisy w kolumnie Referencje tabeli szczegółów podatności mogą zawierać przedrostek identyfikujący organizację, do której należy wartość referencyjna.

Prefiks Odniesienie
A- Identyfikator błędu Androida
Kontrola jakości- Numer referencyjny Qualcomma
M- Numer referencyjny MediaTeka
N- Numer referencyjny NVIDIA
B- Numer referencyjny firmy Broadcom
U- Numer referencyjny UNISOC

5. Co oznacza * obok identyfikatora błędu Androida w kolumnie Referencje ?

Wydania, które nie są publicznie dostępne, są oznaczone * obok odpowiedniego identyfikatora referencyjnego. Aktualizacja rozwiązująca ten problem jest zazwyczaj zawarta w najnowszych sterownikach binarnych dla urządzeń Pixel dostępnych w witrynie Google Developer .

6. Dlaczego luki w zabezpieczeniach są podzielone pomiędzy ten biuletyn i biuletyny dotyczące bezpieczeństwa urządzeń/partnerów, takie jak biuletyn Pixel?

Luki w zabezpieczeniach udokumentowane w tym biuletynie zabezpieczeń są wymagane do zadeklarowania najnowszego poziomu poprawek zabezpieczeń na urządzeniach z systemem Android. Dodatkowe luki w zabezpieczeniach udokumentowane w biuletynach zabezpieczeń urządzenia/partnera nie są wymagane do zadeklarowania poziomu poprawki zabezpieczeń. Producenci urządzeń i chipsetów z Androidem mogą również publikować szczegółowe informacje o lukach w zabezpieczeniach swoich produktów, np. Google , Huawei , LGE , Motorola , Nokia czy Samsung .

Wersje

Wersja Data Notatki
1,0 4 kwietnia 2022 r Opublikowano biuletyn
1.1 5 kwietnia 2022 r Biuletyn zmieniony w celu uwzględnienia łączy AOSP
2.0 18 lipca 2022 r Zmieniona tabela CVE