Бюллетень по безопасности Android – январь 2019 г.

Опубликовано 7 января 2019 г. | Обновлено 7 января 2019 г.

В этом бюллетене содержится информация об уязвимостях в защите устройств Android. Все актуальные проблемы, перечисленные здесь, устранены в исправлении от 5 января 2019 года или более новом. Информацию о том, как проверить обновления системы безопасности, можно найти в Справочном центре.

Мы сообщили партнерам обо всех проблемах по крайней мере за месяц до выхода бюллетеня. Исправления уязвимостей доступны в хранилище Android Open Source Project (AOSP). В бюллетене также приведены ссылки на исправления вне AOSP.

Самая серьезная из проблем – критическая уязвимость в системе, которая позволяет злоумышленнику выполнять произвольный код в контексте привилегированного процесса с помощью специально созданного файла. Уровень серьезности зависит от того, какой ущерб будет нанесен устройству при атаке с использованием уязвимости, если средства защиты будут отключены разработчиком или взломаны.

У нас нет информации о том, что обнаруженные уязвимости эксплуатировались. В разделе Предотвращение атак рассказывается, как платформа безопасности и Google Play Защита помогают снизить вероятность атак на Android.

Примечание. Информация о последних автоматических обновлениях (OTA) и образах встроенного ПО для устройств Google содержится в бюллетене по обновлениям Pixel  за январь 2019 года.

Предотвращение атак

Ниже рассказывается, как платформа безопасности и средства защиты сервисов, например Google Play Защита, позволяют снизить вероятность атак на Android.

  • В новых версиях Android сложнее использовать многие уязвимости, поэтому мы рекомендуем всем пользователям своевременно обновлять систему.
  • Команда, отвечающая за безопасность Android, с помощью Google Play Защиты активно отслеживает злоупотребления и предупреждает пользователей об установке потенциально опасных приложений. Google Play Защита включена по умолчанию на всех телефонах и планшетах, использующих сервисы Google для мобильных устройств. Она особенно важна, если устанавливается ПО из сторонних источников.

Описание уязвимостей (обновление системы безопасности 2019-01-01)

В этом разделе вы найдете подробную информацию обо всех уязвимостях, устраненных в обновлении системы безопасности 2019-01-01. Проблемы сгруппированы по компонентам, которые они затрагивают. Для каждого приведены описание и таблица, где указаны CVE, ссылки, тип уязвимости, уровень серьезности, а также версии AOSP (при наличии). Где возможно, идентификаторы ошибки содержат ссылку на опубликованное изменение (например, список AOSP). Дополнительные ссылки перечислены в квадратных скобках.

Framework

Самая серьезная уязвимость позволяет локальному вредоносному ПО обойти требования к взаимодействию с пользователем и получить доступ к дополнительным разрешениям.

CVE Ссылки Тип Уровень серьезности Обновленные версии AOSP
CVE-2018-9582 A-112031362 ПП Высокий 8.0, 8.1, 9.0

Система

Самая серьезная уязвимость позволяет злоумышленнику выполнять произвольный код в контексте привилегированного процесса с помощью специально созданного файла.

CVE Ссылки Тип Уровень серьезности Обновленные версии AOSP
CVE-2018-9583 A-112860487 УВК Критический 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9.0
CVE-2018-9584 A-114047681 ПП Высокий 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9.0
CVE-2018-9585 A-117554809 ПП Высокий 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9.0
CVE-2018-9586 A-116754444 ПП Высокий 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9.0
CVE-2018-9587 A-113597344 ПП Высокий 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9.0
CVE-2018-9588 A-111450156 РИ Высокий 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9.0
CVE-2018-9589 A-111893132 РИ Высокий 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9.0
CVE-2018-9590 A-115900043 РИ Высокий 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9.0
CVE-2018-9591 A-116108738 РИ Высокий 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9.0
CVE-2018-9592 A-116319076 РИ Высокий 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9.0
CVE-2018-9593 A-116722267 РИ Высокий 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9.0
CVE-2018-9594 A-116791157 РИ Высокий 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9.0

Описание уязвимостей (обновление системы безопасности 2019-01-05)

В этом разделе вы найдете подробную информацию обо всех уязвимостях, устраненных в обновлении системы безопасности 2019-01-05. Проблемы сгруппированы по компонентам, которые они затрагивают. Для каждого приведена таблица, где указаны CVE, ссылки, тип уязвимости, уровень серьезности, а также версии AOSP (при наличии). Где возможно, идентификаторы ошибки содержат ссылку на опубликованное изменение (например, список AOSP). Когда несколько изменений относятся к одной ошибке, дополнительные ссылки перечислены в квадратных скобках.

Компоненты ядра

Самая серьезная уязвимость позволяет локальному вредоносному ПО выполнять произвольный код в контексте привилегированного процесса.

CVE Ссылки Тип Уровень серьезности Компонент
CVE-2018-10876 A-116406122
Upstream kernel
ПП Высокий Файловая система ext4
CVE-2018-10880 A-116406509
Upstream kernel
ПП Высокий Файловая система ext4
CVE-2018-10882 A-116406626
Upstream kernel
ПП Высокий Файловая система ext4
CVE-2018-13405 A-113452403
Upstream kernel
ПП Высокий Файловая система
CVE-2018-18281 A-118836219
Upstream kernel
ПП Высокий TLB
CVE-2018-17182 A-117280327
Upstream kernel
ПП Высокий Диспетчер памяти
CVE-2018-10877 A-116406625
Upstream kernel
РИ Высокий Файловая система ext4

Компоненты NVIDIA

Самая серьезная уязвимость позволяет локальному вредоносному ПО выполнять произвольный код в контексте привилегированного процесса.

CVE Ссылки Тип Уровень серьезности Компонент
CVE-2018-6241 A-62540032* ПП Высокий Пакет поддержки платформы Dragon

Компоненты Qualcomm

Эти уязвимости затрагивают компоненты Qualcomm. Они описаны в бюллетенях по безопасности Qualcomm или оповещениях системы безопасности. Уровень серьезности этих уязвимостей определяется непосредственно компанией Qualcomm.

CVE Ссылки Тип Уровень серьезности Компонент
CVE-2018-11962 A-117118292
QC-CR#2267916
Н/Д Высокий Аудио
CVE-2018-12014 A-117118062
QC-CR#2278688
Н/Д Высокий Данные HLOS – LNX
CVE-2018-13889 A-117118677
QC-CR#2288358
Н/Д Высокий GPS

Закрытые компоненты Qualcomm

Эти уязвимости затрагивают компоненты Qualcomm. Они описаны в бюллетенях по безопасности Qualcomm или оповещениях системы безопасности. Уровень серьезности этих уязвимостей определяется непосредственно компанией Qualcomm.

CVE Ссылки Тип Уровень серьезности Компонент
CVE-2018-11847 A-111092812* Н/Д Критический Компонент с закрытым исходным кодом
CVE-2018-11888 A-111093241* Н/Д Высокий Компонент с закрытым исходным кодом
CVE-2018-13888 A-117119136* Н/Д Высокий Компонент с закрытым исходным кодом

Часто задаваемые вопросы

В этом разделе мы отвечаем на вопросы, которые могут возникнуть после прочтения бюллетеня.

1. Как определить, установлено ли на устройство обновление, в котором устранены перечисленные проблемы?

Информацию о том, как проверить обновления системы безопасности, можно найти в Справочном центре.

  • В исправлении от 1 января 2019 года или более новом устранены все проблемы, связанные с обновлением 2019-01-01.
  • В исправлении от 5 января 2019 года или более новом устранены все проблемы, связанные с обновлением 2019-01-05.

Производители устройств, позволяющие установить эти обновления, должны присвоить им один из этих уровней:

  • [ro.build.version.security_patch]:[2019-01-01]
  • [ro.build.version.security_patch]:[2019-01-05]

2. Почему в этом бюллетене говорится о двух обновлениях системы безопасности?

Мы включили в этот бюллетень сведения о двух обновлениях, чтобы помочь нашим партнерам как можно скорее устранить уязвимости, затрагивающие все устройства Android. Рекомендуем партнерам Android исправить все вышеперечисленные проблемы и установить последнее обновление системы безопасности.

  • На устройствах с установленным обновлением 2019-01-01 должны быть исправлены все проблемы, упомянутые в соответствующем разделе этого бюллетеня, а также в предыдущих выпусках.
  • На устройствах с установленным обновлением 2019-01-05 или более поздним должны быть исправлены все проблемы, упомянутые в этом бюллетене и предыдущих выпусках.

Рекомендуем партнерам собрать все исправления проблем в одно обновление.

3. Что означают сокращения в столбце Тип?

В этом столбце указан тип уязвимости по следующей классификации:

Сокращение Описание
УВК Удаленное выполнение кода
ПП Повышение привилегий
РИ Раскрытие информации
ОО Отказ в обслуживании
Н/Д Классификация недоступна

4. Что означает информация в столбце Ссылки?

В таблицах с описанием уязвимостей есть столбец Ссылки. Каждая запись в нем может содержать префикс, указывающий на источник ссылки, а именно:

Префикс Значение
A- Идентификатор ошибки Android
QC- Ссылочный номер Qualcomm
M- Ссылочный номер MediaTek
N- Ссылочный номер NVIDIA
B- Ссылочный номер Broadcom

5. Что означает символ * рядом с идентификатором ошибки Android в столбце Ссылки?

Символ * означает, что исправление для уязвимости не опубликовано. Необходимое обновление содержится в последних бинарных драйверах для устройств Pixel, которые можно скачать на сайте для разработчиков.

6. Почему теперь одни уязвимости описываются в этих бюллетенях, а другие – в бюллетенях по безопасности Pixel , а также в остальных бюллетенях партнеров?

В этом бюллетене описаны уязвимости, которые были устранены в последнем обновлении системы безопасности для устройств Android. Решать дополнительные проблемы, перечисленные в бюллетенях по безопасности партнеров, для этого не потребовалось. Мы рекомендуем производителям чипсетов и устройств Android рассказывать об исправлениях для своих устройств в бюллетенях по безопасности на собственных сайтах, например Samsung, LGE и Pixel .

Версии

Версия Дата Примечания
1.0 7 января 2019 г. Бюллетень опубликован.
1.1 7 января 2019 г. Добавлены ссылки на AOSP.