Google si impegna a promuovere l'equità razziale per le comunità nere. Vedi come.
Questa pagina è stata tradotta dall'API Cloud Translation.
Switch to English

Bollettino sulla sicurezza di Android — aprile 2017

Pubblicato il 3 aprile 2017 | Aggiornato il 17 agosto 2017

Il Bollettino sulla sicurezza di Android contiene dettagli sulle vulnerabilità della sicurezza che interessano i dispositivi Android. Oltre al bollettino, abbiamo rilasciato un aggiornamento di sicurezza per i dispositivi Nexus attraverso un aggiornamento over-the-air (OTA). Anche le immagini del firmware del dispositivo Google sono state rilasciate sul sito per sviluppatori Google . I livelli di patch di sicurezza del 05 aprile 2017 o successivi risolvono tutti questi problemi. Fai riferimento al programma di aggiornamento di Pixel e Nexus per informazioni su come controllare il livello di patch di sicurezza di un dispositivo.

I partner sono stati informati dei problemi descritti nel bollettino il 06 marzo 2017 o precedenti. Le patch di codice sorgente per questi problemi sono state rilasciate al repository AOSP (Android Open Source Project) e collegate da questo bollettino. Questo bollettino include anche collegamenti a patch al di fuori di AOSP.

Il più grave di questi problemi è una vulnerabilità di sicurezza critica che potrebbe consentire l'esecuzione di codice in modalità remota su un dispositivo interessato attraverso più metodi come e-mail, navigazione Web e MMS durante l'elaborazione dei file multimediali. La valutazione della gravità si basa sull'effetto che lo sfruttamento della vulnerabilità potrebbe avere su un dispositivo interessato, presupponendo che le mitigazioni della piattaforma e del servizio siano disabilitate a fini di sviluppo o se vengano aggirate correttamente.

Non abbiamo avuto notizie di sfruttamento attivo dei clienti o abuso di questi problemi appena segnalati. Fare riferimento alla sezione Mitigazioni dei servizi Android e Google per i dettagli sulle protezioni della piattaforma di sicurezza Android e le protezioni dei servizi come SafetyNet , che migliorano la sicurezza della piattaforma Android.

Incoraggiamo tutti i clienti ad accettare questi aggiornamenti per i loro dispositivi.

Annunci

  • Questo bollettino ha due stringhe a livello di patch di sicurezza per fornire ai partner Android la flessibilità necessaria per correggere più rapidamente un sottoinsieme di vulnerabilità simili a tutti i dispositivi Android. Consulta Domande e risposte comuni per ulteriori informazioni:
    • 01/04/2017 : stringa di livello di patch di sicurezza parziale. Questa stringa a livello di patch di sicurezza indica che tutti i problemi associati a 01-04-2017 (e tutte le stringhe a livello di patch di sicurezza precedenti) vengono risolti.
    • 05-04-2017 : stringa di livello di patch di sicurezza completa. Questa stringa a livello di patch di sicurezza indica che tutti i problemi associati a 2017-04-01 e 2017-04-05 (e tutte le precedenti stringhe a livello di patch di sicurezza) vengono risolti.
  • I dispositivi Google supportati riceveranno un singolo aggiornamento OTA con il livello di patch di sicurezza del 05 aprile 2017.

Mitigazioni dei servizi Android e Google

Questo è un riepilogo delle mitigazioni fornite dalla piattaforma di sicurezza Android e delle protezioni del servizio come SafetyNet. Queste funzionalità riducono la probabilità che le vulnerabilità di sicurezza possano essere sfruttate con successo su Android.

  • Lo sfruttamento per molti problemi su Android è reso più difficile dai miglioramenti nelle nuove versioni della piattaforma Android. Incoraggiamo tutti gli utenti ad aggiornare all'ultima versione di Android ove possibile.
  • Il team di sicurezza di Android monitora attivamente gli abusi con Verify Apps e SafetyNet , progettati per avvisare gli utenti di applicazioni potenzialmente dannose . Verifica che le app siano abilitate per impostazione predefinita sui dispositivi con Google Mobile Services ed è particolarmente importante per gli utenti che installano applicazioni al di fuori di Google Play. Gli strumenti di rooting dei dispositivi sono vietati in Google Play, ma Verifica App avvisa gli utenti quando tentano di installare un'applicazione di rooting rilevata, indipendentemente da dove provenga. Inoltre, Verifica App tenta di identificare e bloccare l'installazione di applicazioni dannose note che sfruttano una vulnerabilità di escalation di privilegi. Se tale applicazione è già stata installata, Verifica App avviserà l'utente e tenterà di rimuovere l'applicazione rilevata.
  • Se del caso, le applicazioni di Google Hangouts e Messenger non passano automaticamente i media a processi come Mediaserver.

Ringraziamenti

Vorremmo ringraziare questi ricercatori per il loro contributo:

  • Aravind Machiry (donfos) del team Shellphish Grill: CVE-2016-5349
  • Daxing Guo ( @ freener0 ) di Xuanwu Lab, Tencent: CVE-2017-0585, CVE-2017-0553
  • Derrek ( @ derrekr6 ) e Scott Bauer: CVE-2017-0576
  • Gal Beniamini del Progetto Zero: CVE-2017-0571, CVE-2017-0570, CVE-2017-0572, CVE-2017-0569, CVE-2017-0561
  • Gengjia Chen ( @ chengjia4574 ) e pjf di IceSword Lab, Qihoo 360 Technology Co. Ltd .: CVE-2017-6426, CVE-2017-0581, CVE-2017-0329, CVE-2017-0332, CVE-2017-0566, CVE-2017-0573
  • Guang Gong (龚 广) ( @oldfresher ) di Alpha Team, Qihoo 360 Technology Co. Ltd .: CVE-2017-0547
  • Hao Chen e Guang Gong di Alpha Team, Qihoo 360 Technology Co. Ltd .: CVE-2017-6424, CVE-2017-0584, CVE-2017-0454, CVE-2017-0574, CVE-2017-0575, CVE-2017 -0567
  • Ian Foster ( @lanrat ): CVE-2017-0554
  • Jack Tang di Trend Micro Inc .: CVE-2017-0579
  • Jianjun Dai ( @Jioun_dai ) di Qihoo 360 Skyeye Labs : CVE-2017-0559, CVE-2017-0541
  • Jianqiang Zhao ( @jianqiangzhao ) e pjf di IceSword Lab, Qihoo 360: CVE-2017-6425, CVE-2016-5346
  • Lubo Zhang ( zlbzlb815@163.com ) del team C0RE e Yonggang Guo ( @guoygang ) di IceSword Lab, Qihoo 360 Technology Co. Ltd .: CVE-2017-0564
  • Mark Salyzyn di Google: CVE-2017-0558
  • Mike Andereson ( @manderbot ) e Nathan Crandall ( @natecray ) del team di sicurezza del prodotto di Tesla: CVE-2017-0327, CVE-2017-0328
  • Peng Xiao, Chengming Yang, Ning You, Chao Yang e Yang canzone di Alibaba Mobile Security Group: CVE-2017-0565
  • Pengfei Ding (丁鹏飞), Chenfu Bao (包 沉浮) e Lenx Wei (韦 韬) di Baidu X-Lab (百度 安全 实验室): CVE-2016-10236
  • Qidan He (何 淇 丹 - @flanker_hqd ) di KeenLab, Tencent: CVE-2017-0544, CVE-2017-0325
  • Roee Hay ( @roeehay ) di Aleph Research, HCL Technologies: CVE-2017-0582, CVE-2017-0563
  • Scott Bauer ( @ ScottyBauer1 ): CVE-2017-0562, CVE-2017-0339
  • Seven Shen ( @lingtongshen ) del team di ricerca sulle minacce mobile TrendMicro: CVE-2016-10231, CVE-2017-0578, CVE-2017-0586
  • Tim Becker: CVE-2017-0546
  • Uma Sankar Pradhan ( @umasankar_iitd ): CVE-2017-0560
  • VEO ( @VYSEa ) del team mobile di risposta alle minacce , Trend Micro : CVE-2017-0555, CVE-2017-0538, CVE-2017-0539, CVE-2017-0557, CVE-2017-0556
  • Weichao Sun ( @sunblate ) di Alibaba Inc: CVE-2017-0549
  • Wenlin Yang ( @wenlin_yang ), Guang Gong ( @oldfresher ) e Hao Chen del team Alpha, Qihoo 360 Technology Co. Ltd .: CVE-2017-0580, CVE-2017-0577
  • Zinuo Han del centro di risposta alla sicurezza di Chengdu di Qihoo 360 Technology Co. Ltd .: CVE-2017-0548
  • Zubin Mithra di Google: CVE-2017-0462

01-04-2017 Livello patch di sicurezza: dettagli della vulnerabilità

Nelle sezioni seguenti forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2017-04-01. C'è una descrizione del problema, una logica di gravità e una tabella con CVE, riferimenti associati, gravità, dispositivi Google aggiornati, versioni AOSP aggiornate (ove applicabile) e data riportata. Se disponibile, collegheremo la modifica pubblica che ha risolto il problema con l'ID bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, riferimenti aggiuntivi sono collegati ai numeri che seguono l'ID bug.

Vulnerabilità legata all'esecuzione di codice in modalità remota in Mediaserver

Una vulnerabilità legata all'esecuzione di codice in modalità remota in Mediaserver potrebbe consentire a un utente malintenzionato che utilizza un file appositamente predisposto di provocare danni alla memoria durante l'elaborazione di file multimediali e dati. Questo problema è classificato come critico a causa della possibilità di esecuzione di codice in modalità remota nel contesto del processo Mediaserver.

CVE Riferimenti Gravità Dispositivi Google aggiornati Versioni AOSP aggiornate Data riportata
CVE-2017-0538 A-33641588 critico Tutti 6.0, 6.0.1, 7.0, 7.1.1 13 dic 2016
CVE-2017-0539 A-33864300 critico Tutti 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 23 dic 2016
CVE-2017-0541 A-34031018 critico Tutti 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 1 gennaio 2017
CVE-2017-0542 A-33934721 critico Tutti 6.0, 6.0.1, 7.0, 7.1.1 Google interno
CVE-2017-0543 A-34097866 critico Tutti 6.0, 6.0.1, 7.0, 7.1.1 Google interno

Elevazione della vulnerabilità dei privilegi in CameraBase

Una vulnerabilità legata all'acquisizione di privilegi più elevati in CameraBase potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario. Questo problema è considerato alto perché si tratta di un'esecuzione di codice arbitrario locale in un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Google aggiornati Versioni AOSP aggiornate Data riportata
CVE-2017-0544 A-31992879 alto Tutti 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 6 ottobre 2016

Elevazione della vulnerabilità dei privilegi in Audioserver

Un'elevata vulnerabilità dei privilegi in Audioserver potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato. Questo problema è considerato alto perché potrebbe essere utilizzato per ottenere l'accesso locale a funzionalità elevate, che normalmente non sono accessibili a un'applicazione di terze parti.

CVE Riferimenti Gravità Dispositivi Google aggiornati Versioni AOSP aggiornate Data riportata
CVE-2017-0545 A-32591350 alto Tutti 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 31 ottobre 2016

Elevazione della vulnerabilità dei privilegi in SurfaceFlinger

Un'elevata vulnerabilità dei privilegi in SurfaceFlinger potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato. Questo problema è considerato alto perché potrebbe essere utilizzato per ottenere l'accesso locale a funzionalità elevate, che normalmente non sono accessibili a un'applicazione di terze parti.

CVE Riferimenti Gravità Dispositivi Google aggiornati Versioni AOSP aggiornate Data riportata
CVE-2017-0546 A-32628763 alto Tutti 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 2 novembre 2016

Vulnerabilità legata alla divulgazione di informazioni in Mediaserver

Una vulnerabilità legata alla divulgazione di informazioni in Mediaserver potrebbe consentire a un'applicazione locale dannosa di accedere ai dati al di fuori dei suoi livelli di autorizzazione. Questo problema è considerato alto perché è un bypass generale per le protezioni del sistema operativo che isola i dati delle applicazioni da altre applicazioni.

CVE Riferimenti Gravità Dispositivi Google aggiornati Versioni AOSP aggiornate Data riportata
CVE-2017-0547 A-33861560 alto Tutti 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 22 dic 2016

Vulnerabilità legata alla negazione del servizio in Libskia

Una vulnerabilità remota di negazione del servizio in libskia potrebbe consentire a un utente malintenzionato di utilizzare un file appositamente predisposto per causare il blocco o il riavvio del dispositivo. Questo problema è classificato come severo a causa della possibilità di Denial of Service remoto.

CVE Riferimenti Gravità Dispositivi Google aggiornati Versioni AOSP aggiornate Data riportata
CVE-2017-0548 A-33251605 alto Tutti 7.0, 7.1.1 29 nov 2016

Vulnerabilità di tipo Denial of Service in Mediaserver

Una vulnerabilità remota di negazione del servizio in Mediaserver potrebbe consentire a un utente malintenzionato di utilizzare un file appositamente predisposto per causare il blocco o il riavvio del dispositivo. Questo problema è classificato come severo a causa della possibilità di Denial of Service remoto.

CVE Riferimenti Gravità Dispositivi Google aggiornati Versioni AOSP aggiornate Data riportata
CVE-2017-0549 A-33818508 alto Tutti 6.0, 6.0.1, 7.0, 7.1.1 20 dic 2016
CVE-2017-0550 A-33933140 alto Tutti 6.0, 6.0.1, 7.0, 7.1.1 Google interno
CVE-2017-0551 A-34097231 [ 2 ] alto Tutti 6.0, 6.0.1, 7.0, 7.1.1 Google interno
CVE-2017-0552 A-34097915 alto Tutti 6.0, 6.0.1, 7.0, 7.1.1 Google interno

Elevazione della vulnerabilità dei privilegi in libnl

Una vulnerabilità legata all'acquisizione di privilegi più elevati in libnl potrebbe consentire a un'applicazione locale dannosa di eseguire codice arbitrario nel contesto del servizio Wi-Fi. Questo problema è classificato come moderato perché richiede innanzitutto di compromettere un processo privilegiato ed è mitigato dalle attuali configurazioni della piattaforma.

CVE Riferimenti Gravità Dispositivi Google aggiornati Versioni AOSP aggiornate Data riportata
CVE-2017-0553 A-32342065 Moderare Tutti 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 21 ottobre 2016

Elevazione della vulnerabilità dei privilegi nella telefonia

Un'elevata vulnerabilità dei privilegi nel componente Telefonia potrebbe consentire a un'applicazione locale dannosa di accedere a funzionalità al di fuori dei suoi livelli di autorizzazione. Questo problema è considerato moderato perché potrebbe essere utilizzato per ottenere l'accesso a funzionalità elevate, che normalmente non sono accessibili a un'applicazione di terze parti.

CVE Riferimenti Gravità Dispositivi Google aggiornati Versioni AOSP aggiornate Data riportata
CVE-2017-0554 A-33815946 [ 2 ] Moderare Tutti 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 20 dic 2016

Vulnerabilità legata alla divulgazione di informazioni in Mediaserver

Una vulnerabilità legata alla divulgazione di informazioni in Mediaserver potrebbe consentire a un'applicazione locale dannosa di accedere ai dati al di fuori dei suoi livelli di autorizzazione. Questo problema è considerato moderato perché potrebbe essere utilizzato per accedere ai dati senza autorizzazione.

CVE Riferimenti Gravità Dispositivi Google aggiornati Versioni AOSP aggiornate Data riportata
CVE-2017-0555 A-33551775 Moderare Tutti 6.0, 6.0.1, 7.0, 7.1.1 12 dicembre 2016
CVE-2017-0556 A-34093952 Moderare Tutti 6.0, 6.0.1, 7.0, 7.1.1 4 gennaio 2017
CVE-2017-0557 A-34093073 Moderare Tutti 6.0, 6.0.1, 7.0, 7.1.1 4 gennaio 2017
CVE-2017-0558 A-34056274 Moderare Tutti 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Google interno

Vulnerabilità legata alla divulgazione di informazioni in libskia

Una vulnerabilità legata alla divulgazione di informazioni in libskia potrebbe consentire a un'applicazione locale dannosa di accedere ai dati al di fuori dei suoi livelli di autorizzazione. Questo problema è considerato moderato perché potrebbe essere utilizzato per accedere ai dati senza autorizzazione.

CVE Riferimenti Gravità Dispositivi Google aggiornati Versioni AOSP aggiornate Data riportata
CVE-2017-0559 A-33897722 Moderare Tutti 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 25 dicembre 2016

Vulnerabilità legata alla divulgazione di informazioni in Factory Reset

Una vulnerabilità legata alla divulgazione di informazioni nel processo di ripristino delle impostazioni di fabbrica potrebbe consentire a un utente malintenzionato malintenzionato locale di accedere ai dati del precedente proprietario. Questo problema è classificato come moderato a causa della possibilità di bypassare la protezione del dispositivo.

CVE Riferimenti Gravità Dispositivi Google aggiornati Versioni AOSP aggiornate Data riportata
CVE-2017-0560 A-30681079 Moderare Tutti 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Google interno

05-04-2017 Livello patch di sicurezza: dettagli della vulnerabilità

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2017-04-05. C'è una descrizione del problema, una logica di gravità e una tabella con il CVE, riferimenti associati, gravità, dispositivi Google aggiornati, versioni AOSP aggiornate (ove applicabile) e data riportata. Se disponibile, collegheremo la modifica pubblica che ha risolto il problema con l'ID bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, riferimenti aggiuntivi sono collegati ai numeri che seguono l'ID bug.

Vulnerabilità legata all'esecuzione di codice in modalità remota nel firmware Wi-Fi Broadcom

Una vulnerabilità legata all'esecuzione di codice in modalità remota nel firmware Wi-Fi Broadcom potrebbe consentire a un utente remoto di eseguire codice arbitrario nel contesto del SoC Wi-Fi. Questo problema è classificato come critico a causa della possibilità di eseguire codice in modalità remota nel contesto del SoC Wi-Fi.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2017-0561 A-34199105 *
B-RB # 110.814
critico Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9 gennaio 2017

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

Vulnerabilità legata all'esecuzione di codice in modalità remota nel driver del motore di crittografia Qualcomm

Una vulnerabilità legata all'esecuzione di codice in modalità remota nel driver del motore di crittografia Qualcomm potrebbe consentire a un utente malintenzionato remoto di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di eseguire codice in modalità remota nel contesto del kernel.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2.016-10.230 A-34389927
QC-CR # 1091408
critico Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 10 gennaio 2017

Vulnerabilità legata all'esecuzione di codice in modalità remota nel sottosistema di rete del kernel

Una vulnerabilità legata all'esecuzione di codice in modalità remota nel sottosistema di rete del kernel potrebbe consentire a un utente remoto di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di eseguire codice in modalità remota nel contesto del kernel.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2.016-10.229 A-32813456
Kernel a monte
critico Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Pixel C, Android One, Nexus Player Google interno

Elevazione della vulnerabilità dei privilegi nel driver del touchscreen MediaTek

Un'elevata vulnerabilità dei privilegi nel driver del touchscreen MediaTek potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di un compromesso permanente del dispositivo locale, che potrebbe richiedere il reflashing del sistema operativo per riparare il dispositivo.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2017-0562 A-30202425 *
M-ALPS02898189
* critical Nessuna** 16 lug 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

** I dispositivi Google supportati su Android 7.0 o versioni successive che hanno installato tutti gli aggiornamenti disponibili non sono interessati da questa vulnerabilità.

Elevata vulnerabilità dei privilegi nel driver del touchscreen HTC

Un'elevata vulnerabilità dei privilegi nel driver del touchscreen HTC potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di un compromesso permanente del dispositivo locale, che potrebbe richiedere il reflashing del sistema operativo per riparare il dispositivo.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2017-0563 A-32089409 *
critico Nexus 9 9 ottobre 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

Elevazione della vulnerabilità dei privilegi nel sottosistema ION del kernel

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel sottosistema ION del kernel potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di un compromesso permanente del dispositivo locale, che potrebbe richiedere il reflashing del sistema operativo per riparare il dispositivo.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2017-0564 A-34276203 *
critico Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Pixel C, Android One, Nexus Player 12 gennaio 2017

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

Vulnerabilità nei componenti Qualcomm

Queste vulnerabilità riguardano i componenti Qualcomm e sono descritte in dettaglio nel bollettino sulla sicurezza AMSS di ottobre 2016 di Qualcomm.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2.016-10.237 A-31628601 **
QC-CR # 1046751
critico Nessuna** Qualcomm interno
CVE-2.016-10.238 A-35358527 **
QC-CR # 1042558
critico Nessuna*** Qualcomm interno
CVE-2.016-10.239 A-31624618 **
QC-CR # 1032929
alto Pixel, Pixel XL Qualcomm interno

* Il livello di gravità per queste vulnerabilità è stato determinato dal fornitore.

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

*** I dispositivi Google supportati su Android 7.0 o versioni successive che hanno installato tutti gli aggiornamenti disponibili non sono interessati da questa vulnerabilità.

Vulnerabilità legata all'esecuzione di codice in modalità remota in v8

Una vulnerabilità legata all'esecuzione di codice in modalità remota in v8 potrebbe consentire agli autori di attacchi remoti di eseguire codice arbitrario nel contesto di un processo privilegiato. Questo problema è considerato elevato a causa della possibilità di esecuzione di codice in remoto nei siti Web.

CVE Riferimenti Gravità Dispositivi Google aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-5129 A-29178923 alto Nessuna* 6.0, 6.0.1, 7.0 20 lug 2016

* I dispositivi Google supportati su Android 7.0 o versioni successive che hanno installato tutti gli aggiornamenti disponibili non sono interessati da questa vulnerabilità.

Vulnerabilità legata all'esecuzione di codice in modalità remota in Freetype

Una vulnerabilità legata all'esecuzione di codice in modalità remota in Freetype potrebbe consentire a un'applicazione dannosa locale di caricare un font appositamente predisposto per causare il danneggiamento della memoria in un processo senza privilegi. Questo problema è considerato elevato a causa della possibilità di esecuzione di codice in modalità remota in un'applicazione che utilizza questa libreria.

CVE Riferimenti Gravità Dispositivi Google aggiornati Versioni AOSP aggiornate Data riportata
CVE-2.016-10.244 A-31470908 alto Nessuna* 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 13 settembre 2016

* I dispositivi Google supportati su Android 7.0 o versioni successive che hanno installato tutti gli aggiornamenti disponibili non sono interessati da questa vulnerabilità.

Elevazione della vulnerabilità dei privilegi nel sottosistema audio del kernel

Un'elevazione della vulnerabilità dei privilegi nel sottosistema audio del kernel potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è considerato elevato perché richiede innanzitutto di compromettere un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2014-4656 A-34464977
Kernel a monte
alto Nexus 6, Nexus Player 26-giu-2014

Elevazione della vulnerabilità dei privilegi nel driver crittografico NVIDIA

Un'elevata vulnerabilità dei privilegi nel driver crittografico NVIDIA potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è considerato elevato perché richiede innanzitutto di compromettere un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2017-0339 A-27930566 *
N-CVE-2017-0339
alto Nexus 9 29-mar-2016
CVE-2017-0332 A-33812508 *
N-CVE-2017-0332
alto Nexus 9 21 dicembre 2016
CVE-2017-0327 A-33893669 *
N-CVE-2017-0327
alto Nexus 9 24 dicembre 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

Elevata vulnerabilità dei privilegi nel driver termico MediaTek

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver termico MediaTek potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è considerato elevato perché richiede innanzitutto di compromettere un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2017-0565 A-28175904 *
M-ALPS02696516
alto Nessuna** 11 aprile 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

** I dispositivi Google supportati su Android 7.0 o versioni successive che hanno installato tutti gli aggiornamenti disponibili non sono interessati da questa vulnerabilità.

Elevata vulnerabilità dei privilegi nel driver della fotocamera MediaTek

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver della fotocamera MediaTek potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è considerato elevato perché richiede innanzitutto di compromettere un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2017-0566 A-28470975 *
M-ALPS02696367
alto Nessuna** 29 aprile 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili dal sito degli sviluppatori di Google .

** I dispositivi Google supportati su Android 7.0 o versioni successive che hanno installato tutti gli aggiornamenti disponibili non sono interessati da questa vulnerabilità.

Elevata vulnerabilità dei privilegi nel driver Wi-Fi Broadcom

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver Broadcom Wi-Fi potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è considerato elevato perché richiede innanzitutto di compromettere un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2017-0567 A-32125310 *
B-RB # 112575
alto Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 12 ottobre 2016
CVE-2017-0568 A-34197514 *
B-RB # 112600
alto Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9 gennaio 2017
CVE-2017-0569 A-34198729 *
B-RB # 110666
alto Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9 gennaio 2017
CVE-2017-0570 A-34199963 *
B-RB # 110688
alto Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9 gennaio 2017
CVE-2017-0571 A-34203305 *
B-RB # 111541
alto Nexus 6, Nexus 6P, Pixel C, Nexus Player 9 gennaio 2017
CVE-2017-0572 A-34198931 *
B-RB # 112597
alto Nessuna** 9 gennaio 2017
CVE-2017-0573 A-34469904 *
B-RB # 91.539
alto Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 18 gennaio 2017
CVE-2017-0574 A-34624457 *
B-RB # 113.189
alto Nexus 6, Nexus 6P, Nexus 9, Pixel C 22 gennaio 2017

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

** I dispositivi Google supportati su Android 7.0 o versioni successive che hanno installato tutti gli aggiornamenti disponibili non sono interessati da questa vulnerabilità.

Elevata vulnerabilità dei privilegi nel driver Wi-Fi Qualcomm

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver Wi-Fi Qualcomm potrebbe consentire a un'applicazione locale dannosa di eseguire codice arbitrario nel contesto del kernel. Questo problema è considerato elevato perché richiede innanzitutto di compromettere un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2017-0575 A-32658595 *
QC-CR # 1103099
alto Nexus 5X, Pixel, Pixel XL 3 novembre 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

Elevazione della vulnerabilità dei privilegi nel driver HID NVIDIA I2C

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver HID NVIDIA I2C potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è considerato elevato perché richiede innanzitutto di compromettere un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2017-0325 A-33040280 *
N-CVE-2017-0325
alto Nexus 9, Pixel C 20 nov 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

Elevazione della vulnerabilità dei privilegi nel driver audio Qualcomm

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver audio Qualcomm potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è considerato elevato perché richiede innanzitutto di compromettere un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2017-0454 A-33353700
QC-CR # 1104067
alto Nexus 5X, Nexus 6P, Pixel, Pixel XL 5 dic 2016

Elevazione della vulnerabilità dei privilegi nel driver del motore di crittografia Qualcomm

Un'elevazione della vulnerabilità dei privilegi nel driver del motore di crittografia Qualcomm potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è considerato elevato perché richiede innanzitutto di compromettere un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2017-0576 A-33544431
QC-CR # 1103089
alto Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 9 dicembre 2016

Elevata vulnerabilità dei privilegi nel driver del touchscreen HTC

Un'elevata vulnerabilità dei privilegi nel driver del touchscreen HTC potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è considerato elevato perché richiede innanzitutto di compromettere un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2017-0577 A-33842951 *
alto Nessuna** 21 dicembre 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

** I dispositivi Google supportati su Android 7.0 o versioni successive che hanno installato tutti gli aggiornamenti disponibili non sono interessati da questa vulnerabilità.

Elevata vulnerabilità dei privilegi nel driver audio DTS

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver audio DTS potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è considerato elevato perché richiede innanzitutto di compromettere un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2017-0578 A-33964406 *
alto Nessuna** 28 dic 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

** I dispositivi Google supportati su Android 7.0 o versioni successive che hanno installato tutti gli aggiornamenti disponibili non sono interessati da questa vulnerabilità.

Elevata vulnerabilità dei privilegi nel driver di codec audio Qualcomm

Un'elevata vulnerabilità dei privilegi nel driver del codec audio Qualcomm potrebbe consentire a un'applicazione locale dannosa di eseguire codice arbitrario nel contesto del kernel. Questo problema è considerato elevato perché richiede innanzitutto di compromettere un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2.016-10.231 A-33966912
QC-CR # 1096799
alto Pixel, Pixel XL 29 dicembre 2016

Elevazione della vulnerabilità dei privilegi nel driver video Qualcomm

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver video Qualcomm potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è considerato elevato perché richiede innanzitutto di compromettere un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Google aggiornati Data riportata
CVE-2017-0579 A-34125463 *
QC-CR # 1115406
alto Nexus 5X, Nexus 6P, Pixel, Pixel XL 5 gennaio 2017
CVE-2.016-10.232 A-34386696
QC-CR # 1024872 [2]
alto Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One Jan 10, 2017
CVE-2016-10233 A-34389926
QC-CR#897452
High None** Jan 10, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Elevation of privilege vulnerability in NVIDIA boot and power management processor driver

An elevation of privilege vulnerability in the NVIDIA boot and power management processor driver could enable a local malicious application to execute arbitrary code within the context of the boot and power management processor. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0329 A-34115304*
N-CVE-2017-0329
High Pixel C Jan 5, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Synaptics touchscreen driver

An elevation of privilege vulnerability in the Synaptics Touchscreen driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0580 A-34325986*
High None** Jan 16, 2017
CVE-2017-0581 A-34614485*
High None** Jan 22, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Elevation of privilege vulnerability in Qualcomm Seemp driver

An elevation of privilege vulnerability in the Qualcomm Seemp driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0462 A-33353601
QC-CR#1102288
High Pixel, Pixel XL Google internal

Elevation of privilege vulnerability in Qualcomm Kyro L2 driver

An elevation of privilege vulnerability in the Qualcomm Kyro L2 driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-6423 A-32831370
QC-CR#1103158
High Pixel, Pixel XL Google internal

Elevation of privilege vulnerability in kernel file system

An elevation of privilege vulnerability in the kernel file system could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2014-9922 A-32761463
Upstream kernel
High Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Android One, Nexus Player Oct 24, 2014

Information disclosure vulnerability in kernel memory subsystem

An information disclosure vulnerability in the kernel memory subsystem could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2014-0206 A-34465735
Upstream kernel
High Nexus 6, Nexus Player May 6, 2014

Information disclosure vulnerability in kernel networking subsystem

An information disclosure vulnerability in the kernel networking subsystem could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2014-3145 A-34469585
Upstream kernel [2]
High Nexus 6, Nexus Player May 9, 2014

Information disclosure vulnerability in Qualcomm TrustZone

An information disclosure vulnerability in the Qualcomm TrustZone could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2016-5349 A-29083830
QC-CR#1021945 [2] [3] [4]
High Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Jun 1, 2016

Information disclosure vulnerability in Qualcomm IPA driver

An information disclosure vulnerability in the Qualcomm IPA driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2016-10234 A-34390017
QC-CR#1069060 [2]
High Nexus 5X, Nexus 6P, Pixel, Pixel XL Jan 10, 2017

Denial of service vulnerability in kernel networking subsystem

A denial of service vulnerability in the kernel networking subsystem could enable a remote attacker to use a specially crafted network packet to cause a device hang or reboot. This issue is rated as High due to the possibility of remote denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2014-2706 A-34160553
Upstream kernel
High Nexus Player Apr 1, 2014

Denial of service vulnerability in Qualcomm Wi-Fi driver

A denial of service vulnerability in the Qualcomm Wi-Fi driver could enable a proximate attacker to cause a denial of service in the Wi-Fi subsystem. This issue is rated as High due to the possibility of remote denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2016-10235 A-34390620
QC-CR#1046409
High None** Jan 10, 2017

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Elevation of privilege vulnerability in kernel file system

An elevation of privilege vulnerability in the kernel file system could enable a local malicious application to execute arbitrary code outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process and is mitigated by current platform configurations.

CVE References Severity Updated Google devices Date reported
CVE-2016-7097 A-32458736
Upstream kernel
Moderate Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Nexus Player Aug 28, 2016

Elevation of privilege vulnerability in Qualcomm Wi-Fi driver

An elevation of privilege vulnerability in the Qualcomm Wi-Fi driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and because of vulnerability specific details which limit the impact of the issue.

CVE References Severity Updated Google devices Date reported
CVE-2017-6424 A-32086742
QC-CR#1102648
Moderate Nexus 5X, Pixel, Pixel XL, Android One Oct 9, 2016

Elevation of privilege vulnerability in Broadcom Wi-Fi driver

An elevation of privilege vulnerability in the Broadcom Wi-Fi driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and is mitigated by current platform configurations.

CVE References Severity Updated Google devices Date reported
CVE-2016-8465 A-32474971*
B-RB#106053
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Oct 27, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in HTC OEM fastboot command

An elevation of privilege vulnerability in the HTC OEM fastboot command could enable a local malicious application to execute arbitrary code within the context of the sensor hub. This issue is rated as Moderate because it first requires exploitation of separate vulnerabilities.

CVE References Severity Updated Google devices Date reported
CVE-2017-0582 A-33178836*
Moderate Nexus 9 Nov 28, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Qualcomm CP access driver

An elevation of privilege vulnerability in the Qualcomm CP access driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and because of vulnerability specific details which limit the impact of the issue.

CVE References Severity Updated Google devices Date reported
CVE-2017-0583 A-32068683
QC-CR#1103788
Moderate Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One Google internal

Information disclosure vulnerability in kernel media driver

An information disclosure vulnerability in the kernel media driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2014-1739 A-34460642
Upstream kernel
Moderate Nexus 6, Nexus 9, Nexus Player Jun 15, 2014

Information disclosure vulnerability in Qualcomm Wi-Fi driver

An information disclosure vulnerability in the Qualcomm Wi-Fi driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0584 A-32074353*
QC-CR#1104731
Moderate Nexus 5X, Pixel, Pixel XL Oct 9, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Broadcom Wi-Fi driver

An information disclosure vulnerability in the Broadcom Wi-Fi driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0585 A-32475556*
B-RB#112953
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Oct 27, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm Avtimer driver

An information disclosure vulnerability in the Qualcomm Avtimer driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-5346 A-32551280
QC-CR#1097878
Moderate Pixel, Pixel XL Oct 29, 2016

Information disclosure vulnerability in Qualcomm video driver

An information disclosure vulnerability in the Qualcomm video driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-6425 A-32577085
QC-CR#1103689
Moderate Pixel, Pixel XL Oct 29, 2016

Information disclosure vulnerability in Qualcomm USB driver

An information disclosure vulnerability in the Qualcomm USB driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-10236 A-33280689
QC-CR#1102418
Moderate Pixel, Pixel XL Nov 30, 2016

Information disclosure vulnerability in Qualcomm sound driver

An information disclosure vulnerability in the Qualcomm sound driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0586 A-33649808
QC-CR#1097569
Moderate Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Dec 13, 2016

Information disclosure vulnerability in Qualcomm SPMI driver

An information disclosure vulnerability in the Qualcomm SPMI driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-6426 A-33644474
QC-CR#1106842
Moderate Pixel, Pixel XL Dec 14, 2016

Information disclosure vulnerability in NVIDIA crypto driver

An information disclosure vulnerability in the NVIDIA crypto driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0328 A-33898322*
N-CVE-2017-0328
Moderate None** Dec 24, 2016
CVE-2017-0330 A-33899858*
N-CVE-2017-0330
Moderate None** Dec 24, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Vulnerabilities in Qualcomm components

These vulnerabilities affecting Qualcomm components were released as part of Qualcomm AMSS security bulletins between 2014–2016. They are included in this Android security bulletin to associate their fixes with an Android security patch level.

CVE References Severity Updated Google devices Date reported
CVE-2014-9931 A-35445101** Critical None** Qualcomm internal
CVE-2014-9932 A-35434683** Critical Pixel, Pixel XL Qualcomm internal
CVE-2014-9933 A-35442512** Critical None** Qualcomm internal
CVE-2014-9934 A-35439275** Critical None** Qualcomm internal
CVE-2014-9935 A-35444951** Critical None** Qualcomm internal
CVE-2014-9936 A-35442420** Critical None** Qualcomm internal
CVE-2014-9937 A-35445102** Critical None** Qualcomm internal
CVE-2015-8995 A-35445002** Critical None** Qualcomm internal
CVE-2015-8996 A-35444658** Critical None** Qualcomm internal
CVE-2015-8997 A-35432947** Critical None** Qualcomm internal
CVE-2015-8998 A-35441175** Critical None** Qualcomm internal
CVE-2015-8999 A-35445401** Critical None** Qualcomm internal
CVE-2015-9000 A-35441076** Critical None** Qualcomm internal
CVE-2015-9001 A-35445400** Critical None** Qualcomm internal
CVE-2015-9002 A-35442421** Critical None** Qualcomm internal
CVE-2015-9003 A-35440626** Critical None** Qualcomm internal
CVE-2016-10242 A-35434643** Critical None** Qualcomm internal

* The severity rating for these vulnerabilities was determined by the vendor.

** The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

*** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Common Questions and Answers

This section answers common questions that may occur after reading this bulletin.

1. How do I determine if my device is updated to address these issues?

To learn how to check a device's security patch level, read the instructions on the Pixel and Nexus update schedule .

  • Security patch levels of 2017-04-01 or later address all issues associated with the 2017-04-01 security patch level.
  • Security patch levels of 2017-04-05 or later address all issues associated with the 2017-04-05 security patch level and all previous patch levels.

Device manufacturers that include these updates should set the patch string level to:

  • [ro.build.version.security_patch]:[2017-04-01]
  • [ro.build.version.security_patch]:[2017-04-05]

2. Why does this bulletin have two security patch levels?

This bulletin has two security patch levels so that Android partners have the flexibility to fix a subset of vulnerabilities that are similar across all Android devices more quickly. Android partners are encouraged to fix all issues in this bulletin and use the latest security patch level.

  • Devices that use the April 01, 2017 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins.
  • Devices that use the security patch level of April 05, 2017 or newer must include all applicable patches in this (and previous) security bulletins.

Partners are encouraged to bundle the fixes for all issues they are addressing in a single update.

3. How do I determine which Google devices are affected by each issue?

In the 2017-04-01 and 2017-04-05 security vulnerability details sections, each table has an Updated Google devices column that covers the range of affected Google devices updated for each issue. This column has a few options:

  • All Google devices : If an issue affects All and Pixel devices, the table will have "All" in the Updated Google devices column. "All" encapsulates the following supported devices : Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel, and Pixel XL.
  • Some Google devices : If an issue doesn't affect all Google devices, the affected Google devices are listed in the Updated Google devices column.
  • No Google devices : If no Google devices running Android 7.0 are affected by the issue, the table will have "None" in the Updated Google devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefix Reference
A- Android bug ID
QC- Qualcomm reference number
M- MediaTek reference number
N- NVIDIA reference number
B- Broadcom reference number

Revisions

  • April 03, 2017: Bulletin published.
  • April 05, 2017: Bulletin revised to include AOSP links.
  • April 21, 2017: Attribution for CVE-2016-10231 and CVE-2017-0586 corrected.
  • April 27, 2017: CVE-2017-0540 removed from bulletin.
  • August 17, 2017: Bulletin revised to update reference numbers.