Bollettino sulla sicurezza Android: novembre 2020

Pubblicato il 2 novembre 2020 | Aggiornato il 4 novembre 2020

L'Android Security Bulletin contiene i dettagli delle vulnerabilità di sicurezza che interessano i dispositivi Android. I livelli di patch di sicurezza del 05-11-2020 o successivi risolvono tutti questi problemi. Per informazioni su come controllare il livello di patch di sicurezza di un dispositivo, consulta Controllare e aggiornare la versione di Android .

I partner Android vengono informati di tutti i problemi almeno un mese prima della pubblicazione. Le patch del codice sorgente per questi problemi sono state rilasciate nel repository Android Open Source Project (AOSP) e collegate da questo bollettino. Questo bollettino include anche collegamenti a patch al di fuori di AOSP.

Il più grave di questi problemi è una vulnerabilità di sicurezza critica nel componente di sistema che potrebbe consentire a un utente malintenzionato prossimale che utilizza una trasmissione appositamente predisposta di eseguire codice arbitrario nel contesto di un processo privilegiato. La valutazione della gravità si basa sull'effetto che lo sfruttamento della vulnerabilità potrebbe avere su un dispositivo interessato, supponendo che la piattaforma e le attenuazioni del servizio siano disattivate per scopi di sviluppo o se bypassate correttamente.

Fare riferimento alla sezione sulle attenuazioni di Android e Google Play Protect per i dettagli sulle protezioni della piattaforma di sicurezza Android e su Google Play Protect, che migliorano la sicurezza della piattaforma Android.

Mitigazioni dei servizi Android e Google

Questo è un riepilogo delle attenuazioni fornite dalla piattaforma di sicurezza Android e dalle protezioni del servizio come Google Play Protect . Queste funzionalità riducono la probabilità che le vulnerabilità della sicurezza possano essere sfruttate con successo su Android.

  • Lo sfruttamento per molti problemi su Android è reso più difficile dai miglioramenti nelle versioni più recenti della piattaforma Android. Incoraggiamo tutti gli utenti ad aggiornare all'ultima versione di Android, ove possibile.
  • Il team di sicurezza di Android monitora attivamente gli abusi tramite Google Play Protect e avvisa gli utenti in merito alle applicazioni potenzialmente dannose . Google Play Protect è abilitato per impostazione predefinita sui dispositivi con Google Mobile Services ed è particolarmente importante per gli utenti che installano app al di fuori di Google Play.

Dettagli sulla vulnerabilità del livello di patch di sicurezza 2020-11-01

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2020-11-01. Le vulnerabilità sono raggruppate sotto la componente che interessano. I problemi sono descritti nelle tabelle seguenti e includono l'ID CVE, i riferimenti associati, il tipo di vulnerabilità , la gravità e le versioni AOSP aggiornate (ove applicabile). Quando disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID del bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, i riferimenti aggiuntivi sono collegati a numeri che seguono l'ID del bug. I dispositivi con Android 10 e versioni successive possono ricevere aggiornamenti di sicurezza e aggiornamenti di sistema di Google Play .

Tempo di esecuzione Android

La vulnerabilità in questa sezione potrebbe consentire a un'applicazione dannosa locale di ignorare i requisiti di interazione dell'utente per ottenere l'accesso a autorizzazioni aggiuntive.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2020-0409
A-156997193 EoP Alto 8.0, 8.1, 9, 10

Struttura

La vulnerabilità più grave in questa sezione può consentire a un utente malintenzionato remoto che utilizza un messaggio appositamente predisposto di causare un Denial of Service permanente.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2020-0441
A-158304295 DoS Critico 8.0, 8.1, 9, 10, 11
CVE-2020-0442
A-147358092 DoS Critico 8.0, 8.1, 9, 10, 11
CVE-2020-0418
A-153879813 EoP Alto 10
CVE-2020-0439
A-140256621 [ 2 ] EoP Alto 8.0, 8.1, 9, 10, 11
CVE-2020-0454
A-161370134 [ 2 ] ID Alto 9
CVE-2020-0443
A-152410253 DoS Alto 8.0, 8.1, 9, 10, 11

Quadro multimediale

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2020-0451
A-158762825 ID Alto 10, 11
RCE Critico 8.0, 8.1, 9
CVE-2020-0452
A-159625731 RCE Alto 8.0, 8.1, 9, 10, 11
CVE-2020-0438
A-161812320 EoP Alto 11
EoP Moderare 10

Sistema

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato prossimale che utilizza una trasmissione appositamente predisposta di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2020-0449
A-162497143 RCE Critico 8.0, 8.1, 9, 10, 11
CVE-2020-12856
A-157038281 [ 2 ] [ 3 ] [ 4 ] EoP Alto 8.0, 8.1, 9, 10, 11
CVE-2020-0424
A-161362564 ID Alto 9, 10, 11
CVE-2020-0448
A-153995334 ID Alto 8.0, 8.1, 9, 10, 11
CVE-2020-0450
A-157650336 ID Alto 8.0, 8.1, 9, 10, 11
CVE-2020-0453
A-159060474 ID Alto 8.0, 8.1, 9
CVE-2020-0437
A-162741784 DoS Alto 8.0, 8.1, 9, 10, 11

Aggiornamenti di sistema di Google Play

I seguenti problemi sono inclusi nei componenti di Project Mainline.

Componente CVE
Controllore delle autorizzazioni CVE-2020-0418
Codec multimediali CVE-2020-0451
Risolutore DNS CVE-2020-0424

Dettagli sulla vulnerabilità del livello di patch di sicurezza 2020-11-05

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2020-11-05. Le vulnerabilità sono raggruppate sotto la componente che interessano. I problemi sono descritti nelle tabelle seguenti e includono l'ID CVE, i riferimenti associati, il tipo di vulnerabilità , la gravità e le versioni AOSP aggiornate (ove applicabile). Quando disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID del bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, i riferimenti aggiuntivi sono collegati a numeri che seguono l'ID del bug.

MediaTek

Queste vulnerabilità interessano i componenti di MediaTek e ulteriori dettagli sono disponibili direttamente da MediaTek. La valutazione della gravità di questi problemi è fornita direttamente da MediaTek.

CVE Riferimenti Gravità Componente
CVE-2020-0445
A-168264527
M-ALPS05253566 *
Alto codificatore video
CVE-2020-0446
A-168264528
M-ALPS05257259 *
M-ALPS05316810 *
Alto decodificatore video
CVE-2020-0447
A-168251617
M-ALPS05287879 *
Alto ptp3

Componenti chiusi di Qualcomm

Queste vulnerabilità interessano i componenti closed-source di Qualcomm e sono descritte più dettagliatamente nel bollettino sulla sicurezza di Qualcomm o nell'avviso di sicurezza appropriato. La valutazione della gravità di questi problemi è fornita direttamente da Qualcomm.

CVE Riferimenti Gravità Componente
CVE-2020-3639
A-155653490 * Critico Componente closed-source
CVE-2020-3632
A-155652696 * Alto Componente closed-source
CVE-2020-11123
A-155652382 * Alto Componente closed-source
CVE-2020-11127
A-155653795 * Alto Componente closed-source
CVE-2020-11168
A-162756122 * Alto Componente closed-source
CVE-2020-11175
A-162756020 * Alto Componente closed-source
CVE-2020-11184
A-162756352 * Alto Componente closed-source
CVE-2020-11193
A-162756585 * Alto Componente closed-source
CVE-2020-11196
A-162756960 * Alto Componente closed-source
CVE-2020-11205
A-162757240 * Alto Componente closed-source

Domande e risposte comuni

Questa sezione risponde alle domande più comuni che possono verificarsi dopo la lettura di questo bollettino.

1. Come faccio a determinare se il mio dispositivo è aggiornato per risolvere questi problemi?

Per informazioni su come controllare il livello di patch di sicurezza di un dispositivo, consulta Controllare e aggiornare la versione di Android .

  • I livelli di patch di sicurezza del 01-11-2020 o successivi risolvono tutti i problemi associati al livello di patch di sicurezza del 01-11-2020.
  • I livelli di patch di sicurezza del 05-11-2020 o successivi risolvono tutti i problemi associati al livello di patch di sicurezza del 05-11-2020 e tutti i livelli di patch precedenti.

I produttori di dispositivi che includono questi aggiornamenti devono impostare il livello della stringa di patch su:

  • [ro.build.version.security_patch]:[2020-11-01]
  • [ro.build.version.security_patch]:[2020-11-05]

Per alcuni dispositivi con Android 10 o versioni successive, l'aggiornamento del sistema di Google Play avrà una stringa di data che corrisponde al livello della patch di sicurezza 2020-11-01. Consulta questo articolo per maggiori dettagli su come installare gli aggiornamenti di sicurezza.

2. Perché questo bollettino ha due livelli di patch di sicurezza?

Questo bollettino ha due livelli di patch di sicurezza in modo che i partner Android abbiano la flessibilità di correggere più rapidamente un sottoinsieme di vulnerabilità simili su tutti i dispositivi Android. I partner Android sono invitati a risolvere tutti i problemi in questo bollettino e utilizzare il livello di patch di sicurezza più recente.

  • I dispositivi che utilizzano il livello di patch di sicurezza 2020-11-01 devono includere tutti i problemi associati a tale livello di patch di sicurezza, nonché le correzioni per tutti i problemi segnalati nei precedenti bollettini sulla sicurezza.
  • I dispositivi che utilizzano il livello di patch di sicurezza 2020-11-05 o successivo devono includere tutte le patch applicabili in questo (e precedenti) bollettini sulla sicurezza.

I partner sono incoraggiati a raggruppare le correzioni per tutti i problemi che stanno affrontando in un unico aggiornamento.

3. Cosa significano le voci nella colonna Tipo ?

Le voci nella colonna Tipo della tabella dei dettagli della vulnerabilità fanno riferimento alla classificazione della vulnerabilità della sicurezza.

Abbreviazione Definizione
RCE Esecuzione di codice a distanza
EoP Elevazione del privilegio
ID Rivelazione di un 'informazione
DoS Negazione del servizio
N / A Classificazione non disponibile

4. Cosa significano le voci nella colonna Riferimenti ?

Le voci nella colonna Riferimenti della tabella dei dettagli della vulnerabilità possono contenere un prefisso che identifica l'organizzazione a cui appartiene il valore di riferimento.

Prefisso Riferimento
UN- ID bug Android
controllo qualità- Numero di riferimento Qualcomm
M- Numero di riferimento MediaTek
N- Numero di riferimento NVIDIA
B- Numero di riferimento Broadcom

5. Cosa significa un * accanto all'ID del bug Android nella colonna Riferimenti ?

I problemi che non sono disponibili pubblicamente hanno un * accanto all'ID di riferimento corrispondente. L'aggiornamento per quel problema è generalmente contenuto nei driver binari più recenti per i dispositivi Pixel disponibili sul sito Google Developer .

6. Perché le vulnerabilità della sicurezza sono suddivise tra questo bollettino e i bollettini sulla sicurezza del dispositivo/partner, come il bollettino Pixel?

Le vulnerabilità di sicurezza documentate in questo bollettino sulla sicurezza sono necessarie per dichiarare il livello di patch di sicurezza più recente sui dispositivi Android. Per dichiarare un livello di patch di sicurezza non sono necessarie ulteriori vulnerabilità di sicurezza documentate nei bollettini sulla sicurezza del dispositivo/partner. I produttori di dispositivi Android e chipset possono anche pubblicare dettagli sulla vulnerabilità della sicurezza specifici dei loro prodotti, come Google , Huawei , LGE , Motorola , Nokia o Samsung .

Versioni

Versione Data Appunti
1.0 2 novembre 2020 Bollettino pubblicato
1.1 4 novembre 2020 Bollettino rivisto per includere i collegamenti AOSP