بولتن امنیتی اندروید - ژانویه 2021

منتشر شده در 4 ژانویه 2021 | به روز شده در 7 ژانویه 2021

بولتن امنیتی اندروید حاوی جزئیاتی از آسیب پذیری های امنیتی است که بر دستگاه های اندرویدی تأثیر می گذارد. سطوح وصله امنیتی 2021-01-05 یا بالاتر همه این مشکلات را برطرف می کند. برای آشنایی با نحوه بررسی سطح وصله امنیتی دستگاه، به بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

شرکای Android حداقل یک ماه قبل از انتشار از همه مشکلات مطلع می شوند. وصله کد منبع برای این مشکلات در مخزن پروژه منبع باز Android (AOSP) منتشر شده و از این بولتن پیوند داده شده است. این بولتن همچنین شامل پیوندهایی به وصله های خارج از AOSP است.

شدیدترین این مسائل یک آسیب پذیری امنیتی حیاتی در مؤلفه System است که می تواند یک مهاجم راه دور را با استفاده از یک انتقال ساخته شده ویژه قادر به اجرای کد دلخواه در چارچوب یک فرآیند ممتاز کند. ارزیابی شدت بر اساس تأثیری است که بهره‌برداری از آسیب‌پذیری احتمالاً روی دستگاه آسیب‌دیده می‌گذارد، با این فرض که پلت‌فرم و تخفیف‌های سرویس برای اهداف توسعه خاموش شده‌اند یا در صورت دور زدن موفقیت‌آمیز انجام شوند.

برای جزئیات بیشتر در مورد حفاظت های پلتفرم امنیتی اندروید و Google Play Protect که امنیت پلتفرم اندروید را بهبود می بخشد، به بخش کاهش دهنده های Android و Google Play Protect مراجعه کنید.

کاهش خدمات اندروید و گوگل

این خلاصه‌ای از کاهش‌های ارائه شده توسط پلتفرم امنیتی Android و محافظت‌های خدماتی مانند Google Play Protect است. این قابلیت ها احتمال سوء استفاده موفقیت آمیز از آسیب پذیری های امنیتی در اندروید را کاهش می دهد.

  • بهره برداری از بسیاری از مسائل در اندروید با پیشرفت در نسخه های جدیدتر پلتفرم اندروید دشوارتر شده است. ما همه کاربران را تشویق می کنیم تا در صورت امکان به آخرین نسخه اندروید بروزرسانی کنند.
  • تیم امنیتی Android به طور فعال از طریق Google Play Protect برای سوء استفاده نظارت می کند و به کاربران در مورد برنامه های بالقوه مضر هشدار می دهد. Google Play Protect به طور پیش‌فرض در دستگاه‌های دارای سرویس‌های Google Mobile فعال است و به ویژه برای کاربرانی که برنامه‌هایی را از خارج از Google Play نصب می‌کنند، مهم است.

جزئیات آسیب‌پذیری سطح وصله امنیتی 01/01/2021

در بخش‌های زیر، جزئیات مربوط به هر یک از آسیب‌پذیری‌های امنیتی را که در سطح وصله 01-01-2021 اعمال می‌شود، ارائه می‌کنیم. آسیب‌پذیری‌ها بر اساس مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند. مسائل در جداول زیر توضیح داده شده اند و شامل شناسه CVE، مراجع مرتبط، نوع آسیب پذیری ، شدت و نسخه های به روز شده AOSP (در صورت لزوم) می باشند. هنگامی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است، مانند لیست تغییرات AOSP، به شناسه اشکال مرتبط می کنیم. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعدادی که پس از شناسه اشکال مرتبط هستند، مرتبط می شوند. دستگاه‌های دارای Android 10 و بالاتر ممکن است به‌روزرسانی‌های امنیتی و همچنین به‌روزرسانی‌های سیستم Google Play را دریافت کنند.

چارچوب

شدیدترین آسیب‌پذیری در این بخش می‌تواند یک مهاجم راه دور را با استفاده از رشته‌ای ساخته‌شده خاص قادر به انکار دائمی سرویس کند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2021-0313
الف-170968514 DoS بحرانی 8.0، 8.1، 9، 10، 11
CVE-2021-0303
الف-170407229 EoP بالا 11
CVE-2021-0306
A-154505240 [ 2 ] EoP بالا 8.0، 8.1، 9، 10، 11
CVE-2021-0307
A-155648771 [ 2 ] EoP بالا 10، 11
CVE-2021-0310
الف-170212632 EoP بالا 11
CVE-2021-0315
الف-169763814 EoP بالا 8.0، 8.1، 9، 10، 11
CVE-2021-0317
الف-168319670 EoP بالا 8.0، 8.1، 9، 10، 11
CVE-2021-0318
الف-168211968 EoP بالا 8.1، 9، 10، 11
CVE-2021-0319
الف-167244818 EoP بالا 8.0، 8.1، 9، 10، 11
CVE-2021-0304
الف-162738636 شناسه بالا 8.0، 8.1، 9، 10
CVE-2021-0309
الف-158480899 شناسه بالا 8.0، 8.1، 9، 10، 11
CVE-2021-0321
الف-166667403 شناسه بالا 11
CVE-2021-0322
A-159145361 [ 2 ] شناسه بالا 9، 10، 11
CVE-2019-9376
الف-129287265 DoS بالا 8.0، 8.1، 9
CVE-2020-15999
الف-171232105 RCE در حد متوسط 8.0، 8.1، 9، 10، 11

چارچوب رسانه ای

شدیدترین آسیب‌پذیری در این بخش می‌تواند یک مهاجم از راه دور را با استفاده از یک فایل ساخته‌شده خاص قادر به اجرای کد دلخواه در چارچوب یک فرآیند ممتاز کند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2016-6328
الف-162602132 RCE بالا 8.0، 8.1، 9، 10، 11
CVE-2021-0311
الف-170240631 شناسه بالا 8.0، 8.1، 9، 10، 11
CVE-2021-0312
الف-170583712 شناسه بالا 8.0، 8.1، 9، 10، 11

سیستم

شدیدترین آسیب‌پذیری در این بخش می‌تواند یک مهاجم از راه دور را با استفاده از یک انتقال ساخته‌شده خاص قادر به اجرای کد دلخواه در چارچوب یک فرآیند ممتاز کند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2021-0316
الف-168802990 RCE بحرانی 8.0، 8.1، 9، 10، 11
CVE-2020-0471
الف-169327567 EoP بالا 8.0، 8.1، 9، 10، 11
CVE-2021-0308
الف-158063095 EoP بالا 8.0، 8.1، 9، 10، 11
CVE-2021-0320
الف-169933423 شناسه بالا 10، 11

به روز رسانی سیستم گوگل پلی

مسائل زیر در اجزای Project Mainline گنجانده شده است.

مولفه CVE
اجزای چارچوب رسانه CVE-2021-0311، CVE-2021-0312

جزئیات آسیب پذیری سطح وصله امنیتی 05/01/2021

در بخش‌های زیر، جزئیات مربوط به هر یک از آسیب‌پذیری‌های امنیتی را که در سطح وصله ۰۵-۰۱-۲۰۲۱ اعمال می‌شوند، ارائه می‌کنیم. آسیب‌پذیری‌ها بر اساس مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند. مسائل در جداول زیر توضیح داده شده اند و شامل شناسه CVE، مراجع مرتبط، نوع آسیب پذیری ، شدت و نسخه های به روز شده AOSP (در صورت لزوم) می باشند. هنگامی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است، مانند لیست تغییرات AOSP، به شناسه اشکال مرتبط می کنیم. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعدادی که پس از شناسه اشکال مرتبط هستند، مرتبط می شوند.

اجزای هسته

شدیدترین آسیب پذیری در این بخش می تواند یک برنامه مخرب محلی را قادر سازد تا از حفاظت های سیستم عاملی که داده های برنامه را از سایر برنامه ها جدا می کند دور بزند.

CVE منابع تایپ کنید شدت مولفه
CVE-2020-10732 الف-170658976
هسته بالادست
شناسه بالا تخلیه هسته ELF
CVE-2020-10766 الف-169505740
هسته بالادست
شناسه بالا اعدام گمانه زنی
CVE-2020-10767 الف-156766097
هسته بالادست
شناسه بالا هسته لینوکس

اجزای مدیاتک

این آسیب پذیری بر اجزای MediaTek تأثیر می گذارد و جزئیات بیشتر به طور مستقیم از MediaTek در دسترس است. ارزیابی شدت این موضوع به طور مستقیم توسط مدیاتک ارائه شده است.

CVE منابع شدت مولفه
CVE-2021-0301 الف-172514667
M-ALPS05342361 *
بالا ged

قطعات کوالکام

این آسیب‌پذیری‌ها بر اجزای کوالکام تأثیر می‌گذارند و با جزئیات بیشتر در بولتن امنیتی یا هشدار امنیتی کوالکام توضیح داده شده‌اند. ارزیابی شدت این مسائل به طور مستقیم توسط کوالکام ارائه شده است.

CVE منابع شدت مولفه
CVE-2020-11233 الف-170138863
QC-CR#2257789
بالا هسته
CVE-2020-11239 الف-168722551
QC-CR#2744826
بالا نمایش دادن
CVE-2020-11240 الف-170138526
QC-CR#2702760 [ 2 ] [ 3 ]
بالا دوربین
CVE-2020-11250 الف-170139097
QC-CR#2734543
بالا سمعی
CVE-2020-11261 الف-161373974
QC-CR#2742124
بالا نمایش دادن
CVE-2020-11262 الف-170138789
QC-CR#2742711
بالا نمایش دادن

اجزای منبع بسته کوالکام

این آسیب‌پذیری‌ها بر اجزای منبع بسته کوالکام تأثیر می‌گذارند و در بولتن امنیتی یا هشدار امنیتی مناسب کوالکام با جزئیات بیشتر توضیح داده شده‌اند. ارزیابی شدت این مسائل به طور مستقیم توسط کوالکام ارائه شده است.

CVE منابع شدت مولفه
CVE-2020-11134 A-170138862 * بحرانی جزء منبع بسته
CVE-2020-11182 A-168722721 * بحرانی جزء منبع بسته
CVE-2020-11126 A-170139227 * بالا جزء منبع بسته
CVE-2020-11159
A-170138666 * بالا جزء منبع بسته
CVE-2020-11181 A-168051034 * بالا جزء منبع بسته
CVE-2020-11235 A-170138866 * بالا جزء منبع بسته
CVE-2020-11238 A-170139099 * بالا جزء منبع بسته
CVE-2020-11241 A-170139229 * بالا جزء منبع بسته
CVE-2020-11260 A-168918332 * بالا جزء منبع بسته

پرسش و پاسخ متداول

این بخش به سوالات متداولی که ممکن است پس از خواندن این بولتن رخ دهد پاسخ می دهد.

1. چگونه تشخیص دهم که آیا دستگاه من برای رفع این مشکلات به روز شده است؟

برای آشنایی با نحوه بررسی سطح وصله امنیتی دستگاه، به بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

  • سطوح وصله امنیتی 2021-01-01 یا جدیدتر تمام مسائل مرتبط با سطح وصله امنیتی 2021-01-01 را برطرف می کند.
  • سطوح وصله امنیتی 2021-01-05 یا جدیدتر، تمام مسائل مرتبط با سطح وصله امنیتی 2021-01-05 و تمام سطوح وصله قبلی را برطرف می کند.

سازندگان دستگاه‌هایی که شامل این به‌روزرسانی‌ها می‌شوند باید سطح رشته وصله را روی موارد زیر تنظیم کنند:

  • [ro.build.version.security_patch]:[01-01-2021]
  • [ro.build.version.security_patch]:[05-01-2021]

برای برخی از دستگاه‌های اندروید 10 یا جدیدتر، به‌روزرسانی سیستم Google Play دارای یک رشته تاریخی است که با سطح وصله امنیتی 01-01-2021 مطابقت دارد. لطفاً برای جزئیات بیشتر در مورد نحوه نصب به‌روزرسانی‌های امنیتی، این مقاله را ببینید.

2. چرا این بولتن دارای دو سطح وصله امنیتی است؟

این بولتن دارای دو سطح وصله امنیتی است تا شرکای Android انعطاف پذیری لازم را داشته باشند تا زیرمجموعه ای از آسیب پذیری ها را که در همه دستگاه های اندرویدی مشابه هستند با سرعت بیشتری برطرف کنند. شرکای Android تشویق می شوند تا تمام مشکلات موجود در این بولتن را برطرف کنند و از آخرین سطح وصله امنیتی استفاده کنند.

  • دستگاه‌هایی که از سطح وصله امنیتی 2021-01-01 استفاده می‌کنند باید همه مشکلات مرتبط با آن سطح وصله امنیتی و همچنین رفع تمام مشکلات گزارش‌شده در بولتن‌های امنیتی قبلی را داشته باشند.
  • دستگاه‌هایی که از سطح وصله امنیتی 2021-01-05 یا جدیدتر استفاده می‌کنند، باید همه وصله‌های قابل‌اجرا در این بولتن‌های امنیتی (و قبلی) را شامل شوند.

شرکا تشویق می شوند تا اصلاحات مربوط به همه مشکلاتی را که در حال رفع آنها هستند در یک به روز رسانی واحد جمع کنند.

3. ورودی های ستون Type به چه معناست؟

ورودی های ستون نوع جدول جزئیات آسیب پذیری به طبقه بندی آسیب پذیری امنیتی اشاره دارد.

مخفف تعریف
RCE اجرای کد از راه دور
EoP بالا بردن امتیاز
شناسه افشای اطلاعات
DoS خود داری از خدمات
N/A طبقه بندی در دسترس نیست

4. ورودی های ستون References به چه معناست؟

ورودی‌های زیر ستون مراجع جدول جزئیات آسیب‌پذیری ممکن است حاوی پیشوندی باشد که سازمانی را که مقدار مرجع به آن تعلق دارد، مشخص می‌کند.

پیشوند ارجاع
آ- شناسه باگ اندروید
QC- شماره مرجع کوالکام
M- شماره مرجع مدیاتک
N- شماره مرجع NVIDIA
ب- شماره مرجع Broadcom

5. یک * در کنار شناسه باگ اندروید در ستون References به چه معناست؟

مسائلی که به صورت عمومی در دسترس نیستند دارای علامت * در کنار شناسه مرجع مربوطه هستند. به‌روزرسانی برای آن مشکل عموماً در آخرین درایورهای باینری دستگاه‌های Pixel موجود در سایت Google Developer موجود است.

6. چرا آسیب‌پذیری‌های امنیتی بین این بولتن و بولتن‌های امنیتی دستگاه/شریک، مانند بولتن Pixel تقسیم می‌شوند؟

آسیب‌پذیری‌های امنیتی که در این بولتن امنیتی مستند شده‌اند برای اعلام آخرین سطح وصله امنیتی در دستگاه‌های اندرویدی مورد نیاز هستند. آسیب‌پذیری‌های امنیتی اضافی که در بولتن‌های امنیتی دستگاه/شریک مستند شده‌اند، برای اعلام سطح وصله امنیتی لازم نیست. سازندگان دستگاه‌ها و چیپ‌ست‌های Android نیز ممکن است جزئیات آسیب‌پذیری امنیتی خاص محصولات خود را منتشر کنند، مانند Google ، Huawei ، LGE ، Motorola ، Nokia یا Samsung .

نسخه ها

نسخه تاریخ یادداشت
1.0 4 ژانویه 2021 بولتن منتشر شد
1.1 7 ژانویه 2021 بولتن اصلاح شد تا شامل پیوندهای AOSP و جدول CVE اصلاح شده باشد