กระดานข่าวความปลอดภัยของ Android—ตุลาคม 2020

เผยแพร่เมื่อ ตุลาคม 5, 2020 | อัปเดตเมื่อวันที่ 6 ตุลาคม 2020

กระดานข่าวความปลอดภัยของ Android มีรายละเอียดเกี่ยวกับช่องโหว่ด้านความปลอดภัยที่ส่งผลต่ออุปกรณ์ Android ระดับแพตช์ความปลอดภัยในวันที่ 10-05-2020 หรือใหม่กว่าจะแก้ไขปัญหาเหล่านี้ทั้งหมด หากต้องการเรียนรู้วิธีตรวจสอบระดับแพตช์ความปลอดภัยของอุปกรณ์ โปรดดู ตรวจสอบและอัปเดตเวอร์ชัน Android ของคุณ

พันธมิตร Android จะได้รับแจ้งปัญหาทั้งหมดอย่างน้อยหนึ่งเดือนก่อนเผยแพร่ แพทช์ซอร์สโค้ดสำหรับปัญหาเหล่านี้ได้รับการเผยแพร่ไปยังพื้นที่เก็บข้อมูล Android Open Source Project (AOSP) และเชื่อมโยงจากกระดานข่าวนี้ กระดานข่าวนี้ยังรวมลิงก์ไปยังแพตช์ภายนอก AOSP อีกด้วย

ปัญหาที่ร้ายแรงที่สุดเหล่านี้คือช่องโหว่ด้านความปลอดภัยสูงในองค์ประกอบของระบบที่อาจทำให้ผู้โจมตีจากระยะไกลใช้การส่งข้อมูลที่สร้างขึ้นเป็นพิเศษเพื่อเข้าถึงสิทธิ์เพิ่มเติมได้ การประเมินความรุนแรง นั้นขึ้นอยู่กับผลกระทบที่การใช้ประโยชน์จากช่องโหว่ที่อาจเกิดขึ้นกับอุปกรณ์ที่ได้รับผลกระทบ โดยถือว่าแพลตฟอร์มและบริการบรรเทาผลกระทบถูกปิดเพื่อวัตถุประสงค์ในการพัฒนาหรือหากข้ามได้สำเร็จ

โปรดดูส่วน การลดปัญหา Android และ Google Play Protect สำหรับรายละเอียดเกี่ยวกับ การป้องกันแพลตฟอร์มความปลอดภัยของ Android และ Google Play Protect ซึ่งปรับปรุงความปลอดภัยของแพลตฟอร์ม Android

การบรรเทาปัญหาบริการ Android และ Google

นี่คือบทสรุปของการบรรเทาผลกระทบจาก แพลตฟอร์มความปลอดภัยของ Android และการปกป้องบริการ เช่น Google Play Protect ความสามารถเหล่านี้ลดโอกาสที่ช่องโหว่ด้านความปลอดภัยจะถูกโจมตีบน Android ได้สำเร็จ

  • การใช้ประโยชน์จากปัญหาต่างๆ บน Android ทำได้ยากขึ้นด้วยการปรับปรุงแพลตฟอร์ม Android เวอร์ชันใหม่ เราขอแนะนำให้ผู้ใช้ทุกคนอัปเดตเป็น Android เวอร์ชันล่าสุดเมื่อเป็นไปได้
  • ทีมรักษาความปลอดภัยของ Android จะคอยตรวจสอบการละเมิดผ่านทาง Google Play Protect และเตือนผู้ใช้เกี่ยวกับ แอปพลิเคชันที่อาจเป็นอันตราย Google Play Protect จะเปิดใช้งานโดยค่าเริ่มต้นในอุปกรณ์ที่มี บริการ Google Mobile และมีความสำคัญเป็นพิเศษสำหรับผู้ใช้ที่ติดตั้งแอปจากภายนอก Google Play

รายละเอียดช่องโหว่ระดับแพทช์รักษาความปลอดภัย 2020-10-01

ในส่วนด้านล่าง เราจะให้รายละเอียดเกี่ยวกับช่องโหว่ด้านความปลอดภัยแต่ละจุดที่ใช้กับระดับแพตช์ 2020-10-01 ช่องโหว่จะถูกจัดกลุ่มภายใต้องค์ประกอบที่ได้รับผลกระทบ ปัญหาต่างๆ ได้รับการอธิบายไว้ในตารางด้านล่างและรวมถึง CVE ID, ข้อมูลอ้างอิงที่เกี่ยวข้อง, ประเภทของช่องโหว่ , ความรุนแรง และเวอร์ชัน AOSP ที่อัปเดต (หากมี) เมื่อพร้อมใช้งาน เราจะเชื่อมโยงการเปลี่ยนแปลงสาธารณะที่แก้ไขปัญหากับรหัสข้อบกพร่อง เช่น รายการการเปลี่ยนแปลง AOSP เมื่อการเปลี่ยนแปลงหลายอย่างเกี่ยวข้องกับจุดบกพร่องจุดเดียว การอ้างอิงเพิ่มเติมจะเชื่อมโยงกับหมายเลขที่ตามหลังรหัสจุดบกพร่อง อุปกรณ์ที่ใช้ Android 10 ขึ้นไปอาจได้รับการอัปเดตด้านความปลอดภัย รวมถึง การอัปเดตระบบ Google Play

รันไทม์ของ Android

ช่องโหว่ในส่วนนี้อาจทำให้ผู้โจมตีเฉพาะที่เรียกใช้โค้ดที่กำหนดเองภายในบริบทของแอปพลิเคชันที่ใช้ไลบรารีได้

ซีวีอี อ้างอิง พิมพ์ ความรุนแรง อัปเดตเวอร์ชัน AOSP
CVE-2020-0408 A-156999009 อีโอพี สูง 8.0, 8.1, 9, 10, 11

กรอบ

ช่องโหว่ที่ร้ายแรงที่สุดในส่วนนี้อาจทำให้แอปพลิเคชันที่เป็นอันตรายในเครื่องสามารถข้ามข้อกำหนดการโต้ตอบของผู้ใช้เพื่อเข้าถึงสิทธิ์เพิ่มเติมได้

ซีวีอี อ้างอิง พิมพ์ ความรุนแรง อัปเดตเวอร์ชัน AOSP
CVE-2020-0420
A-162383705 อีโอพี สูง 11
CVE-2020-0421 A-161894517 อีโอพี สูง 8.0, 8.1, 9, 10, 11
CVE-2020-0246
A-159062405 บัตรประจำตัวประชาชน สูง 10, 11
CVE-2020-0412
A-160390416 บัตรประจำตัวประชาชน สูง 8.0, 8.1, 9, 10, 11
CVE-2020-0419
A-142125338 บัตรประจำตัวประชาชน สูง 8.1, 9, 10, 11

กรอบสื่อ

ช่องโหว่ที่ร้ายแรงที่สุดในส่วนนี้อาจนำไปสู่การเปิดเผยข้อมูลระยะไกลโดยไม่ต้องมีสิทธิ์ดำเนินการเพิ่มเติม

ซีวีอี อ้างอิง พิมพ์ ความรุนแรง อัปเดตเวอร์ชัน AOSP
CVE-2020-0213 A-143464314 บัตรประจำตัวประชาชน สูง 10, 11
CVE-2020-0411 A-142641801 บัตรประจำตัวประชาชน สูง 10, 11
CVE-2020-0414
A-157708122 บัตรประจำตัวประชาชน สูง 10, 11
CVE-2019-2194
A-137284057 อีโอพี ปานกลาง 9

ระบบ

ช่องโหว่ที่ร้ายแรงที่สุดในส่วนนี้อาจทำให้ผู้โจมตีจากระยะไกลใช้การส่งข้อมูลที่สร้างขึ้นเป็นพิเศษเพื่อเข้าถึงสิทธิ์เพิ่มเติมได้

ซีวีอี อ้างอิง พิมพ์ ความรุนแรง อัปเดตเวอร์ชัน AOSP
CVE-2020-0215
A-140417248 [ 2 ] อีโอพี สูง 8.0, 8.1, 9, 10, 11
CVE-2020-0416
A-155288585 [ 2 ] อีโอพี สูง 8.0, 8.1, 9, 10, 11
CVE-2020-0377
A-158833854 บัตรประจำตัวประชาชน สูง 8.0, 8.1, 9, 10, 11
CVE-2020-0378
A-157748906 บัตรประจำตัวประชาชน สูง 9, 10, 11
CVE-2020-0398
A-154323381 บัตรประจำตัวประชาชน สูง 10, 11
CVE-2020-0400
A-153356561 บัตรประจำตัวประชาชน สูง 10, 11
CVE-2020-0410
A-156021269 บัตรประจำตัวประชาชน สูง 8.0, 8.1, 9, 10, 11
CVE-2020-0413
A-158778659 บัตรประจำตัวประชาชน สูง 8.0, 8.1, 9, 10, 11
CVE-2020-0415
A-156020795 บัตรประจำตัวประชาชน สูง 8.0, 8.1, 9, 10, 11
CVE-2020-0422
A-161718556 บัตรประจำตัวประชาชน สูง 8.0, 8.1, 9, 10, 11

การอัปเดตระบบ Google Play

ปัญหาต่อไปนี้จะรวมอยู่ในส่วนประกอบของ Project Mainline

ส่วนประกอบ ซีวีอี
ตัวแปลงสัญญาณมีเดีย CVE-2020-0213
ส่วนประกอบกรอบสื่อ CVE-2020-0411

รายละเอียดช่องโหว่ระดับแพทช์รักษาความปลอดภัย 2020-10-05

ในส่วนด้านล่าง เราจะให้รายละเอียดเกี่ยวกับช่องโหว่ด้านความปลอดภัยแต่ละจุดที่ใช้กับระดับแพตช์ 2020-10-05 ช่องโหว่จะถูกจัดกลุ่มภายใต้องค์ประกอบที่ได้รับผลกระทบ ปัญหาต่างๆ ได้รับการอธิบายไว้ในตารางด้านล่างและรวมถึง CVE ID, ข้อมูลอ้างอิงที่เกี่ยวข้อง, ประเภทของช่องโหว่ , ความรุนแรง และเวอร์ชัน AOSP ที่อัปเดต (หากมี) เมื่อพร้อมใช้งาน เราจะเชื่อมโยงการเปลี่ยนแปลงสาธารณะที่แก้ไขปัญหากับรหัสข้อบกพร่อง เช่น รายการการเปลี่ยนแปลง AOSP เมื่อการเปลี่ยนแปลงหลายอย่างเกี่ยวข้องกับจุดบกพร่องจุดเดียว การอ้างอิงเพิ่มเติมจะเชื่อมโยงกับหมายเลขที่ตามหลังรหัสจุดบกพร่อง

เคอร์เนล

ช่องโหว่ในส่วนนี้อาจทำให้ผู้โจมตีในพื้นที่ใช้ไฟล์ที่สร้างขึ้นเป็นพิเศษเพื่อรันโค้ดที่กำหนดเองภายในบริบทของกระบวนการที่ได้รับสิทธิพิเศษ

ซีวีอี อ้างอิง พิมพ์ ความรุนแรง ส่วนประกอบ
CVE-2020-0423 A-161151868 * อีโอพี สูง เครื่องผูก

ส่วนประกอบ MediaTek

ช่องโหว่เหล่านี้ส่งผลกระทบต่อส่วนประกอบของ MediaTek และรายละเอียดเพิ่มเติมสามารถดูได้จาก MediaTek โดยตรง MediaTek เป็นผู้จัดเตรียมการประเมินความรุนแรงของปัญหาเหล่านี้โดยตรง

ซีวีอี อ้างอิง ความรุนแรง ส่วนประกอบ
CVE-2020-0283 A-163008257
M-ALPS05229282 *
สูง ติดตั้งคีย์
CVE-2020-0339 A-162980705
M-ALPS05194445 *
สูง ไวด์ไวน์
CVE-2020-0367
A-162980455
M-ALPS05194445 *
สูง ไวด์ไวน์
CVE-2020-0371 A-163008256
M-ALPS05229226 *
สูง ติดตั้งคีย์
CVE-2020-0376
A-163003156
M-ALPS05194415 *
สูง ผู้ให้บริการอินเทอร์เน็ต

ส่วนประกอบของควอลคอมม์

ช่องโหว่เหล่านี้ส่งผลกระทบต่อส่วนประกอบของ Qualcomm และมีการอธิบายไว้ในรายละเอียดเพิ่มเติมในกระดานข่าวความปลอดภัยของ Qualcomm หรือการแจ้งเตือนด้านความปลอดภัยที่เหมาะสม การประเมินความรุนแรงของปัญหาเหล่านี้จัดทำโดย Qualcomm โดยตรง

ซีวีอี อ้างอิง ความรุนแรง ส่วนประกอบ
CVE-2020-11125 A-160605820
QC-CR#2617422
QC-CR#2673763
สูง เคอร์เนล
CVE-2020-11162 A-160605604
QC-CR#2677376
สูง เคอร์เนล
CVE-2020-11173 A-160605709
QC-CR#2646001
สูง เคอร์เนล
CVE-2020-11174 A-160605900
QC-CR#2636449
สูง เคอร์เนล

ส่วนประกอบโอเพ่นซอร์สของ Qualcomm

ช่องโหว่เหล่านี้ส่งผลกระทบต่อส่วนประกอบแบบปิดของ Qualcomm และมีการอธิบายไว้ในรายละเอียดเพิ่มเติมในกระดานข่าวความปลอดภัยของ Qualcomm หรือการแจ้งเตือนด้านความปลอดภัยที่เหมาะสม การประเมินความรุนแรงของปัญหาเหล่านี้จัดทำโดย Qualcomm โดยตรง

ซีวีอี อ้างอิง ความรุนแรง ส่วนประกอบ
CVE-2020-3654 A-153346045 * วิกฤต ส่วนประกอบแบบปิด
CVE-2020-3657 A-153344684 * วิกฤต ส่วนประกอบแบบปิด
CVE-2020-3673 A-153345154 * วิกฤต ส่วนประกอบแบบปิด
CVE-2020-3692 A-153345116 * วิกฤต ส่วนประกอบแบบปิด
CVE-2020-11154
A-160605708 * วิกฤต ส่วนประกอบแบบปิด
CVE-2020-11155 A-160605404 * วิกฤต ส่วนประกอบแบบปิด
CVE-2020-3638 A-153346253 * สูง ส่วนประกอบแบบปิด
CVE-2020-3670 A-153345118 * สูง ส่วนประกอบแบบปิด
CVE-2020-3678 A-153345398 * สูง ส่วนประกอบแบบปิด
CVE-2020-3684 A-153346047 * สูง ส่วนประกอบแบบปิด
CVE-2020-3690 A-153344723 * สูง ส่วนประกอบแบบปิด
CVE-2020-3703 A-160605749 * สูง ส่วนประกอบแบบปิด
CVE-2020-3704 A-160605508 * สูง ส่วนประกอบแบบปิด
CVE-2020-11141 A-160606016 * สูง ส่วนประกอบแบบปิด
CVE-2020-11156 A-160605294 * สูง ส่วนประกอบแบบปิด
CVE-2020-11157 A-160605864 * สูง ส่วนประกอบแบบปิด
CVE-2020-11164 A-160605595 * สูง ส่วนประกอบแบบปิด
CVE-2020-11169 A-160605405 * สูง ส่วนประกอบแบบปิด

คำถามและคำตอบทั่วไป

ส่วนนี้จะตอบคำถามทั่วไปที่อาจเกิดขึ้นหลังจากอ่านกระดานข่าวนี้

1. ฉันจะทราบได้อย่างไรว่าอุปกรณ์ของฉันได้รับการอัปเดตเพื่อแก้ไขปัญหาเหล่านี้หรือไม่

หากต้องการเรียนรู้วิธีตรวจสอบระดับแพตช์ความปลอดภัยของอุปกรณ์ โปรดดู ตรวจสอบและอัปเดตเวอร์ชัน Android ของคุณ

  • ระดับแพตช์ความปลอดภัยปี 2020-10-01 หรือใหม่กว่าจะแก้ไขปัญหาทั้งหมดที่เกี่ยวข้องกับระดับแพตช์ความปลอดภัยปี 2020-10-01
  • ระดับแพตช์ความปลอดภัยปี 2020-10-05 หรือใหม่กว่า แก้ไขปัญหาทั้งหมดที่เกี่ยวข้องกับระดับแพตช์ความปลอดภัยปี 2020-10-05 และระดับแพตช์ก่อนหน้าทั้งหมด

ผู้ผลิตอุปกรณ์ที่มีการอัปเดตเหล่านี้ควรตั้งค่าระดับสตริงโปรแกรมแก้ไขเป็น:

  • [ro.build.version.security_patch]:[2020-10-01]
  • [ro.build.version.security_patch]:[2020-10-05]

สำหรับอุปกรณ์บางรุ่นที่ใช้ Android 10 หรือใหม่กว่า การอัปเดตระบบ Google Play จะมีสตริงวันที่ที่ตรงกับระดับแพตช์ความปลอดภัย 2020-10-01 โปรดดู บทความนี้ สำหรับรายละเอียดเพิ่มเติมเกี่ยวกับวิธีการติดตั้งการอัปเดตความปลอดภัย

2. เหตุใดกระดานข่าวนี้จึงมีแพตช์รักษาความปลอดภัยสองระดับ

กระดานข่าวนี้มีแพตช์รักษาความปลอดภัยสองระดับ เพื่อให้พันธมิตร Android มีความยืดหยุ่นในการแก้ไขชุดย่อยของช่องโหว่ที่คล้ายกันในอุปกรณ์ Android ทั้งหมดได้รวดเร็วยิ่งขึ้น เราสนับสนุนให้พันธมิตร Android แก้ไขปัญหาทั้งหมดในกระดานข่าวนี้ และใช้ระดับแพตช์ความปลอดภัยล่าสุด

  • อุปกรณ์ที่ใช้ระดับแพตช์รักษาความปลอดภัยประจำปี 2020-10-01 จะต้องรวมปัญหาทั้งหมดที่เกี่ยวข้องกับระดับแพตช์ความปลอดภัยนั้น รวมถึงการแก้ไขปัญหาทั้งหมดที่รายงานในกระดานข่าวความปลอดภัยก่อนหน้านี้
  • อุปกรณ์ที่ใช้ระดับแพทช์รักษาความปลอดภัย 2020-10-05 หรือใหม่กว่าจะต้องมีแพทช์ที่เกี่ยวข้องทั้งหมดไว้ในกระดานข่าวความปลอดภัยนี้ (และก่อนหน้า)

พันธมิตรได้รับการสนับสนุนให้รวมกลุ่มการแก้ไขสำหรับปัญหาทั้งหมดที่พวกเขาแก้ไขไว้ในการอัปเดตครั้งเดียว

3. รายการในคอลัมน์ ประเภท หมายถึงอะไร

รายการในคอลัมน์ ประเภท ของตารางรายละเอียดช่องโหว่อ้างอิงถึงการจัดประเภทของช่องโหว่ด้านความปลอดภัย

คำย่อ คำนิยาม
อาร์ซีอี การเรียกใช้โค้ดจากระยะไกล
อีโอพี การยกระดับสิทธิพิเศษ
บัตรประจำตัวประชาชน การเปิดเผยข้อมูล
ดอส การปฏิเสธการให้บริการ
ไม่มี ไม่มีการจำแนกประเภท

4. รายการในคอลัมน์ References หมายถึงอะไร?

รายการภายใต้คอลัมน์ การอ้างอิง ของตารางรายละเอียดช่องโหว่อาจมีคำนำหน้าที่ระบุองค์กรที่เป็นเจ้าของค่าอ้างอิง

คำนำหน้า อ้างอิง
เอ- รหัสข้อบกพร่องของ Android
การควบคุมคุณภาพ- หมายเลขอ้างอิงควอลคอมม์
เอ็ม- หมายเลขอ้างอิง MediaTek
น- หมายเลขอ้างอิง NVIDIA
ข- หมายเลขอ้างอิงของ Broadcom

5. * ถัดจาก ID บั๊กของ Android ในคอลัมน์ References หมายความว่าอย่างไร

ปัญหาที่ไม่เปิดเผยต่อสาธารณะจะมี * ถัดจากรหัสอ้างอิงที่เกี่ยวข้อง การอัปเดตสำหรับปัญหานั้นอาจมีอยู่ในไดรเวอร์ไบนารีล่าสุด (สำหรับอุปกรณ์ Pixel มีให้จากไซต์ Google Developer)

ปัญหาที่ไม่เปิดเผยต่อสาธารณะจะมี * ถัดจากรหัสอ้างอิงที่เกี่ยวข้อง การอัปเดตสำหรับปัญหานั้นอาจมีอยู่ในไดรเวอร์ไบนารีล่าสุด (สำหรับอุปกรณ์ Pixel มีให้จาก ไซต์ Google Developer )

6. เหตุใดช่องโหว่ด้านความปลอดภัยจึงถูกแยกระหว่างกระดานข่าวนี้และกระดานข่าวความปลอดภัยของอุปกรณ์ / พันธมิตร เช่น กระดานข่าว Pixel

ช่องโหว่ด้านความปลอดภัยที่ได้รับการบันทึกไว้ในกระดานข่าวความปลอดภัยนี้จำเป็นต้องประกาศระดับแพตช์ความปลอดภัยล่าสุดบนอุปกรณ์ Android ช่องโหว่ด้านความปลอดภัยเพิ่มเติมที่บันทึกไว้ในกระดานข่าวความปลอดภัยของอุปกรณ์ / พันธมิตรไม่จำเป็นสำหรับการประกาศระดับแพตช์ความปลอดภัย ผู้ผลิตอุปกรณ์ Android และชิปเซ็ตอาจเผยแพร่รายละเอียดช่องโหว่ด้านความปลอดภัยสำหรับผลิตภัณฑ์ของตนโดยเฉพาะ เช่น Google , Huawei , LGE , Motorola , Nokia หรือ Samsung

รุ่นต่างๆ

เวอร์ชัน วันที่ หมายเหตุ
1.0 5 ตุลาคม 2020 เผยแพร่กระดานข่าวแล้ว
1.1 6 ตุลาคม 2020 กระดานข่าวแก้ไขเพื่อรวมลิงก์ AOSP