Android のセキュリティに関する公開情報 - 2021 年 11 月

コレクションでコンテンツを整理 必要に応じて、コンテンツの保存と分類を行います。

2021 年 11 月 1 日公開 | 2021 年 12 月 3 日更新

Android のセキュリティに関する公開情報には、Android デバイスに影響を与えるセキュリティの脆弱性の詳細を掲載しています。セキュリティ パッチレベル 2021-11-06 以降では、下記のすべての問題に対処しています。デバイスのセキュリティ パッチレベルを確認するには、Android のバージョンを確認して更新する方法をご覧ください。

Android パートナーには、情報公開の 1 か月前までにすべての問題が通知されます。Android オープンソース プロジェクト(AOSP)のリポジトリに、以下の問題に対するソースコードのパッチをリリースしています。また、この公開情報では、これらのパッチへのリンクに加え、AOSP 以外のパッチへのリンクも掲載しています。

下記の問題のうち最も重大度の高いものは、システム コンポーネントで発見された重大なセキュリティの脆弱性です。細工した通信により、特権プロセス内で任意コードをリモートで実行される危険性があります。重大度の評価は、攻撃対象のデバイスでその脆弱性が悪用された場合の影響に基づいています。プラットフォームやサービスでのリスク軽減策が、開発目的または不正な回避策により無効となっていると仮定しています。

Android セキュリティ プラットフォームの保護や Google Play プロテクトについて詳しくは、Android と Google サービスでのリスク軽減策をご覧ください。こうした保護により、Android プラットフォームのセキュリティが改善されます。

Android と Google サービスでのリスク軽減策

ここでは、Android セキュリティ プラットフォームの保護と Google Play プロテクトのようなサービスの保護によるリスクの軽減について概説します。こうした機能は、Android でセキュリティの脆弱性が悪用される可能性を減らすものです。

  • Android 上の多くの問題の悪用は、Android プラットフォームの最新版で機能が強化されるほど困難になります。Google では、すべてのユーザーに対し、できる限り最新バージョンの Android に更新することをおすすめしています。
  • Android セキュリティ チームは、Google Play プロテクトによって脆弱性の悪用を積極的に監視しており、有害な可能性があるアプリについてユーザーに警告しています。Google Play プロテクトは、Google モバイル サービスを搭載したデバイスではデフォルトで有効になっており、Google Play 以外からアプリをインストールするユーザーにとっては特に重要です。

セキュリティ パッチレベル 2021-11-01 の脆弱性の詳細

以下に、パッチレベル 2021-11-01 に該当するセキュリティ脆弱性の各項目の詳細を示します。脆弱性は、影響を受けるコンポーネントごとに分類しています。下記の表に、問題の内容について説明し、CVE ID、関連する参照先、脆弱性のタイプ重大度、更新対象の AOSP バージョン(該当する場合)を示します。 問題の対処法として一般公開されている変更内容(AOSP の変更の一覧など)が参照可能な場合は、バグ ID の欄にその情報へのリンクがあります。 複数の変更が同じバグに関係する場合は、バグ ID の後に続く番号で、追加の参照先へのリンクを示します。 Android 10 以降を搭載したデバイスは、セキュリティ アップデートと Google Play システム アップデートを受信することがあります。

フレームワーク

フレームワークの最も重大な脆弱性により、ローカルの攻撃者が、ユーザー操作を必要とすることなく追加の権限を取得するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2021-0799 A-197647956 EoP 12
CVE-2021-0921 A-195962697 EoP 11
CVE-2021-0923 A-195338390 EoP 12
CVE-2021-0926 A-191053931 EoP 9、10、11、12
CVE-2021-0933 A-172251622 EoP 9、10、11、12
CVE-2020-13871 A-192606047 ID 11
CVE-2021-0653 A-177931370 ID 9、10、11
CVE-2021-0922 A-195630721 EoP 11

メディア フレームワーク

フレームワークの最も重大な脆弱性により、悪意のあるローカルアプリによって、追加権限を取得するためのユーザー操作の要件が回避されるおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2021-0928 A-188675581 EoP 9、10、11
CVE-2021-0650 A-190286685 ID 9、10、11

システム

システムの最も重大な脆弱性により、リモートの攻撃者が特別に細工した通信を使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2021-0918 A-197536150 RCE 重大 12
CVE-2021-0930 A-181660091 RCE 重大 9、10、11、12
CVE-2021-0434 A-167403112 [2] [3] [4] [5] [6] EoP 9、10、11
CVE-2021-0649 A-191382886 [2] EoP 11
CVE-2021-0932 A-173025705 EoP 10
CVE-2021-0925 A-191444150 ID 12
CVE-2021-0931 A-180747689 ID 9、10、11、12
CVE-2021-0919 A-197336441 DoS 9、10、11

Google Play システム アップデート

プロジェクト Mainline のコンポーネントには次の問題が含まれています。

コンポーネント CVE
テザリング CVE-2021-0653
メディア フレームワーク コンポーネント CVE-2021-0650
テザリング CVE-2021-0649

セキュリティ パッチレベル 2021-11-05 の脆弱性の詳細

以下に、パッチレベル 2021-11-05 に該当するセキュリティ脆弱性の各項目の詳細を示します。脆弱性は、影響を受けるコンポーネントごとに分類しています。下記の表に、問題の内容について説明し、CVE ID、関連する参照先、脆弱性のタイプ重大度、更新対象の AOSP バージョン(該当する場合)を示します。 問題の対処法として一般公開されている変更内容(AOSP の変更の一覧など)が参照可能な場合は、バグ ID の欄にその情報へのリンクがあります。 複数の変更が同じバグに関係する場合は、バグ ID の後に続く番号で、追加の参照先へのリンクを示します。

カーネル コンポーネント

カーネル コンポーネントの最も重大な脆弱性により、解放後の使用が原因でローカルで権限を昇格されるおそれがあります。
CVE 参照 タイプ 重大度 コンポーネント
CVE-2021-0920 A-196926917
アップストリーム カーネル
EoP カーネル
CVE-2021-0924 A-194461020
アップストリーム カーネル
EoP USB
CVE-2021-0929 A-187527909
アップストリーム カーネル [2] [3]
EoP ION

Android TV

Android TV の最も重大な脆弱性により、近くにいる攻撃者が通知なしにテレビとペア設定し、特権やユーザー操作を必要とすることなく任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2021-0889 A-180745296 RCE 重大 Android TV リモコン サービス
CVE-2021-0927 A-189824175 EoP TvInputManager

MediaTek コンポーネント

この脆弱性は MediaTek コンポーネントに影響を与えます。詳細については MediaTek から直接入手できます。この問題の重大度の評価は、MediaTek から直接提供されたものです。

CVE 参照 重大度 コンポーネント
CVE-2021-0672
A-199678035
M-ALPS05969704 *
ブラウザアプリ

Qualcomm クローズドソース コンポーネント

Qualcomm クローズドソース コンポーネントに影響する脆弱性は次のとおりです。詳細については、該当する Qualcomm のセキュリティに関する公開情報やセキュリティ アラートをご覧ください。これらの問題の重大度の評価は、Qualcomm から直接提供されたものです。

CVE 参照 重大度 コンポーネント
CVE-2021-1924
A-187074639 * 重大 クローズドソース コンポーネント
CVE-2021-1975
A-187074053 * 重大 クローズドソース コンポーネント
CVE-2021-1921
A-187074562 * クローズドソース コンポーネント
CVE-2021-1973
A-187074563 * クローズドソース コンポーネント
CVE-2021-1979
A-187073200 * クローズドソース コンポーネント
CVE-2021-1981
A-187074764 * クローズドソース コンポーネント
CVE-2021-1982
A-187074484 * クローズドソース コンポーネント
CVE-2021-30254
A-187074014 * クローズドソース コンポーネント
CVE-2021-30255
A-187074054 * クローズドソース コンポーネント
CVE-2021-30284
A-187074013 * クローズドソース コンポーネント

セキュリティ パッチレベル 2021-11-06 の脆弱性の詳細

以下に、パッチレベル 2021-11-06 に該当するセキュリティ脆弱性の各項目の詳細を示します。脆弱性は、影響を受けるコンポーネントごとに分類しています。下記の表に、問題の内容について説明し、CVE ID、関連する参照先、脆弱性のタイプ重大度、更新対象の AOSP バージョン(該当する場合)を示します。 問題の対処法として一般公開されている変更内容(AOSP の変更の一覧など)が参照可能な場合は、バグ ID の欄にその情報へのリンクがあります。 複数の変更が同じバグに関係する場合は、バグ ID の後に続く番号で、追加の参照先へのリンクを示します。

カーネル コンポーネント

カーネル コンポーネントの脆弱性により、解放後の使用が原因で、ローカルで権限を昇格されるおそれがあります。
CVE 参照 タイプ 重大度 コンポーネント
CVE-2021-1048 A-204573007
アップストリーム カーネル
EoP カーネル

一般的な質問と回答

上記の公開情報に対する一般的な質問とその回答は以下のとおりです。

1. 上記の問題に対処するようにデバイスが更新されているかどうかを確かめるには、どうすればよいですか?

デバイスのセキュリティ パッチレベルを確認するには、Android のバージョンを確認して更新する方法をご覧ください。

  • セキュリティ パッチレベル 2021-11-01 以降では、セキュリティ パッチレベル 2021-11-01 に関連するすべての問題に対処しています。
  • セキュリティ パッチレベル 2021-11-05 以降では、セキュリティ パッチレベル 2021-11-05 以前のすべてのパッチレベルに関連するすべての問題に対処しています。
  • セキュリティ パッチレベル 2021-11-06 以降では、セキュリティ パッチレベル 2021-11-06 以前のすべてのパッチレベルに関連するすべての問題に対処しています。

デバイス メーカーは、こうしたアップデートを組み込む場合、パッチレベル文字列を以下のとおり設定する必要があります。

  • [ro.build.version.security_patch]:[2021-11-01]
  • [ro.build.version.security_patch]:[2021-11-05]
  • [ro.build.version.security_patch]:[2021-11-06]

Android 10 以降を搭載した一部のデバイスでは、Google Play システム アップデートに、セキュリティ パッチレベル 2021-11-01 と一致する日付文字列が含まれます。 セキュリティ アップデートのインストール方法について詳しくは、こちらの記事をご覧ください。

2. この公開情報に 2 つのセキュリティ パッチレベルがあるのはなぜですか?

この公開情報では、2 つのセキュリティ パッチレベルを定義しています。これは、すべての Android デバイスにまたがる同様の脆弱性をひとまとめにして、Android パートナーが迅速かつ柔軟に修正できるようにするためです。Android パートナーは、この公開情報に掲載されている問題をすべて修正し、最新のセキュリティ パッチレベルを使用することが推奨されています。

  • 2021-11-01 のセキュリティ パッチレベルを使用するデバイスには、そのセキュリティ パッチレベルに関連するすべての問題と、それより前のセキュリティに関する公開情報で報告されたすべての問題の修正を含める必要があります。
  • 2021-11-05 以降のセキュリティ パッチレベルを使用するデバイスには、今回(およびそれより前)のセキュリティに関する公開情報に掲載された、該当するすべてのパッチを組み込む必要があります。
  • 2021-11-06 以降のセキュリティ パッチレベルを使用するデバイスには、今回(およびそれより前)のセキュリティに関する公開情報に掲載された、該当するすべてのパッチを組み込む必要があります。

パートナーは、対処するすべての問題の修正を 1 つのアップデートにまとめて提供することが推奨されています。

3. 「タイプ」列の項目はどういう意味ですか?

脆弱性の詳細の表で「タイプ」列に記載した項目は、セキュリティの脆弱性の分類を示しています。

略語 定義
RCE リモートコード実行
EoP 権限昇格
ID 情報開示
DoS サービス拒否
なし 該当する分類なし

4. 「参照」列の項目はどういう意味ですか?

脆弱性の詳細の表で「参照」列に記載した項目には、その参照番号が属する組織を示す接頭辞が含まれる場合があります。

接頭辞 参照
A- Android バグ ID
QC- Qualcomm の参照番号
M- MediaTek の参照番号
N- NVIDIA の参照番号
B- Broadcom の参照番号
U- UNISOC の参照番号

5. 「参照」列の Android バグ ID の横にある「*」はどういう意味ですか?

公開されていない問題には、対応する参照 ID の横に「*」を付けています。この問題のアップデートは、Google デベロッパー サイトから入手できる Pixel デバイス用最新バイナリ ドライバに通常含まれています。

6. セキュリティの脆弱性が、この公開情報とデバイスやパートナーのセキュリティに関する公開情報(Pixel のセキュリティに関する公開情報など)に分けられているのはなぜですか?

Android デバイスの最新のセキュリティ パッチレベルを宣言するためには、このセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処が必要となります。それ以外の、デバイスやパートナーのセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処は必須ではありません。また、Android デバイスやチップセットのメーカー(GoogleHuaweiLGEMotorolaNokiaSamsung など)からも、各社製品に固有のセキュリティの脆弱性に関する詳細情報が公開される場合があります。

バージョン

バージョン 日付 メモ
1.0 2021 年 11 月 1 日 情報公開
1.1 2021 年 11 月 2 日 公開情報を改訂し AOSP リンクを追加
1.2 2021 年 12 月 3 日 CVE の表を改訂