Android のセキュリティに関する公開情報 - 2022 年 7 月

コレクションでコンテンツを整理 必要に応じて、コンテンツの保存と分類を行います。
2022 年 7 月 6 日公開 | 2022 年 7 月 7 日更新

Android のセキュリティに関する公開情報には、Android デバイスに影響を与えるセキュリティの脆弱性の詳細を掲載しています。セキュリティ パッチレベル 2022-07-05 以降では、下記のすべての問題に対処しています。デバイスのセキュリティ パッチレベルを確認するには、Android のバージョンを確認して更新する方法をご覧ください。

Android パートナーには、情報公開の 1 か月前までにすべての問題が通知されます。Android オープンソース プロジェクト(AOSP)のリポジトリに、以下の問題に対するソースコードのパッチをリリースしています。また、この公開情報では、これらのパッチへのリンクに加え、AOSP 以外のパッチへのリンクも掲載しています。

下記の問題のうち最も重大度の高いものは、システム コンポーネントで発見された重大なセキュリティの脆弱性です。追加の実行権限がなくても、リモートでコードが実行されるおそれがあります。重大度の評価は、攻撃対象のデバイスでその脆弱性が悪用された場合の影響に基づいています。プラットフォームやサービスでのリスク軽減策が、開発目的または不正な回避策により無効となっていると仮定しています。

Android セキュリティ プラットフォームの保護や Google Play プロテクトについて詳しくは、Android と Google Play プロテクトでのリスク軽減策をご覧ください。こうした保護により、Android プラットフォームのセキュリティが改善されます。

Android と Google サービスでのリスク軽減策

ここでは、Android セキュリティ プラットフォームGoogle Play プロテクトのようなサービスによる保護でリスクを軽減する手段について概説します。こうした機能は、Android でセキュリティの脆弱性が悪用される可能性を軽減するものです。

  • Android プラットフォームの最新版での機能強化により、Android 上の多くの問題の悪用が困難になります。Google では、すべてのユーザーに対し、できる限り最新版の Android に更新することをおすすめしています。
  • Android セキュリティ チームは、Google Play プロテクトによって脆弱性の悪用を積極的に監視しており、有害な可能性があるアプリについてユーザーに警告しています。Google Play プロテクトは、Google モバイル サービスを搭載したデバイスではデフォルトで有効になっており、Google Play 以外からアプリをインストールするユーザーにとっては特に重要です。

セキュリティ パッチレベル 2022-07-01 の脆弱性の詳細

以下に、パッチレベル 2022-07-01 に該当するセキュリティ脆弱性の各項目の詳細を示します。脆弱性は、影響を受けるコンポーネントごとに分類しています。下記の表に、問題の内容について説明し、CVE ID、関連する参照先、脆弱性のタイプ重大度、更新対象の AOSP バージョン(該当する場合)を示します。 問題の対処法として一般公開されている変更内容(AOSP の変更の一覧など)が参照可能な場合は、バグ ID の欄にその情報へのリンクがあります。 複数の変更が同じバグに関係する場合は、バグ ID の後に続く番号で、追加の参照先へのリンクを示します。 Android 10 以降を搭載したデバイスは、セキュリティ アップデートと Google Play システム アップデートを受信することがあります。

フレームワーク

フレームワークの最も重大な脆弱性により、追加の実行権限を必要とすることなく、ローカルで情報が漏えいするおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2022-20219 A-224585613 [2] [3] [4] [5] ID 10、11、12、12L
CVE-2022-20228 A-213850092 ID 12、12L

システム

システムの最も重大な脆弱性により、追加の実行権限を必要とすることなく、リモートでコードが実行されるおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2022-20222 A-228078096 RCE 重大 12、12L
CVE-2022-20229 A-224536184 RCE 重大 10、11、12、12L
CVE-2021-0981 A-191981182 EoP 10、11
CVE-2022-20223 A-223578534 EoP 10、11、12、12L
CVE-2022-20226 A-213644870 [2] EoP 12、12L
CVE-2022-20221 A-205571133 ID 10、11、12、12L
CVE-2022-20224 A-220732646 ID 10、11、12、12L
CVE-2022-20225 A-213457638 ID 10、11、12、12L
CVE-2022-20230 A-221859869 ID 10、11、12、12L

Google Play システム アップデート

プロジェクト Mainline のコンポーネントには次の問題が含まれています。

コンポーネント CVE
メディア コーデック、メディア フレームワーク コンポーネント CVE-2022-20228

セキュリティ パッチレベル 2022-07-05 の脆弱性の詳細

以下に、パッチレベル 2022-07-05 に該当するセキュリティ脆弱性の各項目の詳細を示します。脆弱性は、影響を受けるコンポーネントごとに分類しています。下の表に、問題の内容について説明し、CVE ID、関連する参照先、脆弱性のタイプ重大度、更新対象の AOSP バージョン(該当する場合)を示します。該当する場合は、バグ ID の欄に、その問題に対処した一般公開されている変更(AOSP の変更の一覧など)へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に記載されている番号に、追加の参照へのリンクが設定されています。

フレームワーク

フレームワークの脆弱性により、ユーザー実行権限を必要として、ローカルで権限を昇格されるおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2022-20220 A-219015884 EoP 12、12L

カーネル コンポーネント

カーネル コンポーネントの最も重大な脆弱性により、追加の実行権限を必要とすることなく、ローカルで情報が漏えいするおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2022-20227 A-216825460
アップストリーム カーネル [2]
ID カーネル

MediaTek コンポーネント

これらの脆弱性は MediaTek コンポーネントに影響を与えます。詳細については MediaTek から直接入手できます。 これらの問題の重大度の評価は、MediaTek から直接提供されたものです。

CVE 参照 重大度 コンポーネント
CVE-2022-20083 A-231275475
M-MOLY00803883*
モデム 2G / 3G CC
CVE-2022-21744 A-231281131
M-MOLY00810064*
モデム 2G RR
CVE-2022-21767 A-231275476
M-ALPS06784430*
Bluetooth
CVE-2022-21768 A-231281132
M-ALPS06784351*
Bluetooth
CVE-2022-21763 A-231275473
M-ALPS07044717*
通信サービス
CVE-2022-21764 A-231271468
M-ALPS07044717*
通信サービス

Unisoc コンポーネント

これらの脆弱性は Unisoc コンポーネントに影響を与えます。詳細については Unisoc から直接入手できます。これらの問題の重大度の評価は、Unisoc から直接提供されたものです。

CVE 参照 重大度 コンポーネント
CVE-2022-20216 A-231911916
U-1867981*
電話
CVE-2022-20217
A-232441378
U-1882905*
電話
CVE-2022-20236 A-233124709
U-1883940*
GPU
CVE-2022-20238 A-233154555
U-1883892*
カーネル

Qualcomm コンポーネント

Qualcomm コンポーネントに影響する脆弱性は次のとおりです。詳細については、該当する Qualcomm のセキュリティに関する公開情報やセキュリティ アラートをご覧ください。 これらの問題の重大度の評価は、Qualcomm から直接提供されたものです。

CVE 参照 重大度 コンポーネント
CVE-2022-22096
A-213371834
QC-CR#3105585
重大 Bluetooth
CVE-2022-22058 A-209075540
QC-CR#2747422
QC-CR#2338216
カーネル

Qualcomm クローズドソース コンポーネント

Qualcomm クローズドソース コンポーネントに影響する脆弱性は次のとおりです。詳細については、該当する Qualcomm のセキュリティに関する公開情報やセキュリティ アラートをご覧ください。 これらの問題の重大度の評価は、Qualcomm から直接提供されたものです。

CVE 参照 重大度 コンポーネント
CVE-2022-25657 A-228101835* クローズドソース コンポーネント
CVE-2022-25658
A-228101855* クローズドソース コンポーネント
CVE-2022-25659 A-228101819* クローズドソース コンポーネント

一般的な質問と回答

上記の公開情報に対する一般的な質問とその回答は以下のとおりです。

1. 上記の問題に対処するようにデバイスが更新されているかどうかを確かめるには、どうすればよいですか?

デバイスのセキュリティ パッチレベルを確認するには、Android のバージョンを確認して更新する方法をご覧ください。

  • セキュリティ パッチレベル 2022-07-01 以降では、セキュリティ パッチレベル 2022-07-01 に関連するすべての問題に対処しています。
  • セキュリティ パッチレベル 2022-07-05 以降では、セキュリティ パッチレベル 2022-07-05、およびそれ以前のすべてのパッチレベルに関連するすべての問題に対処しています。

デバイス メーカーは、こうしたアップデートを組み込む場合、パッチレベル文字列を以下のとおり設定する必要があります。

  • [ro.build.version.security_patch]:[2022-07-01]
  • [ro.build.version.security_patch]:[2022-07-05]

Android 10 以降を搭載した一部のデバイスでは、Google Play システム アップデートに、セキュリティ パッチレベル 2022-07-01 と一致する日付文字列が含まれます。セキュリティ アップデートのインストール方法について詳しくは、こちらの記事をご覧ください。

2. この公開情報に 2 つのセキュリティ パッチレベルがあるのはなぜですか?

この公開情報では、2 つのセキュリティ パッチレベルを定義しています。これは、すべての Android デバイスにまたがる同様の脆弱性をひとまとめにして、Android パートナーが迅速かつ柔軟に修正できるようにするためです。Android パートナーは、この公開情報に掲載されている問題をすべて修正し、最新のセキュリティ パッチレベルを使用することが推奨されています。

  • 2022-07-01 のセキュリティ パッチレベルを使用するデバイスには、そのセキュリティ パッチレベルに関連するすべての問題と、それより前のセキュリティに関する公開情報で報告されたすべての問題の修正を含める必要があります。
  • 2022-07-05 以降のセキュリティ パッチレベルを使用するデバイスには、今回(およびそれより前)のセキュリティに関する公開情報に掲載された、該当するすべてのパッチを組み込む必要があります。

パートナーは、対処するすべての問題の修正を 1 つのアップデートにまとめて提供することが推奨されています。

3. 「タイプ」列の項目はどういう意味ですか?

脆弱性の詳細の表で「タイプ」列に記載した項目は、セキュリティの脆弱性の分類を示しています。

略語 定義
RCE リモートコード実行
EoP 権限昇格
ID 情報開示
DoS サービス拒否
なし 該当する分類なし

4. 「参照」列の項目はどういう意味ですか?

脆弱性の詳細の表で「参照」列に記載した項目には、その参照番号が属する組織を示す接頭辞が含まれる場合があります。

< /table>

5. 「参照」列の Android バグ ID の横にある「*」はどういう意味ですか?

公開されていない問題には、対応する参照 ID の横に「*」を付けています。この問題のアップデートは、Google デベロッパー サイトから入手できる Pixel デバイス用最新バイナリ ドライバに通常含まれています。

6. セキュリティの脆弱性が、この公開情報とデバイスやパートナーのセキュリティに関する公開情報(Google Pixel のセキュリティに関する公開情報など)に分けられているのはなぜですか?

Android デバイスの最新のセキュリティ パッチレベルを宣言するためには、このセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処が必要となります。それ以外の、デバイスやパートナーのセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処は必須ではありません。また、Android デバイスやチップセットのメーカー(GoogleHuaweiLGEMotorolaNokiaSamsung など)からも、各社製品に固有のセキュリティの脆弱性に関する詳細情報が公開される場合があります。

バージョン

接頭辞 参照
A- Android バグ ID
QC- Qualcomm の参照番号
M- MediaTek の参照番号
N- NVIDIA の参照番号
B- Broadcom の参照番号
U- UNISOC の参照番号
バージョン 日付 メモ
1.0 2022 年 7 月 6 日 情報公開
1.1 2022 年 7 月 7 日 公開情報を改訂し AOSP のリンクを追加、CVE の表を改訂