পিক্সেল / নেক্সাস সিকিউরিটি বুলেটিন—নভেম্বর 2017

সেভ করা পৃষ্ঠা গুছিয়ে রাখতে 'সংগ্রহ' ব্যবহার করুন আপনার পছন্দ অনুযায়ী কন্টেন্ট সেভ করুন ও সঠিক বিভাগে রাখুন।

নভেম্বর 6, 2017 প্রকাশিত | 8 নভেম্বর, 2017 আপডেট করা হয়েছে

পিক্সেল / নেক্সাস সিকিউরিটি বুলেটিনে নিরাপত্তা দুর্বলতা এবং কার্যকরী উন্নতির বিবরণ রয়েছে যা সমর্থিত Google পিক্সেল এবং নেক্সাস ডিভাইসগুলিকে (গুগল ডিভাইস) প্রভাবিত করে। Google ডিভাইসের জন্য, 2017-11-05 বা তার পরবর্তী নিরাপত্তা প্যাচ স্তরগুলিও এই বুলেটিনে সমস্ত সমস্যার সমাধান করে৷ একটি ডিভাইসের নিরাপত্তা প্যাচ স্তর কিভাবে পরীক্ষা করতে হয় তা জানতে, আপনার Android সংস্করণ চেক এবং আপডেট দেখুন

সমস্ত সমর্থিত Google ডিভাইস 2017-11-05 প্যাচ স্তরে একটি আপডেট পাবে। আমরা সমস্ত গ্রাহকদের তাদের ডিভাইসে এই আপডেটগুলি গ্রহণ করতে উত্সাহিত করি৷

দ্রষ্টব্য: Google ডিভাইসের ফার্মওয়্যার চিত্রগুলি Google বিকাশকারী সাইটে উপলব্ধ।

ঘোষণা

নভেম্বর 2017 অ্যান্ড্রয়েড সিকিউরিটি বুলেটিনে বর্ণিত নিরাপত্তা দুর্বলতাগুলি ছাড়াও, Pixel এবং Nexus ডিভাইসগুলিতে নীচে বর্ণিত নিরাপত্তা দুর্বলতার জন্য প্যাচ রয়েছে৷ অংশীদারদের অন্তত এক মাস আগে এই সমস্যাগুলি সম্পর্কে অবহিত করা হয়েছিল এবং তারা তাদের ডিভাইস আপডেটের অংশ হিসাবে তাদের অন্তর্ভুক্ত করতে বেছে নিতে পারে৷

নিরাপত্তা প্যাচ

দুর্বলতাগুলি যে উপাদানগুলিকে প্রভাবিত করে তার অধীনে গোষ্ঠীভুক্ত করা হয়। সমস্যাটির বর্ণনা এবং CVE, সংশ্লিষ্ট রেফারেন্স, দুর্বলতার ধরন , তীব্রতা এবং আপডেট করা Android Open Source Project (AOSP) সংস্করণ (যেখানে প্রযোজ্য) সহ একটি টেবিল রয়েছে। উপলব্ধ হলে, আমরা AOSP পরিবর্তনের তালিকার মতো বাগ আইডিতে সমস্যাটির সমাধানকারী সর্বজনীন পরিবর্তনকে লিঙ্ক করি। যখন একাধিক পরিবর্তন একটি একক বাগের সাথে সম্পর্কিত হয়, তখন বাগ আইডি অনুসরণকারী সংখ্যার সাথে অতিরিক্ত উল্লেখ সংযুক্ত করা হয়।

ফ্রেমওয়ার্ক

সিভিই তথ্যসূত্র টাইপ নির্দয়তা AOSP সংস্করণ আপডেট করা হয়েছে
CVE-2017-0845 এ-35028827 DoS পরিমিত 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

মিডিয়া ফ্রেমওয়ার্ক

সিভিই তথ্যসূত্র টাইপ নির্দয়তা AOSP সংস্করণ আপডেট করা হয়েছে
CVE-2017-0838 এ-63522818 ইওপি উচ্চ 7.0, 7.1.1, 7.1.2
CVE-2017-0852 এ-62815506 DoS উচ্চ 5.0.2, 5.1.1, 6.0
CVE-2017-0847 এ-65540999 ইওপি পরিমিত ৮.০
CVE-2017-0848 এ-64477217 আইডি পরিমিত 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0849 এ-62688399 আইডি পরিমিত 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0850 A-64836941 * আইডি পরিমিত 7.0, 7.1.1, 7.1.2
CVE-2017-0851 এ-35430570 আইডি পরিমিত 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0853 এ-63121644 আইডি পরিমিত 7.0, 7.1.1, 7.1.2, 8.0
DoS উচ্চ 6.0, 6.0.1
CVE-2017-0854 এ-63873837 আইডি পরিমিত 7.0, 7.1.1, 7.1.2, 8.0
DoS উচ্চ 6.0, 6.0.1
CVE-2017-0857 এ-65122447 এনএসআই এনএসআই 7.0, 7.1.1, 7.1.2, 8.0
DoS উচ্চ 6.0, 6.0.1
CVE-2017-0858 এ-64836894 এনএসআই এনএসআই 7.0, 7.1.1, 7.1.2, 8.0
DoS উচ্চ 6.0, 6.0.1
CVE-2017-0859 A-36075131 * এনএসআই এনএসআই 7.0, 7.1.1, 7.1.2
DoS উচ্চ 6.0, 6.0.1

রানটাইম

সিভিই তথ্যসূত্র টাইপ নির্দয়তা AOSP সংস্করণ আপডেট করা হয়েছে
CVE-2016-2105 A-63710022 * আরসিই পরিমিত 5.0.2, 5.1.1
CVE-2016-2106 A-63709511 * আরসিই পরিমিত 5.0.2, 5.1.1
CVE-2017-3731 A-63710076 * আইডি পরিমিত 5.0.2, 5.1.1

পদ্ধতি

সিভিই তথ্যসূত্র টাইপ নির্দয়তা AOSP সংস্করণ আপডেট করা হয়েছে
CVE-2017-0860 এ-31097064 ইওপি পরিমিত 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

কার্নেল উপাদান

সিভিই তথ্যসূত্র টাইপ নির্দয়তা উপাদান
CVE-2017-6001 এ-37901413
আপস্ট্রিম কার্নেল
ইওপি পরিমিত কোর কার্নেল
CVE-2017-0861 A-36006981 * ইওপি পরিমিত অডিও ড্রাইভার
CVE-2017-0862 A-36006779 * ইওপি পরিমিত কার্নেল
CVE-2017-11600 এ-64257838
আপস্ট্রিম কার্নেল
ইওপি পরিমিত নেটওয়ার্কিং সাবসিস্টেম
CVE-2017-0863 A-37950620 * ইওপি পরিমিত ভিডিও ড্রাইভার

মিডিয়াটেক উপাদান

সিভিই তথ্যসূত্র টাইপ নির্দয়তা উপাদান
CVE-2017-0864 A-37277147 *
M-ALPS03394571
ইওপি পরিমিত IoCtl (ফ্ল্যাশলাইট)
CVE-2017-0865 A-65025090 *
M-ALPS02973195
ইওপি পরিমিত SoC ড্রাইভার

NVIDIA উপাদান

সিভিই তথ্যসূত্র টাইপ নির্দয়তা উপাদান
CVE-2017-0866 A-38415808 *
N-CVE-2017-0866
ইওপি পরিমিত সরাসরি রেন্ডারিং অবকাঠামো
CVE-2017-6274 A-34705801 *
N-CVE-2017-6274
ইওপি পরিমিত থার্মাল ড্রাইভার
CVE-2017-6275 A-34702397 *
N-CVE-2017-6275
আইডি পরিমিত থার্মাল ড্রাইভার

কোয়ালকম উপাদান

সিভিই তথ্যসূত্র টাইপ নির্দয়তা উপাদান
CVE-2017-11073 A-62084791 *
QC-CR#2064767
ইওপি পরিমিত নেটওয়ার্কিং সাবসিস্টেম
CVE-2017-11035 এ-64431968
QC-CR#2055659 [ 2 ]
ইওপি পরিমিত WLAN
CVE-2017-11012 এ-64455446
QC-CR#2054760
ইওপি পরিমিত WLAN
CVE-2017-11085 A-62952032 *
QC-CR#2077909
ইওপি পরিমিত শ্রুতি
CVE-2017-11091 A-37478866 *
QC-CR#2064235
ইওপি পরিমিত ভিডিও ড্রাইভার
CVE-2017-11026 এ-64453104
QC-CR#1021460
ইওপি পরিমিত লিনাক্স বুট
CVE-2017-11038 A-35888677 *
QC-CR#2034087
ইওপি পরিমিত মেমরি সাবসিস্টেম
CVE-2017-11032 এ-64431966
QC-CR#1051435
ইওপি পরিমিত লিনাক্স কার্নেল
CVE-2017-9719 এ-64438726
QC-CR#2042697 [ 2 ]
ইওপি পরিমিত প্রদর্শন
CVE-2017-11024 এ-64441352
QC-CR#2031178
ইওপি পরিমিত তারযুক্ত সংযোগ
CVE-2017-11025 এ-64440043
QC-CR#2013494
ইওপি পরিমিত শ্রুতি
CVE-2017-11023 এ-64434485
QC-CR#2029216
ইওপি পরিমিত সেবা
CVE-2017-11029 এ-64433362
QC-CR#2025367 [ 2 ]
ইওপি পরিমিত ক্যামেরা
CVE-2017-11018 এ-64441628
QC-CR#897844
ইওপি পরিমিত ক্যামেরা
CVE-2017-9721 এ-64441353
QC-CR#2039552
ইওপি পরিমিত প্রদর্শন
CVE-2017-9702 A-36492827 *
QC-CR#2037398
ইওপি পরিমিত ক্যামেরা
CVE-2017-11089 A-36819059 *
QC-CR#2055013
আইডি পরিমিত WLAN
CVE-2017-8239 A-36251230 *
QC-CR#1091603
আইডি পরিমিত ক্যামেরা
CVE-2017-11090 A-36818836 *
QC-CR#2061676
আইডি পরিমিত WLAN
CVE-2017-11093 A-37625232 *
QC-CR#2077623
আইডি পরিমিত HDMI
CVE-2017-8279 এ-62378962
QC-CR#2015227
আইডি পরিমিত সেবা
CVE-2017-9696 A-36232584 *
QC-CR#2029867
আইডি পরিমিত কার্নেল
CVE-2017-11058 এ-37718081
QC-CR#2061251
আইডি পরিমিত WLAN
CVE-2017-11022 এ-64440918
QC-CR#1086582 [ 2 ]
আইডি পরিমিত WLAN
CVE-2017-9701 এ-63868730
QC-CR#2038992
আইডি পরিমিত লিনাক্স বুট
CVE-2017-11027 এ-64453534
QC-CR#2055630
আইডি পরিমিত লিনাক্স বুট

কার্যকরী আপডেট

Pixel ডিভাইসের নিরাপত্তার সাথে সম্পর্কিত নয় এমন কার্যকারিতা সমস্যাগুলি সমাধান করার জন্য প্রভাবিত Pixel ডিভাইসগুলির জন্য এই আপডেটগুলি অন্তর্ভুক্ত করা হয়েছে। সারণি সংশ্লিষ্ট রেফারেন্স অন্তর্ভুক্ত; প্রভাবিত বিভাগ, যেমন ব্লুটুথ বা মোবাইল ডেটা; এবং সমস্যা একটি সারসংক্ষেপ.

তথ্যসূত্র শ্রেণী উন্নতি
এ-65225835 শ্রুতি কিছু অঞ্চলে ভলিউম সতর্কতা থ্রেশহোল্ড সামঞ্জস্য করা হয়েছে।
এ-37943083 ব্লুটুথ ব্লুটুথ ডিভাইসগুলির জন্য উন্নতি শুধুমাত্র AVRCP সংস্করণ 1.3 সমর্থন করে৷
এ-63790458 ব্লুটুথ উন্নত হেডসেট সংযোগ জোড়া।
এ-64142363 ব্লুটুথ কিছু ব্লুটুথ কারকিটে উন্নত গানের তথ্য প্রদর্শন।
এ-64991621 ব্লুটুথ কিছু কারকিটে উন্নত মেটাডেটা।
এ-65223508 ব্লুটুথ কিছু কারকিটের সাথে উন্নত ব্লুটুথ সংযোগ।
এ-65463237 ব্লুটুথ BLE তে উন্নত জাদু টিথার।
এ-64977836 ক্যামেরা ভিডিও ক্যাপচারের সময় উন্নত অটোফোকাস।
এ-65099590 ক্যামেরা উন্নত ফ্রন্ট ক্যামেরা প্রতিক্রিয়া গতি।
এ-68159303 প্রদর্শন রঙ মোড সেটিং প্রদর্শনের সামঞ্জস্য।
এ-68254840 প্রদর্শন উজ্জ্বলতা সেটিংস প্রদর্শনের জন্য সামঞ্জস্য।
এ-68279369 প্রদর্শন নেভিগেশন বার উজ্জ্বলতা সামঞ্জস্য.
এ-64103722 যথোপযুক্ত সৃষ্টিকর্তাযথোপযুক্ত সৃষ্টিকর্তা মোবাইল ডেটা থেকে Wi-Fi-এ YouTube স্যুইচিং সামঞ্জস্য করা হয়েছে৷
এ-65113738 যথোপযুক্ত সৃষ্টিকর্তাযথোপযুক্ত সৃষ্টিকর্তা 3 নেটওয়ার্কে মোবাইল ডেটা সমন্বয়।
এ-37187694 স্থিতিশীলতা উন্নত অ্যাপ্লিকেশন স্থায়িত্ব.
এ-67959484 স্থিতিশীলতা কল মানের সামঞ্জস্য।

সাধারণ প্রশ্ন এবং উত্তর

এই বিভাগটি সাধারণ প্রশ্নের উত্তর দেয় যা এই বুলেটিন পড়ার পরে হতে পারে।

1. এই সমস্যাগুলি সমাধান করার জন্য আমার ডিভাইস আপডেট করা হয়েছে কিনা তা আমি কীভাবে নির্ধারণ করব?

2017-11-05 এর নিরাপত্তা প্যাচ স্তরগুলি বা তার পরে 2017-11-05 নিরাপত্তা প্যাচ স্তর এবং সমস্ত পূর্ববর্তী প্যাচ স্তরগুলির সাথে সম্পর্কিত সমস্ত সমস্যার সমাধান করে৷ কিভাবে একটি ডিভাইসের নিরাপত্তা প্যাচ স্তর চেক করতে হয় তা জানতে, Pixel এবং Nexus আপডেট শিডিউলের নির্দেশাবলী পড়ুন।

2. টাইপ কলামের এন্ট্রিগুলির অর্থ কী?

দুর্বলতার বিবরণ টেবিলের টাইপ কলামের এন্ট্রি নিরাপত্তা দুর্বলতার শ্রেণীবিভাগ উল্লেখ করে।

সংক্ষিপ্ত রূপ সংজ্ঞা
আরসিই রিমোট কোড এক্সিকিউশন
ইওপি বিশেষাধিকারের উচ্চতা
আইডি তথ্য প্রকাশ
DoS সেবা দিতে অস্বীকার করা
N/A শ্রেণীবিভাগ উপলব্ধ নয়

3. রেফারেন্স কলামের এন্ট্রিগুলির অর্থ কী?

দুর্বলতার বিবরণ সারণীর রেফারেন্স কলামের অধীনে এন্ট্রিতে একটি উপসর্গ থাকতে পারে যে সংস্থার রেফারেন্স মানটি চিহ্নিত করে।

উপসর্গ রেফারেন্স
ক- অ্যান্ড্রয়েড বাগ আইডি
QC- কোয়ালকম রেফারেন্স নম্বর
এম- মিডিয়াটেক রেফারেন্স নম্বর
এন- NVIDIA রেফারেন্স নম্বর
খ- ব্রডকম রেফারেন্স নম্বর

4. রেফারেন্স কলামে অ্যান্ড্রয়েড বাগ আইডির পাশে * এর অর্থ কী?

যে সমস্যাগুলি সর্বজনীনভাবে উপলব্ধ নয় সেগুলির রেফারেন্স কলামে Android বাগ আইডির পাশে একটি * থাকে৷ এই সমস্যার জন্য আপডেটটি সাধারণত Google বিকাশকারী সাইট থেকে উপলব্ধ Nexus ডিভাইসগুলির জন্য সর্বশেষ বাইনারি ড্রাইভারগুলিতে থাকে৷

5. কেন এই বুলেটিন এবং অ্যান্ড্রয়েড সিকিউরিটি বুলেটিনগুলির মধ্যে নিরাপত্তা দুর্বলতাগুলি বিভক্ত?

Android ডিভাইসে সর্বশেষ নিরাপত্তা প্যাচ স্তর ঘোষণা করার জন্য Android নিরাপত্তা বুলেটিনে নথিভুক্ত নিরাপত্তা দুর্বলতা প্রয়োজন। অতিরিক্ত নিরাপত্তা দুর্বলতা, যেমন এই বুলেটিনে নথিভুক্ত, একটি নিরাপত্তা প্যাচ স্তর ঘোষণা করার জন্য প্রয়োজন হয় না।

সংস্করণ

সংস্করণ তারিখ মন্তব্য
1.0 নভেম্বর 6, 2017 বুলেটিন প্রকাশিত হয়েছে।
1.1 নভেম্বর 8, 2017 AOSP লিঙ্ক এবং কার্যকরী আপডেটের অতিরিক্ত বিবরণ সহ বুলেটিন আপডেট করা হয়েছে।