Pixel-Update-Bulletin – September 2019

Veröffentlicht am 3. September 2019 | Aktualisiert am 12. September 2019

Das Pixel Update Bulletin enthält Einzelheiten zu Sicherheitslücken und Funktionsverbesserungen, die unterstützte Pixel-Geräte (Google-Geräte) betreffen. Für Google-Geräte beheben die Sicherheitspatch-Stufen vom 05.09.2019 oder höher alle Probleme in diesem Bulletin und alle Probleme im Android-Sicherheitsbulletin vom September 2019. Informationen zum Überprüfen des Sicherheitspatch-Levels eines Geräts finden Sie unter Überprüfen und aktualisieren Sie Ihre Android-Version .

Alle unterstützten Google-Geräte erhalten ein Update auf den Patch-Level 2019-09-05. Wir empfehlen allen Kunden, diese Updates für ihre Geräte zu akzeptieren.

Ankündigungen

Zusätzlich zu den im Android Security Bulletin vom September 2019 beschriebenen Sicherheitslücken enthalten unterstützte Google-Geräte, die auf Android 10 aktualisiert werden, auch Patches für die in diesem Bulletin beschriebenen Sicherheitslücken. Partner wurden darüber informiert, dass diese Probleme in Android 10 behoben werden.

Sicherheitspatches

Die folgenden Tabellen enthalten Sicherheitspatches, die auf Pixel-Geräten mit Android 10 behoben werden. Schwachstellen werden nach der Komponente gruppiert, die sie betreffen. Die Probleme werden in den folgenden Tabellen beschrieben und umfassen CVE-ID, zugehörige Referenzen, Art der Schwachstelle , Schweregrad und aktualisierte Android Open Source Project (AOSP)-Versionen (sofern zutreffend). Sofern verfügbar, verknüpfen wir die öffentliche Änderung, die das Problem behoben hat, mit der Fehler-ID, z. B. die AOSP-Änderungsliste. Wenn sich mehrere Änderungen auf einen einzelnen Fehler beziehen, werden zusätzliche Verweise mit Nummern verknüpft, die der Fehler-ID folgen.

Broadcom-Komponenten

CVE Verweise Typ Schwere Komponente
CVE-2019-9426 A-110460199 * EoP Mäßig Bluetooth

LG-Komponenten

CVE Verweise Typ Schwere Komponente
CVE-2019-9436 A-127320561 * EoP Mäßig Bootloader
CVE-2019-2191 A-68770980 * AUSWEIS Mäßig Bootloader
CVE-2019-2190 A-68771598 * AUSWEIS Mäßig Bootloader

Kernel-Komponenten

CVE Verweise Typ Schwere Komponente
CVE-2019-9345 A-27915347 * EoP Hoch Kernel
CVE-2019-9461 A-120209610 * AUSWEIS Hoch VPN
CVE-2019-9248 A-120279144 * EoP Mäßig Touch-Treiber
CVE-2019-9270 A-65123745 * EoP Mäßig W-lan
CVE-2019-2182 A-128700140
Upstream-Kernel
EoP Mäßig Kernel-MMU
CVE-2019-9271 A-69006201 * EoP Mäßig Postfrischer Fahrer
CVE-2019-9273 A-70241598 * EoP Mäßig Touch-Treiber
CVE-2019-9274 A-70809925 * EoP Mäßig Postfrischer Fahrer
CVE-2019-9275 A-71508439 * EoP Mäßig Postfrischer Fahrer
CVE-2019-9276 A-70294179 * EoP Mäßig Touch-Treiber
CVE-2019-9441 A-69006882 * EoP Mäßig Postfrischer Fahrer
CVE-2019-9442 A-69808778 * EoP Mäßig Postfrischer Fahrer
CVE-2019-9443 A-70896844 * EoP Mäßig VL53L0-Treiber
CVE-2019-9446 A-118617506 * EoP Mäßig Touch-Treiber
CVE-2019-9447 A-119120571
Upstream-Kernel
EoP Mäßig Touch-Treiber
CVE-2019-9448 A-120141999
Upstream-Kernel
EoP Mäßig Touch-Treiber
CVE-2019-9450 A-120141034
Upstream-Kernel
EoP Mäßig Touch-Treiber
CVE-2019-9451 A-120211415
Upstream-Kernel
EoP Mäßig Touch-Treiber
CVE-2019-9454 A-129148475
Upstream-Kernel
EoP Mäßig I2C-Treiber
CVE-2019-9456 A-71362079
Upstream-Kernel
EoP Mäßig USB stick
CVE-2019-9457 A-116716935
Upstream-Kernel
EoP Mäßig Kernel
CVE-2019-9458 A-117989855
Upstream-Kernel
EoP Mäßig Videotreiber
CVE-2019-8912 A-125367761
Upstream-Kernel
EoP Mäßig Krypto
CVE-2018-18397 A-124036248
Upstream-Kernel
EoP Mäßig Lagerung
CVE-2018-14614 A-116406552
Upstream-Kernel
EoP Mäßig Lagerung
CVE-2018-1000199 A-110918800
Upstream-Kernel
EoP Mäßig ptrace
CVE-2018-13096 A-113148557
Upstream-Kernel
EoP Mäßig Lagerung
CVE-2018-5803 A-112406370
Upstream-Kernel
DOS Mäßig SCTP
CVE-2019-2189 A-112312381 EoP Mäßig Bildtreiber
CVE-2019-2188 A-112309571 * EoP Mäßig Bildtreiber
CVE-2017-16939 A-70521013
Upstream-Kernel
EoP Mäßig Netlink XFRM
CVE-2018-20169 A-120783657
Upstream-Kernel
AUSWEIS Mäßig USB stick
CVE-2019-9245 A-120491338
Upstream-Kernel
AUSWEIS Mäßig Speichertreiber
CVE-2019-9444 A-78597155
Upstream-Kernel
AUSWEIS Mäßig Speichertreiber
CVE-2019-9445 A-118153030
Upstream-Kernel
AUSWEIS Mäßig Speichertreiber
CVE-2019-9449 A-120141031
Upstream-Kernel
AUSWEIS Mäßig Touch-Treiber
CVE-2019-9452 A-120211708
Upstream-Kernel
AUSWEIS Mäßig Touch-Treiber
CVE-2019-9453 A-126558260
Upstream-Kernel
AUSWEIS Mäßig Speichertreiber
CVE-2019-9455 A-121035792
Upstream-Kernel
AUSWEIS Mäßig Videotreiber
CVE-2018-19985 A-131963918
Upstream-Kernel
AUSWEIS Mäßig USB stick
CVE-2018-20511 A-123742046
Upstream-Kernel
AUSWEIS Mäßig nNet/AppleTalk
CVE-2018-1000204 A-113096593
Upstream-Kernel
AUSWEIS Mäßig Lagerung

Qualcomm-Komponenten

CVE Verweise Typ Schwere Komponente
CVE-2017-14888 A-70237718
QC-CR#2119729
N / A Mäßig WLAN-Host
CVE-2018-3573 A-72957667
QC-CR#2124525
N / A Mäßig Bootloader
CVE-2017-15844 A-67749071
QC-CR#2127276
N / A Mäßig Kernel
CVE-2018-3574 A-72957321
QC-CR#2148121 [ 2 ] [ 3 ]
N / A Mäßig Kernel
CVE-2018-5861 A-77527684
QC-CR#2167135
N / A Mäßig Bootloader
CVE-2018-11302 A-109741923
QC-CR#2209355
N / A Mäßig WLAN-Host
CVE-2018-5919 A-65423852
QC-CR#2213280
N / A Mäßig WLAN-Host
CVE-2018-11818 A-111127974
QC-CR#2170083 [ 2 ]
N / A Mäßig MDSS-Treiber
CVE-2018-11832 A-111127793
QC-CR#2212896
N / A Mäßig Kernel
CVE-2018-11893 A-111127990
QC-CR#2231992
N / A Mäßig WLAN-Host
CVE-2018-11919 A-79217930
QC-CR#2209134 [ 2 ] [ 3 ]
N / A Mäßig Kernel
CVE-2018-11939 A-77237693
QC-CR#2254305
N / A Mäßig WLAN-Host
CVE-2018-11823 A-112277122
QC-CR#2204519
N / A Mäßig Leistung
CVE-2018-11929 A-112277631
QC-CR#2231300
N / A Mäßig WLAN-Host
CVE-2018-11943 A-72117228
QC-CR#2257823
N / A Mäßig Bootloader
CVE-2018-11947 A-112277911
QC-CR#2246110 [ 2 ]
N / A Mäßig WLAN-Host
CVE-2018-11947 A-112278406
QC-CR#2272696
N / A Mäßig WLAN-Host
CVE-2018-11942 A-112278151
QC-CR#2257688
N / A Mäßig WLAN-Host
CVE-2018-11983 A-80095430
QC-CR#2262576
N / A Mäßig Kernel
CVE-2018-11984 A-80435805
QC-CR#2266693
N / A Mäßig Kernel
CVE-2018-11987 A-70638103
QC-CR#2258691
N / A Mäßig Kernel
CVE-2018-11985 A-114041193
QC-CR#2163851
N / A Mäßig Bootloader
CVE-2018-11988 A-114041748
QC-CR#2172134 [ 2 ]
N / A Mäßig Kernel
CVE-2018-11986 A-62916765
QC-CR#2266969
N / A Mäßig Kamera
CVE-2018-12010 A-62711756
QC-CR#2268386
N / A Mäßig Kernel
CVE-2018-12006 A-77237704
QC-CR#2257685 [ 2 ]
N / A Mäßig Anzeige
CVE-2018-13893 A-80302295
QC-CR#2291309 [ 2 ]
N / A Mäßig diag_mask
CVE-2018-12011 A-109697864
QC-CR#2274853
N / A Mäßig Kernel
CVE-2018-13912 A-119053502
QC-CR#2283160 [ 2 ]
N / A Mäßig Kamera
CVE-2018-13913 A-119053530
QC-CR#2286485 [ 2 ]
N / A Mäßig Anzeige
CVE-2018-3564 A-119052383
QC-CR#2225279
N / A Mäßig DSP-Dienste
CVE-2019-2248 A-122474006
QC-CR#2328906
N / A Mäßig Anzeige
CVE-2019-2277 A-127512945
QC-CR#2342812
N / A Mäßig WLAN-Host
CVE-2019-2263 A-116024809
QC-CR#2076623
N / A Mäßig Kernel
CVE-2019-2345 A-110849476
QC-CR#2115578
N / A Mäßig Kamera
CVE-2019-2306 A-115907574
QC-CR#2337383 [ 2 ]
N / A Mäßig Anzeige
CVE-2019-2299 A-117988970
QC-CR#2243169
N / A Mäßig WLAN-Host
CVE-2019-2312 A-117885392
QC-CR#2341890
N / A Mäßig WLAN-Host
CVE-2019-2314 A-120028144
QC-CR#2357704
N / A Mäßig Anzeige
CVE-2019-2314 A-120029095
QC-CR#2357704
N / A Mäßig Anzeige
CVE-2019-2302 A-130565935
QC-CR#2300516
N / A Mäßig WLAN-Host
CVE-2019-10506 A-117885703
QC-CR#2252793
N / A Mäßig WLAN-Host
CVE-2018-13890 A-111274306
QC-CR#2288818
N / A Mäßig WLAN-Host
CVE-2019-10507 A-132170503
QC-CR#2253396
N / A Mäßig WLAN-Host
CVE-2019-10508 A-132173922
QC-CR#2288818
N / A Mäßig WLAN-Host
CVE-2019-2284 A-132173427
QC-CR#2358765
N / A Mäßig Kamera
CVE-2019-2333 A-132171964
QC-CR#2381014 [ 2 ] [ 3 ]
N / A Mäßig Kernel
CVE-2019-2341 A-132172264
QC-CR#2389324 [ 2 ]
N / A Mäßig Audio
CVE-2019-10497 A-132173298
QC-CR#2395102
N / A Mäßig Audio
CVE-2019-10542 A-134440623
QC-CR#2359884
N / A Mäßig WLAN-Host
CVE-2019-10502 A-134441002
QC-CR#2401297 [ 2 ] [3 ]
N / A Mäßig Kamera
CVE-2019-10528 A-63528466
QC-CR#2133028 [ 2 ]
N / A Mäßig Kernel
CVE-2018-11825 A-117985523
QC-CR#2205722
N / A Mäßig WLAN-Host
CVE-2019-10565 A-129275872
QC-CR#2213706
N / A Mäßig Kamera

Qualcomm Closed-Source-Komponenten

CVE Verweise Typ Schwere Komponente
CVE-2018-11899 A-69383398 * N / A Mäßig Closed-Source-Komponente
CVE-2019-2298 A-118897119 * N / A Mäßig Closed-Source-Komponente
CVE-2019-2281 A-129765896 * N / A Mäßig Closed-Source-Komponente
CVE-2019-2343 A-130566880 * N / A Mäßig Closed-Source-Komponente

Funktionelle Patches

Eine Beschreibung der in Android 10 enthaltenen Funktionen finden Sie in diesem Beitrag .

Häufige Fragen und Antworten

In diesem Abschnitt werden häufige Fragen beantwortet, die nach dem Lesen dieses Bulletins auftreten können.

1. Wie kann ich feststellen, ob mein Gerät aktualisiert wurde, um diese Probleme zu beheben?

Die Sicherheitspatch-Stufen vom 05.09.2019 oder höher beheben alle Probleme im Zusammenhang mit der Sicherheitspatch-Stufe vom 05.09.2019 und allen vorherigen Patch-Stufen. Um zu erfahren, wie Sie den Sicherheitspatch-Level eines Geräts überprüfen können, lesen Sie die Anweisungen im Aktualisierungsplan für Google-Geräte .

2. Was bedeuten die Einträge in der Spalte Typ ?

Einträge in der Spalte „Typ“ der Tabelle mit den Schwachstellendetails verweisen auf die Klassifizierung der Sicherheitslücke.

Abkürzung Definition
RCE Remote-Codeausführung
EoP Erhöhung der Privilegien
AUSWEIS Offenlegung von Informationen
DOS Denial of Service
N / A Klassifizierung nicht verfügbar

3. Was bedeuten die Einträge in der Spalte „Referenzen“ ?

Einträge in der Spalte „Referenzen“ der Tabelle mit den Schwachstellendetails können ein Präfix enthalten, das die Organisation identifiziert, zu der der Referenzwert gehört.

Präfix Referenz
A- Android-Fehler-ID
QC- Qualcomm-Referenznummer
M- MediaTek-Referenznummer
N- NVIDIA-Referenznummer
B- Broadcom-Referenznummer

4. Was bedeutet ein * neben der Android-Bug-ID in der Spalte „Referenzen“ ?

Probleme, die nicht öffentlich verfügbar sind, sind in der Spalte „Referenzen“ mit einem * neben der Android-Fehler-ID gekennzeichnet. Das Update für dieses Problem ist im Allgemeinen in den neuesten Binärtreibern für Pixel-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

5. Warum werden Sicherheitslücken in diesem Bulletin und den Android-Sicherheitsbulletins aufgeteilt?

Sicherheitslücken, die in den Android-Sicherheitsbulletins dokumentiert sind, sind erforderlich, um die neueste Sicherheitspatch-Stufe auf Android-Geräten bekannt zu geben. Zusätzliche Sicherheitslücken, wie sie in diesem Bulletin dokumentiert sind, sind für die Angabe eines Sicherheitspatch-Levels nicht erforderlich.

Versionen

Ausführung Datum Anmerkungen
1,0 3. September 2019 Bulletin veröffentlicht.
1.1 12. September 2019 Bulletin aktualisiert.