Bollettino sulla sicurezza Android: giugno 2018

Pubblicato il 4 giugno 2018 | Aggiornato il 24 luglio 2018

L'Android Security Bulletin contiene i dettagli delle vulnerabilità di sicurezza che interessano i dispositivi Android. I livelli di patch di sicurezza del 05-06-2018 o successivi risolvono tutti questi problemi. Per informazioni su come controllare il livello di patch di sicurezza di un dispositivo, consulta Controllare e aggiornare la versione di Android .

I partner Android vengono informati di tutti i problemi almeno un mese prima della pubblicazione. Le patch del codice sorgente per questi problemi sono state rilasciate nel repository Android Open Source Project (AOSP) e collegate da questo bollettino. Questo bollettino include anche collegamenti a patch al di fuori di AOSP.

Il più grave di questi problemi è una vulnerabilità di sicurezza critica nel framework Media che potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato. La valutazione della gravità si basa sull'effetto che lo sfruttamento della vulnerabilità potrebbe avere su un dispositivo interessato, supponendo che la piattaforma e le attenuazioni del servizio siano disattivate per scopi di sviluppo o se bypassate correttamente.

Non abbiamo avuto segnalazioni di sfruttamento attivo da parte dei clienti o abuso di questi problemi appena segnalati. Fare riferimento alla sezione sulle attenuazioni di Android e Google Play Protect per i dettagli sulle protezioni della piattaforma di sicurezza Android e su Google Play Protect, che migliorano la sicurezza della piattaforma Android.

Nota: le informazioni sull'ultimo aggiornamento over-the-air (OTA) e sulle immagini del firmware per i dispositivi Google sono disponibili nel Pixel/Nexus Security Bulletin di giugno 2018 .

Mitigazioni dei servizi Android e Google

Questo è un riepilogo delle attenuazioni fornite dalla piattaforma di sicurezza Android e dalle protezioni del servizio come Google Play Protect . Queste funzionalità riducono la probabilità che le vulnerabilità della sicurezza possano essere sfruttate con successo su Android.

  • Lo sfruttamento per molti problemi su Android è reso più difficile dai miglioramenti nelle versioni più recenti della piattaforma Android. Incoraggiamo tutti gli utenti ad aggiornare all'ultima versione di Android, ove possibile.
  • Il team di sicurezza di Android monitora attivamente gli abusi tramite Google Play Protect e avvisa gli utenti in merito alle applicazioni potenzialmente dannose . Google Play Protect è abilitato per impostazione predefinita sui dispositivi con Google Mobile Services ed è particolarmente importante per gli utenti che installano app al di fuori di Google Play.

Dettagli sulla vulnerabilità del livello di patch di sicurezza 2018-06-01

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2018-06-01. Le vulnerabilità sono raggruppate sotto la componente che interessano. Sono presenti una descrizione del problema e una tabella con il CVE, i riferimenti associati, il tipo di vulnerabilità , la gravità e le versioni AOSP aggiornate (ove applicabile). Quando disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID del bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, i riferimenti aggiuntivi sono collegati a numeri che seguono l'ID del bug.

Struttura

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di ignorare i requisiti di interazione dell'utente per ottenere l'accesso a autorizzazioni aggiuntive.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2018-9338 A-71361168 EoP Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2018-9339 A-71508348 EoP Alto 8.0, 8.1
CVE-2017-13227 A-69981710 ID Alto 8.0, 8.1
CVE-2018-9340 A-71360999 ID Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1

Quadro dei media

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2018-9341 A-74016277 RCE Critico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2018-5146 A-77284393 * RCE Critico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2017-13230 A-65483665 RCE Critico 6.0
CVE-2018-9344 A-73172817 EoP Alto 8.1
CVE-2018-9345 A-77238250 ID Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2018-9346 A-77238762 ID Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2018-9347 A-68664359 DoS Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2018-9348 A-68953854 DoS Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1

Sistema

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2018-9355 A-74016921 RCE Critico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2018-9356 A-74950468 RCE Critico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2018-9357 A-74947856 RCE Critico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2018-9358 A-73172115 ID Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2018-9359 A-74196706 ID Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2018-9360 A-74201143 ID Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2018-9361 A-74202041 ID Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2018-9362 A-72298611 DoS Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1

Livello patch di sicurezza 2018-06-05: dettagli sulla vulnerabilità

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2018-06-05. Le vulnerabilità sono raggruppate in base al componente che interessano e includono dettagli come CVE, riferimenti associati, tipo di vulnerabilità , gravità , componente (ove applicabile) e versioni AOSP aggiornate (ove applicabile). Quando disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID del bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, i riferimenti aggiuntivi sono collegati a numeri che seguono l'ID del bug.

componenti Broadcom

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto di accedere a dati normalmente accessibili solo alle applicazioni installate localmente con autorizzazioni.

CVE Riferimenti Tipo Gravità Componente
CVE-2018-5383 A-73665456 *
B-CS4906525
ID Alto Bluetooth

Componenti del kernel

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Componente
CVE-2018-9363 A-65853588 * EoP Alto Bluetooth
CVE-2017-17806 A-71752561
kernel a monte
EoP Alto cripto
CVE-2017-17807 A-71751178
kernel a monte
EoP Alto Portachiavi
CVE-2017-17558 A-71751622
kernel a monte
EoP Alto USB

componenti LG

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato locale di ignorare i requisiti di interazione dell'utente per ottenere l'accesso a autorizzazioni aggiuntive.

CVE Riferimenti Tipo Gravità Componente
CVE-2018-9364 A-69163111 * EoP Critico Boot loader

Quadro dei media

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di ignorare i requisiti di interazione dell'utente per ottenere l'accesso a autorizzazioni aggiuntive.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2018-9409 A-63144992 *
QC-CR#2114346
EoP Alto 8.1

componenti MediaTek

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato in remoto di eseguire codice arbitrario nel contesto del TCB.

CVE Riferimenti Tipo Gravità Componente
CVE-2018-9373 A-71867247 *
M-ALPS03740330
EoP Critico Mediatek WLAN TDLS
CVE-2018-9366 A-72314499 *
M-ALPS03762526
EoP Alto IMSA
CVE-2018-9367 A-72314219 *
M-ALPS03762692
EoP Alto Cameratool CCAP
CVE-2018-9368 A-70727446 *
M-ALPS03730693
EoP Alto mtksocaudio
CVE-2018-9369 A-70514573 *
M-ALPS03666161
EoP Alto boot loader
CVE-2018-9370 A-70515281 *
M-ALPS03693488
EoP Alto boot loader
CVE-2018-9371 A-70515752 *
M-ALPS03683903
EoP Alto Boot loader
CVE-2018-9372 A-70730215 *
M-ALPS03676237
EoP Alto boot loader

componenti NVIDIA

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Componente
CVE-2017-6290 A-69559414 *
N-200373895
EoP Alto TLK TrustZone
CVE-2017-6294 A-69316825 *
N-200369095
EoP Alto NVIDIA Tegra X1 TZ
CVE-2017-6292 A-69480285 *
N-200373888
EoP Alto TLZ TrustZone

componenti Qualcomm

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato locale di ignorare i requisiti di interazione dell'utente per ottenere l'accesso a autorizzazioni aggiuntive.

CVE Riferimenti Tipo Gravità Componente
CVE-2017-18158 A-68992400
QC-CR#2104056
EoP Critico Boot loader
CVE-2018-3569 A-74237215
QC-CR#2161920
EoP Critico Ospite WLAN
CVE-2017-18155 A-66734153 *
QC-CR#1050893
RCE Critico Codec hardware
CVE-2018-5854 A-71800779
QC-CR#2183877
EoP Critico Boot loader
CVE-2017-13077 A-63165064 * EoP Alto WLAN
CVE-2018-5896 A-70399602 *
QC-CR#2163793
ID Alto Driver di diagnostica
CVE-2018-5829 A-74237546
QC-CR#2151241
ID Alto WLAN
CVE-2018-5383 A-73665204 *
QC-CR#2187697
ID Alto Bluetooth
CVE-2017-18159 A-68992405
QC-CR#2105697 [ 2 ] [ 3 ] [ 4 ] [ 5 ] [ 6 ] [ 7 ] [ 8 ] [ 9 ]
EoP Alto Boot loader
CVE-2017-18158 A-67782849 *
QC-CR#2104056
EoP Alto Boot loader
CVE-2018-5835 A-74237148
QC-CR#2153553
EoP Alto Ospite WLAN
CVE-2018-5834 A-74237804
QC-CR#2153326
EoP Alto WLAN
CVE-2018-5831 A-74237606
QC-CR#2161310
EoP Alto Driver GPU
CVE-2018-5830 A-74237532
QC-CR#2157917 [ 2 ]
EoP Alto Ospite WLAN

Componenti chiusi di Qualcomm

Queste vulnerabilità interessano i componenti di Qualcomm e sono descritte in modo più dettagliato nel bollettino sulla sicurezza di Qualcomm AMSS o nell'avviso di sicurezza appropriato. La valutazione della gravità di questi problemi è fornita direttamente da Qualcomm.

CVE Riferimenti Tipo Gravità Componente
CVE-2017-18157 A-73539080 * N / A Alto Componente closed-source
CVE-2017-18156 A-73539065 * N / A Alto Componente closed-source
CVE-2018-5892 A-72951191 * N / A Alto Componente closed-source
CVE-2018-5891 A-72950815 * N / A Alto Componente closed-source
CVE-2018-5885 A-72950554 * N / A Alto Componente closed-source
CVE-2018-5894 A-74236854 * N / A Alto Componente closed-source
CVE-2018-5884 A-74235510 * N / A Alto Componente closed-source

Sistema

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto di accedere a dati normalmente accessibili solo alle applicazioni installate localmente con autorizzazioni.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2018-5383 A-72377774 ID Alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1

Domande e risposte comuni

Questa sezione risponde alle domande più comuni che possono verificarsi dopo la lettura di questo bollettino.

1. Come faccio a determinare se il mio dispositivo è aggiornato per risolvere questi problemi?

Per informazioni su come controllare il livello di patch di sicurezza di un dispositivo, consulta Controllare e aggiornare la versione di Android .

  • I livelli di patch di sicurezza del 01-06-2018 o successivi risolvono tutti i problemi associati al livello di patch di sicurezza del 01-06-2018.
  • I livelli di patch di sicurezza del 05-06-2018 o successivi risolvono tutti i problemi associati al livello di patch di sicurezza del 05-06-2018 e tutti i livelli di patch precedenti.

I produttori di dispositivi che includono questi aggiornamenti devono impostare il livello della stringa di patch su:

  • [ro.build.version.security_patch]:[2018-06-01]
  • [ro.build.version.security_patch]:[2018-06-05]

2. Perché questo bollettino ha due livelli di patch di sicurezza?

Questo bollettino ha due livelli di patch di sicurezza in modo che i partner Android abbiano la flessibilità di correggere più rapidamente un sottoinsieme di vulnerabilità simili su tutti i dispositivi Android. I partner Android sono invitati a risolvere tutti i problemi in questo bollettino e utilizzare il livello di patch di sicurezza più recente.

  • I dispositivi che utilizzano il livello di patch di sicurezza 2018-06-01 devono includere tutti i problemi associati a tale livello di patch di sicurezza, nonché le correzioni per tutti i problemi segnalati nei precedenti bollettini sulla sicurezza.
  • I dispositivi che utilizzano il livello di patch di sicurezza del 05-06-2018 o più recente devono includere tutte le patch applicabili in questo (e precedenti) bollettini sulla sicurezza.

I partner sono incoraggiati a raggruppare le correzioni per tutti i problemi che stanno affrontando in un unico aggiornamento.

3. Cosa significano le voci nella colonna Tipo ?

Le voci nella colonna Tipo della tabella dei dettagli della vulnerabilità fanno riferimento alla classificazione della vulnerabilità della sicurezza.

Abbreviazione Definizione
RCE Esecuzione di codice a distanza
EoP Elevazione del privilegio
ID Rivelazione di un 'informazione
DoS Negazione del servizio
N / A Classificazione non disponibile

4. Cosa significano le voci nella colonna Riferimenti ?

Le voci nella colonna Riferimenti della tabella dei dettagli della vulnerabilità possono contenere un prefisso che identifica l'organizzazione a cui appartiene il valore di riferimento.

Prefisso Riferimento
UN- ID bug Android
controllo qualità- Numero di riferimento Qualcomm
M- Numero di riferimento MediaTek
N- Numero di riferimento NVIDIA
B- Numero di riferimento Broadcom

5. Cosa significa un * accanto all'ID del bug Android nella colonna Riferimenti ?

I problemi che non sono disponibili pubblicamente hanno un * accanto all'ID del bug Android nella colonna Riferimenti . L'aggiornamento per quel problema è generalmente contenuto nei driver binari più recenti per i dispositivi Pixel/Nexus disponibili sul sito Google Developer .

6. Perché le vulnerabilità della sicurezza sono suddivise tra questo bollettino e i bollettini sulla sicurezza del dispositivo/partner, come il bollettino Pixel/Nexus?

Le vulnerabilità di sicurezza documentate in questo bollettino sulla sicurezza sono necessarie per dichiarare il livello di patch di sicurezza più recente sui dispositivi Android. Per dichiarare un livello di patch di sicurezza non sono necessarie ulteriori vulnerabilità di sicurezza documentate nei bollettini sulla sicurezza del dispositivo/partner. I produttori di dispositivi Android e chipset sono incoraggiati a documentare la presenza di altre correzioni sui propri dispositivi tramite i propri siti Web di sicurezza, come i bollettini sulla sicurezza Samsung , LGE o Pixel/Nexus .

Versioni

Versione Data Appunti
1.0 4 giugno 2018 Bollettino pubblicato.
1.1 6 giugno 2018 Bollettino rivisto per includere i collegamenti AOSP.
1.2 24 luglio 2018 Bollettino rivisto per includere riferimenti a CVE-2018-5383 come da informativa coordinata.