نشرة أمان Android - ديسمبر 2019

تم النشر في 2 ديسمبر 2019 | تم التحديث في 14 يناير 2020

تحتوي نشرة أمان Android على تفاصيل الثغرات الأمنية التي تؤثر على أجهزة Android. مستويات تصحيح الأمان لعام 2019-12-05 أو ما بعده تعالج كل هذه المشكلات. لمعرفة كيفية التحقق من مستوى تصحيح الأمان لجهاز ، راجع التحقق من إصدار Android وتحديثه .

يتم إخطار شركاء Android بجميع المشكلات قبل شهر على الأقل من النشر. تم إصدار تصحيحات التعليمات البرمجية المصدر لهذه المشكلات إلى مستودع Android Open Source Project (AOSP) وربطها من هذه النشرة. تتضمن هذه النشرة أيضًا روابط إلى تصحيحات خارج AOSP.

وتتمثل أخطر هذه المشكلات في وجود ثغرة أمنية خطيرة في مكون Framework والتي يمكن أن تمكن مهاجمًا عن بُعد يستخدم رسالة مصممة خصيصًا لإحداث رفض دائم للخدمة. يعتمد تقييم الخطورة على التأثير الذي قد يحدثه استغلال الثغرة الأمنية على الجهاز المتأثر ، بافتراض إيقاف تشغيل عمليات تخفيف النظام الأساسي والخدمة لأغراض التطوير أو إذا تم تجاوزها بنجاح.

راجع قسم تخفيف Android و Google Play Protect للحصول على تفاصيل حول حماية نظام أمان Android و Google Play Protect ، والتي تعمل على تحسين أمان نظام Android الأساسي.

ملاحظة: تتوفر معلومات حول آخر تحديث عبر الهواء (OTA) وصور البرامج الثابتة لأجهزة Google في نشرة تحديث Pixel لشهر ديسمبر 2019 .

عمليات التخفيف من خدمة Android و Google

هذا ملخص لعمليات التخفيف التي يوفرها نظام أمان Android الأساسي وخدمات حماية مثل Google Play Protect . تقلل هذه الإمكانات من احتمالية نجاح استغلال الثغرات الأمنية على Android.

  • أصبح استغلال العديد من المشكلات على Android أكثر صعوبة من خلال التحسينات في الإصدارات الأحدث من نظام Android الأساسي. نشجع جميع المستخدمين على التحديث إلى أحدث إصدار من Android حيثما أمكن ذلك.
  • يقوم فريق أمان Android بمراقبة إساءة الاستخدام بنشاط من خلال Google Play Protect ويحذر المستخدمين من التطبيقات التي يُحتمل أن تكون ضارة . يتم تمكين Google Play Protect افتراضيًا على الأجهزة المزودة بخدمات Google Mobile ، وهو مهم بشكل خاص للمستخدمين الذين يقومون بتثبيت التطبيقات من خارج Google Play.

2019-12-01 تفاصيل الثغرة الأمنية في مستوى تصحيح الأمان

في الأقسام أدناه ، نقدم تفاصيل عن كل ثغرة أمنية تنطبق على مستوى التصحيح 2019-12-01. يتم تجميع الثغرات الأمنية تحت المكون الذي تؤثر عليه. يوجد وصف للمشكلة وجدول مع CVE ، والمراجع المرتبطة بها ، ونوع الثغرة الأمنية ، والخطورة ، وإصدارات AOSP المحدثة (حيثما ينطبق ذلك). عند توفرها ، نقوم بربط التغيير العام الذي عالج المشكلة بمعرف الخطأ ، مثل قائمة تغيير AOSP. عندما تتعلق تغييرات متعددة بخلل واحد ، يتم ربط مراجع إضافية بأرقام تتبع معرّف الخطأ. قد تتلقى الأجهزة التي تعمل بنظام Android 10 والإصدارات الأحدث تحديثات أمنية بالإضافة إلى تحديثات نظام Google Play .

نطاق

قد تمكن أخطر ثغرة أمنية في هذا القسم مهاجمًا عن بُعد يستخدم رسالة معدة خصيصًا للتسبب في رفض دائم للخدمة.

CVE مراجع يكتب خطورة إصدارات AOSP المحدثة
CVE-2019-2232 أ -140632678 DoS حرج 8.0 ، 8.1 ، 9 ، 10
CVE-2019-9464 A-141028068 [ 2 ] [ 3 ] [ 4 ] EoP عالٍ 10
CVE-2019-2217 أ -141003796 EoP عالٍ 10
CVE-2019-2218 أ -141169173 EoP عالٍ 8.0 ، 8.1 ، 9 ، 10
CVE-2019-2220 A-138636979 [ 2 ] بطاقة تعريف عالٍ 9 ، 10
CVE-2019-2221 A-138583650 [ 2 ] EoP معتدل 10

إطار عمل الوسائط

يمكن أن تمكن الثغرة الأمنية الأكثر خطورة في هذا القسم مهاجمًا عن بُعد يستخدم ملفًا تم إنشاؤه خصيصًا لتنفيذ تعليمات برمجية عشوائية في سياق عملية ذات امتيازات.

CVE مراجع يكتب خطورة إصدارات AOSP المحدثة
CVE-2019-2222 أ -140322595 RCE معتدل 10
RCE حرج 8.0 ، 8.1 ، 9
CVE-2019-2223 أ -140692129 RCE معتدل 10
RCE حرج 8.0 ، 8.1 ، 9

نظام

يمكن أن تمكن الثغرة الأمنية الأكثر خطورة في هذا القسم مهاجمًا عن بُعد يستخدم ملفًا تم إنشاؤه خصيصًا لتنفيذ تعليمات برمجية عشوائية في سياق عملية غير مميزة.

CVE مراجع يكتب خطورة إصدارات AOSP المحدثة
CVE-2019-15140 أ -140328986 RCE عالٍ 8.0 ، 8.1 ، 9 ، 10
CVE-2019-2225 A-110433804 [ 2 ] EoP عالٍ 8.0 ، 8.1 ، 9 ، 10
CVE-2019-2226 أ -140152619 بطاقة تعريف عالٍ 8.0 ، 8.1 ، 9 ، 10
CVE-2019-2227 أ -140768453 بطاقة تعريف عالٍ 9 ، 10
CVE-2019-2228 A-111210196 [ 2 ] بطاقة تعريف عالٍ 8.0 ، 8.1 ، 9 ، 10
CVE-2019-2229 A-139803872 [ 2 ] بطاقة تعريف عالٍ 8.0 ، 8.1 ، 9 ، 10
CVE-2019-2230 أ -141170038 بطاقة تعريف عالٍ 10

تحديثات نظام جوجل بلاي

يتم تضمين مشكلات الأمان هذه في تحديثات نظام Google Play.

مكون CVEs
برامج ترميز الوسائط CVE-2019-2222 ، CVE-2019-2223

2019-12-05 تفاصيل الثغرة الأمنية في مستوى تصحيح الأمان

في الأقسام أدناه ، نقدم تفاصيل عن كل ثغرة أمنية تنطبق على مستوى التصحيح 2019-12-05. يتم تجميع الثغرات الأمنية ضمن المكون الذي تؤثر عليه وتتضمن تفاصيل مثل CVE والمراجع المرتبطة ونوع الثغرة الأمنية والخطورة والمكون (عند الاقتضاء) وإصدارات AOSP المحدثة (عند الاقتضاء). عند توفرها ، نقوم بربط التغيير العام الذي عالج المشكلة بمعرف الخطأ ، مثل قائمة تغيير AOSP. عندما تتعلق تغييرات متعددة بخلل واحد ، يتم ربط مراجع إضافية بأرقام تتبع معرّف الخطأ.

نظام

قد تؤدي الثغرة الأمنية في هذا القسم إلى تمكين مهاجم محلي يتمتع بامتيازات الوصول للوصول إلى البيانات الحساسة.

CVE مراجع يكتب خطورة إصدارات AOSP المحدثة
CVE-2019-2231 أ 141955555 بطاقة تعريف عالٍ 9 ، 10

مكونات النواة

قد تمكن أخطر ثغرة في هذا القسم تطبيقًا ضارًا محليًا من تنفيذ تعليمات برمجية عشوائية في سياق عملية ذات امتيازات.

CVE مراجع يكتب خطورة مكون
CVE-2018-20961 أ -139522588
نواة المنبع
EoP عالٍ USB سائق وظيفة فئة MIDI
CVE-2019-15220 A-140329469
نواة المنبع
EoP عالٍ برنامج تشغيل USB WiFi Prism54
CVE-2019-15239 أ -140328996
نواة المنبع
EoP عالٍ مكدس TCP

مكونات كوالكوم

تؤثر هذه الثغرات الأمنية على مكونات Qualcomm ويتم وصفها بمزيد من التفصيل في نشرة أمان Qualcomm المناسبة أو تنبيه الأمان. يتم توفير تقييم خطورة هذه المشكلات مباشرة من قبل شركة Qualcomm.

CVE مراجع يكتب خطورة مكون
CVE-2019-10557 A-78657016
QC-CR # 2255369
QC-CR # 2259707
غير متاح عالٍ مضيف WLAN
CVE-2018-11980 أ -140423440
QC-CR # 2270117
غير متاح عالٍ مضيف WLAN
CVE-2019-10480 أ -140423811
QC-CR # 2309399
غير متاح عالٍ مضيف WLAN
CVE-2019-10481 أ -140423794
QC-CR # 2304610
QC-CR # 2318632
غير متاح عالٍ مضيف WLAN
CVE-2019-10536 أ -140423334
QC-CR # 2433802
غير متاح عالٍ مضيف WLAN
CVE-2019-10537 أ -140423693
QC-CR # 2436502
غير متاح عالٍ مضيف WLAN
CVE-2019-10595 أ -140423810
QC-CR # 2148184
غير متاح عالٍ مضيف WLAN
CVE-2019-10598 أ -140423155
QC-CR # 2324139
غير متاح عالٍ مضيف WLAN
CVE-2019-10601 أ -140423156
QC-CR # 2428798
غير متاح عالٍ مضيف WLAN
CVE-2019-10605 A-140424124
QC-CR # 2187441
غير متاح عالٍ مضيف WLAN
CVE-2019-10607 أ -140423690
QC-CR # 2211711
غير متاح عالٍ حماية
CVE-2019-2304 أ -123238115
QC-CR # 2331868
QC-CR # 2335530
QC-CR # 2348299
QC-CR # 2203904 *
غير متاح عالٍ مضيف WLAN

مكونات كوالكوم المغلقة المصدر

تؤثر هذه الثغرات الأمنية على مكونات Qualcomm المغلقة المصدر ويتم وصفها بمزيد من التفصيل في نشرة أمان Qualcomm المناسبة أو تنبيه الأمان. يتم توفير تقييم خطورة هذه المشكلات مباشرة من قبل شركة Qualcomm.

CVE مراجع يكتب خطورة مكون
CVE-2019-2242 A-123998200 * غير متاح حرج مكون مغلق المصدر
CVE-2019-10500 A-134437248 * غير متاح حرج مكون مغلق المصدر
CVE-2019-10525 A-134437319 * غير متاح حرج مكون مغلق المصدر
CVE-2019-10482 A-132108950 * غير متاح عالٍ مكون مغلق المصدر
CVE-2019-10487 A-134437030 * غير متاح عالٍ مكون مغلق المصدر
CVE-2019-10516 A-134437075 * غير متاح عالٍ مكون مغلق المصدر
CVE-2019-2274 A-134437362 * غير متاح عالٍ مكون مغلق المصدر
CVE-2019-10513 A-134437225 * غير متاح عالٍ مكون مغلق المصدر
CVE-2019-10517 A-140424724 * غير متاح عالٍ مكون مغلق المصدر
CVE-2019-10600 A-140424089 * غير متاح عالٍ مكون مغلق المصدر

أسئلة وأجوبة شائعة

يجيب هذا القسم على الأسئلة الشائعة التي قد تطرأ بعد قراءة هذه النشرة.

1. كيف يمكنني تحديد ما إذا كان قد تم تحديث جهازي لمعالجة هذه المشكلات؟

لمعرفة كيفية التحقق من مستوى تصحيح الأمان لجهاز ، راجع التحقق من إصدار Android وتحديثه .

  • تتناول مستويات تصحيح الأمان لعام 2019-12-01 أو الإصدارات الأحدث جميع المشكلات المرتبطة بمستوى تصحيح الأمان 2019-12-01.
  • تتناول مستويات تصحيح الأمان لعام 2019-12-05 أو أحدث جميع المشكلات المرتبطة بمستوى تصحيح الأمان 2019-12-05 وجميع مستويات التصحيح السابقة.

يجب على الشركات المصنعة للأجهزة التي تتضمن هذه التحديثات تعيين مستوى سلسلة التصحيح على:

  • [ro.build.version.security_patch]: [2019-12-01]
  • [ro.build.version.security_patch]: [2019-12-05]

بالنسبة لبعض الأجهزة التي تعمل بنظام Android 10 أو إصدار أحدث ، سيكون لتحديث نظام Google Play سلسلة تاريخ تطابق مستوى تصحيح الأمان 2019-12-01. الرجاء مراجعة هذه المقالة للحصول على مزيد من التفاصيل حول كيفية تثبيت تحديثات الأمان.

2. لماذا تحتوي هذه النشرة على مستويين من تصحيح الأمان؟

تحتوي هذه النشرة على مستويين من تصحيح الأمان بحيث يتمتع شركاء Android بالمرونة لإصلاح مجموعة فرعية من الثغرات الأمنية المتشابهة عبر جميع أجهزة Android بسرعة أكبر. يتم تشجيع شركاء Android على إصلاح جميع المشكلات الواردة في هذه النشرة واستخدام أحدث مستوى من تصحيح الأمان.

  • يجب أن تتضمن الأجهزة التي تستخدم مستوى تصحيح الأمان 2019-12-01 جميع المشكلات المرتبطة بمستوى تصحيح الأمان هذا ، بالإضافة إلى إصلاحات لجميع المشكلات التي تم الإبلاغ عنها في نشرات الأمان السابقة.
  • يجب أن تشتمل الأجهزة التي تستخدم مستوى تصحيح الأمان 2019-12-05 أو أحدث على جميع التصحيحات القابلة للتطبيق في نشرات الأمان هذه (والسابقة).

يتم تشجيع الشركاء على تجميع الإصلاحات لجميع المشكلات التي يعالجونها في تحديث واحد.

3. ماذا تعني الإدخالات في عمود النوع ؟

تشير الإدخالات في عمود النوع في جدول تفاصيل الثغرات الأمنية إلى تصنيف الثغرة الأمنية.

اختصار تعريف
RCE تنفيذ التعليمات البرمجية عن بعد
EoP رفع الامتياز
بطاقة تعريف الإفصاح عن المعلومات
DoS الحرمان من الخدمة
غير متاح التصنيف غير متوفر

4. ماذا تعني الإدخالات في عمود المراجع ؟

قد تحتوي الإدخالات الموجودة ضمن عمود المراجع في جدول تفاصيل الثغرات الأمنية على بادئة تحدد المؤسسة التي تنتمي إليها القيمة المرجعية.

بادئة المرجعي
أ- معرف خطأ Android
QC- الرقم المرجعي لشركة Qualcomm
م- الرقم المرجعي MediaTek
ن- الرقم المرجعي لـ NVIDIA
ب- الرقم المرجعي من Broadcom

5. ماذا يعني * الموجود بجوار معرف خطأ Android في عمود المراجع ؟

المشكلات غير المتاحة للجمهور بها علامة * بجوار معرف خطأ Android في عمود المراجع . يتم تضمين التحديث الخاص بهذه المشكلة بشكل عام في أحدث برامج التشغيل الثنائية لأجهزة Pixel المتوفرة من موقع Google Developer .

6. لماذا يتم تقسيم الثغرات الأمنية بين هذه النشرة ونشرات أمان الجهاز / الشريك ، مثل نشرة Pixel؟

الثغرات الأمنية التي تم توثيقها في نشرة الأمن هذه مطلوبة للإعلان عن أحدث مستوى من تصحيح الأمان على أجهزة Android. الثغرات الأمنية الإضافية التي تم توثيقها في نشرات أمان الجهاز / الشريك غير مطلوبة للإعلان عن مستوى تصحيح الأمان. قد ينشر مصنعو أجهزة Android ومجموعة الشرائح أيضًا تفاصيل الثغرات الأمنية الخاصة بمنتجاتهم ، مثل Google أو Huawei أو LGE أو Motorola أو Nokia أو Samsung .

إصدارات

إصدار تاريخ ملحوظات
1.0 2 ديسمبر 2019 تم نشر النشرة
1.1 3 ديسمبر 2019 تمت مراجعة النشرة لتشمل روابط AOSP
1.2 13 ديسمبر 2019 جدول CVE المنقح
1.3 14 يناير 2020 تم تحديث معرّف CVE للإصدار A-140328986 إلى CVE-2019-15140