Android Güvenlik Bülteni—Kasım 2021

1 Kasım 2021'de yayınlandı | 3 Aralık 2021'de güncellendi

Android Güvenlik Bülteni, Android cihazlarını etkileyen güvenlik açıklarının ayrıntılarını içerir. 2021-11-06 veya sonraki güvenlik yaması seviyeleri, tüm bu sorunları giderir. Bir cihazın güvenlik düzeltme eki düzeyini nasıl kontrol edeceğinizi öğrenmek için Android sürümünüzü kontrol edin ve güncelleyin bölümüne bakın.

Android iş ortaklarına, tüm sorunlar yayınlanmadan en az bir ay önce bildirilir. Bu sorunlar için kaynak kodu yamaları Android Açık Kaynak Projesi (AOSP) deposunda yayınlandı ve bu bültenden bağlantı verildi. Bu bülten ayrıca AOSP dışındaki yamalara bağlantılar içerir

Bu sorunlardan en ciddi olanı, özel hazırlanmış bir iletim kullanan uzak bir saldırganın ayrıcalıklı bir işlem bağlamında rastgele kod yürütmesine olanak verebilecek Sistem bileşenindeki kritik bir güvenlik açığıdır. Önem derecesi değerlendirmesi , platform ve hizmet azaltmalarının geliştirme amacıyla kapatıldığı veya başarılı bir şekilde atlandığı varsayılarak, güvenlik açığından yararlanmanın muhtemelen etkilenen bir cihaz üzerindeki etkisine dayanır.

Android platformunun güvenliğini artıran Android güvenlik platformu korumaları ve Google Play Protect ile ilgili ayrıntılar için Android ve Google Play Protect azaltıcı etkenler bölümüne bakın.

Android ve Google hizmet azaltmaları

Bu, Android güvenlik platformu ve Google Play Protect gibi hizmet korumaları tarafından sağlanan azaltmaların bir özetidir. Bu yetenekler, güvenlik açıklarından Android'de başarıyla yararlanma olasılığını azaltır.

  • Android platformunun daha yeni sürümlerinde yapılan geliştirmeler sayesinde Android'deki birçok sorundan yararlanma daha zor hale getirildi. Tüm kullanıcıları, mümkün olduğunda Android'in en son sürümüne güncellemeye teşvik ediyoruz.
  • Android güvenlik ekibi, Google Play Protect aracılığıyla kötüye kullanımı etkin bir şekilde izler ve kullanıcıları Zararlı Olabilecek Uygulamalar hakkında uyarır. Google Play Protect, Google Mobil Hizmetleri bulunan cihazlarda varsayılan olarak etkindir ve özellikle Google Play dışından uygulama yükleyen kullanıcılar için önemlidir.

2021-11-01 güvenlik yaması düzeyinde güvenlik açığı ayrıntıları

Aşağıdaki bölümlerde, 2021-11-01 yama düzeyi için geçerli olan güvenlik açıklarının her biri için ayrıntılar sunuyoruz. Güvenlik açıkları, etkiledikleri bileşen altında gruplandırılmıştır. Sorunlar aşağıdaki tablolarda açıklanmıştır ve CVE Kimliği, ilgili referanslar, güvenlik açığı türü , önem derecesi ve güncellenmiş AOSP sürümlerini (varsa) içerir. Mevcut olduğunda, sorunu ele alan genel değişikliği AOSP değişiklik listesi gibi hata kimliğine bağlarız. Birden fazla değişiklik tek bir hatayla ilgili olduğunda, hata kimliğini izleyen sayılara ek referanslar bağlanır. Android 10 ve sonraki sürümlere sahip cihazlar, Google Play sistem güncellemelerinin yanı sıra güvenlik güncellemelerini de alabilir.

Çerçeve

Bu bölümdeki en ciddi güvenlik açığı, yerel bir saldırganın kullanıcı etkileşimi gerektirmeden ek izinlere erişmesini sağlayabilir.

CVE Referanslar Tip önem Güncellenmiş AOSP sürümleri
CVE-2021-0799 A-197647956 EoP Yüksek 12
CVE-2021-0921 A-195962697 EoP Yüksek 11
CVE-2021-0923 A-195338390 EoP Yüksek 12
CVE-2021-0926 A-191053931 EoP Yüksek 9, 10, 11, 12
CVE-2021-0933 A-172251622 EoP Yüksek 9, 10, 11, 12
CVE-2020-13871 A-192606047 İD Yüksek 11
CVE-2021-0653 A-177931370 İD Yüksek 9, 10, 11
CVE-2021-0922 A-195630721 EoP Ilıman 11

Medya Çerçevesi

Bu bölümdeki en ciddi güvenlik açığı, yerel bir kötü amaçlı uygulamanın ek izinlere erişmek için kullanıcı etkileşimi gereksinimlerini atlamasına olanak verebilir.

CVE Referanslar Tip önem Güncellenmiş AOSP sürümleri
CVE-2021-0928 A-188675581 EoP Yüksek 9, 10, 11
CVE-2021-0650 A-190286685 İD Yüksek 9, 10, 11

sistem

Bu bölümdeki en ciddi güvenlik açığı, özel hazırlanmış bir iletim kullanan uzak bir saldırganın ayrıcalıklı bir işlem bağlamında rasgele kod yürütmesine olanak verebilir.

CVE Referanslar Tip önem Güncellenmiş AOSP sürümleri
CVE-2021-0918 A-197536150 RCE kritik 12
CVE-2021-0930 A-181660091 RCE kritik 9, 10, 11, 12
CVE-2021-0434 A-167403112 [ 2 ] [ 3 ] [ 4 ] [ 5 ] [ 6 ] EoP Yüksek 9, 10, 11
CVE-2021-0649 A-191382886 [ 2 ] EoP Yüksek 11
CVE-2021-0932 A-173025705 EoP Yüksek 10
CVE-2021-0925 A-191444150 İD Yüksek 12
CVE-2021-0931 A-180747689 İD Yüksek 9, 10, 11, 12
CVE-2021-0919 A-197336441 DoS Ilıman 9, 10, 11

Google Play sistem güncellemeleri

Aşağıdaki sorunlar Project Mainline bileşenlerine dahil edilmiştir.

Bileşen CVE
bağlama CVE-2021-0653
Medya Çerçevesi bileşenleri CVE-2021-0650
bağlama CVE-2021-0649

2021-11-05 güvenlik yaması düzeyinde güvenlik açığı ayrıntıları

Aşağıdaki bölümlerde, 2021-11-05 yama düzeyi için geçerli olan güvenlik açıklarının her biri için ayrıntılar sağlıyoruz. Güvenlik açıkları, etkiledikleri bileşen altında gruplandırılmıştır. Sorunlar aşağıdaki tablolarda açıklanmıştır ve CVE Kimliği, ilgili referanslar, güvenlik açığı türü , önem derecesi ve güncellenmiş AOSP sürümlerini (varsa) içerir. Mevcut olduğunda, sorunu ele alan genel değişikliği AOSP değişiklik listesi gibi hata kimliğine bağlarız. Birden fazla değişiklik tek bir hatayla ilgili olduğunda, hata kimliğini izleyen sayılara ek referanslar bağlanır.

çekirdek bileşenleri

Bu bölümdeki en ciddi güvenlik açığı, ücretsiz kullanımdan sonra yerel olarak ayrıcalık yükselmesine neden olabilir.
CVE Referanslar Tip önem Bileşen
CVE-2021-0920 A-196926917
yukarı akış çekirdeği
EoP Yüksek Çekirdek
CVE-2021-0924 A-194461020
yukarı akış çekirdeği
EoP Yüksek USB
CVE-2021-0929 A-187527909
Yukarı akış çekirdeği [ 2 ] [ 3 ]
EoP Yüksek İYON

Android TV

Bu bölümdeki en ciddi güvenlik açığı, yakın bir saldırganın bir TV ile sessizce eşleşmesini ve herhangi bir ayrıcalık veya kullanıcı etkileşimi gerekmeden rastgele kod yürütmesini sağlayabilir.

CVE Referanslar Tip önem Bileşen
CVE-2021-0889 A-180745296 RCE kritik Android TV Uzaktan Servisi
CVE-2021-0927 A-189824175 EoP Yüksek TvGirdiYöneticisi

MediaTek bileşenleri

Bu güvenlik açığı MediaTek bileşenlerini etkiler ve daha fazla ayrıntı doğrudan MediaTek'ten edinilebilir. Bu sorunun önem derecesi değerlendirmesi doğrudan MediaTek tarafından sağlanmaktadır.

CVE Referanslar önem Bileşen
CVE-2021-0672
A-199678035
M-ALPS05969704 *
Yüksek tarayıcı uygulaması

Qualcomm kapalı kaynak bileşenleri

Bu güvenlik açıkları Qualcomm kapalı kaynak bileşenlerini etkiler ve uygun Qualcomm güvenlik bülteninde veya güvenlik uyarısında daha ayrıntılı olarak açıklanır. Bu sorunların önem derecesi değerlendirmesi doğrudan Qualcomm tarafından sağlanır.

CVE Referanslar önem Bileşen
CVE-2021-1924
A-187074639 * kritik Kapalı kaynak bileşeni
CVE-2021-1975
A-187074053 * kritik Kapalı kaynak bileşeni
CVE-2021-1921
A-187074562 * Yüksek Kapalı kaynak bileşeni
CVE-2021-1973
A-187074563 * Yüksek Kapalı kaynak bileşeni
CVE-2021-1979
A-187073200 * Yüksek Kapalı kaynak bileşeni
CVE-2021-1981
A-187074764 * Yüksek Kapalı kaynak bileşeni
CVE-2021-1982
A-187074484 * Yüksek Kapalı kaynak bileşeni
CVE-2021-30254
A-187074014 * Yüksek Kapalı kaynak bileşeni
CVE-2021-30255
A-187074054 * Yüksek Kapalı kaynak bileşeni
CVE-2021-30284
A-187074013 * Yüksek Kapalı kaynak bileşeni

2021-11-06 güvenlik yaması düzeyinde güvenlik açığı ayrıntıları

Aşağıdaki bölümlerde, 2021-11-06 yama düzeyi için geçerli olan güvenlik açıklarının her biri için ayrıntılar sağlıyoruz. Güvenlik açıkları, etkiledikleri bileşen altında gruplandırılmıştır. Sorunlar aşağıdaki tablolarda açıklanmıştır ve CVE Kimliği, ilgili referanslar, güvenlik açığı türü , önem derecesi ve güncellenmiş AOSP sürümlerini (varsa) içerir. Mevcut olduğunda, sorunu ele alan genel değişikliği AOSP değişiklik listesi gibi hata kimliğine bağlarız. Birden fazla değişiklik tek bir hatayla ilgili olduğunda, hata kimliğini izleyen sayılara ek referanslar bağlanır.

çekirdek bileşenleri

Bu bölümdeki güvenlik açığı, ücretsiz kullanımdan sonra yerel bir ayrıcalık yükselmesine neden olabilir.
CVE Referanslar Tip önem Bileşen
CVE-2021-1048 A-204573007
yukarı akış çekirdeği
EoP Yüksek Çekirdek

Sık sorulan sorular ve cevaplar

Bu bölüm, bu bülteni okuduktan sonra ortaya çıkabilecek genel soruları yanıtlamaktadır.

1. Cihazımın bu sorunları gidermek için güncellenip güncellenmediğini nasıl belirleyebilirim?

Bir cihazın güvenlik düzeltme eki düzeyini nasıl kontrol edeceğinizi öğrenmek için Android sürümünüzü kontrol edin ve güncelleyin bölümüne bakın.

  • 2021-11-01 veya sonraki güvenlik yaması seviyeleri, 2021-11-01 güvenlik yaması seviyesiyle ilişkili tüm sorunları ele alır.
  • 2021-11-05 veya sonraki güvenlik yaması seviyeleri, 2021-11-05 güvenlik yaması seviyesi ve önceki tüm yama seviyeleri ile ilişkili tüm sorunları ele alır.
  • 2021-11-06 veya sonraki güvenlik yaması seviyeleri, 2021-11-06 güvenlik yaması seviyesi ve önceki tüm yama seviyeleri ile ilişkili tüm sorunları ele alır.

Bu güncellemeleri içeren cihaz üreticileri, yama dizesi düzeyini şu şekilde ayarlamalıdır:

  • [ro.build.version.security_patch]:[2021-11-01]
  • [ro.build.version.security_patch]:[2021-11-05]
  • [ro.build.version.security_patch]:[2021-11-06]

Android 10 veya sonraki sürümlerdeki bazı cihazlar için Google Play sistem güncellemesi, 2021-11-01 güvenlik yaması düzeyiyle eşleşen bir tarih dizisine sahip olacaktır. Güvenlik güncellemelerinin nasıl yükleneceği hakkında daha fazla ayrıntı için lütfen bu makaleye bakın.

2. Bu bültende neden iki güvenlik düzeltme eki düzeyi var?

Bu bültende, Android iş ortaklarının tüm Android cihazlarda benzer olan bir dizi güvenlik açığını daha hızlı düzeltme esnekliğine sahip olması için iki güvenlik düzeltme eki düzeyi vardır. Android iş ortaklarının bu bültendeki tüm sorunları düzeltmeleri ve en son güvenlik düzeltme eki düzeyini kullanmaları önerilir.

  • 2021-11-01 güvenlik yaması düzeyini kullanan cihazlar, bu güvenlik yaması düzeyiyle ilişkili tüm sorunların yanı sıra önceki güvenlik bültenlerinde bildirilen tüm sorunların düzeltmelerini içermelidir.
  • 2021-11-05 veya daha yeni güvenlik düzeltme eki düzeyini kullanan cihazlar, bu (ve önceki) güvenlik bültenlerinde geçerli tüm yamaları içermelidir.
  • 2021-11-06 veya daha yeni güvenlik yama düzeyini kullanan cihazlar, bu (ve önceki) güvenlik bültenlerinde geçerli tüm yamaları içermelidir.

İş ortaklarının, ele aldıkları tüm sorunlara yönelik düzeltmeleri tek bir güncellemede toplamaları önerilir.

3. Tür sütunundaki girişler ne anlama geliyor?

Güvenlik açığı ayrıntıları tablosunun Tür sütunundaki girişler, güvenlik açığının sınıflandırmasına başvurur.

Kısaltma Tanım
RCE Uzaktan kod yürütme
EoP Ayrıcalığın yükseltilmesi
İD Bilgi ifşası
DoS hizmet reddi
Yok Sınıflandırma mevcut değil

4. Referanslar sütunundaki girişler ne anlama geliyor?

Güvenlik açığı ayrıntıları tablosunun Referanslar sütunu altındaki girişler, referans değerinin ait olduğu kuruluşu tanımlayan bir önek içerebilir.

Önek Referans
A- Android hata kimliği
KK- Qualcomm referans numarası
M- MediaTek referans numarası
N- NVIDIA referans numarası
B- Broadcom referans numarası
U- UNISOC referans numarası

5. Referanslar sütunundaki Android hata kimliğinin yanında * işareti ne anlama gelir?

Herkese açık olmayan sorunlarda, ilgili referans kimliğinin yanında * bulunur. Bu soruna ilişkin güncelleme genellikle, Google Developer sitesinde bulunan Pixel cihazları için en son ikili sürücülerinde bulunur.

6. Güvenlik açıkları neden bu bülten ile Pixel bülteni gibi cihaz/iş ortağı güvenlik bültenleri arasında bölünmüştür?

Bu güvenlik bülteninde belgelenen güvenlik açıkları, Android cihazlarda en son güvenlik düzeltme eki düzeyini bildirmek için gereklidir. Cihaz/ortak güvenlik bültenlerinde belgelenen ek güvenlik açıkları, bir güvenlik yaması düzeyi bildirmek için gerekli değildir. Android cihaz ve yonga seti üreticileri de Google , Huawei , LGE , Motorola , Nokia veya Samsung gibi ürünlerine özel güvenlik açığı ayrıntılarını yayınlayabilir.

Sürümler

sürüm Tarih notlar
1.0 1 Kasım 2021 Bülten Yayımlandı
1.1 2 Kasım 2021 Bülten, AOSP bağlantılarını içerecek şekilde revize edildi
1.2 3 Aralık 2021 Revize edilmiş CVE tablosu