Biuletyn dotyczący zabezpieczeń Androida — maj 2017 r.

Zadbaj o dobrą organizację dzięki kolekcji Zapisuj i kategoryzuj treści zgodnie ze swoimi preferencjami.

Opublikowano 01 maja 2017 | Zaktualizowano 3 października 2017 r.

Biuletyn Android Security Bulletin zawiera szczegółowe informacje na temat luk w zabezpieczeniach urządzeń z systemem Android. Wraz z biuletynem udostępniliśmy aktualizację zabezpieczeń urządzeń Nexus za pośrednictwem aktualizacji bezprzewodowej (OTA). Obrazy oprogramowania układowego urządzeń Google zostały również udostępnione w witrynie Google Developer . Poziomy poprawek zabezpieczeń z 5 maja 2017 r. lub później rozwiązują wszystkie te problemy. Zapoznaj się z harmonogramem aktualizacji Pixela i Nexusa, aby dowiedzieć się, jak sprawdzić poziom aktualizacji zabezpieczeń urządzenia.

Partnerzy zostali powiadomieni o problemach opisanych w biuletynie w dniu 03.04.2017 r. lub wcześniej. Poprawki do kodu źródłowego dla tych problemów zostały udostępnione w repozytorium Android Open Source Project (AOSP) i połączone z tym biuletynem. Biuletyn ten zawiera również łącza do poprawek spoza AOSP.

Najpoważniejszym z tych problemów jest krytyczna luka w zabezpieczeniach, która podczas przetwarzania plików multimedialnych może umożliwić zdalne wykonanie kodu na zaatakowanym urządzeniu za pomocą wielu metod, takich jak poczta e-mail, przeglądanie stron internetowych i MMS. Ocena dotkliwości opiera się na możliwym wpływie wykorzystania luki na urządzenie, którego dotyczy, przy założeniu, że platforma i usługi ograniczania zagrożeń są wyłączone w celach programistycznych lub pomyślnie ominięte.

Nie mieliśmy żadnych doniesień o aktywnym wykorzystywaniu lub nadużywaniu przez klientów tych nowo zgłoszonych problemów. Szczegółowe informacje na temat zabezpieczeń platformy Android i zabezpieczeń usług, takich jak SafetyNet , które poprawiają bezpieczeństwo platformy Android, można znaleźć w sekcji Ograniczenia ryzyka w usługach Android i Google .

Zachęcamy wszystkich klientów do zaakceptowania tych aktualizacji na swoich urządzeniach.

Ogłoszenia

  • Ten biuletyn zawiera dwa łańcuchy poziomów poprawek zabezpieczeń, aby zapewnić partnerom systemu Android elastyczność umożliwiającą szybsze naprawianie podzbioru luk, które są podobne na wszystkich urządzeniach z systemem Android. Zobacz Często zadawane pytania i odpowiedzi, aby uzyskać dodatkowe informacje:
    • 2017-05-01 : Częściowy ciąg poziomu poprawek zabezpieczeń. Ten ciąg poziomu poprawek zabezpieczeń wskazuje, że rozwiązano wszystkie problemy związane z 01.05.2017 (i wszystkimi poprzednimi ciągami poziomów poprawek zabezpieczeń).
    • 2017-05-05 : Kompletny ciąg poziomu poprawek zabezpieczeń. Ten ciąg poziomu poprawki zabezpieczeń wskazuje, że rozwiązano wszystkie problemy związane z 2017-05-01 i 2017-05-05 (oraz wszystkimi poprzednimi ciągami poziomu poprawek zabezpieczeń).
  • Obsługiwane urządzenia Google otrzymają pojedynczą aktualizację OTA z poziomem poprawki zabezpieczeń z 5 maja 2017 r.

Ograniczenia dotyczące Androida i usług Google

To jest podsumowanie środków łagodzących zapewnianych przez platformę zabezpieczeń Androida i zabezpieczenia usług, takie jak SafetyNet. Te możliwości zmniejszają prawdopodobieństwo pomyślnego wykorzystania luk w zabezpieczeniach w systemie Android.

  • Wykorzystanie wielu problemów w systemie Android jest utrudnione przez ulepszenia w nowszych wersjach platformy Android. Zachęcamy wszystkich użytkowników do aktualizacji do najnowszej wersji Androida tam, gdzie to możliwe.
  • Zespół Android Security aktywnie monitoruje nadużycia za pomocą funkcji Verify Apps i SafetyNet , które mają ostrzegać użytkowników o potencjalnie szkodliwych aplikacjach . Weryfikacja aplikacji jest domyślnie włączona na urządzeniach z usługami Google Mobile Services i jest szczególnie ważna dla użytkowników instalujących aplikacje spoza Google Play. Narzędzia do rootowania urządzeń są zabronione w Google Play, ale Weryfikacja aplikacji ostrzega użytkowników, gdy próbują zainstalować wykrytą aplikację do rootowania — bez względu na to, skąd pochodzi. Ponadto Verify Apps próbuje zidentyfikować i zablokować instalację znanych złośliwych aplikacji, które wykorzystują lukę w eskalacji uprawnień. Jeśli taka aplikacja została już zainstalowana, Verify Apps powiadomi użytkownika i podejmie próbę usunięcia wykrytej aplikacji.
  • W stosownych przypadkach aplikacje Google Hangouts i Messenger nie przekazują automatycznie multimediów do procesów takich jak Mediaserver.

Podziękowanie

Chcielibyśmy podziękować tym badaczom za ich wkład:

  • ADlab firmy Venustech: CVE-2017-0630
  • Di Shen ( @returnsme ) z KeenLab ( @keen_lab ), Tencent: CVE-2016-10287
  • Ecular Xu (徐健) firmy Trend Micro: CVE-2017-0599, CVE-2017-0635
  • En On ( @heeeeen4x ) i Bo Liu z zespołu MS509 : CVE-2017-0601
  • Ethan Yonker z Team Win Recovery Project : CVE-2017-0493
  • Gengjia Chen ( @chengjia4574 ) i pjf z IceSword Lab, Qihoo 360 Technology Co. Ltd: CVE-2016-10285, CVE-2016-10288, CVE-2016-10290, CVE-2017-0624, CVE-2017-0616, CVE -2017-0617, CVE-2016-10294, CVE-2016-10295, CVE-2016-10296
  • godzheng (郑文选@VirtualSeekers ) z Tencent PC Manager: CVE-2017-0602
  • Güliz Seray Tuncay z University of Illinois w Urbana-Champaign : CVE-2017-0593
  • Hao Chen i Guang Gong z zespołu Alpha, Qihoo 360 Technology Co. Ltd: CVE-2016-10283
  • Juhu Nie, Yang Cheng, Nan Li i Qiwu Huang firmy Xiaomi Inc: CVE-2016-10276
  • Michał Bednarski : CVE-2017-0598
  • Nathan Crandall ( @natecray ) z zespołu ds. bezpieczeństwa produktów Tesli: CVE-2017-0331, CVE-2017-0606
  • Niky1235 ( @jiych_guru ): CVE-2017-0603
  • Peng Xiao, Chengming Yang, Ning You, Chao Yang i Yang piosenka Alibaba Mobile Security Group: CVE-2016-10281, CVE-2016-10280
  • Roee Hay ( @roeehay ) z Aleph Research : CVE-2016-10277
  • Scott Bauer ( @ScottyBauer1 ): CVE-2016-10274
  • Tong Lin , Yuan-Tsung Lo i Xuxian Jiang z zespołu C0RE : CVE-2016-10291
  • Wasilij Wasiliew: CVE-2017-0589
  • VEO ( @VYSEa ) zespołu ds. reagowania na zagrożenia mobilne , Trend Micro : CVE-2017-0590, CVE-2017-0587, CVE-2017-0600
  • Xiling Gong Departamentu Platformy Bezpieczeństwa Tencent: CVE-2017-0597
  • Xingyuan Lin z 360 Marvel Team: CVE-2017-0627
  • Yong Wang (王勇) ( @ThomasKing2014 ) z Alibaba Inc: CVE-2017-0588
  • Yonggang Guo ( @guoygang ) z IceSword Lab, Qihoo 360 Technology Co. Ltd: CVE-2016-10289, CVE-2017-0465
  • Yu Pan z zespołu Vulpecker, Qihoo 360 Technology Co. Ltd: CVE-2016-10282, CVE-2017-0615
  • Yu Pan i Peide Zhang z zespołu Vulpecker, Qihoo 360 Technology Co. Ltd: CVE-2017-0618, CVE-2017-0625

2017-05-01 poziom poprawki zabezpieczeń-Szczegóły dotyczące luki w zabezpieczeniach

W poniższych sekcjach podajemy szczegółowe informacje o każdej z luk w zabezpieczeniach, które dotyczą poziomu poprawki 2017-05-01. Znajduje się tam opis problemu, uzasadnienie ważności oraz tabela z CVE, powiązanymi odniesieniami, dotkliwością, zaktualizowanymi urządzeniami Google, zaktualizowanymi wersjami AOSP (jeśli dotyczy) i datą zgłoszenia. Gdy będzie to możliwe, połączymy publiczną zmianę, która dotyczyła problemu, z identyfikatorem błędu, takim jak lista zmian AOSP. Gdy wiele zmian dotyczy pojedynczego błędu, dodatkowe odnośniki są powiązane z liczbami następującymi po identyfikatorze błędu.

Luka umożliwiająca zdalne wykonanie kodu w Mediaserver

Luka w zabezpieczeniach serwera Mediaserver umożliwiająca zdalne wykonanie kodu może umożliwić osobie atakującej użycie specjalnie spreparowanego pliku do uszkodzenia pamięci podczas przetwarzania plików multimedialnych i danych. Ten problem został oceniony jako krytyczny ze względu na możliwość zdalnego wykonania kodu w kontekście procesu Mediaserver.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0587 A-35219737 Krytyczny Wszystko 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 4 stycznia 2017 r.
CVE-2017-0588 A-34618607 Krytyczny Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 21 stycznia 2017 r.
CVE-2017-0589 A-34897036 Krytyczny Wszystko 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 1 lut 2017
CVE-2017-0590 A-35039946 Krytyczny Wszystko 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 6 lut 2017
CVE-2017-0591 A-34097672 Krytyczny Wszystko 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 Google wewnętrzne
CVE-2017-0592 A-34970788 Krytyczny Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 Google wewnętrzne

Podniesienie poziomu uprawnień w interfejsach API Framework

Luka umożliwiająca podniesienie uprawnień w interfejsach API platformy może umożliwić lokalnej złośliwej aplikacji uzyskanie dostępu do uprawnień niestandardowych. Ten problem został oceniony jako wysoki, ponieważ jest to ogólne obejście zabezpieczeń systemu operacyjnego, które izolują dane aplikacji od innych aplikacji.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0593 A-34114230 Wysoki Wszystko 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 5 stycznia 2017 r.

Podwyższenie luki uprawnień w Mediaserver

Luka umożliwiająca podniesienie uprawnień w serwerze Mediaserver może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście procesu uprzywilejowanego. Ten problem jest oceniany jako wysoki, ponieważ może służyć do uzyskiwania lokalnego dostępu do podwyższonych funkcji, które zwykle nie są dostępne dla aplikacji innych firm.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0594 A-34617444 Wysoki Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 22 stycznia 2017 r.
CVE-2017-0595 A-34705519 Wysoki Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 24 stycznia 2017 r.
CVE-2017-0596 A-34749392 Wysoki Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 24 stycznia 2017 r.

Podwyższona luka uprawnień w Audioserver

Luka umożliwiająca podniesienie uprawnień w Audioserver może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście uprzywilejowanego procesu. Ten problem jest oceniany jako wysoki, ponieważ może służyć do uzyskiwania lokalnego dostępu do podwyższonych funkcji, które zwykle nie są dostępne dla aplikacji innych firm.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0597 A-34749571 Wysoki Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 25 stycznia 2017 r.

Podatność na ujawnienie informacji w Framework API

Luka umożliwiająca ujawnienie informacji w interfejsach API Framework może umożliwić lokalnej złośliwej aplikacji ominięcie zabezpieczeń systemu operacyjnego, które izolują dane aplikacji od innych aplikacji. Ten problem został oceniony jako wysoki, ponieważ może być wykorzystany do uzyskania dostępu do danych, do których aplikacja nie ma dostępu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0598 A-34128677 [ 2 ] Wysoki Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 6 stycznia 2017 r.

Luka typu Denial of Service w Mediaserver

Luka umożliwiająca zdalną odmowę usługi w serwerze Mediaserver może umożliwić osobie atakującej użycie specjalnie spreparowanego pliku w celu zawieszenia lub ponownego uruchomienia urządzenia. Ten problem został oceniony jako Wysoki ze względu na możliwość zdalnej odmowy usługi.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0599 A-34672748 Wysoki Wszystko 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 23 stycznia 2017
CVE-2017-0600 A-35269635 Wysoki Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 10 lut 2017

Podwyższenie podatności uprawnień w Bluetooth

Luka dotycząca podniesienia uprawnień w Bluetooth może potencjalnie umożliwić lokalnej złośliwej aplikacji przyjmowanie szkodliwych plików udostępnianych przez Bluetooth bez zgody użytkownika. Ten problem został oceniony jako Umiarkowany ze względu na lokalne pomijanie wymagań dotyczących interakcji użytkownika.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0601 A-35258579 Umiarkowany Wszystko 7.0, 7.1.1, 7.1.2 9 lut 2017

Luka umożliwiająca ujawnienie informacji w szyfrowaniu opartym na plikach

Luka umożliwiająca ujawnienie informacji w Szyfrowaniu opartym na plikach może umożliwić lokalnej złośliwej osobie atakującej ominięcie zabezpieczeń systemu operacyjnego ekranu blokady. Ten problem jest oceniany jako Umiarkowany ze względu na możliwość ominięcia ekranu blokady.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0493 A-32793550 [ 2 ] [ 3 ] Umiarkowany Wszystko 7,0, 7.1.1 9 listopada 2016

Luka umożliwiająca ujawnienie informacji w Bluetooth

Luka umożliwiająca ujawnienie informacji w Bluetooth może umożliwić lokalnej złośliwej aplikacji ominięcie zabezpieczeń systemu operacyjnego, które izolują dane aplikacji od innych aplikacji. Ten problem został oceniony jako Umiarkowany ze względu na szczegóły dotyczące luki.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0602 A-34946955 Umiarkowany Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 5 grudnia 2016

Luka umożliwiająca ujawnienie informacji w OpenSSL i BoringSSL

Luka umożliwiająca ujawnienie informacji w OpenSSL i BoringSSL może umożliwić zdalnemu napastnikowi uzyskanie dostępu do poufnych informacji. Ten problem został oceniony jako Umiarkowany ze względu na szczegóły dotyczące luki.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2016-7056 A-33752052 Umiarkowany Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 19 grudnia 2016

Luka typu Denial of Service w Mediaserver

Luka typu „odmowa usługi” w serwerze Mediaserver może umożliwić osobie atakującej użycie specjalnie spreparowanego pliku w celu zawieszenia lub ponownego uruchomienia urządzenia. Ten problem jest oceniany jako Umiarkowany, ponieważ wymaga nietypowej konfiguracji urządzenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0603 A-35763994 Umiarkowany Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 23 lut 2017

Luka typu Denial of Service w Mediaserver

Luka umożliwiająca zdalną odmowę usługi w serwerze Mediaserver może umożliwić osobie atakującej użycie specjalnie spreparowanego pliku w celu zawieszenia lub ponownego uruchomienia urządzenia. Ten problem został oceniony jako Niski ze względu na szczegóły dotyczące luki.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0635 A-35467107 Niski Wszystko 7.0, 7.1.1, 7.1.2 16 lut 2017

2017-05-05 poziom poprawki zabezpieczeń-Szczegóły dotyczące luki w zabezpieczeniach

W poniższych sekcjach podajemy szczegółowe informacje o każdej z luk w zabezpieczeniach, które dotyczą poziomu poprawek 2017-05-05. Znajduje się tam opis problemu, uzasadnienie ważności oraz tabela z CVE, powiązanymi odniesieniami, dotkliwością, zaktualizowanymi urządzeniami Google, zaktualizowanymi wersjami AOSP (jeśli dotyczy) i datą zgłoszenia. Gdy będzie to możliwe, połączymy publiczną zmianę, która dotyczyła problemu, z identyfikatorem błędu, takim jak lista zmian AOSP. Gdy wiele zmian dotyczy pojedynczego błędu, dodatkowe odnośniki są powiązane z liczbami następującymi po identyfikatorze błędu.

Luka umożliwiająca zdalne wykonanie kodu w GIFLIB

Luka w zabezpieczeniach programu GIFLIB umożliwiająca zdalne wykonanie kodu może umożliwić osobie atakującej użycie specjalnie spreparowanego pliku do uszkodzenia pamięci podczas przetwarzania plików multimedialnych i danych. Ten problem został oceniony jako krytyczny ze względu na możliwość zdalnego wykonania kodu w kontekście procesu Mediaserver.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2015-7555 A-34697653 Krytyczny Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2 13 kwietnia 2016

Podwyższona luka uprawnień w sterowniku ekranu dotykowego MediaTek

Luka umożliwiająca podniesienie uprawnień w sterowniku ekranu dotykowego MediaTek może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako krytyczny ze względu na możliwość lokalnego trwałego włamania do urządzenia, co może wymagać przeflashowania systemu operacyjnego w celu naprawy urządzenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-10274 A-30202412*
M-ALPS02897901
Krytyczny Nic** 16 lipca 2016

* Poprawka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

** Ta luka nie dotyczy obsługiwanych urządzeń Google z systemem Android 7.1.1 lub nowszym, na których zainstalowano wszystkie dostępne aktualizacje.

Podwyższona luka uprawnień w bootloaderze Qualcomm

Luka umożliwiająca podniesienie uprawnień w programie rozruchowym Qualcomm może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako krytyczny ze względu na możliwość lokalnego trwałego włamania do urządzenia, co może wymagać przeflashowania systemu operacyjnego w celu naprawy urządzenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-10275 A-34514954
QC-CR#1009111
Krytyczny Nexus 5X, Nexus 6, Pixel, Pixel XL, Android One 13 września 2016 r.
CVE-2016-10276 A-32952839
QC-CR#1094105
Krytyczny Nexus 5X, Nexus 6P, Pixel, Pixel XL 16 listopada 2016

Podwyższenie podatności uprawnień w podsystemie dźwiękowym jądra

Luka umożliwiająca podniesienie uprawnień w podsystemie dźwiękowym jądra może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako krytyczny ze względu na możliwość lokalnego trwałego włamania do urządzenia, co może wymagać przeflashowania systemu operacyjnego w celu naprawy urządzenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-9794 A-34068036
Jądro nadrzędne
Krytyczny Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Android One, Nexus Player 3 grudnia 2016

Podwyższona luka uprawnień w bootloaderze Motorola

Luka umożliwiająca podniesienie uprawnień w programie rozruchowym Motoroli może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście programu rozruchowego. Ten problem jest oceniany jako krytyczny ze względu na możliwość lokalnego trwałego włamania do urządzenia, co może wymagać przeflashowania systemu operacyjnego w celu naprawy urządzenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-10277 A-33840490*
Krytyczny Nexus 6 21 grudnia 2016

* Poprawka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

Podatność na podniesienie uprawnień w sterowniku wideo NVIDIA

Luka umożliwiająca podniesienie uprawnień w sterowniku wideo NVIDIA może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako krytyczny ze względu na możliwość lokalnego trwałego włamania do urządzenia, co może wymagać przeflashowania systemu operacyjnego w celu naprawy urządzenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2017-0331 A-34113000*
N-CVE-2017-0331
Krytyczny Nexus 9 4 stycznia 2017 r.

* Poprawka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

Podwyższona luka uprawnień w sterowniku zasilania Qualcomm

Luka umożliwiająca podniesienie uprawnień w sterowniku zasilania Qualcomm jądra może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako krytyczny ze względu na możliwość lokalnego trwałego włamania do urządzenia, co może wymagać przeflashowania systemu operacyjnego w celu naprawy urządzenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2017-0604 A-35392981
QC-CR#826589
Krytyczny Nic* 15 lut 2017

* Ta luka nie dotyczy obsługiwanych urządzeń Google z systemem Android 7.1.1 lub nowszym, na których zainstalowano wszystkie dostępne aktualizacje.

Luki w komponentach Qualcomm

Te luki w zabezpieczeniach dotyczą składników Qualcomm i zostały szczegółowo opisane w biuletynach zabezpieczeń Qualcomm AMSS z sierpnia, września, października i grudnia 2016 r.

CVE Bibliografia Surowość* Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-10240 A-32578446**
QC-CR#955710
Krytyczny Nexus 6P Qualcomm wewnętrzny
CVE-2016-10241 A-35436149**
QC-CR#1068577
Krytyczny Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL Qualcomm wewnętrzny
CVE-2016-10278 A-31624008**
QC-CR#1043004
Wysoki Piksel, Piksel XL Qualcomm wewnętrzny
CVE-2016-10279 A-31624421**
QC-CR#1031821
Wysoki Piksel, Piksel XL Qualcomm wewnętrzny

* Ocena ważności tych luk została określona przez dostawcę.

* Poprawka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

Luka umożliwiająca zdalne wykonanie kodu w libxml2

Luka w zabezpieczeniach biblioteki libxml2 umożliwiająca zdalne wykonanie kodu może umożliwić osobie atakującej użycie specjalnie spreparowanego pliku do wykonania dowolnego kodu w kontekście nieuprzywilejowanego procesu. Ten problem został oceniony jako Wysoki ze względu na możliwość zdalnego wykonania kodu w aplikacji korzystającej z tej biblioteki.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2016-5131 A-32956747* Wysoki Nic** 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 23 lipca 2016

* Poprawka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

** Ta luka nie dotyczy obsługiwanych urządzeń Google z systemem Android 7.1.1 lub nowszym, na których zainstalowano wszystkie dostępne aktualizacje.

Podniesienie poziomu uprawnień w sterowniku termicznym MediaTek

Luka umożliwiająca podniesienie uprawnień w sterowniku termicznym MediaTek może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga naruszenia uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-10280 A-28175767*
M-ALPS02696445
Wysoki Nic** 11 kwi 2016
CVE-2016-10281 A-28175647*
M-ALPS02696475
Wysoki Nic** 11 kwi 2016
CVE-2016-10282 A-33939045*
M-ALPS03149189
Wysoki Nic** 27 grudnia 2016

* Poprawka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

** Ta luka nie dotyczy obsługiwanych urządzeń Google z systemem Android 7.1.1 lub nowszym, na których zainstalowano wszystkie dostępne aktualizacje.

Podwyższona luka uprawnień w sterowniku Qualcomm Wi-Fi

Luka umożliwiająca podniesienie uprawnień w sterowniku Qualcomm Wi-Fi może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga naruszenia uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-10283 A-32094986
QC-CR#2002052
Wysoki Nexus 5X, Pixel, Pixel XL, Android One 11 października 2016 r.

Podwyższona luka uprawnień w sterowniku wideo Qualcomm

Luka umożliwiająca podniesienie uprawnień w sterowniku wideo Qualcomm może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga naruszenia uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-10284 A-32402303*
QC-CR#2000664
Wysoki Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 24 października 2016 r.
CVE-2016-10285 A-33752702
QC-CR#1104899
Wysoki Piksel, Piksel XL 19 grudnia 2016
CVE-2016-10286 A-35400904
QC-CR#1090237
Wysoki Piksel, Piksel XL 15 lut 2017

* Poprawka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

Podwyższona luka uprawnień w podsystemie wydajności jądra

Luka umożliwiająca podniesienie uprawnień w podsystemie wydajności jądra może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga naruszenia uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2015-9004 A-34515362
Jądro nadrzędne
Wysoki Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Android One, Nexus Player 23 listopada 2016

Podwyższona luka uprawnień w sterowniku dźwięku Qualcomm

Luka umożliwiająca podniesienie uprawnień w sterowniku dźwięku Qualcomm może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga naruszenia uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-10287 A-33784446
QC-CR#1112751
Wysoki Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One 20 grudnia 2016
CVE-2017-0606 A-34088848
QC-CR#1116015
Wysoki Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One 3 stycznia 2017 r.
CVE-2016-5860 A-34623424
QC-CR#1100682
Wysoki Piksel, Piksel XL 22 stycznia 2017 r.
CVE-2016-5867 A-35400602
QC-CR#1095947
Wysoki Nic* 15 lut 2017
CVE-2017-0607 A-35400551
QC-CR#1085928
Wysoki Piksel, Piksel XL 15 lut 2017
CVE-2017-0608 A-35400458
QC-CR#1098363
Wysoki Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 15 lut 2017
CVE-2017-0609 A-35399801
QC-CR#1090482
Wysoki Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One 15 lut 2017
CVE-2016-5859 A-35399758
QC-CR#1096672
Wysoki Nic* 15 lut 2017
CVE-2017-0610 A-35399404
QC-CR#1094852
Wysoki Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 15 lut 2017
CVE-2017-0611 A-35393841
QC-CR#1084210
Wysoki Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 15 lut 2017
CVE-2016-5853 A-35392629
QC-CR#1102987
Wysoki Nic* 15 lut 2017

* Ta luka nie dotyczy obsługiwanych urządzeń Google z systemem Android 7.1.1 lub nowszym, na których zainstalowano wszystkie dostępne aktualizacje.

Podwyższona luka uprawnień w sterowniku Qualcomm LED

Luka umożliwiająca podniesienie uprawnień w sterowniku Qualcomm LED może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga naruszenia uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-10288 A-33863909
QC-CR#1109763
Wysoki Piksel, Piksel XL 23 grudnia 2016

Podniesienie poziomu uprawnień w sterowniku kryptograficznym Qualcomm

Luka umożliwiająca podniesienie uprawnień w sterowniku kryptograficznym Qualcomm może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga naruszenia uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-10289 A-33899710
QC-CR#1116295
Wysoki Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 24 grudnia 2016

Podniesienie poziomu uprawnień w sterowniku pamięci współdzielonej Qualcomm

Luka umożliwiająca podniesienie uprawnień w sterowniku pamięci współdzielonej Qualcomm może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga naruszenia uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-10290 A-33898330
QC-CR#1109782
Wysoki Nexus 5X, Nexus 6P, Pixel, Pixel XL 24 grudnia 2016

Podwyższona luka uprawnień w sterowniku Qualcomm Slimbus

Luka umożliwiająca podniesienie uprawnień w sterowniku Qualcomm Slimbus może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga naruszenia uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-10291 A-34030871
QC-CR#986837
Wysoki Nexus 5X, Nexus 6, Nexus 6P, Android One 31 grudnia 2016

Podniesienie poziomu uprawnień w sterowniku Qualcomm ADSPRPC

Luka umożliwiająca podniesienie uprawnień w sterowniku Qualcomm ADSPRPC może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga naruszenia uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2017-0465 A-34112914
QC-CR#1110747
Wysoki Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One 5 stycznia 2017 r.

Podniesienie poziomu uprawnień w sterowniku Qualcomm Secure Execution Environment Communicator

Luka umożliwiająca podniesienie uprawnień w sterowniku Qualcomm Secure Execution Environment Communicator może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga naruszenia uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2017-0612 A-34389303
QC-CR#1061845
Wysoki Piksel, Piksel XL 10 stycznia 2017 r.
CVE-2017-0613 A-35400457
QC-CR#1086140
Wysoki Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 15 lut 2017
CVE-2017-0614 A-35399405
QC-CR#1080290
Wysoki Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 15 lut 2017

Podwyższona luka uprawnień w sterowniku zasilania MediaTek

Luka umożliwiająca podniesienie uprawnień w sterowniku zasilania MediaTek może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga naruszenia uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2017-0615 A-34259126*
M-ALPS03150278
Wysoki Nic** 12 stycznia 2017 r.

* Poprawka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

** Ta luka nie dotyczy obsługiwanych urządzeń Google z systemem Android 7.1.1 lub nowszym, na których zainstalowano wszystkie dostępne aktualizacje.

Podwyższona luka uprawnień w sterowniku przerwań zarządzania systemem MediaTek

Luka umożliwiająca podniesienie uprawnień w sterowniku przerwań zarządzania systemem MediaTek może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga naruszenia uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2017-0616 A-34470286*
M-ALPS03149160
Wysoki Nic** 19 stycznia 2017

* Poprawka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

** Ta luka nie dotyczy obsługiwanych urządzeń Google z systemem Android 7.1.1 lub nowszym, na których zainstalowano wszystkie dostępne aktualizacje.

Podniesienie poziomu uprawnień w sterowniku wideo MediaTek

Luka umożliwiająca podniesienie uprawnień w sterowniku wideo MediaTek może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga naruszenia uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2017-0617 A-34471002*
M-ALPS03149173
Wysoki Nic** 19 stycznia 2017

* Poprawka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

** Ta luka nie dotyczy obsługiwanych urządzeń Google z systemem Android 7.1.1 lub nowszym, na których zainstalowano wszystkie dostępne aktualizacje.

Podniesienie poziomu uprawnień w sterowniku kolejki poleceń MediaTek

Luka umożliwiająca podniesienie uprawnień w sterowniku kolejki poleceń MediaTek może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga naruszenia uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2017-0618 A-35100728*
M-ALPS03161536
Wysoki Nic** 7 lut 2017

* Poprawka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

** Ta luka nie dotyczy obsługiwanych urządzeń Google z systemem Android 7.1.1 lub nowszym, na których zainstalowano wszystkie dostępne aktualizacje.

Podwyższona luka uprawnień w sterowniku kontrolera pinów Qualcomm

Luka umożliwiająca podniesienie uprawnień w sterowniku kontrolera pinów Qualcomm może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga naruszenia uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2017-0619 A-35401152
QC-CR#826566
Wysoki Nexus 6, Android One 15 lut 2017

Podniesienie poziomu uprawnień w sterowniku Qualcomm Secure Channel Manager

Luka umożliwiająca podniesienie uprawnień w sterowniku Qualcomm Secure Channel Manager może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga naruszenia uprzywilejowanego procesu.

CVE Bibliografia Surowość Updated Google devices Date reported
CVE-2017-0620 A-35401052
QC-CR#1081711
High Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Feb 15, 2017

Elevation of privilege vulnerability in Qualcomm sound codec driver

An elevation of privilege vulnerability in the Qualcomm sound codec driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-5862 A-35399803
QC-CR#1099607
High Pixel, Pixel XL Feb 15, 2017

Elevation of privilege vulnerability in kernel voltage regulator driver

An elevation of privilege vulnerability in the kernel voltage regulator driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2014-9940 A-35399757
Upstream kernel
High Nexus 6, Nexus 9, Pixel C, Android One, Nexus Player Feb 15, 2017

Elevation of privilege vulnerability in Qualcomm camera driver

An elevation of privilege vulnerability in the Qualcomm camera driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0621 A-35399703
QC-CR#831322
High Android One Feb 15, 2017

Elevation of privilege vulnerability in Qualcomm networking driver

An elevation of privilege vulnerability in the Qualcomm networking driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-5868 A-35392791
QC-CR#1104431
High Nexus 5X, Pixel, Pixel XL Feb 15, 2017

Elevation of privilege vulnerability in kernel networking subsystem

An elevation of privilege vulnerability in the kernel networking subsystem could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-7184 A-36565222
Upstream kernel [2]
High Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Android One Mar 23, 2017

Elevation of privilege vulnerability in Goodix touchscreen driver

An elevation of privilege vulnerability in the Goodix touchscreen driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0622 A-32749036
QC-CR#1098602
High Android One Google internal

Elevation of privilege vulnerability in HTC bootloader

An elevation of privilege vulnerability in the HTC bootloader could enable a local malicious application to execute arbitrary code within the context of the bootloader. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0623 A-32512358*
High Pixel, Pixel XL Google Internal

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm Wi-Fi driver

An information disclosure vulnerability in the Qualcomm Wi-Fi driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2017-0624 A-34327795*
QC-CR#2005832
High Nexus 5X, Pixel, Pixel XL Jan 16, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in MediaTek command queue driver

An information disclosure vulnerability in the MediaTek command queue driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2017-0625 A-35142799*
M-ALPS03161531
High None** Feb 8, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.1.1 or later that have installed all available updates are not affected by this vulnerability.

Information disclosure vulnerability in Qualcomm crypto engine driver

An information disclosure vulnerability in the Qualcomm crypto engine driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2017-0626 A-35393124
QC-CR#1088050
High Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Feb 15, 2017

Denial of service vulnerability in Qualcomm Wi-Fi driver

A denial of service vulnerability in the Qualcomm Wi-Fi driver could enable a proximate attacker to cause a denial of service in the Wi-Fi subsystem. This issue is rated as High due to the possibility of remote denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2016-10292 A-34514463*
QC-CR#1065466
High Nexus 5X, Pixel, Pixel XL Dec 16, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in kernel UVC driver

An information disclosure vulnerability in the kernel UVC driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0627 A-33300353*
Moderate Nexus 5X, Nexus 6P, Nexus 9, Pixel C, Nexus Player Dec 2, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm video driver

An information disclosure vulnerability in the Qualcomm video driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-10293 A-33352393
QC-CR#1101943
Moderate Nexus 5X, Nexus 6P, Android One Dec 4, 2016

Information disclosure vulnerability in Qualcomm power driver (device specific)

An information disclosure vulnerability in the Qualcomm power driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-10294 A-33621829
QC-CR#1105481
Moderate Nexus 5X, Nexus 6P, Pixel, Pixel XL Dec 14, 2016

Information disclosure vulnerability in Qualcomm LED driver

An information disclosure vulnerability in the Qualcomm LED driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-10295 A-33781694
QC-CR#1109326
Moderate Pixel, Pixel XL Dec 20, 2016

Information disclosure vulnerability in Qualcomm shared memory driver

An information disclosure vulnerability in the Qualcomm shared memory driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-10296 A-33845464
QC-CR#1109782
Moderate Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One Dec 22, 2016

Information disclosure vulnerability in Qualcomm camera driver

An information disclosure vulnerability in the Qualcomm camera driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0628 A-34230377
QC-CR#1086833
Moderate Nexus 5X, Nexus 6, Pixel, Pixel XL Jan 10, 2017
CVE-2017-0629 A-35214296
QC-CR#1086833
Moderate Nexus 5X, Nexus 6, Pixel, Pixel XL Feb 8, 2017

Information disclosure vulnerability in kernel trace subsystem

An information disclosure vulnerability in the kernel trace subsystem could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0630 A-34277115*
Moderate Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Android One, Nexus Player Jan 11, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm sound codec driver

An information disclosure vulnerability in the Qualcomm sound codec driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-5858 A-35400153
QC-CR#1096799 [2]
Moderate Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Feb 15, 2017

Information disclosure vulnerability in Qualcomm camera driver

An information disclosure vulnerability in the Qualcomm camera driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0631 A-35399756
QC-CR#1093232
Moderate Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One Feb 15, 2017

Information disclosure vulnerability in Qualcomm sound driver

An information disclosure vulnerability in the Qualcomm sound driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-5347 A-35394329
QC-CR#1100878
Moderate Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Feb 15, 2017

Information disclosure vulnerability in Qualcomm SPCom driver

An information disclosure vulnerability in the Qualcomm SPCom driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-5854 A-35392792
QC-CR#1092683
Moderate None* Feb 15, 2017
CVE-2016-5855 A-35393081
QC-CR#1094143
Moderate None* Feb 15, 2017

* Supported Google devices on Android 7.1.1 or later that have installed all available updates are not affected by this vulnerability.

Information disclosure vulnerability in Qualcomm sound codec driver

An information disclosure vulnerability in the Qualcomm sound codec driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0632 A-35392586
QC-CR#832915
Moderate Android One Feb 15, 2017

Information disclosure vulnerability in Broadcom Wi-Fi driver

An information disclosure vulnerability in the Broadcom Wi-Fi driver could enable a local malicious component to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0633 A-36000515*
B-RB#117131
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Feb 23, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Synaptics touchscreen driver

An information disclosure vulnerability in the Synaptics touchscreen driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0634 A-32511682*
Moderate Pixel, Pixel XL Google internal

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Vulnerabilities in Qualcomm components

These vulnerabilities affecting Qualcomm components were released as part of Qualcomm AMSS security bulletins between 2014–2016. They are included in this Android security bulletin to associate their fixes with an Android security patch level.

CVE References Severity* Updated Google devices Date reported
CVE-2014-9923 A-35434045** Critical None*** Qualcomm internal
CVE-2014-9924 A-35434631** Critical None*** Qualcomm internal
CVE-2014-9925 A-35444657** Critical None*** Qualcomm internal
CVE-2014-9926 A-35433784** Critical None*** Qualcomm internal
CVE-2014-9927 A-35433785** Critical None*** Qualcomm internal
CVE-2014-9928 A-35438623** Critical None*** Qualcomm internal
CVE-2014-9929 A-35443954**
QC-CR#644783
Critical None*** Qualcomm internal
CVE-2014-9930 A-35432946** Critical None*** Qualcomm internal
CVE-2015-9005 A-36393500** Critical None*** Qualcomm internal
CVE-2015-9006 A-36393450** Critical None*** Qualcomm internal
CVE-2015-9007 A-36393700** Critical None*** Qualcomm internal
CVE-2016-10297 A-36393451** Critical None*** Qualcomm internal
CVE-2014-9941 A-36385125** High None*** Qualcomm internal
CVE-2014-9942 A-36385319** High None*** Qualcomm internal
CVE-2014-9943 A-36385219** High None*** Qualcomm internal
CVE-2014-9944 A-36384534** High None*** Qualcomm internal
CVE-2014-9945 A-36386912** High None*** Qualcomm internal
CVE-2014-9946 A-36385281** High None*** Qualcomm internal
CVE-2014-9947 A-36392400** High None*** Qualcomm internal
CVE-2014-9948 A-36385126** High None*** Qualcomm internal
CVE-2014-9949 A-36390608** High None*** Qualcomm internal
CVE-2014-9950 A-36385321** High None*** Qualcomm internal
CVE-2014-9951 A-36389161** High None*** Qualcomm internal
CVE-2014-9952 A-36387019** High None*** Qualcomm internal

* The severity rating for these vulnerabilities was determined by the vendor.

** The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

*** Supported Google devices on Android 7.1.1 or later that have installed all available updates are not affected by this vulnerability.

Common Questions and Answers

This section answers common questions that may occur after reading this bulletin.

1. How do I determine if my device is updated to address these issues?

To learn how to check a device's security patch level, read the instructions on the Pixel and Nexus update schedule .

  • Security patch levels of 2017-05-01 or later address all issues associated with the 2017-05-01 security patch level.
  • Security patch levels of 2017-05-05 or later address all issues associated with the 2017-05-05 security patch level and all previous patch levels.

Device manufacturers that include these updates should set the patch string level to:

  • [ro.build.version.security_patch]:[2017-05-01]
  • [ro.build.version.security_patch]:[2017-05-05]

2. Why does this bulletin have two security patch levels?

This bulletin has two security patch levels so that Android partners have the flexibility to fix a subset of vulnerabilities that are similar across all Android devices more quickly. Android partners are encouraged to fix all issues in this bulletin and use the latest security patch level.

  • Devices that use the May 01, 2017 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins.
  • Devices that use the security patch level of May 05, 2017 or newer must include all applicable patches in this (and previous) security bulletins.

Partners are encouraged to bundle the fixes for all issues they are addressing in a single update.

3. How do I determine which Google devices are affected by each issue?

In the 2017-05-01 and 2017-05-05 security vulnerability details sections, each table has an Updated Google devices column that covers the range of affected Google devices updated for each issue. This column has a few options:

  • All Google devices : If an issue affects All and Pixel devices, the table will have "All" in the Updated Google devices column. "All" encapsulates the following supported devices : Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel, and Pixel XL.
  • Some Google devices : If an issue doesn't affect all Google devices, the affected Google devices are listed in the Updated Google devices column.
  • No Google devices : If no Google devices running Android 7.0 are affected by the issue, the table will have "None" in the Updated Google devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefix Reference
A- Android bug ID
QC- Qualcomm reference number
M- MediaTek reference number
N- NVIDIA reference number
B- Broadcom reference number

Revisions

  • May 01, 2017: Bulletin published.
  • May 02, 2017: Bulletin revised to include AOSP links.
  • August 10, 2017: Bulletin revised to include additional AOSP link for CVE-2017-0493.
  • August 17, 2017: Bulletin revised to update reference numbers.
  • October 03, 2017: Bulletin revised to remove CVE-2017-0605.