نشرة أمان Android - أبريل 2019

تنظيم صفحاتك في مجموعات يمكنك حفظ المحتوى وتصنيفه حسب إعداداتك المفضّلة.

تم النشر في ١ أبريل ٢٠١٩ | تم التحديث في 3 أبريل 2019

تحتوي نشرة أمان Android على تفاصيل الثغرات الأمنية التي تؤثر على أجهزة Android. مستويات تصحيح الأمان 2019-04-05 أو ما بعده تعالج كل هذه المشكلات. لمعرفة كيفية التحقق من مستوى تصحيح الأمان لجهاز ، راجع التحقق من إصدار Android وتحديثه .

يتم إخطار شركاء Android بجميع المشكلات قبل شهر على الأقل من النشر. تم إصدار تصحيحات التعليمات البرمجية المصدر لهذه المشكلات إلى مستودع Android Open Source Project (AOSP) وربطها من هذه النشرة. تتضمن هذه النشرة أيضًا روابط إلى تصحيحات خارج AOSP.

إن أخطر هذه المشكلات هو الثغرة الأمنية الحرجة في إطار عمل الوسائط التي يمكن أن تمكن مهاجمًا عن بُعد باستخدام ملف مُعد خصيصًا لتنفيذ تعليمات برمجية عشوائية في سياق عملية ذات امتيازات. يعتمد تقييم الخطورة على التأثير الذي قد يحدثه استغلال الثغرة الأمنية على الجهاز المتأثر ، بافتراض إيقاف تشغيل عمليات تخفيف النظام الأساسي والخدمة لأغراض التطوير أو إذا تم تجاوزها بنجاح.

لم يكن لدينا أي تقارير عن استغلال أو إساءة استخدام العملاء النشط لهذه المشكلات التي تم الإبلاغ عنها حديثًا. راجع قسم تخفيف Android و Google Play Protect للحصول على تفاصيل حول حماية نظام أمان Android و Google Play Protect ، والتي تعمل على تحسين أمان نظام Android الأساسي.

ملاحظة: تتوفر معلومات حول آخر تحديث عبر الأثير (OTA) وصور البرامج الثابتة لأجهزة Google في نشرة تحديث Pixel لشهر أبريل 2019 .

عمليات التخفيف من خدمة Android و Google

هذا ملخص لعمليات التخفيف التي يوفرها نظام أمان Android الأساسي وخدمات حماية مثل Google Play Protect . تقلل هذه الإمكانات من احتمالية نجاح استغلال الثغرات الأمنية على Android.

  • أصبح استغلال العديد من المشكلات على Android أكثر صعوبة من خلال التحسينات في الإصدارات الأحدث من نظام Android الأساسي. نشجع جميع المستخدمين على التحديث إلى أحدث إصدار من Android حيثما أمكن ذلك.
  • يقوم فريق أمان Android بمراقبة إساءة الاستخدام بنشاط من خلال Google Play Protect ويحذر المستخدمين من التطبيقات التي يُحتمل أن تكون ضارة . يتم تمكين Google Play Protect افتراضيًا على الأجهزة المزودة بخدمات Google Mobile ، وهو مهم بشكل خاص للمستخدمين الذين يقومون بتثبيت التطبيقات من خارج Google Play.

2019-04-01 تفاصيل الثغرة الأمنية في مستوى تصحيح الأمان

في الأقسام أدناه ، نقدم تفاصيل عن كل ثغرة أمنية تنطبق على مستوى التصحيح 2019-04-01. يتم تجميع الثغرات الأمنية تحت المكون الذي تؤثر عليه. يوجد وصف للمشكلة وجدول مع CVE ، والمراجع المرتبطة بها ، ونوع الثغرة الأمنية ، والخطورة ، وإصدارات AOSP المحدثة (حيثما ينطبق ذلك). عند توفرها ، نقوم بربط التغيير العام الذي عالج المشكلة بمعرف الخطأ ، مثل قائمة تغيير AOSP. عندما تتعلق تغييرات متعددة بخلل واحد ، يتم ربط مراجع إضافية بأرقام تتبع معرّف الخطأ.

نطاق

قد تؤدي الثغرة الأمنية في هذا القسم إلى تمكين مهاجم محلي من الحصول على أذونات إضافية لتجاوز تفاعل المستخدم.

CVE مراجع يكتب خطورة إصدارات AOSP المحدثة
CVE-2019-2026 A-120866126 * EoP عالٍ 8.0

إطار عمل الوسائط

يمكن أن تمكن الثغرة الأمنية الأكثر خطورة في هذا القسم مهاجمًا عن بُعد يستخدم ملفًا تم إنشاؤه خصيصًا لتنفيذ تعليمات برمجية عشوائية في سياق عملية ذات امتيازات.

CVE مراجع يكتب خطورة إصدارات AOSP المحدثة
CVE-2019-2027 A-119120561 RCE حرج 7.0 ، 7.1.1 ، 7.1.2 ، 8.0 ، 8.1 ، 9
CVE-2019-2028 أ -120644655 RCE حرج 7.0 ، 7.1.1 ، 7.1.2 ، 8.0 ، 8.1 ، 9

نظام

قد تمكن أخطر ثغرة في هذا القسم تطبيقًا ضارًا محليًا من تنفيذ تعليمات برمجية عشوائية في سياق عملية ذات امتيازات.

CVE مراجع يكتب خطورة إصدارات AOSP المحدثة
CVE-2019-2030 أ 119496789 EoP عالٍ 9
CVE-2019-2031 أ -120502559 EoP عالٍ 7.0 ، 7.1.1 ، 7.1.2 ، 8.0 ، 8.1 ، 9
CVE-2019-2033 A-121327565 [ 2 ] EoP عالٍ 9
CVE-2019-2034 أ -122035770 EoP عالٍ 7.0 ، 7.1.1 ، 7.1.2 ، 8.0 ، 8.1 ، 9
CVE-2019-2035 أ -122320256 EoP عالٍ 7.0 ، 7.1.1 ، 7.1.2 ، 8.0 ، 8.1 ، 9
CVE-2019-2038 A-121259048 بطاقة تعريف عالٍ 7.0 ، 7.1.1 ، 7.1.2 ، 8.0 ، 8.1 ، 9
CVE-2019-2039 أ -121260197 بطاقة تعريف عالٍ 7.0 ، 7.1.1 ، 7.1.2 ، 8.0 ، 8.1 ، 9
CVE-2019-2040 أ -122316913 بطاقة تعريف عالٍ 9

2019-04-05 تفاصيل الثغرة الأمنية في مستوى تصحيح الأمان

في الأقسام أدناه ، نقدم تفاصيل عن كل ثغرة أمنية تنطبق على مستوى التصحيح 2019-04-05. يتم تجميع الثغرات الأمنية ضمن المكون الذي تؤثر عليه وتتضمن تفاصيل مثل CVE والمراجع المرتبطة ونوع الثغرة الأمنية والخطورة والمكون (عند الاقتضاء) وإصدارات AOSP المحدثة (عند الاقتضاء). عند توفرها ، نقوم بربط التغيير العام الذي عالج المشكلة بمعرف الخطأ ، مثل قائمة تغيير AOSP. عندما تتعلق تغييرات متعددة بخلل واحد ، يتم ربط مراجع إضافية بأرقام تتبع معرّف الخطأ.

نظام

يمكن أن تمكن الثغرة الأمنية الأكثر خطورة في هذا القسم مهاجمًا عن بُعد يستخدم ملفًا تم إنشاؤه خصيصًا لتنفيذ تعليمات برمجية عشوائية في سياق عملية ذات امتيازات.

CVE مراجع يكتب خطورة إصدارات AOSP المحدثة
CVE-2019-2029 أ -120612744 RCE حرج 7.0 ، 7.1.1 ، 7.1.2 ، 8.0 ، 8.1 ، 9
CVE-2019-2032 أ -121145627 EoP عالٍ 8.0 ، 8.1 ، 9
CVE-2019-2041 A-122034690 [ 2 ] [ 3 ] EoP عالٍ 8.1 ، 9
CVE-2019-2037 A-119870451 بطاقة تعريف عالٍ 7.0 ، 7.1.1 ، 7.1.2 ، 8.0 ، 8.1 ، 9

مكونات كوالكوم

تؤثر هذه الثغرات الأمنية على مكونات Qualcomm ويتم وصفها بمزيد من التفصيل في نشرة أمان Qualcomm المناسبة أو تنبيه الأمان. يمكن العثور على غالبية هذه الإصلاحات في نشرات أمان Qualcomm التي تم إصدارها في 2018. يتم توفير تقييم خطورة هذه المشكلات مباشرةً من قبل Qualcomm.

CVE مراجع يكتب خطورة مكون
CVE-2018-11940 A-79377832
QC-CR # 2254946
غير متاح حرج مضيف WLAN
CVE-2017-17772 A-72957385
QC-CR # 2153003 [ 2 ]
غير متاح عالٍ مضيف WLAN
CVE-2018-11294 أ -109741680
QC-CR # 2197481
غير متاح عالٍ مضيف WLAN
CVE-2018-5855 A-77527719
QC-CR # 2193421
غير متاح عالٍ مضيف WLAN
CVE-2018-11299 أ -109741946
QC-CR # 2186953
غير متاح عالٍ مضيف WLAN
CVE-2018-11826 أ 111127853
QC-CR # 2205957
غير متاح عالٍ مضيف WLAN
CVE-2018-11827 أ -111128575
QC-CR # 2206569
غير متاح عالٍ مضيف WLAN
CVE-2018-11840 أ -111126050
QC-CR # 2215443
غير متاح عالٍ مضيف WLAN
CVE-2018-11851 أ 111125792
QC-CR # 2221902
غير متاح عالٍ مضيف WLAN
CVE-2018-11860 أ 111128301
QC-CR # 2225113
غير متاح عالٍ مضيف WLAN
CVE-2018-11868 أ -111128420
QC-CR # 2227248
غير متاح عالٍ مضيف WLAN
CVE-2018-11869 أ -111128838
QC-CR # 2227263
غير متاح عالٍ مضيف WLAN
CVE-2018-11878 أ -111128797
QC-CR # 2228608
غير متاح عالٍ مضيف WLAN
CVE-2018-11889 أ -111128421
QC-CR # 2230998
غير متاح عالٍ مضيف WLAN
CVE-2018-11891 أ -111128578
QC-CR # 2231767
غير متاح عالٍ مضيف WLAN
CVE-2018-11894 أ 111127989
QC-CR # 2232358
غير متاح عالٍ مضيف WLAN
CVE-2018-11895 أ 111128877
QC-CR # 2232542
غير متاح عالٍ مضيف WLAN
CVE-2018-11897 A-111128841
QC-CR # 2233033
غير متاح عالٍ مضيف WLAN
CVE-2018-11902 أ 111126532
QC-CR # 2225604
غير متاح عالٍ مضيف WLAN
CVE-2018-11904 أ 111125111
QC-CR # 2215446
غير متاح عالٍ مضيف WLAN
CVE-2018-11905 أ -112277221
QC-CR # 2146878
غير متاح عالٍ مضيف WLAN
CVE-2018-11923 أ -112276863
QC-CR # 2224443
غير متاح عالٍ مضيف WLAN
CVE-2018-11924 أ -112278150
QC-CR # 2224451
غير متاح عالٍ مضيف WLAN
CVE-2018-11925 A-112277910
QC-CR # 2226375 [ 2 ]
غير متاح عالٍ مضيف WLAN
CVE-2018-11927 أ -112277186
QC-CR # 2227076
غير متاح عالٍ مضيف WLAN
CVE-2018-11930 أ -112278861
QC-CR # 2231770
غير متاح عالٍ مضيف WLAN
CVE-2018-11937 أ -112277891
QC-CR # 2245944
غير متاح عالٍ مضيف WLAN
CVE-2018-11949 أ -112278405
QC-CR # 2249815
غير متاح عالٍ مضيف WLAN
CVE-2018-11953 أ -112277852
QC-CR # 2235576
غير متاح عالٍ مضيف WLAN
CVE-2018-13920 A-120487136 *
QC-CR # 2293841
غير متاح عالٍ نواة

مكونات كوالكوم المغلقة المصدر

تؤثر هذه الثغرات الأمنية على مكونات Qualcomm ويتم وصفها بمزيد من التفصيل في نشرة أمان Qualcomm المناسبة أو تنبيه الأمان. يتم توفير تقييم خطورة هذه المشكلات مباشرة من قبل شركة Qualcomm.

CVE مراجع يكتب خطورة مكون
CVE-2018-11271 A-120487384 * غير متاح حرج مكون مغلق المصدر
CVE-2018-11976 A-117119000 * غير متاح حرج مكون مغلق المصدر
CVE-2018-12004 A-117118976 * غير متاح حرج مكون مغلق المصدر
CVE-2018-13886 A-117118295 * غير متاح حرج مكون مغلق المصدر
CVE-2018-13887 A-117119172 * غير متاح حرج مكون مغلق المصدر
CVE-2019-2250 A-122473270 * غير متاح حرج مكون مغلق المصدر
CVE-2018-11291 A-109678120 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11821 A-111093019 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11822 A-111092813 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11828 A-111089816 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11849 A-111092945 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11850 A-111092919 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11853 A-111091938 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11854 A-111093762 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11856 A-111093242 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11859 A-111090373 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11861 A-111092814 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11862 A-111093763 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11867 A-111093243 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11870 A-111089817 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11871 A-111092400 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11872 A-111090534 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11873 A-111091378 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11874 A-111092946 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11875 A-111093022 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11876 A-111093244 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11877 A-111092888 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11879 A-111093280 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11880 A-111092401 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11882 A-111093259 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11884 A-111090535 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11928 A-112279580 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11936 A-112279127 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11967 A-119049704 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11967 A-119052960 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-11968 A-114042276 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-12005 A-117118499 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-12012 A-117119174 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-12013 A-117119152 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-13885 A-117118789 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-13895 A-122472377 * غير متاح عالٍ مكون مغلق المصدر
CVE-2018-13925 A-120483842 * غير متاح عالٍ مكون مغلق المصدر
CVE-2019-2244 A-122472139 * غير متاح عالٍ مكون مغلق المصدر
CVE-2019-2245 A-122473145 * غير متاح عالٍ مكون مغلق المصدر

أسئلة وأجوبة شائعة

يجيب هذا القسم على الأسئلة الشائعة التي قد تطرأ بعد قراءة هذه النشرة.

1. كيف يمكنني تحديد ما إذا كان قد تم تحديث جهازي لمعالجة هذه المشكلات؟

لمعرفة كيفية التحقق من مستوى تصحيح الأمان لجهاز ، راجع التحقق من إصدار Android وتحديثه .

  • تعالج مستويات تصحيح الأمان لعام 2019-04-01 أو الإصدارات الأحدث جميع المشكلات المرتبطة بمستوى تصحيح الأمان 2019-04-01.
  • تتناول مستويات تصحيح الأمان لعام 2019-04-05 أو الإصدارات الأحدث جميع المشكلات المرتبطة بمستوى تصحيح الأمان 2019-04-05 وجميع مستويات التصحيح السابقة.

يجب على الشركات المصنعة للأجهزة التي تتضمن هذه التحديثات تعيين مستوى سلسلة التصحيح على:

  • [ro.build.version.security_patch]: [2019-04-01]
  • [ro.build.version.security_patch]: [2019-04-05]

2. لماذا تحتوي هذه النشرة على مستويين من تصحيح الأمان؟

تحتوي هذه النشرة على مستويين من تصحيح الأمان بحيث يتمتع شركاء Android بالمرونة لإصلاح مجموعة فرعية من الثغرات الأمنية المتشابهة عبر جميع أجهزة Android بسرعة أكبر. يتم تشجيع شركاء Android على إصلاح جميع المشكلات الواردة في هذه النشرة واستخدام أحدث مستوى من تصحيح الأمان.

  • يجب أن تتضمن الأجهزة التي تستخدم مستوى تصحيح الأمان 2019-04-01 جميع المشكلات المرتبطة بمستوى تصحيح الأمان هذا ، بالإضافة إلى إصلاحات لجميع المشكلات التي تم الإبلاغ عنها في نشرات الأمان السابقة.
  • يجب أن تتضمن الأجهزة التي تستخدم مستوى تصحيح الأمان 2019-04-05 أو أحدث تضمين جميع التصحيحات القابلة للتطبيق في نشرات الأمان هذه (والسابقة).

يتم تشجيع الشركاء على تجميع الإصلاحات لجميع المشكلات التي يعالجونها في تحديث واحد.

3. ماذا تعني الإدخالات في عمود النوع ؟

تشير الإدخالات في عمود النوع في جدول تفاصيل الثغرات الأمنية إلى تصنيف الثغرة الأمنية.

اختصار تعريف
RCE تنفيذ التعليمات البرمجية عن بعد
EoP رفع الامتياز
بطاقة تعريف الإفصاح عن المعلومات
DoS الحرمان من الخدمة
غير متاح التصنيف غير متوفر

4. ماذا تعني الإدخالات في عمود المراجع ؟

قد تحتوي الإدخالات الموجودة ضمن عمود المراجع في جدول تفاصيل الثغرات الأمنية على بادئة تحدد المؤسسة التي تنتمي إليها القيمة المرجعية.

بادئة المرجعي
أ- معرف خطأ Android
QC- الرقم المرجعي لشركة Qualcomm
م- الرقم المرجعي MediaTek
ن- الرقم المرجعي لـ NVIDIA
ب- الرقم المرجعي من Broadcom

5. ماذا يعني * بجوار معرف خطأ Android في عمود المراجع ؟

المشكلات غير المتاحة للجمهور بها علامة * بجوار معرف خطأ Android في عمود المراجع . يتم تضمين التحديث الخاص بهذه المشكلة بشكل عام في أحدث برامج التشغيل الثنائية لأجهزة Pixel المتوفرة من موقع Google Developer .

6. لماذا يتم تقسيم الثغرات الأمنية بين هذه النشرة ونشرات أمان الجهاز / الشريك ، مثل نشرة Pixel؟

الثغرات الأمنية التي تم توثيقها في نشرة الأمن هذه مطلوبة للإعلان عن أحدث مستوى من تصحيح الأمان على أجهزة Android. الثغرات الأمنية الإضافية التي تم توثيقها في نشرات أمان الجهاز / الشريك غير مطلوبة للإعلان عن مستوى تصحيح الأمان. يتم تشجيع الشركات المصنعة لأجهزة Android ومجموعة الشرائح على توثيق وجود إصلاحات أخرى على أجهزتهم من خلال مواقع الأمان الخاصة بهم ، مثل نشرات الأمان Samsung أو LGE أو Pixel .

إصدارات

إصدار تاريخ ملحوظات
1.0 1 أبريل 2019 تم نشر النشرة
1.1 3 أبريل 2019 تمت مراجعة النشرة لتشمل روابط AOSP