Android 安全性公告 - 2020 年 5 月

發佈於 2020 年 5 月 4 日 |更新於 2020 年 5 月 7 日

Android 安全公告包含影響 Android 裝置的安全漏洞的詳細資訊。 2020 年 5 月 5 日或更高版本的安全性修補程式等級可解決所有這些問題。若要了解如何檢查裝置的安全性修補程式級別,請參閱檢查和更新您的 Android 版本

Android 合作夥伴至少會在發布前一個月收到有關所有問題的通知。這些問題的源代碼補丁已發佈到 Android 開源專案 (AOSP) 儲存庫,並從此公告連結。此公告還包含 AOSP 之外的補丁的連結。

其中最嚴重的問題是系統元件中的一個嚴重安全漏洞,該漏洞可能使遠端攻擊者能夠使用特製的傳輸在特權程序的上下文中執行任意程式碼。嚴重性評估是基於利用漏洞可能對受影響設備的影響,假設平台和服務緩解措施出於開發目的而關閉或成功繞過。

有關 Android安全平台保護Google Play Protect 的詳細信息,請參閱 Android 和 Google Play Protect 緩解措施部分,這些保護可提高 Android 平台的安全性。

Android 和 Google 服務緩解措施

這是Android 安全平台和服務保護(例如Google Play Protect)提供的緩解措施的摘要。這些功能降低了 Android 上安全漏洞被成功利用的可能性。

  • 新版 Android 平台的增強功能使得利用 Android 上的許多問題變得更加困難。我們鼓勵所有用戶盡可能更新到最新版本的 Android。
  • Android 安全團隊透過Google Play Protect積極監控濫用行為,並向使用者發出潛在有害應用程式的警告。預設情況下,在具有Google 行動服務的裝置上啟用 Google Play Protect,這對於從 Google Play 外部安裝應用程式的使用者尤其重要。

2020-05-01 安全修補程式等級漏洞詳情

在下面的部分中,我們提供了適用於 2020-05-01 修補程式等級的每個安全漏洞的詳細資訊。漏洞按其影響的組件進行分組。下表描述了問題,包括 CVE ID、相關參考文獻、漏洞類型嚴重性和更新的 AOSP 版本(如果適用)。如果可用,我們會將解決問題的公共變更連結到錯誤 ID,例如 AOSP 變更清單。當多個變更與單一錯誤相關時,其他參考連結到錯誤 ID 後面的數字。搭載 Android 10 及更高版本的裝置可能會收到安全性更新以及Google Play 系統更新

框架

本節中最嚴重的漏洞可能使本機攻擊者能夠使用特製檔案在特權程序的上下文中執行任意程式碼。

CVE參考類型嚴重性更新了 AOSP 版本
CVE-2020-0096 A-145669109 [ 2 ]結束時間批判的8.0、8.1、9
CVE-2020-0097 A-145981139 [ 2 ] [ 3 ]結束時間高的9, 10
CVE-2020-0098 A-144285917結束時間高的8.0、8.1、9、10

媒體框架

本節中最嚴重的漏洞可能使本地攻擊者能夠繞過使用者互動要求以獲得額外權限。

CVE參考類型嚴重性更新了 AOSP 版本
CVE-2020-0094 A-148223871結束時間高的9, 10
CVE-2020-0093 A-148705132 ID高的8.0、8.1、9、10
CVE-2020-0100 A-150156584 ID高的8.0, 8.1
CVE-2020-0101 A-144767096 ID高的8.0、8.1、9、10

系統

本節中最嚴重的漏洞可能使遠端攻擊者能夠使用特製的傳輸在特權程序的上下文中執行任意程式碼。

CVE參考類型嚴重性更新了 AOSP 版本
CVE-2020-0103 A-148107188遠端程式碼執行批判的9, 10
CVE-2020-0102 A-143231677結束時間高的8.0、8.1、9、10
CVE-2020-0109 A-148059175結束時間高的9, 10
CVE-2020-0105 A-144285084結束時間高的9, 10
CVE-2020-0024 A-137015265 [ 2 ]結束時間高的8.0、8.1、9、10
CVE-2020-0092 A-145135488 ID高的10
CVE-2020-0106 A-148414207 ID高的10
CVE-2020-0104 A-144430870 ID緩和9, 10

Google Play 系統更新

本月 Google Play 系統更新(Project Mainline)中沒有解決任何安全性問題。

2020-05-05 安全修補程式等級漏洞詳情

在下面的部分中,我們提供了適用於 2020-05-05 修補程式等級的每個安全漏洞的詳細資訊。漏洞按其影響的元件進行分組,包括 CVE、關聯引用、漏洞類型嚴重性、元件(如果適用)和更新的 AOSP 版本(如果適用)等詳細資訊。如果可用,我們會將解決問題的公共變更連結到錯誤 ID,例如 AOSP 變更清單。當多個變更與單一錯誤相關時,其他參考連結到錯誤 ID 後面的數字。

核心元件

本節中最嚴重的漏洞可能使本機攻擊者能夠使用特製檔案在特權程序的上下文中執行任意程式碼。

CVE參考類型嚴重性成分
CVE-2020-0110 A-148159562
上游內核
結束時間高的核心調度器
CVE-2019-19536 A-146642883
上游內核
ID高的PCAN-USB驅動程式

聯發科技組件

此部分中最嚴重的漏洞可能使具有特權存取權限的本機攻擊者能夠存取敏感資料。

CVE參考類型嚴重性成分
CVE-2020-0064 A-149866855 *
M-ALPS04737871
ID高的奧馬克普
CVE-2020-0065 A-149813448 *
M-ALPS04886658
ID高的Android 套件守護程式
CVE-2020-0090 A-149813048 *
M-ALPS04983879
ID高的電子郵件
CVE-2020-0091 A-149808700 *
M-ALPS04356368
ID高的明尼德

高通組件

這些漏洞影響 Qualcomm 元件,並在相應的 Qualcomm 安全公告或安全警報中進行了更詳細的描述。這些問題的嚴重性評估由高通直接提供。

CVE參考類型嚴重性成分
CVE-2019-14053 A-143902261
QC-CR#2317498
不適用高的核心
CVE-2019-14087 A-145546454
QC-CR#2165928
不適用高的展示
CVE-2020-3610 A-148816869
QC-CR#2460844 [ 2 ]
不適用高的展示
CVE-2020-3615 A-148817147
QC-CR#2256679 [ 2 ]
QC-CR#2258844
不適用高的無線區域網路
CVE-2020-3623 A-148815534 *
QC-CR#2472080
不適用高的安全
CVE-2020-3625 A-148816727 *
QC-CR#2493825
不適用高的安全
CVE-2020-3630 A-148816037
QC-CR#2534752 [ 2 ]
不適用高的影片
CVE-2020-3680 A-144350801
QC-CR#2597382
不適用高的核心

高通閉源元件

這些漏洞影響 Qualcomm 封閉源元件,並在相應的 Qualcomm 安全公告或安全警報中進行了更詳細的描述。這些問題的嚴重性評估由高通直接提供。

CVE參考類型嚴重性成分
CVE-2020-3641 A-148816624 *不適用批判的閉源元件
CVE-2019-14054 A-143902264 *不適用高的閉源元件
CVE-2019-14066 A-143903296 *不適用高的閉源元件
CVE-2019-14067 A-143902707 *不適用高的閉源元件
CVE-2019-14077 A-143903001 *不適用高的閉源元件
CVE-2019-14078 A-143902885 *不適用高的閉源元件
CVE-2020-3616 A-148816292 *不適用高的閉源元件
CVE-2020-3618 A-148817245 *不適用高的閉源元件
CVE-2020-3633 A-148816216 *不適用高的閉源元件
CVE-2020-3645 A-148816217 *不適用高的閉源元件

常見問題及解答

本節回答閱讀本公告後可能出現的常見問題。

1. 如何確定我的裝置是否已更新以解決這些問題?

若要了解如何檢查裝置的安全性修補程式級別,請參閱檢查和更新您的 Android 版本

  • 2020-05-01 或更高版本的安全性修補程式等級解決了與 2020-05-01 安全性修補程式等級相關的所有問題。
  • 2020-05-05 或更高版本的安全性修補程式等級解決了與 2020-05-05 安全性修補程式等級和所有先前修補程式等級相關的所有問題。

包含這些更新的裝置製造商應將補丁字串層級設定為:

  • [ro.build.version.security_patch]:[2020-05-01]
  • [ro.build.version.security_patch]:[2020-05-05]

對於某些運行 Android 10 或更高版本的設備,Google Play 系統更新將具有與 2020-05-01 安全性修補程式等級相符的日期字串。有關如何安裝安全更新的更多詳細信息,請參閱本文

2. 為什麼本公告有兩個安全修補程式等級?

此公告有兩個安全修補程式級別,以便 Android 合作夥伴能夠靈活地更快地修復所有 Android 裝置上相似的漏洞子集。我們鼓勵 Android 合作夥伴修復本公告中的所有問題並使用最新的安全性修補程式等級。

  • 使用 2020-05-01 安全性修補程式等級的裝置必須包含與該安全性修補程式等級相關的所有問題,以及先前安全性公告中報告的所有問題的修復程序。
  • 使用 2020-05-05 或更高版本安全性修補程式等級的裝置必須包含本(和先前)安全性公告中的所有適用修補程式。

我們鼓勵合作夥伴將他們正在解決的所有問題的修復程式捆綁在一次更新中。

3.類型欄中的條目是什麼意思?

漏洞詳細資料表的「類型」欄位中的條目引用安全漏洞的分類。

縮寫定義
遠端程式碼執行遠端程式碼執行
結束時間特權提升
ID資訊揭露
拒絕服務拒絕服務
不適用分類不可用

4.參考文獻欄中的條目是什麼意思?

漏洞詳細資料表的參考列下的條目可能包含標識引用值所屬組織的前綴。

字首參考
A-安卓錯誤 ID
QC-高通參考號
M-聯發科參考號
N- NVIDIA 參考號
B-博通參考號

5.參考資料欄中 Android bug ID 旁邊的 * 是什麼意思?

未公開發布的問題在「參考」列中的 Android bug ID 旁邊有一個 *。此問題的更新通常包含在Google 開發者網站上提供的 Pixel 裝置的最新二進位驅動程式中。

6. 為什麼安全漏洞會分為本公告和設備/合作夥伴安全公告(例如 Pixel 公告)?

本安全公告中記錄的安全漏洞需要在 Android 裝置上聲明最新的安全修補程式等級。聲明安全修補程式等級不需要設備/合作夥伴安全公告中記錄的其他安全漏洞。 Android 裝置和晶片組製造商還可能發布特定於其產品的安全漏洞詳細信息,例如Google華為LGE摩托羅拉諾基亞三星

版本

版本日期筆記
1.0 2020 年 5 月 4 日公告發布
1.1 2020 年 5 月 7 日公告已修訂以包含 AOSP 鏈接